Avaya Call Management System
Release 13
Administration
Providing telecommunications security

Telecommunications security (of voice, data, and video communications) is the prevention of any type of intrusion to (that is, either unauthorized or malicious access to or use of) your company's telecommunications equipment by some party.

Your company's "telecommunications equipment" includes both your Avaya product and any other voice/data/video equipment that could be accessed via this Avaya product (that is, "networked equipment").

An "outside party" is anyone who is not a corporate employee, agent, subcontractor, or person working on your company's behalf. Whereas, a "malicious party" is anyone (including someone who may be otherwise authorized) who accesses your telecommunications equipment with either malicious or mischievous intent.

Such intrusions may be either through synchronous (time-multiplexed and/or circuit-based) or asynchronous (character-, message-, or packet-based) equipment or interfaces for reasons of:

- Use (of capabilities special to the accessed equipment)
- Theft (such as, of intellectual property, financial assets, or toll-facility access)
- Eavesdropping (privacy invasions to humans)
- Mischief (troubling, but apparently innocuous, tampering)
- Harm (such as harmful tampering, data loss or alteration, regardless of motive or intent)

Be aware that there may be a risk of unauthorized intrusions associated with your system and/or its networked equipment. Also realize that, if such an intrusion should occur, it could result in a variety of losses to your company (including, but not limited to, human and data privacy, intellectual property, material assets, financial resources, labor costs, and legal costs).
# Preface

- Purpose ........................................................................... 18
- Intended users ................................................................. 18
- Overview ......................................................................... 18
- Conventions and terminology .......................................... 20
- Reasons for reissue .......................................................... 20
- Availability ...................................................................... 21
- Related documentation ...................................................... 22
- Change description ............................................................ 22
- Software documents .......................................................... 22
- Administration documents .................................................. 23
- Hardware documents .......................................................... 23
- Call Center documents ........................................................ 23
- Avaya CMS upgrade documents ........................................... 24
  - Base load upgrades ......................................................... 24
  - Platform upgrades and data migration ................................. 24
  - Avaya Call Management System Upgrade Express (CUE) ........ 24
- Documentation Web sites ..................................................... 25
- Support .......................................................................... 26

## Chapter 1: Introduction

- What is Avaya CMS? ............................................................ 27
- Operating system ............................................................... 27
- How Avaya CMS stores ACD data ....................................... 28
- How Avaya CMS logically stores ACD data ........................ 28
  - Real-time databases ....................................................... 28
  - Historical databases ....................................................... 28
  - Data summarizing ............................................................ 29
  - CMS data storage ............................................................ 29
- How Avaya CMS physically stores ACD data ......................... 31
  - Dbspace ..................................................................... 31
  - Chunks ...................................................................... 32
- ACD Administration ............................................................ 33
- How Avaya CMS tracks ACD data ....................................... 33
  - How CMS tracks a call ................................................... 33
  - Events that start or stop data collection ............................... 34
## Contents

<table>
<thead>
<tr>
<th>Component</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUX reason code names</td>
<td>86</td>
</tr>
<tr>
<td>Permissions</td>
<td>86</td>
</tr>
<tr>
<td>Before you begin</td>
<td>86</td>
</tr>
<tr>
<td>Adding an AUX reason code name</td>
<td>87</td>
</tr>
<tr>
<td>Viewing an AUX reason code name</td>
<td>88</td>
</tr>
<tr>
<td>Listing all AUX reason code names</td>
<td>89</td>
</tr>
<tr>
<td>Modifying an AUX reason code name</td>
<td>90</td>
</tr>
<tr>
<td>Deleting an AUX reason code</td>
<td>92</td>
</tr>
<tr>
<td>Calculations</td>
<td>94</td>
</tr>
<tr>
<td>Permissions</td>
<td>94</td>
</tr>
<tr>
<td>Before you begin</td>
<td>94</td>
</tr>
<tr>
<td>Viewing a calculation</td>
<td>95</td>
</tr>
<tr>
<td>Listing all calculations</td>
<td>97</td>
</tr>
<tr>
<td>Adding a calculation</td>
<td>98</td>
</tr>
<tr>
<td>Modifying a custom calculation</td>
<td>99</td>
</tr>
<tr>
<td>Deleting a custom calculation</td>
<td>100</td>
</tr>
<tr>
<td>Call work codes</td>
<td>102</td>
</tr>
<tr>
<td>Permissions</td>
<td>102</td>
</tr>
<tr>
<td>Before you begin</td>
<td>102</td>
</tr>
<tr>
<td>Adding a name to a call work code</td>
<td>103</td>
</tr>
<tr>
<td>Viewing a call work code name</td>
<td>104</td>
</tr>
<tr>
<td>Listing all call work code names</td>
<td>105</td>
</tr>
<tr>
<td>Modifying a call work code name</td>
<td>106</td>
</tr>
<tr>
<td>Deleting a call work code name</td>
<td>107</td>
</tr>
<tr>
<td>Constants</td>
<td>109</td>
</tr>
<tr>
<td>Permissions</td>
<td>109</td>
</tr>
<tr>
<td>Adding a constant</td>
<td>110</td>
</tr>
<tr>
<td>Viewing a constant</td>
<td>111</td>
</tr>
<tr>
<td>Listing all constants</td>
<td>112</td>
</tr>
<tr>
<td>Modifying a constant</td>
<td>113</td>
</tr>
<tr>
<td>Deleting a constant</td>
<td>114</td>
</tr>
<tr>
<td>Custom database items</td>
<td>116</td>
</tr>
<tr>
<td>Permissions</td>
<td>116</td>
</tr>
<tr>
<td>Before you begin</td>
<td>116</td>
</tr>
<tr>
<td>Adding a custom database item</td>
<td>117</td>
</tr>
<tr>
<td>Viewing a custom database item</td>
<td>118</td>
</tr>
<tr>
<td>Listing all custom database items</td>
<td>119</td>
</tr>
<tr>
<td>Modifying a custom database item</td>
<td>120</td>
</tr>
<tr>
<td>Deleting a custom database item</td>
<td>121</td>
</tr>
<tr>
<td>Generic string values synonyms</td>
<td>122</td>
</tr>
<tr>
<td>Permissions</td>
<td>122</td>
</tr>
<tr>
<td>Viewing generic string values</td>
<td>123</td>
</tr>
<tr>
<td>Modifying generic string values</td>
<td>124</td>
</tr>
<tr>
<td>Location IDs</td>
<td>125</td>
</tr>
<tr>
<td>Permissions</td>
<td>125</td>
</tr>
<tr>
<td>Adding a location ID</td>
<td>126</td>
</tr>
<tr>
<td>Viewing a location ID</td>
<td>127</td>
</tr>
<tr>
<td>Listing all location IDs</td>
<td>128</td>
</tr>
</tbody>
</table>
Modifying a location ID .......................................................... 129
Deleting a Location ID .......................................................... 130
Login ID names ..................................................................... 132
  Permissions ........................................................................... 132
  Before you begin .................................................................... 132
  Adding a name to a login ID ................................................... 133
  Viewing a login ID name ......................................................... 134
  Listing all login ID names ....................................................... 135
  Modifying a login ID name ..................................................... 136
  Deleting a login ID name ....................................................... 137
Logout reason code names ........................................................ 139
  Permissions ........................................................................... 139
  Before you begin .................................................................... 139
  Adding a logout reason code name ........................................ 140
  Viewing a logout reason code name ....................................... 141
  Listing all logout reason code names ..................................... 142
  Modifying a logout reason code name .................................... 143
  Deleting a logout reason code name ...................................... 145
Split/skill string values ............................................................. 147
  Permissions ........................................................................... 147
  Before you begin .................................................................... 147
  Viewing split/skill string values .............................................. 148
  Modifying split/skill string values .......................................... 149
  Split/skill string value field descriptions ............................... 150
Split/Skill names .................................................................... 152
  Permissions ........................................................................... 152
  Before you begin .................................................................... 152
  Adding a split/skill name ......................................................... 153
  Viewing a split/skill name ....................................................... 154
  Listing all the split/skill names ................................................. 155
  Modifying a split/skill name .................................................... 156
  Deleting a split/skill name ...................................................... 157
Standard database items ......................................................... 159
  Permissions ........................................................................... 159
  Viewing a standard database item ......................................... 160
  Viewing all standard database items alphabetically ............... 161
Trunk group names ................................................................. 162
  Permissions ........................................................................... 162
  Before you begin .................................................................... 162
  Adding a trunk group name .................................................... 163
  Viewing a trunk group name .................................................. 164
  Listing all trunk group names ............................................... 165
  Modifying a trunk group name ............................................... 166
  Deleting a trunk group name ................................................ 167
Trunk string values ................................................................. 169
  Permissions ........................................................................... 169
  Viewing and modifying trunk string values ............................ 170
  Trunk string values field descriptions ................................... 171
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>VDN names ........................................... 173</td>
</tr>
<tr>
<td>Permissions ........................................... 173</td>
</tr>
<tr>
<td>Before you begin ..................................... 173</td>
</tr>
<tr>
<td>Adding a VDN name ................................... 174</td>
</tr>
<tr>
<td>Viewing a VDN name ................................... 175</td>
</tr>
<tr>
<td>Listing all VDN names ............................... 176</td>
</tr>
<tr>
<td>Modifying a VDN name ................................ 177</td>
</tr>
<tr>
<td>Deleting a VDN name ................................ 178</td>
</tr>
<tr>
<td>Vector names .......................................... 180</td>
</tr>
<tr>
<td>Permissions ........................................... 180</td>
</tr>
<tr>
<td>Before you begin ..................................... 180</td>
</tr>
<tr>
<td>Adding a vector name ................................ 181</td>
</tr>
<tr>
<td>Viewing a vector name ................................ 182</td>
</tr>
<tr>
<td>Listing all vector names ............................ 183</td>
</tr>
<tr>
<td>Modifying a vector name ............................. 184</td>
</tr>
<tr>
<td>Deleting a vector name .............................. 185</td>
</tr>
<tr>
<td>Dictionary reports ................................. 187</td>
</tr>
<tr>
<td>Permissions ........................................... 187</td>
</tr>
<tr>
<td>Printing Dictionary reports ....................... 187</td>
</tr>
<tr>
<td>Running an agent group members report .......... 189</td>
</tr>
<tr>
<td>Chapter 4: Using reports ............................ 191</td>
</tr>
<tr>
<td>Background ............................................ 192</td>
</tr>
<tr>
<td>Interfaces for reports ............................... 192</td>
</tr>
<tr>
<td>Types of reports ...................................... 192</td>
</tr>
<tr>
<td>What reports summarize .............................. 193</td>
</tr>
<tr>
<td>Choosing a report .................................... 194</td>
</tr>
<tr>
<td>Generating a report .................................. 196</td>
</tr>
<tr>
<td>Printing a report ..................................... 197</td>
</tr>
<tr>
<td>Printing a Historical report ....................... 198</td>
</tr>
<tr>
<td>Changing the print setup ............................ 198</td>
</tr>
<tr>
<td>Restarting a report .................................. 199</td>
</tr>
<tr>
<td>Chapter 5: Scripting CMS operations ............... 201</td>
</tr>
<tr>
<td>Before you begin ..................................... 201</td>
</tr>
<tr>
<td>Tasks scripts can automate .......................... 202</td>
</tr>
<tr>
<td>Interactive and automatic scripts .................. 202</td>
</tr>
<tr>
<td>Creating scripts ...................................... 203</td>
</tr>
<tr>
<td>Accessing scripts ..................................... 203</td>
</tr>
<tr>
<td>Accessing the script options ....................... 204</td>
</tr>
<tr>
<td>Creating an interactive report script .......... 205</td>
</tr>
<tr>
<td>Creating an automatic report script .............. 206</td>
</tr>
<tr>
<td>Creating a script to export report data ........ 207</td>
</tr>
<tr>
<td>Creating a script to export report data as HTML 208</td>
</tr>
<tr>
<td>Scripting other Supervisor operations ............ 210</td>
</tr>
<tr>
<td>Actions not associated with reports .............. 210</td>
</tr>
</tbody>
</table>
### Chapter 6: Administering contact center agents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Starting or stopping an agent trace</td>
<td>218</td>
</tr>
<tr>
<td>Viewing current agent trace states</td>
<td>221</td>
</tr>
<tr>
<td>Listing agents traced</td>
<td>223</td>
</tr>
<tr>
<td>Changing agent skills</td>
<td>225</td>
</tr>
<tr>
<td>Changing skills for multiple agents</td>
<td>232</td>
</tr>
<tr>
<td>Changing extension split assignments</td>
<td>236</td>
</tr>
<tr>
<td>Moving extensions between splits</td>
<td>239</td>
</tr>
<tr>
<td>Running a split members report</td>
<td>242</td>
</tr>
</tbody>
</table>

### Chapter 7: Administering the contact center configuration

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Before you begin</td>
<td>245</td>
</tr>
<tr>
<td>ACD Groups</td>
<td>246</td>
</tr>
<tr>
<td>Before you begin</td>
<td>246</td>
</tr>
<tr>
<td>ACD Group capabilities</td>
<td>247</td>
</tr>
<tr>
<td>ACD Groups feature interfaces</td>
<td>248</td>
</tr>
<tr>
<td>Permissions</td>
<td>248</td>
</tr>
<tr>
<td>Adding an ACD Group</td>
<td>249</td>
</tr>
<tr>
<td>Listing all ACD Groups</td>
<td>250</td>
</tr>
<tr>
<td>Adding an ACD to an ACD Group</td>
<td>251</td>
</tr>
<tr>
<td>Viewing the contents of an ACD Group</td>
<td>252</td>
</tr>
<tr>
<td>Deleting an ACD from an ACD Group</td>
<td>254</td>
</tr>
<tr>
<td>Modifying an ACD Group</td>
<td>256</td>
</tr>
<tr>
<td>Deleting an ACD Group</td>
<td>258</td>
</tr>
<tr>
<td>Call work codes</td>
<td>260</td>
</tr>
<tr>
<td>Before you begin</td>
<td>260</td>
</tr>
<tr>
<td>Permissions</td>
<td>261</td>
</tr>
<tr>
<td>Adding call work codes</td>
<td>261</td>
</tr>
<tr>
<td>Viewing call work codes</td>
<td>263</td>
</tr>
<tr>
<td>Listing all call work codes</td>
<td>264</td>
</tr>
<tr>
<td>Deleting call work codes</td>
<td>265</td>
</tr>
<tr>
<td>VDN skill preferences</td>
<td>267</td>
</tr>
<tr>
<td>Before you begin</td>
<td>267</td>
</tr>
<tr>
<td>Permissions</td>
<td>268</td>
</tr>
<tr>
<td>Changing VDN skill preferences</td>
<td>268</td>
</tr>
<tr>
<td>Viewing VDN skill preferences</td>
<td>269</td>
</tr>
<tr>
<td>Listing all VDN skill preferences</td>
<td>271</td>
</tr>
<tr>
<td>Split/skill call profiles</td>
<td>273</td>
</tr>
<tr>
<td>Before you begin</td>
<td>273</td>
</tr>
<tr>
<td>Permissions</td>
<td>274</td>
</tr>
<tr>
<td>Adding split/skill call profiles</td>
<td>274</td>
</tr>
<tr>
<td>Viewing an existing split/skill call profile</td>
<td>276</td>
</tr>
</tbody>
</table>
Chapter 8: Administering exceptions .......................................................... 305

About exceptions . .................................................................................. 306
Types of Exceptions . ............................................................................. 306
Notification . ............................................................................................ 307
Exception capacities . .............................................................................. 308
Before you begin . ................................................................................... 309
Permissions . ........................................................................................... 310
Exception notification . ............................................................................ 311
Changing exception notification .............................................................. 311
Agent exceptions . .................................................................................. 313
Before you begin . ................................................................................... 313
Permissions . ........................................................................................... 313
Adding agent exceptions ......................................................................... 314
Modifying agent exceptions .................................................................... 316
Deleting agent exceptions . ..................................................................... 318
Agent exception definitions ..................................................................... 321
Agent exceptions report . ......................................................................... 323
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Viewing CMS users</td>
<td>386</td>
</tr>
<tr>
<td>Modifying CMS users</td>
<td>389</td>
</tr>
<tr>
<td>Deleting CMS users</td>
<td>391</td>
</tr>
<tr>
<td>ACD access</td>
<td>394</td>
</tr>
<tr>
<td>Before you begin</td>
<td>394</td>
</tr>
<tr>
<td>Permissions</td>
<td>395</td>
</tr>
<tr>
<td>Adding ACD access</td>
<td>395</td>
</tr>
<tr>
<td>Viewing ACD access</td>
<td>397</td>
</tr>
<tr>
<td>Listing all ACD access</td>
<td>398</td>
</tr>
<tr>
<td>Modifying ACD access</td>
<td>400</td>
</tr>
<tr>
<td>Deleting ACD access</td>
<td>402</td>
</tr>
<tr>
<td>Feature access</td>
<td>405</td>
</tr>
<tr>
<td>Contents</td>
<td>405</td>
</tr>
<tr>
<td>Before you begin</td>
<td>406</td>
</tr>
<tr>
<td>Permissions</td>
<td>406</td>
</tr>
<tr>
<td>Viewing Feature Access user permissions</td>
<td>407</td>
</tr>
<tr>
<td>Listing all Feature Access user permissions</td>
<td>408</td>
</tr>
<tr>
<td>Modifying Feature Access user permissions</td>
<td>410</td>
</tr>
<tr>
<td>Main Menu Addition Access</td>
<td>412</td>
</tr>
<tr>
<td>Contents</td>
<td>412</td>
</tr>
<tr>
<td>Before you begin</td>
<td>412</td>
</tr>
<tr>
<td>Permissions</td>
<td>413</td>
</tr>
<tr>
<td>Viewing Main Menu Addition Access</td>
<td>413</td>
</tr>
<tr>
<td>Listing all Main Menu Addition Access</td>
<td>414</td>
</tr>
<tr>
<td>Assigning or modifying Main Menu Addition Access</td>
<td>416</td>
</tr>
<tr>
<td>Split/Skill access</td>
<td>418</td>
</tr>
<tr>
<td>Before you begin</td>
<td>418</td>
</tr>
<tr>
<td>Permissions</td>
<td>419</td>
</tr>
<tr>
<td>Adding split/skill user permissions</td>
<td>421</td>
</tr>
<tr>
<td>Viewing split/skill user permissions</td>
<td>423</td>
</tr>
<tr>
<td>Listing all split/skill user permissions</td>
<td>424</td>
</tr>
<tr>
<td>Modifying split/skill user permissions</td>
<td>426</td>
</tr>
<tr>
<td>Deleting split/skill user permissions</td>
<td></td>
</tr>
<tr>
<td>Trunk group access</td>
<td>429</td>
</tr>
<tr>
<td>Before you begin</td>
<td>429</td>
</tr>
<tr>
<td>Permissions</td>
<td>430</td>
</tr>
<tr>
<td>Adding trunk group user permissions</td>
<td>430</td>
</tr>
<tr>
<td>Viewing trunk group user permissions</td>
<td>432</td>
</tr>
<tr>
<td>Listing all trunk group user permissions</td>
<td>434</td>
</tr>
<tr>
<td>Modifying trunk group user permissions</td>
<td>435</td>
</tr>
<tr>
<td>Deleting trunk group user permissions</td>
<td>437</td>
</tr>
<tr>
<td>Vector access</td>
<td>440</td>
</tr>
<tr>
<td>Before you begin</td>
<td>440</td>
</tr>
<tr>
<td>Permissions</td>
<td>441</td>
</tr>
<tr>
<td>Adding vector user permissions</td>
<td>441</td>
</tr>
<tr>
<td>Viewing vector user permissions</td>
<td>443</td>
</tr>
<tr>
<td>Listing all vector user permissions</td>
<td>445</td>
</tr>
<tr>
<td>Modifying vector user permissions</td>
<td>446</td>
</tr>
</tbody>
</table>

Issue 1.1  June 2005  11
Chapter 10: Configuring CMS system settings

Before you begin ................................................. 463
CMS state .......................................................... 464
  Before you begin ............................................. 464
  Permissions ..................................................... 465
  Changing the CMS state .................................... 465
  Changing the master ACD ................................. 466
Data collection ................................................... 468
  Before you begin ............................................. 468
  Permissions ..................................................... 469
  Changing the data collection state ..................... 469
Data Storage Allocation ........................................ 471
  Before you begin ............................................. 471
  Permissions ..................................................... 472
  Viewing Data Storage Allocation ........................ 472
  Modifying Data Storage Allocation ....................... 474
Data summarizing ............................................... 480
  Before you begin ............................................. 480
  Permissions ..................................................... 481
  Archiving data ............................................... 481
External Application Status .................................... 483
  Before you begin ............................................. 483
  Permissions ..................................................... 483
  Enabling or disabling the External Application Status feature 484
  Viewing the states of external applications ......... 485
  Starting or stopping external applications ........... 486
Free Space Allocation ........................................... 489
  Before you begin ............................................. 489
  Permissions ..................................................... 490
  Viewing Free Space Allocation .......................... 490
  Viewing Free Space Allocation contents ............... 492
  Modifying Free Space Allocation ....................... 494
  Verifying chunk allocation .............................. 495
Migrating CMS data ............................................. 497
  Before you begin ............................................. 497
  Permissions ..................................................... 497
  Migrating R3 data .............................................. 497
### Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pseudo-ACDs</td>
<td>502</td>
</tr>
<tr>
<td>Before you begin</td>
<td>502</td>
</tr>
<tr>
<td>Permissions</td>
<td>504</td>
</tr>
<tr>
<td>Creating a pseudo-ACD</td>
<td>504</td>
</tr>
<tr>
<td>Viewing pseudo-ACDs</td>
<td>505</td>
</tr>
<tr>
<td>Deleting a pseudo-ACD</td>
<td>506</td>
</tr>
<tr>
<td>Loading pseudo-ACD data</td>
<td>507</td>
</tr>
<tr>
<td>Storage intervals</td>
<td>510</td>
</tr>
<tr>
<td>Before you begin</td>
<td>510</td>
</tr>
<tr>
<td>Permissions</td>
<td>510</td>
</tr>
<tr>
<td>Viewing storage interval settings</td>
<td>511</td>
</tr>
<tr>
<td>Changing the intrahour interval</td>
<td>512</td>
</tr>
<tr>
<td>Changing switch time zone</td>
<td>514</td>
</tr>
<tr>
<td>Modifying data summarizing settings</td>
<td>516</td>
</tr>
<tr>
<td>Switch setup</td>
<td>520</td>
</tr>
<tr>
<td>Before you begin</td>
<td>520</td>
</tr>
<tr>
<td>Permissions</td>
<td>521</td>
</tr>
<tr>
<td>Viewing switch setup data</td>
<td>521</td>
</tr>
<tr>
<td>Listing all switch setup data</td>
<td>522</td>
</tr>
<tr>
<td>Chapter 11: Maintaining CMS</td>
<td>525</td>
</tr>
<tr>
<td>Before you begin</td>
<td>526</td>
</tr>
<tr>
<td>ACD status</td>
<td>526</td>
</tr>
<tr>
<td>Before you begin</td>
<td>526</td>
</tr>
<tr>
<td>Permissions</td>
<td>527</td>
</tr>
<tr>
<td>Viewing ACD status</td>
<td>527</td>
</tr>
<tr>
<td>Listing ACD status</td>
<td>530</td>
</tr>
<tr>
<td>Description of the ACD Status window - with EAS</td>
<td>531</td>
</tr>
<tr>
<td>Description of the ACD Status window - without EAS</td>
<td>532</td>
</tr>
<tr>
<td>Requesting ACD translations</td>
<td>533</td>
</tr>
<tr>
<td>Archiving status</td>
<td>534</td>
</tr>
<tr>
<td>Before you begin</td>
<td>534</td>
</tr>
<tr>
<td>Permissions</td>
<td>534</td>
</tr>
<tr>
<td>Viewing the archiving status of a single ACD</td>
<td>535</td>
</tr>
<tr>
<td>Viewing the archiving status of all ACDs</td>
<td>536</td>
</tr>
<tr>
<td>Description of the Archiving Status - List All window</td>
<td>538</td>
</tr>
<tr>
<td>Backup/restore devices</td>
<td>539</td>
</tr>
<tr>
<td>Permissions</td>
<td>539</td>
</tr>
<tr>
<td>Viewing a backup/restore device</td>
<td>540</td>
</tr>
<tr>
<td>Listing all backup/restore devices</td>
<td>541</td>
</tr>
<tr>
<td>Adding a backup/restore device</td>
<td>543</td>
</tr>
<tr>
<td>Modifying a backup/restore device</td>
<td>544</td>
</tr>
<tr>
<td>Deleting a backup/restore device</td>
<td>546</td>
</tr>
<tr>
<td>Data Backup</td>
<td>548</td>
</tr>
<tr>
<td>CMSADM backup</td>
<td>548</td>
</tr>
<tr>
<td>Maintenance backup</td>
<td>549</td>
</tr>
<tr>
<td>Tape drives and cartridges</td>
<td>549</td>
</tr>
</tbody>
</table>
Things to consider when backing up or restoring data ............................................. 549
  Factors that impact backup and restore times ......................................................... 550
  Reducing tape backup and restore times ................................................................ 550
  Alternate methods for backing up and restoring data .............................................. 551
Performing a CMSADM backup .................................................................................. 551
Performing a maintenance backup .............................................................................. 553
Description of the Backup Data window ..................................................................... 556
  The Backup Data window .......................................................................................... 556
  Field descriptions ..................................................................................................... 557
  Data to back up descriptions ..................................................................................... 557
Common backup error messages .................................................................................. 558
Labeling the backup volume ......................................................................................... 559
Recovery kit .................................................................................................................. 560
Restoring data .............................................................................................................. 561
  Before you begin ....................................................................................................... 561
Permissions ................................................................................................................... 562
Automatic restore ......................................................................................................... 562
Manual restore ............................................................................................................... 564
Recommendation to restart your CMS server ................................................................ 567
Connection status ........................................................................................................ 568
  Permissions ............................................................................................................... 568
  Viewing the connection status of an ACD ................................................................. 568
  Listing the connection status of all ACDs ................................................................. 570
  Description of the Connection Status window ......................................................... 571
Administering a printer .................................................................................................. 574
  Before you begin ....................................................................................................... 574
Permissions ................................................................................................................... 574
Adding a new printer ..................................................................................................... 575
Listing all printers ........................................................................................................ 576
Modifying printer options ............................................................................................. 578
Deleting a printer .......................................................................................................... 579
Maintenance Error Log .................................................................................................. 581
  Before you begin ....................................................................................................... 581
Running a Maintenance Error Log ............................................................................ 582
  Severity of errors ...................................................................................................... 584
  Maintenance Error Log messages .......................................................................... 584
ACD Administration Log ............................................................................................... 608
  Before you begin ....................................................................................................... 608
Permissions ................................................................................................................... 608
Running the ACD Administration Log report .............................................................. 609
ACD Administration Log window field descriptions .................................................. 611

Chapter 12: Using Solaris ............................................................................................ 613
  Before you begin ....................................................................................................... 613
Logging in to CMS ........................................................................................................ 614
  Logging in to CMS from the remote console ......................................................... 614
  Logging in to CMS from the server console ......................................................... 614
Preface

Avaya Call Management System (CMS) is an application for businesses and organizations that use Avaya communication servers to process large volumes of telephone calls using the Automatic Call Distribution (ACD) feature. Avaya CMS supports solutions for routing and agent selection, multi-site contact centers, remote agents, reporting, interfaces to other systems, workforce management, desktop applications, system recovery, and quality monitoring.

Avaya CMS is part of the Operational Effectiveness solution of the Avaya Customer Interaction Suite.

This section includes the following topics:

- **Purpose** on page 18
- **Intended users** on page 18
- **Overview** on page 18
- **Conventions and terminology** on page 20
- **Reasons for reissue** on page 20
- **Availability** on page 21
- **Related documentation** on page 22
- **Support** on page 26
Purpose

The purpose of this document is to provide instructions on administering a contact center through Avaya CMS Supervisor.

This information product specifically addresses the functionality of CMS.

Intended users

This document is written for:

- Avaya Call Management System (CMS) administrators who have access to all parts of CMS
- Split/Skill supervisors with limited access to CMS

Overview

This document includes the following topics:

- **Chapter 1: Introduction** on page 27
  
  This chapter provides an overview of this document, password information, and cross-references for Avaya CMS Supervisor usage

- **Chapter 2: Configuring Avaya CMS Supervisor** on page 37
  
  This chapter describes the Supervisor configuration options

- **Chapter 3: Using the Dictionary to name contact center entities** on page 49
  
  This chapter describes how to create synonyms in the Dictionary

- **Chapter 4: Using reports** on page 191
  
  This chapter describes the basic use of the Reports subsystem

- **Chapter 5: Scripting CMS operations** on page 201
  
  This chapter describes how to script common actions

- **Chapter 6: Administering contact center agents** on page 217
  
  This chapter describes how to change agent splits/skills, create agent templates, move extensions between splits, and use agent trace
● **Chapter 7: Administering the contact center configuration** on page 245
  This chapter describes how to add or delete call work codes and split/skill call profiles, change VDN skill preferences, view trunk group assignments, change VDN call profiles, and other contact center activities

● **Chapter 8: Administering exceptions** on page 305
  This chapter describes how to define exceptions and run exception reports for agents, split/skills, trunk groups, VDNs, and vectors

● **Chapter 9: Administering user permissions** on page 381
  This chapter describes how to create users and define, change, or modify associated CMS permissions

● **Chapter 10: Configuring CMS system settings** on page 463
  This chapter describes how to change the state of CMS, allocate storage space, specify storage intervals, and other system setup activities

● **Chapter 11: Maintaining CMS** on page 525
  This chapter describes backups, restores, backup strategies, maintenance reports, backup volumes, and labeling

● **Chapter 12: Using Solaris** on page 613
  This chapter describes the Sun Microsystems, Inc. Solaris operating system and how to use it with CMS

● **Chapter 13: Using timetables and shortcuts** on page 621
  This chapter describes how to use timetables and shortcuts to streamline activities
Conventions and terminology

If you see any of the following safety labels in this document, take careful note of the information presented.

⚠️ CAUTION:
Caution statements call attention to situations that can result in harm to software, loss of data, or an interruption in service.

⚠️ WARNING:
Warning statements call attention to situations that can result in harm to hardware or equipment.

⚠️ DANGER:
Danger statements call attention to situations that can result in harm to personnel.

⚠️ SECURITY ALERT:
Security alert statements call attention to situations that can increase the potential for unauthorized use of a telecommunications system.

Note:
In some instances, your communication server and its associated software may be referred to as "switch". Unless otherwise noted, the term, Communication Manager, includes earlier Avaya communication servers, such as MultiVantage and DEFINITY®.

Reasons for reissue

This is the first issue of this document.
Availability

Copies of this document are available from one or both of the following sources:

Note:
Although there is no charge to download documents through the Avaya Web site, documents ordered from the Avaya Publications Center must be purchased.

- The Avaya online support Web site, http://www.avayadocs.com
- The Avaya Publications Center, which you can contact by:

  Voice:
  +1-207-866-6701
  +1-800-457-1764 (Toll-free, U.S. and Canada only)

  Fax:
  +1-207-626-7269
  +1-800-457-1764 (Toll-free, U.S. and Canada only)

  Mail:
  GlobalWare Solutions
  200 Ward Hill Avenue
  Haverhill, MA 01835 USA
  Attention: Avaya Account Manager

  E-mail:
  totalware@gwsmail.com
Related documentation

You might find the following Avaya CMS documentation useful. This section includes the following topics:

- Change description on page 22
- Software documents on page 22
- Administration documents on page 23
- Hardware documents on page 23
- Call Center documents on page 23
- Avaya CMS upgrade documents on page 24
- Documentation Web sites on page 25

Change description

For information about the changes made in Avaya CMS R13, see:

- Avaya Call Center 3.0 and Call Management System (CMS) Release 13 Change Description, 07-300304

Software documents

For more information about Avaya CMS software, see:

- Avaya Call Management System Release 13 Software Installation, Maintenance, and Troubleshooting Guide, 07-300340
- Avaya CMS Open Database Connectivity Version 4.2, 585-780-701
- Avaya Call Management System Release 13 External Call History Interface, 07-300332
- Avaya CMS Custom Reports, 585-215-822
- Avaya Visual Vectors Release 13 Installation and Getting Started, 07-300353
- Avaya Call Management System (CMS) Supervisor Release 13 Report Designer, 07-300335
Administration documents

For more information about Avaya CMS administration, see:

- Avaya Call Management System Release 13 Administration, 07-300331
- Avaya Call Management System (CMS) Release 13 Database Items and Calculations, 07-300330
- Avaya Call Management System Supervisor Release 13 Reports, 07-300334
- Avaya Call Management System (CMS) Supervisor Release 13 Installation and Getting Started, 07-300333
- Avaya Call Management System High Availability User Guide, 07-300066
- Avaya Call Management System High Availability Connectivity, Upgrade and Administration, 07-300065

Hardware documents

For more information about Avaya CMS hardware, see:

- Avaya Call Management System Sun Fire V880/V890 Computer Hardware Installation, Maintenance, and Troubleshooting, 585-215-116
- Avaya Call Management System Sun Blade 100/150 Workstation Hardware Installation, Maintenance, and Troubleshooting, 585-310-783
- Avaya Call Management System Terminals, Printers, and Modems, 585-215-874

Call Center documents

For more information about Avaya Call Center documents, see:

- Avaya Communication Manager Call Center Software Basic Call Management System (BCMS) Operations, 07-300061
- Avaya Call Management System Switch Connections, Administration, and Troubleshooting, 585-215-876
- Avaya Communication Manager Call Center Software Call Vectoring and Expert Agent Selection (EAS) Guide, 07-300303
- Avaya Communication Manager Call Center Software Automatic Call Distribution (ACD) Guide, 07-300301
- Avaya Business Advocate User Guide, 07-300336
Avaya CMS upgrade documents

There are several upgrade paths supported with Avaya CMS. There is a document designed to support each upgrade.

This section includes the following topics:

- **Base load upgrades** on page 24
- **Platform upgrades and data migration** on page 24
- **Avaya Call Management System Upgrade Express (CUE)** on page 24

**Base load upgrades**

Use a base load upgrade when upgrading CMS to the latest load of the same version (for example, r13ak.g to r13al.k). A specific set of instructions is written for the upgrade. The instructions are shipped to the customer site with the CMS software CD-ROM as part of a Product Correction Notice (PCN).

For more information about base load upgrades, see:

- **Avaya Call Management System Release 13 Base Load Upgrade**

**Platform upgrades and data migration**

Use a platform upgrade when upgrading to a new hardware platform (for example, upgrading from a SPARCserver 5 to a Sun Blade 150). The new hardware platform is shipped from the Avaya factory with the latest CMS load. Therefore, as part of the upgrade you will have the latest CMS load (for example, R3V9 to R13).

For more information about platform upgrades and data migration, see:

- **Avaya Call Management System Release 13 Platform Upgrade and Data Migration**, 07-300339

**Avaya Call Management System Upgrade Express (CUE)**

Use CUE when CMS is being upgraded from an earlier version (for example, R3V9) to the latest version (for example, R13).

A specific set of upgrade instructions is written for the upgrade. These instructions are included on the CUE software CD-ROM that is shipped to the customer site with the CUE kit.

For information about customer requirements for CUE upgrades, see:

- **Avaya Call Management System Release 13 CMS Upgrade Express (CUE) Customer Requirements**, 700356744
For information about CUE upgrade procedures, see:

- Avaya Call Management System Release 13 Sun Blade 100/150 Workstation Mirrored and Nonmirrored Systems CMS Upgrade Express (CUE), 07-300481
- Avaya Call Management System Release 13 Sun Fire V880/V890 Computer CMS Upgrade Express (CUE), 07-300344

### Documentation Web sites

For Avaya product documentation, go to [http://www.avayadocs.com](http://www.avayadocs.com). Additional information about new software or hardware updates will be contained in future issues of this book. New issues of this book will be placed on the Web site when available.

Use the following Web sites to view related support documentation:

- Information about Avaya products and service
  [http://www.avaya.com](http://www.avaya.com)
- Sun hardware documentation
  [http://docs.sun.com](http://docs.sun.com)
- Informix documentation
  [http://www.informix.com](http://www.informix.com)
- Tivoli Storage Manager documentation
  [http://www.tivoli.com](http://www.tivoli.com)
Support

Contacting Avaya technical support

Avaya provides support telephone numbers for you to report problems or ask questions about your product.

For United States support:
1- 800- 242-2121

For international support:
See the 1-800 Support Directory listings on the Avaya Web site.

Escalating a technical support issue

Avaya Global Services Escalation Management provides the means to escalate urgent service issues. For more information, see the Escalation Management listings on the Avaya Web site.
Chapter 1: Introduction

This section provides introductory information on Avaya CMS Supervisor and complementary products. Basic information regarding the interfaces and usage of Supervisor can be found in the Avaya CMS Supervisor Installation and Getting Started document.

This section contains the following topics:

- What is Avaya CMS? on page 27
- How Avaya CMS stores ACD data on page 28
- ACD Administration on page 33

What is Avaya CMS?

Avaya CMS is a software product for businesses and organizations that have an Avaya Communication Manager system and receive a large volume of telephone calls that are processed through the Automatic Call Distribution (ACD) feature. Avaya CMS collects call-traffic data, formats management reports, and provides an administrative interface to the ACD feature on the Communication Manager system.

A CMS administrator accesses the CMS database, generates reports, administers ACD parameters, and monitors call activities to determine the most efficient service for the calling customers.

Operating system

Avaya CMS resides on the Sun Microsystems, Inc. Solaris operating system and uses several Solaris system utilities to communicate with terminals and printers, to log errors, and to execute processes. CMS utilizes the Informix Software, Inc. INFORMIX database management system, which provides an interface to the CMS historical database.
How Avaya CMS stores ACD data

There are two ways to describe how Avaya Call Management System (CMS) stores ACD data:

● Logically - How the CMS system organizes data for processing
● Physically - How the CMS system mechanically stores the data on the disk drive

This section includes the following topics:

● How Avaya CMS logically stores ACD data on page 28
● How Avaya CMS physically stores ACD data on page 31

How Avaya CMS logically stores ACD data

The logical storage of the ACD data has more impact on the CMS user than does the physical storage. The logical data storage controls how a CMS user is able to access and manipulate ACD data. CMS stores all of the ACD data received from the communication server in the real-time and historical databases.

Real-time databases

Real-time databases include tables for the current intrahour interval data and the previous intrahour interval data. The storage interval can be 15, 30, or 60 minutes.

Historical databases

Historical databases include tables for the intrahour, daily, weekly, and monthly data. The following table shows all of the historical database tables and the maximum amount of time data can be stored in a particular table:

<table>
<thead>
<tr>
<th>Historical database tables</th>
<th>Maximum time for data storage</th>
</tr>
</thead>
<tbody>
<tr>
<td>Intrahour historical data</td>
<td>62 days</td>
</tr>
<tr>
<td>Daily historical data</td>
<td>5 years (1825 days)</td>
</tr>
<tr>
<td>Weekly historical data</td>
<td>10 years (520 weeks)</td>
</tr>
<tr>
<td>Monthly historical data</td>
<td>10 years (120 months)</td>
</tr>
</tbody>
</table>
Note:
You can use historical data to predict future call traffic and future agent and trunk requirements. For more information see Avaya CMS Forecast User Guide.

Data summarizing

When CMS collects data from the ACD, the data is stored in the real-time database for the current interval. At the end of the current interval, the following events occur:

- The data that was in current interval database table is archived to the previous interval database table.
- The data that was in previous interval database table is archived in the historical database as intrahour historical data.

The data remains in the historical database as intrahour historical data for a maximum of 62 days. At your designated data summarizing time, the intrahour historical data is summarized into daily historical data.

The daily historical data is summarized on a weekly and monthly basis. At the end of your designated week, the daily historical data is summarized into weekly historical data. On the first day of a new month, the daily historical data is summarized into monthly historical data for the previous month.

For more information, see CMS data storage on page 29.

CMS data storage

The following figure illustrates how CMS stores data.
Introduction

### Communication Server

- **ACD#**

### CMS Processor

- **Data**

## Real-time database

- **Current interval data**
  - **Agent** (cagent)
  - **Split** (csplit)
  - **Trunk** (ctrunk)
  - **Trunk group** (ctkgrp)
  - **Vector** (cvector)
  - **VDN** (cvdn)
  - **Call work codes** (ccwc)

## Previous interval data

- **Agent** (pagent)
- **Split** (psplit)
- **Trunk** (ptrunk)
- **Trunk group** (ptkgrp)
- **Vector** (pvector)
- **VDN** (pvdn)
- **Call work codes** (pcwc)

## Historical database

### Intrahour historical data

- **Agent** (hagent)
- **Split** (hsplit)
- **Trunk** (htrunk)
- **Trunk group** (htkgrp)
- **Vector** (hvector)
- **VDN** (hvdn)
- **Call work codes** (hcwc)

### Daily historical data

- **Agent** (dagent)
- **Split** (dsplit)
- **Trunk** (dtrunk)
- **Trunk group** (dkgrp)
- **Vector** (dvector)
- **VDN** (dvdn)
- **Call work codes** (dcwc)

### Weekly historical data

- **Agent** (wagent)
- **Split** (wsplit)
- **Trunk** (wtrunk)
- **Trunk group** (wtkgrp)
- **Vector** (wvector)
- **VDN** (wvdn)
- **Call work codes** (wcwc)

### Monthly historical data

- **Agent** (magent)
- **Split** (msplit)
- **Trunk** (mtrunk)
- **Trunk group** (mtkgrp)
- **Vector** (mvector)
- **VDN** (mvdn)
- **Call work codes** (mcwc)
How Avaya CMS physically stores ACD data

The relational database used by CMS R3V9 and later is Informix Dynamic Server (IDS). IDS manages the CMS data in specific dbspaces. The historical database can span multiple disks. Each ACD dbspace contains the CMS historical database table for a single ACD.

In the following example:
- The dbspace acd1 contains the historical database table for ACD 1
- The dbspace acd2 contains the historical database table for ACD 2

Dbspace

A dbspace is a logical unit that consists of one or more chunks. Dbspaces can exist across multiple disks. A CMS system contains the following dbspaces:
- rootdbs
- physdbs
- logdbs
- dbtemp
- aasdbs
- cmsdbs
- freedbs
- acd1 through acd26
Important:
Do not attempt to alter rootdbs, physdbs, logdbs, dbtemp, aasdbs, or cmsdbs. Contact CMS services if you think you have a problem with any of these dbspaces.

In the following example, the dbspace acd1 exists across multiple disks.

Chunks

A chunk is a unit of physical disk space used to store database data that is managed by IDS. Each chunk contains 256 MB of disk space. In the following example, the dbspace acd1 contains multiple chunks.
ACD Administration

CMS provides an administrative interface to the communication server. From the ACD interface, you can view or change parameters on the communication server related to ACDs, Call Vectoring, and Expert Agent Selection (EAS). An administrator can also run reports that describe your contact center configuration.

For example, an administrator can:

- Add or remove agents from splits or skills
- Move extensions between splits
- Change skill assignments
- Change trunk group-to-split
- Change trunk group-to-VDN
- Change VDN-to-vector assignments
- Start an agent trace
- List the agents being traced
- Create, copy, and edit call vectors

How Avaya CMS tracks ACD data

CMS uses the data in the real-time and historical databases to generate standard reports that help you monitor your contact center’s activities. Various agent, split/skill, trunk, trunk group, vector, and VDN activities are tracked at different points in the call process.

This section includes the following topics:

- How CMS tracks a call on page 33
- Events that start or stop data collection on page 34

How CMS tracks a call

The following diagram shows how CMS tracks a call from the time the call seizes a trunk until an agent ends after-call-work (ACW) activity.

The trunk table, trunk group table, vector table, VDN table, split/skill table, agent table, and call work code (CWC) table are CMS database tables that store call data. In the following diagram, the positions of the CMS database tables identify the points where CMS begins to collect call data. The arrowheads identify the points where data collection ends. The data is not recorded in the tables until the call and any ACW is complete.
**Note:**

With vectoring, the \texttt{stop} command stops the processing of vector commands.

### Call process

<table>
<thead>
<tr>
<th>Call process</th>
<th>Call enters VDN/vector</th>
<th>Call queues to split/skill</th>
<th>Vector processing ends</th>
<th>Call rings agent</th>
<th>Agent answers call</th>
<th>Trunk drops call</th>
<th>Agent ends ACW</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trunk/trunk group table</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
</tr>
<tr>
<td>Vector table</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
</tr>
<tr>
<td>VDN table</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
</tr>
<tr>
<td>Split/Skill table</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
</tr>
<tr>
<td>Agent table</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
</tr>
<tr>
<td>CWC table</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
<td>--</td>
</tr>
</tbody>
</table>

### Events that start or stop data collection

Data collection starts or stops when one of these events occur:

- The Agent table starts collecting data on non-ACD calls when the agent answers or completes dialing.

- The Split/Skill table stops collecting data when:
  - The ACW for an ACD call ends
  - The call leaves the split queue and is forwarded to another destination (for example, intraflow)
  - The caller abandons the call

- The Vector table stops collecting data for the current vector when the call is:
  - Sent to an ACD agent
  - Connected to a station or trunk
  - Routed to a VDN or vector
  - Abandoned by the caller

**Note:**

Time in the vector stops but the vector tracks the call disposition to determine if the call was answered or abandoned.

- The VDN table stops collecting data for the current VDN when:
  - The ACW for an ACD call ends
- The call is routed to a trunk or VDN
- The call is transferred
- The caller abandons the call
Introduction
Chapter 2: Configuring Avaya CMS Supervisor

This section contains information regarding configuration of Avaya CMS Supervisor through the Options window.

The Options window allows you to adjust and control the following types of settings:

- The default ACD for all operations and reports windows
- Scripting defaults
- Colors used in Supervisor reports
- Formatting of the different types of fields displayed in Supervisor reports

This section contains the following topics:

- Before you begin on page 37
- General tab on page 38
- Scripting tab on page 39
- Report Colors tab on page 40
- Creating a new report color scheme on page 41
- Threshold Colors tab on page 44
- Creating a new threshold color scheme on page 45
- Name Format tab on page 47
- Defining entity formats on page 48

Before you begin

Except for the CMS Servers tab, all other tabs of the Options window are only available after a successful login to a CMS server. The CMS Servers tab is disabled when you are logged in to a CMS server.
Configuring Avaya CMS Supervisor

General tab

Use the General tab to set your first calendar day, default ACD, and other interface usage options.

This tab of the Options dialog contains the following controls:

- **First Day of Week** - This option affects only how the calendar is displayed. For example, if you browse for a date, the calendar starts the week based on the day that you choose. It does not change the Start of Week day for weekly data collection which is set through the System Setup - Storage Intervals window.

- **Default ACD** - Select the ACD that will be used as the default ACD for operations and reports windows. Note that an ACD Group can also be set as the default.

- **Synchronize PC and CMS Time at Login** - Select this check box to change the internal clock of the PC to match the current time on the CMS server. This option does not affect the time on the CMS server.

- **Use Sound** - Select this check box to receive an audible alert when the Exceptions Indicator box is updated. The Exceptions Indicator box is located on the Controller status bar. The sound that you hear is the sound that you chose for the exclamation event in Windows. Note that Threshold Highlighting does not use sound. It uses color only as an indicator of a threshold being met.

- **Use Tooltips** - Select this check box to make tooltips visible for the controls in the Supervisor interface. For example, when you are working in the Supervisor Controller window, you can place your mouse cursor over a toolbar button and the system displays a yellow box that provides a brief description of that button.

- **Use Taskbar Icon** - Select this check box to have Supervisor place an icon in the system tray.
Scripting tab

Use the Scripting tab to set the user ID used to run scripts, adjust the logging level, and set the file used for logging.

This tab of the Options dialog contains the following controls:

- **User ID** - The login ID for a CMS user.
- **Set User Button** - Select this button to open the Save as Script - User Information dialog box.
- **Logging Level** - This option group allows the following logging levels in configuring the amount of information that is recorded during the use of scripting:
  - **Minimum** - The only activities that will be logged are errors and messages from Supervisor that would have been displayed to the window as if the user performed the scripted activity manually.
  - **Normal** - All of the above activities are logged plus the start and stop time of each task of the script. The script name is also included.
- **Maximum** - All of the above activities are logged plus additional information that may be useful for debugging a script. Any message that displays as the script runs is logged.

- **Log File Path** - Enter the path and filename of the logfile in this field. You may also use the Browse button to the right of this field to select an existing file on the PC.

- **Log File Size** - This field determines how large the script log file can get before it begins replacing the oldest data. The field defaults to a value of 200KB.

- **View Log Button** - Select this button to view the script log file.

---

**Report Colors tab**

Use the **Report Colors** tab to set the colors that are used in your graphical reports.

This tab of the **Options** dialog contains the following controls:

- **Scheme** - This drop-down list box contains all of the existing color schemes available.

- **Save As** - Selecting this button saves any changes made in the color bar window as a new scheme. See **Creating a new report color scheme** on page 41 for instructions on creating report color schemes.

- **Remove** - Selecting this button deletes the currently displayed scheme.

- **Color window** - This displays of 16 bars allows you to change the color and pattern of each bar by performing a right-click on that bar.

- **Background** - There are two choices for the background color of reports:
  - **White** - Select this option to display a white background for all reports.
- **Automatic** - Select this option to have the background of all reports use the color scheme configured through *Windows*.

---

### Creating a new report color scheme

To create a new color scheme for reports:

1. From the menu bar of the Controller window, select **Tools > Options**. *Supervisor* displays the **Options** window.

2. Select the **Report Colors** tab.

3. From the **Scheme** drop-down list, select the color scheme you want to use as a basis for the new color scheme.

   *Supervisor* displays the configuration of the scheme in the color bar window.

4. From the **Background** options, select **White** or **Automatic**.

5. Click the color bar (1 through 16) that you want to modify.
6. If you want to modify the color, select the **Change Color** button and select the color through the **Color** dialog that is displayed.

7. If you want to modify the pattern, select the **Change Pattern** button and select the pattern from the resulting list.

8. Repeat Step 5 through Step 7 until you have updated all of the color bars that you want to modify.
9. When you are done modifying color bars, select the **Save As** button.

*Supervisor* displays the **Save Scheme As** window.

![Save Scheme As window](image)

**Note:**

If you do not save the new color scheme using the **Save As** button, the changes that you have made will overwrite the default color scheme that you modified.

10. Enter a name for this new color scheme in the text box.

11. Select **OK** to save this scheme.

   To view the changes that you made to a color scheme at any point in the modification, select the **Apply** button. The current color scheme is then applied to any reports that are running.
Threshold Colors tab

Use the Threshold Colors tab to set the colors that are used in reports to notify you when exceptions thresholds are reached.

This tab of the Options dialog contains the following controls:

- **Scheme** - This drop-down list box contains all of the existing color schemes available.

- **Save As** - Selecting this button saves any changes made in the color bar window as a new scheme. See Creating a new threshold color scheme on page 45 for instructions on creating new color schemes.

- **Remove** - Selecting this button deletes the currently displayed scheme.

- **View/set colors for report threshold indicators** - This list box displays the states used for exception thresholds. A graphical representation of the selected state is displayed in the area to the right.

- **Color** - Use the button to the right of this field to change the color for the selected exception threshold state.

- **Pattern** - Use the button to the right of this field to change the graphical pattern applied for the selected exception threshold state.
Creating a new threshold color scheme

To create a new threshold color scheme for reports:

1. From the menu bar of the Controller window, select **Tools > Options**.
   
   *Supervisor* displays the **Options** window.

2. Select the **Threshold Colors** tab.

3. From the **Scheme** drop-down list, select the color scheme you want to use as a basis for the new color scheme.
   
   *Supervisor* displays the view of the scheme.

4. In the **View/set colors for report threshold indicators** list, select the item you want to change.
   
   *Supervisor* displays the current setting for the selected item in the area to the right of the list box. The **Color:** and **Pattern:/Background:** fields display the respective settings for the current item.
5. If you want to change the color of the selected item, select the **Change Color** button at the right of the **Color:** field.

*Supervisor* displays the standard **Color** window from Windows allowing you to select the new color.

![Color window](image)

6. If you want to change the pattern/background color for the selected item, select the button at the right of the **Pattern:/Background:** field.

Depending on the item selected, *Supervisor* will display either the pattern list or the **Color** window which allows you to select a new pattern or background color.

7. Repeat Steps 4 through 6 until you have updated all of the threshold element colors that you want to modify.

8. When you are done modifying the threshold element colors, select the **Save As** button.

*Supervisor* displays the **Save Scheme As** window:

![Save Scheme As window](image)

9. In the text box, enter a name for this new threshold color scheme you have just created.

10. Select the **OK** button to save this new color scheme.

To view the changes that you made to a color scheme at any point in the modification, select the **Apply** button. The current color scheme is then applied to any reports that are running.
Use the **Name Format** tab to choose or create formats for how CMS entities (splits/skills, ACDs, VDNs, vectors, trunks, trunk groups, call work codes, and AUX codes) are displayed in *Supervisor*. The display can be set to any one or a combination of {name} for Dictionary Name, {entity} for entity type, and {number} for entity number.

Choose or create a name format using {name} for entity name (as entered in the Dictionary), {entity} for entity type, and {number} for entity number. These formats determine how items are displayed in reports. For example, if you select the name format of {entity}{number}, all of the entities that can be named in the Dictionary are displayed as the entity type and number instead of the name defined in the Dictionary. If you selected {name} as the name format, the names that are assigned to the entities in the Dictionary are displayed.
Defining entity formats

To define the name format for an entity:

1. From the Entity field, select the item for which you want to change the format.

2. In the Format field, use one of the following methods to select a format for the specified entity type:
   - Manually enter the format that you want using the three possible types: {name}, {entity}, and/or {number}. It is not necessary to use a separator character between formats unless you want the separator to appear in the report. For example, if you want to display agent names and extension numbers on reports, enter {name} {number} in the Format box.
   - Use the drop-down list to choose from a set of preformatted options.
     The Example field provides an example of what the format looks like based on your current definition.
     If you entered a nonstandard name format, it is not saved in the Format list.

3. Select OK to save your changes.
Chapter 3: Using the Dictionary to name contact center entities

This section provides information on procedures for using the Dictionary to administer names associated with contact center entities.

This section includes the following topics:

● About the Dictionary on page 50
● Before you begin on page 51
● Dictionary rules on page 51
● Searching the Dictionary on page 52
● ACD Groups on page 55
● ACDs on page 59
● Agent groups on page 64
● Agent string values on page 74
● Announcement names on page 79
● AUX reason code names on page 86
● Calculations on page 94
● Call work codes on page 102
● Constants on page 109
● Custom database items on page 116
● Generic string values synonyms on page 122
● Location IDs on page 125
● Login ID names on page 132
● Logout reason code names on page 139
● Split/skill string values on page 147
● Split/Skill names on page 152
● Standard database items on page 159
● Trunk group names on page 162
Using the Dictionary to name contact center entities

- **Trunk string values** on page 169
- **VDN names** on page 173
- **Vector names** on page 180
- **Dictionary reports** on page 187

---

**About the Dictionary**

The Dictionary subsystem is used to assign synonyms or names to contact center entities. The following list gives a short sample of the items used in the Dictionary:

- Login IDs
- Splits/skills
- Call work codes
- ACDs
- AUX reason codes
- Logout reason codes
- Trunk reason codes
- Trunk groups
- VDNs
- Vectors

The Dictionary also allows users to work with items in the database such as:

- Viewing standard database items
- Viewing standard calculations
- Creating and administering custom calculations
- Creating and administering constants
- Creating and administering custom database items

The names assigned through the Dictionary appear on reports to help users understand them better. The Dictionary also makes it possible for users to create agent groups, change agent splits/skills, and change trunk string values for reporting purposes. The Dictionary also provides a global search function to find any item within it.
Before you begin

If an ACD Group is selected as the current ACD in the Dictionary window, only those operations that are valid for the ACD Group will appear in the Operations: list.

Dictionary rules

The following rules apply to the names assigned in the Dictionary:

- Dictionary names can have from 1 to 20 characters.
- Names (synonyms) must begin with an alphabetic character.
- Dictionary names can include the following characters:
  - Any alphanumeric character
  - Underscore (_)
  - Blank ( )
  - Comma (,)
  - Period (.)
  - Apostrophe (’)
  - Plus sign (+)
- Blanks ( ) are allowed in all Dictionary names except:
  - Calculation names
  - Constant names
- Names must be unique within each section of the Dictionary for an ACD.
  - For example, you can name trunk group 1 as sales, and split/skill 1 as sales, but you cannot name split/skill 1 as sales and split/skill 2 as sales on the same ACD.
- Fields and entries made in the Dictionary are case-sensitive.

The following rules apply to the descriptions assigned in the Dictionary:

- Descriptions in the Dictionary can have from 1 to 50 characters.
- Descriptions can include all printable characters except:
  - Semicolon (;)
  - Backward slash (\)
Using the Dictionary to name contact center entities

- Grave accent (´)
- Tilde (~)
- Double quotes ("")
- Pipe symbol (|)
- Asterisk (*)
- Question mark (?)

Searching the Dictionary

The Dictionary contains a global search feature that can be used to find a wide variety of information. Some examples of the types of information you can search for in the dictionary are:

- A login ID or a group of login IDs
- A split, skill, or trunk group
- ACD names
- Database items
- Calculations
- Agent names

Permissions

To do a global search in the dictionary, you need write permissions for the Dictionary subsystem.
Steps

1. From the Controller Window, select **Commands > Dictionary**.
   *Supervisor* displays the **Dictionary** window.

![Dictionary window](image)

2. In the **Operations:** list, highlight **Global Search**.
   *Supervisor* displays the **Dictionary Global Search Input** window.

![Dictionary Global Search Input window](image)

**Note:**

Remember the following before entering search criteria:

- You can search on any pattern
- You can include an asterisk (*) or question mark (?) in your pattern
- The search is case sensitive

3. In the **Search for:** field, enter the item name or pattern.
Using the Dictionary to name contact center entities

4. From the **Actions** menu, select **Run**.

*Supervisor* displays the **Dictionary Global Search Results** window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value matched</td>
<td>Displays the matches for your pattern.</td>
</tr>
<tr>
<td>Field matched</td>
<td>Displays the name of the field in the Dictionary that corresponds to value matched.</td>
</tr>
<tr>
<td>In submenu</td>
<td>The Dictionary submenu where your search pattern was found.</td>
</tr>
<tr>
<td>Name</td>
<td>The name that corresponds to the value matched.</td>
</tr>
</tbody>
</table>
ACD Groups

This section provides information for viewing ACD Groups in the Dictionary. ACD Groups and the corresponding members can only be viewed through the Dictionary Operations window. Administration of ACD Groups is done through the Call Center Administration subsystem. The capability of viewing ACD Groups through the Dictionary subsystem allows those individuals who only run reports in the contact center to view which ACDs are defined within each ACD Group. This capability can assist these individuals in determining which ACD Groups should be used when running reports.

Note:
ACD Groups cannot be selected to display information through standard CMS reports. To run reports for ACD Groups, you will need to create custom reports through the CMS ASCII interface or have them created for you by contacting the Avaya Professional Services Organization.

This section contains the following topics:

- Before you begin on page 55
- Permissions on page 56
- Listing all ACD Groups on page 56
- Viewing the contents of an ACD Group on page 57

Related topic
For more information on ACD Groups and their usage, see ACD Groups on page 246.

Before you begin

The following should be read and understood before working with ACD Groups in the Dictionary:

- If you add an ACD Group, you will need to log out of Supervisor and log back in to see this group as a choice in the appropriate dialogs.

- An ACD Group cannot serve as the CMS master ACD.

- Overlapping ACD Groups (groups having common member ACDs), could result in synonym conflict within the members of an ACD Group if poorly administered. Because of this capability, entity IDs in overlapping ACD Groups must be mutually exclusive.

- Entity synonyms must be unique for an ACD Group and across all of the ACDs that are members of the ACD Group.

- User permissions are administered separately for an ACD Group and its member ACDs.
Using the Dictionary to name contact center entities

- CMS real-time custom reports are only displayed if data collection is enabled and the ACD link status is 'up' for at least one member ACD in the specified ACD Group. An error message will be displayed if these conditions are not met.
- Custom reports that are created with the Single ACD Only option enabled cannot be run for an ACD Group and vice versa.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view ACD Group names, you need read permissions for the Dictionary subsystem and the ACD Group.

Listing all ACD Groups

To view all ACD Groups defined on the CMS server:

1. From the Controller Window, select Commands > Dictionary. Supervisor displays the Dictionary window.

   ![Dictionary window screenshot]

2. In the Operations: list, highlight ACD Groups.
3. Select **OK**.

*Supervisor* displays the **Dictionary ACD Groups** window.

4. From the menu bar, select **Actions > List all**.

*Supervisor* displays the **Dictionary ACD Groups List all** window listing all ACD Groups defined on this CMS server.

---

**Viewing the contents of an ACD Group**

To view the ACDs assigned to an ACD Group:

1. From the Controller Window, select **Commands > Dictionary**.

*Supervisor* displays the **Dictionary** window.

2. In the **Operations: list**, highlight **ACD Groups**.
Using the Dictionary to name contact center entities

3. Select **OK**.

   *Supervisor* displays the **Dictionary ACD Groups** window.

![Dictionary ACD Groups window](image)

4. In the **ACD Group Name** field, enter the name of the ACD Group that you want to view.

5. From the menu bar, select **Actions > Find one**.

   *Supervisor* retrieves the information for the specified ACD Group, if valid.

6. From the menu bar, select **Actions > Get contents**.

   *Supervisor* displays the **Dictionary ACD Groups Get contents** window which lists all ACDs assigned to this ACD Group.
This section provides information on administering ACD names in the Dictionary. The Dictionary Operations window is used to assign names to real and pseudo ACDs. Generated reports will contain the ACDs names, rather than the assigned ACD numbers.

You can add, delete, or change an ACD name regardless of the ACD that you are currently logged in to. For example, you can be logged in to ACD 1 and change the name for ACD 3. This change does not appear on the changed window border of the ACD until you open a new window.

⚠️ Important:
The Dictionary naming rules apply to these procedures. See Dictionary rules on page 51 for more information.

This section contains the following topics:
- Permissions on page 59
- Adding an ACD name on page 60
- Modifying an ACD name on page 61
- Deleting an ACD Name on page 62

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To add, delete, or modify the name of an ACD, you need write permissions for the Dictionary subsystem and for the ACD.
- To view ACD names, you need read permissions for the Dictionary subsystem and for the ACD.
Adding an ACD name

To add a name for an ACD to the Dictionary:

1. From the Controller Window, select Commands > Dictionary. Supervisor displays the Dictionary window.

2. In the Operations: list, highlight ACDs.


4. In the ACD Name: field, enter the name of the ACD or ACD Group that you want to add, delete, or change.

   The name you assign to an ACD, pseudo ACD, or ACD Group in the Dictionary is displayed on all reports and window titles that are associated with that ACD.

5. In the ACD Number: field, enter a number between 1 and 38 to correspond with the new ACD name where 1 through 8 is reserved for real ACDs, 9 through 26 is reserved for pseudo-ACDs, and 27 through 38 is reserved for ACD Groups.

   Any additional information about the ACD can be entered in the Description: field. Only 50 or fewer characters can be entered in this field.
6. To add your changes to the Dictionary, select Actions > Add.

---

### Modifying an ACD name

To modify the name of an ACD in the Dictionary:

1. From the Controller Window, select Commands > Dictionary. 
   
   *Supervisor* displays the Dictionary window.

2. In the Operations: list, highlight ACDs.
3. Select OK.  
   
   *Supervisor* displays the Dictionary ACDs window.

4. In the ACD Number: field, enter the number of the ACD, pseudo-ACD, or ACD Group that you want to modify.
5. From the Actions menu, select Find One.
6. In the ACD Name: field, enter the new name for the selected ACD.
7. To add your changes to the Dictionary, select Actions > Modify.
Deleting an ACD Name

⚠️ Important:
Deleting an ACD name from the Dictionary only removes the name of the ACD. The ACD is then displayed as **unnamed_acd** \( n \) where \( n \) is the number of the ACD. No warnings are given during the process of deleting an ACD name. This procedure should not be performed unless you are certain that you want to delete the ACD name.

To delete the name of an ACD in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**. 
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **ACDs**.
3. Select **OK**. 
   *Supervisor* displays the **Dictionary** window.

4. In the **ACD Number**: field, enter the number of the ACD, pseudo-ACD, or ACD Group for which you want to delete the name.
5. From the **Actions** menu, select **Find One**.

   The name of the ACD is displayed in the **ACD Name**: field.

6. Select **Actions > Delete** to remove the ACD from the Dictionary.
Agent groups

This section provides procedures for creating and naming, copying, and deleting agent groups in the Dictionary using the Agent Groups window.

Agents can be grouped for reporting purposes, without regard to the split/skill assignment for the agent. For example, you can create a group for new employees or a group for employees with special skills.

This section contains the following topics:

● Permissions on page 64  
● Adding an agent group on page 65  
● Listing agents in an agent group on page 66  
● Copying an existing agent group to a new name on page 68  
● Adding agents to an existing agent group on page 69  
● Deleting agents in an existing agent group on page 71  
● Deleting an agent group on page 72

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

● To add, delete, or modify agent groups, you need write permissions for the Dictionary subsystem.

● To view agent groups, you need read permissions for the Dictionary subsystem.
Adding an agent group

To add an agent group to the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **Agent Groups**.

3. In the **ACD** field, enter the ACD or ACD Group on which you want to create the agent group.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Agent Groups** window.

5. In the **Agent group name** field, enter the name of the new agent group.

6. To add the agent group to the Dictionary, select **Actions > Add**.
Using the Dictionary to name contact center entities

7. To add the Login IDs for this agent group, select Actions > Get Contents.
   Supervisor displays the Agent Groups-Get Contents window.

   ![Agent Groups-Get Contents window]

8. Enter the Login IDs for the new group.
9. To add the Login IDs to the Dictionary for this agent group, select the Actions > Add.

Listing agents in an agent group

To list the agents defined in an agent group in the Dictionary:

1. From the Controller Window, select Commands > Dictionary.
   Supervisor displays the Dictionary window.

   ![Dictionary window]

2. In the Operations: list, highlight Agent Groups.
3. In the ACD: field, enter the ACD or ACD Group on which the agent group exists.
4. Select **OK**.

   *Supervisor* displays the **Dictionary Agent Groups** window.

![Dictionary Agent Groups window](image)

5. In the **Agent group name**: field, enter the name of the agent group.

6. From the **Actions** menu, select **Get contents**.

   *Supervisor* displays the **Agent Groups-Get Contents** window.

![Agent Groups-Get Contents window](image)

7. From the **Actions** menu, select **List All**.

   *Supervisor* displays the **Dictionary Agent Groups-Get Contents-List All** window listing the agents in the group.
Copying an existing agent group to a new name

To copy an existing agent group in the Dictionary to a new name:

1. From the Controller Window, select **Commands > Dictionary**.
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Agent Groups**.

3. In the **ACD**: field, enter the ACD or ACD Group on which the agent group exists.

4. Select **OK**.
   *Supervisor* displays the **Dictionary Agent Groups** window.

5. In the **Agent group name**: field, enter the name of the new agent group.
6. From the Actions menu, select Copy Group. 
   Supervisor displays the Dictionary-Agent Groups-Copy window.

   ![Dictionary-Agent Groups-Copy window]

7. In the Copy from: field, enter the name of the agent group that you want to copy.
8. From the Actions menu, select Copy Group.
   The new agent group is automatically populated with all the agents from the copied group.

---

Adding agents to an existing agent group

To add agents to a group that already exists in the Dictionary:

1. From the Controller Window, select Commands > Dictionary. 
   Supervisor displays the Dictionary window.

   ![Dictionary window]

2. In the Operations: list, highlight Agent Groups.
3. In the ACD: field, enter the ACD or ACD Group on which the agent group exists.
Using the Dictionary to name contact center entities

4. Select **OK**.

   Supervisor displays the **Dictionary Agent Groups** window.

5. In the **Agent group name:** field, enter the name of the agent group to which you will add agents.

6. From the **Actions** menu, select **Get Contents**.

   Supervisor displays the **Dictionary-Agent Groups-Get Contents** window.

7. Enter the Login IDs that you want to add to this group.

8. From the **Actions** menu, select **Add**.
Deleting agents in an existing agent group

To delete agents from an existing group in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Agent Groups**.

3. In the **ACD**: field, enter the ACD or ACD Group on which the agent group exists.

4. Select **OK**.
   
   *Supervisor* displays the **Dictionary Agent Groups** window.

5. In the **Agent group name**: field, enter the name of the agent group from which agents will be deleted.
Using the Dictionary to name contact center entities

6. From the **Actions** menu, select **Get contents**.

   *Supervisor* displays the **Agent Groups-Get Contents** window.

7. Enter the Login IDs to delete from this group.

8. From the **Actions** menu, select **Delete**.

---

### Deleting an agent group

To delete an agent group from the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Agent Groups**.

3. In the **ACD**: field, enter the ACD or ACD Group on which the agent group exists.
4. Select **OK**.

*Supervisor* displays the **Dictionary Agent Groups** window.

![Dictionary Agent Groups window]

5. In the **Agent group name** field, enter the name of the agent group to delete.

6. From the **Actions** menu, select **Delete**.

The selected agent group name is removed from the Dictionary.
Agent string values

Agent string values are the descriptive words in reports that correspond with agent states. These words, such as ACD, ACW, or AUX, describe the value of the data. Strings are changed to the values you administer when they are displayed as data in a report. The report heading is not affected.

This section contains the following topics:

- Permissions on page 74
- Changing agent string value descriptions on page 75
- Agent string value field descriptions on page 77

Permissions

Depending on the procedure that you want to perform, you will need the following permissions:

- To modify agent string values, you need write permissions for the Dictionary subsystem.
- To view agent string values, you need read permissions for the Dictionary subsystem.
Changing agent string value descriptions

To change agents string value descriptions in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

   ![Dictionary Window]

   2. In the **Operations** list, highlight **Agent String Values**.
3. In the **ACD** field, select the ACD or ACD Group that you want to modify. *Supervisor* displays the **Dictionary Agent String Values** window.

4. Enter a new descriptive word in the field that you want to change. See *Agent string value field descriptions* on page 77 for field descriptions.
Agent string value field descriptions

The following table describes the fields for the agent string values:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Work Mode</td>
<td>To change any of the work-mode default names, enter the new descriptive word in the appropriate work mode field. Agents can be in any one of the following work modes:</td>
</tr>
<tr>
<td></td>
<td>● ACD - The agent is on an ACD call.</td>
</tr>
<tr>
<td></td>
<td>● ACW - The agent is in the after-call work mode.</td>
</tr>
<tr>
<td></td>
<td>● AUX - The agent is in the auxiliary work mode.</td>
</tr>
<tr>
<td></td>
<td>● AVAIL - The agent is available to take an ACD call.</td>
</tr>
<tr>
<td></td>
<td>● DACD - The agent is on a direct agent ACD call.</td>
</tr>
<tr>
<td></td>
<td>● DACW - The agent is in the after-call work mode for a direct agent ACD call.</td>
</tr>
<tr>
<td></td>
<td>● OTHER - The agent has just logged in and CMS has not yet been notified of the agent's state, or the agent is dialing to place an extension call while in auto-in/manual-in (AI/MI), or the agent is in AI/MI and has an extension call ringing, or the agent has put a call on hold and has taken no further call-related action.</td>
</tr>
<tr>
<td></td>
<td>● RINGING - An ACD call is ringing at the agent's voice terminal and the agent is not doing anything else.</td>
</tr>
<tr>
<td></td>
<td>● UNKNOWN - CMS does not recognize the current state.</td>
</tr>
<tr>
<td></td>
<td>● UNSTAFF - The agent is not logged in (is not staffed).</td>
</tr>
<tr>
<td>Agent Trace Work Mode</td>
<td>To change the agent trace, work-mode default names, enter the new descriptive word next to LOGON or LOGOFF.</td>
</tr>
<tr>
<td></td>
<td>● LOGON - An agent is logged in.</td>
</tr>
<tr>
<td></td>
<td>● LOGOFF - An agent is logged out and is not available to take ACD calls.</td>
</tr>
<tr>
<td>Call Handling Preference</td>
<td>To change the call-handling preference default names, enter the new descriptive word next to LEVEL, NEED, or PERCENT.</td>
</tr>
<tr>
<td></td>
<td>● LEVEL - The agent's call-handling preference is by skill level.</td>
</tr>
<tr>
<td></td>
<td>● NEED - The agent's call-handling preference is by greatest need.</td>
</tr>
<tr>
<td></td>
<td>● PERCENT - The agent's call-handling preference is based on an assigned percentage of time allocated to each skill.</td>
</tr>
<tr>
<td>Reserve Level</td>
<td>To change the reserve-level default names, enter the new descriptive word next to Rsv1 or Rsv2.</td>
</tr>
<tr>
<td></td>
<td>● Rsv1 - The agent begins answering calls when the skill's 1st threshold is crossed.</td>
</tr>
<tr>
<td></td>
<td>● Rsv2 - The agent begins answering calls when the skill's second threshold is crossed.</td>
</tr>
</tbody>
</table>
Using the Dictionary to name contact center entities

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Call Direction      | To change the call-direction default names, enter the new descriptive word next to IN or OUT:  
|                     | ● IN - The agent is on an incoming call.  
|                     | ● OUT - The agent is on an outbound call.                                                                                                                                 |
| Call Origination    | To change the call-origination default names, enter the new descriptive word next to PHONE or KEYBOARD. Agents can be on either type of the following outbound calls:  
|                     | ● PHONE - The agent dialed an outbound call using the voice terminal dial pad.  
|                     | ● KEYBOARD - The agent dialed an outbound call using the computer keyboard.                                                                                                                                 |
| Call Destination    | To change the call-destination default names, enter the new descriptive word next to PBX or OFF.  
|                     | ● PBX - Internal to the switch.  
|                     | ● OFF - External to the switch.                                                                                                                                 |
| Agent Role          | To change the agent role default names, enter the new descriptive word next to TOP, ALLOCATED, BACKUP, ROVING, or RESERVE.  
|                     | ● TOP - The agent can be counted on to answer the skill's calls (unless an agent's other skills go into overload).  
|                     | ● ALLOCATED - The agent has a percentage of his/her time allocated to answering the skill's calls.  
|                     | ● BACKUP - The agent helps to answer the skill's calls when his/her top skill is not busy.  
|                     | ● ROVING - The agent answers a skill's calls when this skill has the greatest need.  
|                     | ● RESERVE - The agent helps answer the skill's calls when the skill is over threshold. These roles vary according to call-handling preference. |
Announcement names

This section provides information on working with announcement names in the Dictionary. Announcements are recorded messages that are played for callers. Announcement names are synonyms assigned to these recorded messages in the Dictionary.

This section contains the following topics:

- Permissions on page 79
- Before you begin on page 79
- Adding an announcement name on page 80
- Viewing an announcement name on page 81
- Listing all announcement names for an ACD on page 82
- Modifying an announcement name on page 83
- Deleting an announcement name on page 84

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view announcement names, you need read permissions for the Dictionary subsystem.
- To add, delete, or modify announcement names, you need write permissions for the Dictionary subsystem.

Before you begin

The following items should be read and understood before working with announcement names in the Dictionary:

- Announcement names must be unique.
- Multiple values are not allowed for announcement names or numbers.
Using the Dictionary to name contact center entities

---

Adding an announcement name

To add a name for an announcement to the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **Announcements**.

3. In the **ACD** field, enter the ACD on which the announcement resides.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Announcements** window.

5. In the **Announcement Name** field, enter the name that you want to assign to the announcement.

6. In the **Announcement Number** field, enter a number that will correspond with the announcement name.

   Any additional information about the announcement can be entered in the **Description** field. Only 50 or fewer characters can be entered in this field.

7. From the **Action** menu, select **Add**.
Viewing an announcement name

To view an announcement name in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Announcements**.
3. In the **ACD:** field, enter the ACD on which the announcement resides.
4. Select **OK**.
   *Supervisor* displays the **Dictionary Announcements** window.

5. To find an announcement name to view, only one of the fields requires an announcement to be specified. Perform one of the following actions to specify an existing announcement in the Dictionary:
   - In the **Announcement Name:** field, enter the synonym name of the announcement.
   - In the **Announcement Number:** field, enter the number of the announcement.

6. From the **Action** menu, select **Find One**.
   *Supervisor* retrieves and displays the data for the specified announcement, if valid.
Listing all announcement names for an ACD

To list all announcement names that are defined in the Dictionary for an ACD:

1. From the Controller Window, select **Commands > Dictionary**.
   *Supervisor* displays the Dictionary window.

2. In the **Operations** list, highlight **Announcements**.

3. In the **ACD**: field, enter the ACD on which the announcement resides.

4. Select **OK**.
   *Supervisor* displays the Dictionary Announcements window.

5. From the **Action** menu, select **List All**.
Modifying an announcement name

To modify an announcement name in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **Announcements**.
3. In the **ACD** field, enter the ACD on which the announcement resides.
4. Select **OK**.

   *Supervisor* displays the **Dictionary Announcements** window.

5. To find an announcement name to modify, only one of the fields requires an announcement to be specified so that it can be found. Perform one of the following actions to specify an existing announcement in the Dictionary:

   - In the **Announcement Name**: field, enter the name of the announcement.
   - In the **Announcement Number**: field, enter the number of the announcement.

6. From the **Action** menu, select **Find One**.

   *Supervisor* retrieves and displays the data for the specified announcement, if valid.
Using the Dictionary to name contact center entities

7. In the **Announcement Name:** field, enter the new announcement name.
8. From the **Action** menu, select **Modify**.

---

### Deleting an announcement name

To delete an announcement name in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Announcements**.
3. In the **ACD:** field, enter the ACD on which the announcement resides.
4. Select **OK**.
   
   *Supervisor* displays the **Dictionary Announcements** window.

5. To find an announcement name to delete, only one of the fields requires an announcement to be specified so that it can be found in the Dictionary. Perform one of the following actions to specify an existing announcement in the Dictionary:
   
   - In the **Announcement Name:** field, enter the name of the announcement.
● In the Announcement Number: field, enter the number of the announcement.

6. From the Action menu, select Find One.

   Supervisor retrieves and displays the data for the specified announcement, if valid.

7. From the Action menu, select Delete.
AUX reason code names

This section provides information on working with AUX reason code names in the Dictionary. AUX reason codes enable a contact center to track an agent's time more precisely when the agent is in the AUX work mode. The agent can specify exactly why the AUX state is used, such as for lunch or meetings. You can view, add, delete, or change AUX reason code names by selecting AUX Reason Codes from the Dictionary menu.

Complete the AUX Reason Codes window if you want names associated with your AUX reason codes to appear in the AUX Reasons Code standard real-time and historical reports.

This section contains the following topics:

- Permissions on page 86
- Before you begin on page 86
- Adding an AUX reason code name on page 87
- Viewing an AUX reason code name on page 88
- Listing all AUX reason code names on page 89
- Modifying an AUX reason code name on page 90
- Deleting an AUX reason code on page 92

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view AUX reason codes, you need read permissions for the Dictionary subsystem.
- To add, delete, or modify AUX reason codes, you need write permissions for the Dictionary subsystem.

Before you begin

The following items should be read and understood before working with AUX reason code names in the Dictionary:

- To use AUX reason codes, your switch must have EAS.
- AUX reason codes are single digits, 0 through 9.
- AUX reason code names can be up to 20 characters long.
AUX reason code names

- AUX reason code 0 is used for cases in which the switch automatically puts an agent into AUX work mode. You can change this name.
- Names must be unique within an ACD. No two AUX reason codes in the same ACD can have the same name.
- If you make changes to the AUX reason code names you must restart any report that uses AUX reason codes to see the changes.

Adding an AUX reason code name

To add a name in the Dictionary for an AUX reason code:

1. From the Controller Window, select **Commands > Dictionary**.  
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **AUX Reason Codes**.
3. In the **ACD**: field, enter the ACD or ACD Group on which the AUX Reason Codes reside.
4. Select **OK**.  
   *Supervisor* displays the **Dictionary AUX Reason Codes** window.
Using the Dictionary to name contact center entities

5. In the **AUX Reason Code name**: field, enter the name for the AUX reason code.
6. In the **AUX Reason Code**: field, enter the one-digit AUX reason code number, between 0 and 9.

   Any additional information about the AUX reason code can be entered in the **Description**: field. Only 50 or fewer characters can be entered in this field.

7. From the **Action** menu, select **Add**.

---

**Viewing an AUX reason code name**

To view the name of an AUX reason code in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **AUX Reason Codes**.
3. In the **ACD**: field, enter the ACD or ACD Group on which the AUX Reason Codes reside.
4. Select **OK**.

   *Supervisor* displays the **Dictionary AUX Reason Codes** window.
5. To find an AUX reason code name to view, only one of the fields requires an AUX reason code to be specified. Perform one of the following actions to specify an existing AUX reason code in the Dictionary:

- In the **AUX Reason Code name**: field, enter the name for the AUX reason code.
- In the **AUX Reason Code**: field, enter the one-digit AUX reason code number, between 0 and 9.

6. From the **Actions** menu, select **Find One**.

*Supervisor* retrieves and displays the information for the specified AUX reason code, if valid.

---

**Listing all AUX reason code names**

To list all AUX reason code names in the Dictionary for an ACD:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **AUX Reason Codes**.

3. In the **ACD**: field, enter the ACD or ACD Group on which the AUX Reason Codes reside.
Using the Dictionary to name contact center entities

4. Select **OK**.

*Supervisor* displays the **Dictionary AUX Reason Codes** window.

5. From the **Actions** menu, select **List All**.

*Supervisor* displays the **Dictionary AUX Reason Codes - List All** window.

**Modifying an AUX reason code name**

To modify an AUX reason code name in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

*Supervisor* displays the **Dictionary** window.
2. In the **Operations** list, highlight **AUX Reason Codes**.

3. In the **ACD** field, enter the ACD or ACD Group on which the AUX reason codes reside.

4. Select **OK**.

   *Supervisor* displays the **Dictionary AUX Reason Codes** window.

5. To find an AUX reason code name to modify, only one of the fields requires an AUX reason code name to be specified. Perform one of the following actions to specify an existing AUX reason code name in the Dictionary:
   
   - In the **AUX Reason Code name** field, enter the name for the AUX reason code.
   - In the **AUX Reason Code** field, enter the one-digit AUX reason code number, between 0 and 9.

6. From the **Actions** menu, select **Find One**.

   *Supervisor* retrieves and displays the information for the specified AUX reason code, if valid.

7. In the **AUX Reason Code name** field, enter the new name for the AUX reason code.

8. From the **Actions** menu, select **Modify**.

   *Supervisor* updates the name for the AUX reason code in the database.
Deleting an AUX reason code

To delete an AUX reason code name from the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **AUX Reason Codes**.

3. In the **ACD**: field, enter the ACD or ACD Group on which the AUX reason codes reside.

4. Select **OK**.

   *Supervisor* displays the **Dictionary AUX Reason Codes** window.

5. To find an AUX reason code name to delete, only one of the fields requires an AUX reason code to be specified. Perform one of the following actions to specify an existing AUX reason code in the Dictionary:

   - In the **AUX Reason Code name**: field, enter the name for the AUX reason code.
   - In the **AUX Reason Code**: field, enter the one-digit AUX reason code number, between 0 and 9.
6. From the **Actions** menu, select **Find One**.

   *Supervisor* retrieves and displays the information for the specified AUX reason code, if valid.

7. From the **Actions** menu, select **Delete**.

   *Supervisor* removes the specified AUX reason code from the Dictionary.
Calculations

Calculation names are abbreviated names for the calculations in the database that are used to create reports. You can view standard calculations or create your own custom calculations to use in custom reports. The names for calculations used in standard reports already exist in the Dictionary.

This section contains the following topics:

- Permissions on page 94
- Before you begin on page 94
- Viewing a calculation on page 95
- Listing all calculations on page 97
- Adding a calculation on page 98
- Modifying a custom calculation on page 99
- Deleting a custom calculation on page 100

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view calculations, you need read permissions for the Dictionary subsystem.
- To create, delete or modify a custom calculation, you need write permissions for the Dictionary subsystem.

Before you begin

The following items should be read and understood before changing calculations in the Dictionary:

- Calculations must be one word with no blanks.
- Reports will not run if you embed calculations more than three levels deep.
- Standard calculations cannot be deleted.

The standard CMS calculations are listed in the following documents:

- Avaya CMS Database Items and Calculations
- Avaya CMS Supervisor Report Designer User Guide
It is recommended that you identify your own calculations in all lowercase letters to distinguish them from the standard CMS calculations, which are in all uppercase letters.

If you delete a custom calculation from the Dictionary, any reports that it appeared in will not run.

You can adversely affect standard reports if you change a standard CMS calculation. Reports will probably run, but the results may be different from those expected.

Reports will not run if you create calculations that reference each other in a circular fashion. For example, assume that CALC_1 uses CALC_2 in its processing. If CALC_2 then uses CALC_1 in its processing, this creates a circular pattern where processing cannot be completed.

---

**Viewing a calculation**

To view a calculation in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**. *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Calculations**.
Using the Dictionary to name contact center entities

3. Select **OK**.

   *Supervisor* displays the **Dictionary Calculations** window.

4. To find a calculation to view, only one of the fields requires a calculation to be specified. Perform one of the following actions to specify an existing database calculation in the Dictionary:

   - If you know the name of the calculation, enter it in the **Calculation name**: field.
   - If you do not know the name of the calculation, perform the following steps to view all the calculations alphabetically:
     1. Leave all the fields in the **Dictionary Calculations** window blank, and from the **Actions** menu, select **Find One**.
     2. Use the **Next** or **Previous** buttons to move through the list of existing calculations.
Listing all calculations

To list all calculations in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **Calculations**.
3. Select **OK**.
   
   *Supervisor* displays the **Dictionary Calculations** window.

4. From the **Actions** menu, select **List All**.
Adding a calculation

To add a calculation in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   Supervisor displays the **Dictionary** window.

2. In the **Operations** list, highlight **Calculations**.

3. Select **OK**.
   
   Supervisor displays the **Dictionary Calculations** window.

4. Enter the name of the calculation in the **Calculation name** field.

   **Important:**
   
   Use lowercase letters in the name to distinguish this custom calculations from a standard CMS calculation.

5. In the **Calculation** field, enter the formula for the calculation.

   Formulas can include:
   
   - Database items
• Constants
• Calculations (the maximum nesting level is 3)
• The following arithmetic operators:
  - + (add)
  - - (subtract)
  - * (multiply)
  - / (divide)
  - ( ) (do first, as in standard mathematical operations)
Any additional information about the calculation can be entered in the **Description:** field. Only 50 or fewer characters can be entered in this field.

6. From the **Actions** menu, select **Add**.
   The custom calculation is added to the Dictionary.

### Modifying a custom calculation

⚠️ **Important:**
Modifying a standard CMS calculation is not recommended. If you modify a standard CMS calculation, the meaning of that calculation is changed in every report in which it appears.

To modify a custom calculation:

1. From the Controller Window, select **Commands > Dictionary**.
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Calculations**.
Using the Dictionary to name contact center entities

3. Select **OK**.

   *Supervisor* displays the **Dictionary Calculations** window.

![Dictionary Calculations window](image)

4. Enter the name of the custom calculation in the **Calculation name:** field.

5. From the **Actions** menu, select **Find One**.

6. In the **Calculation:** field, enter the new formula.
   
   Any changes to the descriptive information, can be entered in the **Description:** field.

7. From the **Actions** menu, select **Modify**.

---

**Deleting a custom calculation**

To delete a custom calculation:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

![Dictionary window](image)

2. In the **Operations:** list, highlight **Calculations**.
3. Select **OK**.

   *Supervisor* displays the **Dictionary Calculations** window.

4. Enter the name of the custom calculation in the **Calculation name:** field.

5. From the **Actions** menu, select **Find One**.

   *Supervisor* retrieves and displays the information for the specified calculation, if valid.

6. From the **Actions** menu, select **Delete**.

   The specified calculation is removed from the Dictionary.
Using the Dictionary to name contact center entities

Call work codes

Call work codes are numeric sequences that are entered by agents to categorize the type of call that they have just received or are currently handling. By entering call work codes, agents can assign one of many defined categories to the calls which can be later viewed in detail through reports. The call work codes are defined in the Dictionary and can be used to represent any type of call in which there is an interest in tracking, such as complaints, special sales, promotional events, and so forth. Up to five call work codes can be assigned to each call. You can view, add, delete, or modify call work codes and their names from the Call Work Codes window. These names then appear in the standard Call Work Code historical report.

This section contains the following topics:

- Permissions on page 102
- Before you begin on page 102
- Adding a name to a call work code on page 103
- Viewing a call work code name on page 104
- Listing all call work code names on page 105
- Modifying a call work code name on page 106
- Deleting a call work code name on page 107

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view call work code names, you need read permissions for the Dictionary subsystem.
- To add, delete or modify call work code names, you need write permissions for the Dictionary subsystem.

Before you begin

The following items should be read and understood before changing call work codes in the Dictionary:

- Call work codes must be activated on the ACD before the administration and naming of them can be performed.
- Call work codes require storage space on the CMS file system. The number of call work codes available on a system must be configured through the Data Storage Allocation
Call work codes

window. See Chapter 10: Configuring CMS system settings on page 463 for more information.

- Call Work Code 0 is reserved for unadministered work codes so that summary data can be collected. The default name for Call Work Code 0 is Unadministered codes, but this name can be modified.
- Even though call work codes can be up to 16 digits in length, a Dictionary name can only be assigned to a call work code that is 9 digits in length.

Adding a name to a call work code

To add a name to a call work code:

1. From the Controller Window, select Commands > Dictionary.
   Supervisor displays the Dictionary window.

2. In the Operations: list, highlight Call Work Codes.
3. In the ACD: field, enter the ACD on which the call work code resides.
4. Select OK.
   Supervisor displays the Dictionary Call Work Codes window.

5. In the Call work code name: field, enter the name of the new call work code.
Using the Dictionary to name contact center entities

6. In the **Call work code**: field, enter the number of the new call work code.

7. From the **Actions** menu, select **Add**.
   The specified call work code and its associated name is added to the Dictionary.

---

**Viewing a call work code name**

To view the name assigned to a call work code in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   *Supervisor* displays the **Dictionary** window.

   ![Dictionary window](image)

2. In the **Operations**: list, highlight **Call Work Codes**.

3. In the **ACD**: field, enter the ACD on which the call work code resides.

4. Select **OK**.
   *Supervisor* displays the **Dictionary Call Work Codes** window.

   ![Dictionary Call Work Codes window](image)

5. To find a call work code name to view, only one of the fields requires a call work code to be specified. Perform one of the following actions to specify an existing call work code in the Dictionary:
   - In the **Call work code name**: field, enter the name of the call work code.
Call work codes

- In the **Call work code**: field, enter the number of the call work code.

6. From the **Actions** menu, select **Find One**.

   *Supervisor* retrieves and displays the information for the specified call work code, if valid.

---

### Listing all call work code names

To list all call work code names in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Call Work Codes**.

3. In the **ACD**: field, enter the ACD on which the call work codes reside.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Call Work Codes** window.

5. From the **Actions** menu, select **List All**.
Modifying a call work code name

To modify a call work code name in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.  
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Call Work Codes**.
3. In the **ACD:** field, enter the ACD on which the call work code resides.
4. Select **OK**.  
   *Supervisor* displays the **Dictionary Call Work Codes** window.

5. To find a call work code name to modify, only one of the fields requires a call work code to be specified. Perform one of the following actions to specify an existing call work code in the Dictionary:
   - In the **Call work code name:** field, enter the name of the of the call work code.
   - In the **Call work code:** field, enter the number of the of the call work code.
6. From the **Actions** menu, select **Find One**.  
   *Supervisor* retrieves and displays the information for the specified call work code, if valid.
7. In the **Call work code name**: field, enter the new name for the call work code.
8. From the **Actions** menu, select **Modify**.

The specified call work code entry is modified in the Dictionary.

---

### Deleting a call work code name

To delete the name of a call work code in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **Call Work Codes**.

3. In the **ACD** field, enter the ACD on which the call work code resides.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Call Work Codes** window.

5. To find a call work code name to delete, only one of the fields requires a call work code to be specified. Perform one of the following actions to specify an existing call work code in the Dictionary:
   - In the **Call work code name**: field, enter the name of the call work code.
   - In the **Call work code**: field, enter the number of the call work code.
Using the Dictionary to name contact center entities

6. From the **Actions** menu, select **Find One**.

   *Supervisor* retrieves and displays the information for the specified call work code, if valid.

7. From the **Actions** menu, select **Delete**.

   The specified call work code is removed from the Dictionary.
Constants

Constants are items with fixed numerical values that you can enter into the Dictionary for use only in custom and designer reports. Constants do not exist in CMS when it is installed.

This section contains the following topics:

- Permissions on page 109
- Adding a constant on page 110
- Viewing a constant on page 111
- Listing all constants on page 112
- Modifying a constant on page 113
- Deleting a constant on page 114

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view a constant, you need read permissions for the Dictionary subsystem.
- To add, delete or modify a constant, you need write permissions for the Dictionary subsystem.
Using the Dictionary to name contact center entities

---

## Adding a constant

To add a constant to the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Constants**.

3. Select **OK**.
   
   *Supervisor* displays the **Dictionary Constants** window.

4. In the **Constant name:** field, enter the name of the new constant.

5. In the **Value:** field, enter the numerical value of the constant. The value can range from -99999 to 999999.
   
   Any additional information about the constant can be entered in the **Description:** field. Only 50 or fewer characters can be entered in this field.

6. From the **Actions** menu, select **Add**.
Viewing a constant

To view a constant in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Constants**.
3. Select **OK**.
   
   *Supervisor* displays the **Dictionary Constants** window.

4. To find a constant to view, only one of the fields requires an entry to be specified.
   Perform one of the following actions to specify an existing constant in the Dictionary:
   
   - In the **Constant name:** field, enter the name of the constant.
   - In the **Value:** field, enter the numerical value of the constant.

5. From the **Actions** menu, select **Find One**.
   
   *Supervisor* retrieves and displays the information for the specified constant, if valid.
Using the Dictionary to name contact center entities

Listing all constants

To list all constants defined in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **Constants**.
3. Select **OK**.
   
   *Supervisor* displays the **Dictionary Constants** window.

4. From the **Actions** menu, select **List All**.
Modifying a constant

To modify a constant that is defined in the Dictionary:

1. From the Controller Window, select Commands > Dictionary.

   Supervisor displays the Dictionary window.

2. In the Operations: list, highlight Constants.

3. Select OK.

   Supervisor displays the Dictionary Constants window.

4. To find a constant to modify, only one of the fields requires an entry to be specified.
   Perform one of the following actions to specify an existing constant in the Dictionary:
   ● In the Constant name: field, enter the name of the constant.
   ● In the Value: field, enter the numerical value of the constant.

5. From the Actions menu, select Find One.

   Supervisor retrieves and displays the information for the specified constant, if valid.

6. In the Value: field, enter the new numerical value for the constant.
Using the Dictionary to name contact center entities

Note:
You cannot modify the name of the new constant. If you want to change the name, you must delete the old constant and add a new one.

7. From the Actions menu, select Modify.

Deleting a constant

To delete a constant from the Dictionary:

1. From the Controller Window, select Commands > Dictionary.

Supervisor displays the Dictionary window.

2. In the Operations: list, highlight Constants.

3. Select OK.

Supervisor displays the Dictionary Constants window.

4. To find a constant to delete, only one of the fields requires an entry to be specified. Perform one of the following actions to specify an existing constant in the Dictionary:
   - In the Constant name: field, enter the name of the constant.
In the **Value**: field, enter the numerical value of the constant.

5. From the **Actions** menu, select **Find One**.
   
   *Supervisor* retrieves and displays the information for the specified constant, if valid.

6. From the **Actions** menu, select **Delete**.
   
   The specified constant is removed from the Dictionary.
Custom database items

You can define your own custom database items, which are stored in the CMS database. The custom database items are entered from the Dictionary Custom Items window, and allow you to combine your own data with the CMS data on custom or designer reports. You can also modify or delete custom database items.

This section contains the following topics:

- Permissions on page 116
- Before you begin on page 116
- Adding a custom database item on page 117
- Viewing a custom database item on page 118
- Listing all custom database items on page 119
- Modifying a custom database item on page 120
- Deleting a custom database item on page 121

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view a custom database item, you need read permissions for the Dictionary subsystem.
- To add, delete, or modify a custom database item, you need write permissions for the Dictionary subsystem.

Before you begin

The following items should be read and understood before working with custom database items in the Dictionary:

- You must first create the table in the database before you create a custom database item.
Adding a custom database item

To create a custom database item in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Custom Items**.
3. Select **OK**.

   *Supervisor* displays the **Dictionary Custom Items** window.

4. In the **Database item:** field, enter the name of the new database item.

   Any additional information about the custom database item can be entered in the **Description:** field. Only 50 or fewer characters can be entered in this field.
5. In the **Table:** field, enter the name of the table that will contain the new custom database item.
6. From the **Actions** menu, select **Add**.
Using the Dictionary to name contact center entities

---

**Viewing a custom database item**

To view a custom database item in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Custom Items**.

3. Select **OK**.
   
   *Supervisor* displays the **Dictionary Custom Items** window.

4. In the **Database item:** field, enter the name of the custom database item.

5. From the **Actions** menu, select **Find One**.
   
   *Supervisor* retrieves and displays the information for the specified custom database item, if valid.
Listing all custom database items

To list all custom database items in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Custom Items**.
3. Select **OK**.
   
   *Supervisor* displays the **Dictionary Custom Items** window.

4. In the **Database item:** field, enter the name of the custom database item.
5. From the **Actions** menu, select **List All**.
Modifying a custom database item

To modify an existing custom database item in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**. 
   *Supervisor* displays the Dictionary window.

2. In the **Operations:** list, highlight **Custom Items**.
3. Select **OK**. 
   *Supervisor* displays the Dictionary Custom Items window.

4. In the **Database item:** field, enter the new name for the custom database item.
5. In the **Table:** and **Description:** fields, enter the new information for the custom database item. Only 50 or fewer characters can be entered in the **Description:** field.

   **Note:**
   Note: You cannot modify the name of a custom database item. You must delete the old item and add the new item if you want a different name.

6. From the **Actions** menu, select **Modify**. 
   The specified custom database item and its changes are saved to the Dictionary.
Deleting a custom database item

To delete a custom database item from the Dictionary:

1. From the Controller Window, select Commands > Dictionary.
   
   Supervisor displays the Dictionary window.

2. In the Operations: list, highlight Custom Items.
3. Select OK.
   
   Supervisor displays the Dictionary Custom Items window.

4. In the Database item: field, enter the name of the database item to delete.
5. From the Actions menu, select Find One.
   
   Supervisor retrieves and displays the information for the specified custom database item, if valid.
6. From the Actions menu, select Delete.
   
   The specified custom database item is removed from the Dictionary.
Generic string values synonyms

Modifying generic string values allows you to enter a replacement string for the default y for YES and n for NO values. The string values can be up to six characters in length. These modified string values appear in custom or designer reports that use the YES or NO synonyms.

This section contains the following topics:

- Permissions on page 122
- Viewing generic string values on page 123
- Modifying generic string values on page 124

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view generic string values, you need read permissions for the Dictionary subsystem.
- To modify generic string values, you need write permissions for the Dictionary subsystem.
Viewing generic string values

To view a generic string value from the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Generic String Values**.

3. In the **ACD**: field, enter the ACD or ACD Group on which the generic string values reside.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Generic String Values** window.
Modifying generic string values

To modify an existing generic string value in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.  
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Generic String Values**.
3. In the **ACD**: field, enter the ACD or ACD Group on which the generic string values reside.
4. Select **OK**.  
   *Supervisor* displays the **Dictionary Generic String Values** window.

5. In the **YES**: field, enter up to six characters.
6. In the **NO**: field, enter up to six characters.
   
   The characters entered in the **YES**: and **NO**: fields will appear in reports that use YES and NO fields.
7. From the **Actions** menu, select **Modify**.
Location IDs

Location IDs represent the physical location or site where an agent sits or the port network to which a trunk is assigned. Location IDs can be named for ease of identification in reporting for multi-site environments. The same location IDs and their synonyms are used for both agents and trunks.

This section contains the following topics:

- Permissions on page 125
- Adding a location ID on page 126
- Viewing a location ID on page 127
- Listing all location IDs on page 128
- Modifying a location ID on page 129
- Deleting a Location ID on page 130

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view the name of a location ID, you need read permissions for the Dictionary subsystem.
- To add, delete, or modify the name of a location ID, you need write permissions for the Dictionary subsystem.
Adding a location ID

To add a location ID to the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

   ![Dictionary Window]

2. In the **Operations** list, highlight **Location IDs**.

3. In the **ACD** field, enter the ACD on which you want to add the location ID.

4. Select **OK**.
   
   *Supervisor* displays the **Dictionary Location IDs** window.

   ![Dictionary Location IDs Window]

5. In the **Location name**: field, enter the name of the new location.

6. In the **Location ID**: field, enter the number from 1 to 44 for the new location.

   Any additional information about the location ID can be entered in the **Description**: field. Only 50 or fewer characters can be entered in this field.

7. From the **Actions** menu, select **Add**.
Viewing a location ID

To view the information associated with an existing location ID in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   Supervisor displays the **Dictionary** window.

2. In the **Operations** list, highlight **Location IDs**.
3. In the **ACD** field, enter the ACD on which the location ID resides.
4. Select **OK**.
   Supervisor displays the **Dictionary Location IDs** window.

5. To find a location ID to view, only one of the fields requires a value to be specified.
   Perform one of the following actions to specify a location ID in the Dictionary:
   - In the **Location Name** field, enter the name of the location.
   - In the **Location ID** field, enter the number of the location.

6. From the **Actions** menu, select **Find One**.
   Supervisor retrieves and displays the information for the specified location ID, if valid.
Using the Dictionary to name contact center entities

---

### Listing all location IDs

To list all location IDs defined in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Location IDs**.

3. In the **ACD**: field, enter the ACD on which the location IDs reside.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Location IDs** window.

5. From the **Actions** menu, select **List All**.
Modifying a location ID

To modify an existing location ID in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Location IDs**.

3. In the **ACD:** field, enter the ACD on which the location ID resides.

4. Select **OK**.
   
   *Supervisor* displays the **Dictionary Location IDs** window.

5. To find a location ID to modify, only one of the fields requires a value to be specified. Perform one of the following actions to specify a location ID in the Dictionary:
   
   - In the **Location Name:** field, enter the name of the location.
   - In the **Location ID:** field, enter the number of the location.

6. From the **Actions** menu, select **Find One**.
   
   *Supervisor* retrieves and displays the information for the specified location ID, if valid.

7. In the **Location Name:** field, enter the new name for the location.
Using the Dictionary to name contact center entities

8. From the **Actions** menu, select **Add**.

---

### Deleting a Location ID

To remove a location ID from the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **Location IDs**.

3. In the **ACD** field, enter the ACD on which the location ID resides.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Location IDs** window.

5. To find a location ID to delete, only one of the fields requires a value to be specified. Perform one of the following actions to specify a location ID in the Dictionary:
   - In the **Location Name** field, enter the name of the location.
   - In the **Location ID** field, enter the number of the location.
6. From the **Actions** menu, select **Find One**.
   *Supervisor* retrieves and displays the information for the specified location ID.

7. From the **Actions** menu, select **Delete**.
   The specified location ID is removed from the Dictionary.
CMS uses agent login IDs to identify measured ACD agents. After an agent's name is assigned to a login ID, CMS windows and reports show that agent's login ID name instead of the login ID number.

You do not have to input agent names in the Dictionary, but CMS administration windows and reports are easier to understand with agent names instead of login IDs. Depending on the amount of space in the report, agent names can be truncated.

This section contains the following topics:

- Permissions on page 132
- Before you begin on page 132
- Adding a name to a login ID on page 133
- Viewing a login ID name on page 134
- Listing all login ID names on page 135
- Modifying a login ID name on page 136
- Deleting a login ID name on page 137

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view login IDs, you need read permissions for the Dictionary subsystem.
- To add, delete, or modify login IDs, you need write permissions for the Dictionary subsystem.

Before you begin

The following items should be read and understood before working with login ID names in the Dictionary:

- Login ID names are sorted alphabetically in the Dictionary based on the first character that you input in the Agent name: field.
  For example, if the agent is listed as Jane Brown, CMS sorts on the J for Jane. If the agent is listed as Brown, Jane CMS sorts on the B in Brown. Supervisor reports do not automatically sort by agent name, but the user can request the report to do so.
- You can assign no more than one agent name to the same login ID.
- You cannot assign the same agent name to multiple login IDs.
- You can use only numbers in login IDs.
- If you are viewing a real-time report when a change is made to a login ID that appears on that report, you must exit the report and rerun it to see the change.

---

**Adding a name to a login ID**

To add a name to a login ID in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

   ![Dictionary Window]

2. In the **Operations** list, highlight **Login Identifications**.

3. In the **ACD** field, enter the ACD or ACD Group on which you want to assign a name to a login ID.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Login Identifications** window.

   ![Dictionary Login Identifications Window]

5. In the **Login ID** field, enter the number of the login ID on which you want to assign a new name.
Using the Dictionary to name contact center entities

6. In the Agent Name: field, enter the name of the agent to be associated with the Login ID number.
7. From the Actions menu, select Add.

Viewing a login ID name

To view the information associated with an existing login ID name in the Dictionary:

1. From the Controller Window, select Commands > Dictionary.
   Supervisor displays the Dictionary window.

2. In the Operations: list, highlight Login Identifications.
3. In the ACD: field, enter the ACD or ACD Group on which you want to view a login ID name.
4. Select OK.
   Supervisor displays the Dictionary Login Identifications window.

5. To find a login ID to view, only one of the fields requires a value to be specified.
   Perform one of the following actions to specify a login ID in the Dictionary:
   ● In the Login ID: field, enter the number of the login ID.
In the Agent Name: field, enter the name of the agent.

6. From the Actions menu, select Find One.

Supervisor retrieves and displays the information for the specified login ID, if valid.

---

**Listing all login ID names**

To list all login ID names defined in the Dictionary:

1. From the Controller Window, select Commands > Dictionary.

Supervisor displays the Dictionary window.

2. In the Operations: list, highlight Login Identifications.

3. In the ACD: field, enter the ACD or ACD Group on which you want to list all login ID names.

4. Select OK.

Supervisor displays the Dictionary Login Identifications window.

5. From the Actions menu, select List All.
Modifying a login ID name

To modify an existing login ID name in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **Login Identifications**.

3. In the **ACD**: field, enter the ACD or ACD Group on which you want to modify a login ID name.

4. Select **OK**.
   
   *Supervisor* displays the **Dictionary Login Identifications** window.

5. To find a login ID to modify, only one of the fields requires a value to be specified. Perform one of the following actions to specify a login ID in the Dictionary:
   
   - In the **Login ID**: field, enter the number of the login ID.
   - In the **Agent Name**: field, enter the name of the agent.

6. From the **Actions** menu, select **Find One**.
   
   *Supervisor* retrieves and displays the information associated with the specified login ID name, if valid.

7. In the **Agent Name**: field, enter the modified name of the agent.
8. From the **Actions** menu, select **Modify**.
   The specified login ID name and its changes are saved in the Dictionary.

---

**Deleting a login ID name**

To delete an existing login ID name from the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   *Supervisor* displays the **Dictionary** window.

   ![Dictionary Window](image)

2. In the **Operations:** list, highlight **Login Identifications**.

3. In the **ACD:** field, enter the ACD or ACD Group on which the login ID name to delete resides.

4. Select **OK**.
   *Supervisor* displays the **Dictionary Login Identifications** window.

   ![Dictionary Login Identifications](image)

5. To find a login ID to delete, only one of the fields requires a value to be specified.
   Perform one of the following actions to specify a login ID in the Dictionary:
   - In the **Login ID:** field, enter the number of the login ID.
   - In the **Agent Name:** field, enter the name of the agent.
Using the Dictionary to name contact center entities

6. From the **Actions** menu, select **Find One**.
   
   *Supervisor* retrieves and displays the information for the specified login ID name, if valid.

7. From the **Actions** menu, select **Delete**.
Logout reason code names

Logout reason codes enable an agent to give the reason for logging out, such as attending training or the end of a shift. You can add, delete, modify, and view logout reason codes from the Logout Reason Codes window. The names that are assigned to the logout reason codes appear in the standard agent login/logout and agent trace historical reports.

This section contains the following topics:

● Permissions on page 139
● Before you begin on page 139
● Adding a logout reason code name on page 140
● Viewing a logout reason code name on page 141
● Listing all logout reason code names on page 142
● Modifying a logout reason code name on page 143
● Deleting a logout reason code name on page 145

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

● To view logout reason codes, you need read permissions for the Dictionary subsystem.

● To add, delete, or modify logout reason code, you need write permissions for the Dictionary subsystem.

Before you begin

● Logout reason codes are single digits, 0 through 9. A zero is used when the system logs an agent out or if the agent does not specify a code.

● Logout reason code names can be up to 20 characters long.

● To use logout reason codes, your switch must have the Expert Agent Selection (EAS) feature.
Adding a logout reason code name

To add a logout reason code name in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary.**
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Logout Reason Codes.**

3. In the **ACD:** field, enter the ACD or ACD Group on which you want to add a logout reason code.

4. Select **OK.**
   
   *Supervisor* displays the **Dictionary Logout Reason Codes** window.

5. In the **Logout Reason Code name:** field, enter the name of the new logout reason code.

6. In the **Logout Reason Code:** field, enter a number from 0 to 9 to be associated with the logout reason code name.

   Any additional information about the logout reason code can be entered in the **Description:** field. Only 50 or fewer characters can be entered in this field.

7. From the **Actions** menu, select **Add.**
Viewing a logout reason code name

To view an existing logout reason code name in the Dictionary:

1. From the Controller Window, select Commands > Dictionary.
   *Supervisor* displays the Dictionary window.

2. In the Operations: list, highlight Logout Reason Codes.

3. In the ACD: field, enter the ACD or ACD Group on which you want to view a logout reason code name.

4. Select OK.
   *Supervisor* displays the Dictionary Logout Reason Codes window.

5. To find a logout reason code to view, only one of the fields requires a value to be specified. Perform one of the following actions to specify a logout reason code in the Dictionary:
   - In the Logout Reason Code name: field, enter the name of the logout reason code.
   - In the Logout Reason Code: field, enter a number from 0 to 9 that is associated with the logout reason code.
Using the Dictionary to name contact center entities

6. From the **Actions** menu, select **Find One**.

*Supervisor* retrieves and displays the information for the specified logout reason code name, if valid.

---

**Listing all logout reason code names**

To list all existing logout reason code names in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Logout Reason Codes**.

3. In the **ACD:** field, enter the ACD or ACD Group on which you want to view all logout reason code names.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Logout Reason Codes** window.
5. From the **Actions** menu, select **List All**. 

*Supervisor* displays the **Dictionary Logout Reason Codes - List All** window.

![Dictionary Logout Reason Codes - List All](image1)

---

**Modifying a logout reason code name**

To modify an existing logout reason code name in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**. 

*Supervisor* displays the **Dictionary** window.

![Dictionary window](image2)

2. In the **Operations**: list, highlight **Logout Reason Codes**.

3. In the **ACD**: field, enter the ACD or ACD Group on which you want to modify a logout reason code name.
Using the Dictionary to name contact center entities

4. Select **OK**.

   *Supervisor* displays the **Dictionary Logout Reason Codes** window.

![Dictionary Logout Reason Codes Window]

5. To find a logout reason code to modify, only one of the fields requires a value to be specified. Perform one of the following actions to specify a logout reason code in the Dictionary:
   
   - In the **Logout Reason Code name** field, enter the name of the logout reason code.
   - In the **Logout Reason Code** field, enter the number from 0 to 9 that is associated with the logout reason code.

6. From the **Actions** menu, select **Find One**.

   *Supervisor* retrieves and displays the information for the specified logout reason code name, if valid.

7. In the **Logout Reason Code name** field, enter the new name for the logout reason code.

8. From the **Actions** menu, select **Modify**.

   The specified logout reason code name and its changes are saved to the Dictionary.
Deleting a logout reason code name

To delete an existing logout reason code name from the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   *Supervisor* displays the **Dictionary** window.

   ![Dictionary Window](image)

   2. In the **Operations:** list, highlight **Logout Reason Codes**.

   3. In the **ACD:** field, enter the ACD or ACD Group on which the logout reason code name to delete resides.

   4. Select **OK**.
      *Supervisor* displays the **Dictionary Logout Reason Codes** window.

   ![Dictionary Logout Reason Codes Window](image)

   5. To find a logout reason code to delete, only one of the fields requires a value to be specified. Perform one of the following actions to specify a logout reason code in the Dictionary:
      - In the **Logout Reason Code name:** field, enter the name of the logout reason code.
      - In the **Logout Reason Code:** field, enter the number from 0 to 9 that is associated with the logout reason code.
Using the Dictionary to name contact center entities

6. From the **Actions** menu, select **Find One**.
   *Supervisor* retrieves and displays the information for the specified logout reason code name, if valid.

7. From the **Actions** menu, select **Delete**.
   The specified logout reason code name is removed from the Dictionary.
Split/skill string values

Split/skill string values are the descriptive words used in the split/skill call profile reports in place of the split/skill numeric values. From the Split/Skill String Values window, you can change the default string values to correspond with your own requirements.

This section contains the following topics:

- Permissions on page 147
- Before you begin on page 147
- Viewing split/skill string values on page 148
- Modifying split/skill string values on page 149
- Split/skill string value field descriptions on page 150

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view split/skill string values, you need read permissions for the Dictionary subsystem.
- To modify split/skill string values, you need write permissions for the Dictionary subsystem.

Before you begin

- If you assign values that are longer than the field lengths allowed on standard reports, those values are truncated to fit on the reports. Similar custom reports can be created to accommodate the longer string values.
- If you do not assign different values to the split/skill string values, the default values are used.
Using the Dictionary to name contact center entities

Viewing split/skill string values

To view the string value for splits or skills in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Split/Skill String Values**.

3. In the **ACD**: field, enter the ACD or ACD Group on which you want to view the split/skill string values.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Split/Skill String Values** window.
Modifying split/skill string values

To modify the existing string values for splits or skills in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **Split/Skill String Values**.

3. In the **ACD** field, enter the ACD or ACD Group on which you want to modify the split/skill string values.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Split/Skill String Values** window.

5. Enter a new split/skill string value in each field that you want to modify.

   See [Split/skill string value field descriptions](#) on page 150 for more information.

6. From the **Actions** menu, select **Modify**.

   The split/skill string values and their changes are saved to the Dictionary.
### Split/skill string value field descriptions

The following table describes the fields in the **Dictionary Split/Skill String Values** window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| Service Level Changed  | The service level is the time limit in seconds for calls to wait in queue before being answered. The Split/Skill Call Profile reports can be used to see how many calls were either answered or abandoned within each service level increment. The string values in the following fields are displayed on the Split/Skill Call Profile Report:  
  - **YES** - The string value in this field will appear on the Split/Skill Call Profile Report if the service level in the split/skill call profile has changed.  
  - **NO** - The string value in this field will appear on the Split/Skill Call Profile Report if the service level in the split/skill call profile has not changed. |

---

**Note:**

Using the Dictionary to name contact center entities
### Period Changed

There are ten time increments of administrable length in the real-time and historical Split/Skill Call Profile Reports.

The string values in the following fields are displayed on the Split/Skill Call Profile Report:

- **YES** - The string value in this field will appear on the Split/Skill Call Profile if the time period in the split/skill call profile has changed.
- **NO** - The string value in this field will appear on the Split/Skill Call Profile if the time period in the split/skill call profile has not changed.

### Skill State

Skill states are used to specify states for the different skills.

The string values in the following fields represent the following skill states:

- **UNKNOWN** - Leave the default value. The default value is UNKN.
- **NORMAL** - Enter the descriptive word for the state of a skill using the Service Level Supervisor feature when it is below all overload thresholds. The default value is NORMAL.
- **OVERLOAD1** - Enter the descriptive word for the state of a skill using the Service Level Supervisor feature when it exceeds the first overload threshold. The default value is OVRLD1.
- **OVERLOAD2** - Enter the descriptive word for the state of a skill using the Service Level Supervisor feature when it exceeds both the first and second thresholds. The default value is OVRLD2.
- **BEHIND** - This string indicates that a split or skill is either close to or failing to meet the administered target service level and agents are not being auto-reserved to compensate for this situation. The default value for this string is BEHIND.
- **AUTORSV** - This string indicates that a split or skill is either close to or failing to meet the administered target service level and agents are currently being auto-reserved to achieve the necessary level. The default value for this string is AUTORSV.
Split/Skill names

You can assign names to your ACD splits or skills. These split/skill names appear on the split/skill reports, making your reports easier to identify and read.

Split/skill names should reflect the configuration of your splits/skills and ACDs.

For example, if you want splits in your system to be divided according to Sales, Customer Service, and Wholesale, assign those names to the splits that handle those areas of the business. If you want skills in your system to be divided by language such as French, Spanish, and German, assign those names to the skills that handle calls in those languages.

This section contains the following topics:

- Permissions on page 152
- Before you begin on page 152
- Adding a split/skill name on page 153
- Viewing a split/skill name on page 154
- Listing all the split/skill names on page 155
- Modifying a split/skill name on page 156
- Deleting a split/skill name on page 157

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view the name assigned to a split/skill, you need read permissions for the Dictionary subsystem and for the split/skill.
- To add, delete or modify the name assigned to a split/skill, you need write permissions for the Dictionary subsystem and for the split/skill.

Before you begin

The following items should be read and understood before working with split/skill names in the Dictionary:

- It is advised that you be consistent with the names given by your switch administrator.
- If you assign a name, the split/skill number no longer appears in split/skill reports or windows. The split/skill name appears instead.
Split/Skill names

- If you make changes to split/skill names when viewing a report that includes those splits/skills, you must exit the report and rerun it to see the changes.

---

Adding a split/skill name

To add a name for a split or skill in the Dictionary:

1. From the Controller Window, select Commands > Dictionary.
   
   Supervisor displays the Dictionary window.

2. In the Operations: list, highlight Splits/Skills.

3. In the ACD: field, enter the ACD or ACD Group on which you want to name a split/skill.

4. Select OK.
   
   Supervisor displays the Dictionary Splits/Skills window.

5. In the Split/Skill name: field, enter the name of the split/skill.

6. In the Split/Skill number: field, enter the number of the split/skill.

   Any additional information about the split/skill can be entered in the Description: field.
   Only 50 or fewer characters can be entered in this field.
7. From the **Actions** menu, select **Add**.

---

**Viewing a split/skill name**

To view an existing name for a split or skill in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**. Supervisor displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Splits/Skills**.

3. In the **ACD**: field, enter the ACD or ACD Group on which you want to view a split/skill.

4. Select **OK**.

   Supervisor displays the **Dictionary Splits/Skills** window.

5. To find a split/skill to view, only one of the fields requires a split/skill to be specified. Perform one of the following actions to specify an existing split/skill in the Dictionary:
   - In the **Split/Skill name**: field, enter the name of the split/skill.
   - In the **Split/Skill number**: field, enter the number of the split/skill.
6. From the **Actions** menu, select **Find One**.

*Supervisor* retrieves and displays the information for the specified split/skill name, if valid.

---

**Listing all the split/skill names**

To list the names for all splits or skills in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

*Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Splits/Skills**.

3. In the **ACD**: field, enter the ACD or ACD Group on which you want to view all split/skill names.

4. Select **OK**.

*Supervisor* displays the **Dictionary Splits/Skills** window.

5. From the **Actions** menu, select **List All**.
Using the Dictionary to name contact center entities

---

Modifying a split/skill name

To modify an existing name for a split or skill in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Splits/Skills**.

3. In the **ACD**: field, enter the ACD or ACD Group on which you want to modify the split/skill name.

4. Select **OK**.
   *Supervisor* displays the **Dictionary Splits/Skills** window.

5. To find a split/skill to modify, only one of the fields requires a split/skill to be specified. Perform one of the following actions to specify an existing split/skill in the Dictionary:
   - In the **Split/Skill name:** field, enter the name of the split/skill.
   - In the **Split/Skill number:** field, enter the number of the split/skill.

6. From the **Actions** menu, select **Find One**.
   *Supervisor* retrieves and displays the information for the specified split/skill name, if valid.
7. In the **Split/Skill name**: field, enter the new name of the split/skill.

8. From the **Actions** menu, select **Modify**.

   The split/skill name and its changes are saved to the Dictionary.

### Deleting a split/skill name

To delete the name for a split or skill in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Splits/Skills**.

3. In the **ACD**: field, enter the ACD or ACD Group on which the split/skill name to delete resides.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Splits/Skills** window.

5. To find a split/skill to delete, only one of the fields requires a split/skill to be specified. Perform one of the following actions to specify an existing split/skill in the Dictionary:

   - In the **Split/Skill name**: field, enter the name of the split/skill.
Using the Dictionary to name contact center entities

- In the **Split/Skill number**: field, enter the number of the split/skill.

6. From the **Actions** menu, select **Find One**.
   Supervisor retrieves and displays the information for the specified split/skill name, if valid.

7. From the **Actions** menu, select **Delete**.
   The split/skill name is removed from the Dictionary.
Standard database items

Standard database items store ACD data and are used by CMS in its default reports.

You cannot change or delete standard database items because this is a read-only section of the Dictionary. You can view the standard information about each database item, the description for that item, and the tables in which the item appears.

The following example shows a current real-time agent table with standard CMS database item column headings:

<table>
<thead>
<tr>
<th>Extension</th>
<th>Split</th>
<th>Logid</th>
<th>Logon start</th>
<th>Work mode</th>
<th>Started</th>
<th>Direction</th>
<th>Changed</th>
<th>&gt;*</th>
</tr>
</thead>
<tbody>
<tr>
<td>1000</td>
<td>1</td>
<td>4000</td>
<td>8:00</td>
<td>AVAIL</td>
<td>8:00</td>
<td>NULL</td>
<td>8:00</td>
<td>&gt;</td>
</tr>
<tr>
<td>1001</td>
<td>1</td>
<td>5966</td>
<td>7:58</td>
<td>ACD</td>
<td>8:04</td>
<td>IN</td>
<td>8:04</td>
<td>&gt;</td>
</tr>
<tr>
<td>1002</td>
<td>1</td>
<td>2200</td>
<td>7:59</td>
<td>ACD</td>
<td>8:03</td>
<td>IN</td>
<td>8:03</td>
<td>&gt;</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>&gt;</td>
</tr>
</tbody>
</table>

Note:
>

Note:

>`* indicates that more database item column headings follow. A dot (.) indicates that more data follows down the table.

This section contains the following topics:

- Permissions on page 159
- Viewing a standard database item on page 160
- Viewing all standard database items alphabetically on page 161

Permissions

To view the standard database items, you need read permissions for the Dictionary subsystem.
Viewing a standard database item

To view a standard database item in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Standard CMS Items**.

3. Select **OK**.

   *Supervisor* displays the **Dictionary Standard CMS Items** window.

4. In the **Database item:** field, enter the name of the database item entirely in uppercase letters.

   **Important:**
   
   If you do not know the entire database item name, enter part of the database item name along with an asterisk (*) to find the item. You can use pattern searching in any field in the window.

   You can also enter information in the **Table:** field to limit the search of a database item to a single table.
5. From the Actions menu, select Find One.

Supervisor retrieves and displays the information for the specified standard database item, if valid.

Note:

If you used pattern matching in your search for a standard database item, it is possible that more than one match was found. To view the next database item that matches the search parameter, select Next from the Actions menu. Continue to select Next until the appropriate database item is found.

Viewing all standard database items alphabetically

To view all standard database items in the Dictionary:

1. From the Controller Window, select Commands > Dictionary.

Supervisor displays the Dictionary window.

2. In the Operations: list, highlight Standard CMS Items.

3. Select OK.

Supervisor displays the Dictionary Standard CMS Items window.

4. From the Actions menu, select List All.
Trunk group names

The Trunk Groups window is used to assign names to ACD trunk groups. The trunk groups names appear in reports making the reports easier to understand.

This section contains the following topics:
- Permissions on page 162
- Before you begin on page 162
- Adding a trunk group name on page 163
- Viewing a trunk group name on page 164
- Listing all trunk group names on page 165
- Modifying a trunk group name on page 166
- Deleting a trunk group name on page 167

Permissions

Depending on the procedure that you want to perform, you need the following permissions:
- To view the name that is assigned to a trunk group, you need read permissions for the Dictionary subsystem and for the trunk group.
- To add, delete, or modify the name assigned to a trunk group, you need write permissions for the Dictionary subsystem and for the trunk group.

Before you begin

The following items should be read and understood before working with trunk groups names in the Dictionary:
- When naming trunk groups, you may want to be consistent with the names given to trunk groups and splits/skills by your switch administrator.
- If you assign a trunk group name, the name is displayed on trunk group reports or windows instead of the trunk group number.
- If you make changes to trunk group names while viewing a report that includes those trunk groups, you must exit the report and rerun it to see the changes.
Adding a trunk group name

To add a trunk group name to the Dictionary:

1. From the Controller Window, select **Commands > Dictionary.**
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Trunk Groups.**

3. In the **ACD:** field, enter the ACD on which you want to name a trunk group.

4. Select **OK.**
   
   *Supervisor* displays the **Dictionary Trunk Groups** window.

5. In the **Trunk group name:** field, enter the name of the trunk group.

6. In the **Trunk group number:** field, enter the number of the trunk group.
   
   Any additional information about the trunk group can be entered in the **Description:** field. Only 50 or fewer characters can be entered in this field.

7. From the **Actions** menu, select **Add.**
Using the Dictionary to name contact center entities

Viewing a trunk group name

To view an existing trunk group name in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**. Supervisor displays the **Dictionary** window.

2. In the **Operations**: list, highlight **Trunk Groups**.

3. In the **ACD**: field, enter the ACD on which you want to view a trunk group name.

4. Select **OK**.

Supervisor displays the **Dictionary Trunk Groups** window.

5. To find a trunk group to view, only one of the fields requires a trunk group to be specified. Perform one of the following actions to specify an existing trunk group in the Dictionary:
   - In the **Trunk group name**: field, enter the name of the trunk group.
   - In the **Trunk group number**: field, enter the number of the trunk group.

6. From the **Actions** menu, select **Find One**.

Supervisor retrieves and displays the information for the specified trunk group, if valid.
Listing all trunk group names

To list all trunk group names in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **Trunk Groups**.

3. In the **ACD** field, enter the ACD on which you want to list all trunk group names.

4. Select **OK**.
   
   *Supervisor* displays the **Dictionary Trunk Groups** window.

5. From the **Actions** menu, select **List All**.
Modifying a trunk group name

To change the name or description of a trunk group in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

   ![Dictionary window](image)

2. In the **Operations** list, highlight **Trunk Groups**.

3. In the **ACD** field, enter the ACD on which you want to modify a trunk group name.

4. Select **OK**.

   *Supervisor* displays the **Dictionary Trunk Groups** window.

   ![Dictionary Trunk Groups window](image)

5. To find a trunk group to modify, only one of the fields requires a trunk group to be specified. Perform one of the following actions to specify an existing trunk group in the Dictionary:
   - In the **Trunk group name** field, enter the name of the trunk group.
   - In the **Trunk group number** field, enter the number of the trunk group.

6. From the **Actions** menu, select **Find One**.

   *Supervisor* retrieves and displays the information for the specified trunk group, if valid.
7. In the **Trunk group name:** or **Description** field, make the necessary changes for the trunk group.

8. From the **Actions** menu, select **Modify**.

---

**Deleting a trunk group name**

To remove a name for a trunk group from the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.
   
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Trunk Groups**.

3. In the **ACD:** field, enter the ACD on which the trunk group to delete resides.

4. Select **OK**.
   
   *Supervisor* displays the **Dictionary Trunk Groups** window.

5. To find a trunk group to delete, only one of the fields requires a trunk group to be specified. Perform one of the following actions to specify an existing trunk group in the Dictionary:
   
   - In the **Trunk group name:** field, enter the name of the trunk group.
Using the Dictionary to name contact center entities

- In the **Trunk group number**: field, enter the number of the trunk group.

6. From the **Actions** menu, select **Delete**.

The selected trunk group name is removed from the Dictionary.
Trunk string values

Trunk string values are the descriptive words such as IDLE, HOLD, or QUEUED on trunk reports. These words are displayed in the data fields of the report. They are not displayed as headings. From the Trunk String Values window, the default values can be changed to any values that meet the needs of your contact center. If you do not assign different trunk string values, the default values are used. Any changes that you make to the trunk string values affect what you see in the corresponding fields on trunk reports.

This section contains the following topics:

- Permissions on page 169
- Viewing and modifying trunk string values on page 170
- Trunk string values field descriptions on page 171

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view the trunk string values, you need read permissions for the Dictionary subsystem.
- To modify a trunk string value, you need write permissions for the Dictionary subsystem.
Using the Dictionary to name contact center entities

Viewing and modifying trunk string values

To view and modify trunk string values in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations:** list, highlight **Trunk String Values**.

3. Select **OK**.

   *Supervisor* displays the **Dictionary Trunk String Values** window.
4. To change any of the default names, enter the new descriptive word in the text box that is next to the name that you want to change.

See Trunk string values field descriptions on page 171 for more information on the fields in the Dictionary Trunk String Values window.

5. From the Actions menu, select Modify when the necessary changes have been completed.

Trunk string values field descriptions

The following table describes the trunk string value fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Trunk State**        | To change any of the trunk state default names, enter the new descriptive word next to any of the following:  
  ● IDLE - The trunk is waiting for a call.  
  ● SEIZED - A call is holding the trunk, either incoming or outgoing.  
  ● QUEUED - An ACD call has seized the trunk, is queued to a split/skill, and is waiting for an agent to become available.  
  ● CONN - The caller and an agent are connected on a call.  
  ● DABN - The caller has abandoned the call.  
  ● FBUSY - The caller receives a forced busy signal.  
  ● FDISC - The caller receives a forced disconnect.  
  ● HOLD - The agent has put the caller on hold.  
  ● MBUSY - The trunk is out of service for maintenance purposes.  
  ● RINGING - The call is ringing at an agent's voice terminal.  
  ● UNKNOWN - CMS does not recognize the trunk state. |
| **Queue Type**         | To change the queue type default names, enter the new descriptive name next to MAIN or BACKUP. The name entered here is displayed instead of the default value in real-time reports containing the trunk QUETYPE database item. (Standard reports do not contain this item).  
  ● MAIN - The call is queued to a split/skill as a result of a queue to main split/skill vector command.  
  ● BACKUP - The call is queued to a split/skill as a result of a vector command other than queue to main split/skill. |
| **Call Priority**      | To change the call priority (non-vectoring) default names, enter the new descriptive name next to YES or NO. The name entered here is displayed instead of the default name in real-time reports containing the trunk PRIORITY database item. (Standard reports do not contain this item.)  
  ● YES - The call occupying the trunk has priority entering the trunk.  
  ● NO - The call occupying the trunk does not have priority entering the split. |
Using the Dictionary to name contact center entities

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Call Priority (Vectoring)</td>
<td>To change the call priority (vectoring) default names, enter the new descriptive name next to <strong>LOW, MED, HIGH,</strong> or <strong>TOP.</strong> The priority level at which calls on a trunk queue to a split/skill is specified using either the <code>queue to split/skill</code> or <code>check split/skill</code> command in the vector that is processing the call. The name entered here is displayed instead of the default name in real-time reports containing the trunk <strong>PRIORITY</strong> database item. (Standard reports do not contain this item).</td>
</tr>
<tr>
<td></td>
<td>• <strong>LOW</strong> - The call occupying the trunk is queued to a split or skill at the lowest priority level.</td>
</tr>
<tr>
<td></td>
<td>• <strong>MED</strong> - The call occupying the trunk is queued to a split or skill at the second lowest priority level.</td>
</tr>
<tr>
<td></td>
<td>• <strong>HIGH</strong> - The call occupying the trunk is queued to a split or skill at the second highest priority level.</td>
</tr>
<tr>
<td></td>
<td>• <strong>TOP</strong> - The call occupying the trunk is queued to a split or skill at the highest priority level.</td>
</tr>
<tr>
<td>Call Direction</td>
<td>To change the call-direction default names, enter the new descriptive word next to <strong>IN</strong> or <strong>OUT.</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>IN</strong> - The trunk is on an incoming call.</td>
</tr>
<tr>
<td></td>
<td>• <strong>OUT</strong> - The trunk is on an outbound call.</td>
</tr>
<tr>
<td>All Trunks Busy</td>
<td>To change the all trunks busy default names, enter the new descriptive word next to <strong>YES</strong> or <strong>NO.</strong></td>
</tr>
<tr>
<td></td>
<td>• <strong>YES</strong> - All trunks in the trunk group are busy (in use or maintenance).</td>
</tr>
<tr>
<td></td>
<td>• <strong>NO</strong> - Not all trunks in the trunk group are busy.</td>
</tr>
</tbody>
</table>
VDN names

From the VDNs window, you can assign names to VDNs so that names instead of numbers appear on VDN reports and VDN administration windows. VDN names should reflect the configuration of your ACD and convey one or more of the following:

- The VDN's purpose; for example, sales or customer service.
- The VDN destination vector; for example, FBusy-Nat.Accts.
- The trunk groups assigned to the VDN; for example, WATS 800-331-1111.

This section contains the following procedures:

- Permissions on page 173
- Before you begin on page 173
- Adding a VDN name on page 174
- Viewing a VDN name on page 175
- Listing all VDN names on page 176
- Modifying a VDN name on page 177
- Deleting a VDN name on page 178

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view the name that is assigned to a VDN, you need read permissions for the Dictionary subsystem and for the VDN.
- To add, delete, or modify the name that is assigned to a VDN, you need write permissions for the Dictionary subsystem and for the VDN.

Before you begin

The following items should be read and understood before working with VDN names in the Dictionary:

- The VDNs window is available only if the Call Vectoring feature is installed and activated on your switch.
- VDNs must be created on the switch and assigned for measurement via CMS.
Using the Dictionary to name contact center entities

- To get a list of VDNs that can be named, run the vector configuration report. While all VDNs can be named, it is recommended that only those VDNs that are used are then named instead of all of the VDNs. This will conserve system resources.
- If you make changes to the VDN names when a report that includes those VDNs is running, you must exit the report and rerun it to see the changes.
- When naming VDNs, you may want to be consistent with the names given to VDNs by your switch administrator.
- If a name is assigned to a VDN, it will appear on VDN reports and windows instead of the VDN number.

---

**Adding a VDN name**

To add a name for a VDN in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**. 
   *Supervisor* displays the **Dictionary** window.

2. In the **Operations** list, highlight **VDNs**.

3. In the **ACD** field, enter the ACD on which you want to name a VDN.
4. Select OK.

    *Supervisor* displays the **Dictionary VDNs** window.

![Dictionary VDNs window](image)

5. In the **VDN name**: field, enter the name of the VDN.

6. In the **VDN**: field, enter the number of the VDN.

    Any additional information about the VDN, can be entered in the **Description**: field. Only 50 or fewer characters can be entered in this field.

7. From the **Actions** menu, select **Add**.

---

**Viewing a VDN name**

To view an existing VDN name in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

    *Supervisor* displays the **Dictionary** window.

![Dictionary window](image)

2. In the **Operations**: list, highlight **VDNs**.

3. In the **ACD**: field, enter the ACD on which you want to view a VDN.
Using the Dictionary to name contact center entities

4. Select **OK**.

*Supervisor* displays the **Dictionary VDNs** window.

5. To find a VDN name to view, only one of the fields requires a VDN to be specified. Perform one of the following actions to specify an existing VDN in the Dictionary:

   - In the **VDN name**: field, enter the name of the VDN.
   - In the **VDN**: field, enter the number of the VDN.

6. From the **Actions** menu, select **Find One**.

*Supervisor* retrieves and displays the information for the specified VDN name, if valid.

---

**Listing all VDN names**

To list all defined VDN names in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **VDNs**.

3. In the **ACD**: field, enter the ACD on which you want to view all the VDNs.
4. Select **OK**.

   *Supervisor* displays the **Dictionary VDNs** window.

5. From the **Actions** menu, select **List All**.

---

### Modifying a VDN name

To modify the name or description of an existing VDN in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

2. In the **Operations**: list, highlight **VDNs**.

3. In the **ACD**: field, enter the ACD on which you want to modify the name of a VDN.
Using the Dictionary to name contact center entities

4. Select **OK**.

*Supervisor* displays the **Dictionary VDNs** window.

5. To find a VDN name to modify, only one of the fields requires a VDN to be specified. Perform one of the following actions to specify an existing VDN in the Dictionary:
   - In the **VDN name**: field, enter the name of the VDN.
   - In the **VDN**: field, enter the number of the VDN.

6. From the **Actions** menu, select **Find One**.

*Supervisor* retrieves and displays the information for the specified VDN name, if valid.

7. In the **VDN name**: or **Description**: field, make the necessary changes.

8. From the **Actions** menu, select **Modify**.

---

**Deleting a VDN name**

To delete the name of a VDN from the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

*Supervisor* displays the **Dictionary** window.
2. In the **Operations**: list, highlight **VDNs**.

3. In the **ACD**: field, enter the ACD on which the VDN to delete resides.

4. Select **OK**.

   *Supervisor* displays the **Dictionary VDNs** window.

5. To find a VDN name to delete, only one of the fields requires a VDN to be specified. Perform one of the following actions to specify an existing VDN in the Dictionary:

   - In the **VDN name**: field, enter the name of the VDN.
   - In the **VDN**: field, enter the number of the VDN.

6. From the **Actions** menu, select **Find One**.

   *Supervisor* retrieves and displays the information for the specified VDN, if valid.

7. From the **Actions** menu, select **Delete**.

   The name and description for this VDN is removed from the Dictionary.
Vector names

From the Vectors window, you can assign names to vectors so that the names instead of the vector numbers are displayed on vector reports and administration windows. Vector names should reflect the configuration of your ACD and convey one or more of the following:

- The vector's purpose; for example, sales or customer service.
- The VDNs assigned to the vector; for example, vdn2001, vdn3001, and vdn4001.
- The splits or skills to which the vector sends calls; for example, sales1, sales2, AUDIX system.

This section contains the following topics:

- Permissions on page 180
- Before you begin on page 180
- Adding a vector name on page 181
- Viewing a vector name on page 182
- Listing all vector names on page 183
- Modifying a vector name on page 184
- Deleting a vector name on page 185

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view the name that is assigned to a vector, you need read permissions for the Dictionary subsystem and for the vector.
- To add, delete, or modify the name that is assigned to a vector, you need write permissions for the Dictionary subsystem and for the vector.

Before you begin

The following items should be read and understood before working with vector names in the Dictionary:

- The Vectors window is available only if the Call Vectoring feature is installed and activated on the switch.
- You can assign a name to a vector even if the steps to the vector have not been assigned.
- The number of available vectors depends on the switch type.
- If a name is assigned to a vector, it appears on reports and windows instead of the vector number.
- If you make changes to vector names when a report that includes those vectors is running, you must exit the report and rerun it to see the changes.

---

**Adding a vector name**

To add a name for a vector in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.  
   _Supervisor_ displays the **Dictionary** window.

   ![Dictionary Window](image)

2. In the **Operations:** list, highlight **Vectors**.
3. In the **ACD:** field, enter the ACD on which you want to name a vector.
Using the Dictionary to name contact center entities

4. Select OK.

  Supervisor displays the Dictionary Vectors window.

5. In the Vector name: field, enter the name of the vector.

6. In the Vector number: field, enter the number of the vector.

  Any additional information about the vector, can be entered in the Description: field.
  Only 50 or fewer characters can be entered in this field.

7. From the Actions menu, select Add.

---

Viewing a vector name

To view an existing name for a vector in the Dictionary:

1. From the Controller Window, select Commands > Dictionary.

  Supervisor displays the Dictionary window.

2. In the Operations: list, highlight Vectors.

3. In the ACD: field, enter the ACD on which you want to view a vector name.
4. Select **OK**.

*Supervisor* displays the **Dictionary Vectors** window.

![Dictionary Vectors window](image)

5. To find a vector name to view, only one of the fields requires a vector to be specified. Perform one of the following actions to specify an existing vector in the Dictionary:

- In the **Vector name**: field, enter the name of the vector.
- In the **Vector number**: field, enter the number of the vector.

6. From the **Actions** menu, select **Find One**.

*Supervisor* retrieves and displays the information for the specified vector, if valid.

---

### Listing all vector names

To list all vector names defined in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

*Supervisor* displays the **Dictionary** window.

![Dictionary window](image)

2. In the **Operations**: list, highlight **Vectors**.

3. In the **ACD**: field, enter the ACD on which you want to list all vector names.
Using the Dictionary to name contact center entities

4. Select OK.

   Supervisor displays the Dictionary Vectors window.

5. From the Actions menu, select List All.

---

Modifying a vector name

To change the current name or description of a vector in the Dictionary:

1. From the Controller Window, select Commands > Dictionary.

   Supervisor displays the Dictionary window.

2. In the Operations: list, highlight Vectors.

3. In the ACD: field, enter the ACD on which you want to modify a vector name.
4. Select **OK**.

   *Supervisor* displays the **Dictionary Vectors** window.

   ![Dictionary Vectors window](image)

5. To find a vector name to modify, only one of the fields requires a vector to be specified. Perform one of the following actions to specify an existing vector in the Dictionary:
   - In the **Vector name**: field, enter the name of the vector.
   - In the **Vector number**: field, enter the number of the vector.

6. From the **Actions** menu, select **Find One**.

   *Supervisor* retrieves and displays the information for the specified vector, if valid.

7. In the **Vector name**: or **Description**: field, make the necessary changes.

8. From the **Actions** menu, select **Modify**.

---

**Deleting a vector name**

To remove the name for a vector in the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   *Supervisor* displays the **Dictionary** window.

   ![Dictionary window](image)
Using the Dictionary to name contact center entities

2. In the Operations: list, highlight Vectors.
3. In the ACD: field, enter the ACD on which the vector name to delete resides.
4. Select OK.

Supervisor displays the Dictionary Vectors window.

5. To find a vector name to delete, only one of the fields requires a vector to be specified.
   Perform one of the following actions to specify an existing vector in the Dictionary:
   - In the Vector name: field, enter the name of the vector.
   - In the Vector number: field, enter the number of the vector.
6. From the Actions menu, select Find One.

Supervisor retrieves and displays the information for the specified vector, if valid.
7. From the Actions menu, select Delete.

The name for this VDN is removed from the Dictionary.
Dictionary reports

In the Dictionary window, use the Reports tab to generate reports on most sections of the Dictionary. These reports can be printed, sent to a file, or displayed on the screen.

This section contains the following topics:
- Permissions on page 187
- Printing Dictionary reports on page 187
- Running an agent group members report on page 189

Permissions

To obtain a report, you need read permissions for the Dictionary subsystem.

Printing Dictionary reports

To print Dictionary reports:

1. From the Controller Window, select Commands > Dictionary. 
Supervisor displays the Dictionary window.

![Dictionary window with Reports tab selected]
Using the Dictionary to name contact center entities

2. Select the **Reports** tab.

   *Supervisor* displays the **Reports** window.

3. In the **Reports** list, select the Dictionary item on which you want to generate a report.

4. Select **OK**.

   *Supervisor* displays a report window.

5. Select one of the following options:
   - **View Reports on Screen**
   - **Print Report on**:

     To send the report to a printer other than the default printer in the report window, select **Print Report on**: and then select the printer button on the right side of the report window. Select the new printer from the **Print** window.
6. Select **OK**.

Depending on the option that you selected, the report is either sent to a printer or displayed on the screen.

The following is an example of screen output:

```
Running an agent group members report

As an example, the following procedure describes the steps used to run an agent group members report from the Dictionary:

1. From the Controller Window, select **Commands > Dictionary**.

   **Supervisor** displays the **Dictionary** window.
```
Using the Dictionary to name contact center entities

2. Select the Reports tab.
   
   *Supervisor* displays the Reports window.

3. In the Reports list, select Agent Group Members.
4. Select OK.
   
   *Supervisor* displays the Dictionary Agent Groups window.

5. In the Agent group name: field, enter the name of the agent group, and then press the Enter key.
6. Select one of the following options:
   
   ● View Reports on Screen
   
   ● Print Report on
7. Select OK.
   
   Depending on the option that you selected, the report is either sent to a printer or displayed on the screen.
Chapter 4: Using reports

This section describes Supervisor reports and provides procedures in generating and administrating them. The procedures are general in scope so as to provide usability for all reports run through the Reports subsystem. For more information on specific reports and usage, see the Avaya CMS Supervisor Installation and Getting Started and Avaya CMS Supervisor Reports manuals.

CMS collects data from ACD activity and stores it in one of the CMS databases. The data reflects the activity of your contact center and can be viewed through CMS reports that cover such areas as:

- Splits/Skills
- Trunks
- Trunk Groups
- Agents
- Agent Groups
- VDNs
- Vectors

This section contains the following topics:

- **Background** on page 192
- **Choosing a report** on page 194
- **Generating a report** on page 196
- **Printing a report** on page 197
- **Printing a Historical report** on page 198
- **Changing the print setup** on page 198
- **Restarting a report** on page 199
Background

Reports consist of standard reports, custom reports, and designer reports. Standard reports are shipped as part of the CMS system. Custom reports are created by contact center administrators through the CMS ASCII interface. Designer Reports are created through Supervisor.

See the Avaya CMS Custom Reports and Avaya CMS Supervisor Report Designer User Guide manuals for more information on creating custom and designer reports.

This section includes the following topics:

- Interfaces for reports on page 192
- Types of reports on page 192
- What reports summarize on page 193

Interfaces for reports

The following list displays which interfaces are used in the creation of reports and which ones can be used for viewing these reports:

- Most standard reports can also be viewed through the CMS ASCII interface. The exceptions to this are the Supervisor integrated reports, reports containing charts, and others.
- Custom reports are created through the CMS ASCII interface, but can be viewed through both the CMS ASCII interface and Supervisor.
- Designer reports can only be created and viewed through Supervisor.

Types of reports

The following types of reports can be generated:

- Standard real-time
- Standard historical
- Standard integrated
- Custom (CMS) real-time
- Custom (CMS) historical
- Designer (Supervisor) real-time
Background

- Designer (Supervisor) historical
- Designer (Supervisor) integrated
- Exceptions
- Forecast (available as an add-on feature)

What reports summarize

Use CMS/Supervisor reports to summarize the status of:

- Any measured subset of the ACD, including agents, splits/skills, trunks/trunk groups, VDNs, vectors, call work codes, and call records
- Agent administration
- Contact center administration
- Dictionary
- Exceptions
- Maintenance
Choosing a report

Most reports are found in the Reports subsystem found under the Commands item on the menu bar. This section provides the general procedure for running reports in this subsystem. Reports may be run by selecting the Real-Time, Historical, or Integrated tab from the Select a Report window.

Other reports are available on the Reports tab found on the main window of the following subsystems:

- Dictionary
- Exceptions
- Agent Administration
- Call Center Administration
- Maintenance

The reports for the subsystems listed above are not available in the main Reports interface.

Procedures on running reports through the areas other than the Reports subsystem are covered in their respective chapters. The following procedures provide information on working with reports from the Reports subsystem.

Steps

To run a report from the Reports system.

1. Select Commands > Reports from the Controller Window.

   Supervisor displays the Select a Report window.
Choosing a report

2. Determine the type of report to be run by select the appropriate tab: **Real-Time**, **Historical**, or **Integrated**.

3. From the **Run Report for ACD** field, select the ACD to serve as the data source for the report.

4. Select a category from the **Category** field.

5. Select a report from the **Report** field.

6. Select **OK**.

*Supervisor* displays a report input window similar to the example below. The input fields vary according to the report and its type.

![Agent Group Report](image)

To continue this process, see the following section, [Generating a report](#) on page 196.
Generating a report

Once a report type has been selected by following the previous procedure, information must be entered to define the parameters of the report.

1. To specify an object for the report, such as an agent, vector, VDN, and so forth, perform one of the following actions:
   - Manually enter the name or number of the object for the report.
   - Select the **Browse** button to view available objects.
   - Select the **History** list to select an input used previously.

2. Select **OK** to run the report with the specified object.

The type of report selected is displayed with information related to the object that was specified.
Printing a report

Once a report has been generated, a Real-Time or Integrated report can be printed. To print a Real-time or Integrated report:

1. Select **Reports > Print** from the menu bar of the report window.

   *Windows* displays the **Print** window opens.

   ![Print window]

2. Select the printer and options for this report:

   ● Select the printer destination by selecting a printer in the **Name** drop-down list box.

   ● Select the number of copies of this report to be printed in the **Number of copies** field.

   ● Use the **Properties** button to change options specific to the selected printer. This could include image resolution, orientation, and other options.

3. Select **OK**.

   The report is printed based on the options selected.

   To print a report to a file on the local system, place a check mark in the **Print to file** check box. Set the printer to **Generic/Text Printer**. Failing to select the **Generic/Text Printer** will cause the **Print to file** check box to be ignored and the report is sent to the selected printer.
Printing a Historical report

Once a report has been generated, a Historical report can be printed using two different methods:

1. Follow the steps listed in Generating a report on page 196 and Printing a report on page 197.

2. When specifying an object, such as an agent, vector, VDN, and so forth, for a report, the Destination group of controls can be seen on the lower half of the dialog box. This allows the report to be viewed on the screen or sent to the printer specified. Selecting the printer button in this area will allows specification of a different printer as well as setting all printer and print job options. This button is not available on Real-time and Integrated reports.

Changing the print setup

Once a report has been printed to the screen, the settings for margins, page numbering, and table borders can be altered. To change the current print setup:

1. Select Reports > Page Setup from the report window menu bar.

Supervisor displays the Page Setup dialog box.

2. Select the settings for page margins, page numbers, and table borders, as needed.

3. Select OK to save these settings. The new settings will be applied to the next report that is printed.
Restarting a report

⚠️ Important:
Work-state drill-down reports cannot be restarted.

To restart a report once it is running on the screen, perform the following steps:

1. Select Restart from the Report menu.
   
   The report window closes and the input window that is used to specify the object of the report is displayed again.

2. Enter the requested information in the input window and select OK.
   
   Supervisor displays the report window with the newly updated information for the selected object.
Using reports
Chapter 5: Scripting CMS operations

Scripting enables the automation of tasks such as running reports, exporting report data, and other operations.

This section contains the following topics:

- **Before you begin** on page 201
- **Tasks scripts can automate** on page 202
- **Interactive and automatic scripts** on page 202
- **Creating scripts** on page 203
- **Scripting other Supervisor operations** on page 210
- **Error and warning messages** on page 215

---

**Before you begin**

Before a script can be run through Supervisor, the following conditions must be met:

- The username associated with an automatic script must be assigned all the permissions required for all operations specified by the script.
- No more than four scripting Supervisor sessions, including background sessions initiated by automatic scripts, can be run simultaneously on a PC.
- The PC must be running at the time when an automatic script is scheduled to run.
- Once a script is created, it can be started by accessing the script file directly from a Microsoft Windows Explorer window.
- Due to PC-related issues, it is strongly recommended that mission-critical activities, such as backups, be scheduled through Timetables on the CMS server. For more information about Timetable scheduling, see **Creating and scheduling a timetable** on page 623.
Tasks scripts can automate

Scripts can be used to automate several CMS tasks, such as:

- Running reports
- Exporting data from reports
- Performing Dictionary operations and reports
- Administering Exceptions and requesting Exception reports
- Performing Agent Administration operations
- Performing Call Center Administration operations and reports
- Performing System Setup operations
- Performing Maintenance operations and viewing the Error Log
- Administering User Permissions

Interactive and automatic scripts

Each script is designated to be either interactive or automatic, as defined below:

- An interactive script runs in the current Supervisor session and the actions display on the PC. If the Supervisor session is disconnected from the CMS server, the script will not run.

- An automatic script launches a new Supervisor session that logs into CMS and runs the requested tasks as a background process. Script actions are not displayed on the screen. Although Supervisor provides the ability to create automatic scripts, a third-party scheduling program must be used in order to run the scripts automatically on a regular schedule.
Creating scripts

This section describes how to create interactive or automatic scripts used to run reports. Interactive and automatic scripts used to run reports have the following differences:

- An *interactive* script runs in the current *Supervisor* session and the actions display on the PC. If the Supervisor session is disconnected from the *CMS* server, the script will not run.

- An *automatic* script launches a new *Supervisor* session that logs into *CMS* and runs the requested tasks as a background process. Script actions are not displayed on the screen. Although *Supervisor* provides the ability to create automatic scripts, a third-party scheduling program must be used in order to run the scripts automatically on a regular schedule.

This section contains the following topics:

- [Accessing scripts](#) on page 203
- [Accessing the script options](#) on page 204
- [Creating an interactive report script](#) on page 205
- [Creating an automatic report script](#) on page 206
- [Creating a script to export report data](#) on page 207
- [Creating a script to export report data as HTML](#) on page 208

Accessing scripts

Scripts can be created and accessed through the *Scripts* button found on several dialog boxes. Dialog boxes containing the *Scripts* button can be accessed through the following menu selections:

- **Commands > Reports**
- **Commands > Dictionary**
- **Commands > Exceptions**
- **Commands > Agent Administration**
- **Commands > Call Center Administration**
- **Tools > System Setup**
- **Tools > Maintenance**
- **Tools > User Permissions**
Scripting CMS operations

Scripts can also be accessed from agent administration windows or once a report is run. The Script button is also available when you use any other Supervisor command or tool that allows you to add or change objects.

Accessing the script options

Before you create scripts, you should be aware of the different options and behaviors available for scripts.

To access script options:

1. Select Tools > Options from the menu bar on the Controller Window. Supervisor displays the Options dialog box.

2. Select the Scripting tab.

The Scripting dialog provides the fields required to set the scripting options, which includes:

- **User ID** - This read only ID allows automatic scripts to make their connection to the CMS server. The login ID and password are not validated until an automatic script is run.

- **Logging Level** - The extent to which script-related activities and outputs are logged, according to the following criteria:
  - **Minimum** - Logged activities are limited to those errors and messages from Supervisor which would otherwise be displayed when the scripts are run manually.
  - **Normal** - Logged activities include those recorded at the Minimum setting, plus the following information: task start time; task end time; name of the script.
  - **Maximum** - Logged activities include all those recorded at Minimum and Normal settings, plus additional error messages which may be useful for debugging a script.
Creating scripts

- **Log File: Path** - Allows you to specify a non-default file directory path. Selecting the folder icon to the right of this field also lets you browse the file system to select a log file directory.

- **Log File: Size** - Allows you to specify the size of the log file before it rolls over and begins to overwrite itself.

---

**Creating an interactive report script**

To create an interactive script used to run a report:

1. Select **Commands > Reports** from the Controller Window menu bar.  
   *Supervisor* displays the **Reports** window.

2. Select the tab associated with the type of report you want to run (Real-Time, Historical, or Integrated), and then highlight the report from the categories and listings which are displayed.

3. Select the **Script** button on the report selector window.  
   *Supervisor* displays the **Save as Script** window.

4. Select a directory and file name for the script and select **Save**.  
   *Supervisor* closes the **Save as Script** window and returns you to the report selector window.
Creating an automatic report script

To create an automatic script used to run a report:

1. Select **Commands > Reports** from the Controller Window menu bar.
   
   *Supervisor* displays the **Reports** window.

2. To select a report for scripting, select the appropriate report type from the dialog box tabs (Real-Time, Historical, or Integrated), highlight the report, and select **OK**.
   
   *Supervisor* displays the input window for the selected report.

3. Enter the appropriate data in the input window and run the report by selecting **OK**.
   
   *Supervisor* displays the selected report.
Note:
If a historical report was selected, set the Destination controls to View Report on Screen.

4. In the dialog displayed for the report, select Reports > Script from the main menu. Supervisor displays the Save as Script window.

5. Select a directory and file name for the script. The file type is set to automatic by default.

6. Select Save.
Executing this automatic script causes the report to run with the inputs provided during its creation.

Creating a script to export report data

To create a script that exports report data to the clipboard or a specified file:

1. Run a report and display it to screen. See Choosing a report on page 194 for this procedure.
   Supervisor displays the window for the selected report.

2. From the Edit menu of the report window, select one of the following actions:
   ● Export Chart Data
   ● Export Table Data
Scripting CMS operations

- **Export All Data**

The data export dialog box is displayed. The dialog that is displayed will vary according to which export option is selected.

Some of these options can also be selected from a pop-up menu by performing a right-click in the report window.

3. Set the appropriate options in the data export dialog, and then select the **Script** button.

⚠️ **Important:**

Do not select **OK** after the options are selected.

*Supervisor* displays the **Save as Script** window.

4. Select a directory and file name for the script, and set the file type to either **Interactive** or **Automatic**.

5. Select **Save**.

---

**Creating a script to export report data as HTML**

To create a script that saves a *Supervisor* report as an HTML file:

1. Select a report that you want to export as HTML and display it to the screen.

For more information, see **Choosing a report** on page 194.

*Supervisor* displays the report window.
2. From the menu bar of the report window, select **Reports > Save As HTML**.

   *Supervisor* displays the **Save As HTML** window.

3. Select the appropriate option from the **Template** group.

   A template can be used to provide company logos, background color, specific fonts, or surrounding text to the HTML file. If you do not select a template, the export process generates basic HTML tags to display the report.

   *Supervisor* provides you with several templates that can be found in the \samples directory of the main *Supervisor* directory.

4. In the **Output** field, select a name for the HTML file you are creating. To save the file in a directory other than the current directory, specify a full file path, such as c:\temp\myrpt.htm. You may also use the browse button located to the right of this field to navigate to a target directory.

5. Select the **Script** button.

   *Supervisor* displays the **Save as Script** window.

6. Select a directory and file name for the script, and set the file type to either **Interactive** or **Automatic**.

7. Select **Save**.

   If there are charts associated with the file, they are converted into .GIF files. After the HTML is saved, you can move or copy it and all associated graphics files to a web server directory for viewing on the Internet or an Intranet.
Scripting CMS operations

Scripting other Supervisor operations

This section provides information on the procedures used to create and save scripts for actions not associated with reports.

This section contains the following topics:
- Actions not associated with reports on page 210
- Scripting an input window on page 210
- Scripting an action on page 212
- Organizing scripts on page 214

Actions not associated with reports

Actions not associated with reports include:
- Displaying an input window for actions, not reports, requiring data entry when the script is run.
- An Add, Modify, or Delete action

Scripting an input window

This procedure describes how to create a script that displays an input window for a specific, non-report operation. Executing the script displays the input window for the operation selected when this script was created.

Actions captured in a script

Actions associated with the following functions can be captured in a script:
- Dictionary
- Exceptions
- Maintenance
- System Setup
- Agent Administration
- Call Center Administration
Scripting other Supervisor operations

Steps
To create a script for an input window:

1. Select the necessary item from the Commands menu on the Controller Window.
   Supervisor displays the associated selector window for the item selected.

   ![Selector window](example_image)

   **Important:**
   Do not double-click the option or press the Enter key when an operation is highlighted or the action will be initiated and the script recording will be aborted.

2. Highlight the operation to be made into a script from the Operations list on the Operations tab of the selector window and then select the Script button in the selector window.
   Supervisor displays the Save as Script window.
   The file type is set to Interactive by default.

3. Complete the Save as Script window by entering a file name and folder location and then select Save when finished.
   Supervisor displays an acknowledgment message to indicate that the script has been saved.

4. Select the OK button on the acknowledgment message box.
   Supervisor closes the Save as Script window and the selector window remains open.
Scripting an action

Use this procedure to create a script that results in the execution of an action. Running the saved script will cause an **Add**, **Modify**, **Delete**, or **No action** action to be performed for the selected operation.

To script a **Supervisor** action:

1. Select the necessary item from the **Commands** menu on the Controller Window. Valid items for scripting an action include:
   - Dictionary
   - Exceptions
   - Maintenance
   - System Setup
   - Agent Administration
   - Call Center Administration
   *Supervisor* displays the selector window associated with the selected item.

2. Highlight the operation to be made into a script from the **Operations**: list on the **Operations** tab of the selector window.

3. Select the **OK** button.
   *Supervisor* displays the input window for the selected operation.
4. Select **Actions > Script** from the menu bar of the input window. If none of the valid scriptable actions, **Add**, **Modify**, or **Delete**, are present, you cannot select **Script**. 

*Supervisor* displays the **Save as Script - Action** window.

5. Select the action to be performed by the script.

6. Select the **OK** button.

*Supervisor* displays the **Save as Script** window.

**Note:**

If the **Cancel** button is selected, *Supervisor* dismisses this window and displays the input window without saving an action.

7. In the **Save as Script** window, select a file folder location and file name.

8. Specify the script type as either **Automatic** or **Interactive**.

9. Select **Save**.

*Supervisor* displays an acknowledgment message box stating that the script has been saved.

10. Select the **OK** button on the acknowledgment message box

*Supervisor* displays the **Save as Script - Action** window.
Organizing scripts

The **Organize Scripts** window provides a simple file management interface which allows you to rename, delete or move script files.

To organize existing **Supervisor** scripts:

1. Select **Scripts > Organize Scripts...** from the menu bar on the Controller Window. **Supervisor** displays the **Organize Scripts** window.

2. Perform actions on the scripts as needed. This can include renaming, deleting, and moving.

3. When you are finished organizing scripts, select **Close** to exit the **Organize Scripts** window.
Error and warning messages

This section lists possible error messages which may be encountered when running scripts and describes their associated causes and possible solutions:

<table>
<thead>
<tr>
<th>Message</th>
<th>Reason</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>This script will not run unless a CMS login ID and password have been specified.</td>
<td>The CMS login ID and password have not been set on the Scripting tab of the Controller Options window.</td>
<td>Specify a login ID and password on the User Information window.</td>
</tr>
<tr>
<td>Automatic scripts are set to run with the permissions of another user of the PC.</td>
<td>The User Information window designates the other user as the owner of automatic scripts.</td>
<td>You can change the permissions via the login information on the Scripting tab of the Options window for the Controller Window. The change will apply to subsequent automatic scripts that are run on the PC.</td>
</tr>
</tbody>
</table>
| (Action) Supervisor displays the Save as Script: Add or Replace window. | The file already exists. | Select one of the following actions at the bottom of the window:  
  ● Add (default) - Adds the new script to the end of the existing script  
  ● Replace - Deletes the existing script and create a new script file  
  ● Cancel - Closes the Add or Replace window and returns to the Save as Script window  
  ● Help - Displays the help topic for the current window. |
Chapter 6: Administering contact center agents

This section provides information on using the Agent Administration window.

The items on the Agent Administration menu vary depending on the type of switch that Call Management System (CMS) is connected to and the features that are activated on the switch. These procedures include instructions for administering agents in an Automatic Call Distribution (ACD) with and without the Expert Agent Selection (EAS) feature.

This section contains the following topics:

- Starting or stopping an agent trace on page 218
- Viewing current agent trace states on page 221
- Listing agents traced on page 223
- Changing agent skills on page 225
- Changing skills for multiple agents on page 232
- Changing extension split assignments on page 236
- Moving extensions between splits on page 239
- Running a split members report on page 242
Starting or stopping an agent trace

This section provides the procedure for starting and stopping the tracing of agents. Tracing an agent records the activities of the agent, state changes, and time when these events occurred. The agent trace report displays this information when it is run. The agent trace report can help you to evaluate how well agents use their time.

Before you begin

The following items should be read and understood before working with agent traces:

- Traces can be activated for a maximum of 400 agents at a time across all ACDs from one CMS server. This maximum does not take into account whether or not the agents are logged in. It also applies to the number of agents who are administered and traced by one server across all ACDs. To avoid compromising performance, activate only the traces that you need.

- A maximum of 500,000 agent trace records can be stored. The oldest record is discarded and overwritten by the newest record when the file reaches the allocated maximum number of records.

- Turning a trace off does not delete the trace records for that agent. Agent trace records are overwritten automatically when the trace file reaches the maximum number of allocated records.

- The settings in the Data Storage Allocation window determine the maximum number of agent trace records that CMS can record. See Data Storage Allocation on page 471 for more information on this window.

- Starting and stopping agent traces requires that the Data Collection feature is currently activated.

- An agent trace must be started before the Agent Trace report can be run.

- Scripts can open and use the Activate Agent Trace window. You can also schedule the script. See Chapter 5: Scripting CMS operations on page 201, for more information on scripting.

- The Activate Agent Trace window can be set on a timetable. See Chapter 13: Using timetables and shortcuts on page 621, for more information.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To start or stop an agent trace, the user ID used to log in to this Supervisor session requires write permission for the Agent Administration subsystem.

- To view an agent trace report, the user ID used to log in to this Supervisor session requires read permission for the Reports subsystem.
Steps

1. From the Controller Window, select **Commands > Agent Administration**. 
   *Supervisor* displays the **Agent Administration** window.

   On Communication Manager systems with EAS:

   ![Agent Administration Window with EAS](image)

   On Communication Manager systems without EAS:

   ![Agent Administration Window without EAS](image)

2. In the **Operations:** list, highlight **Activate Agent Trace**.
3. In the **ACD** drop-down list, select the ACD on which the agent trace will be run or is currently running.
4. Select OK.

   "Supervisor" displays the **Activate Agent Trace** window.

5. In the **Agent names or logids**: field, enter the names or login IDs of the agents who are to be traced or are being traced.

   This field can accept multiple values. Multiple values must be separated by a semicolon (;).

   Using the Browse button to the right of this field will only display those agents that have synonyms assigned to them through the Dictionary.

6. Perform one of the following actions for the **Agent trace**: options:

   - To start an agent trace, select **On**.
   - To stop an agent trace that is currently running, select **Off**.

7. Select **Actions > Modify** from the menu bar to start or stop the agent trace.

   The status bar displays **Working** and then, if successful, displays **Successful** when the operation finishes.
Viewing current agent trace states

This section provides the procedure for viewing all agent traces that are set to either On or Off.

To view all On or Off agent traces:

1. From the Controller Window, select Commands > Agent Administration. 
   Supervisor displays the Agent Administration window.

On Communication Manager systems with EAS:

2. In the Operations: list, highlight Activate Agent Trace.

On Communication Manager systems without EAS:

3. In the ACD drop-down list, select the ACD on which the agent trace will be run or is currently running.
4. Select **OK**. 

*Supervisor* displays the **Activate Agent Trace** window.

5. Ensure that the **Agent names or logids**: field is blank.

6. In the **Agent trace**: options, select the state to view:
   - **On** - Displays all currently active agent traces.
   - **Off** - Displays all disabled agent traces.

7. From the menu bar, select **Actions > List All**.

*Supervisor* displays a window with a list of all agents who are currently in the selected trace state.
Listing agents traced

This section provides the procedure for listing agents and dates for which agent trace data is available on reports. As with most operations, it is possible to run these operations through scripts and timetables. For more information on scripts and timetables, see Chapter 5: Scripting CMS operations on page 201 and Chapter 13: Using timetables and shortcuts on page 621, respectively.

Before you begin

To view data through this operation, an agent trace must be activated for one or more agents. Also, agents for whom traces are activated must log in so that CMS creates agent trace records.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To list all agents traced, the user ID used to start this Supervisor session must have read permission for the Agent Administration subsystem.

Steps

To list all agents with trace data:

1. From the Controller Window, select Commands > Agent Administration. Supervisor displays the Agent Administration window.

2. In the Operations: list, highlight List Agents Traced.

3. In the ACD: field, select the ACD for which agents being traced will be listed.
4. Select **OK**.

*Supervisor* displays the **List Agents Traced** window.

**Note:**

The procedure for viewing agent trace records varies according to the information that you enter in the fields of the **List Agents Traced** window. The results for listing agents traced relies on the entries made in the **Agent(s):** field, the **Dates:** field, or a combination of the two. For example, you can specify a small range of agents in the **Agent(s):** field and a date range in the **Dates:** field. This will result in a list of only the specified agents for the date range entered.

5. Use the following descriptions to determine how information is entered in the **Agent(s):** and **Dates:** fields:

- Use the **Agent(s):** field to specify none, one, or more agents to use in displaying agent trace records.
  
  Leave this field blank to show all agent trace records for the dates entered in the **Dates:** field.
  
  Only those agents with login IDs in the Dictionary can be entered in the **Agent(s):** field.
  
  This field can accept multiple values. Multiple values must be separated by a semicolon (;

- Use the **Dates:** field to specify no date, a single date, multiple dates, or a range of dates.
  
  Leave this field blank to show all agent trace records for the agents entered in the **Agent(s):** field.
  
  This field can accept multiple dates or a range of dates. Multiple dates must be separated by a semicolon (;).

- Leave both the **Agent(s):** and **Dates:** fields blank to have *Supervisor* display all agent trace records.

6. Select **Actions > List All** to display the agent trace records that match the information that you entered in the **Agent(s):** and **Dates:** fields.

*Supervisor* displays a secondary window listing the dates and agents for which agent trace data is available, sorted by date.
Changing agent skills

Use the **Change Agent Skills** window to configure agent skills on systems with Expert Agent Selection (EAS).

**Actions performed by this feature**

Use this feature to perform the following actions:

- View the current skill assignment
- Change the skills of an agent or agent template
- Add agents to an agent template
- Set the skill of an agent or agent template to *primary* or *secondary*
- Set the level of the skill for an agent from 1 to 16

**Before you begin**

The following items should be read and understood before changing agent skills:

- The **Change Agent Skills** item is only available for ACDs on which EAS is activated.
- When agent skills are changed, the change is made to the Communication Manager system and remains in effect until another change is made through Supervisor or the Communication Manager system itself.
- When agent skills are changed, you cannot exit the **Change Agent Skills** window until the ACD responds to the requested agent changes.
- A template can be any existing agent profile where the skill settings of the profile are applied to other agent profiles. You can specify multiple agents individually and by using ranges. Entries must be separated with semicolons. You are limited to 250 characters in this field. After you apply the skill settings, any changes that you make to the agent profile that was originally used as the template do not affect the other agent profiles.
- Skill changes take effect immediately for agents who are in AUX work mode, AVAIL (available), or logged out. Changes are pending for agents on calls or in ACW work mode until the agent enters the AUX work mode, becomes available, or logs out. Because of this, agents who frequently have calls on hold may have skill changes remain pending for a longer time than expected.
- Changing agent skills should only be done through Supervisor as it checks if the agent has the appropriate permissions for the newly assigned skills. The CMS ASCII interface does not perform permission checking which can result in agents belonging to skills to which they do not have permissions.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view agent skill assignments, the user ID used to log in to this Supervisor session requires read permission for the Agent Administration subsystem.
- To change agent skills, the user ID used to log in to this Supervisor session requires write permission for the Agent Administration subsystem.

Steps

To change skills for an agent:

1. From the Controller Window, select **Commands > Agent Administration**. Supervisor displays the **Agent Administration** window.

2. In the ACD field, select the ACD for which you want to change agent skills.
3. In the Operations: list, highlight **Change Agent Skills**.
4. Select **OK**. Supervisor displays the **Select Agent/Template** window.

5. In the **Select Agent/Template** window, enter the Agent ID using one of the following methods in order view or change their skills:
   - The agent login ID
Changing agent skills

- The name of the agent
- An agent template

See the beginning of this section for more information on agent templates.

6. Select **OK**.

*Supervisor* displays the **Change Agent Skills** window with the agent or template name and login ID in the title bar.

![Image of Change Agent Skills window]

The skills and skill level for the agent or template that you named are shown in the **Assigned Skills** field and **Level** field, respectively.

Skill names are shown for the skills that are defined in the Dictionary. Skill numbers are shown for the skills that are not defined in the Dictionary.

These skill settings for an agent can be passed on to other agent profiles. To specify the agents who are to receive the skill settings, select **Use for one or more Agents** and enter the agent IDs in the associated field.
7. Choose one of the following options to change the skills of this agent or template.

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
</table>
| You want to change which calls an agent receives first | Select a different method in the **Call Handling Preferences** group box. Calls can be distributed to the selected agent based on:  
   - Skill Level  
   - Greatest Need  
   - Percent Allocation  
   The **Skill Level** for the agent is shown in the **Assigned Skills** list. **Percent Allocation** is only available if *Avaya Business Advocate* is enabled on the Communication Manager system. |
| You want to change the skill that is used to queue an agent's direct agent calls | Perform one of the following actions:  
   - Select a new skill from the **Direct Agent Skill** drop-down list.  
   - Enter the name or number of the skill in the **Assigned Skills** column of the **Agent Skills and Skill Levels** group that will be used for queuing the direct agent calls to the specified agent. You may then select the skill from the **Direct Agent Skill** drop-down list.  
   The **Direct Agent Skill** list does not contain reserve skills. If the agent who is currently displayed has only reserve skills in the **Assigned Skills** list, no **Direct Agent Skill** can be assigned to that agent. |
| You want to change the level/type that is associated with skill that is already assigned | Perform the following procedure:  
   1. In the **Assigned Skills** list, select the level of the skill for which you want to change the value. Note that if you have a Skill Level Call Handling Preference, an arrow indicates the agent's Top Skill assignment.  
   2. Select a new value for the skill level from the **Level** drop-down list in the **Agent Skills and Skill Levels** group.  
   If **Skill Level** is selected in the **Call Handling Preference** group and only reserve levels are assigned to an agent, that agent does not have a top skill and the **Make Top Skill** button is disabled.  
   3. Select **OK**. |
### Changing agent skills

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
</table>
| You want to remove skills that are assigned to this agent or template | Perform the following procedure:  
1. In the **Assigned Skills** field, select the skills to remove from the agent.  
2. Select the **Delete Skills** button.  
Note that if an agent has only one assigned skill, this skill cannot be deleted. |
| You want to add skills to this agent or template | Select the **Add Skills** button. In the **Available Skills** list of the **Add Agent Skills** window, highlight one or more skills that you want to assign to the agent as well as the **Skill Level** for these new skills. The **Available Skills** field lists all the skills that are defined on this ACD. When you are finished adding skills, select the **OK** button in the **Add Agent Skills** window. |
| You have Avaya Business Advocate and want to specify a new percent allocation | Perform the following procedure:  
1. In the **Call Handling Preferences** group, select **Percent Allocation**.  
Note that the **Percent Allocation** field is unavailable if a reserve level has already been specified for an agent or template.  
2. Select the **Yes** button from the warning window. This indicates that you want to enable the Percent Allocation feature.  
If an agent or template has **Percent Allocation** call handling preference, the total percent allocation for all standard skills must equal 100%.  
By default, **Direct Agent Calls First** is activated. If a call handling preference other than **Percent Allocation** is selected, direct agent calls are delivered first, and the **Direct Agent Calls First** check box is not applicable. |
| You want to make an **Assigned Skill** the **Top Skill** for this agent | Perform the following procedure:  
1. In the **Assigned Skills** column of the **Agent Skills and Skill Levels** group, select the skill that you want to be the top skill of the agent.  
2. Select the **Make Top Skill** button. |
<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
</table>
| You want to apply the changes to multiple agents | Perform the following procedure:  
  1. Select the **Use for One or More Agents** check box.  
  2. Enter the agent names or login IDs in the **Agent Name(s)/Login ID(s)** field, select them from the drop-down list, or select them from the **Browse** window.  
  3. Select **OK**.  
    Changes are submitted to the **CMS** server. If a move is pending, you are notified that the operation will not occur until the pending conditions are resolved. If you are applying a template to multiple agents, **Supervisor** buffers the change agents skills requests and send them to the **CMS** server one at a time. **Supervisor** displays a status box that indicates the status of each requested agent change.  
    If an error in encountered with changes to agent skills, **Supervisor** displays a message that states what is in error. Select **OK** or **Cancel** to dismiss the error message and return to the **Change Agent Skills** window so that the error can be corrected.  
  4. Select **OK**.  
    If the change is successfully made, **Supervisor** displays a successful message in the status bar.  
    If the state of an agent is not in AUX or AVAIL, **Supervisor** displays a message which states that the changes will be applied when the agent returns to one of those states.  
  5. Select **OK**.  
    **Supervisor** closes the **Change Agent Skills** window. |
**If...** | **Then...**
---|---
You are finished making changes | Perform one of the following actions:
  * Select **OK** in the **Select Agent/Template** window. This action saves the changes that you made to the agent skills.
  * Select **Cancel** in the **Select Agent/Template** window. This action cancels any changes that you made.

You want to make skill assignment changes for other agents or templates | Perform the following actions:
  1. Select another agent or template in the **Select Agent/Template** window.
  2. Return to Step 5 and continue with the procedure.
Changing skills for multiple agents

This section provides the procedure for changing skills for more than one agent at a time. Use the Multi-Agent Skill Change window to view current skill assignments or to change a skill for as many as 32 agents. You can also use this window to specify the skill levels and type of the skills.

Before you begin
The following items should be read and understood before beginning work with the Multi-Agent Skill Change window:

- When agent skills are changed, the change is made to the Communication Manager system and remains in effect until another change is made through Supervisor or the Communication Manager system.

- You cannot exit from the Multi-Agent Skill Change window until the Communication Manager system responds to the requested changes.

- Skill changes take effect immediately for agents who are in AUX work mode, AVAIL (available), or logged out. Changes are pending for agents on calls or in ACW work mode until the agent enters the AUX work mode, becomes available, or logs out.

- For agents who frequently have calls on hold, skill changes can remain pending for a longer time than expected.

Permissions
Depending on the procedure that you want to perform, you need the following permissions:

- To view agent skill assignments, the user ID used to log in to this Supervisor session requires read permission for the Agent Administration subsystem.

- To change agent skills, the user ID used to log in to this Supervisor session requires write permission for the Agent Administration subsystem and for the skills to which agents are assigned.
Steps
To change one skill for multiple agents:

1. From the Controller Window, select Commands > Agent Administration.
   Supervisor displays the Agent Administration window.

2. In the ACD: field, select the ACD for which you want to change agent skills.
3. In the Operations: list, highlight the Multi-Agent Skill Change item.
4. Select OK.
   Supervisor displays the Multi-Agent Skill Change window.

5. Use one of the following methods to choose a skill:
   - Double-click the skill name or number.
Administering contact center agents

- Highlight a skill and press the Enter key.

Supervisor displays a second window that shows the agents assigned to this skill who are currently logged in.

Clicking the left mouse button on the column headings sorts the contents between ascending and descending order.

To view or change the current skills of an agent in the skill window, double-click the agent name.

6. To move agents from the current skill to another skill, perform one of the following actions:

- To move a single agent, use the mouse to drag-and-drop an agent to a new skill in the Skill List window.

- To move multiple agents to a new skill, hold down the Ctrl key and click on multiple agents to select them. You can select a range of agents by clicking on the agent at the beginning of the range, holding down the Shift key, and then clicking the agent at the bottom of the range.

Use the drag-and-drop method to move the agents from the window for their current skill to a new skill in the Skill List window.

- Another way of moving agents from one skill to another is to open a window for the new, target skill by double-clicking that skill in the Skill List window. You can then drag-and-drop agents between the two skill windows.

Note that holding down the Ctrl key while dragging and dropping agents will add, not move, the agent or agents to the new skill.

Supervisor displays the Move Agents Between Skills window with the Agents field showing the following:

- The agents you moved
- The call-handling preferences of the agents
Changing skills for multiple agents

- The reserve level or skill level of each agent
- The service objective of each agent
- The percent allocation for the skill of each agent. Percent allocation is only available on Communication Manager systems with *Avaya Business Advocate*.

The Move group displays information showing the skills involved in moving this agent. If the agent is being added to a new skill, not moved, the From Skill: information is blank and the Preserve Original Levels option is unavailable.

7. In the Move Agents Between Skills window, perform one of the following actions to complete moving agents from skill to skill:

- Select the Level option and enter a skill-level value for each agent that you moved to this new skill.

- To keep the current skill level of the agent, select the Preserve Original Level option. This action deactivates the Level option.

8. Select OK.

If one or more agent moves fail, Supervisor displays a status window showing the reasons for failure. Otherwise, the status window notifies you that the change is pending.
Changing extension split assignments

This section provides the procedure for assigning an extension to a different split. This feature is used for Communication Manager systems without Expert Agent Selection (EAS). Use the Change Extension Split Assignments window to list the extensions that are in the currently assigned splits or to change the splits that are assigned to a specific extension number.

Before you begin

The following should be read and understood before changing extension split assignments:

● You cannot exit from the Change Extension Split Assignments window until the Communication Manager system responds to the requested changes.

● Extension split assignment changes take effect immediately for agents who are in AUX work mode, AVAIL (available), or logged out. Changes are pending for agents on calls or in ACW work mode until the agent enters the AUX work mode, becomes available, or logs out.

● For agents who frequently have calls on hold, extension split assignment changes can remain pending for a long time.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

● To view extension split assignments, you need read permission for the Agent Administration subsystem.

● To change extension split assignments, you need write permission for the Agent Administration subsystem and for the splits to which the extensions are assigned.
Steps
To change an extension split assignment:

1. From the Controller Window, select **Commands > Agent Administration**.
   *Supervisor* displays the **Agent Administration** window.

   ![Agent Administration Window](image)

2. In the **ACD** field, select the ACD for which you want to change extension split assignments.

3. Select **Operations > Change Extension Split Assignments**.

4. Select **OK**.
   *Supervisor* displays the **Select Extension** window.

   ![Select Extension Window](image)

5. In the **Select Extension** window, enter the extension number for which the split assignment is to be changed.

   The extensions that are assigned to each split can be viewed in the **Move Extensions Between Splits** window. See [Moving extensions between splits](#) on page 239 for more information.
6. Select **OK**.

   *Supervisor* displays the **Change Extension Split Assignments** window.

   ![](image)

   The **Move Extension From Split** field shows the current split assignment. The **Move Extension To Split** field shows available split names or numbers. If an agent is logged in on the extension, the logged-in icon is displayed as shown in the above graphic. If an agent is not logged in on the extension, an icon is not displayed.

7. Perform one of the following actions:

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>You want to change split assignments for an extension other than the one that is displayed</td>
<td>Select <strong>Cancel</strong> to return to the <strong>Select Extension</strong> window and then return to step 5.</td>
</tr>
<tr>
<td>You want to change split assignments for this extension</td>
<td>Continue with the next step.</td>
</tr>
</tbody>
</table>

8. Perform one of the following actions:

<table>
<thead>
<tr>
<th>If...</th>
<th>Then...</th>
</tr>
</thead>
<tbody>
<tr>
<td>You want to remove a split assignment from this extension</td>
<td>Select the split name or number that is to be removed from this extension in the <strong>Move Extension From Split</strong> box.</td>
</tr>
<tr>
<td>You want to assign a split assignment to this extension</td>
<td>Select the split name or number that is to be assigned to this extension in the <strong>Move Extension To Split</strong> box.</td>
</tr>
</tbody>
</table>
Moving extensions between splits

This section provides the procedures for adding a split to an extension, removing a split from an extension, and moving an extension to another split. This feature is for those systems without Expert Agent Selection (EAS). You can also use the Move Extensions Between Splits window to view extension split assignments.

Before you begin

The following items should be read and understood before moving extensions between splits:

● As many as 32 agents can be moved at one time.

● You cannot exit from the Move Extensions Between Splits window until the Communication Manager system responds to your request.

● Extension split assignment changes take effect immediately for agents who are in AUX work mode, AVAIL (available), or logged out. Changes are pending for agents on call or in ACW work mode until the agent enters the AUX work mode, becomes available, or logs out.

● For agents who frequently have calls on hold, an extension move request can remain pending for an extended period of time.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

● To view extension assignments, the user ID used to log in to this Supervisor session requires read permission for the Agent Administration subsystem and the affected splits.

● To move extension assignments, the user ID used to log in to this Supervisor session requires write permission for the Agent Administration subsystem and the affected splits.
Steps

To move extensions between splits:

1. From the Controller Window, select Commands > Agent Administration.

   Supervisor displays the Agent Administration window.

2. In the ACD: field, select the ACD that contains the extensions to move.

3. In the Operations: list, highlight Move Extensions Between Splits.

4. Select OK.

   Supervisor displays the Move Extensions Between Splits window.

5. Select the split to work with by performing one of the following actions:
   - Double-click the split name or number in the Split List window.
   - Highlight the split to work with in the Split List window and then select Split > Open selected split from the menu bar.
6. To move one or more extensions from the current split to another split, perform one of the following actions:

- To move a single extension, use the mouse to drag-and-drop an extension to a new split in the **Split List** window.

- To move multiple extensions to a new split, hold down the **Ctrl** key and click on multiple extensions to select them. You can select a range of extensions by clicking on the extension at the beginning of the range, holding down the **Shift** key, and then clicking the extension at the bottom of the range.

  Use the drag-and-drop method to move the extensions from the window for their current split to a new split in the **Split List** window.

- Another way of moving extensions from one split to another is to open a window for the new, target split by double-clicking that split in the **Split List** window. You can then drag-and-drop extensions between the two split windows.

  *Supervisor* displays the **Move Extensions Between Splits** window.

![Move Extensions Between Splits window](image)

7. Select **OK** in the **Move Extensions Between Splits** window to complete the moving of the selected extensions.
Running a split members report

This section provides the procedure for running a split members report. This report displays the extensions that are members of a specific split. Unlike regular reports, a custom or designer report cannot be created from the split members report. The split members report lists the selected splits in numerical order, each split's assigned name, and the extensions that are assigned to the split.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To run a split members report, the user ID used to log in to this Supervisor session requires read permission for the Agent Administration subsystem and for all affected splits.

Steps

To run a split members report:

1. From the Controller Window, select Commands > Agent Administration. Supervisor displays the Agent Administration window.

2. Select the Reports tab. Supervisor displays the Reports tab of the Agent Administration window.

3. In the ACD: field, select the ACD on which to run the split members report.

4. In the Reports: list, highlight Split Members.
5. Select **OK**.

*Supervisor* displays the **Split Members** window.

![Split Members window](image)

6. Enter the split information in the **Splits**: field. This can be one split, multiple splits, or a range of splits. Multiple splits must be separated by a semicolon (;).

7. In the **Destination** group, select **View Report on Screen** or **Print Report on**:

8. Select **OK**.

*Supervisor* displays or prints the **Split Members** report.

![Split Members report](image)

If the split does not have a name assigned, the **Split Name** columns on the report shows the split number. If the split has no extensions assigned to it, the **Extension** column is blank.
Administering contact center agents
Chapter 7: Administering the contact center configuration

This section provides the procedures to perform operations to configure the contact center. Depending on the type of Communication Manager system and the features that are enabled on it, the items on the Call Center Administration menu will vary.

This section contains the following topics:

- Before you begin on page 245
- ACD Groups on page 246
- Call work codes on page 260
- VDN skill preferences on page 267
- Split/skill call profiles on page 273
- Trunk group assignments on page 281
- Trunk group members report on page 286
- VDN-to-vector assignments on page 288
- VDN call profiles on page 293
- Vector configuration report on page 301

Before you begin

If an ACD Group is selected as the current ACD in the Dictionary window, only those operations that are valid for the ACD Group will appear in the Operations: list.
ACD Groups

An ACD Group is an administrator-assigned collection of ACDs.
This section contains the following topics:

- Before you begin on page 246
- ACD Group capabilities on page 247
- ACD Groups feature interfaces on page 248
- Permissions on page 248
- Adding an ACD Group on page 249
- Listing all ACD Groups on page 250
- Adding an ACD to an ACD Group on page 251
- Viewing the contents of an ACD Group on page 252
- Deleting an ACD from an ACD Group on page 254
- Modifying an ACD Group on page 256
- Deleting an ACD Group on page 258

Before you begin

The following items should be read and understood before you work with ACD Groups:

Availability
- If you add an ACD Group, you will need to log out of Supervisor and log back in to see this group as a choice in the appropriate dialogs.

Capabilities/Performance
- A maximum of 12 ACD Groups can exist on an Avaya CMS server.
- Each ACD Group can contain zero to eight ACDs.
- CMS must be in single-user mode in order to add or delete ACD Groups.

Roles/Definitions
- An ACD Group cannot serve as the CMS master ACD.
- An ACD Group cannot be deleted if it is set as the current ACD.
● When created, ACD Groups will be assigned an ACD ID number from 27 through 38. This number is automatically assigned by CMS and cannot be altered.

● ACD Groups will not disallow an ACD being added as a member based on its version or feature set.

● Pseudo-ACDs cannot be a member of an ACD Group.

● When an ACD Group is deleted, all synonyms assigned to its member ACDs will remain.

● Names must begin with an alphabetic character and can be up to 20 characters long. Valid characters are alphanumerical (a-z, A-Z, 0-9), underscore (_), blank ( ), comma (,), period (.), single quote ('), and plus (+). Multiple values are not allowed.

Synonyms

● Overlapping ACD Groups (groups having common member ACDs), could result in synonym conflict within the members of an ACD Group if poorly administered. Because of this capability, entity IDs in overlapping ACD Groups must be mutually exclusive.

● Entity synonyms must be unique for an ACD Group and across all of the ACDs that are members of the ACD Group.

Other

● User permissions are administered separately for an ACD Group and its member ACDs.

● CMS real-time custom reports are only displayed if data collection is enabled and the ACD link status is 'up' for at least one member ACD in the specified ACD Group. An error message will be displayed if these conditions are not met.

● Custom reports that are created with the Single ACD Only option enabled cannot be run for an ACD Group and vice versa.

● If a backup was created on a CMS server where the Global Dictionary feature was authorized, the data can only be restored on a CMS server that also has this feature authorized. If the Global Dictionary feature authorizations between a backup and the target CMS server do not match, an error is displayed, a message is written to the error log, and the restore or migration fails.

ACD Group capabilities

This optional feature provides the following capabilities:

● Easy administration of synonyms in the Dictionary across multiple ACDs. A synonym assigned to a CMS entity for an ACD Group is then propagated to all members ACDs within that group. For example, if you assign skill 102 in the ACD Group with the synonym of Sales, this synonym is assigned to skill 102 for all ACDs within that group.
This feature should be utilized when a contact center uses multiple ACDs that require the same synonyms across all of the ACDs for the following entities:

- Agent login IDs
- Agent groups
- Splits/Skills
- AUX reason codes
- Logout reason codes
- Agent string values
- Split/Skill string values
- Generic string value synonyms

- The reporting of data from multiple ACDs through the use of custom reports. Reports for ACD Groups collect, aggregate, and display contact center data as a single value for the ACD Group instead of one set of values for each member ACD. Custom reports can be created through the CMS ASCII interface or ordered through the Avaya Professional Services Organization. For example, the reporting aspect of this feature can be used to view data for a CMS entity across multiple ACDs such as a skill, a specific agent login ID, and so forth.

---

**ACD Groups feature interfaces**

The ACD Groups feature is available through two interfaces:

- **Call Center Administration** - This subsystem is used for administrators to create, modify, and delete ACD Groups.
- **Dictionary** - This subsystem is used by CMS users who need to view ACD Groups, their contents, and to assign ACD Group synonyms.

---

**Permissions**

- To create, modify, and delete ACD Groups, a CMS user must have the *read* and *write* permissions for the **Call Center Administration** subsystem.
- If a CMS user only requires the ability to view ACD Groups and the member ACDs, *read* permission is required for the **Dictionary** subsystem.
- To assign synonyms to an ACD group, a CMS user requires the *read* and *write* permissions for the **Dictionary** subsystem as well as the ACD Group and its member ACDs.
Adding an ACD Group

This topic provides the procedure for creating an ACD Group. After an ACD Group is created, member ACDs can then be added. See Adding an ACD to an ACD Group for more information.

Before you begin

Before performing this procedure, you should ensure that you have read and understood Before you begin on page 246.

Steps

To add an ACD Group to CMS:

1. From the Controller Window, select Commands > Call Center Administration. Supervisor displays the Call Center Administration window.

2. In the Operations: list, highlight ACD Groups.

3. Select OK. Supervisor displays the Call Center Administration ACD Groups window.

4. In the ACD Group Name: field, enter a name for this new ACD Group.
Administering the contact center configuration

5. From the menu bar, select **Actions > Add**.

* CMS creates the ACD Group and assigns an ACD Group Number.

---

**Listing all ACD Groups**

This topic provides the procedure for listing all ACD Groups defined on the CMS server.

Listing all ACD Groups can be done through either the **Call Center Administration** or **Dictionary** subsystems. Only those CMS users who have *read* permission for the **Call Center Administration** subsystem can use the procedure listed below. CMS users who only work with synonyms or running reports should use the procedure associated with the **Dictionary** subsystem for listing all ACD Groups.

**Steps**

To list all ACD Groups defined on the CMS server:

1. From the Controller Window, select **Commands > Call Center Administration**.

   * Supervisor displays the **Call Center Administration** window.

2. In the **Operations:** list, highlight **ACD Groups**.

3. Select **OK**.

   * Supervisor displays the **Call Center Administration ACD Groups** window.
4. From the menu bar, select **Edit > Clear All** to remove any data from the fields.

5. Select **Actions > List All**.

   *Supervisor* displays a dialog listing the ACD Groups defined on this CMS server.

---

**Adding an ACD to an ACD Group**

This topic provides the procedure for adding an ACD as a member of an existing ACD Group. This procedure can only be performed after an ACD Group has been created. See **Adding an ACD Group** on page 249 for more information.

**Before you begin**

Before performing this procedure, you should ensure that you have read and understood **Before you begin** on page 246.

**Steps**

To add an ACD to an existing ACD Group:

1. From the Controller Window, select **Commands > Call Center Administration**.

   *Supervisor* displays the **Call Center Administration** window.
2. In the **Operations**: list, highlight **ACD Groups**.

3. Select **OK**.

   *Supervisor* displays the **Call Center Administration ACD Groups** window.

![Call Center Admin: ACD Groups](image1)

4. In the **ACD Group Name** field, enter the name of the ACD Group that will receive a new ACD member.

5. Select **Actions > Find One** from the menu bar.

   If the ACD Group name is valid, its numeric ID is displayed in the **ACD Group Number** field and **1 matches found** is displayed in the status bar.

6. From the menu bar, select **Actions > Get contents**.

   *Supervisor* displays the **Call Center Admin ACD Groups Get contents** dialog.

![Call Center Admin: ACD Groups Get contents](image2)

7. From the **ACD** drop-down list box, select the ACD that will be added to this group.

   **Note:**

   If a **CMS** user does not have read and write permissions for an ACD, that ACD will not appear in this list. To view all of the ACDs assigned to this ACD Group, see **Viewing the contents of an ACD Group** on page 252.

8. Select **Actions > Add** from the menu bar.

   The selected ACD is added to this ACD Group and **Successful** is displayed in the status bar.

---

### Viewing the contents of an ACD Group

This topic provides the procedure for displaying the contents of an ACD Group.

Viewing the contents of an ACD Group can be done through either the **Call Center Administration** or **Dictionary** subsystems. Only those **CMS** users who have **read**
permission for the **Call Center Administration** subsystem can use the following procedure. **CMS** users who only work with synonyms or running reports should use the procedure in [ACD Groups](#) on page 55.

**Steps**

To view the current contents of an ACD Group:

1. From the Controller Window, select **Commands > Call Center Administration**.  
   *Supervisor* displays the **Call Center Administration** window.

![Call Center Administration window](image)

2. In the **Operations:** list, highlight **ACD Groups**.
3. Select **OK**.
   
   *Supervisor* displays the **Call Center Administration ACD Groups** window.

![Call Center Administration ACD Groups window](image)

4. In the **ACD Group Name:** field, enter the name of the ACD Group you want to view.

   **Note:**
   
   If you are unsure of the name of the ACD Group, use [Listing all ACD Groups](#) on page 250 to determine the name.

5. From the menu bar, select **Actions > Find one**.
   
   If the ACD Group name is valid, its numeric ID is displayed in the **ACD Group Number** field and **1 matches found** is displayed in the status bar.
6. Select **Actions > Get contents**.

   *Supervisor* displays the **Call Center Admin ACD Groups Get contents** dialog.

   ![Call Center Admin ACD Groups Get contents dialog](image)

7. In the **ACD** drop-down list box, select **(none)**.

   **Note:**
   
   If you do not select the **(none)** item, only the selected item in the ACD list will be displayed in the resulting dialog if it is a member of the specified ACD Group. If it is not a member of the ACD Group, the resulting dialog will be blank.

8. From the menu bar, select **Actions > List all**.

   *Supervisor* displays the **Call Center Admin ACD Groups Get Contents List All** dialog showing all ACDs that are members of this ACD Group.

---

**Deleting an ACD from an ACD Group**

This topic provides the procedure for removing an ACD from an ACD Group.

**Before you begin**

Before performing this procedure, you should ensure that you have read and understood **Before you begin** on page 246.
Steps
To remove an ACD from an ACD Group:

1. From the Controller Window, select **Commands > Call Center Administration**. 
   *Supervisor* displays the **Call Center Administration** window.

   ![Call Center Administration window]

2. In the **Operations:** list, highlight **ACD Groups**.

3. Select **OK**.
   *Supervisor* displays the **Call Center Administration ACD Groups** window.

   ![Call Center Admin ACD Groups window]

4. In the **ACD Group Name:** field, enter the name of the ACD Group from which you want to delete a member ACD.

   **Note:**
   If you are unsure of the name of the ACD Group, use the procedure, **Listing all ACD Groups** on page 250.
5. From the menu bar, select **Actions > Get contents**.

   *Supervisor* displays the **Call Center Admin ACD Groups Get contents** dialog.

6. In the **ACD** drop-down list box, select the ACD to remove from this ACD Group.

   **Note:**
   
   If a CMS user does not have read and write permissions for an ACD, that ACD will not appear in this list. To view all of the ACDs assigned to this ACD Group, see **Viewing the contents of an ACD Group** on page 252.

7. From the menu bar, select **Actions > Find one**.

   If the select ACD is a member of the specified ACD Group, **1 matches found** is displayed in the status bar.

8. Select **Actions > Delete**.

   The selected ACD is removed from the specified ACD Group and *Supervisor* displays a message box asking if the synonyms assigned to this ACD should be removed as well.

9. Select the **Yes** button to remove all synonyms that were assigned to this ACD through ACD Group administration. Otherwise, select **No** to preserve all synonyms on the ACD.

---

**Modifying an ACD Group**

This topic provides the procedure for modifying the name of an existing ACD Group.
Steps

To modify the name of an existing ACD Group:

1. From the Controller Window, select **Commands > Call Center Administration**.
   
   *Supervisor* displays the **Call Center Administration** window.

![Call Center Administration Window](image)

2. In the **Operations** list, highlight **ACD Groups**.

3. Select **OK**.
   
   *Supervisor* displays the **Call Center Administration ACD Groups** window.

![Call Center Admin: ACD Groups Window](image)

4. In the ACD Group Name: field, enter the name of the ACD Group to change.
   
   If you do not know the name of the ACD Group, use the procedure, [Listing all ACD Groups](#) on page 250.

5. From the menu bar, select **Actions > Find One**.
   
   If the ACD Group name is valid, its numeric ID is displayed in the **ACD Group Number** field and **1 matches found** is displayed in the status bar.

6. In the ACD Group Name field, change the name of this ACD Group
   
   See [Before you begin](#) on page 246 for information on naming conventions.
When you have finished changing the name of the ACD Group, select **Actions > Modify** from the menu bar.

The modification for the ACD Group is made to the CMS database and **Successful** is displayed in the status bar.

---

**Deleting an ACD Group**

This topic provides the procedure for deleting an existing ACD Group.

**Before you begin**

Before performing this procedure, you should ensure that you have read and understood **Before you begin** on page 246.

**Steps**

To remove an ACD Group from the CMS server:

1. From the Controller Window, select **Commands > Call Center Administration**.

   **Supervisor** displays the **Call Center Administration** window.

2. In the **Operations: list**, highlight **ACD Groups**.
3. Select **OK**.

   *Supervisor* displays the **Call Center Administration ACD Groups** window.

4. In the **ACD Group Name:** field, enter the name of the ACD Group to delete.

   If you do not know the name of the ACD Group, you can find it using the procedure, [Listing all ACD Groups](#) on page 250.

5. Select **Actions > Find One** from the menu bar.

   If the ACD Group name is valid, its numeric ID is displayed in the **ACD Group Number** field and **1 matches found** is displayed in the status bar.

6. Select **Actions > Delete**.

   The specified ACD Group is deleted from the CMS server.
Call work codes

A call work code is a number that represents a particular call type or activity to track in the contact center, for example, promotional ads, complaints, or repeat orders. Agents use the dial pad on their voice terminal to enter call work codes. This information is sent to CMS for management reporting and can then be viewed in the call work code and call record historical reports.

Note:
Some telephony applications that are used on PCs require that digits be entered through the software interface instead of the dial pad on the voice terminal.

This section contains the following topics:

- **Before you begin** on page 260
- **Permissions** on page 261
- **Adding call work codes** on page 261
- **Viewing call work codes** on page 263
- **Listing all call work codes** on page 264
- **Deleting call work codes** on page 265

Before you begin

The following items should be read and understood before beginning to work with call work codes:

- Call work codes must be positive integers with 1 to 16 digits. Names can be assigned in the Dictionary to call work codes that consist of nine digits or less. It is recommended that a fixed number of digits be used consistently for all call work codes. The use of a consistent number of digits makes it easier to add, delete, and search for call work codes.

- Call work code 0 is always assigned and is used to collect information on unassigned call work codes. Call work code 0 cannot be deleted. If an agent enters an unassigned call work code, it is displayed as code 0 on the call work code report. If a call work code exception is defined, the agent exceptions historical report shows the agents who entered invalid or unassigned call work codes.

- Disk space must be allocated for call work codes before they can be used. Call work codes are assigned to a specific ACD. The number of call work codes that can be assigned depends on the Data Storage Allocation settings for the ACD. See Data Storage Allocation on page 471 for more information.
● Daily, weekly, and monthly standard historical reports are available for call work codes. Call work codes also appear on the standard historical call record report. See the Avaya CMS Supervisor Reports document for more information.

● For standard call work code reports, the codes are assigned in the Call Work Codes window.

● To have a name refer to a call work code in a report instead of its numerical code, the name must first be assigned in the Dictionary.

Permissions

Depending on the procedure to be performed, the following permissions are needed:

● To view call work codes, the user ID used to log in to this Supervisor session requires read permission for the Call Center Administration subsystem.

● To add or delete call work codes, the user ID used to log in to this Supervisor session requires read and write permission for the Call Center Administration subsystem.

Adding call work codes

This section provides the procedure for adding a call work code for use in a contact center.

Steps

To add a call work code:

1. From the Controller Window, select Commands > Call Center Administration. Supervisor displays the Call Center Administration window.
2. In the **Operations**: list, highlight **Call Work Codes**.

3. Select **OK**.

   *Supervisor* displays the **Call Work Codes** window.

The following fields are displayed in the **Call Work Codes** window:

- **Number of codes allocated**: Total number of call work codes that exist in the *CMS* database
- **Number of codes administered**: Total number of call work codes currently in use
- **Call work code(s)**: Used to specify a call work code that will receive an action

4. Enter the new call work code in the **Call work code(s)**: field.

5. Select **Actions > Add**.

   The status bar displays **Successful** if the call work code is added to the *CMS* database.
Viewing call work codes

This section provides the procedure for viewing an existing call work code.

Steps
To view a call work code:

1. From the Controller Window, select **Commands > Call Center Administration**.
   
   *Supervisor* displays the **Call Center Administration** window.

2. In the **Operations**: list, highlight **Call Work Codes**.
3. Select **OK**.
   
   *Supervisor* displays the **Call Work Codes** window.

4. Enter the call work code to view in the **Call work code(s)**: field.
5. Select **Actions > Find one**.
   
   If the call work code exists in the **CMS** database, the status bar displays the message, **1 matches found**.
Listing all call work codes

This section provides the procedure for listing all existing call work codes.

Steps

To list all call work codes in the CMS database:

1. From the Controller Window, select **Commands > Call Center Administration**.
   
   *Supervisor* displays the **Call Center Administration** window.

2. In the **Operations** list, highlight **Call Work Codes**.

3. Select **OK**.
   
   *Supervisor* displays the **Call Work Codes** window.

4. Select **Actions > List all**.
   
   *Supervisor* displays a secondary window that lists all call work codes having a synonym in the Dictionary.
Deleting call work codes

This section provides the procedure for deleting a call work code from the CMS database.

Steps

To delete a call work code:

1. From the Controller Window, select **Commands > Call Center Administration**.
   
   *Supervisor* displays the **Call Center Administration** window.

2. In the **Operations:** list, highlight **Call Work Codes**.

3. Select **OK**.
   
   *Supervisor* displays the **Call Work Codes** window.

4. Enter the call work code that you want to delete in the **Call work code(s):** field.

5. Select **Actions > Find one**.

   If the specified call work code is found in the CMS database, the status bar displays the message, **1 matches found**.
6. Select **Actions > Delete**.

   The status bar displays **Successful** if the call work code is deleted from the CMS database.
VDN skill preferences

A Vector Directory Number (VDN) is an extension number that enables calls to connect to a vector for processing. A VDN is not assigned an equipment location, but is assigned to a vector. A VDN can connect calls to a vector when the calls arrive over an assigned automatic-in trunk group or when calls arrive over a dial-repeating, Direct-Inward-Dialing (DID) trunk group and the final digits match the VDN. The VDN, by itself, may be dialed to access the vector from any extension that is connected to the switch.

Calls use VDN skills for routing based on the preferences that are assigned. The skill preferences are used in the assigned vector as 1st, 2nd, and 3rd.

This section describes the procedures to change the first, second, and third skill preferences assigned to a VDN. You can also list the currently assigned skill preferences for VDNs as well as list all the VDNs that currently have skill preferences assigned to them.

This section contains the following topics:
- Before you begin on page 267
- Permissions on page 268
- Changing VDN skill preferences on page 268
- Viewing VDN skill preferences on page 269
- Listing all VDN skill preferences on page 271

Before you begin

The following items should be read and understood before working with VDN skill preferences:

- You can only work with VDN skill preferences on a Communication Manager system and the Expert Agent Selection (EAS) feature is present and activated.
- When VDN skill preferences are changed through Supervisor, the change takes place immediately on the Communication Manager system. This can affect the processing of calls at the time of the change.
- If the changes to VDN skill preferences should occur at a specific time, they can be run through scripts that can then be scheduled through a third-party scheduling application.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view current VDN skill preferences, the user ID used to log in to this Supervisor session requires read permission for the Call Center Administration subsystem and the affected VDNs.

- To change VDN skill preferences, the user ID used to log in to this Supervisor session requires write permission for the Call Center Administration subsystem and the affected VDNs.

Changing VDN skill preferences

This section provides the procedure for changing skill preferences for a VDN. This feature is only available on Communication Manager systems with the Expert Agent Selection (EAS) feature.

Steps

To change a VDN skill preference:

1. From the Controller Window, select Commands > Call Center Administration. Supervisor displays the Call Center Administration window.

2. In the ACD: field, select the ACD on which VDN skill preferences will be changed.

3. In the Operations: list, highlight Change VDN Skill Preferences.
4. Select **OK**.

   *Supervisor* displays the **Change VDN Skill Preferences** window.

5. In the **VDN(s):** field, enter the VDN for which skill preferences are to be changed.

6. From the **Actions** menu, select **Find one**.

   The status bar displays a successful message if the VDN was found.

7. Enter skill preferences for the VDN in the **1st:**, **2nd:**, and **3rd:** fields using one of the following methods:
   
   - Enter the skill name or number.
   - Select the skill name or number from the drop-down list.
   - Use the Browse button at the right of each field to select a skill.

8. Select **Actions > Modify**.

   The status bar displays a successful message when the operation completes.

---

**Viewing VDN skill preferences**

This section provides the procedure for viewing skill preferences for a VDN. This feature is only available on Communication Manager systems with the Expert Agent Selection (EAS) feature.
Steps
To view one or more existing VDN skill preferences:

1. From the Controller Window, select **Commands > Call Center Administration**.
   *Supervisor* displays the **Call Center Administration** window.

2. In the **ACD**: field, select the ACD on which VDN skill preferences will be viewed.

3. In the **Operations**: list, highlight **Change VDN Skill Preferences**.

4. Select **OK**.
   *Supervisor* displays the **Change VDN Skill Preferences** window.

5. In the **VDN(s)**: field, enter the VDN for which skill preferences are to be viewed.

6. From the **Actions** menu, select **Find one**.
   The status bar displays a successful message if the VDN was found and lists the skill preferences, if any exist for this VDN.
Listing all VDN skill preferences

This section provides the procedure for listing all skill preferences for a VDN. This feature is only available on switches with the Expert Agent Selection (EAS) feature.

Steps
To list all VDN skill preferences:

1. From the Controller Window, select **Commands > Call Center Administration**.
   
   *Supervisor* displays the **Call Center Administration** window.

   ![Call Center Administration window](image)

2. In the **ACD**: field, select the ACD on which the VDNs and their skill preferences will be viewed.

3. In the **Operations**: list, highlight **Change VDN Skill Preferences**.

4. Select **OK**.
   
   *Supervisor* displays the **Change VDN Skill Preferences** window.

![Change VDN Skill Preferences window](image)
5. Select **Actions > List all.**

*Supervisor* displays a window listing all VDNs on this ACD and the associated skill preferences.
Split/skill call profiles

Call profiles are settings for a split or skill that assist in determining how much time passes before a call is answered or abandoned. The accumulated number of seconds that have passed for an unanswered call are divided into different service-level increments. If a call surpasses the time that is allowed for the first service-level increment, it then moves to the next service-level increment. This information is recorded for each call and can later be viewed through the split/skill call profile report to determine the number of calls that were answered or abandoned in each increment.

This section contains the following topics:

- Before you begin on page 273
- Permissions on page 274
- Adding split/skill call profiles on page 274
- Viewing an existing split/skill call profile on page 276
- Modifying a split/skill call profile on page 277
- Deleting a split/skill call profile on page 279

Before you begin

The following items should be read and understood before working with split/skill call profiles:

- Each service-level increment value can be set to a different length of time in seconds.
- Each of the first nine service-level increments can have a different time length and represents a unit of wait time. The number of seconds for the second through the ninth increment must be at least 1 second greater than the number of seconds in the previous increment.
- CMS counts the calls that are either answered or abandoned within each increment and shows the totals on split/skill call profile reports. Therefore, the settings of these increments affect what is displayed in reports.
- Making changes to the service level field after data was collected with a different service level value causes reports to give inaccurate data for the Percent within Service Level value. If you must change the service level, it is best to change the value at midnight on the first day of a month so that data for the entire month is gathered using the same service level value.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view split/skill call profiles, the user ID used to log in to this Supervisor session requires read permission for the Call Center Administration subsystem and all affected splits and skills.

- To add, delete, or change a split/skill call profile, the user ID used to log in to this Supervisor session requires write permission for the Call Center Administration subsystem and all affected splits and skills.

Adding split/skill call profiles

The section provides the procedure for adding a split/skill call profile.

Steps

To add a split/skill call profile:

1. From the Controller Window, select Commands > Call Center Administration
   Supervisor displays the Call Center Administration window.

   ![Call Center Administration Window]

2. In the ACD: field, select the ACD on which the new split/skill call profile will be created.

3. In the Operations: list, highlight Split/Skill Call Profile Setup.
4. Select **OK**.

*Supervisor* displays the **Split/Skill Call Profile Setup** window.

5. In the **Split(s)/Skill(s):** field, enter the split or skill numbers or names.

6. In the **Acceptable service level:** field, enter the objective speed of answer for the splits or skills. This field represents the number of seconds for the speed of answer and can accept values from 0 to 9999. This value should be no larger than the number of seconds in the intrahour interval that is set on CMS. For example, 1800 for a half-hour intrahour interval or 3600 for an hour-long intrahour interval. You must enter a value in this field.

The following example displays how an administrator might set up a split/skill call profile:

The **Acceptable service level:** field, has been set to 1800 seconds to correspond with the intrahour interval on the CMS server.

**Inc 1** has been set for the range of 0 to 5 seconds. **Inc 2** ranges covers 5 to 15 seconds. The other service level increments continue on until **Inc 10**. This last service level increment is used in this example is for those calls that extend beyond 360 seconds. If a call is not addressed after the acceptable service level of 1800 seconds, the call is then tracked in a different CMS database category.
7. In the **Service level increments (seconds)**: fields, enter a progressively greater number of seconds in each to field. Each field can support values from 0 to 999.

If the unanswered call surpasses the time limit for an increment, it moves on to the next increment. For example, 0 to 5 to 10 to 25 represents 0 to 5 seconds, 6 to 10 seconds, and 11 to 25 seconds.

Each of the nine increments can vary in length, for example, 0 to 15, 16 to 20, 21 to 26, 27 to 38, 39 to 43, and so forth.

If these fields are not supplied with data, 0 is used for all service level increments and all calls appear in the first increment on the split/skill call profile report.

8. Select **Actions > Add**.

The status bar displays a message stating if the operation succeeded or failed.

---

**Viewing an existing split/skill call profile**

This section provides the procedure for viewing a split/skill call profile that already exists.

**Steps**

To view an existing split/skill call profile:

1. From the Controller Window, select **Commands > Call Center Administration**.

   **Supervisor** displays the **Call Center Administration** window.

   ![Call Center Administration Window](image)

2. In the **ACD**: field, select the ACD on which the existing split/skill call profile resides.

3. In the **Operations**: list, highlight **Split/Skill Call Profile Setup**.
4. Select **OK**.  
*Supervisor* displays the **Split/Skill Call Profile Setup** window.

5. In the **Split(s)/Skill(s):** field, enter the split or skill that is represented by the call profile to view.

6. From the **Actions** menu, select **Find One**.

   The status bar displays a **Successful** message if the call profile for the specified split or skill is found. Additionally, *Supervisor* populates the **Service Level Increments (seconds):** fields with the service level increments for this call profile.

---

**Modifying a split/skill call profile**

This section provides the procedure for modifying a call profile for a split or skill.
Steps

To modify a split/skill call profile:

1. From the Controller Window, select **Commands > Call Center Administration**.
   
   *Supervisor* displays the **Call Center Administration** window.

2. In the **ACD**: field, select the ACD on which the split/skill call profile to modify resides.

3. In the **Operations**: list, highlight **Split/Skill Call Profile Setup**.

4. Select **OK**.
   
   *Supervisor* displays the **Split/Skill Call Profile Setup** window.

5. In the **Split(s)/Skill(s)**: field, enter the split or skill on which the call profile to modify resides.

6. From the **Actions** menu, select **Find One**.
   
   The status bar displays a **Successful** message if the call profile for the specified split or skill is found. Additionally, *Supervisor* populates the **Service Level Increments (seconds)**: fields with the service level increments for this call profile.
7. Enter the new values in the **Acceptable service level**: or the **Service level increments (seconds)**: fields.

8. From the **Actions** menu, select **Modify**.

   The status bar displays a **Successful** message when the operation completes.

---

**Deleting a split/skill call profile**

This section provides the procedure for deleting a split/skill call profile.

**Steps**

To delete an existing split/skill call profile:

1. From the Controller Window, select **Commands > Call Center Administration**.

   **Supervisor** displays the **Call Center Administration** window.

2. In the **ACD**: field, select the ACD on which the split/skill call profile to delete resides.
3. In the **Operations** list, highlight **Split/Skill Call Profile Setup**.  
*Supervisor* displays the **Split/Skill Call Profile Setup** window.

![Call Center Admin: Split/Skill Call Profile Setup](image)

4. In the **Split(s)/Skill(s):** field, enter the split or skill on which the call profile to delete resides.

5. From the **Actions** menu, select **Find One**.

   The status bar displays a **Successful** message if the call profile for the specified split or skill is found. Additionally, *Supervisor* populates the **Service Level Increments (seconds):** fields with the service level increments for this call profile.

6. From the **Actions** menu, select **Delete**.

   *Supervisor* deletes the specified split/skill call profile and displays a **Successful** message in the status bar.
Trunk group assignments

A trunk group is a group of circuits that are assigned the same dialing digits, either a telephone number or a Direct-Inward-Dialing (DID) prefix. Trunk groups can be assigned to Vector Directory Numbers (VDNs) or non-vector-controlled splits.

This section contains the following topics:

- Before you begin on page 281
- Permissions on page 281
- Viewing all trunk group assignments on page 282
- Viewing a single trunk group assignment on page 283
- Viewing a trunk group assignment by VDN or split on page 284

Before you begin

The following items should be read and understood before working with trunk group assignments:

- Automatic-in trunk groups, such as those that are used as Listed Directory Numbers, must be assigned to VDNs or splits through an administration tool for the Communication Manager system.

- DID or dial-repeating trunks, such as those that toll-free numbers are assigned to, are not assigned to VDNs or splits since the Central Office (CO) passes VDN digits or the split extension number to the Communication Manager system. Because of this, toll-free numbers do not appear during these procedures.

- Vector-controlled splits cannot have trunk groups assigned to them because they can only receive calls through vector processing.

- The Trunk Group Assign window used in these procedures cannot be used to change trunk group assignments. Changing trunk group assignments is done through an administration tool for the Communication Manager system.

Permissions

To view trunk group assignments, the user ID used to log in to this Supervisor session requires read permission for the Call Center Administration subsystem and for all affected trunk groups, splits, and VDNs.
Viewing all trunk group assignments

This section provides the procedure for viewing all trunk group assignments.

Steps

To view all trunk group assignments:

1. From the Controller Window, select Commands > Call Center Administration. 
   
   Supervisor displays the Call Center Administration window.

2. In the ACD: field, select the ACD on which trunk group assignments are to be viewed.

3. In the Operations: list, highlight Trunk Group Assignments.

4. Select OK.
   
   Supervisor displays the Trunk Group Assign window.

5. With all fields blank, select Actions > List All.

   Supervisor displays the Trunk Group Assignments - List All window showing all trunk groups and their current assignments.

   To clear all fields of information, select Edit > Clear all.
Viewing a single trunk group assignment

This section provides the procedure for viewing the assigned VDN or split for a single trunk group.

Steps

To view the assigned VDN or split for a single trunk group:

1. From the Controller Window, select Commands > Call Center Administration. Supervisor displays the Call Center Administration window.

2. In the ACD: field, select the ACD for which trunk group assignments are to be viewed.

3. In the Operations: list, highlight Trunk Group Assignments.

4. Select OK. Supervisor displays the Call Center Admin: Trunk Group Assign window.

5. In the Trunk Groups: field, enter the trunk group for which assignments are to be viewed. More than one trunk group can be entered in this field. Multiple trunk groups must be separated with a semicolon (;).
6. Select **Actions > Find One**.

The VDN or split assignment for the specified trunk group is displayed in the corresponding field.

If a VDN or split is not assigned to this trunk group, the status bar displays **0 matches found**.

---

**Viewing a trunk group assignment by VDN or split**

This section provides the procedure for viewing the trunk group that is assigned to a specific VDN or split.

**Steps**

To view the trunk group that is assigned to a VDN or skill:

1. From the Controller Window, select **Commands > Call Center Administration**.

   *Supervisor* displays the **Call Center Administration** window.

   ![Call Center Administration Window](image)

   2. In the **ACD**: field, select the ACD for which trunk group assignments are to be viewed.

   3. In the **Operations**: list, highlight **Trunk Group Assignments**.
4. Select **OK**.

   *Supervisor* displays the **Trunk Group Assign** window.

5. Either a VDN or split can be specified to display the trunk group or groups assigned to it.

   - To display the trunk groups that are assigned to a VDN:
     
     i. In the **Select one:** group, select **VDN**.
     
     ii. Enter the VDN number or name in the field for the **VDN** option.

   - To display the trunk groups that are assigned to a split:
     
     i. In the **Select one:** group, select **Split**.
     
     ii. Enter the split number or name in the field for the **Split** option.

6. Select **Actions > Find one**.

   *Supervisor* displays the first trunk group that is assigned to the specified VDN or split in the **Trunk Groups** field. If more trunk groups are currently assigned, click the **Next** button to view them.
Trunk group members report

The trunk group members report is used to view the equipment locations of all the trunks that are in a particular trunk group. The report lists the selected trunk groups in numerical order, each trunk group's assigned name, and the equipment location of each trunk in the trunk group. If the trunk group does not have an assigned name, the Trunk Group Name field shows the trunk group number. Also, if the trunk group has no trunks assigned to it, the equipment location field is blank.

This section includes the following topics:

- **Before you begin** on page 286
- **Permissions** on page 286
- **Running a trunk group members report** on page 286

Before you begin

The following items should be read and understood before working with the trunk group members report:

- Custom or designer reports cannot be created from the trunk group members report.
- The link to the Communication Manager system must be active in order to run this report.

Permissions

To run a trunk group members report, the user ID used to log in to this Supervisor session requires read permission for the Call Center Administration subsystem and all affected trunk groups.

Running a trunk group members report

To run a trunk group members report:

1. From the Controller Window, select Commands > Call Center Administration. Supervisor displays the Call Center Administration window.
2. On the Call Center Administration window, select the Reports tab.
3. In the **ACD**: field, select the ACD for which the report will run.

4. In the **Reports**: list, highlight **Trunk Group Members**.

5. Select **OK**.

*Supervisor* displays the **Trunk Group Members** window.

6. In the **Trunk Groups**: field, enter the numbers or names of the trunk groups that are to be used in the report.

   Multiple trunk groups must be separated by a semicolon (;).

7. In the **Destination** group, select the output option of the report:
   - **View Report on Screen** - The report is displayed on the screen.
   - **Print Report on:** - Sends the report to the printer that is specified in the associated field. To change the specified printer, select the **Select printer** button located on the right side of this group.

8. Select **OK**.

*Supervisor* runs the report and sends it to the specified destination.
VDN-to-vector assignments

A Vector Directory Number (VDN) is an extension number that enables incoming calls to be connected to a vector for processing. The VDN by itself may be dialed to access the vector from any extension that is connected to the switch. Initial assignment of a VDN to a vector is done on the Communication Manager system, but can later be changed using CMS or Supervisor.

This section contains the following procedures:
- Before you begin on page 288
- Permissions on page 289
- Viewing all VDN-to-vector assignments on page 289
- Listing VDNs associated with a vector on page 290
- Modifying VDN-to-vector assignments on page 291

Before you begin

The following items should be read and understood before working with VDN-to-vector assignments:
- Changing any VDN-to-vector assignments can alter call processing
- Multiple VDNs can be assigned to the same vector.
- VDNs cannot be assigned to more than one vector.
- You cannot exit the VDN-to-vector assignment window until Supervisor receives a response to the requested change.
- Calls that are already in vector processing are not affected by a VDN-to-vector change.
- Changing the VDN-to-vector assignment affects the next call that enters the VDN.
- VDN-to-vector assignment changes that are scheduled should either be grouped together in a timetable or individually scheduled so that one assignment completes before the next assignment change request is scheduled.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view VDN-to-vector assignments, the user ID used to log in to this Supervisor session requires read permission for the Call Center Administration subsystem and for all affected VDNs and vectors.

- To modify VDN-to-vector assignments, the user ID used to log in to this Supervisor session requires write permission for the Call Center Administration subsystem and for all affect VDNs and vectors.

Viewing all VDN-to-vector assignments

This section provides the procedure to view all VDN-to-vector assignments.

Steps

To view all current VDN-to-vector assignments:

1. From the Controller Window, select **Commands** > **Call Center Administration**. 

   * Supervisor* displays the **Call Center Administration** window.

2. In the **ACD**: field, select the ACD for which VDN-to-vector assignments are to be viewed.

3. In the **Operations**: list, highlight **VDN Assignments**.
Administering the contact center configuration

4. Select **OK**.

   *Supervisor* displays the **VDN Assignments** window.

5. Select **Actions > List all** from the menu bar.

   *Supervisor* displays a secondary window that lists all VDNs for which this user ID has *read* permission.

---

**Listing VDNs associated with a vector**

This section provides the procedure for listing the VDNs that are associated with a specific vector.

**Steps**

To list the VDNs that are associated with a specific vector:

1. From the Controller Window, select **Commands > Call Center Administration**.

   *Supervisor* displays the **Call Center Administration** window.

2. In the **ACD**: field, select the ACD on which the vector resides.

3. In the **Operations**: list, highlight **VDN Assignments**.
4. Select **OK**.

*Supervisor* displays the **VDN Assignments** window.

5. In the **Vector** field, enter the name or number of the vector.

6. Select **Actions > List all** from the menu bar.

*Supervisor* displays a secondary window that lists all VDNs assigned to the specified vector.

---

### Modifying VDN-to-vector assignments

This section provides the procedure for modifying the current VDN-to-vector assignments. Remember that VDNs can only be assigned to vectors initially through administrative utilities that are available only on Communication Manager system.

**Steps**

To modify the assignment of a VDN to a vector:

1. From the Controller Window, select **Commands > Call Center Administration**.

   *Supervisor* displays the **Call Center Administration** window.

2. In the **ACD:** field, select the ACD on which the VDNs and vectors reside.
3. In the Operations: list, highlight VDN Assignments.
4. Select OK.
   Supervisor displays the VDN Assignments window.

5. In the VDNs: field, enter the name or number of the VDN that is to be reassigned.
6. Select Actions > Find one from the menu bar.
   Supervisor displays the vector to which this VDN is currently assigned in the Vector: field.
7. In the Vector: field, enter the new vector for the specified VDN.
8. Select Actions > Modify from the menu bar.
   The status bar displays a Successful message once the operation completes.
VDN call profiles

Call profiles are time ranges for a VDN that CMS uses to track how much time passes before a call is resolved by being answered, connected to a non-ACD destination, or abandoned. CMS refers to these time ranges as service-level increments. The accumulated number of seconds that pass for an unanswered call are divided into different service-level increments. If a call surpasses the time that is allowed for the first service-level increment, it then moves to the next service-level increment. This information is recorded for each call and can later be viewed through the VDN call profile reports to determine the number of calls that were addressed in each increment.

This section contains the following procedures:

- Before you begin on page 293
- Permissions on page 294
- Adding a VDN call profile on page 294
- Viewing an existing VDN call profile on page 296
- Modifying a VDN call profile on page 297
- Deleting a VDN call profile on page 299

Before you begin

The following items should be read and understood before work is done with VDN call profiles.

- When installed, CMS sets all service-level increments to 0 by default. This causes all calls to appear in the first increment on the VDN call profile report.
- Each service level can be set to different lengths of time.
- Service-level increments can only be used to categorize a call to a maximum limit of 999 seconds.
- The number of seconds for the second through the ninth increment must be at least 1 second greater than the number of seconds in the previous increment. For example, if the second increment covers the range of 5 to 10 seconds, the maximum value in the third increment must be set to 11 or greater.
- Making changes to the service level field after data was collected with another service level value causes reports to give inaccurate data for the Percent within Service Level value. If you must change the service level, it is best to change the value at midnight on the first day of a month so that data for the entire month is gathered using the same service level value.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view a VDN call profile, the user ID used to log in to this Supervisor session requires read permission for the Call Center Administration subsystem and all affected VDNs.

- To add, delete, or change a VDN call profile, the user ID used to log in to this Supervisor session requires write permission for the Call Center Administration subsystem and all affected VDNs.

Adding a VDN call profile

This section provides the procedure for adding a VDN call profile to an ACD.

Steps

To add a VDN call profile:

1. From the Controller Window, select Commands > Call Center Administration. Supervisor displays the Call Center Administration window.

2. In the ACD: field, select the ACD on which the VDN call profile will be added.

3. In the Operations: list, highlight VDN Call Profile Setup.
4. Select **OK**.

*Supervisor* displays the **VDN Call Profile Setup** window.

5. In the **VDNs**: field, enter the name or number of the VDN which will have a new call profile.

6. In the **Acceptable service level**: field, enter the maximum number of seconds in which a VDN call should be addressed.

   This value can range from 0 to 3600. However, the value should be no larger than the number of seconds in the intrahour interval that is set on **CMS**, for example, 1800 for a half-hour intrahour interval or 3600 for an hour-long intrahour interval.

7. In each **Service level increments (seconds)**: field, enter a progressively larger number of seconds in each **to** field.

   The following example shows how an administrator might set up a VDN call profile:

   The **Acceptable service level**: field, is set to 1800 seconds to correspond with the intrahour interval that is used on the **CMS** server.

   **Inc 1** is set to a range of 0 to 5 seconds. **Inc 2** ranges is set to a range of 5 to 15 seconds. If the call is not resolved, **CMS** continues to process the call through the other service-level increments until **Inc 10**. The **Inc 10** service-level increment is used in this example for those calls that extend beyond 360 seconds. If a call is not addressed after the acceptable service level of 1800 seconds, the call is then tracked in a different **CMS** database category.
8. Select Actions > Add from the menu bar.

   The status bar displays a **Successful** message when the operation completes.

---

### Viewing an existing VDN call profile

This section provides the procedure for viewing a VDN call profile that already exists on an ACD.

**Steps**

To view an existing VDN call profile:

1. From the Controller Window, select **Commands > Call Center Administration**.

   *Supervisor* displays the **Call Center Administration** window.

2. In the **ACD**: field, select the ACD on which the VDN call profile will be added.

3. In the **Operations**: list, highlight **VDN Call Profile Setup**.

   ![Call Center Administration window]

296   CMS Administration
4. Select OK.

*Supervisor* displays the **VDN Call Profile Setup** window.

![VDN Call Profile Setup Window](image)

5. In the **VDNs:** field, enter the name or number of the VDN for which the associated call profile is to be viewed.

6. Select **Actions** > **Find one** from the menu bar.

*Supervisor* populates the remaining fields on the **VDN Call Profile Setup** window with the call profile settings for this VDN. If no call profile has been created for this VDN, the **Service level increments (seconds):** values are set to 0.

---

**Modifying a VDN call profile**

This section provides the procedure for modifying a VDN call profile that already exists on an ACD.
Administering the contact center configuration

Steps
To modifying an existing VDN call profile:

1. From the Controller Window, select Commands > Call Center Administration.
   Supervisor displays the Call Center Administration window.

2. In the ACD: field, select the ACD on which the VDN call profile will be modified.

3. In the Operations: list, highlight VDN Call Profile Setup.

4. Select OK.
   Supervisor displays the VDN Call Profile Setup window.

5. In the VDNs: field, enter the name or number of the VDN for which the associated call profile is to be modified.

6. Select Actions > Find one from the menu bar.
   Supervisor populates the remaining fields on the VDN Call Profile Setup window with the call profile settings for this VDN. If no call profile has been created for this VDN, the Service level increments (seconds): values are set to 0.

7. Enter new values in the appropriate fields:
● Enter a new value in the **Acceptable service level** field to match the intrahour interval that is set on the CMS server.
● Enter new ranges of time in the **Service level increments (seconds)**: fields as needed.

8. Select **Actions > Modify** from the menu bar.

The status bar displays a **Successful** message when the operation completes.

---

**Deleting a VDN call profile**

This section provides the procedure for deleting an existing VDN call profile on an ACD.

**Steps**

To delete an existing VDN call profile:

1. From the Controller Window, select **Commands > Call Center Administration**.

   *Supervisor* displays the **Call Center Administration** window.

2. In the **ACD** field, select the ACD on which the VDN call profile will be deleted.

3. In the **Operations** list, highlight **VDN Call Profile Setup**.
Administering the contact center configuration

4. Select **OK**.

   *Supervisor* displays the **VDN Call Profile Setup** window.

   ![VDN Call Profile Setup Window]

5. In the **VDNs**: field, enter the name or number of the VDN for which the associated call profile is to be deleted.

6. Select **Actions > Find one** from the menu bar.

   *Supervisor* displays the call profile data for the selected VDN in the **Acceptable service level:** and **Service level increments (seconds):** fields.

7. Select **Actions > Delete** from the menu bar.

   The status bar displays a **Successful** message when the operation completes.
Vector configuration report

Vector configuration reports display the following items that are associated with a vector:

- Trunk group
- Trunk group name
- VDN
- VDN name
- Vector
- Vector name
- 1st, 2nd, and 3rd skill preferences
- 1st, 2nd, and 3rd skill names

This section contains the following topics:

- Before you begin on page 301
- Permissions on page 302
- Running vector configuration reports on page 302

Before you begin

The following items should be read and understood before running vector configuration reports:

- A vector may appear in a report even if it is not associated with a trunk group or VDN.
- A vector may appear in a report even if it does not contain any steps.
- A custom or designer report cannot be created from a vector configuration report.
- A go to vector step can cause a trunk group or VDN to carry calls to another vector to which the VDN being used is not assigned. Trunk groups and VDNs that carry calls to a secondary vector in this manner do not appear in the vector configuration report for those secondary vectors.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view a vector configuration report, the user ID used to log in to this Supervisor session requires read permission for the Call Center Administration subsystem and all vectors to be listed on the report. Permissions are not required for the trunk groups and VDNs that are associated with the specified vectors.

Running vector configuration reports

This section provides the procedure for running a vector configuration report.

Steps

To run a vector configuration report:

1. From the Controller Window, select Commands > Call Center Administration. Supervisor displays the Call Center Administration window.

2. Select the Reports tab.

3. In the ACD: field, select the ACD containing the vector on which the report will be run.

4. In the Reports list, highlight Vector Configuration.
5. Select OK.

*Supervisor* displays the **Vector** window.

![Vector window](image)

6. In the **Vectors**: field, enter the name or number of the vector for which the report will be run.

Multiple vectors can be entered in this field but must be separated by a semicolon (;).

7. In the **Destination** group, select the output option of the report:

- **View Report on Screen** - The report is displayed on the screen.
- **Print Report on** - Sends the report to the printer that is specified in the associated field. To change the specified printer, select the **Select printer** button located on the right side of this group.

8. Select OK.

*Supervisor* runs the report and sends it to the specified destination.
Administering the contact center configuration
Chapter 8: Administering exceptions

This section provides the procedures for administering exceptions, running the Real-time Exception Log report, and running other exception reports for the following exception areas:

- Agent
- Split/skill
- Trunk group
- VDN
- Vector
- Data Collection
- Malicious call trace
- Real-time exceptions log

This section contains the following topics:

- About exceptions on page 306
- Before you begin on page 309
- Permissions on page 310
- Exception notification on page 311
- Agent exceptions on page 313
- Split/skill exceptions on page 327
- Trunk group exceptions on page 339
- VDN exceptions on page 350
- Vector exceptions on page 362
- Data collection exceptions report on page 373
- Malicious call trace report on page 376
- Real-time exceptions log on page 379
About exceptions

An exception is a type of activity in the ACD that falls outside the limits that have been defined and could indicate unacceptable performance. Exceptions are gathered on agents, splits/skills, trunk groups, VDNs, vectors, and unusual events such as Malicious Call Trace and disruptions in data collection. This chapter describes the operations, prerequisites, and rules for administering exceptions and the different types of exception reports that are available.

You can administer exceptions and generate reports for VDNs and vectors if your company has purchased the Call Vectoring feature.

You can administer exceptions and generate reports for skills if your company has purchased the Expert Agent Selection (EAS) feature.

This section includes the following topics:

- Types of Exceptions on page 306
- Notification on page 307
- Exception capacities on page 308

Types of Exceptions

An exception can be one of three types:

- Peg count
- Agent timed
- Other timed exceptions

Peg count exceptions

A peg count exception occurs when the number of occurrences of an ACD activity exceeds an occurrence threshold that is defined for your contact center in the current interval.

The current interval is a set number of either 15, 30, or 60 minutes. Many CMS exceptions are measured based on this interval.

Most exception conditions apply to ACD events that occur within the current interval that is defined for your contact center. When the current interval changes, ACD event occurrences are cleared and CMS begins to count event occurrences again. Therefore, your exception conditions should realistically reflect what you want to trigger an exception within your current interval.
Agent timed exceptions

Agent timed exceptions are tracked from the time that the agent logs in until the agent logs out. These exceptions can occur many times during the login period and within an interval. The exception count is cleared when the agent leaves the state that triggered the exception.

For example, an agent timed exception could be configured to occur whenever an agent spends more than 5 minutes in the AUX work mode. Then, when an agent spends longer than 5 minutes in the AUX work mode, an exception is triggered for that agent. When the agent changes to another state, such as AVAIL, the exception is reset so that it can occur again when the agent reenters the AUX work mode.

Other timed exceptions

Other timed exceptions are triggered when the number of ACD activity occurrences exceeds the minimum or maximum time limits that are set for such activity.

For example, you may set the time limit at 20 seconds for any call to wait in queue before being answered. You may then define an occurrence boundary of three for the acceptable number of calls that can wait in the queue for 20 seconds. An exception occurs if more than three calls wait in the queue longer than 20 seconds within an interval.

Timed occurrence boundaries for this type of exception apply to ACD activity within the last interval. At the beginning of the next interval, the occurrence count for any timed exception type, except for agent timed exceptions, is cleared and starts again from zero. However, since the time limit for a timed exception type can be more than 1 hour, the duration of an exception activity is not cleared at the end of the intrahour interval. CMS continues to track the time that is spent on an exception activity that continues from one interval to the next for this type of exception.

Notification

The status bar of the Supervisor Controller window shows the current exception total for both the peg count and time exceptions. This exception total is for all of the ACDs for which you have permission to view exceptions. The exception count is cleared at the end of each interval and can display a maximum number of 9999.

The PC on which Supervisor is running is, by default, configured to beep each time an exception occurs. Changing this setting can be done by selecting Options > General on the Supervisor menu bar.
Exception capacities

CMS requires that storage space be defined on the server for the purpose of recording the activities of the contact center. The recording of exceptions also uses this storage space. The following items provide information on the limits for recording exceptions:

- CMS can store a maximum of 2000 exception records of each element on all ACDs. Therefore, your contact center can store up to 2000 agent, 2000 split/skill, 2000 trunk group, 2000 VDN, and 2000 vector exception records across all ACDs.

- Exception retrieval capacity is the number of days in the past for which you can retrieve exceptions. This is determined by the following criteria:
  - The number of exception records that are allocated for storage in the Data Storage operation in the System Setup window. The maximum number of exception records of each entity that can be stored is 2000 across all ACDs.
  - The frequency with which exceptions are recorded each day. For example, if you allocate storage for 1000 exception records and approximately 100 exceptions occur each day, you can save exception records for nearly 10 days.
Before you begin

The following items should be read and understood before you begin working with exceptions:

- If an ACD Group is selected as the current ACD in the Exceptions window, only those operations that are valid for the ACD Group will appear in the Operations list.

Rules for administering exceptions

When exception thresholds are configured, the following rules must be followed:

- The occurrence threshold for any exception must be between 0 to 999.
- The time limit for timed exceptions must be between 0 to 28800 seconds.
- If a time limit is entered for an activity, an occurrence threshold for that activity must also be entered.
- When an exception is made active, CMS starts checking for the exception immediately as long as data collection is activated.
- When at least one exception is added to an entity, any future additions must be made by using the Modify item on the Action menu.
- When exceptions are being modified, the Find one menu item should always be used to retrieve the current settings for the exception before any changes are made.
- The default setting for most exceptions is off. However, the following exceptions are always active and cannot be stopped:
  - Malicious call trace
  - Data collection disruptions
  - Audio difficulty
  - Agent attempts to log in with more than one login ID
Permissions

The following table describes the permission settings that are required in order for a user to access exception information:

<table>
<thead>
<tr>
<th>Does the user have read permission for the Exceptions feature?</th>
<th>... and exceptions permission for splits/skills, trunk groups, ACDs, vectors, and VDNs?</th>
<th>Then, the user can use the following exception information:</th>
</tr>
</thead>
</table>
| yes                                                           | yes                                                                               | ● Exception reports  
● Messages in the Real-Time Exception Log  
● Real-time notification of exceptions |
| yes                                                           | no                                                                                 | ● Exceptions reports |
| no                                                            | yes                                                                               | ● Real-time notification of exceptions |
| no                                                            | no                                                                                 | ● No exceptions features available to this user |

Setting the exception permissions for these entities can be done through Tools > User Permissions on the Supervisor Controller window.

Other permissions

To set up or change the method in which the system checks for exceptions, the user ID used to log in to this Supervisor session requires the write permission for the Exceptions feature.

To be notified of a malicious call exception, the user ID used to log in to this Supervisor session requires the exception permission for the appropriate contact center entity.
Exception notification

An exception notification is a beep that is sounded by Supervisor when an exception is encountered. By default, this occurs when the user who is currently logged in to Supervisor has the exceptions permission for the entity on which the exception occurred. If you do not want Supervisor to beep when an exception occurs, follow the procedure in this section.

This section contains the following topic:

● Changing exception notification on page 311

Changing exception notification

This section provides the procedure for changing whether the beep notification is sounded when an exception occurs.

Steps

To change the exception notification:

1. From the Controller window, select Tools > Options.

   Supervisor displays the Options window.

2. Select the General tab.

3. Perform one of the following actions:

   ● To activate exception notification, place a check mark in the Use Sound check box.
Administering exceptions

- To turn off exception notification, remove the check mark in the **Use Sound** check box.

4. Select **OK**.
Agent exceptions

Agent exceptions can occur for many different activities in relation to an agent. These can include the amount of time on a call or in a work state, the number of calls that an agent has in queue, and other activities. This section provides the procedure for configuring if and when these exceptions are checked by CMS.

This section contains the following topics:

- Before you begin on page 313
- Permissions on page 313
- Adding agent exceptions on page 314
- Modifying agent exceptions on page 316
- Deleting agent exceptions on page 318
- Agent exception definitions on page 321
- Agent exceptions report on page 323

Before you begin

The following items should be read and understood before working with agent exceptions:

- Agent exceptions are assigned per split/skill and not for each agent. When an agent logs into a split/skill, any exceptions that are configured for that split/skill are applied to the agent.

- External outbound exceptions are a subset of outbound exceptions. If both types of exceptions are administered, the limit for external outbound covers external outbound calls and the limit for outbound covers only internal outbound calls.

- The agent exceptions record for a split/skill are not created by default in the CMS database when the split/skill is created. If a split/skill does not have agent exceptions, an Add action must be taken to create the associated agent exceptions record.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view agent exceptions, the user ID used to log in to this Supervisor session requires read permission for the Exceptions subsystem and all affected splits/skills as well as the exceptions permission for the affected splits/skills.
Administering exceptions

To add, delete, or modify agent exceptions, the user ID used to log in to this Supervisor session requires write permission for the Exceptions subsystem and all affected split/skills as well as the exceptions permission for the affected splits/skills.

Adding agent exceptions

This section provides the procedure for adding agent exceptions for a split/skill.

Steps

To add agent exceptions for a split/skill:

1. From the Controller window, select Commands > Exceptions on the menu bar. 
   Supervisor displays the Exceptions window.

2. In the ACD: field, select the ACD for the split/skill where agent exceptions are to be created.

3. In the Operations: list, highlight Agent Exceptions.

   Note:
   If you need to add agent exceptions for AUX reason codes 10 through 99, select the appropriate operation:
   
   ● Agent Exceptions Reason Codes 0-49
   ● Agent Exceptions Reason Codes 50-99
4. Select **OK**.

*Supervisor* displays the **Agent Exceptions Administration** window.

This window appears with all fields blank when first opened.

**Note:**

This is a scrolling dialog box that contains more exceptions than those shown in the above graphic. Use the scroll bar on the right side of the dialog box to view the other exceptions.

5. In the **Split(s)/Skill(s):** field, enter the name or number of the split/skill for which an agent exceptions configuration is to be created.

The **Split(s)/Skill(s):** field can accept multiple entries. Each entry must be separated by a semicolon (,);

6. Perform the following actions in the specified fields for each **Exception Type** that you want to monitor:

- **Active** - Place a check mark in this check box to enable the exception and allow it to run and adhere to the parameters that are given in the other fields. Leaving this check box blank disables the exception and **CMS** will not attempt to track the activity for this exception.

- **Time Limit** - Enter the time limit in seconds (0 to 28800) for those exception types that use a time limit. This value is used as the minimum or maximum amount of time for an activity depending on the type of exception. If this limit is surpassed, **CMS**
counts this activity and compares it against the **Threshold** field. This field requires an entry and cannot be left blank.

- **Threshold** - Enter the number of acceptable occurrences of this activity (0 to 999). Any occurrences beyond this number will generate an exception. If you want CMS to create an exception on the very first instance, enter 0 in this field. This field requires an entry and cannot be left blank.

7. When all necessary time limits and thresholds have been entered, select **Actions > Add** from the menu bar.

The exception configuration data will be saved for this split/skill and the status bar displays a **Successful** message.

---

### Modifying agent exceptions

This section provides the procedure for modifying the existing agent exception configuration for a split/skill.

**Steps**

To modify an existing agent exception configuration:

1. From the Controller window, select **Commands > Exceptions**. **Supervisor** displays the **Exceptions** window.

![Exception Configuration Window](image)

2. In the **ACD:** field, select the ACD on which the split/skill to modify for agent exceptions resides.

3. In the **Operations:** list, highlight **Agent Exceptions**.
Note:
If you need to add agent exceptions for AUX reason codes 10 through 99, select the appropriate operation:

- Agent Exceptions Reason Codes 0-49
- Agent Exceptions Reason Codes 50-99

4. Select OK. 

*Supervisor* displays the **Agent Exceptions Administration** window.

Note:
This is a scrolling dialog that contains more exceptions than those shown in the above graphic. Use the scroll bar on the right side of the dialog to view the other exceptions.

5. In the **Split(s)/Skill(s):** field, enter the name or number of the split/skill for which the agent exceptions configuration is to be modified.

6. From the menu bar, select **Actions > Find one**.

*Supervisor* locates the agent exception configuration for the specified split/skill and displays the data in the appropriate fields. If the exception configuration data cannot be found, the status bar displays **0 matches found**.

To return all splits/skills, leave the **Split(s)/Skill(s):** field blank before performing the **Find one** action. *Supervisor* will return all split(s)/skill(s) for which you have the **read**
Administering exceptions

permission. You can then use the Next and Previous menu actions to cycle through the splits/skills.

7. Perform the following actions in the specified fields for each Exception Type that you want to monitor:

- **Active** - Place a check mark in this check box to enable the exception and allow it to run and adhere to the parameters that are given in the other fields. Leaving this check box blank disables the exception and CMS will not attempt to track the activity for this exception.

- **Time Limit** - Enter the time limit in seconds (0 to 28800) for those exception types that use a time limit. This value is used as the minimum or maximum amount of time for an activity depending on the type of exception. If this limit is surpassed, CMS counts this activity and compares it against the **Threshold** field. This field requires an entry and cannot be left blank.

- **Threshold** - Enter the number of acceptable occurrences of this activity (0 to 999). Any occurrences beyond this number will generate an exception. If you want CMS to create an exception on the very first instance, enter 0 in this field. This field requires an entry and cannot be left blank.

8. When all necessary time limits and thresholds have been modified, select **Actions > Modify** from the menu bar.

Supervisor updates the data for this split/skill and displays a Successful message in the status bar.

Deleting agent exceptions

This section provides the procedure for deleting the agent exceptions for a split/skill.
Steps

To delete agent exceptions:

1. From the Controller Window, select **Commands > Exceptions**.
   
   *Supervisor* displays the **Exceptions** window.

2. In the **ACD**: field, select the ACD on which the split/skill to delete resides.

3. In the **Operations**: list, highlight **Agent Exceptions**.

   **Note:**
   
   If you need to add agent exceptions for AUX reason codes 10 through 99, select the appropriate operation:

   - **Agent Exceptions Reason Codes 0-49**
   - **Agent Exceptions Reason Codes 50-99**
4. Select **OK**.

*Supervisor* displays the **Agent Exceptions Administration** window.

![Agent Exceptions Administration Window](image)

**Note:**

This is a scrolling dialog that contains more exceptions than those shown in the above graphic. Use the scroll bar on the right side of the dialog to view the other exceptions.

5. In the **Split(s)/Skill(s):** field, enter the name or number of the split/skill for which an agent exceptions configuration is to be deleted.

6. From the menu bar, select **Actions > Find one**.

*Supervisor* locates the agent exception configuration for the specified split/skill and displays the data in the appropriate fields. If exception configuration data cannot be found, the status bar displays **0 matches found**.

To return all splits/skills, leave the **Split(s):/Skill(s):** field blank before performing the **Find one** action. *Supervisor* will return all split(s)/skill(s) for which you have the *read* permission. You can then use the **Next** and **Previous** menu actions to cycle through the splits/skills.

7. From the menu bar, select **Actions > Delete**.

*Supervisor* deletes the agent exception configuration for this split/skill from the CMS database and displays a **Successful** message in the status bar.
## Agent exception definitions

The following table provides the definitions for the different agent exceptions:

<table>
<thead>
<tr>
<th>Exception</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time available</td>
<td>The time that an agent spends in AVAIL (this is idle time).</td>
</tr>
<tr>
<td>Time on inbound ACD call (minimum)</td>
<td>The minimum time that an agent spends on an ACD call.</td>
</tr>
<tr>
<td>Time on inbound ACD call (maximum)</td>
<td>The maximum time that an agent spends on an ACD call.</td>
</tr>
<tr>
<td>Time in after-call work (maximum)</td>
<td>The maximum time that an agent spends on after-call work.</td>
</tr>
<tr>
<td>Time on inbound ACW call (maximum)</td>
<td>The maximum time that an agent spends on an inbound call during after-call work.</td>
</tr>
<tr>
<td>Number of inbound ACW calls/agent</td>
<td>The total number of inbound calls that an agent can receive during after-call work. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Time on outbound ACW call (maximum)</td>
<td>The maximum time that an agent spends on an outbound call during after-call work.</td>
</tr>
<tr>
<td>Number of outbound ACW calls/agent</td>
<td>The total number of outbound calls that an agent can make during after-call work. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Time in AUX work (maximum)</td>
<td>The maximum time that an agent spends doing auxiliary work.</td>
</tr>
<tr>
<td>Time on inbound AUX call</td>
<td>The maximum time that an agent spends on an inbound call during auxiliary work.</td>
</tr>
<tr>
<td>Number of inbound AUX calls/agent</td>
<td>The total number of inbound calls that an agent can receive during auxiliary work. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Time on outbound AUX call (maximum)</td>
<td>The maximum time that an agent spends on an outbound call during auxiliary work.</td>
</tr>
<tr>
<td>Number of outbound AUX calls/agent</td>
<td>The total number of outbound calls that an agent can place during auxiliary work. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Time in AUX with Reason Code X (maximum)</td>
<td>The maximum time that agents can spend doing auxiliary work with Reason Code X (X is from 0 to 9 or 0 to 99).</td>
</tr>
<tr>
<td>Administering exceptions</td>
<td></td>
</tr>
<tr>
<td>--------------------------</td>
<td></td>
</tr>
<tr>
<td><strong>Login Identification</strong></td>
<td>Select <strong>Active</strong> to receive a notification of a login violation. A violation occurs when an agent attempts to log in with an ID that is not in the Dictionary or if an agent tries to log in with more than one ID at the same terminal. If you deactivate this exception, you are not notified if an agent logs in with an ID that is not in the Dictionary, but you still are notified if an agent tries to log in with more than one ID.</td>
</tr>
<tr>
<td><strong>Time on outbound ACD call (minimum)</strong></td>
<td>The minimum time that an agent spends on an outbound ACD call.</td>
</tr>
<tr>
<td><strong>Time on outbound ACD call (maximum)</strong></td>
<td>The maximum time that an agent spends on an outbound ACD call.</td>
</tr>
<tr>
<td><strong>Number calls transferred</strong></td>
<td>The maximum number of calls that an agent can transfer.</td>
</tr>
<tr>
<td><strong>Time ACD call spent on hold (maximum)</strong></td>
<td>The maximum time that an agent can put an ACD call on hold. This time value is cumulative for each call. If an agent removes a call from hold and places it back on hold again, this value is not reset.</td>
</tr>
<tr>
<td><strong>Number ACD calls placed on hold (maximum)</strong></td>
<td>The maximum number of ACD calls that an agent can put on hold. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td><strong>Number ACD calls abandoned while on hold (maximum)</strong></td>
<td>The maximum number of calls that are abandoned after being put on hold by an agent. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td><strong>Time ACD call spends ringing (maximum)</strong></td>
<td>The maximum time that a split/skill or direct agent ACD call can ring at agent's voice terminal before an exception is triggered.</td>
</tr>
<tr>
<td><strong>Ringing call automatically redirected from agent</strong></td>
<td>Select <strong>Active</strong> to be notified when an agent lets an ACD call ring at the voice terminal long enough for the switch to automatically redirect the call. You must have the <strong>Redirection on No Answer</strong> feature activated on the Communication Manager system to use this exception.</td>
</tr>
<tr>
<td><strong>Time on direct agent call (maximum)</strong></td>
<td>The maximum number of seconds that an agent spends on a direct agent ACD call.</td>
</tr>
<tr>
<td><strong>Number calls in direct agent queue (maximum)</strong></td>
<td>The maximum number of direct agent ACD calls that an agent can have waiting in queue.</td>
</tr>
<tr>
<td><strong>Time call waited in direct agent queue (maximum)</strong></td>
<td>The maximum time that any call waits in the direct agent queue.</td>
</tr>
<tr>
<td><strong>Number calls abandoned from direct agent queue (maximum)</strong></td>
<td>The maximum number of direct agent ACD calls that can leave the direct agent queue by abandoning before an exception is triggered. This exception can only be triggered once per interval.</td>
</tr>
</tbody>
</table>
## Agent exceptions

<table>
<thead>
<tr>
<th>Exception</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number calls outflowed from direct agent queue (maximum)</td>
<td>The maximum number of direct agent calls that outflow from the direct agent queue. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Time on external outbound ACW call (maximum)</td>
<td>The maximum number of seconds that an agent spends on an external outbound call during after-call work.</td>
</tr>
<tr>
<td>Number of external outbound ACW calls/agent (maximum)</td>
<td>The maximum number of external outbound calls that an agent can make while in after-call work. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Time on external outbound AUX calls (maximum)</td>
<td>The maximum number of seconds an agent spends on an external outbound call during auxiliary work.</td>
</tr>
<tr>
<td>Number external outbound AUX calls/agent (maximum)</td>
<td>The maximum number of external outbound calls that an agent can make during auxiliary work. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Agent logged out with active/held calls</td>
<td>Select <strong>Active</strong> to be notified when an agent logs out with active or held calls on the voice terminal.</td>
</tr>
<tr>
<td>Logout attempt without valid reason code</td>
<td>The acceptable number of times that an agent can enter an invalid reason code when trying to log out. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>AUX attempt without valid reason code</td>
<td>The acceptable number of times that an agent can enter an invalid AUX reason code. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Agent entered invalid call work codes</td>
<td>An exception that is pegged for CWC 0 (an agent types an unadministered call work code). This exception should be turned off if you are collecting call work codes in call records only.</td>
</tr>
</tbody>
</table>

### Agent exceptions report

Use the agent exceptions report to view exceptions that have occurred for the selected agents. For each agent exception, the report shows the time, agent, and type of exception.

### Before you begin

To be able to view data for an agent exception report, the following events must have occurred:

- One or more agent exceptions must have been activated.
- The exceptions must have occurred at some point. Otherwise, the report is blank.
- Active exceptions must be specified in the input window so that they are included in the report.
Steps

To run the agent exceptions report:

1. From the Controller window, select **Commands > Exceptions**.
   
   *Supervisor* displays the **Exceptions** window.

2. Select the **Reports** tab.

3. In the **ACD** field, select the ACD that contains the agents on which to run the report.

4. In the **Reports** list, highlight **Agent Exceptions by Location**.

5. Select **OK**.

   *Supervisor* displays the **Agent Exceptions** window.

---

**Administering exceptions**

---
6. In the **Date**: field, specify the date for the report in one of the following date formats:

- Enter the date in MM/DD/YY format, for example, **10/06/01**.
- Enter the relative date, for example, **0** for today, **-1** for yesterday, or **-7** for one week ago.
- Enter a relative date range, for example, **-9 - 0** causes the report to display data for the past ten days including today.
- Select a date from the drop-down list.
- Select a date by using the Browse button.

This is a required field.

7. In the **Split/Skill**: field, enter the name or number of the split/skill to display in the report.

This is a required field.

8. In the **Agents**: field, specify the name or number of the agents to display in the report.

This is a required field.

This field accepts the specification of multiple agents. Multiple values must be separated by a semicolon (**;**).

9. In the **Order by**: field, select one of the following sorting options:

- **Agent** - The report results are sorted by agent name or number.
- **Time** - The report results are sorted by the time that the exceptions occurred.

10. In the **Exceptions**: field, select one or more exceptions to include in the report.

Select only those exceptions that are or have been activated during the date specified. If you select exceptions that have not been active during the date specified, the report does not display any data in the report.

11. In the **Destination** group, select the output option of the report:

- **View Report on Screen** - The report is displayed on the screen.
- **Print Report on** - Sends the report to the printer that is specified in the associated field. To change the specified printer, select the **Select printer** button located on the right side of this group.
12. Select **OK**. 

*Supervisor* runs the report and sends it to the specified destination.
Split/skill exceptions

Using split/skill exceptions can help identify those splits/skills that need to be adjusted to achieve more efficiency in the contact center.

Split/skill exceptions can assist you in the identification of problems in the following areas:

- The length of time that calls wait for different handling options
- The number of calls that are directed through different handling options
- The average speed with which the calls are being answered

This section contains the following topics:

- Before you begin on page 327
- Permissions on page 327
- Adding split/skill exceptions on page 328
- Modifying split/skill exceptions on page 330
- Deleting split/skill exceptions on page 332
- Split/skill exception definitions on page 334
- Split/skill exceptions report on page 335

Before you begin

The following items should be read and understood before working with split/skill exceptions:

- To administer exceptions for skills, your company must have purchased Expert Agent Selection (EAS). However, this feature is not needed to administer exceptions for splits.

- The split/skill exceptions configuration is not created by default in the CMS database when the split/skill is created. If a split/skill does not have an exceptions configuration, an Add action must be taken to create it.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view split/skill exceptions, the user ID used to log in to this Supervisor session requires read permission for the Exceptions subsystem and all affected splits/skills as well as the exceptions permission for all affected splits/skills.
Administering exceptions

- To add, delete, or modify split/skill exceptions, the user ID used to log in to this Supervisor session requires write permission for the Exceptions subsystem and all affected splits/skills as well as the exceptions permission for all affected splits/skills.

---

**Adding split/skill exceptions**

This section provides the procedure for adding split/skill exception configurations.

**Steps**

To add a split/skill exception configuration:

1. From the Controller window, select **Commands > Exceptions**.
   
   Supervisor displays the Exceptions window.

2. In the **ACD:** field, select the ACD that contains the split/skill to receive the new exception configuration.

3. In the **Operations:** list, highlight **Split/Skill Exceptions**.

---
4. Select **OK**.

*Supervisor* displays the **Split/Skill Exception Administration** window.

5. In the **Split(s)/Skill(s)**: field, enter the name or number of the split/skill for which an exceptions configuration is to be created.

6. For each **Exception Type** that should be monitored, the following fields must be configured:

   - **Active** - Place a check mark in this check box to enable the exception allowing it to run and adhere to the parameters given in the other fields. Leaving this check box blank will disable the exception and CMS will not attempt to track the activity for this exception.

   - **Time Limit** - Set the time limit in seconds (0-28800) for exception types that use a time limit. This value is used as the minimum or maximum amount of time for an activity. If this limit is surpassed, CMS will count this activity and compare it against the **Threshold** field. This field is requires an entry and cannot be left blank.

   - **Threshold** - Enter the number of acceptable occurrences of this activity (0-999). Any occurrences beyond this number will generate an exception. If CMS should create an exception on the very first instance, enter 0 in this field. This field requires an entry and cannot be left blank.
7. When all necessary time limits and thresholds have been entered, select **Actions > Add** from the menu bar.

*Supervisor* saves the data for this split/skill and the status bar displays a **Successful** message.

---

**Modifying split/skill exceptions**

This section provides the procedure for modifying existing split/skill exception configurations.

**Steps**

To modify a split/skill exception configuration:

1. From the Controller window, select **Commands > Exceptions**.

   *Supervisor* displays the **Exceptions** window.

   ![Exceptions Window](image)

2. In the **ACD:** field, select the ACD that contains the split/skill and its exception configuration.

3. In the **Operations:** list, highlight **Split/Skill Exceptions**.
4. Select OK.

*Supervisor* displays the **Split/Skill Exception Administration** window.

5. In the **Split(s)/Skill(s):** field, enter the name or number of the split/skill for which its exceptions configuration is to be modified.

6. From the menu bar, select **Actions > Find one.**

*Supervisor* locates the exception configuration for the specified split/skill and the displays the data in the appropriate fields. If exception configuration data cannot be found, the status bar displays **0 matches found.**

To have all splits/skills returned in this step, leave the **Split(s):/Skill(s):** field blank before performing the **Find one** action. *Supervisor* will return all split(s)/skill(s) for which you have the **read** permission. You can then use the **Next** and **Previous** menu actions to cycle through the splits/skills.

7. Make the necessary changes in the following fields for each **Exception Type** that requires modification:

- **Active** - Place a check mark in this check box to enable the exception allowing it to run and adhere to the parameters given in the other fields. Leaving this check box blank will disable the exception and **CMS** will not attempt to track the activity for this exception.

- **Time Limit** - Set the time limit in seconds (0-28800) for exception types that use a time limit. This value is used as the minimum or maximum amount of time for an
Administering exceptions

activity. If this limit is surpassed, CMS will count this activity and compare it against the Threshold field. This field is requires an entry and cannot be left blank.

- Threshold - Enter the number of acceptable occurrences of this activity (0-999). Any occurrences beyond this number will generate an exception. If CMS should create an exception on the very first instance, enter 0 in this field. This field requires an entry and cannot be left blank.

8. When all necessary time limits and thresholds have been entered, select Actions > Modify from the menu bar.

Supervisor saves the data for this split/skill and the status bar displays a Successful message.

Deleting split/skill exceptions

This section provides the procedure for deleting existing split/skill exception configurations.

Steps
To delete a split/skill exception configuration:

1. From the Controller window, select Commands > Exceptions.

Supervisor displays the Exceptions window.

2. In the ACD: field, select the ACD that contains the split/skill and its exception configuration.

4. Select **OK**.

*Supervisor* displays the **Split/Skill Exception Administration** window.

5. In the **Split(s)/Skill(s):** field, enter the name or number of the split/skill for which the exception configuration is to be deleted.

6. From the menu bar, select **Actions > Find one**.

*Supervisor* locates the exception configuration for the specified split/skill and the displays the data in the appropriate fields. If exception configuration data cannot be found, the status bar displays **0 matches found**.

To have all splits/skills returned in this step, leave the **Split(s):/Skill(s):** field blank before performing the **Find one** action. *Supervisor* will return all split(s)/skill(s) for which you have the **read** permission. You can then use the **Next** and **Previous** menu actions to cycle through the splits/skills.

7. From the menu bar, select **Actions > Delete**.

*Supervisor* deletes the exception configuration for this split/skill from the **CMS** database and a displays a **Successful** message in the status bar.
## Split/skill exception definitions

The following table provides the definitions for the different split/skill exceptions:

<table>
<thead>
<tr>
<th>In this field...</th>
<th>Enter this value...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time call has waited in queue</td>
<td>The total acceptable amount of time any call in queue remains unanswered before an occurrence is counted against the threshold limit.</td>
</tr>
<tr>
<td>Number calls waiting</td>
<td>The maximum number of calls waiting in queue at any one time.</td>
</tr>
<tr>
<td>Number calls abandoned</td>
<td>The total number of acceptable abandoned calls. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Average speed of answer (seconds)</td>
<td>The maximum acceptable amount of time in seconds that a call waits in that split/skill queue before an agent answers. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number intraflowed-out calls</td>
<td>The maximum acceptable number of calls that intraflow out from or in to a split or skill. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number intraflowed-in calls</td>
<td>The acceptable number of calls that can intraflow in to the split or skill before an occurrence is counted against the threshold limit. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number interflowed-out calls</td>
<td>The acceptable number of calls that can interflow out of the split or skill. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number calls handled as backup</td>
<td>The acceptable number of calls that this split or skill can handle as a backup for another split or skill. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number calls transferred</td>
<td>The acceptable number of calls that can be transferred from this split or skill. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number calls offered while queue full</td>
<td>The acceptable number of calls that can be offered to the split or skill while the queue is full. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Expected Wait Time (pri Top) exceeds threshold</td>
<td>The maximum acceptable time in seconds that a call is expected to wait at Top priority before connecting to an agent. This exception can only be triggered once per interval.</td>
</tr>
</tbody>
</table>
The split/skill exceptions report is used to view exceptions that have occurred for the selected splits/skills. For each split/skill exception, the report shows the time and type of exception.

**Before you begin**

To be able to view data for a split/skill exception report, the following events must have occurred:

- One or more split/skill exceptions must have been activated.
- The exceptions must have occurred at some point. Otherwise, the report is blank.
- Active exceptions must be specified in the input window so that they are included in the report.
- The user ID used to run the report must have the read permission for the Exceptions subsystem and the affected splits/skills as well as the exceptions permission for all affected splits/skills.

<table>
<thead>
<tr>
<th>Expected Wait Time (pri High) exceeds threshold</th>
<th>The maximum acceptable time in seconds that a call is expected to wait at High priority before connecting to an agent. This exception can only be triggered once per interval.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expected Wait Time (pri Medium) exceeds threshold</td>
<td>The maximum acceptable time in seconds that a call is expected to wait at Med priority before connecting to an agent. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Expected Wait Time (pri Low)</td>
<td>The maximum acceptable time in seconds that a call is expected to wait at Low priority before connecting to an agent. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Rolling Average Speed of Answer</td>
<td>The maximum acceptable amount of time in seconds that is calculated for the rolling average speed of answer (ASA) for a split/skill. This exception can only be triggered once per interval. The ASA for the measured split/skill is sent to CMS by way of the ASA message. An occurrence is counted (in seconds) when CMS receives an ASA that exceeds the time limit that is specified for a split/skill. An exception is triggered when the threshold is exceeded.</td>
</tr>
</tbody>
</table>
Administering exceptions

Steps

To run the split/skill exceptions report:

1. From the Controller window, select **Commands > Exceptions**.
   
   *Supervisor* displays the **Exceptions** window.

2. Select the **Reports** tab.
3. In the **ACD**: field, select the ACD that contains the split/skill on which to run the report.
4. In the **Reports**: list, highlight **Split/Skill Exceptions**.
5. Select **OK**.
   
   *Supervisor* displays the **Split/Skill Exceptions** window.
6. In the **Date**: field, specify the date for which you want to view the report. Entry of the date can be done through the following methods:
   - Enter MM/DD/YY format; for example, **10/06/01**.
   - Enter the relative day; for example, **0** for today, **-1** for yesterday, or **-7** for one week ago.
   - Enter a relative range; for example, **-9 - 0** causes the report to display data for the past ten days including today.
   - Select a date from the drop-down list.
   - Select a date by using the Browse button.

   This is a required field.

7. In the **Splits/Skills**: field, specify the name or number of one or more splits/skills to run the report against. Entry of the split/skill can be done through the following methods:
   - Enter the name or number of the split/skill.
   - Select the split/skill from the drop-down list.
   - Select the split/skill by using the Browse button.

   Multiple splits/skills can be entered in this field, but must be separated by a semicolon (**;**). This is a required field.

8. In the **Order by**: field, select one of the following sorting options:
   - **Split/Skill** - The report results are sorted by split/skill name or number.
   - **Time** - The report results are sorted by the time the exceptions occurred.

9. In the **Exceptions**: field, select one or more exceptions to include in the report.

   Only those exceptions that have been activated in the past should be selected. Selecting exceptions that have not been activated will not return any data in the report.

10. In **Destination** group, select one of the following output options:
    - **View Report on Screen** - The report is displayed on the screen.
    - **Print Report on**: - The report is sent to the specified printer. Any printer available to the PC can be used and selected through the button at the right of the field.
11. Select **OK**.

*Supervisor* sends the report to the specified output option.
Trunk group exceptions

Trunk group exceptions are used to identify performance and capacity issues for the trunk groups in the contact center.

This section contains the following topics:

- Before you begin on page 339
- Permissions on page 339
- Adding trunk group exceptions on page 340
- Modifying trunk group exceptions on page 342
- Deleting trunk group exceptions on page 344
- Trunk group exception definitions on page 345
- Trunk group exceptions report on page 346

Before you begin

The following items should be read and understood before working with trunk group exceptions:

- An Audio Difficulty exception is associated with each trunk group. This exception is always provided for all Communication Manager systems that support event counts and it cannot be disabled. For this reason, this exception is not available on the Trunk Group Exception Administration window.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view trunk group exceptions, the user ID used to log in to this Supervisor session requires read permission for the Exceptions subsystem and all affected trunk groups as well as the exceptions permission for all affected trunk groups.

- To add, delete, or change trunk group exceptions, the user ID used to log in to this Supervisor session requires write permission for the Exceptions subsystem and all affected trunk groups as well as the exceptions permission for all affected trunk groups.
Administering exceptions

Adding trunk group exceptions

This section provides the procedure for adding an exception configuration for a trunk group.

Steps

To add exceptions for a trunk group:

1. From the Controller Window, select Commands > Exceptions.

   Supervisor displays the Exceptions window.

2. In the ACD: field, select the ACD for the trunk group that will receive the new exceptions configuration.

3. In the Operations: list, highlight Trunk Group Exceptions.
4. Select **OK**.

*Supervisor* displays the **Trunk Group Exception Administration** window.

5. In the **Trunk groups**: field, enter the name or number of the trunk group for which an exceptions configuration is to be created.

6. For each **Exception Type** that should be monitored, the following fields must be configured:

   - **Active** - Place a check mark in this check box to enable the exception allowing it to run and adhere to the parameters given in the other fields. Leaving this check box blank will disable the exception and CMS will not attempt to track the activity for this exception.

   - **Time Limit** - Set the time limit in seconds (0-28800) for exception types that use a time limit. This value is used as the minimum or maximum amount of time for an activity. If this limit is surpassed, CMS will count this activity and compare it against the **Threshold** field. This field is requires an entry and cannot be left blank.

   - **Threshold** - Enter the number of acceptable occurrences of this activity (0-999). Any occurrences beyond this number will generate an exception. If CMS should create an exception on the very first instance, enter 0 in this field. This field requires an entry and cannot be left blank.

7. When all necessary time limits and thresholds have been entered, select **Actions > Add** from the menu bar.

*Supervisor* saves the data for this trunk group and the status bar displays a **Successful** message.
Modifying trunk group exceptions

This section provides the procedure for modifying an existing exception configuration for a trunk group.

**Steps**

To modify trunk group exceptions:

1. From the Controller window, select **Commands > Exceptions**.

   *Supervisor* displays the **Exceptions** window.

2. In the **ACD**: field, select the ACD that contains the trunk group and its exception configuration.

3. In the **Operations**: list, highlight **Trunk Group Exceptions**.

![Exceptions window screenshot]
4. Select **OK**.

*Supervisor* displays the **Trunk Group Exception Administration** window.

5. In the **Trunk groups:** field, enter the name or number of the trunk group for which exception configuration is to be modified.

6. From the menu bar, select **Actions > Find one**.

*Supervisor* locates the exception configuration data for the specified trunk group and displays it in the appropriate fields. If data cannot be found for this trunk group, the status bar displays **0 matches found**.

To return all trunk groups, leave the **Trunk groups:** field blank before performing the **Find one** action. *Supervisor* will return all trunk groups for which you have the **read** permission. You can then use the **Next** and **Previous** menu actions to cycle through the trunk groups.

7. For each **Exception Type** that should be monitored, the following fields must be configured:

- **Active** - Place a check mark in this check box to enable the exception allowing it to run and adhere to the parameters given in the other fields. Leaving this check box blank will disable the exception and **CMS** will not attempt to track the activity for this exception.

- **Time Limit** - Set the time limit in seconds (0-28800) for exception types that use a time limit. This value is used as the minimum or maximum amount of time for an activity. If this limit is surpassed, **CMS** will count this activity and compare it against the **Threshold** field. This field requires an entry and cannot be left blank.

- **Threshold** - Enter the number of acceptable occurrences of this activity (0-999). Any occurrences beyond this number will generate an exception. If **CMS** should create an exception on the very first instance, enter **0** in this field. This field requires an entry and cannot be left blank.
8. When all necessary time limits and thresholds have been entered, select **Actions > Modify** from the menu bar.

*Supervisor* updates the data for this trunk group and the status bar displays a **Successful** message.

---

### Deleting trunk group exceptions

This section provides the procedure for deleting existing trunk group exception configurations.

**Steps**

To delete a trunk group exception configuration:

1. From the Controller window, select **Commands > Exceptions**.

   *Supervisor* displays the **Exceptions** window.

   ![Exceptions window](image)

2. In the **ACD**: field, select the ACD that contains the trunk group and its exception configuration.

3. In the **Operations**: list, highlight **Trunk Group Exceptions**.

---

344  CMS Administration
4. Select OK.

_Supervisor_ displays the **Trunk Group Exception Administration** window.

5. In the **Trunk groups**: field, enter the name or number of the trunk group for which the exception configuration is to be deleted.

6. From the menu bar, select **Actions > Find one**.

   The exception configuration is found for the specified trunk group and the data displays in the appropriate fields. If exception configuration data cannot be found, the status bar will display **0 matches found**.

   To return all trunk groups, leave the **Trunk groups**: field blank before performing the **Find one** action. *Supervisor* will return all trunk groups for which you have the _read_ permission. You can then use the **Next** and **Previous** menu actions to cycle through the trunk groups.

7. From the menu bar, select **Actions > Delete**.

   The exception configuration for this trunk group is deleted from the _CMS_ database and a **Successful** message displays in the status bar.

---

**Trunk group exception definitions**

The following table provides the definitions for the different trunk group exceptions:

<table>
<thead>
<tr>
<th>In this field...</th>
<th>Enter this value...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time trunk in use (minimum)</td>
<td>The minimum acceptable time in seconds that a trunk in the trunk group can be in use. This exception can only be triggered once per interval for the same trunk.</td>
</tr>
</tbody>
</table>
### Administering exceptions

<table>
<thead>
<tr>
<th>Time trunk in use (maximum)</th>
<th>The maximum acceptable time in seconds that a trunk in the trunk group can be in use. This exception can only be triggered once per interval for the same trunk.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time any trunk maintenance busy</td>
<td>The maximum acceptable time in seconds that a trunk in the trunk group can be in the maintenance busy state.</td>
</tr>
<tr>
<td>Length of time all trunks busy</td>
<td>The maximum acceptable time that all trunks in the trunk group can be busy at once. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number of trunks in use</td>
<td>The maximum acceptable number of trunks that can be in use at the same time in the trunk group. An exception is reached each time the allowed number of trunks in use exceeds the threshold within the interval.</td>
</tr>
<tr>
<td>Number of trunks maintenance busy</td>
<td>The maximum acceptable number of trunks that can be in the maintenance busy state in the trunk group. An exception is reached each time the allowed number of trunk that are in the maintenance busy state exceeds the threshold within the interval.</td>
</tr>
</tbody>
</table>

---

**Trunk group exceptions report**

Use the trunk group exceptions report to view exceptions that have occurred for the selected trunk groups. For each trunk group exception, the report shows the time and type of exception.

**Before you begin**

To be able to view data for a trunk group exception report, the following events must have occurred:

- One or more trunk group exceptions must have been activated.
- The exceptions must have occurred at some point. Otherwise, the report is blank.
- Active exceptions must be specified in the input window so that they are included in the report.
Steps
To run the trunk group exceptions report:

1. From the Controller window, select **Commands > Exceptions**.
   
   *Supervisor* displays the **Exceptions** window.

2. Select the **Reports** tab.

3. In the **ACD**: field, select the ACD that contains the trunk group on which to run the report.

4. In the **Reports**: list, highlight **Trunk Group Exceptions by Location**.

5. Select **OK**.

*Supervisor* displays the **Trunk Group Exceptions** window.
6. In the **Date**: field, specify the date to view for the report. Entry of the date can be done through the following methods:
   - Enter MM/DD/YY format; for example, **10/06/01**.
   - Enter the relative day; for example, **0** for today, **-1** for yesterday, or **-7** for one week ago.
   - Enter a relative range; for example, **-9-0** causes the report to display data for the past ten days including today.
   - Select a date from the drop-down list.
   - Select a date by using the Browse button.
   
   This is a required field.

7. In the **Trunk Groups**: field, specify the name or number of one or more trunk groups to run the report against. Entry of the trunk group can be done through the following methods:
   - Enter the name or number of the trunk group.
   - Select the trunk group from the drop-down list.
   - Select the trunk group by using the Browse button.
   
   Multiple trunk groups can be entered in this field, but must be separated by a semicolon (**;**).
   
   This is a required field.

8. In the **Order by**: field, select one of the following sorting options:
   - **Trunk Group** - The report results are sorted by trunk group number.
   - **Trunk Location** - The report results are sorted by individual trunks.
   - **Time** - The report results are sorted by the time the exceptions occurred.

9. In the **Exceptions**: field, select one or more exceptions to include in the report.
   
   Select only those exceptions that are or have been activated during the date specified. If you select exceptions that have not been active during the date specified, the report does not display any data in the report.
   
   **Audio difficulty** is a trunk group exception that can be requested on a report even though it cannot be administered in trunk group exception operations.

10. In **Destination** group, select one of the following output options:
   - **View Report on Screen** - The report is displayed on the screen.
   - **Print Report on:** - The report is sent to the specified printer. Any printer available to the PC can be used and selected through the button at the right of the field.
11. Select **OK**.

*Supervisor* sends the report to the specified output option.
VDN exceptions

Use Vector Directory Number (VDN) exceptions to assist in the identification of problems in the following areas:

- The amount of time calls that remain in the vector or at an agent
- The number of calls that reach specific states, such as disconnected, busy, and abandoned
- The number of calls that are routed in or out of the VDN and if they are successful

This section contains the following topics:

- Before you begin on page 350
- Permissions on page 351
- Adding VDN exceptions on page 351
- Modifying VDN exceptions on page 353
- Deleting VDN exceptions on page 355
- VDN exception definitions on page 357
- VDN exceptions report on page 358

Before you begin

The following items should be read and understood before working with VDN exceptions:

- To administer VDN exceptions, your company must have purchased and installed the Call Vectoring feature.

- Because of the routing that is permitted by the go to vector command, the Time in vector exception may include the time that a call spends in more than one vector.

- CMS begins to monitor for VDN exceptions when a call connects to the VDN and stops when the call is disconnected, sent to another VDN, sent to an external destination, or transferred. The call remains connected to the VDN if one of the following circumstances is encountered:
  - The call routes to another vector through a go to vector step.
  - The call is sent through a route to or adjunct routing step to a non-VDN extension that is internal to the local Communication Manager system.

- If a large number of VDNs exist in the Dictionary (over 2000), there can be lengthy waiting periods when you browse for VDNs through Supervisor.
Some exception types require that an appropriate step exists in the vector to which the VDN is assigned. For example, to get exceptions on unsuccessful Look Ahead Interflow attempts, the vector for the VDN must have at least one route to step that routes calls to a vector on a remote switch.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view VDN exceptions, the user ID used to log in to this Supervisor session requires read permission for the Exceptions subsystem and all affected VDNs as well as the exceptions permission for all affected VDNs.
- To add, delete, or change VDN exceptions, the user ID used to log in to this Supervisor session requires write permission for the Exceptions subsystem and all affected VDNs as well as the exceptions permissions for all affected VDNs.

Adding VDN exceptions

This section provides the procedure for adding an exceptions configuration to a VDN.

Steps

To add an exceptions configuration to a VDN:

1. From the Controller window, select **Commands > Exceptions**. Supervisor displays the **Exceptions** window.

2. In the **ACD:** field, select the ACD that contains the VDN that will receive the new exceptions configuration.
3. In the **Operations** list, highlight **VDN Exceptions**.

4. Select **OK**. 

   *Supervisor* displays the **VDN Exception Administration** window.

5. In the **VDNs** field, enter the name or number of the VDN for which the exceptions configuration is to be created.

6. For each **Exception Type** that should be monitored, the following fields must be configured:

   - **Active** - Place a check mark in this check box to enable the exception allowing it to run and adhere to the parameters given in the other fields. Leaving this check box blank will disable the exception and *CMS* will not attempt to track the activity for this exception.
   - **Time Limit** - Set the time limit in seconds (0-28800) for exception types that use a time limit. This value is used as the minimum or maximum amount of time for an activity. If this limit is surpassed, *CMS* will count this activity and compare it against the **Threshold** field. This field requires an entry and cannot be left blank.
   - **Threshold** - Enter the number of acceptable occurrences of this activity (0-999). Any occurrences beyond this number will generate an exception. If *CMS* should create an exception on the very first instance, enter 0 in this field. This field requires an entry and cannot be left blank.
7. When all necessary time limits and thresholds have been entered, select **Actions** > **Add** from the menu bar.

*Supervisor* saves the data for this VDN exception configuration and the status bar displays a **Successful** message.

---

### Modifying VDN exceptions

This section provides the procedure for modifying an existing exception configuration for a VDN.

**Steps**

To modify VDN exceptions:

1. From the Controller window, select **Commands** > **Exceptions**.

   *Supervisor* displays the **Exceptions** window.

   ![Exceptions Window](image)

2. In the **ACD**: field, select the ACD that contains the VDN and its exception configuration.

3. In the **Operations**: list, highlight **VDN Exceptions**.
4. Select OK.

*Supervisor* displays the **VDN Exception Administration** window.

5. In the **VDNs:** field, enter the name or number of the VDN for which exception configuration is to be modified.

6. From the menu bar, select **Actions > Find one.**

*Supervisor* locates the exception configuration data for the specified VDN and displays it in the appropriate fields. If exception configuration data cannot be found for this VDN, the status bar displays **0 matches found.**

To have all VDNs returned in this step, leave the **VDNs:** field blank before performing the **Find one** action. *Supervisor* will return all VDNs for which you have the *read* permission. You can then use the **Next** and **Previous** menu actions to cycle through the VDNs.

7. For each **Exception Type** that should be monitored, the following fields must be configured:

- **Active** - Place a check mark in this check box to enable the exception allowing it to run and adhere to the parameters given in the other fields. Leaving this check box blank will disable the exception and **CMS** will not attempt to track the activity for this exception.

- **Time Limit** - Set the time limit in seconds (0-28800) for exception types that use a time limit. This value is used as the minimum or maximum amount of time for an
activity. If this limit is surpassed, CMS will count this activity and compare it against the Threshold field. This field requires an entry and cannot be left blank.

- **Threshold** - Enter the number of acceptable occurrences of this activity (0-999). Any occurrences beyond this number will generate an exception. If CMS should create an exception on the very first instance, enter 0 in this field. This field requires an entry and cannot be left blank.

8. When all necessary time limits and thresholds have been entered, select Actions > Modify from the menu bar.

Supervisor updates the exception configuration data for this VDN and the status bar displays a Successful message.

---

**Deleting VDN exceptions**

This section provides the procedure for deleting existing VDN exception configurations.

**Steps**

To delete a VDN exception configuration:

1. From the Controller window, select Commands > Exceptions.

Supervisor displays the Exceptions window.

2. In the ACD: field, select the ACD that contains the VDN and its exception configuration.

3. In the Operations: list, highlight VDN Exceptions.
4. Select **OK**.

*Supervisor* displays the **VDN Exception Administration** window.

5. In the **VDNs:** field, enter the name or number of the VDN for which the exception configuration is to be deleted.

6. From the menu bar, select **Actions > Find one**.

*Supervisor* locates the exception configuration for the specified VDN and the data displays in the appropriate fields. If exception configuration data cannot be found, the status bar displays **0 matches found**.

To have all VDNs returned through this step, leave the **VDNs:** field blank. *Supervisor* displays the total number of matches in the status bar. The VDNs can then be navigated by using the **Next** and **Previous** actions.

7. From the menu bar, select **Actions > Delete**.

*Supervisor* deletes the exception configuration for this VDN from the **CMS** database and displays a **Successful** message in the status bar.
## VDN exception definitions

The following table provides the definitions for the different VDN exceptions:

<table>
<thead>
<tr>
<th>In this field...</th>
<th>Enter this value...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time in Vector</td>
<td>The maximum acceptable time in seconds that a call should spend in vector processing. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Time at agent (minimum)</td>
<td>The minimum acceptable time in seconds that a call to this VDN is connected to an agent. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Time at agent (maximum)</td>
<td>The maximum acceptable time in seconds that a call to this VDN is connected to an agent. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number of calls abandoned while in vector</td>
<td>The maximum acceptable number of calls to this VDN that are abandoned before being answered during an interval. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number of calls forced busy</td>
<td>The maximum acceptable number of calls to this VDN that receive a busy signal from the switch during an interval. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number of calls disconnected</td>
<td>The maximum acceptable number of calls that are disconnected during vector processing during an interval. Disconnects can be caused by the disconnect vector command, by the vector disconnect timer, or because a call reached the end of vector processing without being queued. Calls that are disconnected after receiving a busy signal from the busy command are not included. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number of calls in an ACD split/skill queue</td>
<td>The maximum acceptable number of calls to this VDN that are in a split/skill queue.</td>
</tr>
<tr>
<td>Number of calls that flowed into VDN</td>
<td>The maximum number of calls during an interval that enter this VDN by a route-to or adjunct routing link vector step, or a transfer from a local extension. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number of calls that flowed out of VDN</td>
<td>The maximum acceptable number of calls that are routed from this VDN during an interval to another VDN or external destination. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number of calls that interflowed out of VDN</td>
<td>The maximum acceptable number of calls that are routed from this VDN to an external destination during an interval. This exception can only be triggered once per interval.</td>
</tr>
</tbody>
</table>
Administering exceptions

Use the VDN exceptions report to view exceptions that have occurred for the selected VDN. For each VDN exception, the report shows the time and type of exception.

**Before you begin**

To be able to view data for a VDN exception report, the following events must have occurred:

- One or more VDN exceptions must have been activated.
- The exceptions must have occurred at some point. Otherwise, the report is blank.
- Active exceptions must be specified in the input window so that they are included in the report.

<table>
<thead>
<tr>
<th>In this field...</th>
<th>Enter this value...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of calls handled by backup split or skill</td>
<td>The maximum acceptable number of calls to this VDN that are connected to a backup split/skill during an interval. A check backup split, check backup skill, messaging split, or messaging skill vector command causes a call to be handled by a backup split/skill. This exception cannot trigger more than once per interval.</td>
</tr>
<tr>
<td>Number of unsuccessful look ahead interflow attempts</td>
<td>The maximum acceptable number of calls to this VDN that fail to interflow to another Communication Manager system during an interval. The route-to vector command causes a call to interflow. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Number of unsuccessful adjunct routing attempts</td>
<td>The maximum acceptable number of failures of a call to this VDN to connect to an adjunct host computer during an interval. The failure of an adjunct route link vector command causes an unsuccessful adjunct routing attempt. The failure can occur because the connection to the adjunct is out of service or busy, or because the adjunct software rejects control. This exception can only be triggered once per interval.</td>
</tr>
<tr>
<td>Rolling Average Speed of Answer</td>
<td>The acceptable amount of time, in seconds, that is calculated for the rolling average speed of answer for a VDN. This exception can only be triggered once per interval.</td>
</tr>
</tbody>
</table>

**VDN exceptions report**
Steps
To run the VDN exceptions report:

1. From the Controller window, select **Commands > Exceptions**.
   
   *Supervisor* displays the **Exceptions** window.

2. Select the **Reports** tab.

3. In the **ACD**: field, select the ACD that contains the VDN on which to run the report.

4. In the **Reports**: list, highlight **VDN Exceptions by Location**.

5. Select **OK**.

*Supervisor* displays the **VDN Exceptions** window.
6. In the **Date:** field, specify the date to view for the report. Entry of the date can be done through the following methods:
   - Enter MM/DD/YY format; for example, 10/06/01.
   - Enter the relative day; for example, 0 for today, -1 for yesterday, or -7 for one week ago.
   - Enter a relative range; for example, -9-0 causes the report to display data for the past ten days including today.
   - Select a date from the drop-down list.
   - Select a date by using the Browse button.
   This is a required field.

7. In the **VDNs:** field, specify the name or number of one or more VDNs to run the report against. Entry of the VDN can be done through the following methods:
   - Enter the name or number of the VDN.
   - Select the VDN from the drop-down list.
   - Select the VDN by using the Browse button.
   Multiple VDNs can be entered in this field, but must be separated by a semicolon (;). This is a required field.

8. In the **Order by:** field, select one of the following sorting options:
   - **Time** - The report results are sorted by the time the exceptions occurred.
   - **VDN** - The report results are sorted by VDN name or number.
   - **Vector** - The report results are sorted by vector.

9. In the **Exceptions:** field, select one or more exceptions to include in the report.
   Select only those exceptions that have been activated at some point in the past. Selecting exceptions that have not been activated will not return any data in the report.

10. In **Destination** group, select one of the following output options:
    - **View Report on Screen** - The report is displayed on the screen.
    - **Print Report on:** - The report is sent to the specified printer. Any printer available to the PC can be used and selected through the button at the right of the field.
11. Select **OK**.

*Supervisor* sends the report to the specified output option.
Vector exceptions

When vector exceptions are configured and activated, CMS monitors for these exceptions when a call enters the vector and continues monitoring until the call connects to an agent, is abandoned, or is routed to another destination.

Vector exceptions can assist in the identification of problems in the following areas:

- The amount of time that a call waits in a vector
- The number of calls that are abandoned, disconnected, or forced busy while in the vector
- Numerous unsuccessful routing attempts

This section contains the following topics:

- **Before you begin** on page 362
- **Permissions** on page 363
- **Adding vector exceptions** on page 363
- **Modifying vector exceptions** on page 365
- **Deleting vector exceptions** on page 367
- **Vector exception definitions** on page 368
- **Vector exceptions report** on page 369

---

**Before you begin**

The following items should be read and understood before working with vector exceptions:

- Calls may generate some exceptions for a vector, even after the vector has given routing control to the adjunct by an **adjunct routing** vector command.

- Some exception types require that an appropriate step exists in the vector. For example, to get exceptions on unsuccessful Look Ahead Interflow attempts, the vector must have at least one **route to step** which routes calls to a remote Communication Manager system.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view vector exceptions, the user ID used to log in to this Supervisor session requires read permission for the Exceptions subsystem and all affected vectors as well as the exceptions permission for the affected vectors.
- To add, delete, or change vector exceptions, the user ID used to log in to this Supervisor session requires write permission for the Exceptions subsystem and all affected vectors as well as the exceptions permission for the affected vectors.

Adding vector exceptions

This section provides the procedure for adding an exceptions configuration for a vector.

Steps

To add a vector exception configuration:

1. From the Controller window, select Commands > Exceptions. Supervisor displays the Exceptions window.

2. In the ACD: field, select the ACD that contains the vector that will receive the new exceptions configuration.

3. In the Operations: list, highlight Vector Exceptions.
Administering exceptions

4. Select OK.

Supervisor displays the **Vector Exception Administration** window.

5. In the **Vectors**: field, enter the name or number of the vector for which an exceptions configuration is to be created.

6. For each **Exception Type** that should be monitored, the following fields must be configured:

   - **Active** - Place a check mark in this check box to enable the exception allowing it to run and adhere to the parameters given in the other fields. Leaving this check box blank will disable the exception and CMS will not attempt to track the activity for this exception.

   - **Time Limit** - Set the time limit in seconds (0-28800) for exception types that use a time limit. This value is used as the minimum or maximum amount of time for an activity. If this limit is surpassed, CMS will count this activity and compare it against the **Threshold** field. This field is requires an entry and cannot be left blank.

   - **Threshold** - Enter the number of acceptable occurrences of this activity (0-999). Any occurrences beyond this number will generate an exception. If CMS should create an exception on the very first instance, enter 0 in this field. This field requires an entry and cannot be left blank.

7. When all necessary time limits and thresholds have been entered, select **Actions > Add** from the menu bar.

Supervisor saves the data for this vector exception configuration and the displays a **Successful** message in the status bar.
Modifying vector exceptions

This section provides the procedure for modifying an existing exception configuration for a vector.

Steps

To modify vector exceptions:

1. From the Controller window, select Commands > Exceptions.

   *Supervisor* displays the Exceptions window.

2. In the ACD: field, select the ACD that contains the vector and its exception configuration.

3. In the Operations: list, highlight Vector Exceptions.
4. Select **OK**.

_Supervisor_ displays the **Vector Exception Administration** window.

5. In the **Vectors:** field, enter the name or number of the vector for which the exception configuration is to be modified.

6. From the menu bar, select **Actions > Find one**.

_Supervisor_ locates the agent exception configuration for the specified split/skill and displays the data in the appropriate fields. If the exception configuration data cannot be found, the status bar displays **0 matches found**.

To have all vectors returned when performing this step, leave the **Vectors:** field blank before performing the **Find one** action. _Supervisor_ will return all vectors for which you have the **read** permission. You can then use the **Next** and **Previous** menu actions to cycle through the vectors.

7. For each **Exception Type** that should be monitored, the following fields must be configured:

- **Active** - Place a check mark in this check box to enable the exception allowing it to run and adhere to the parameters given in the other fields. Leaving this check box blank will disable the exception and _CMS_ will not attempt to track the activity for this exception.

- **Time Limit** - Set the time limit in seconds (0-28800) for exception types that use a time limit. This value is used as the minimum or maximum amount of time for an activity. If this limit is surpassed, _CMS_ will count this activity and compare it against the **Threshold** field. This field is requires an entry and cannot be left blank.

- **Threshold** - Enter the number of acceptable occurrences of this activity (0-999). Any occurrences beyond this number will generate an exception. If _CMS_ should create an exception on the very first instance, enter 0 in this field. This field requires an entry and cannot be left blank.
8. When all necessary time limits and thresholds have been entered, select **Actions > Modify** from the menu bar.

*Supervisor* updates the exception configuration data for this vector and the status bar displays a **Successful** message.

---

**Deleting vector exceptions**

This section provides the procedure for deleting existing vector exception configurations.

**Steps**

To delete a vector exception configuration:

1. From the Controller window, select **Commands > Exceptions**.

   *Supervisor* displays the **Exceptions** window.

   ![Exceptions Window](image)

2. In the **ACD** field, select the ACD that contains the vector and its exception configuration.

3. In the **Operations** list, highlight **Vector Exceptions**.
Administering exceptions

4. Select **OK**.

*Supervisor* displays the Vector Exception Administration window.

5. In the **Vectors**: field, enter the name or number of the vector for which the exception configuration is to be deleted.

6. From the menu bar, select **Actions > Find one**.

*Supervisor* locates the agent exception configuration for the specified split/skill and displays the data in the appropriate fields. If the exception configuration data cannot be found, the status bar displays **0 matches found**.

To have all vectors returned in this step, leave the **Vectors**: field blank before performing the **Find one** action. *Supervisor* will return all vectors for which you have the read permission. You can then use the **Next** and **Previous** menu actions to cycle through the vectors.

7. From the menu bar, select **Actions > Delete**.

*Supervisor* deletes the exception configuration for this vector from the CMS database and displays a **Successful** message in the status bar.

---

**Vector exception definitions**

The following table provides the definitions for the different vector exceptions:

<table>
<thead>
<tr>
<th>In this field...</th>
<th>Enter this value...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time in vector (max)</td>
<td>The maximum acceptable time in seconds that a call is in vector processing. This exception cannot trigger more than once per interval.</td>
</tr>
</tbody>
</table>
**Vector exceptions report**

Use the vector exceptions report to view exceptions that have occurred for the selected vectors. For each vector exception, the report shows the time and type of exception.

**Before you begin**

To be able to view data for a vector exception report, the following events must have occurred:

- One or more vector exceptions must have been activated at some time in the past.
- The exceptions must have occurred at some point. Otherwise, the report is blank.
- Active exceptions must be specified in the input window so that they are included in the report.
Administering exceptions

Steps
To run an vector exceptions report:

1. From the Controller window, select **Commands > Exceptions**. 
   *Supervisor* displays the **Exceptions** window.

2. Select the **Reports** tab.
3. In the **ACD** field, select the ACD that contains the vector on which to run the report.
4. In the **Reports** list, highlight **Vector Exceptions**.
5. Select **OK**.
   *Supervisor* displays the **Vector Exceptions** window.
6. In the **Date**: field, specify the date to view for the report. Entry of the date can be done through the following methods:

- Enter MM/DD/YY format; for example, **10/06/01**.
- Enter the relative day; for example, 0 for today, -1 for yesterday, or -7 for one week ago.
- Enter a relative range; for example, -9 - 0 causes the report to display data for the past ten days including today.
- Select a date from the drop-down list.
- Select a date by using the Browse button.

This is a required field.

7. In the **Vectors**: field, specify the name or number of one or more vectors to run the report against. Entry of the vector can be done through the following methods:

- Enter the name or number of the vector.
- Select the vector from the drop-down list.
- Select the vector by using the Browse button.

Multiple vectors can be entered in this field, but must be separated by a semicolon (**;**). This is a required field.

8. In the **Order by**: field, select one of the following sorting options:

- **Time** - The report results are sorted by the time the exceptions occurred.
- **Vector** - The report results are sorted by vector name or number.

9. In the **Exceptions**: field, select one or more exceptions to include in the report.

The exceptions selected in this field should be those that have been activated at some point in the past. Selecting exceptions that have not been activated will not return any data in the report.

10. In **Destination** group, select one of the following output options:

- **View Report on Screen** - The report is displayed on the screen.
- **Print Report on** - The report is sent to the specified printer. Any printer available to the PC can be used and selected through the button at the right of the field.
Administering exceptions

11. Select **OK**.

*Supervisor* sends the report to the specified output option.
Data collection exceptions report

Use the data collection exceptions report to view any event that affects the storage of contact center data. This includes the following:

- Starting or stopping data collection
- Resetting the clock
- A session (link) is down

This section contains the following topics:

- Before you begin on page 373
- Running a data collection exceptions report on page 373

Before you begin

The following items should be read and understood before working with the data collections exceptions report:

- Exceptions must have occurred for the exception type that you want the report to cover. Otherwise, the report is blank.

- User IDs must have the *exception* permission for the ACD in order to be notified of a *link-down* exception.

Running a data collection exceptions report

This section provides the procedure for running the data collection exceptions report so that any event that affects the storage of data can be viewed.
Administering exceptions

Steps

To run the data collection exceptions report:

1. From the Controller window, select **Commands > Exceptions**.
   
   *Supervisor* displays the **Exceptions** window.

2. Select the **Reports** tab.

3. In the **Reports**: list, highlight **Data Collection Exceptions**.

4. Select **OK**.
   
   *Supervisor* displays the **Data Collection Exceptions** window.

5. In the **ACDs**: field, select one or more ACDs for which you want to run the report.
   
   This field accepts multiple values. Multiple ACDs must be separated by a semicolon (**;**).

6. In the **Dates**: field, enter the date the report will cover by using one of the following methods:
   
   - Enter MM/DD/YY format; for example, **10/06/01**.
Data collection exceptions report

- Enter the related day; for example, 0 for today, -1 for yesterday, or -7 for one week ago.
- Enter a relative range; for example, -9-0 causes the report to display data for the past ten days including today.
- Select the date from the drop-down list box.
- Select a date or date range by using the Browse button.

This field can accept multiple date values, but the dates must be separated by a semicolon (;). This field is required.

7. In **Destination** group, select one of the following output options:

- **View Report on Screen** - The report is displayed on the screen.
- **Print Report on** - The report is sent to the specified printer. Any printer available to the PC can be used and selected through the button at the right of the field.

8. Select **OK**.

**Supervisor** sends the data collection exceptions report to the specified output method.
Malicious call trace report

The Malicious Call Trace feature provides a way for a terminal user to notify a predefined set of users that he or she may be party to a malicious call, such as bomb threats, hackers, and so forth.

The following actions occur when the Malicious Call Trace feature is activated:

- The inbound phone line is prevented from "hanging up".
- Management is immediately alerted.
- The call is recorded (with an additional Communication Manager feature).
- All data regarding the call is stored.

The malicious call trace report is used to view detailed information on the occurrences of these calls. The report shows the date and time when each call occurred, the agent who received the call, and the involved split or skill. If the automatic number identification / station number identification (ANI/SID) network feature has been purchased and implemented, the report also shows where the call originated. This report is only available with Supervisor.

This section contains the following topics:

- Before you begin on page 376
- Running a malicious call trace report on page 376

Before you begin

The following items should be read and understood before working with the malicious call trace report:

- To view the malicious call trace report, the user ID used to log in to this Supervisor session requires the exception permission for the split/skill that received the malicious call.

Running a malicious call trace report

This section provides the procedure for running a malicious call trace report.
Steps

To run a malicious call trace report:

1. From the Controller window, select **Commands > Exceptions**.
   
   *Supervisor* displays the **Exceptions** window.

![Exceptions window](image)

2. Select the **Reports** tab.

3. In the **ACD**: field, select the ACD for which the report will gather data.

4. In the **Reports**: list, highlight **Malicious Call Trace by Location**.

5. Select **OK**.
   
   *Supervisor* displays the **Malicious Call Trace** window.

![Malicious Call Trace window](image)

6. In the **Dates**: field, enter the date the report will cover by using one of the following methods:
   
   - Enter MM/DD/YY format; for example, 10/06/01.
   
   - Enter the related day; for example, 0 for today, -1 for yesterday, or -7 for one week ago.
Administering exceptions

- Enter a relative range; for example, -9-0 causes the report to display data for the past ten days including today.
- Select the date from the drop-down list box.
- Select a date or date range by using the Browse button.

This field can accept multiple date values, but the dates must be separated by a semicolon (;). This field is required.

7. In **Destination** group, select one of the following output options:
   - **View Report on Screen** - The report is displayed on the screen.
   - **Print Report on:** - The report is sent to the specified printer. Any printer available to the PC can be used and selected through the button at the right of the field.

8. Select **OK**.

  * Supervisor* sends the malicious call trace report to the specified output method.
Real-time exceptions log

The real-time exception log lists the last ten exceptions in chronological order, with the oldest exception listed first. The log displays all types of exceptions for which the user has the exception permission, such as agent, split/skill, trunk group, VDN, and vector.

This section contains the following topics:

- Before you begin on page 379
- Running the real-time exceptions log on page 380

Before you begin

The following items should be read and understood before working with the real-time exceptions log:

- When the log is first opened, the most recent exception is on the last line in the window. As long as the window remains open, the log automatically scrolls to display each new exception record. If the scroll bar is used to view the older records at the top of the log, automatic scrolling for new exceptions stops until the user scrolls back to the bottom of the log.

- Each exception record in the log supplies the following information:
  - The date and time that the exception occurred
  - The name of the ACD for which the exception occurred
  - The ACD element, such as a specific agent, split/skill, or VDN that was involved in the exception.
    
    If names for these elements were assigned in the Dictionary, these will display instead. If the names are longer than the space that is allowed in the exception record, the names will be truncated.
  
  - The information about an activity that fell outside of the exception conditions that you set.

    Therefore, for a peg count exception, the exception record shows the occurrence threshold that you set, even though the number of occurrences may be substantially greater. For a timed exception, the exception record shows the time limit that you set, not the actual duration of an occurrence.

    - The real-time exception log can hold a maximum of 100 records. If a new exception occurs when the log is full, the oldest exception is deleted so that the new exception can be recorded.
Running the real-time exceptions log

This section provides the procedure for running the real-time exceptions log.

Steps
To run the real-time exceptions log:
1. From the Controller window, select Commands > Exceptions.
   Supervisor displays the Exceptions window.
2. In the ACD: field, select the ACD for which exceptions will be shown.
3. In the Operations: list, highlight Real-time Exception Log.
4. Select OK.
   Supervisor displays the Real-Time Exception Log window.
Chapter 9: Administering user permissions

The User Permissions subsystem is used to create CMS user IDs as well as assigning and administering user permissions such as read, write, and exception permissions for ACDs, splits/skills, trunk groups, VDNs, and vectors.

The default CMS administrator user ID, cms, provides access to the entire system. Using the cms ID, user IDs can be created for each person requiring access to the CMS system and set with the permissions necessary to perform job duties. Users should not share an ID since logging in with the same ID at multiple terminals uses more system resources than if each user had different IDs.

This section contains the following topics:

- Before you begin on page 382
- Example of user permissions on page 382
- User data on page 383
- ACD access on page 394
- Feature access on page 405
- Main Menu Addition Access on page 412
- Split/Skill access on page 418
- Trunk group access on page 429
- Vector access on page 440
- VDN access on page 451
Before you begin

If an ACD Group is selected as the current ACD in the User Permissions window, only those operations that are valid for the ACD Group will appear in the Operations: list.

Example of user permissions

⚠️ Important:
Any user ID (normal or administrator) given write access to the User Permission feature will be able to alter their own permissions for all CMS subsystems.

The following table displays an example of permissions that would be necessary for a split supervisor:

<table>
<thead>
<tr>
<th>If the contact center has one split called...</th>
<th>And assigned to it are...</th>
<th>The split 1 supervisor requires read/write permissions for...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Split 1</td>
<td>Trunk groups 22 and 23</td>
<td>Split 1 Trunk groups 22 and 23 Dictionary Exceptions</td>
</tr>
</tbody>
</table>
User data

In order for users to use Supervisor, they must first be created through the User Data feature. Afterwards, users can use their assigned ID to log in through Supervisor and CMS. User IDs should only be created for those persons who will be using Supervisor as a part of their job duties in administering the contact center.

The User Data window is used for the following actions:

- Assign a CMS user ID.
- Specify a default CMS printer for a user ID.
- Specify a user ID as Normal or Administrator.
- Administer the maximum number of open simultaneous windows allowed for a user ID.
- Set the minimum refresh rate for real-time reports for a user ID.
- Set the default logon ACD for a user ID.

This section contains the following topics:

- Adding a CMS user on page 383
- Viewing CMS users on page 386
- Modifying CMS users on page 389
- Deleting CMS users on page 391

Adding a CMS user

This section provides the procedure for adding a user through Supervisor.

Before you begin

The following items should be read and understood before adding a user:

- A user ID must be created before any permissions can be assigned to it.
- Users added through the Sun Microsystems, Inc. Solaris system instead of the User Data window will not be able to run CMS without assuming the role of a valid user by using the su command. Solaris users will have a shell of /usr/bin/sh. The User Data window will not display users that were created through Solaris.
- Users added through the User Data window will automatically have CMS launch when they log in. The shell for these users will be /usr/bin/cms.
- The User Data window can be run through scripts and timetables.
Administering user permissions

Permissions

Depending on the procedure to be performed, the following permissions must be observed:

- To display the User Data window and view user information, the user ID used to log in to this Supervisor session requires read permission for the User Permissions subsystem.

- To add, delete, or modify users through the User Data window, the user ID used to log in to this Supervisor session requires write permission for the User Permissions subsystem.

Steps

To add a CMS user ID:

1. From the Controller window, select Tools > User Permissions. Supervisor displays the User Permissions window.

   The Vector Access and VDN Access menu items are listed if the Call Vectoring feature has been purchased.

2. In the ACD: field, select the ACD or ACD Group on which the user will be created.

   The same user ID does not need to be created on each ACD. A user created on one ACD can be given permissions to the other ACDs.

4. Select **OK**.

*Supervisor* displays the **User Permissions User Data** window.

5. In the **User ID** field, enter the new user ID to be created. The user ID must adhere to the following rules:

- The user ID can be three to eight characters.
- User IDs cannot contain certain diacritical, accented, special characters, or blanks (for example, á, ñ, ç, |, ®). If a user ID is entered with an invalid character, *Supervisor* displays an error message.

   This is a required field.

6. In the **User name**, **Room number**, and **Telephone number** fields, enter the appropriate information for this user.

   These fields are optional and may be left blank.

7. In the **Default printer name** field, select a default CMS printer from the drop-down list box for this user ID.

   This field is optional and may be left as *(none)*.

8. For **Login type**:, select the role of this user ID:

   - **Normal user** - Select this type to designate those users whose job responsibilities *do not* include maintenance, configuration, and updating of *CMS*.

     This role of user has only the *read* permission for the following features:

     - Agent Administration
     - Custom Reports/Report Designer
     - Dictionary
     - Exceptions
**Administering user permissions**

- Forecast
- Maintenance
- Reports
- Timetable

- **Administrator** - Select this type to designate those users who job responsibilities include maintenance, configuration, or updating of CMS. This user role is assigned *read* and *write* permissions for all features.

⚠️ **Important:**

Changing the role of the user after creation will not change any permissions assigned to the user. All permission changes need to be done manually.

9. In the **Maximum user window count (1-12):** field, enter the number of windows that the user may have open simultaneously. The default for this field is 4.

⚠️ **Important:**

Allowing many users to have multiple windows open will consume more CMS processor resources.

10. In the **Minimum refresh rate (seconds):** field, enter the number of seconds (3 - 600) in which data for real-time reports is retrieved again from the database and displayed for this user ID.

⚠️ **Important:**

Faster refresh rates consume more CMS processor resources.

11. In the **Login ACD:** field, select the ACD which will be used to login this user ID. The user can change the current ACD after logging in, but each time the user logs in, the current ACD defaults to the value entered in this field.

If an ACD is selected in this field for log in and the user does not have any permissions for it, *Supervisor* displays an error message.

This is a required field and cannot be left with the default value of *(none)*.

12. Select **Actions > Add** from the menu bar.

The user ID is created on the ACD specified earlier in the User Permissions dialog box. If the user ID already exists, *Supervisor* displays an **Already exists** message in the status bar.

---

**Viewing CMS users**

This section provides the procedure for viewing one or more existing CMS users through the User Data window.
Before you begin

The following items should be read and understood before attempting to view users through the User Data window:

● The default values in the User Data window should be cleared before attempting to perform a Find one or List all action unless these values should be included in the search.

Permissions

Depending on the procedure to be performed, the following permissions must be observed:

● To display the User Data window and view user information, the user ID used to log in to this Supervisor session requires read permission for the User Permissions subsystem.

● To add, delete, or modify users through the User Data window, the user ID used to log in to this Supervisor session requires write permission for the User Permissions subsystem.

Steps

1. From the Controller window, select Tools > User Permissions.

   Supervisor displays the User Permissions window.

   ![User Permissions window]

   The Vector Access and VDN Access menu items are listed if the CallVectoring feature has been purchased.

2. In the Operations: list, highlight User Data.
3. Select **OK**.

*Supervisor* displays the **User Permissions User Data** window.

4. Using the menu bar, select **Edit > Clear all**.

The information in all fields is removed. This includes the default information that appears when this window is first displayed.

5. There are two possible methods in searching for and displaying **CMS** user information:

- **List all** - Selecting this item from the **Action** menu will display a secondary window displaying all users whose settings match those in the fields of this window. If no information is present in the fields, all users are displayed. This method is convenient when the need arises to look for one or more user IDs.

- **Find one** - Selecting this item from the **Action** menu will take the information currently in all the fields of this dialog and query the database for users with matching settings. For example, having a 6 in the **Maximum user window count (1-12)**: field with all other fields blank and selecting **Find one** will result in a search for all **CMS** users having a 6 for their **Maximum user window count**. If multiple users are found, each can be viewed by selecting the **Next** and **Previous** items under the **Actions** menu.

When using the **Find one** command, partial text strings are not supported in the search. Therefore, to view the settings for a user ID, the complete name must be entered in the **User ID:** field.

If multiple users are found using the **Find one** action, the **Next** action will not become disabled at the last user, but instead cause the first user found to be displayed again.
Modifying CMS users

This section provides the procedure for modifying the settings for an existing CMS user.

Before you begin

The following items should be read and understood before modifying users through the User Data window:

- If a user’s login ACD is removed and the user tries to log into CMS, an acknowledgment tells the user either to contact the CMS administrator or to change the login ACD.
- Changing the login type for a user from Administration to Normal or vice versa does not change the permissions for that user ID. Permissions must be changed manually.
- Changes to maximum window count, minimum refresh rate, or default login ACD for a user do not take effect until the user logs out and back in again.

Permissions

Depending on the procedure to be performed, the following permissions must be observed:

- To display the User Data window and view user information, the user ID used to log in to this Supervisor session requires read permission for the User Permissions subsystem.
- To add, delete, or modify users through the User Data window, the user ID used to log in to this Supervisor session requires write permission for the User Permissions subsystem.
Administering user permissions

Steps

To modify the settings for an existing CMS user:

1. From the Controller window, select **Tools > User Permissions**.
   
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations**: list, highlight **User Data**.

3. Select **OK**.
   
   *Supervisor* displays the **User Permissions User Data** window.

4. Clear all field default values by selecting **Edit > Clear All** from the menu bar.
5. In the **Login type (select only one):** field, select the login type for the user that will be modified.

6. Enter the name of the user to modify in the **User ID:** field.

7. Select **Actions > Find one.**

   The settings for the specified user ID will populate their associated fields.

   If the user ID was not found, try selecting the other login type in the **Login type (select only one):** field.

8. Modify the settings for this user as needed.

9. After all necessary modifications have been made, select **Actions > Modify.**

   The settings for this user are updated and the status bar will display a **Successful** message.

---

**Deleting CMS users**

This section provides the procedure for deleting an existing CMS user.

**Before you begin**

The following items should be read and understood before deleting users through the **User Data** window:

- Deleting a user ID added through the **User Data** window of CMS will remove that ID and its associated permissions from CMS and the Solaris system.
- Deleting a user who had custom reports, designer reports, or timetables, will result in an acknowledgment window asking if those items should be moved to your user ID. If they are moved and there is a conflict between the assigned names, a prompt window will appear allowing the moved items to be renamed. If not moved, any custom reports, designer reports, and timetables will be deleted along with the user ID.

**Permissions**

Depending on the procedure to be performed, the following permissions must be observed:

- To display the **User Data** window and view user information, the user ID used to log in to this **Supervisor** session requires **read** permission for the **User Permissions** subsystem.
- To add, delete, or modify users through the **User Data** window, the user ID used to log in to this **Supervisor** session requires **write** permission for the **User Permissions** subsystem.
Administering user permissions

Steps
To delete an existing CMS user:

1. From the Controller window, select Tools > User Permissions. Supervisor displays the User Permissions window.

The Vector Access and VDN Access menu items are listed if the Call Vectoring feature has been purchased.

2. In the Operations: list, highlight User Data.

3. Select OK. Supervisor displays the User Permissions User Data window.
4. Using the menu bar, select **Edit > Clear all**.
   The information in all fields is removed. This includes the default information that appears when this window is first displayed.

5. In the **Login type (select only one)**: field, select the login type of the user that will be deleted.

6. Enter the name of the user in the **User ID**: field.
   If the user ID is not known, the other fields of this dialog box can be used to enter information that can return all users having matching information. For example, the **User name:** and **Room number:** fields can have information entered in them.

7. After user-identifying data has been entered in the fields, select **Actions > Find one** from the menu bar.
   The status bar will return the number of matches found. Select **Actions > Next** to navigate to the next user in the list, if necessary.

8. When the dialog box displays the correct user, select **Actions > Delete** from the menu bar.
   The identified user is deleted from the system and the status bar displays a **Successful** message.
Administering user permissions

ACD access

The ACD Access window is used to view and modify the user permissions for a selected real or pseudo ACD. This window can also be used to turn exception notification on or off for a selected ACD.

This section contains the following topics:

- Before you begin on page 394
- Permissions on page 395
- Adding ACD access on page 395
- Viewing ACD access on page 397
- Listing all ACD access on page 398
- Modifying ACD access on page 400
- Deleting ACD access on page 402

Before you begin

The following items should be read and understood before working with ACD access permissions:

- By default, a newly-created user is granted read, write, and exceptions permissions for all real and pseudo ACDs.
- User permissions for ACD access are stored separately from the user ID created through the Adding a CMS user procedure. Because of this, user permissions for the ACD can be deleted and modified without affecting the state of the user ID.
- If the ACD permissions for a user are changed, the change does not take effect until the user logs out and logs back in again.
- If the read and write permissions are disabled for a user, then the user will not be able to access any splits/skills, trunk groups, vectors, or VDNS in that ACD. If read is enabled and write is disabled, the user will not be able to modify splits/skills, trunk groups, vectors, or VDNs in that ACD.
- If the permissions for the default login ACD of a user are removed, the user must have another login ACD assigned.
- A user must be created through the User Data window before any ACD permissions can be assigned.
Users should only have the ACD permissions necessary to perform job duties. Assigning only those necessary user permissions will ensure the best system performance.

In some instances, it may be necessary to restrict a user from viewing information on an ACD. To do so, either delete the permissions definition for the user or remove all permissions for the necessary ACDs. Deleting the ACD permissions definition for a user will save more disk space.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view user permission settings in the ACD Access window, the user ID used to log in to this Supervisor session requires read permission for the User Permissions subsystem.

- To add, delete, or modify user permission settings in the ACD Access window, the user ID used to log in to this Supervisor session requires write permission for the User Permissions subsystem.

Adding ACD access

This section provides the procedure for adding ACD access permissions for a CMS user. Since a user permission definition for ACD access is created by default when the user ID is created, this procedure is only necessary if that permission definition has been deleted.
Administering user permissions

Steps
To add a user permission definition for an ACD:

1. On the Controller window, select **Tools > User Permissions**.
   
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations** list, highlight **ACD Access**.

3. Select **OK**.
   
   *Supervisor* displays the **User Permissions ACD Access** window.

4. In the **User ID** field, enter the ID of the user for whom to create an ACD permissions definition.

   This field is required.

5. In the **ACD** field, enter the names or numbers for one or more ACDs that this user will be able to access (real, pseudo, or group).

   Multiple values in this field must be separated with a semicolon (**;**).

6. Place a check mark in the permissions that will be assigned to this user:
   
   ● **Read**: - User can view but not modify information for the specified ACDs.
● **Write**: - User can modify information on the specified ACDs. This permission requires that the user also have the *read* permission.

● **Exceptions**: - User will receive notification of exceptions occurring on the specified ACDs.

7. After assigning the necessary permissions, select **Actions > Add** from the menu bar. The ACD permissions for this user are saved.

It is possible to add permission definitions for multiple users at one time. To do so, enter multiple CMS users in the **User ID:** field and separate them with semicolons (;). The ACDs specified in the **ACDs:** field and the selected permissions are then created for these user IDs when the **Add** action is performed.

---

### Viewing ACD access

This section provides the procedure for viewing the ACD access permissions for a CMS user.

**Steps**

To view the ACD permission definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.

   *Supervisor* displays the **User Permissions** window.

2. In the **Operations**: list, highlight **ACD Access**.
3. Select **OK**.

   *Supervisor* displays the **User Permissions ACD Access** window.

4. In the **User ID:** field, enter the ID of the CMS user for which the permissions for ACDs are to be viewed.

   This field is required.

   When searching for the user permissions definitions on specific ACDs, these ACDs can be entered in the **ACDs:** field. Multiple entries must be separated by a semicolon (**;**).

5. From the menu bar, select **Actions > Find one**.

   The status bar displays how many matching permission definitions are available. The fields of this window display the user permissions definition for the first ACD.

   If more than one ACD is returned, use the **Next** action to view the permission definitions for the other ACDs.

---

**Listing all ACD access**

This section provides the procedure for listing the ACD permission definitions for all CMS users.
Steps
To list all ACD permission definitions for all CMS users:

1. On the Controller window, select **Tools > User Permissions**.
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations:** list, highlight **ACD Access**.

3. Select **OK**.
   *Supervisor* displays the **User Permissions ACD Access** window.
Administering user permissions

4. From the menu bar, select **Actions > List all**.

All user permission definitions are displayed with their corresponding ACDs. Only those ACDs for which you have *read* permission will be shown.

---

**Modifying ACD access**

This section provides the procedure for modifying the ACD permission definitions for a CMS user.

If all ACD permissions are to be denied for a user, deleting the permissions definition for the user will save more disk space and accomplish the same goal.

⚠️ **Important:**

If the *read* permissions is denied for the ACD that the user logs into, that user will no longer be able to log on. A new default login ACD must be set for the user.
Steps
To modify the ACD permissions definition for a CMS user:

1. On the Controller window, select Tools > User Permissions. 
   Supervisor displays the User Permissions window.

2. In the Operations: list, highlight ACD Access.
3. Select OK. 
   Supervisor displays the User Permissions ACD Access window.

4. In the User ID: field, enter the ID of the CMS user for which the permissions for ACDs are to be modified.
5. CMS user for which the permissions for ACDs are to be modified.

   When searching for the user permissions definitions on specific ACDs, these ACDs can be entered in the ACDs: field. Multiple entries must be separated by a semicolon (;). These entries can include real ACDs, pseudo-ACDs, or ACD Groups.
Administering user permissions

6. From the menu bar, select Actions > Find one.

   The status bar displays how many matching permission definitions are available. The fields of this window display the user permissions definition for the first ACD.

   If more than one ACD is returned, use the Next action to view the permission definitions for the other ACDs.

7. Once the correct permission definition is displayed in the window, change the permissions by adding or removing check marks in the Read:, Write:, or Exceptions: check boxes.

8. Once the permissions have been changed to the necessary settings, select Actions > Modify from the menu bar.

   The user permissions definition for this ACD is updated and the status bar displays a Successful message.

Deleting ACD access

This section provides the procedure for deleting the ACD permission definition for a CMS user.

⚠️ Important:

   If the user permissions definition is deleted for the ACD that the user logs into, that user will no longer be able to log on. A new default login ACD must be set for the user. Deleting the permissions definition does not restrict the permissions for the user, but actually deletes the user from the specified ACD. This action does not affect the user ID created through the User Data feature.
Steps

To delete the ACD permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.

   *Supervisor* displays the **User Permissions** window.

![User Permissions window](image)

2. In the **Operations** list, highlight **ACD Access**.

3. Select **OK**.

   *Supervisor* displays the **User Permissions ACD Access** window.

![User Permissions ACD Access window](image)

4. In the **User ID** field, enter the ID of the CMS user for which the permissions for ACDs are to be modified.

   When searching for the user permissions definitions on specific ACDs, these ACDs can be entered in the **ACDs** field. Multiple entries must be separated by a semicolon (;). These entries can include real ACDs, pseudo-ACDs, or ACD Groups.

5. From the menu bar, select **Actions > Find one**.

   The status bar displays how many matching permission definitions are available. The fields of this window display the user permissions definition for the first ACD.

   If more than one ACD is returned, use the **Next** action to view the permission definitions for the other ACDs.
6. Once the correct permission definition is displayed in the window, select **Actions > Delete** from the menu bar.

The ACD permissions definition for this user is deleted and the status bar displays a **Successful** message.

7. Once the permissions have been changed to the necessary settings, select **Actions > Modify** from the menu bar.

The user permissions definition for this ACD is updated and the status bar displays a **Successful** message.
Feature access

The Feature Access window is used to view and modify the permissions available to a CMS user ID for the following features:

- Agent Administration
- Call Center Administration
- Custom Reports
- Dictionary
- Exceptions
- Forecast
- Maintenance
- Reports
- CMS System Setup
- Timetable
- User Permissions
- UNIX® System

The permissions assigned to a user will affect the appearance of the Supervisor Controller window. For example, a user without permissions for the Dictionary feature will not have a corresponding toolbar button on the Controller window.

Contents

This section contains the following topics:

- Before you begin on page 406
- Permissions on page 406
- Viewing Feature Access user permissions on page 407
- Listing all Feature Access user permissions on page 408
- Modifying Feature Access user permissions on page 410
Before you begin

The following items should be read and understood before working with Feature Access permissions:

- **Feature Access** permissions cannot be modified for the `cms` and `cmssvc` user IDs. This prevents a user with access to the User Permissions feature from disabling access to all or part of CMS for the administrator or services personnel.

- If the Feature Access permissions for a user are modified, the changes do not take effect until the user logs off and back on again.

- A user ID must be created through the User Data feature before that user can have Feature Access permissions assigned.

- Default Feature Access permissions are assigned when a user ID is created. The Administrator type of user ID has permissions for all features. The Normal type of user ID is given read permissions for all features except User Permissions, System Setup, Call Center Administration, and Forecasting. User ID types are set through the User Data feature. Avaya CMS Forecast is purchased separately.

- Assigning a user the write permission for the User Permissions feature allows that user to change permissions for all users.

- A user ID cannot have write permissions without also having read permissions.

- If a user does not have read permission for a feature, that feature will not be displayed as a toolbar button or menu item in the Supervisor Controller window.

- Assigning only the necessary access permissions ensures the best system performance.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view the Feature Access window, the user ID used to log in to this Supervisor session requires read permission for the User Permissions subsystem.

- To add, delete, or modify settings through the Feature Access window, the user ID used to log in to this Supervisor session requires write permission for the User Permissions subsystem.
Viewing Feature Access user permissions

This section provides the procedure for viewing Feature Access permissions for a CMS user.

Steps

To view the Feature Access permissions for a CMS user:

1. On the Controller window, select Tools > User Permissions. Supervisor displays the User Permissions window.

2. In the Operations: list, highlight Feature Access.

3. In the ACD: field, select the ACD or ACD Group on which you want to view user permissions for its feature set.
4. Select **OK**.

   *Supervisor* displays the **User Permissions Feature Access** window.

5. In the **User IDs**: field, enter the ID of an existing **CMS** user.

   This field can accept more than one user ID. Multiple IDs must be separated by a semicolon (**;**).

6. From the menu bar, select **Actions > Find one**.

   *Supervisor* will display the permissions for the first user found. If multiple user IDs were entered, the status bar will display the number of matches found.

   If multiple matches were found, use the **Actions > Next** command to navigate through the user IDs and their permissions.

---

**Listing all Feature Access user permissions**

This section provides the procedure for listing the **Feature Access** permissions for all **CMS** users on an **ACD** or **ACD Group**.
Steps
To list the **Feature Access** permissions for all CMS users:

1. On the Controller window, select **Tools > User Permissions**.
   
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations**: list, highlight **Feature Access**.

3. In the **ACD**: field, select the ACD or ACD Group to view the user permissions for its feature set.

4. Select **OK**.
   
   *Supervisor* displays the **User Permissions Feature Access** window.

5. From the menu bar, select **Actions > List all**.
   
   *Supervisor* displays a secondary window listing all users and their associated feature permissions.
Modifying Feature Access user permissions

This section provides the procedure for modifying Feature Access permissions for a CMS user on an ACD or ACD Group.

Steps

To modify Feature Access permissions for a CMS user:

1. On the Controller window, select Tools > User Permissions.

   Supervisor displays the User Permissions window.

   ![User Permissions Window]

2. In the Operations: list, highlight Feature Access.

3. In the ACD: field, select the ACD or ACD Group on which the user permissions for its feature set will be modified.
4. Select **OK**. 

*Supervisor* displays the **User Permissions Feature Access** window.

5. In the **User IDs:** field, enter the ID of an existing **CMS** user.

6. From the menu bar, select **Actions > Find one**.

*Supervisor* will display the permissions for the user.

A check mark in a check box signifies that the associated feature permission is enabled for the user.

7. Change the **Read** and **Write** permissions as necessary by placing or removing check marks in the check boxes for each feature.

8. When the necessary changes have been made to the user feature permissions, select **Actions > Modify** from the menu bar.

The feature access permissions for this user ID are updated and the status bar displays a **Successful** message.
Administering user permissions

---

Main Menu Addition Access

The **Main Menu Addition Access** feature is used to control which custom menu items appear on the CMS Main Menu for a user. Custom menu items are created through the **Main Menu Addition** feature which is located in the **System Setup** screen from the CMS ASCII interface.

These menu items cannot be created through **Supervisor**.

The custom menu items display on the CMS Main Menu which is seen through either **Terminal Emulator**, a telnet session to the CMS server, or the CMS console. The custom menu items do not display in the **Supervisor Controller Window**.

---

Contents

This section contains the following topics:

- **Before you begin** on page 412
- **Permissions** on page 413
- **Viewing Main Menu Addition Access** on page 413
- **Listing all Main Menu Addition Access** on page 414
- **Assigning or modifying Main Menu Addition Access** on page 416

---

**Before you begin**

The following items should be read and understood before working with **Main Menu Addition Access**:

- If the assigned **Main Menu Addition Access** permission for a user is disabled, the custom menu item will not be displayed on the CMS Main Menu for that user.

- If a the **Main Menu Addition Access** permission is changed for a user, those changes will not take effect until the user logs out and back in again.

- A user ID must be created through the **User Data** feature before assignments or changes can be made to that user ID through the **Main Menu Addition Access** feature.

- Main Menu additions must be created through **System Setup** before these custom menu items can be assigned to users.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view **Main Menu Addition Access** user configurations, the user ID used to log in to CMS requires *read* permission for the **User Permissions** subsystem.
- To add, delete, or modify **Main Menu Addition Access** user configurations, the user ID used to log in to CMS requires *write* permission for the **User Permissions** subsystem.

Viewing Main Menu Addition Access

This section provides the procedure for viewing CMS user configurations for **Main Menu Addition Access**.

Steps

To view the **Main Menu Addition Access** configuration for a user:

1. On the Controller window, select **Tools > User Permissions**. 

   *Supervisor* displays the **User Permissions** window.

2. In the **Operations:** list, highlight **Main Menu Addition Access**.
Administering user permissions

3. Select **OK**.

  *Supervisor* displays the **User Permissions Main Menu Addition Access** window.

![User Permissions Main Menu Addition Access window]

4. In the **User IDs:** field, enter a **CMS** user ID that has been previously defined through the **User Data** feature.

   This field can accept the entry of multiple users at one time. Multiple entries must be separated by a semicolon (;).

5. From the menu bar, select **Actions > Find one**.

   *Supervisor* retrieves the **Main Menu Addition Access** information for the specified **CMS** user ID and displays this information in the remaining fields.

   If multiple users were specified in the **User IDs:** field, the other users and their configurations can be seen by using **Actions > Next** from the menu bar.

---

**Listing all Main Menu Addition Access**

This section provides the procedure for listing all **Main Menu Addition Access** configurations that have been assigned to **CMS** users.
Steps
To list all Main Menu Addition Access configurations for CMS users:

1. On the Controller window, select Tools > User Permissions.
   Supervisor displays the User Permissions window.

   ![User Permissions window](image)

2. In the Operations: list, highlight Main Menu Addition Access.
3. Select OK.
   Supervisor displays the User Permissions Main Menu Addition Access window.

   ![User Permissions Main Menu Addition Access](image)
4. From the menu bar, select **Actions > List all**.

*Supervisor* displays a secondary window listing all CMS users that have custom menu items assigned and the permissions for those custom menu items.

Assigning or modifying Main Menu Addition Access

This section provides the procedure for assigning or modifying a custom Main Menu item for a CMS user.

**Steps**

To assign or modify a custom Main Menu item for a CMS users:

1. On the Controller window, select **Tools > User Permissions**.

*Supervisor* displays the **User Permissions** window.

2. In the **Operations** list, highlight **Main Menu Addition Access**.
3. Select **OK**.

   *Supervisor* displays the **User Permissions Main Menu Addition Access** window.

4. In the **User IDs**: field, enter a **CMS** user ID that has been previously defined through the **User Data** feature.

   This field can accept the entry of multiple users at one time. Multiple entries must be separated by a semicolon (,).

5. From the menu bar, select **Actions > Find one**.

   *Supervisor* retrieves the Main Menu Addition Access information for the specified **CMS** user ID and displays this information in the remaining fields.

   If multiple users were specified in the **User IDs**: field, the other users and their configurations can be seen by using **Actions > Next** from the menu bar.

6. In the **Addition**: field, enter the custom menu item to be assigned or modified for the specified **CMS** user.

7. In the **Access**: check box, place a check mark to enable this custom menu item or remove the check mark to disable this menu item for the specified **CMS** user.

8. From the menu bar, select **Actions > Modify**.

   The user configuration is updated and the status bar displays a **Successful** message.

   Only the current **CMS** displayed in the **User IDs**: field is modified. If other user IDs are available through using the **Next** command, each one will require the **Modify** action for assignments to be applied.
Split/Skill access

This section provides the procedures for working with user permissions regarding splits/skills.

For users providing administration for splits/skills or running split/skill reports, it is necessary for them to have the proper split/skill permissions to perform their job functions. Split/skill exceptions notification is also configured through this interface. Users who are given the Exceptions permission will be notified of split/skill exceptions when they occur.

This section contains the following topics:

- **Before you begin** on page 418
- **Permissions** on page 419
- **Adding split/skill user permissions** on page 419
- **Viewing split/skill user permissions** on page 421
- **Listing all split/skill user permissions** on page 423
- **Modifying split/skill user permissions** on page 424
- **Deleting split/skill user permissions** on page 426

Before you begin

The following items should be read and understood before working with split/skill permissions:

- A CMS user ID must be created through the User Data feature before split/skill permissions can be assigned.

- When a new user ID is created through the User Data feature, split/skill permission definitions for that user are not created. This is done to conserve disk space. When a split/skill permissions definition does not exist for a user ID, CMS will deny read and write access to splits/skills.

- A user ID must first have permissions for the ACD on which the split/skill resides before split/skill permissions can be assigned. If a user ID is assigned split/skill permissions and does not have the appropriate ACD permissions, Supervisor displays an error message.

- A user ID cannot be assigned the write permission without first having the read permission.

- Assigning only those permissions that are necessary for each user ID ensures the best system performance.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view split/skill user permissions, the user ID used to log in to this Supervisor session requires read permission for the User Permissions subsystem.

- To add, delete, or modify split/skill user permissions, the user ID used to log in to this Supervisor session requires write permission for the User Permissions subsystem.

Adding split/skill user permissions

This section provides the procedure for adding a split/skill permissions definition for a CMS user.

Before you begin

The following items should be read and understood before adding a split/skill permissions definition for a CMS user:

- If a user does not have corresponding ACD permissions for the permissions set for them on the split/skill, Supervisor displays an error message.

- When the permissions definition for a user is created, the split/skill permissions do not take effect until the user logs off and back on again.
**Steps**

To add a split/skill permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.
   
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations**: list, highlight **Split/Skill Access**.

3. In the **ACD**: field, select the ACD or ACD Group containing the split/skill for which the user will be given permissions.

4. Select **OK**.
   
   *Supervisor* displays the **User Permissions Split/Skill Access** window.

5. In the **User ID**: field, enter the name of the user who will be assigned split/skill permissions.

6. In the **Splits/Skills**: field, enter the name or number of the split/skill for which the user will have permissions assigned.

   This field can accept multiple splits/skills. Multiple entries must be separated by a semicolon (;).

   Multiple splits/skills can be entered by using a range, for example, 1-256.
7. Place a check mark in the permissions that will be assigned to this user:
   - **Read**: User can view but not modify information for the specified splits/skills including reports.
   - **Write**: User can modify information on the specified splits/skills. This permission requires that the user also have the **read** permission.
   - **Exceptions**: User will receive notification of exceptions occurring on the specified splits/skills.

Only the split/skill exceptions made active through the **Exceptions** feature will provide notification to the user. See Chapter 8: Administering exceptions on page 305 for more information.

8. After assigning the necessary permissions, select **Actions > Add** from the menu bar.
   The split/skill permissions for this user are saved.

   It is possible to add permission definitions for multiple splits/skills at one time. To do so, enter multiple splits/skills in the **Splits/Skills** field and separate them with semicolons (,).

---

**Viewing split/skill user permissions**

This section provides the procedure for viewing the split/skill permissions definition for a CMS user.

**Before you begin**

The following items should be read and understood before viewing split/skill permission definitions for CMS users:

- The wildcard characters * and ? cannot be used in the **User Permissions Split/Skill Access** window.
Administering user permissions

Steps

To view the split/skill permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.
   
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations**: list, highlight **Split/Skill Access**.

3. In the **ACD**: field, select the ACD or ACD Group containing the split/skill for which the user has a permissions definition.

4. Select **OK**.
   
   *Supervisor* displays the **User Permissions Split/Skill Access** window.

5. In the **User ID**: field, enter the name of the user for which the split/skill permissions definition is to be viewed.

6. If the specific split/skill to view for this user is known, enter the name or number of the split/skill in the **Splits/Skills**: field. To have all splits/skills returned for this user ID, leave this field blank.
   
   This field can accept multiple splits/skills. Multiple entries must be separated by a semicolon (;).
7. From the menu bar, select **Actions > Find one**.

    *Supervisor* queries the database and displays the number of matches found for this user ID in the status bar.

---

**Listing all split/skill user permissions**

This section provides the procedure for listing all of the user permission definitions for a split/skill.

**Before you begin**

The following items should be read and understood before listing all split/skill permission definitions for CMS users:

- The wildcard characters * and ? cannot be used in the **User Permissions Split/Skill Access** window.

**Steps**

To list all user permission definitions for a split/skill:

1. On the Controller window, select **Tools > User Permissions**.

    *Supervisor* displays the **User Permissions** window.

2. In the **Operations**: list, highlight **Split/Skill Access**.

3. In the **ACD**: field, select the ACD or ACD Group containing the split/skill for which all permission definitions will be shown.
4. Select **OK**.

*Supervisor* displays the **User Permissions Split/Skill Access** window.

5. From the menu bar, select **Actions > List all**.

*Supervisor* displays a secondary window listing all user permissions for splits/skills on the specified ACD.

A filter can be created when listing all user split/skill permission definitions. This filter is based on any information contained in the **User ID:** and **Splits/Skills:** fields on this dialog box when the **List all** action is performed.

For example, to view all of the user permission definitions for skill 26, enter **26** in the **Splits/Skills:** field before performing the **List all** action. This will cause only the user permission definitions for skill 26 to display. If more information is entered into the other fields of this dialog box, the results will be more restricted. If information for the user ID, splits/skills, and permissions are entered, the **List all** command will only return those permission definitions which match all of the information.

---

### Modifying split/skill user permissions

This section provides the procedure for modifying the split/skill permissions definition for a CMS user.

**Before you begin**

The following items should be read and understood before modifying split/skill permissions:

- When the permissions definition for a user is modified, the change does not take effect until the user logs off and back on again.
- If a user does not have corresponding ACD permissions for the permissions set for them on the split/skill, *Supervisor* displays an error message.
- The wildcard characters * and ? cannot be used in the **User Permissions Split/Skill Access** window.
Steps
To modify the split/skill permissions definition for a CMS user:

1. On the Controller window, select Tools > User Permissions.
   *Supervisor* displays the User Permissions window.


3. In the ACD: field, select the ACD or ACD Group containing the split/skill for which the user has a permissions definition.

4. Select OK.
   *Supervisor* displays the User Permissions Split/Skill Access window.

5. In the User ID: field, enter the name of the user for which the split/skill permissions definition is to be modified.

6. If the specific split/skill to view for this user is known, enter the name or number of the split/skill in the Splits/Skills: field. For all splits/skills to be returned for this user ID, leave this field blank.

   This field can accept multiple splits/skills. Multiple entries must be separated by a semicolon (;).
7. From the menu bar, select **Actions > Find one**.

*Supervisor* queries the database and displays the number of matches found for this user ID in the status bar.

If multiple matches are found, use the **Next** and **Previous** items found under the **Action** menu to navigate to the correct split/skill.

8. Change the permissions for the user on this split/skill as needed:

- **Read**: - User can view but not modify information for the specified splits/skills including reports.

- **Write**: - User can modify information on the specified splits/skills. This permission requires that the user also have the *read* permission.

- **Exceptions**: - User will receive notification of exceptions occurring on the specified splits/skills.

**Important:**

If all permissions are to be removed for this user ID, it saves more server disk space to delete this permission definition rather than disabling all permissions. See [Deleting split/skill user permissions](#) on page 426 for more information.

Only the split/skill exceptions made active through the **Exceptions** feature will provide notification to the user. See *[Chapter 8: Administering exceptions](#)* on page 305 for more information.

9. After the necessary permission changes have been completed, select **Actions > Modify** from the menu bar.

The permissions definition for this user ID and split/skill is updated. The status bar displays a **Successful** message.

---

**Deleting split/skill user permissions**

This section provides the procedure for deleting the split/skill permissions definition for a CMS user.
Steps

To delete the split/skill permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.

   *Supervisor* displays the **User Permissions** window.

![User Permissions Window](image)

2. In the **Operations**: list, highlight **Split/Skill Access**.

3. In the **ACD**: field, select the ACD or ACD Group containing the split/skill for which the user has a permissions definition.

4. Select **OK**.

   *Supervisor* displays the **User Permissions Split/Skill Access** window.

![User Permissions Split/Skill Access Window](image)

5. In the **User ID**: field, enter the name of the user for which the split/skill permissions definition is to be deleted.

6. If the specific split/skill to view for this user is known, enter the name or number of the split/skill in the **Splits/Skills**: field. To return all split/skills for this user ID, leave this field blank.
7. From the menu bar, select **Actions > Find one**.

*Supervisor* queries the database and displays the number of matches found for this user ID in the status bar.

If multiple matches are found, use the **Next** and **Previous** items found under the **Action** menu to navigate to the correct split/skill.

8. From the menu bar, select **Actions > Delete**.

*Supervisor* deletes the permissions definition for this user ID and the associated split/skill. The status bar displays a **Successful** message upon completion of the action.

This action does not delete the permission definitions for all splits/skills for this user, only the one displayed in the **Splits/Skills**: field.
Trunk group access

Trunk group permissions allow users to view data for trunk group reports, view trunk group configuration information, and change trunk group configurations. The User Permissions Trunk Group Access window is also used to configure which users receive exception notifications.

This section contains the following topics:

- Before you begin on page 429
- Permissions on page 430
- Adding trunk group user permissions on page 430
- Viewing trunk group user permissions on page 432
- Listing all trunk group user permissions on page 434
- Modifying trunk group user permissions on page 435
- Deleting trunk group user permissions on page 437

Before you begin

The following items should be read and understood before working with trunk group permissions:

- A CMS user ID must be created through the User Data feature before it can be assigned trunk group permissions.

- When a new user ID is created through the User Data feature, trunk group permission definitions for that user are not created. This is done to conserve disk space. When a trunk group permissions definition does not exist for a user ID, CMS will deny read and write access to trunk groups.

- A user ID must first have permissions for the ACD on which the trunk group resides before trunk group permissions can be assigned. If a user ID is assigned trunk group permissions and does not have the appropriate ACD permissions, Supervisor displays an error message.

- A user ID cannot be assigned the write permission without first having the read permission.

- Assigning only those permissions that are necessary for each user ID ensures the best system performance.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view trunk group user permissions, the user ID used to log in to this Supervisor session requires read permission for the User Permissions subsystem.
- To add, delete, or modify trunk group user permissions, the user ID used to log in to this Supervisor session requires write permission for the User Permissions subsystem.

Adding trunk group user permissions

This section provides the procedure for adding a trunk group permissions definition for a CMS user.

Before you begin

The following items should be read and understood before adding a trunk group permissions definition for a CMS user:

- If a user does not have corresponding ACD permissions for the permissions set for them on the trunk group, Supervisor displays an error message.
- When the permissions definition for a user is created, the trunk group permissions do not take effect until the user logs off and back on again.
Steps
To add a trunk group permissions definition for a CMS user:

1. On the Controller window, select Tools > User Permissions. 
   *Supervisor* displays the User Permissions window.

2. In the Operations: list, highlight Trunk Group Access.

3. In the ACD: field, select the ACD containing the trunk group for which the user will be given permissions.

4. Select OK.
   *Supervisor* displays the User Permissions Trunk Group Access window.

5. In the User ID: field, enter the name of the user who will be assigned trunk group permissions.

6. In the Trunk Groups: field, enter the name or number of the trunk group for which the user will have permissions assigned.
   This field can accept multiple trunk groups. Multiple entries must be separated by a semicolon (;).

7. Place a check mark in the permissions that will be assigned to this user:
Administering user permissions

- **Read**: User can view but not modify information for the specified trunk groups including reports.

- **Write**: User can modify information on the specified trunk groups. This permission requires that the user also have the *read* permission.

- **Exceptions**: User will receive notification of exceptions occurring on the specified trunk groups.

  Only the trunk group exceptions made active through the Exceptions feature will provide notification to the user. See Chapter 8: Administering exceptions on page 305 for more information.

8. After assigning the necessary permissions, select **Actions > Add** from the menu bar.

  The trunk group permissions for this user are saved.

  It is possible to add permission definitions for multiple trunk groups at one time. To do so, enter multiple trunk groups in the **Trunk Groups**: field and separate them with semicolons (;).

### Viewing trunk group user permissions

This section provides the procedure for viewing the trunk group permissions definition for a CMS user.

**Before you begin**

The following items should be read and understood before viewing trunk group permission definitions for CMS users:

- The wildcard characters * and ? cannot be used in the User Permissions Trunk Group Access window.
Steps

To view the trunk group permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**. 
   
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations**: list, highlight **Trunk Group Access**.

3. In the **ACD**: field, select the ACD containing the trunk group for which the user has a permissions definition.

4. Select **OK**.
   
   *Supervisor* displays the **User Permissions Trunk Group Access** window.

5. In the **User ID**: field, enter the name of the user for which the trunk group permissions definition is to be viewed.

6. If the specific trunk group to view for this user is known, enter the name or number of the trunk group in the **Trunk Groups**: field. To have all trunk groups returned for this user ID, leave this field blank.

   This field can accept multiple trunk groups. Multiple entries must be separated by a semicolon (;).
7. From the menu bar, select Actions > Find one.

The database is queried and the number of matches found for this user ID displays in the status bar.

---

**Listing all trunk group user permissions**

This section provides the procedure for listing all of the user permission definitions for a trunk group.

**Before you begin**

The following items should be read and understood before listing all trunk group permission definitions for CMS users:

- The wildcard characters * and ? cannot be used in the User Permissions Trunk Group Access window.

**Steps**

To list all user permission definitions for a trunk group:

1. On the Controller window, select Tools > User Permissions.

   Supervisor displays the User Permissions window.

![User Permissions window](image)

2. In the Operations: list, highlight Trunk Group Access.

3. In the ACD: field, select the ACD containing the trunk group for which all permission definitions will be shown.
4. Select **OK**.

*Supervisor* displays the **User Permissions Trunk Group Access** window.

![User Permissions Trunk Group Access Window]

5. From the menu bar, select **Actions > List all**.

*Supervisor* displays a secondary window listing all user permissions for trunk groups on the specified ACD.

A filter can be created when listing all user trunk group permission definitions. This filter is based on any information contained in the **User ID:** and **Trunk Groups:** fields on this dialog box when the **List all** action is performed.

For example, to view all of the user permission definitions for trunk group 4, enter 4 in the **Trunk Groups:** field before performing the List all action. This will cause only the user permission definitions for trunk group 4 to display. If more information is entered into the other fields of this dialog box, the results will be more restricted. If information for the user ID, trunk groups, and permissions are entered, the **List all** command will only return those permission definitions which match all of the information.

---

**Modifying trunk group user permissions**

This section provides the procedure for modifying the trunk group permissions definition for a **CMS** user.

**Before you begin**

The following items should be read and understood before modifying trunk group permissions:

- When the permissions definition for a user is modified, the change does not take effect until the user logs off and back on again.

- If a user does not have corresponding ACD permissions for the permissions set for them on the trunk group, *Supervisor* displays an error message.

- The wildcard characters * and ? cannot be used in the **User Permissions Trunk Group Access** window.
Administering user permissions

Steps

To modify the trunk group permissions definition for a CMS user:

1. On the Controller window, select Tools > User Permissions.
   
   Supervisor displays the User Permissions window.

2. In the Operations: list, highlight Trunk Group Access.

3. In the ACD: field, select the ACD containing the trunk group for which the user has a permissions definition.

4. Select OK.
   
   Supervisor displays the User Permissions Trunk Group Access window.

5. In the User ID: field, enter the name of the user for which the trunk group permissions definition is to be modified.

6. If the specific trunk group to view for this user is known, enter the name or number of the trunk group in the Trunk Groups: field. To have all trunk groups returned for this user ID, leave this field blank.

   This field can accept multiple trunk groups. Multiple entries must be separated by a semicolon (;).
7. From the menu bar, select **Actions > Find one**.

   The database is queried and the number of matches found for this user ID displays in the status bar. The first match found populates the fields of this dialog box.

   If multiple matches are found, use the **Next** and **Previous** items found under the **Action** menu to navigate to the correct trunk group.

8. Change the permissions for the user on this trunk group as needed:

   - **Read**: User can view but not modify information for the specified trunk groups including reports.
   - **Write**: User can modify information on the specified trunk groups. This permission requires that the user also have the **read** permission.
   - **Exceptions**: User will receive notification of exceptions occurring on the specified trunk groups.

   **Important:**
   
   If all permissions are to be removed for this user ID, it saves more server disk space to delete this permission definition rather than disabling all permissions.

   Only the trunk group exceptions made active through the **Exceptions** feature will provide notification to the user. See **Chapter 8: Administering exceptions** on page 305 for more information.

9. After the necessary permission changes have been completed, select **Actions > Modify** from the menu bar.

   The permissions definition for this user ID and trunk group is updated. The status bar displays a **Successful** message upon completion.

---

**Deleting trunk group user permissions**

This section provides the procedure for deleting the trunk group permissions definition for a CMS user.
Steps

To delete the trunk group permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.  
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations** list, highlight **Trunk Group Access**.

3. In the **ACD** field, select the ACD containing the trunk group for which the user has a permissions definition.

4. Select **OK**.  
   *Supervisor* displays the **User Permissions Trunk Group Access** window.

5. In the **User ID** field, enter the name of the user for which the trunk group permissions definition is to be deleted.

6. If the specific trunk group to view for this user is known, enter the name or number of the trunk group in the **Trunk Groups** field. To return all trunk groups for this user ID, leave this field blank.
7. From the menu bar, select Actions > Find one.

   The database is queried and the number of matches found for this user ID displays in the status bar. The first match found populates the fields of this dialog box.

   If multiple matches are found, use the Next and Previous items found under the Action menu to navigate to the correct trunk group.

8. From the menu bar, select Actions > Delete.

   The permissions definition for this user ID and the associated trunk group is deleted. The status bar displays a Successful message upon completion of the action.

   This action does not delete the permission definitions for all trunk groups for this user, only the one displayed in the Trunk Groups: field.
Vector access

Vector permissions allow users to view data for vector reports, view vector configuration information, and change vector configurations. The User Permissions Vector Access window is also used to configure which users receive exception notifications.

This feature is not available if the Vectoring product has not been purchased and installed.

This section contains the following topics:

- Before you begin on page 440
- Permissions on page 441
- Adding vector user permissions on page 441
- Viewing vector user permissions on page 443
- Listing all vector user permissions on page 445
- Modifying vector user permissions on page 446
- Deleting vector user permissions on page 448

Before you begin

The following items should be read and understood before working with vector permissions:

- A CMS user ID must be created through the User Data feature before it can be assigned vector permissions.
- When a new user ID is created through the User Data feature, vector permission definitions for that user are not created. This is done to conserve disk space. When a vector permissions definition does not exist for a user ID, CMS will deny read and write access to vectors.
- A user ID must first have permissions for the ACD on which the vector resides before vector permissions can be assigned. If a user ID is assigned vector permissions and does not have the appropriate ACD permissions, Supervisor displays an error message.
- A user ID cannot be assigned the write permission without first having the read permission.
- Assigning only those permissions that are necessary for each user ID ensures the best system performance.
- A user must be given the exceptions permission in order to be notified of vector exceptions that occur.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view vector user permissions, the user ID used to log in to this Supervisor session requires read permission for the User Permissions subsystem.
- To add, delete, or modify vector user permissions, the user ID used to log in to this Supervisor session requires write permission for the User Permissions subsystem.

Adding vector user permissions

This section provides the procedure for adding a vector permissions definition for a CMS user.

Before you begin

The following items should be read and understood before adding a vector permissions definition for a CMS user:

- If a user does not have corresponding ACD permissions for the permissions set for them on the vector, Supervisor displays an error message.
- When the permissions definition for a user is created, the vector permissions do not take effect until the user logs off and back on again.
Steps

To add a vector permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.
   
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations**: list, highlight **Vector Access**.

3. In the **ACD**: field, select the ACD containing the vector for which the user will be given permissions.

4. Select **OK**.
   
   *Supervisor* displays the **User Permissions Vector Access** window.

5. In the **User ID**: field, enter the name of the user who will be assigned vector permissions.

6. In the **Vectors**: field, enter the name or number of the vector for which the user will have permissions assigned.

   This field can accept multiple vectors. Multiple entries must be separated by a semicolon (**;**).

7. Place a check mark in the permissions that will be assigned to this user:
Vector access

- **Read**: User can view but not modify information for the specified vectors including reports.

- **Write**: User can modify information on the specified vectors. This permission requires that the user also have the *read* permission.

- **Exceptions**: User will receive notification of exceptions occurring on the specified vectors.

Only the vector exceptions made active through the **Exceptions** feature will provide notification to the user. See Chapter 8: Administering exceptions on page 305 for more information.

8. After assigning the necessary permissions, select **Actions > Add** from the menu bar.

The vector permissions for this user are saved.

It is possible to add permission definitions for multiple vectors at one time. To do so, enter multiple vectors in the **Vectors**: field and separate them with semicolons (;).

---

**Viewing vector user permissions**

This section provides the procedure for viewing the vector permissions definition for a **CMS** user.

**Before you begin**

The following items should be read and understood before viewing vector permission definitions for **CMS** users:

- The wildcard characters * and ? cannot be used in the **User Permissions Vector Access** window.
Administering user permissions

Steps
To view the vector permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.
   
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations**: list, highlight **Trunk Group Access**.

3. In the **ACD**: field, select the ACD containing the vector for which the user has a permissions definition.

4. Select **OK**.
   
   *Supervisor* displays the **User Permissions Vector Access** window.

5. In the **User ID**: field, enter the name of the user for which the vector permissions definition is to be viewed.

6. If the specific vector to view for this user is known, enter the name or number of the vector in the **Vectors**: field. To have all vectors returned for this user ID, leave this field blank.

   This field can accept multiple vectors. Multiple entries must be separated by a semicolon (**;**).
7. From the menu bar, select **Actions > Find one**.

The database is queried and the number of matches found for this user ID displays in the status bar.

---

**Listing all vector user permissions**

This section provides the procedure for listing all of the user permission definitions for a vector.

**Before you begin**

The following items should be read and understood before listing all vector permission definitions for **CMS** users:

- The wildcard characters * and ? cannot be used in the **User Permissions Vector Access** window.

**Steps**

To list all user permission definitions for a vector:

1. On the Controller window, select **Tools > User Permissions**.

   **Supervisor** displays the **User Permissions** window.

2. In the **Operations**: list, highlight **Vector Access**.

3. In the **ACD**: field, select the ACD containing the vector for which all permission definitions will be shown.
4. Select OK. Supervisor displays the User Permissions Vector Access window.

5. From the menu bar, select Actions > List all. Supervisor displays a secondary window listing all user permissions for vectors on the specified ACD.

A filter can be created when listing all user vector permission definitions. This filter is based on any information contained in the fields on this dialog box when the List all action is performed.

For example, to view all of the user permission definitions for vector 1, enter 1 in the Vectors: field before performing the List all action. This will cause only the user permission definitions for vector 1 to display. If more information is entered into the other fields of this dialog box, the results will be more restricted. If information for the user ID, vectors, and permissions are entered, the List all command will only return those permission definitions which match all of the information.

---

Modifying vector user permissions

This section provides the procedure for modifying the vector permissions definition for a CMS user.

Before you begin
The following items should be read and understood before modifying vector permissions:

- When the permissions definition for a user is modified, the change does not take effect until the user logs off and back on again.
- If a user does not have corresponding ACD permissions for the permissions set for them on the vector, Supervisor displays an error message.
- The wildcard characters * and ? cannot be used in the User Permissions Vector Access window.
Steps
To modify the vector permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations:** list, highlight **Vector Access**.
3. In the **ACD:** field, select the ACD containing the vector for which the user has a permissions definition.
4. Select **OK**.
   *Supervisor* displays the **User Permissions Vector Access** window.

5. In the **User ID:** field, enter the name of the user for which the vector permissions definition is to be modified.
6. If the specific vector to view for this user is known, enter the name or number of the vector in the **Vectors:** field. To have all vectors returned for this user ID, leave this field blank.
   This field can accept multiple vectors. Multiple entries must be separated by a semicolon (**;**).
7. From the menu bar, select **Actions > Find one.**

   The database is queried and the number of matches found for this user ID displays in the status bar. The first match found populates the fields of this dialog box.

   If multiple matches are found, use the **Next** and **Previous** items found under the **Action** menu to navigate to the correct vector.

8. Change the permissions for the user on this vector as needed:
   - **Read:** - User can view but not modify information for the specified vectors including reports.
   - **Write:** - User can modify information on the specified vectors. This permission requires that the user also have the *read* permission.
   - **Exceptions:** - User will receive notification of exceptions occurring on the specified vectors.

   **Important:**
   - If all permissions are to be removed for this user ID, it saves more server disk space to delete this permission definition rather than disabling all permissions.

   Only the vector exceptions made active through the **Exceptions** feature will provide notification to the user. See Chapter 8: Administering exceptions on page 305 for more information.

9. After the necessary permission changes have been completed, select **Actions > Modify** from the menu bar.

   The permissions definition for this user ID and vector is updated. The status bar displays a **Successful** message upon completion.

### Deleting vector user permissions

This section provides the procedure for deleting the vector permissions definition for a CMS user.
Steps

To delete the vector permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.
   
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations** list, highlight **Vector Access**.

3. In the **ACD** field, select the ACD containing the vector for which the user has a permissions definition.

4. Select **OK**.
   
   *Supervisor* displays the **User Permissions Vector Access** window.

5. In the **User ID** field, enter the name of the user for which the vector permissions definition is to be deleted.

6. If the specific vector to view for this user is known, enter the name or number of the vector in the **Vectors** field. To return all vectors for this user ID, leave this field blank.
7. From the menu bar, select **Actions** > **Find one**.
   The database is queried and the number of matches found for this user ID displays in the status bar. The first match found populates the fields of this dialog box.
   If multiple matches are found, use the **Next** and **Previous** items found under the **Action** menu to navigate to the correct vector.

8. From the menu bar, select **Actions** > **Delete**.
   The permissions definition for this user ID and the associated vector is deleted. The status bar displays a successful message upon completion of the action.
   This action does not delete the permission definitions for all vectors for this user, only the one displayed in the **Vectors**: field.
VDN access

Vector Directory Number (VDN) permissions allow users to view data for VDN reports, view VDN configuration information, and change VDN configurations. The User Permissions VDN Access window is also used to configure which users receive exception notifications.

This feature is not available if the Vectoring product has not been purchased, installed, and enabled on the corresponding ACD.

This section contains the following topics:

- **Before you begin** on page 451
- **Permissions** on page 452
- **Adding VDN user permissions** on page 452
- **Viewing VDN user permissions** on page 454
- **Listing all vector user permissions** on page 445
- **Modifying vector user permissions** on page 446
- **Deleting VDN user permissions** on page 459

### Before you begin

The following items should be read and understood before working with VDN permissions:

- A **CMS** user ID must be created through the **User Data** feature before it can be assigned VDN permissions.

- When a new user ID is created through the **User Data** feature, VDN permission definitions for that user are not created. This is done to conserve disk space. When a VDN permissions definition does not exist for a user ID, **CMS** denies read and write access to VDNs.

- A user ID must first have permissions for the ACD on which the VDN resides before VDN permissions can be assigned. If a user ID is assigned VDN permissions and does not have the appropriate ACD permissions, **Supervisor** an error message.

- A user ID cannot be assigned the write permission without first having the read permission.

- Assigning only those permissions that are necessary for each user ID ensures the best system performance.

- A user must be given the exceptions permission in order to be notified of VDN exceptions that occur.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view VDN user permissions, the user ID used to log in to this Supervisor session requires read permission for the User Permissions subsystem.
- To add, delete, or modify VDN user permissions, the user ID used to log in to this Supervisor session requires write permission for the User Permissions subsystem.

Adding VDN user permissions

This section provides the procedure for adding a VDN permissions definition for a CMS user.

Before you begin

The following items should be read and understood before adding a VDN permissions definition for a CMS user:

- If a user does not have corresponding ACD permissions for the permissions set for them on the VDN, Supervisor displays an error message.
- When the permissions definition for a user is created, the VDN permissions do not take effect until the user logs off and back on again.
Steps

To add a VDN permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.
   
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations**: list, highlight **VDN Access**.

3. In the **ACD**: field, select the ACD containing the VDN for which the user will be given permissions.

4. Select **OK**.
   
   *Supervisor* displays the **User Permissions VDN Access** window.

5. In the **User ID**: field, enter the name of the user who will be assigned VDN permissions.

6. In the **VDNs**: field, enter the name or number of the VDN for which the user will have permissions assigned.
   
   This field can accept multiple VDNs. Multiple entries must be separated by a semicolon (**;**).

7. Place a check mark in the permissions that will be assigned to this user:
Administering user permissions

- **Read**: User can view but not modify information for the specified VDNs including reports.

- **Write**: User can modify information on the specified VDNs. This permission requires that the user also have the read permission.

- **Exceptions**: User will receive notification of exceptions occurring on the specified VDNs.

  Only the VDN exceptions made active through the Exceptions feature will provide notification to the user. See Chapter 8: Administering exceptions on page 305 for more information.

8. After assigning the necessary permissions, select **Actions > Add** from the menu bar.

   The VDN permissions for this user are saved.

   It is possible to add permission definitions for multiple VDNs at one time. To do so, enter multiple VDNs in the **VDNs:** field and separate them with semicolons (;).

---

### Viewing VDN user permissions

This section provides the procedure for viewing the VDN permissions definition for a CMS user.

**Before you begin**

The following items should be read and understood before viewing VDN permission definitions for CMS users:

- The wildcard characters * and ? cannot be used in the User Permissions VDN Access window.
**Steps**

To view the VDN permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.
   
   *Supervisor* displays the **User Permissions** window.

   ![User Permissions window](image)

2. In the **Operations** list, highlight **Trunk Group Access**.

3. In the **ACD** field, select the ACD containing the VDN for which the user has a permissions definition.

4. Select **OK**.
   
   *Supervisor* displays the **User Permissions VDN Access** window.

   ![User Permissions VDN Access window](image)

5. In the **User ID** field, enter the name of the user for which the VDN permissions definition is to be viewed.

6. If the specific VDN to view for this user is known, enter the name or number of the VDN in the **VDNs** field. To have all VDNs returned for this user ID, leave this field blank.

   This field can accept multiple VDNs. Multiple entries must be separated by a semicolon (;).
7. From the menu bar, select **Actions > Find one**.

The database is queried and the number of matches found for this user ID is displayed in the status bar.

---

### Listing all VDN user permissions

This section provides the procedure for listing all of the user permission definitions for a VDN.

**Before you begin**

The following items should be read and understood before listing all VDN permission definitions for **CMS** users:

- The wildcard characters * and ? cannot be used in the **User Permissions VDN Access** window.

**Steps**

To list all user permission definitions for a VDN:

1. On the Controller window, select **Tools > User Permissions**.

   **Supervisor** displays the **User Permissions** window.

2. In the **Operations**: list, highlight **VDN Access**.

3. In the **ACD**: field, select the ACD containing the VDN for which all permission definitions will be shown.
4. Select **OK**.

*Supervisor* displays the **User Permissions VDN Access** window.

5. From the menu bar, select **Actions > List all**.

*Supervisor* displays a secondary window listing all user permissions for VDNs on the specified ACD.

A filter can be created when listing all user VDN permission definitions. This filter is based on any information contained in the **User ID:** and **VDNs:** fields on this dialog box when the **List all** action is performed.

For example, to view all of the user permission definitions for VDN 10, enter 10 in the **VDNs:** field before performing the **List all** action. This will cause only the user permission definitions for VDN 10 to display. If more information is entered into the other fields of this dialog box, the results will be more restricted. If information for the user ID, VDNs, and permissions are entered, the **List all** command will only return those permission definitions which match all of the information.

---

**Modifying VDN user permissions**

This section provides the procedure for modifying the VDN permissions definition for a **CMS** user.

This feature is available if the following items are true:

- The Vectoring feature has been purchased and installed.
- VDN permission checking is enabled.

**Before you begin**

The following items should be read and understood before modifying VDN permissions:

- When the permissions definition for a user is modified, the change does not take effect until the user logs off and back on again.
- If a user does not have corresponding ACD permissions for the permissions set for them on the VDN, *Supervisor* displays an error message.
Administering user permissions

- The wildcard characters * and ? cannot be used in the User Permissions VDN Access window.

Steps
To modify the VDN permissions definition for a CMS user:

1. On the Controller window, select Tools > User Permissions. 
   *Supervisor* displays the User Permissions window.

2. In the Operations: list, highlight VDN Access.

3. In the ACD: field, select the ACD containing the VDN for which the user has a permissions definition.

4. Select OK. 
   *Supervisor* displays the User Permissions VDN Access window.

5. In the User ID: field, enter the name of the user for which the VDN permissions definition is to be modified.
6. If the specific VDN to view for this user is known, enter the name or number of the VDN in the **VDNs:** field. To have all VDNs returned for this user ID, leave this field blank. This field can accept multiple VDNs. Multiple entries must be separated by a semicolon (;).

7. From the menu bar, select **Actions > Find one.**

The database is queried and the number of matches found for this user ID displays in the status bar. The first match found populates the fields of this dialog box.

If multiple matches are found, use the **Next** and **Previous** items found under the **Action** menu to navigate to the correct VDN.

8. Change the permissions for the user on this VDN as needed:

   - **Read:** - User can view but not modify information for the specified VDNs including reports.
   - **Write:** - User can modify information on the specified VDNs. This permission requires that the user also have the *read* permission.
   - **Exceptions:** - User will receive notification of exceptions occurring on the specified VDNs.

   **Important:**
   If all permissions are to be removed for this user ID, it saves more server disk space to delete this permission definition rather than disabling all permissions.

Only the VDN exceptions made active through the **Exceptions** feature will provide notification to the user. See Chapter 8: **Administering exceptions** on page 305 for more information.

9. After the necessary permission changes have been completed, select **Actions > Modify** from the menu bar.

The permissions definition for this user ID and VDN is updated. The status bar displays a **Successful** message upon completion.

---

**Deleting VDN user permissions**

This section provides the procedure for deleting the VDN permissions definition for a **CMS** user.
Administering user permissions

Steps

To delete the VDN permissions definition for a CMS user:

1. On the Controller window, select **Tools > User Permissions**.
   *Supervisor* displays the **User Permissions** window.

2. In the **Operations:** list, highlight **VDN Access**.

3. In the **ACD:** field, select the ACD containing the VDN for which the user has a permissions definition.

4. Select **OK**.
   *Supervisor* displays the **User Permissions VDN Access** window.

5. In the **User ID:** field, enter the name of the user for which the VDN permissions definition is to be deleted.

6. If the specific VDN to view for this user is known, enter the name or number of the VDN in the **VDNs:** field. To return all VDNs for this user ID, leave this field blank.
7. From the menu bar, select **Actions > Find one**.

   The database is queried and the number of matches found for this user ID displays in the status bar. The first match found populates the fields of this dialog box.

   If multiple matches are found, use the **Next** and **Previous** items found under the **Action** menu to navigate to the correct VDN.

8. From the menu bar, select **Actions > Delete**.

   The permissions definition for this user ID and the associated VDN is deleted. The status bar displays a **Successful** message upon completion of the action.

   This action does not delete the permission definitions for all VDN for this user, only the one displayed in the **VDNs** field.
Administering user permissions
Chapter 10: Configuring CMS system settings

This section provides procedures on viewing and changing the setup of the CMS system configured during the initial installation. These configuration values are used in adjusting the state of the system and the collection, storage, and retrieval of data. Making changes to these configuration settings can affect system performance, disk space usage, and data collection.

This section contains the following topics:

- **Before you begin** on page 463
- **CMS state** on page 464
- **Data collection** on page 468
- **Data Storage Allocation** on page 471
- **Data summarizing** on page 480
- **External Application Status** on page 483
- **Free Space Allocation** on page 489
- **Migrating CMS data** on page 497
- **Pseudo-ACDs** on page 502
- **Storage intervals** on page 510
- **Switch setup** on page 520

---

**Before you begin**

If an ACD Group is selected as the current ACD in the System Setup window, only those operations that are valid for the ACD Group will appear in the Operations: list.
CMS state

CMS can run in two operational states:

● Multi-user mode - Any defined user can log on to CMS.
● Single-user mode - Only one user can be logged on to the CMS server at a time.

The single-user mode is necessary when changes must be made to the following systems and procedures:

● Change Master ACD
● Data storage allocation
● Storage intervals
● Restore specific types of data
● Migrate specific types of data

The CMS State window can be used to select which ACD serves as the master for time synchronization. The time displayed on the Controller window originates from the master ACD.

This section contains the following topics:

● Before you begin on page 464
● Permissions on page 465
● Changing the CMS state on page 465
● Changing the master ACD on page 466

Before you begin

The following items should be read and understood before changing the CMS state:

● Viewing data in the Data Storage Allocation, Storage Intervals, and Restore Data windows can be done through both the multi-user and single-user modes.

● To add to or modify configuration settings for the Data Storage Allocation, Storage Intervals, or Restore Data windows requires that the CMS state is set to single-user mode.

● If a log out is performed while CMS is still in the single-user state, at least ten seconds must pass before a logon can be performed.

● When in single-user mode, CMS continues to collect data for all ACDs with the data collection feature enabled.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view the CMS state or the master ACD, the user ID used to log on to this Supervisor session requires read permission for the CMS System Setup feature.
- To modify the CMS state or the master ACD, the user ID used to log on to this Supervisor session requires write permission for the CMS System Setup feature.

Changing the CMS state

This section provides the procedure for changing the state of the CMS system to single-user or multi-user mode.

Steps

To change the current CMS state:

1. From the Controller window, select Tools > System Setup.... Supervisor displays the CMS System Setup window.

2. In the Operations: list, highlight CMS State.
Configuring CMS system settings

3. Select **OK**.

_Supervisor_ displays the **CMS State** window.

![CMS State window](image)

4. Under **CMS user mode**;, select one of the following options:

- **Single-user mode** - Specifies that the CMS state is being set to single-user mode. When CMS is set to single-user mode, a message box displays to all users indicating that CMS will be brought down in one minute. Users are automatically logged off after one minute.

- **Multi-user mode** - Specifies that the CMS state is being set to allow multiple users to log on to CMS

5. After selecting the **CMS user mode**, select **Actions > Modify** from the menu bar.

If the **CMS user mode** is set to single-user, all CMS users are notified to log off. If the **CMS user mode** is set to multi-user, CMS users can again log on to the system.

---

**Changing the master ACD**

This section provides the procedure for selecting the master ACD which will be used for time synchronization.

**Steps**

⚠️ **Important:**

Changing the master ACD requires that you turn data collection off.
To select the ACD which will serve as the master for time synchronization:

1. From the Controller window, select **Tools > System Setup....**  
   *Supervisor* displays the **CMS System Setup** window.

2. In the **Operations** list, highlight **CMS State**.
3. Select **OK**.  
   *Supervisor* displays the **CMS State** window.

4. In the **Master ACD for clock synchronization** field, select the ACD that will serve as the master for the synchronization of time for **CMS**.
5. After selecting the master ACD, select **Actions > Modify** from the menu bar.  
   The selected ACD is set as the master for time synchronization and the status bar displays a **Successful** message.
Data collection

The Data Collection window is used to enable and disable the storing of data for real ACDs. When data collection is disabled, no contact center data is recorded during the current interval. Also, reports run to include this time period will not accurately reflect the activities in the contact center.

This section contains the following topic:

- Before you begin on page 468
- Permissions on page 469
- Changing the data collection state on page 469

Before you begin

The following items should be read and understood before working with the data collection feature:

- When data collection is enabled, the connection status of the link should be monitored to ensure data is being transferred. Use the Connection Status feature in the Maintenance subsystem to view this information.
- The data collection feature does not apply for pseudo-ACDs as they do not collect data.
- When changing the data collection status, each ACD must be administered separately.
- Data collection must be disabled when making changes to the following features:
  - Data Storage Allocation
  - Storage Intervals
  - Change Master ACD
  - Restore specific types of data
  - Migrate specific types of data
  
  Viewing data through the features listed above can be done with data collection enabled.
- Data collection must be enabled for the current ACD in order to activate an agent trace or do any switch administration from CMS.
- When data collection is disabled, no new data is collected. If calls are in the system, the data they generate is not recorded in CMS. If data collection is to be disabled, it is best to wait for the current interval to be archived so that data loss is minimized.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view Data Collection settings, the user ID used to log on to this Supervisor session requires read permission for the CMS System Setup feature.
- To modify the Data Collection settings, the user ID used to log on to this Supervisor session requires write permission for the CMS System Setup feature.

Changing the data collection state

This section provides the procedure for enabling or disabling data collection for an ACD.

Steps

1. On the Controller window, select Tools > System Setup....
   Supervisor displays the CMS System Setup window.

2. In the Operations: list, highlight Data Collection.
3. Select **OK**.

*Supervisor* displays the **Data Collection** window.

4. In the **ACD** field, select the ACD which will have data collection turned on or off.

5. Under **Data collection**, select one of the following options:
   - **On**: Enables data collection for the selected ACD.
   - **Off**: Disables data collection for the selected ACD.
Data Storage Allocation

The Data Storage Allocation window is used to specify the amount of historical data saved by CMS and the duration for which it is saved. The amount of data saved and the duration for which it is saved affects disk space on the server and is limited by the configuration of the system. Data storage parameters are initially set during installation.

This section contains the following topics:

- Before you begin on page 471
- Permissions on page 472
- Viewing Data Storage Allocation on page 472
- Modifying Data Storage Allocation on page 474

Before you begin

The following items should be read and understood before working with Data Storage Allocation:

- A full maintenance backup should be performed before changing the Data Storage Allocation configuration.

- If changes to the Communication Manager system are made through the swsetup command on the CMS console, the settings for Data Storage Allocation should be checked to ensure that storage is set for any new or modified entities. For example, enable the Call Vectoring feature requires data storage space for VDNs and vectors. Changing the release of the Communication Manager system may change the number of measured entities allowed and affect the storage allocation for each entity.

- Disable data collection for all real ACDs before making modifications through Data Storage Allocation.

- Set the CMS state to single-user mode before making modifications through Data Storage Allocation.

- When determining the amount of storage space needed, remember that future growth of items, such as trunk groups or splits/skills, need to be taken into account.

- For reference, print out the Data Storage Allocation window before modifications are made.

- If a Data Storage Allocation window is modifying data, do not open a second Data Storage Allocation window. Wait for the first window to finish the modifications as performing simultaneous modifications through two Data Storage Allocation windows can result in damage to data tables.
Activating a feature such as vectoring requires not only changing switch parameters but also requires the allocation of space for VDNs and vectors which did not have space previously allocated.

The amount of free space available on the server limits the maximum amount of storage space usable through **Data Storage Allocation**. Use the **Free Space Allocation** window to view the utilization of disk space before making changes to **Data Storage Allocation**. If changes are made to the **Data Storage Allocation** settings, you must run **Free Space Allocation** so that the disk space is properly adjusted.

The length of the intrahour interval affects the amount of disk space required to store intrahour data. For example, an intrahour interval of 30 minutes requires twice the amount of disk space than an intrahour interval of 60 minutes.

If the Call Vectoring feature has not been purchased and installed, the fields corresponding to call work codes, vectors, and VDNs are not displayed.

The data storage values determine how much data is available for running historical reports. For example, if weekly and monthly data is not saved, weekly or monthly reports display no data.

Disk space affects the amount of historical data that can be stored. The following list provides the maximum durations possible when storing historical data:

- Intrahour - 62 days
- Daily - 1825 days (5 years)
- Weekly - 520 weeks (10 years)
- Monthly - 120 months (10 years)

---

**Permissions**

Depending on the procedure that you want to perform, you need the following permissions:

- To view **Data Storage Allocation** settings, the user ID used to log on to this **Supervisor** session requires **read** permission for the **CMS System Setup** feature.

- To modify **Data Storage Allocation** settings, the user ID used to log on to this **Supervisor** session requires **write** permission for the **CMS System Setup** feature.

---

**Viewing Data Storage Allocation**

This section provides the procedure for viewing the **Data Storage Allocation** parameters.
Steps

1. From the Controller window, select **Tools > System Setup**.
   
   *Supervisor* displays the **CMS System Setup** window.

2. In the **Operations** list, highlight **Data Storage Allocation**.

3. In the **ACD** field, select the ACD for which the data storage settings will be viewed.
Configuring CMS system settings

4. Select OK.

*Supervisor* displays the **Data Storage Allocation** window.

---

**Modifying Data Storage Allocation**

This section provides the definitions of the fields displayed in the **Data Storage Allocation** window and suggestions for determining the necessary values. The data storage configuration is performed on a per-ACD basis. In a multi-ACD environment, data storage allocation should not be set too high as it can exceed disk capacity for storing information for the other ACDs.

**Before you begin**

Before modifying the configuration of the **Data Storage Allocation** window, the following must occur:

- Data collection for all real ACDs must be disabled.
- The CMS state must be set to single-user mode.
A full maintenance backup should be performed before changing the Data Storage Allocation configuration.

Data storage allocation needs vary among installations. Base your CMS data storage needs on these criteria:

- The available disk space on your CMS system
- The number of real and pseudo-ACDs on the CMS system
- The size of the real ACDs and all pseudo-ACDs, such as number of agents, trunks, and so forth.
- The length of time for data to be stored. For example, 30 days versus 100 days versus two years.
Fields

The following table lists the fields found on the Data Storage Allocation window.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Item</td>
<td>Lists the maximum number of splits/skills, trunk groups, trunks, call work codes, vectors, and VDNs allowed for the system.</td>
</tr>
<tr>
<td># of Items</td>
<td>The number of splits/skills, trunk groups, trunks, call work codes, vectors, and VDNs for which data storage space should be allocated. When this window is initially displayed, these fields display the number of currently administered data items. These numbers should include expected growth. For example, a 30 in this field for Splits/Skills indicates that storage space is allocated for 30 splits/skills. The system may have only 25 splits/skills in existence, but this number allows for future growth.</td>
</tr>
<tr>
<td>Days of Intrahour</td>
<td>The number of days where the system stores intrahour data for splits/skills, agents, trunk groups, trunks, call work codes, vectors, and VDNs. Each entity can have a different number of days associated with it. A 0 (zero) in this field causes the system to discard intrahour data which also means that no daily, weekly, or monthly data can be collected. When data collection reaches the end of the length of time specified, the data is combined, archived, and appended into daily information.</td>
</tr>
</tbody>
</table>
### Days of Daily
The number of days for which the system stores daily data for splits/skills, agents, trunk groups, trunks, call work codes, vectors, and VDNs. Each entity can have a different number of days associated with it. A 0 (zero) in this field causes the system to discard daily data which also means that no daily or weekly data can be collected. When data collection reaches the end of the length of time specified, the data is combined, archived, and appended into weekly information.

### Weeks of Weekly
The number of weeks for which the system stores weekly data for splits/skills, agents, trunk groups, trunks, call work codes, vectors, and VDNs. Each entity can have a different number of weeks associated with it. A 0 (zero) in this field causes the system to discard weekly data. When data collection reaches the end of the length of time specified, the data is combined, archived, and appended into monthly information.

### Months of Monthly
The number of months for which the system stores monthly data for splits/skills, agents, trunk groups, trunks, call work codes, vectors, and VDNs. Each entity can have a different number of months associated with it. A 0 (zero) in this field causes the system to discard monthly data. When data collection reaches the end of the length of time specified, the data is deleted.

### Shift n times (1, 2, 3, or 4)
The shift start and stop times for each shift of agents (up to four shifts) for the specified ACD. This information is used to calculate the amount of space to be reserved for this historical agent table. Shifts may overlap.

If you specify a shift that starts before the data collection start time or ends after the data collection stop time, you receive an error message. The data collection start and stop times are found in the Storage Intervals window in System Setup... CMS rounds shift times to the nearest interval. For example, if you use 30-minute intervals and specify a shift from 8:15 to 5:15, CMS assumes that this shift is from 8:00 to 5:30. Shift must be at least one minute in length.

Specify 24-hour shifts according to the following example:
8:00AM to 7:59AM This information is used throughout CMS.

### Maximum agents logged in
The maximum number of agents logged in during the shift
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total split/skill members, summed over all splits/skills</td>
<td>The maximum number of agents or extensions across all splits/skills that are measured or logged in at any one time. This number should include those agents or extensions that are members of multiple splits/skills. For this field, each split/skill the agent belongs to counts as a split/skill member. Using this method of determining members results in a higher number than the number of agents. For Communication Manager systems without Expert Agent Selection (EAS), this value represents the maximum number of administered split members. For Communication Manager systems with EAS, this value represents the maximum agent/skill pairs (skill members) that are logged in.</td>
</tr>
<tr>
<td>Number of agent login/logout records</td>
<td>The number of agent login/logout records stored by the system. Each time an agent logs in, the system creates a login/logout record. The subsequent logout of the agent also uses this same record. If, at a later time, the agent logs in again, another login/logout record is created. The following equation demonstrates how this number is calculated: [(\text{Number of agents}) \times (\text{Number of times each agent logs in each day}) = \text{Number of agent login/logout records}] If there are 200 agents and each agent logs in three times per day, using the equation above would result in 600 agent login/logout records for this field. When skills for an agent are changed, a new login/logout record is generated if the agent is currently logged in to the system.</td>
</tr>
<tr>
<td>Number of agent trace records</td>
<td>The number of agent trace records for the currently specified ACD. This number is not representative of all ACDs.</td>
</tr>
</tbody>
</table>
| Number of unmeasured trunk facilities      | The number of trunks not measured by the CMS system. An unmeasured trunk facilities are used for:  
  - Internal calls (intraswitch) to a measured split or agent  
  - Internal calls to VDNs  
  - Calls made by agents to internal destinations or using a trunk group that is not measured  
  - Transfers and conferences until the transfer/conference is complete  
This number should be set high enough to handle the traffic expected over these unmeasured trunks, but cannot exceed the maximum number of trunks minus the number of measured trunks. The default value for this field is 300. |
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of exception records</td>
<td>The total number of exceptions stored for CMS. This total is for each type of exception, such as agents, splits/skills, VDNs, and so forth.</td>
</tr>
<tr>
<td>Number of call records</td>
<td>The number of call records the system stores for a selected ACD. Using the CMS server for storage and analysis allows a maximum of 5000 records. If the Avaya CMS External Call History product has been purchased and installed, another computer can be used for storage and analysis of the call records. This field then represents the amount of buffer space set aside on the CMS server that is used to collect the call records prior to transmission to the other system. The maximum value for this field using this configuration is 99999999 across all ACDs.</td>
</tr>
</tbody>
</table>
Data summarizing

Data is automatically archived based on the entries in the Storage Intervals window. The Data Summarizing window is used to manually archive data in the daily, weekly, and monthly tables of the historical database.

This section contains the following topic:

- Before you begin on page 480
- Permissions on page 481
- Archiving data on page 481

Before you begin

The following items should be read and understood before working with the Data Summarizing window:

⚠️ Important:
Since data is automatically archived based on the entries in the Storage Intervals window, this tool must not be used unless an archive failed or did not occur.

- Using the Data Summarizing window causes the archiving to happen immediately.
- Multiple data summarizing requests are queued and are run in the order requested.
- Automatic daily, weekly, and monthly data summaries are queued along with manual requests so that just one type of data summarizing occurs at a time.
- Adequate storage space must be made available through the Data Storage Allocation window before archiving can occur.
- A manual archive cannot be performed unless data exists in the daily, weekly, or monthly tables. If a day of data is missing within the period you are attempting to manually archive, the archive will fail.
- Results of daily, weekly, and monthly archives can be viewed through the Error Log Report or the Archiving Status window.
- If CMS is not operational when an automatic archive should occur, an error message is logged which indicates that a manual archive should be performed using the Data Summarizing window.
- If an incomplete week or month is specified as a date, data summarizing will not occur. Partial weekly or monthly data cannot be summarized.
For example, if a week is configured in the **Storage Intervals** window as being Monday through Friday, entering a date which falls on Saturday in the **Data Summarizing** window results in the week previous to the date specified being archived.

**Permissions**

Depending on the procedure that you want to perform, you need the following permissions:

- To view the **Data Summarizing** window, the user ID used to log in to this *Supervisor* session requires *read* permission for the **CMS System Setup** feature.
- To use the **Data Summarizing** window to perform an archive of the system, the user ID used to log in to this *Supervisor* session requires *write* permission for the **CMS System Setup** feature.

**Archiving data**

This section provides the procedure for manually archiving data using the **Data Summarizing** window.

**Steps**

To archive data with the **Data Summarizing** window:

1. From the Controller window, select **Tools > System Setup**.

   *Supervisor* displays the **CMS System Setup** window.

   ![CMS System Setup Window](image)

   2. In the **Operations** list, highlight **Data Summarizing**.
3. Select OK.

Supervisor displays the Data Summarizing window.

4. In the ACD: field, select the ACD for which data will be archived.

5. In the Data type: field, select the appropriate option:

   - **Daily** - Archives data for one day. A daily summaryarchives a partial day. Daily summaries must be complete for each day of the week or month before CMS archives the data for that week or month.

   - **Weekly** - Archives data for one week. A weekly summary must be requested by entering a date that falls within a completed predefined week. See the weekly configuration in the Storage Intervals window.

   - **Monthly** - Archives data for one month. Set any day during the month in a completed month for which monthly data should be summarized.

6. From the menu bar, select Actions > Run.

Supervisor displays a warning message stating that data archiving is a lengthy process and cannot be cancelled. Through this window, it is possible to cancel the data archive, otherwise the process continues when the message box is dismissed.

Archiver started displays on the status line for the first request and Archiver request submitted displays if a data summary is currently in progress.
External Application Status

The External Application Status feature, a separately purchased option for CMS, sends real-time data to an external device or to an external program.

The types of external devices or programs used with the External Application Status feature can consist of the following:

- A wallboard - This is a large display placed in a contact center where all agents can view data. This data can consist of the number of calls in the queue, calls being handled by different splits/skills, and other information.
- An employee scheduler program - This third-party software is used to compare the start and end times for agents with schedules created by management.
- A contact center data consolidation program - This third-party software is used to collect data from all contact centers for reporting purposes.

This section contains the following topics:

- Before you begin on page 483
- Permissions on page 483
- Enabling or disabling the External Application Status feature on page 484
- Viewing the states of external applications on page 485
- Starting or stopping external applications on page 486

Before you begin

The following items should be read and understood before working with the External Application Status feature:

- In the United States, external applications are designed and administered by the Avaya Professional Services Organization. For more information about external applications, call Avaya Contact Center CRM Solutions at 1-877-927-6662. For assistance outside the United States, contact your local Avaya distributor or representative.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view External Application Status data, the user ID used to log in to this Supervisor session requires read permission for the CMS System Setup feature.
Configuring CMS system settings

- To enable or disable the **External Application Status** feature, and start or stop external applications, the user ID used to log in to this **Supervisor** session requires *write* permission for the **CMS System Setup** feature.

---

Enabling or disabling the External Application Status feature

This section provides the procedure for enabling or disabling the **External Application Status** feature. This feature must be enabled before external applications can be started. Disabling this feature will cause **CMS** to stop sending data and the external applications cannot be viewed.

**Steps**

1. From the Controller window, select **Tools > System Setup....**
   
   **Supervisor** displays the **CMS System Setup** window.

2. In the **Operations:** list, highlight **External Application Status**.

3. Select **OK**.
   
   **Supervisor** displays the **External Application Status** window.
4. In the **External Application (Select one):** group, select the **External application feature (turns on/off all applications)** option.

5. Select the appropriate option from the **Application status (Select one):** group:
   - **Start** - This option will enable the **External Application Status** feature.
   - **Stop** - This option will disable the **External Application Status** feature.

6. From the menu bar, select **Actions > Modify.**
   The status bar displays a message indicating if the action succeeded or failed.

---

**Viewing the states of external applications**

This section provides the procedure for viewing the state of one or more external applications through the **External Application Status** window.

**Steps**

To view the states of any external applications:

1. From the Controller window, select **Tools > System Setup....**
   
   **Supervisor** displays the **CMS System Setup** window.

   ![CMS System Setup Window]

2. In the **Operations:** list, highlight **External Application Status.**
3. Select OK. Supervisor displays the **External Application Status** window.

![External Application Status window](image)

4. In the **External Applications (Select one):** group, select **External application feature (turns on/off all applications).**

5. From the menu bar, select **Actions > List all.**

*Supervisor* displays a secondary window displaying one or more applications, their names, and the associated states depending on which option was selected in the step above.

The status of an external application can be one of the following:

- **Starting** - A request to start the external application has been made.
- **Running** - The external application has started and is still running after ten seconds.
- **Stopping** - A request to stop the external application has been made.
- **Stopped** - All processes associated with the external application have stopped.
- **Failed** - The external application has failed repeatedly and is no longer being restarted.

---

### Starting or stopping external applications

This section provides the procedure for starting and stopping external applications through the **External Application Status** window.
Steps

To start or stop an external application:

1. From the Controller window, select **Tools > System Setup**.

   *Supervisor* displays the **CMS System Setup** window.

2. In the **Operations**: list, highlight **External Application Status**.

3. Select **OK**.

   *Supervisor* displays the **External Application Status** window.

4. Select the **Application name**: option and enter the name of the application to start or stop in the adjacent field.

5. In the **Application status (Select one)**: group, select the appropriate option:
   - **Start** - *Supervisor* will attempt to start the specified external application.
   - **Stop** - *Supervisor* will attempt to stop the specified external application.
Configuring CMS system settings

6. From the menu bar, select **Actions > Modify**.

*Supervisor* attempts to carry out the specified action. The status bar displays the results of the action.

The information that displays in the status bar after this step can consist of the following.

- **Starting** - A request to start the external application has been made.
- **Running** - The external application has started and is still running after ten seconds.
- **Stopping** - A request to stop the external application has been made.
- **Stopped** - All processes associated with the external application have stopped.
- **Failed** - The external application has failed repeatedly and is no longer being restarted.
Free Space Allocation

The Free Space Allocation window is used to view the current storage statistics and disk usage for the contact center data collected through CMS. This window also allows administrators to modify the ACD dbspaces (database spaces) so that more chunks can be added or dropped to accommodate the amount of data being stored.

Storage on the CMS server is managed by Informix Dynamic Server (IDS). This feature allows information to be stored in chunks where each one is equivalent to 256 megabytes. Each contact center entity, such as splits/skills, trunk groups, VDNs and so forth, is given an amount of data storage space on the CMS server through the Data Storage Allocation window.

If, at any time, you modify the Data Storage Allocation configuration, the Free Space Allocation window must be used to ensure that the appropriate number of chunks are allocated for use within the affected ACD dbspace. Failure to do so can result in serious data storage problems.

This section contains the following topics:

- Before you begin on page 489
- Permissions on page 490
- Viewing Free Space Allocation on page 490
- Viewing Free Space Allocation contents on page 492
- Modifying Free Space Allocation on page 494
- Verifying chunk allocation on page 495

Before you begin

The following items should be read and understood before working with the Free Space Allocation feature:

- When any of the CMS data storage parameters are altered, the change is reflected (for information purposes only) in the Free Space Allocation window. For example, if the number of splits/skills on your system is increased in the Data Storage Allocation window, the Free Space Allocation window will then display the new number as well as the approximate amount of disk space required to handle the data storage for splits/skills.

- The IDS dbspaces used in the Free Space Allocation window are created during installation.

- It is not necessary to disable the Data Collection feature in order to modify the Free Space Allocation window.
Configuring CMS system settings

● If more data storage space is allocated on a file system than is available, the Allocated Space field in the Free Space Allocation window will display its value in parentheses.

● Be sure to check the Available Space field of an ACD dbspace before increasing any data storage parameters through the Data Storage Allocation feature. Doing this can ensure that there will be enough disk space available.

● Be aware that creating custom tables causes CMS to use more disk space. If dbspace that is used to store custom tables nears capacity, you are presented with a warning message during login.

● Values entered in the CMS System Setup features of Data Storage Allocation, Storage Intervals, and Call Work Codes directly affect usage of disk space. Check Free Space Allocation when any of these features are modified.

● Values entered in the Data Storage Allocation window of Forecast Administration also affect storage space and cause the need for Free Space Allocation to be run.

● If a new ACD is added, a new ACD dbspace will be created. Information on adding a new ACD to the CMS server can be found in the chapter, Maintaining the CMS software, in the Avaya Call Management System Software Installation, Maintenance, and Troubleshooting document.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

● To view the Free Space Allocation window, the user ID used to log in to this Supervisor session requires read permission for the CMS System Setup feature.

● To modify ACD dbspaces through the Free Space Allocation window, the user ID used to log in to this Supervisor session requires write permission for the CMS System Setup feature.

Viewing Free Space Allocation

This section provides the procedure for viewing the Informix Dynamic Server (IDS) storage information and allocations through the Free Space Allocation window.
Steps

To view the usage of data storage for ACD dbspaces:

1. From the Controller window, select **Tools > System Setup**.
   
   *Supervisor* displays the **CMS System Setup** window.

2. In the **Operations** list, highlight **Free Space Allocation**.

3. Select **OK**.
   
   *Supervisor* displays the **Free Space Allocation** input window.

   ![Free Space Allocation window](image)

This window displays the following information for each ACD dbspace:

- **Dbspace Name** - The name assigned to this ACD dbspace
- **Current Size** - The total amount of disk space used for this dbspace. Since IDS uses 256 MB *chunks*, this number will always be in increments of 256,000 kilobytes.
- **Allocated Size** - The amount of space needed to store data based on the settings in the **Data Storage Allocation** window
Configuring CMS system settings

- **Available Space** - The space that will be available after all data has been collected for the time periods specified in the Data Storage Allocation window. This number is calculated by subtracting Allocated Size from Current Size.

- **Space used to Date** - The amount of data actually stored at this time

The window may take a few minutes to open as CMS is calculating the current free space and other values on the system before the window can be displayed.

---

Viewing Free Space Allocation contents

This section provides the procedure for viewing the allocations for each contact center entity within an ACD dbspace.

**Steps**

To view the amount of storage used by contact center entities within an ACD dbspace:

1. From the Controller window, select Tools > System Setup....

   Supervisor displays the CMS System Setup window.

2. In the Operations: list, highlight Free Space Allocation.
3. Select **OK**.

*Supervisor* displays the **Free Space Allocation** input window.

![Free Space Allocation Window](image)

**Note:**

The window may take a few minutes to open as CMS is calculating the current free space before the window can be displayed.

4. In the **Enter Dbspace name**: field, enter the name of the ACD dbspace to view.

5. From the menu bar, select **Actions > Get contents**.

*Supervisor* displays a secondary window showing the amount of data currently in use by each contact center entity.

![Data in Use Window](image)
Modifying Free Space Allocation

This section provides the procedure for modifying the number of chunks utilized for data storage by Informix Dynamic Server (IDS).

Steps

To modify the number of IDS chunks assigned to ACD dbspaces:

1. From the Controller window, select **Tools > System Setup...**.

   *Supervisor* displays the **CMS System Setup** window.

2. In the **Operations**: list, highlight **Free Space Allocation**.

3. Select **OK**.

   *Supervisor* displays the **Free Space Allocation** input window.
Note:
The window make take a few minutes to open as CMS is calculating the current free space before the window can be displayed.

4. In the Enter DbSpace name:, enter the name of the ACD dbspace to adjust.

5. From the menu bar, select Actions > Modify.

CMS calculates if more, fewer, or the same number of chunks is required for the specified ACD dbspace and displays a dialog box asking if the process should continue.

If less than 256000 KB of disk space is available when the Modify command is executed, an error message will appear that states that no more ACD dbspace chunks can be created.

⚠️ Important:
It is important that you ensure that the Current Size is greater than the Allocated Size. It is possible for you to create the undesired situation where the Allocated Size is larger than the Current Size by setting large values in the Data Storage Allocation window and then not using the Free Space Allocation window to modify the ACD dbspace appropriately. While the Free Space Allocation window may display a positive value in the Total Free Space field, it is important to remember that the Allocated Size field is a projection of how much space will be used in the future when all the data has been collected for the time periods you have specified. If the number in the Available Space field is in parentheses, this indicates that there will not be enough room to store all the data.

6. If CMS requires a change in the number of chunks used by the ACD dbspace, select Yes from the dialog box.

The number of chunks for the specified ACD dbspace is modified and the status bar displays a Successful message.

⚠️ Important:
Do not reboot the system until all chunks have been moved. For more information about verifying when you can reboot the CMS system, see Verifying chunk allocation on page 495.

Verifying chunk allocation

To verify that all chunks have been moved:

1. Open a terminal window. For more information see, Logging in to CMS on page 614.

2. Enter:

   . /opt/informix/bin/setenv
Configuring CMS system settings

3. Enter:
   
   onstat -d |egrep -c 'MR|MD'

4. Repeat Step 3 until only the command prompt is displayed by the system. There must be no MR or MD messages. You can reboot the system when only the command prompt is displayed by the system.
Migrating CMS data

This section provides the procedures and information involved in migrating data from a backup tape that was created using a previous version of CMS and into the database of the new CMS.

This section contains the following topic:
- Before you begin on page 497
- Permissions on page 497
- Migrating R3 data on page 497

Before you begin

The following items should be read and understood before working with the R3 Migrate Data window:

- Attempting to migrate Agent and Call Center Administration data more once may cause serious errors from which recovery is difficult. A re-migration of ACD administration data requires a second setup of the CMS software must be performed.
- To migrate Agent and Call Center Administration data, CMS must be in single-user mode.
- Migrations of system administration data cannot be done in phases. Migrating some user IDs at one time and others at a later time results in two separate sets of data. Only one set of data can be used and cannot be migrated into another set.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To run the R3 Migrate Data process, the user ID used to log in to this Supervisor session requires write permission for CMS System Setup.

Migrating R3 data

This section provides the procedure for using the R3 Migrate Data to merge data created using a previous version of CMS to the database of the current version.
Steps
To migrate R3 data into the current database:

1. From the Controller window, select **Tools > System Setup**....
   *Supervisor* displays the **CMS System Setup** window.

2. In the **Operations:** list, highlight **R3 Migrate Data**.
3. Select **OK**.
   *Supervisor* displays the **R3 Migrate Data** window.

4. In the **Device name:** field, enter the device that will read the backup tape containing the data.
   To list all devices on the system, select **Actions > List devices**.
CAUTION:

If you choose the **System Administration data** option in this step, note that this migration can only be performed once. Performing the migration of this data a second time can result in corruption of the password tables.

5. In the **Data type**: group, select one of the following three options:

<table>
<thead>
<tr>
<th>Data type</th>
<th>Migrated data</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Administration data</td>
<td>Report GEM files (historical)</td>
</tr>
<tr>
<td>(single user required)</td>
<td>Report GEM files (real-time)</td>
</tr>
<tr>
<td></td>
<td>Shortcut settings for <strong>CMS</strong></td>
</tr>
<tr>
<td></td>
<td><strong>CMS</strong> users</td>
</tr>
<tr>
<td></td>
<td>Timetable settings</td>
</tr>
<tr>
<td></td>
<td>Database items</td>
</tr>
<tr>
<td></td>
<td>Hypothetical data for the Forecast product</td>
</tr>
<tr>
<td></td>
<td>Feature access settings, timetables, schedules, and associated tasks from the User Permissions subsystem</td>
</tr>
<tr>
<td></td>
<td>Historical and real-time custom reports</td>
</tr>
<tr>
<td></td>
<td>Menu and interface settings for the <strong>CMS</strong> terminal interface</td>
</tr>
<tr>
<td></td>
<td>Printer parameters for the <strong>CMS</strong> printer</td>
</tr>
</tbody>
</table>
6. In the **Stop date:** field, enter the date through which you wish to record data for migration to the new CMS. The migration process does not migrate data collected after the date specified.

   Leaving this field blank will cause the program to migrate data up to the data written on the tape by the CMS Maintenance Backup procedure.

7. In the **Stop time:** field, enter the time through which you wish to record data for migration to the new CMS. The migration process does not migrate data collected after the stop date and time specified.

   If this field is left blank, the stop time defaults to 23:59.

8. In the **Specify ACD(s) to migrate:** group, select one of the following options:

   - **All ACDs** - Data is migrated from the backup tape to the hard disk on an ACD-by-ACD basis. Data for ACD1 on the tape backup will be used for ACD1 on the new CMS.

<table>
<thead>
<tr>
<th>Data type</th>
<th>Migrated data</th>
</tr>
</thead>
</table>
| Agent/Call Center Admin data (single user required) | ACD profiles - VDN profiles  
Agent trace - agents being traced, trace data  
Agents - shifts, groups  
Dictionary - synonyms  
Exceptions - agent admin, link data, malicious call trace, split admin, splits, split profile, trunk group admin, VDN admin, vector admin  
User permissions - ACD access, split/skill access, trunk groups access, VDN access, vector access  
Forecast - current day report, current day configuration, call handling profiles, costs profiles, data storage allocation, special day admin, manager status, trunk group profiles |
| Historical data            | Exceptions - agent data, split access, trunk groups, trunk group access, VDN data, vector data  
Historical reports - agent activity, agent login/logout, daily agent data, daily call work codes data, daily splits data, daily trunk groups data, daily trunk groups data, daily trunks data, daily VDN data, daily vector data, intrahour agent data, intrahour agent login/logout data, intrahour call work code data, intrahour split data, intrahour trunk group data, intrahour trunk data, intrahour VDN data, intrahour vector data, monthly agent data, monthly call work code data, monthly split data, monthly trunk group data, monthly trunk data, monthly VDN data, monthly vector data, weekly agent data, weekly call work code data, weekly split data, weekly trunk group data, weekly trunk data, weekly VDN data, weekly vector data  
Forecast - daily split data, daily trunk group data, special day split data, interval split data, interval trunk group data |
- **Single ACD** - Historical data is migrated from the backup tape to the hard disk for the ACDs specified in the **from:** and **to:** fields.

  For example, to migrate data from ACD1 on the backup tape to ACD4 on the new CMS, place 1 in the **from:** field and 4 in the **to:** field.

9. From the menu bar, select **Actions > Run.** The **Run** menu item appears only if the settings for **Data Collection** and **CMS State** are appropriate for the type of migration selected.

   *CMS* begins the migration process. The **Status:** field will report the progress of the migration.
Pseudo-ACDs

A pseudo-ACD is an area created on the CMS server to store previously backed-up ACD data. A pseudo-ACD is not a real ACD and does not communicate with any Communication Manager system.

Pseudo-ACDs are used to store data which can then be viewed in reports. This could be useful in the following scenarios:

- Storing data from an off-site contact center for the purposes of reporting in conjunction with an on-site CMS.
- Storing data for archival purposes. This data can no longer be deleted by the Data Storage Allocation feature and can be used to generate reports on older data for comparison with more recent ACD data.

This section contains the following topics:

- **Before you begin** on page 502
- **Permissions** on page 504
- **Creating a pseudo-ACD** on page 504
- **Viewing pseudo-ACDs** on page 505
- **Deleting a pseudo-ACD** on page 506
- **Loading pseudo-ACD data** on page 507

---

Before you begin

The following items should be read and understood before working with pseudo-ACDs:

- Each pseudo-ACD is given a number from 9 through 26. Numbers 1 through 8 are reserved for eight real ACDs connected to the CMS server.
- In order to load the pseudo-ACD data, the CMS server must have enough free space available. Use the Free Space Allocation window to see how much space is required for the existing ACDs and how much is available for the pseudo-ACD data.
- Use the Data Storage Allocation window to define how much historical data will be stored for the pseudo-ACD. Enter storage values equal to or greater than those used from the ACD which originally held the data.
- Use the Storage Intervals window to set storage intervals for the pseudo-ACD data to match the interval size and data collection times of the ACD from which the data was taken.
Pseudo-ACDs

- The Data Collection feature can be running when modifications are made in the Data Storage Allocation or Storage Intervals windows for a pseudo-ACD, but CMS must be in single-user mode.

- If the pseudo-ACD has the separately purchased Forecast feature on it, Forecast Data Storage Allocation parameters may require changes in order to match those of the pseudo-ACD. This is not the same as the Data Storage Allocation window normally used in CMS.

- In order for users to access the pseudo-ACD, permissions must be given through the ACD Access window in the User Permissions subsystem.

- A pseudo-ACD can have a name assigned to it in the Dictionary even before the pseudo-ACD is created.

- Creation of a pseudo-ACD using Supervisor while users are logged in requires that the users log out and back in before they can see the new pseudo-ACD.

- Before deleting a pseudo-ACD, turn off permissions to it so that users will not be working in the pseudo-ACD when it is deleted.

- CMS does not automatically summarize pseudo-ACD data.

- The following menu items are available when a pseudo-ACD is selected and the appropriate user permissions are assigned:

<table>
<thead>
<tr>
<th>Reports</th>
<th>CMS System Setup</th>
<th>Maintenance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Historical</td>
<td>CMS State</td>
<td>ACD Status</td>
</tr>
<tr>
<td>Dictionary</td>
<td>Data Collection</td>
<td>Archiving Status</td>
</tr>
<tr>
<td>all submenu items</td>
<td>Data Storage Allocations</td>
<td>Backup Data</td>
</tr>
<tr>
<td>Forecast</td>
<td>Data Summarizing</td>
<td>Backup/Restore</td>
</tr>
<tr>
<td>all submenu items</td>
<td>Free Space Allocation</td>
<td>Devices</td>
</tr>
<tr>
<td>Custom Reports</td>
<td>Load Pseudo-ACD</td>
<td>Connection Status</td>
</tr>
<tr>
<td>all submenu items</td>
<td>Pseudo-ACD Setup</td>
<td>Printer Administration</td>
</tr>
<tr>
<td>User Permissions</td>
<td>R3 Migrate Data</td>
<td>Restore Data</td>
</tr>
<tr>
<td>all submenu items</td>
<td>Storage Intervals</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Switch Setup</td>
<td></td>
</tr>
</tbody>
</table>
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view the Pseudo-ACD Setup window, the user ID used to log in to this Supervisor session requires read permission for the CMS System Setup feature.
- To add or delete pseudo-ACDs, the user ID used to log in to this Supervisor session requires write permission for the CMS System Setup feature.

Creating a pseudo-ACD

This section provides the procedure for creating a pseudo-ACD on a CMS server.

Steps

To create a pseudo-ACD on a CMS server:

1. From the Controller window, select Tools > System Setup....
   Supervisor displays the CMS System Setup window.

   ![CMS System Setup window](image)

2. In the Operations: list, highlight Pseudo-ACD Setup.
3. Select **OK**.

   *Supervisor* displays the **Pseudo ACD Setup** window.

![Pseudo ACD Setup window](image)

4. In the **ACD**: field, enter the number or the name of the pseudo-ACD. The number can range from 9 to 26. This field requires a number to be entered if a name for this pseudo-ACD has not been defined in the Dictionary.

5. From the menu bar, select **Actions > Add**.

   *CMS* creates the pseudo-ACD.

---

### Viewing pseudo-ACDs

This section provides the procedure for listing the pseudo-ACDs on a *CMS* server.

**Steps**

To list pseudo-ACDs on a *CMS* server:

1. From the Controller window, select **Tools > System Setup**....

   *Supervisor* displays the **CMS System Setup** window.

![CMS System Setup window](image)

2. In the **Operations**: list, highlight **Pseudo-ACD Setup**.
3. Select **OK**.

*Supervisor* displays the **Pseudo ACD Setup** window.

4. From the menu bar, select **Actions > List all**.

*Supervisor* displays a secondary window listing all ACDs. The status bar displays the total number of pseudo-ACDs on the **CMS** server. Only those ACDs for which this user ID has *read* permission are displayed.

---

### Deleting a pseudo-ACD

This section provides the procedure for deleting a pseudo-ACD on a **CMS** server.

**Steps**

To delete a pseudo-ACD on a **CMS** server:

1. From the Controller window, select **Tools > System Setup**.

   *Supervisor* displays the **CMS System Setup** window.

2. In the **Operations** list, highlight **Pseudo-ACD Setup**.
3. Select **OK**.

   Supervisor displays the **Pseudo ACD Setup** window.

![Pseudo ACD Setup window](image)

4. In the **ACD**: field, enter the name or number of a pseudo-ACD to delete.

5. From the menu bar, select **Actions > Find one**.

   The status bar displays whether a match was found for the specified pseudo-ACD.

6. From the menu bar, select **Actions > Delete**.

   CMS deletes the pseudo-ACD, the associated data, and any associated disk space. When the operation completes, Supervisor displays a **Successful** message in the status bar.

---

### Loading pseudo-ACD data

This section provides the procedure for loading historical data archived from an existing ACD into a pseudo-ACD. After the pseudo-ACD receives the data, historical reports can be run with this information.

#### Before you begin

The following items should be read and understood before loading data into a pseudo-ACD:

- A pseudo-ACD must have been created in order for data to be loaded into it.
- Loading data into a pseudo-ACD requires data archived from an existing ACD on a CMS server.
- Set the pseudo-ACD as the current ACD before attempting to load data into it.
- Since the pseudo-ACD accepts any data on a backup volume, the data from a full backup may be more than needed. Loading a pseudo-ACD with a full backup creates the possibility of disk space problems. To eliminate this problem, perform a **Specific Tables** backup when creating the ACD data to load on a pseudo-ACD.
- Loading a pseudo-ACD with data automatically overwrites any existing data currently used by the pseudo-ACD.
Configuring CMS system settings

- The number of splits/skills, agents, and other contact center entities are set to 0 (zero) for the pseudo-ACD when it is created. Set these entities to match the ACD supplying the data. Change these settings through the Call Center Administration feature.

- When created, a new pseudo-ACD has historical data storage parameters set to 0 (zero). To load data into the pseudo-ACD, the historical data storage parameters must be set to those of the ACD from which the data was archived, if not greater. Change these settings through the Data Storage Allocation window.

- The Storage Intervals and Data Collection settings for the pseudo-ACD require configuration in order to match those of the ACD supplying the data. If these settings are incorrect, loading the data into the pseudo-ACD fails.

Permissions

To load data into a pseudo-ACD, the user ID used to log in to this Supervisor session requires write permission for the CMS System Setup feature.

Steps

To load a data backup into a pseudo-ACD:

1. From the Controller window, select Tools > System Setup.... Supervisor displays the CMS System Setup window.

2. In the ACD: field, select the pseudo-ACD that will receive the data.

4. Select **OK**. 

*Supervisor* displays the **Load Pseudo-ACD Data** window.

5. In the **From ACD:** field, enter the number of the ACD used to make the data backup.

6. In the **Device name:** field, enter the name of the device that has the backup volume loaded.

   To list all the devices on the **CMS** server, select **Actions > List devices** from the menu bar.

7. In the **Start date:** field, enter the date representing the first day of historical data to load on the pseudo-ACD. **CMS** searches the data backup for this date which serves as the starting point for loading data.

8. In the **Start time:** field, enter the time of the **Start date:** for which **CMS** will start loading data. The default is **12:00 AM**.

9. In the **Stop date:** field, enter the last date of historical data that **CMS** will load on the pseudo-ACD.

10. In the **Stop time:** field, enter the time of the **Stop date:** for which **CMS** will stop loading data from the data backup. The default is **12:00 AM**.

11. From the menu bar, select **Actions > Run**.

   **CMS** begins loading data from the backup into the pseudo-ACD. The **Status:** field at the top of the window displays events in the loading process. The **Errors:** field displays any problems encountered during the loading process.

   Cancelling the load process before it is finished will cause the pseudo-ACD to have partial data.
Storage intervals

The Storage Intervals window allows changes to be made to CMS which affect how and when data for the contact center is stored.

It is recommended that these settings are configured during installation and not changed because subsequent changes will affect data storage and report data coverage.

This section contains the following topics:

- Before you begin on page 510
- Permissions on page 510
- Viewing storage interval settings on page 511
- Changing the intrahour interval on page 512
- Changing switch time zone on page 514
- Modifying data summarizing settings on page 516

Before you begin

The following items should be read and understood before working with the Storage Intervals window:

- CMS must be in single-user mode and the data collection must be off before modifications to these settings can be made.
- Do not open another Storage Intervals window if one is already being used to alter these settings. The loss of data tables can result if multiple Storage Intervals windows are used.
- Free space allocation, data storage allocation, and storage intervals closely tied. A change in storage intervals may require adjustment of data storage or storage times in the Data Storage Allocation and Free Space Allocation windows. The more frequently CMS archives data, the more storage space is required.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view settings in the Storage Intervals window, the user ID used to log in to this Supervisor session requires read permission for the CMS System Setup feature.
To modify settings in the Storage Intervals window, the user ID used to log in to this Supervisor session requires write permission for the CMS System Setup feature.

Viewing storage interval settings

This section provides the procedure for viewing the Storage Interval settings for contact center data.

Steps

To view settings in the Storage Intervals window:

1. From the Controller window, select Tools > System Setup....
   Supervisor displays the CMS System Setup window.

2. In the Operations: list, highlight Storage Intervals.
3. In the ACD: field, select the ACD for which settings will be viewed.
Configuring CMS system settings

4. Select OK.

Supervisor displays the **Storage Intervals** window.

### Changing the intrahour interval

This section provides the procedure for changing the rate at which CMS archives data within a one-hour time period.

#### Before you begin

The following items should be read and understood before changing the intrahour interval setting:

- Changing the intrahour interval can result in a lengthy process as CMS must make modifications to all previously collected data.

- Increasing the frequency of the intrahour interval results in the contact center data taking more storage space. This can require changes to the length of time for which CMS stores contact center data. To change the length of time which data is stored, use the **Data Storage Allocation** window.

- Perform a full backup of historical data before making changes to the intrahour interval or data collection times or dates. After the changes are made, perform another full backup of historical data.

- Real-time reports use the intrahour interval when displaying data. Cumulative data is reset to zero at the beginning of each intrahour interval.
Storage intervals

Steps
To change the setting for the intrahour interval:

1. From the Controller window, select **Tools > System Setup**.

   *Supervisor* displays the **CMS System Setup** window.

![CMS System Setup Window]

2. In the **Operations**: list, highlight **Storage Intervals**.
3. In the **ACD**: field, select the ACD for which the intrahour interval will be changed.
4. Select **OK**.

   *Supervisor* displays the **Storage Intervals** window.

![Storage Intervals Window]

5. In the **Intrahour interval (Select one)**: group, select the option for the rate at which **CMS** archives contact center data.
Configuring CMS system settings

⚠️ CAUTION:
Do not open another Storage Intervals window and attempt to change other settings during the following step. Doing so can result in the loss of database tables.

6. From the menu bar, select Actions > Modify.

   CMS records the setting change and alters all previously recorded data to match this setting. This update process is lengthy and must not be interrupted. The status bar will display a Successful message when the operation completes.

7. Restart data collection. See Changing the data collection state on page 469 for information on this procedure.

8. Return CMS to multi-user mode. See the Changing the CMS state on page 465 for information on this procedure.

---

Changing switch time zone

This section provides the procedure on changing the time zone settings for an ACD so that it matches the time zone of the CMS server. Use this feature if you want the CMS title bar to show the time where the CMS is located instead of the master ACD time. If you do not use this feature, the CMS title bar will automatically display the master ACD time.

This procedure is only necessary for those configurations where an ACD resides in a different time zone than that of the CMS server, but you want the title bar to display the CMS time.

Before you begin

The following items should be read and understood before changing the time zone for an ACD:

- CMS must be in single-user mode and the data collection must be off before modifications to these settings can be made.
- If an ACD is connected to a CMS server in the same time zone, the Switch time zone offset: field should be set to 0.
- This procedure does not effect the time stamps on the CMS reports, real time or historical.
- This procedure does not effect the timetable schedule for timetables set to run at local times for a specific ACD.
**Steps**

To change the time zone offset for an ACD:

1. From the Controller window, select **Tools > System Setup**....
   
   *Supervisor* displays the **CMS System Setup** window.

   ![CMS System Setup Window](image)

2. In the **Operations**: list, highlight **Storage Intervals**.
3. In the **ACD**: field, select the ACD which will have its time zone offset changed.
4. Select **OK**.
   
   *Supervisor* displays the **Storage Intervals** window.

   ![Storage Intervals Window](image)
Configuring CMS system settings

5. In the **Switch time zone offset (-23 to +23):** field, enter the number of hours that will convert the time zone of the ACD so that it matches the time zone of the **CMS** server.

   If the ACD time is ahead of the **CMS** time, you must enter a plus sign (+) followed by the number of hours the ACD is ahead. If the ACD time is behind the **CMS** time, you must enter a minus sign (-) followed by the number of hours the ACD is behind.

   For example, if the master ACD is in New York City and the **CMS** server is in Los Angeles, you would enter **+3** because the ACD is 3 hours ahead of the **CMS** time. The time zone offset does not affect the time stamps that are used with historical data.

6. From the menu bar, select **Actions > Modify.**

   **CMS** adjust the time setting of the ACD by the value specified. The status bar will display a **Successful** message when the operation is complete.

   **Note:**
   The CMS time reverts to the Unix clock if the link to the ACD that is designated as the master clock stops functioning. Even if the link begins to function normally, the only way CMS will reset back to the master clock is to either:
   - Turn CMS off and then on
   - Reboot the server

7. Restart data collection. See ***Changing the data collection state*** on page 469 for information on this procedure.

8. Return **CMS** to multi-user mode. See ***Changing the CMS state*** on page 465 for information on this procedure.

---

Modifying data summarizing settings

This section provides the procedure for modifying the times and days for which contact center data is recorded and summarized.

**Before you begin**

The following items should be read and understood before modifying data summarizing settings:

- **CMS** must be in single-user mode and the data collection must be off before modifications to these settings can be made.
- Perform a full backup of historical data before making changes to the data collection times or dates. After the changes are made, perform another full backup of historical data.
- When a weekly report is requested, the date entered must correspond to the day of the week specified in the **Week start day** field.
Storage intervals

⚠️ CAUTION:
Do not open another Storage Intervals window and attempt to change other settings while modifying these settings. Doing so can result in the loss of database tables.

Steps
To modify the CMS date and time settings for data summarizing:

1. From the Controller window, select Tools > System Setup....
   Supervisor displays the CMS System Setup window.

   ![CMS System Setup Window]

2. In the Operations: list, highlight Storage Intervals.

3. In the ACD: field, select the ACD which will have its data summarizing settings changed.
4. Select **OK**.

   *Supervisor* displays the **Storage Intervals** window.

5. In the **Data summarizing time**: field, enter the time when **CMS** should summarize data for the previous day, week, and month. The time must be entered in one of the following formats:

   - **HH:MM PM** - For example, **12:35 AM**
   - **24-hour format** - For example, **00:35**

   If you do not wish to change this field, skip this step and proceed to the next.

   The time entered in this field must be equal to or greater to intrahour interval in order to allow **CMS** to finish archiving data. The default time for this field is **12:35 AM**.

   Weekly summaries are started on the day following the day specified in the **Week stop day** field. Monthly summaries are started on the first day of the next month. For example, the monthly summary for January is done on the first day of February.

   To run data summarizing on the day for which data was collected, the **Data summarizing time**: field must be set for 15 minutes after the **Daily stop time** and prior to midnight. For example, the **Data summarizing time**: field can be set to **11:59 PM** or **23:59**. This would require that the **Daily stop time**: field be set to **11:44 PM** or **23:44**.

6. In the **Week start day (Select one)**: group, select the day that represents the start of the work week for the contact center.

   If you do not wish to change this field, skip this step and proceed to the next.

   The default value for this field is **Sunday**.
7. In the **Week stop day (Select one)**: group, select the day that represents the end of the work week for the contact center.

If you do not wish to change this field, skip this step and proceed to the next.

The default value for this field is **Saturday**. Data through the end of the stop day is collected and included in the weekly summary.

When the start or stop day is changed for the week, the data from the old start day through the new stop day for the week is archived.

If possible, make any changes to the **Week start day** and **Week stop day** after **CMS** performs the weekly archive. This change is not possible for a seven-day week. When the start and stop day for the week are changed, the current week will contain the data item, **INCOMPLETE**, to indicate that the data for this week is peculiar since the definition of that week was changed.

If the **Week start day** and **Week stop day** are identical, data for only one day will be collected for that week.

8. In the **Daily start time**: field, enter the time at which data collection should start. Enter the time in one of the following formats:

   - HH:MM PM - For example, 12:00 AM
   - 24-hour format - For example, 00:00

If you do not wish to change this field, skip this step and proceed to the next.

The default value for this field is **12:00 AM** (midnight).

9. In the **Daily stop time**: field, enter the time at which data collection should stop. Enter the time in one of the formats specified in the previous step.

If you do not wish to change this field, skip this step and proceed to the next.

The default value for this field is **11:59 PM**. Data is collected through the end of the minute specified.

Do not enter the same time in this field as in the **Daily start time**: field. Doing so will result in data being collected for only one minute per day.

10. From the menu bar, select **Actions > Modify**.

    **CMS** updates the data summarizing parameters as specified. A **Successful** message appears in the status bar when **CMS** completes the operation.

11. Restart data collection. See **Changing the data collection state** on page 469 for information on this procedure.

12. Return **CMS** to multi-user mode. See **Changing the CMS state** on page 465 for information on this procedure.
Switch setup

Use the Switch Setup window to view the following information:

- Communication Manager setup information - ACD name, release, and activated features, such as Call Vectoring, Call Prompting, and Expert Agent Selection (EAS)
- CMS software information - release, version, and load
- Phantom abandon call timer values

This section contains the following topics:

- **Before you begin** on page 520
- **Permissions** on page 521
- **Viewing switch setup data** on page 521
- **Listing all switch setup data** on page 522

Before you begin

The following items should be read and understood before working with the **Switch Setup** window:

- The **Switch Setup** window can only display real ACDs. Pseudo-ACDs are not supported.
- This window can only be used to view information. No modifications to the ACD can be made through Supervisor.
- The phantom abandon call timer is used to determine which calls to count as abandoned calls rather than ACD call. If the call lasts less than the number of seconds specified, the Communication Manager system considers it an abandoned call. The feature is useful in areas where the central office does not provide disconnect supervision on trunks.
- To display an ACD name in the **Switch Setup** window, it must first have the name assigned in the Dictionary. See **Adding an ACD name** on page 60 for more information on this procedure.
Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view ACDs in the Switch Setup window, the user ID used to log in to this Supervisor session requires read permission for the CMS System Setup feature.

Viewing switch setup data

This section provides the procedure for viewing setup information for an ACD.

Steps

To view the setup settings for an ACD:

1. From the Controller window, select Tools > System Setup.... Supervisor displays the CMS System Setup window.

2. In the Operations: list, highlight Switch Setup.
3. Select OK.

`Supervisor` displays the **Switch Setup** window.

4. In the **ACD**: field, enter the name or number of the ACD to display.

   To have all ACDs returned from the query so that you can cycle through them in this dialog, leave this field blank and proceed to the next step.

5. From the menu bar, select **Actions > Find one**.

   `Supervisor` displays the setup information for the specified ACD. If more than one match was found, use the **Next** and **Previous** items under **Actions** menu to cycle through them.

---

**Listing all switch setup data**

This section provides the procedure for viewing setup information for all ACDs.
Steps

To view the setup settings for all ACDs:

1. From the Controller window, select Tools > System Setup....
   
   Supervisor displays the CMS System Setup window.

2. In the Operations: list, highlight Switch Setup.

3. Select OK.
   
   Supervisor displays the Switch Setup window.
Configuring CMS system settings

4. From the menu bar, select **Actions > List all**.

*Supervisor* displays a secondary window listing all ACDs and their associated settings.
Chapter 11: Maintaining CMS

Maintaining a CMS server consists of routine tasks such as backing up data, checking the status of the CMS connection to the switch, and viewing the maintenance error log.

The Maintenance menu allows you to perform the following tasks:

- Initiate CMS backups and restores
- Assign a name and description to the full path name for a device used for data backups
- Assign printer names and options
- Monitor the data link between the CMS server and the switch
- View the measurement status of a particular ACD
- View the Maintenance Error Log
- View the archiving status

This section contains the following topics:

- Before you begin on page 526
- ACD status on page 526
- Archiving status on page 534
- Backup/restore devices on page 539
- Data Backup on page 548
- Restoring data on page 561
- Recommendation to restart your CMS server on page 567
- Connection status on page 568
- Administering a printer on page 574
- Maintenance Error Log on page 581
- ACD Administration Log on page 608
Before you begin

If an ACD Group is selected as the current ACD in the Maintenance window, only those operations that are valid for the ACD Group will appear in the Operations: list.

ACD status

The ACD Status window displays information about the current selected ACD, including the number of splits or skills, agents logged in, trunk groups, trunks, VDNs, vectors (if your company has purchased Call Vectoring), and measured splits. You can also use the ACD status window to request a complete set of translations from a specific ACD. The ACD status window will look different if your switch has Expert Agent Selection (EAS).

This section contains the following topics:

- Before you begin on page 526
- Permissions on page 527
- Viewing ACD status on page 527
- Listing ACD status on page 530
- Description of the ACD Status window - with EAS on page 531
- Description of the ACD Status window - without EAS on page 532
- Requesting ACD translations on page 533

Before you begin

The following items should be read and understood before viewing the status of an ACD through the Maintenance subsystem:

- The link must be up between the Communication Manager system and the CMS, if you want to view the status or request translations from a specific ACD.
- Data collection must be on for the specific ACD for the translations you request.
- The data will be lost during a translations pump-up. An acknowledgement window will ask if you want to proceed.
Permissions

Depending on the procedure you wish to perform, you will need the following permissions:

- To view the **ACD Status** window, you need to have *read* permission for the **Maintenance** subsystem.
- To request translations, you need to have *write* permission for the **Maintenance** subsystem.

Viewing ACD status

1. From the Controller window, select **Tools > Maintenance**.
   
   *Supervisor* displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Highlight **ACD Status** in the **Operations** list.
4. Select **OK**.

*Supervisor* displays the **ACD Status** window.

If your Communication Manager system does not have EAS, *Supervisor* displays the following window:

![ACD Status window - without EAS](image)

If your Communication Manager has EAS, *Supervisor* displays the following window:

![ACD Status window - with EAS](image)

For additional information on the fields in the **ACD Status** window, see Description of the ACD Status window - with EAS on page 531 and Description of the ACD Status window - without EAS on page 532.

5. Perform one of the following steps to enter information in the **ACD(s):** field:
● Enter the name or number of the ACD directly into the field.
● Use the history list to select an ACD.
● Use the Browse button to select an ACD.

**Note:**
You can also select an ACD Group which will return all the members of that group.

6. From the **Actions** menu, select **Find one**.

**Supervisor** displays the **ACD Status** window for the selected ACD.

If you selected an ACD Group, the first member of the group is displayed. View any other member ACDs by using the **Next** and **Previous** buttons.
Listing ACD status

To list the status of all ACDs:

1. From the Controller window, select **Tools > Maintenance**.
   
   *Supervisor* displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Highlight **ACD Status** in the **Operations**: list.

4. Select **OK**.

   *Supervisor* displays the **ACD Status** window.

5. From the **Edit** menu, select **Clear all**.

6. From the **Actions** menu select **List all**.

   *Supervisor* displays the **ACD Status - List All** window.
Description of the ACD Status window - with EAS

Field descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Skills</td>
<td>The skills measured by CMS.</td>
</tr>
<tr>
<td>Skill members in use</td>
<td>The agent/skill pairs logged in at the time the ACD Status window was opened.</td>
</tr>
<tr>
<td>Trunk groups</td>
<td>The trunk groups measured by CMS.</td>
</tr>
<tr>
<td>Trunks</td>
<td>The trunks measured by CMS. Unmeasured trunks are not included.</td>
</tr>
<tr>
<td>VDNs</td>
<td>The VDNs measured on the selected ACD.</td>
</tr>
<tr>
<td>Vectors</td>
<td>The vectors available for use in the selected ACD.</td>
</tr>
<tr>
<td>Errors</td>
<td>The errors encountered by the ACD.</td>
</tr>
</tbody>
</table>
Maintaining CMS

Description of the ACD Status window - without EAS

Field descriptions

The following table provides the descriptions of the fields on the ACD Status window where Expert Agent Selection (EAS) is not installed:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMS is measuring</td>
<td>The current value of each of the following items.</td>
</tr>
<tr>
<td>Splits</td>
<td>The splits measured by CMS.</td>
</tr>
<tr>
<td>Total split members</td>
<td>The agent/split pairs logged in at the time the ACD Status window was opened.</td>
</tr>
<tr>
<td>Trunk groups</td>
<td>The trunk groups measured by CMS.</td>
</tr>
<tr>
<td>Trunks</td>
<td>The trunks measured by CMS. Unmeasured trunks are not included.</td>
</tr>
<tr>
<td>VDNs</td>
<td>The VDNs measured on the ACD.</td>
</tr>
<tr>
<td>Vectors</td>
<td>The vectors available for use in the selected ACD.</td>
</tr>
<tr>
<td>Measured splits</td>
<td>The number of measured splits in a selected ACD.</td>
</tr>
<tr>
<td>Errors</td>
<td>Errors encountered by the ACD.</td>
</tr>
</tbody>
</table>
Requesting ACD translations

The ACD translation request was used to manually synchronize the measure contact center entities from an ACD to the CMS server.

⚠️ Important:
This functionality was available for Generic 2 and System 85 switches and is no longer needed when your CMS server is connected to a Communication Manager system. ACD translations are downloaded automatically when changes are made to measured contact center entities.

⚠️ Important:
If you request an ACD translation, contact center data is interrupted on the Communication Manager system and can result in inaccurate reports.
Archiving status

Use the Archiving Status window to display the status, date, and time of the last archive for interval, daily, weekly, and monthly data. This information can help you decide when to turn off data collection or change your archiving times to minimize data loss.

This information can help you decide when to turn off data collection or change your archiving times without losing data.

This section contains the following topics:
- **Before you begin** on page 534
- **Permissions** on page 534
- **Viewing the archiving status of a single ACD** on page 535
- **Viewing the archiving status of all ACDs** on page 536
- **Description of the Archiving Status - List All window** on page 538

---

**Before you begin**

The following items should be read and understood before working with the Archiving Status window:

- Archive indicates that CMS is storing interval, daily, weekly, and monthly data in the appropriate database tables.

- The three archive status indications are:
  - Finished - The last archive has been completed
  - Running - The archive is currently running
  - Not run - The archive has never run

---

**Permissions**

You need read permission for the Maintenance subsystem to view the Archiving Status window.
Viewing the archiving status of a single ACD

Steps
To view the archiving status of a single ACD:

1. From the Controller window, select **Tools > Maintenance**.
   
   *Supervisor* displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Select **Archiving Status** in the **Operations**: list.

4. Select **OK**.
   
   *Supervisor* displays the **Archiving Status** window.

5. Perform one of the following steps to enter information in the **ACD(s)**: field:
   
   - Enter the name or number of the ACD directly into the field.
   - Use the history list to select an ACD.
   - Use the Browse button to select an ACD.
6. In the Archiving type (Select any you wish): check boxes, deselect the archives you do not want to view. If you want to view all archive types, leave the check boxes as check marked and proceed to the next step.

7. From the Actions menu, select List all.

Supervisor displays the Archiving Status - List All window.

For more detailed information about the Archiving Status - List All window, see Description of the Archiving Status - List All window on page 538.

Note:
It is also possible to view the archiving status of all members of a single ACD Group using this procedure. Instead of the name or number of a single ACD, enter the name or number of the ACD Group in the ACD: field.

### Viewing the archiving status of all ACDs

#### Steps
To view the archiving status of all ACDs:

1. From the Controller window, select Tools > Maintenance.

Supervisor displays the Maintenance window.
2. Select the **Operations** tab.

3. Select **Archiving Status** in the **Operations**: list.

4. Select **OK**.

   *Supervisor* displays the **Archiving Status** window.

5. If the **ACD(s)**: field is not clear; go to the **Edit** menu, and select **Clear all**.

6. Select the type of archives you want to view in the **Archiving type**: check boxes.

7. From the **Actions** menu, select **List all**.

   *Supervisor* displays the **Archiving Status - List All** window.

For more detailed information about the **Archiving Status** - List All window, see [Description of the Archiving Status - List All window](page) on page 538.
### Description of the Archiving Status - List All window

The following table lists the fields and the associated descriptions for the **Archiving Status - List All** window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Status</td>
<td>The archiving status of the ACD.</td>
</tr>
<tr>
<td>Date</td>
<td>The date the last archive completed for the ACD.</td>
</tr>
<tr>
<td>Time</td>
<td>The time the last archive completed for the ACD.</td>
</tr>
<tr>
<td>Next scheduled</td>
<td>The date and time of the next-scheduled archive. Dates and times will not appear for the <strong>Interval</strong> archiving. <strong>Interval</strong> archives occur at the end of each interval: 15, 30, or 60 minutes.</td>
</tr>
</tbody>
</table>
Backup/restore devices

Use the **Backup/Restore Devices** window to assign a name and description to a full path name for a device. The device name is used for data backup, data migration, data restore, and for loading a pseudo-ACD.

The *LAN Backup* feature of CMS is not available through the *Supervisor* interface. For more information regarding this feature, see the *Avaya Call Management System LAN Backup User Guide*.

This section contains the following topics:

- [Permissions](#) on page 539
- [Viewing a backup/restore device](#) on page 540
- [Listing all backup/restore devices](#) on page 541
- [Adding a backup/restore device](#) on page 543
- [Modifying a backup/restore device](#) on page 544
- [Deleting a backup/restore device](#) on page 546

---

Permissions

Depending on the procedure you wish to perform, you need the following permissions:

- You need *read* permission for the **Maintenance** subsystem to view the **Backup/Restore Devices** window.

- You need *write* permission for the **Maintenance** subsystem to add, delete or modify any backup/restore devices.
To view a backup/restore device:

1. From the Controller window, select **Tools > Maintenance**.
   
   *Supervisor* displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Select **Backup/Restore Devices** in the **Operations** list.

4. Select **OK**.
   
   *Supervisor* displays the **Backup/Restore Devices** window.
5. From the **Actions** menu, select **Find one**.  
   *Supervisor* displays the information for the first device.

   ![Backup/Restore Devices](image)

6. If more than one match is found, go to the **Actions** menu, and select **Next**. Repeat this step until all devices have been displayed.

---

**Listing all backup/restore devices**

To list all backup/restore devices defined on the CMS server:

1. From the Controller window, select **Tools > Maintenance**.  
   *Supervisor* displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Select **Backup/Restore Devices** in the **Operations** list.
4. Select **OK**.

*Supervisor* displays the **Backup/Restore Devices** window.

![Backup/Restore Devices window](image)

5. From the **Actions** menu, select **List all**.

*Supervisor* displays a list of all devices.

![Backup/Restore Devices - List All](image)
Adding a backup/restore device

To add a backup/restore device to the CMS server:

1. From the Controller window, select Tools > Maintenance. Supervisor displays the Maintenance window.

2. Select the Operations tab.


4. Select OK. Supervisor displays the Backup/Restore Devices window.

5. In the Device name: field, enter the name of the backup/restore device.

   If you want to refer to your backup/restore device as ddrive1, enter ddrive1 in the Device name: field.
6. In the **Path**: field, enter the full Solaris system path to access the device.  
   See the *Accessing devices* section in your *Solaris System Administrator's Guide* for more information about devices and paths.

7. In the **Description**: field, enter any additional information to help identify the device.

8. In the **Device type**: option list, select the correct tape capacity for your backup/restore device.  
   Selecting the correct capacity tape allows the system to estimate the number of tapes that will be needed to perform a full backup to the device.

9. From the **Actions** menu, select **Add**.  
   The device is defined through CMS and can be used for backup and restore operations.

---

**Modifying a backup/restore device**

To modify the definition of a backup/restore device on the CMS server:

1. From the Controller window, select **Tools > Maintenance**.  
   *Supervisor* displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Select **Backup/Restore Devices** in the **Operations**: list.
4. Select **OK**.

*Supervisor* displays the **Backup/Restore Devices** window.

5. Perform one of the following procedures to select the correct backup/restore device:

- If you know the name of the device, enter the name of the device in the **Device name** field and then press the **Enter** key.

- If you do not know the name of the device, perform the following steps:
  
  i. From the **Actions** menu, select **Find one**.
  
  ii. If more than one match is found, select **Actions > Next**. Repeat this step until the device you want to modify is displayed in the dialog box.

6. Enter the new information in the fields that require modification.

7. From the **Actions** menu, select **Modify**.

   The changes made to the device definition are saved.
Deleting a backup/restore device

To delete the definition for a backup/restore device on the CMS server:

1. From the Controller window, select **Tools > Maintenance**.

   Supervisor displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Select **Backup/Restore Devices** in the **Operations** list.

4. Select **OK**.

   Supervisor displays the **Backup/Restore Devices** window.

5. Perform one of the following procedures to select the correct backup/restore device:

   - If you know the name of the device, enter the name of the device in the **Device name** field and then press the **Enter** key.
   - If you do not know the name of the device, perform the following steps:
i. From the **Actions** menu, select **Find one**.

   ii. If more than one match is found, go to the **Actions** menu, and select **Next**. Repeat this step until the device you want to delete is displayed in the dialog box.

6. From the **Actions** menu, select **Delete**.

   The specified backup/restore device definition is deleted from the **CMS** server.
Data Backup

There are two types of data backup available through CMS, CMSADM and Maintenance. Avaya CMS can backup and restore while the data collection remains on. This ability helps minimize data loss. However, once a CMSADM backup is started, new logins through the ASCII interface, through Avaya CMS Supervisor, and through Avaya Visual Vectors are blocked. A maintenance restore of CMS System Administration data or ACD Administration data requires Avaya CMS to be in single-user mode.

The LAN Backup feature of CMS is not available through the Supervisor interface. For more information regarding this feature, see the Avaya Call Management System LAN Backup User Guide.

This section contains the following topics:

- CMSADM backup on page 548
- Maintenance backup on page 549
- Tape drives and cartridges on page 549
- Things to consider when backing up or restoring data on page 549
- Performing a CMSADM backup on page 551
- Performing a maintenance backup on page 553
- Description of the Backup Data window on page 556
- Common backup error messages on page 558
- Labeling the backup volume on page 559
- Recovery kit on page 560

CMSADM backup

The CMSADM backup saves all of the system data on the computer onto a tape.

The CMSADM backup includes the following data:

- Solaris system files and programs
- CMS programs
- Non-CMS customer data placed on the computer

The CMSADM backup will not save CMS database tables. For complete data recovery, both CMSADM and maintenance backups are required.

This type of backup is only performed through the CMS ASCII interface. A Supervisor interface for this type of backup is not available.
Maintenance backup

Maintenance backups are used to archive and restore CMS data. If you do not have a backup, data is lost and cannot be recovered in the event of system or disk failure. The frequency of your backups is determined by how much data your contact center is willing to lose.

Through Supervisor, you can use the Backup Data operation on the Maintenance window to perform full and incremental backups of CMS historical and administration data.

Tape drives and cartridges

The following table lists the models of tape drives that are supported:

<table>
<thead>
<tr>
<th>Tape drive</th>
<th>Tape description</th>
<th>Generic name</th>
</tr>
</thead>
<tbody>
<tr>
<td>DAT 72</td>
<td>DDS compliant 170 meter 36/72-GB DAT cartridge 4 mm</td>
<td>Sun Blade 150, Sun Fire V880 or V890</td>
</tr>
<tr>
<td>DDS-4</td>
<td>DDS compliant 150 meter 20/40-GB DAT cartridge 4mm</td>
<td>Sun Blade 100 or 150, Sun Fire V880</td>
</tr>
</tbody>
</table>

Things to consider when backing up or restoring data

Avaya recommends that you back up your CMS system data on a monthly basis and you back up your CMS ACD data on a daily basis. The backup tapes should be stored in a safe location, easily retrievable, correctly labeled, and replaced when worn out. Running system backups is no longer service affecting, but the backups will impact the performance of the CMS system. It is recommended that backups be run when CMS system activity is low.

This section presents several factors that will impact the amount of time it takes to backup or restore your data and presents options to reduce backup and restore times.

This section includes the following topics:
- Factors that impact backup and restore times on page 550
- Reducing tape backup and restore times on page 550
- Alternate methods for backing up and restoring data on page 551
Factors that impact backup and restore times

The amount of time it takes to back up or restore data depends on the:

- **Amount of data** - An increase in the amount of data will cause an increase in the amount of time it takes to back up or restore the data. Some factors that will increase the amount of data being stored are:
  - Number of items being measured - CMS R3V9 and later have increased capacities. More data is generated if you measure 100,000 agent skill pairs instead of 10,000.
  - Number of days information is stored - The greater the data storage time, the greater the amount of data that will have to be backed up or restored. When the CMS system reaches a predetermined threshold for data storage, the oldest record is deleted so that the newest record can be stored. Twice the amount of data is stored if you set your data storage for 62 days instead of 31 days.
  - Interval size - Shorter intervals generate more data. A 15 minute interval will generate significantly more data than a 60 minute interval.

- **System load** - Processes that require a large amount of system resources will slow down the CMS system. Backing up data requires a large amount of system resources. Additional processes that require a large amount of system resources are:
  - Running reports - Running a single large report or multiple smaller reports will use a large amount of system resources.
  - Archiving data - Archiving a large amount of data will use a large amount of system resources.

- **Necessity for manually changing backup tapes** - If the amount of data exceeds the capacity of a single backup tape, someone must monitor the system and manually load additional tapes. A data backup or restore will not finish unless someone is able to load tapes into the tape device as needed.

Reducing tape backup and restore times

If you do not take steps to optimize your CMS backup and restore times, you will begin to experience performance issues. Your CMS system performance will drop if the backup continues to run when contact center activity increases. With the increased CMS capacities that are now available, CMS backups and restores could take much longer to complete than they have in the past. To reduce the amount of time it takes to backup or restore data, you can:

- Select the maximum interval time that will meet your data collection needs.
- Select the minimum data storage times that will meet your data collection needs for all the historical database tables.
- Run reports when the CMS system is not actively backing up or restoring data.
- Schedule routine backups to occur at a time that is different from data archiving.
Data Backup

- Schedule routine backups to occur when CMS system activity is low.
- Reduce the amount of data being stored so only one backup tape is needed to store the data.
- Upgrade your CMS system to a more powerful hardware platform or add additional memory and CPUs.

Alternate methods for backing up and restoring data

If you need a higher capacity process for backing up and restoring your data, you may want to use the Avaya CMS LAN Backup feature. The Avaya CMS LAN Backup feature provides an alternative to the traditional method of backing up and restoring data with a tape device. LAN Backup allows you to back up CMS data and system information over a local area network (LAN) to a storage manager.

*Avaya Call Management System LAN Backup User Guide* provides information about using the CMS LAN backup feature, hardware requirements, software requirements, and support guidelines.

Performing a CMSADM backup

The CMSADM backup should be done at the following times:

- Once a month (This is always the customer's responsibility.)
- After the CMS is provisioned (Never use the original tapes made during provisioning.)
- Before and after the CMS software is upgraded
- After the system has been set up in the factory (performed by factory personnel).

This backup contains the default factory configuration. These tapes should be saved if the system must be reinstalled in the field.

⚠️ Important:

Use a new set of backup tapes for the monthly CMSADM backup. Do NOT use the original sets of factory backup tapes or provisioning backup tapes. Make sure that there are enough tapes for the new backup.

Before you begin

The following items should be read and understood before beginning to work with tape drives and cartridges on your Sun Microsystems, Inc. *Solaris* system.

- Prior to running a cmsadm backup, it is recommended that you restart the CMS server.
- Verify that you are using the correct tape for the tape drive on your system.
● Backup tapes can wear out. Be sure to refresh your supply of backup tapes at appropriate intervals.

Permissions
In order to perform a CMSADM backup you need write permission for the Unix (r) subsystem. Only employees with administrative responsibilities should be given the permissions and passwords.

Steps
1. Log into the Solaris system as root and open a terminal window.
   See Logging in to CMS from the server console on page 614 for additional information.
2. Verify that the computer is in a Solaris multi-user state (2 or 3). To check if you are in the multi-user state, enter:
   ```
   who -r
   ```
3. Enter the following command and press the Enter key:
   ```
   cmsadm
   ```
   The Avaya Call Management System Administration Menu is displayed:
4. Enter the number associated with the backup option.
   Depending on the configuration of your system, one of the following outputs occurs.
   a. If only one tape drive is available on the system, proceed to step 5.
   b. If more than one tape drive is available for use by the system, the system displays a list of tape devices. Enter a tape drive selection from the displayed list.
   The system displays the following message:
   ```
   Please insert the first cartridge tape into <device name>
   Press ENTER when ready or Del to quit:^?
   ```
5. Press the Enter key.
   The backup process begins.
   If more than one tape is required, the program displays the following message:
   ```
   End of medium on "output".
   Please remove the current tape, number it,
   insert tape number x, and press Enter
   ```
   If you receive the message displayed above, insert the next tape and allow it to rewind. When it is properly positioned, press the Enter key.
6. When the backup is completed, the system displays information according to the number of tapes that are required for the backup:
   ● If the number of tapes required is one, the system displays the following message:
   ```
   xxxxxxxxx blocks
   ```
Data Backup

Tape Verification
xxxxxx blocks
WARNING: A CMS Full Maintenance Backup in addition to this cmsadm backup must be done to have a complete backup of the system.

Please label the backup tape(s) with the date and the current CMS version (Rxxxxx.x)

- If the number of tapes required is more than one, the system displays the following message:

xxxxxx blocks
Tape Verification
Insert the first tape
Press Return to proceed:

If you receive the message displayed above, insert the first tape used in the backup and press the Enter key. Wait for the tape drive light-emitting diode (LED) to stop blinking before you remove the tape. When prompted, repeat this process for any additional tapes generated by the backup process.

When the final tape is verified, CMS displays the following message:

xxxxxx blocks
Tape Verification
xxxxxx blocks
WARNING: A CMS Full Maintenance Backup in addition to this cmsadm backup must be done to have a complete backup of the system.

Please label the backup tape(s) with the date and the current CMS version (Rxxxxx.x)

7. Label all tapes with the following information:

- Tape number
- Date of backup
- Current version of Avaya CMS

8. Set the tape write-protect switch to read-only and put the tapes in a safe location.

If you have problems performing a CMSADM backup, see the document, Software Installation, Maintenance, and Troubleshooting.

Performing a maintenance backup

Since new data is written each day, you should frequently back up this data. Both the full and incremental backups can be scheduled to run automatically on a timetable.
Before you begin
The following items should be read and understood before performing a Maintenance backup:

- A sufficient supply of tapes should be available so that tapes can be rotated. One common plan is to keep seven tapes in stock and recycle them daily. A new tape is used each day of the week, and each week the sequence is repeated.
- Backups run in the background. You can exit the Backup Data window without affecting the backup.
- Running backups during archiving may cause performance problems. For best performance, run backups either before or after the archiving process.
- Most systems come equipped with tape drives that can accommodate a full backup on one tape. Incremental backups may not need to be done. Full backups can be scheduled to run every day.

⚠️ Important:
The maintenance backup does *not* back up the CMS software, Solaris system files or non-CMS customer data on the system. For complete data recovery, both CMSADM and maintenance backups are required. See Performing a CMSADM backup on page 551 for instructions on how to run a CMSADM backup.

Permissions
To run a Maintenance backup you need *write* permission to the Maintenance subsystem.

Steps
1. From the Controller window, select Tools > Maintenance.

   Supervisor displays the Maintenance window.
2. Select the **Operations** tab.

3. Depending on if you want to back up a single ACD or all ACDs, choose one of the following steps:
   - To back up a single ACD, enter the ACD identification in the **ACD:** field.
   - To back up all ACDs, make sure no ACDs are selected in the **ACD:** field.

4. Select **Backup data** in the **Operations:** list.

5. Select **OK**.
   
   *Supervisor* displays the **Backup Data** window.

6. In the **Device name:** field, verify that the correct backup device is displayed. If you need to select another device, select **List devices** from the **Actions** menu.

7. Ensure that the **Verify tape can be read after backup?:** check box is selected.
   
   It is recommended that the tape backup be checked for readability. When the tape is being verified, a message displays in the **Status:** field. If the tape cannot be read a message displays in the **Errors:** field. See [Common backup error messages](#) on page 558 for information on additional error messages you may receive.

8. In the **ACD(s) to back up:** field, select one of the following options:
   - The **All ACD(s)** option will back up data from all real ACDs (not pseudo-ACDs).
   - The **Current ACD** option will back up data from the ACD that is displayed in the bottom right corner of the **Backup Data** window.
9. The **Data to back up**: check boxes, by default, are all selected. If you do not want to back up the maximum amount of data, deselect the types of data you do not want backed up.

For an explanation of the **Data to back up**: check box options, see **Description of the Backup Data window** on page 556.

10. From the **Actions** menu, select **Run**.

The backup process begins. When the backup process is complete, **Supervisor** displays an acknowledgement window.

If your backup requires more than one tape, you will receive a message telling you to mount another volume to complete the backup.

11. When the backup completes, remove and label the tape(s).

---

**Description of the Backup Data window**

This section includes the following topics:

- **The Backup Data window** on page 556
- **Field descriptions** on page 557
- **Data to back up descriptions** on page 557

**The Backup Data window**

![Backup Data window](image)
Field descriptions

Fields in the **Backup Data** window are described as follows:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Backups completed today</td>
<td>Shows the number of backups completed for the current day.</td>
</tr>
<tr>
<td>Status</td>
<td>Shows the status of the current or most recent backup and what is currently being backed up.</td>
</tr>
<tr>
<td>Errors</td>
<td>Shows any errors found in the backup.</td>
</tr>
<tr>
<td>Device name</td>
<td>Displays the name of the backup device.</td>
</tr>
<tr>
<td>Verify tape can be read after backup?</td>
<td>Check box to request that the data be reread to ensure that the data has been backed up properly.</td>
</tr>
<tr>
<td>ACD(s) to back up.</td>
<td>Options to perform a backup of all ACDs or a single ACD.</td>
</tr>
<tr>
<td>Data to back up.</td>
<td>Series of check boxes where you can select the types of data you want to back up. See <a href="#">Data to back up descriptions</a> on page 557 for additional information.</td>
</tr>
</tbody>
</table>

Data to back up descriptions

Descriptions of the types of data that may be backed up are described as follows:

<table>
<thead>
<tr>
<th>Check Box</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Local System administration data</td>
<td>Includes IP addresses, port numbers, and other data configured at installation.</td>
</tr>
<tr>
<td>CMS System administration data</td>
<td>Includes user permissions, feature access permissions, <a href="#">Main Menu</a> additional data, timetable, printer administration, default values, color choices, and custom report definitions (not the data associated with custom reports).</td>
</tr>
<tr>
<td>ACD-specific administration data</td>
<td>Includes Forecast data (if the feature is active), call work code administration data, VDN administration data, data storage allocation data, exception administration data, agent trace data (historical list of agents traced), and ACD-specific Dictionary names.</td>
</tr>
</tbody>
</table>
Maintaining CMS

Common backup error messages

Common error messages and their solutions are described as follows:

<table>
<thead>
<tr>
<th>Error</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMS cannot access the specified device.</td>
<td>Enter a new device name.</td>
</tr>
<tr>
<td>The volume mounted is bad (corrupt).</td>
<td>Mount a new volume.</td>
</tr>
<tr>
<td>A volume tape is not mounted in the drive.</td>
<td>Mount a volume.</td>
</tr>
<tr>
<td>The volume mounted contains CMS data that you might not want to overwrite.</td>
<td>Mount a different volume if you do not want to overwrite the data on the volume in the drive.</td>
</tr>
<tr>
<td>The volume mounted is the last backup volume.</td>
<td>You have to mount a different volume. Unless you direct CMS to do so, it does not let you overwrite your last backup.</td>
</tr>
</tbody>
</table>
Labeling the backup volume

After a successful backup, CMS automatically generates a label for the backup volumes. Depending on the circumstances, CMS provides the following information:

- An acknowledgement window displays the final backup information. If the backup was scheduled on a timetable, the information is recorded in the Maintenance Error Log.
- An acknowledgement window displays a message indicating when a backup can write to a previously used tape.

**Example backup information format and interpretation**

```
0001  CMS-NNNNNNN-NN-LLLL-NN-L-NN
0002  | |    |  |   | | |
0003  1 2    3  4   5 6 7
```

The following table provides information on the labels of backup tapes:

<table>
<thead>
<tr>
<th>Part #</th>
<th>Code</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>CMS</td>
<td>System name</td>
</tr>
<tr>
<td>2</td>
<td>NNNNNN</td>
<td>Year, month and day of the backup (yymmdd)</td>
</tr>
<tr>
<td>3</td>
<td>NN</td>
<td>Number of backups for this day</td>
</tr>
</tbody>
</table>
| 4      | LLLL  | Type of data backed up:  
               A - ACD-specific administration data and historical data  
               C - custom data  
               H - historical data  
               L - local system administration data  
               M - ACD-specific administration data  
               S - CMS system data  
               X - no backup |
| 5      | NN    | Number of the ACD (00 means All ACDs were selected on the Back Up window) |
Recovery kit

The recovery kit is composed of the backup media that the Avaya Technical Services Organization will need to restore service to your system if major problems occur. This kit should be stored in a secure location in order to minimize the time your system is out of service.

Recovery kit contents

The Recovery Kit contains the most recent:

- CMSADM backup tape
- Full Maintenance backup tape and any Incremental backup tapes since the latest full backup
- CMS Load tape
- Patching CDs and tapes
- All the software packages that were shipped with the CMS system.

<table>
<thead>
<tr>
<th>Part #</th>
<th>Code</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>L</td>
<td>Backup mode (F for Full, I for Incremental)</td>
</tr>
<tr>
<td>7</td>
<td>NN</td>
<td>The tape number if this tape was part of a multi-tape backup.</td>
</tr>
</tbody>
</table>
Restoring data

Use the Restore Data window to restore CMS data that has been lost due to system failure, disk crashes, or power outages. You can restore all CMS data files that you have previously backed up. You can also select which ACDs and CMS data to restore.

The automatic restore will restore all CMS data files from your last backup. Most data is restored by the automatic restore procedure.

The manual restore will restore specific CMS data files. The manual restore is used only when a select number of database tables need to be restored. A manual restore gives you control over which data is restored.

This section contains the following topics:

- Before you begin on page 561
- Permissions on page 562
- Automatic restore on page 562
- Manual restore on page 564

Before you begin

The following items should be read and understood before attempting to restore data:

- The Data Collection and CMS states must be set as noted for the following backups:
  - Local system administration data - Data Collection off; CMS Single-user mode
  - CMS system administration data - Data Collection on or off; CMS Single-user mode
  - ACD system administration data - Data Collection on or off; CMS Single-user mode
  - Historical data, Non-CMS data, or specific tables - Data Collection on or off; CMS Single- or Multi-user mode.

- Data must be backed up before it can be restored. To ensure the safety of your data, you should frequently back up your system.

- The restore procedure is run in the background. The Status field on the Restore Data window allows you to monitor the status of the restore process as it is performed.

- You can turn CMS back to multi-user mode when the Status field displays Restore is complete.
Maintaining CMS

Permissions

To restore data you need write permission for the Maintenance subsystem.

Automatic restore

To have CMS automatically restore data from a backup:

1. From the Controller window, select Tools > Maintenance. Supervisor displays the Maintenance window.

2. Select the Operations tab.

4. Select **OK**.

_Supervisor_ displays the **Restore Data** window.

![Restore Data Window](image)

The **Status:** field shows the status of the current restore or a previous restore if one has taken place.

The **Errors:** field will show any errors found during the restore.

5. Check the **Device name:** field to make sure the correct backup/restore device is selected.

   If you want to use another backup/restore device, select **Actions > List devices.**

   Enter the correct backup/restore device name in the **Device name:** field.

   This field defaults to the device named during installation.

6. Select the **Restore from last backup:** check box.

7. From the **Actions** menu, select **Run.**

   The system notifies you which volumes to mount to restore the data. At the end of every restored volume, the tables that have been fully or partially restored will be displayed.

   If the system asks for a tape that you cannot provide, you must cancel the restore process. The restore can be rerun if the tape is found.
## Manual restore

⚠ **Important:**
The manual restore stops when severe errors occur or when you tell it there are no more volumes to restore. Select **Stop** to tell the restore process that you are finished. Do not select **Cancel** since it implies an abnormal termination. Cancelling a restore leaves the data that has already been restored in the tables, which may result in the database being in an abnormal state. You will receive an acknowledgment window asking if you are sure you want to cancel the restore.

To manually restore data:

1. From the Controller window, select **Tools > Maintenance**.
   
   *Supervisor* displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Select **Restore Data** in the **Operations** list.
4. Select **OK**.

    *Supervisor* displays the **Restore Data** window.

![Restore Data Window](image)

The **Status** field shows the status of the current restore or a previous restore if one has taken place.

The **Errors** field will show any errors found during the restore.

5. Check the **Device name** field to ensure that the correct backup/restore device is selected.

   If you want to use another backup/restore device, select **Actions > List devices**.

   Enter the correct backup/restore device name in the **Device name** field.

   This field defaults to the device named during installation.

   **Important:**

   Do not select the **Restore from last backup** check box. A manual restore will accept any tape you mount as long as the data on the tape corresponds with the requested data.

6. In the **Start date** field, enter the oldest date to be included in the restore by using one of the following methods:

   - Enter the date in the mm/dd/yy format.
   - Use the drop down calendar to select a date.
   - Enter the date in relative format; for example, 0 for today and -1 for yesterday.
7. In the **Start time:** field, enter the time you want to start restoring data. Use the format of \texttt{hh:mm XM} when entering the time where \texttt{hh} is hours, \texttt{mm} is minutes, and \texttt{XM} is AM or PM.

   If you wanted to restore data starting at 1:15 AM, you would enter \texttt{01:15 AM}

   If AM or PM is not specified, a 24 hour clock is assumed.

8. In the **Stop date:** field, enter the most recent date to be included in the restore.

9. In the **Stop time:** field, enter the time you want to stop restoring data. Use the format of \texttt{hh:mm XM} when entering the time.

10. In the **ACD(s) to restore** options, select either **All ACDs** or **Current ACD**.

11. In the **Data to restore:** group, select the types of data you want to restore.

12. If you do not select **Specific tables**, go to Step 16. Otherwise, select **Actions > Select tables**.

   *Supervisor* displays the **Restore Data - Select tables** window.

   If you are performing the **Specific tables** restore, you cannot restore any other information at the same time. This includes:

   - Local system administration data - This data can only be restored once. A second attempt will corrupt data.
   - CMS system administration data
   - ACD system administration data
   - Historical data

13. Select the tables you want to restore.

14. From the **Actions** menu, select **Modify**.

15. Close the **Restore Data - Select tables** window to return to the **Restore Data** window.

16. From the **Actions** menu, select **Run**.
Recommendation to restart your CMS server

Avaya recommends that you restart your CMS server once every three months for preventative maintenance reasons. Rebooting your CMS server should not take longer than 10 minutes and should be performed when the CMS server load is low.

Although rebooting your CMS server is not a requirement, periodically rebooting your CMS server is a recommended procedure targeted at minimizing the risk of a system failure. Restarting your CMS server lessens the possibility of your system being adversely impacted by anomalies such as memory leaks, packet loss, un-released file locks, data inconsistency, data corruption, and storage space fragmentation. These types of problems are known to occur on any computer system.

Avaya offers a High Availability solution if data loss from a server restart is a concern. The Avaya CMS High Availability (HA) solution provides an uninterrupted data stream between the communication server and two HA CMS servers. If you use the HA solution, restart each CMS server at a different time to prevent data loss.

Avaya support personnel who are performing system maintenance work may require you to restart your CMS system. If Avaya support personnel require that you to restart your CMS system, they will work with you to determine the best time to perform the restart. Avaya support personnel will make every attempt to determine the root cause of any problem that might require a restart.
Connection status

You can use the Connection Status window to monitor the data link between the CMS processor and the Communication Manager system. You can also view the current status of the application, session, and connection layers of the link between the Communication Manager system and CMS.

This section contains the following topics:

- Permissions on page 568
- Viewing the connection status of an ACD on page 568
- Listing the connection status of all ACDs on page 570
- Description of the Connection Status window on page 571

Permissions

You need read permission for the Maintenance subsystem to view the Connection Status window.

Viewing the connection status of an ACD

To view the connection status of a single ACD:

1. From the Controller window, select Tools > Maintenance. Supervisor displays the Maintenance window.
2. Select the **Operations** tab.

3. Select **Connection Status** in the **Operations** list.

4. Select **OK**.

   *Supervisor* displays the **Connection Status** window.

   ![Connection Status Window]

5. In the **ACD(s):** field, enter the name or number of the ACD or ACD Group.

   See [Description of the ACD Status window - with EAS](#) on page 531 or [Description of the ACD Status window - without EAS](#) on page 532 for additional information about the fields present on the **Connection Status** window.

6. From the **Actions** menu, select **Find one**.

   *Supervisor* displays the **Connection Status** window for the selected ACD.
Listing the connection status of all ACDs

To list the connection status of all ACDs:

1. From the Controller window, select Tools > Maintenance. 
   
   Supervisor displays the Maintenance window.

2. Select the Operations tab.


4. Select OK.
   
   Supervisor displays the Connection Status window.

5. If the ACD(s): field is not clear, select Edit > Clear all.
6. From the **Actions** menu select **List all**.

**Supervisor** displays the **Connection Status - List All** window.

---

**Description of the Connection Status window**

---
# Field descriptions

The **Connection Status Window** contains the following fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Status Messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACD(s)</td>
<td>Enter the number or name of the ACD(s) for which you would like to check the connection status.</td>
<td>-</td>
</tr>
</tbody>
</table>
| Application | Displays status for the application layer of the link between the Communication Manager system and CMS. | **waiting session** - The application layer is inactive. This is the state of the application layer when the system is first powered on.  
**translation pumpup** - CMS is receiving translations from the Communication Manager system. Translations are needed for CMS to correctly track the ACD calls coming from the switch.  
**data transfer** - The application layer can receive and transmit data successfully.  
**not collecting data** - Data collection has been turned off.  
**CMS System Setup** - The link has gone down. To resume data collection, use the **Data Collection** window  
**busied out (switch)** - The link between CMS and the Communication Manager system has been busied out from the switch side, usually to change switch translations. |
| Session   | Displays status for the session layer of the link between the Communication Manager system and CMS. | **quiescent** - The session layer is inactive. This is the state of the session layer when the system is first powered on.  
**waiting acceptance** - The session layer is waiting for the connection layer to become operational and for the remote session layer to accept the session.  
**data transfer** - The session layer can now transmit and receive data from the Communication Manager system. |
### Connection status

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
<th>Status Messages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connection</td>
<td>Displays status for the connection layer of the link between the Communication Manager system and CMS.</td>
<td><strong>quiescent</strong> - Indicates that the connection is inactive. This is the state of the connection when the system is first powered on. <strong>out of order</strong> - Something is wrong with the connection to the Communication Manager system. For example, the network connection between the Communication Manager system and CMS is currently unavailable. <strong>operational</strong> - The connection can transmit information physically between the Communication Manager system and CMS. <strong>waiting session accept</strong> - The link is down.</td>
</tr>
<tr>
<td>Date/Time</td>
<td>Displays the date/time for the ACD, unless the link to the ACD is down when CMS is brought up. If this happens, CMS uses the Solaris system time until the link is reestablished.</td>
<td></td>
</tr>
<tr>
<td>Errors</td>
<td>Displays any errors found.</td>
<td></td>
</tr>
</tbody>
</table>
Maintaining CMS

Administering a printer

Use the **Printer Administration** window to assign a name, description, and options to a printer that can be used by terminals connected to **CMS**. Users of **Supervisor** do not have access to printers assigned through this window but can use printers that are normally used through their Windows-based PC.

This section contains the following topics:

- Before you begin on page 574
- Permissions on page 574
- Adding a new printer on page 575
- Listing all printers on page 576
- Modifying printer options on page 578
- Deleting a printer on page 579

Before you begin

- Before you can assign a printer in the **Printer Administration** window, the printer must already be administered in the **Solaris** system. See the **Avaya CMS Terminals, Printers, and Modems** document for additional information about the **Port Administration Tool**.

- The printer set up as the default printer will receive all terminal requested print jobs, unless otherwise specified by the user.

- If jobs are sent to a printer that is no longer administered, the print job will be sent to the default printer and an error will be logged in the Maintenance Error Log.

- The name of a printer administered in the Printer Administration window can be used by terminal users as the default destination when printing historical reports.

Permissions

Depending on the procedure you want to perform, you will need the following permissions:

- To view the **Printer Administration** window, you will need *read* permission for the **Maintenance** subsystem.

- To add, delete, or modify the **Printer Administration** window, you will need *write* permission for the **Maintenance** subsystem.
Adding a new printer

To add a new printer to the CMS server:

1. From the Controller window, select **Tools > Maintenance**.
   
   *Supervisor* displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Select **Printer Administration** in the **Operations:** list.

4. Select **OK**.
   
   *Supervisor* displays the **Printer Administration** window.

5. In the **CMS printer name:** field, enter the name of the new printer.
   
   The name assigned to the printer must be unique from all other installed printers; however, it can be assigned the same name it was given during the Solaris administration.
6. In the **LP printer name:** field, enter the name assigned to the printer when it was administered in Solaris.

7. In the **Description:** field, enter any additional information to identify the printer.

8. If the printer uses IBM graphic characters, select the **IBM graphic characters:** check box. Otherwise, leave the check box deselected.

9. In the **Lines per page:** field, enter the number of lines that fit on a page.

   The default is 66 lines. CMS formats reports to correspond to the value in this field.

10. In the **Print type:** options select one of the following choices:

    - Select **Normal** (default setting)
    - Select **Other.** Then, in the corresponding field, enter the specific print type such as pica, elite, or compressed.

11. If you want a banner to be printed for every print job, select the **Banners:** check box.

    A banner is a cover sheet that identifies the user who requested the print job.

12. From the **Actions** menu, select **Add.**

---

**Listing all printers**

To list all printers defined on the CMS server:

1. From the Controller window, select **Tools > Maintenance.**

   *Supervisor* displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Select **Printer Administration** in the **Operations:** list.
4. Select **OK**.
   
   *Supervisor* displays the **Printer Administration** window.

5. From the **Actions** menu, select **List all**.
   
   *Supervisor* displays the **Printer Administration - List All** window.
Modifying printer options

To modify the options for a printer currently existing on the CMS server:

1. From the Controller window, select **Tools > Maintenance**.
   Supervisor displays the **Maintenance** window.

2. Select the **Operations** tab.

3. Select **Printer Administration** in the **Operations**: list.

4. Select **OK**.
   Supervisor displays the **Printer Administration** window.

5. Perform one of the following procedures to select the correct printer:
   - If you know the name of the printer, enter the name of the printer in the **CMS printer name**: field, and then press the **Enter** key.
If you do not know the name of the printer, perform the following:

i. From the Actions menu, select Find one.

ii. If more than one match is found, go to the Actions menu, and select Next. Repeat this step until the printer you want to modify is displayed.

⚠️ Important:

You cannot modify the name of a CMS printer. If you want to change a printer name, you must delete the printer and add it again with a new name. See Deleting a printer on page 579, and Adding a new printer on page 575 for more information.

6. Make changes to any of the fields in the Printer Administration window, except the CMS printer name: field

7. From the Actions menu, select Modify.

---

**Deleting a printer**

To delete a printer currently defined on a CMS server:

1. From the Controller window, select Tools > Maintenance.

   Supervisor displays the Maintenance window.

   ![Maintenance window](image)

2. Select the Operations tab.

4. Select **OK**.

*Supervisor* displays the **Printer Administration** window.

![Printer Administration window](image)

5. Perform one of the following procedures to select the correct printer:

- If you know the name of the printer, enter the name of the printer in the **CMS printer name** field, and then press **Enter**.

- If you do not know the name of the printer, perform the following:
  1. From the **Actions** menu, select **Find one**.
  2. If more than one match is found, go to the **Actions** menu, and select **Next**. Repeat this step until the printer you want to delete is displayed.

6. From the **Actions** menu, select **Delete**.

If you try to delete a printer that is assigned to users, you will receive a message asking if you still want to delete the printer.

Users assigned to this printer will not have another printer assigned when it is deleted.
Maintenance Error Log

Use the Maintenance Error Log Report to aid you in working on system problems and to aid Services personnel in clearing problems from your system. The Maintenance Error Log displays a chronological list of warnings, information, and errors detected by CMS.

This section contains the following topics:

- Before you begin on page 581
- Running a Maintenance Error Log on page 582
- Severity of errors on page 584
- Maintenance Error Log messages on page 584

Before you begin

The following items should be read and understood before working with the Maintenance Error Log:

- The Maintenance Error Log can contain 500 entries. When the log reaches 500 records the next record will overwrite the oldest record.
- The entries in the Maintenance Error Log are displayed in chronological order, starting with the most recent entry.
- You can search the log by error severity or by error code
- The results of all archives and backups are written to the Maintenance Error Log.
- If you have Avaya CMS Forecast, the results of the Forecast Manager are written to the Maintenance Error Log.
Running a Maintenance Error Log

1. From the Controller window, select **Tools > Maintenance**.
   *Supervisor* displays the **Maintenance** window.

2. Select the **Reports** tab.
3. Select **Error Log Report** in the **Reports**: list.
4. Select **OK**.
   *Supervisor* displays the **Maintenance Error Log** window.

5. In the **ACD**: drop down list, enter the ACD on which you want to see an error log or select **All** to include all ACDs. Selecting an ACD Group shows the error logs for only the member ACDs of that group.
6. If the **Error codes:** field is blank, all error codes are displayed in the error log report. If you only want the report to include specific error codes, enter the necessary codes in the **Error codes:** field.

7. In the **Severities:** drop down list, enter the severity of errors you want to see the report or select **All Severities** to include errors of any severity.

See **Severity of errors** on page 584 for additional information on error code classifications.

8. In the **Dates:** field, enter the amount of time that the report will include through one of the following methods:

   - Enter the date(s) in the MM/DD/YY format.
   - Use the history list to select the dates.
   - Use the Browse button to select the dates.

8. Enter the date in relative format; for example, 0 for today, -1 for yesterday.

9. Select one of the following **Destination:** options:

   - To display the Maintenance Error Log on the monitor, select **View Report on Screen**.
   - To send the Maintenance Error Log to a printer, select **Print Report**.

10. Select **OK**.

    **Supervisor** displays the **Maintenance Error Log Report**.

See **Maintenance Error Log messages** on page 584 for additional definitions for the possible error messages.
Severity of errors

The following list describes the error classifications in the Maintenance Error Log:

- **ALARM** - This type of entry could cause the system to crash or fail. You must work with Avaya Services to avoid the possibility of system failure.

- **ERROR** - This type of entry needs immediate action. For example, a backup may not be working properly.

- **INFO** - This type of entry does not need immediate action but is listed either to let you know that some aspect of the system is not operating correctly or to indicate the status of an operation. For example, **Successful**.

Maintenance Error Log messages

The Maintenance error codes and related messages are organized by error code number. If any of the solutions do not resolve the problem you are experiencing, contact your CMS services representative. If a reference to a task number is shown in the Maintenance Error Log, give the number to the CMS services personnel.

The following table lists the possible error codes as well as the related information:

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Message</th>
<th>Reason/Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>500</td>
<td>UNIX error on OPEN, file: &lt;filename&gt;</td>
<td>Could not write a file which is part of a timetable. One or more timetable tasks may be corrupted.</td>
</tr>
<tr>
<td>505</td>
<td>UNIX error on WRITE, file: File system may be out of space.</td>
<td>Error in writing the file. Potential file space problem.</td>
</tr>
<tr>
<td></td>
<td>The following two errors are found together:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>UNIX error on WRITE, file: SIGPIPE signal caught during printing, print request is incomplete or failed</td>
<td></td>
</tr>
<tr>
<td></td>
<td>UNIX error on WRITE, file: lp. The user may have no default printer assigned and the UNIX(r) system administration for a default system line printer has not been done.</td>
<td>Could not print a file. The Solaris server probably does not have a default system line printer assigned, and the user probably does not have a CMS default printer assigned. Administer a default printer with Solaris. Select the &lt;F3&gt; key -&gt; Options -&gt; default printer to assign a default printer to a user. Ensure that the user has the appropriate permissions to the printer in the User Permissions subsystem.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>555</td>
<td>UNIX error on EXEC: Couldn't execute the following command: &lt;user command&gt;</td>
<td>System is too busy for command to be processed.</td>
</tr>
<tr>
<td>555</td>
<td>UNIX error on EXEC: CMS couldn't run because &lt;user command&gt; wouldn't execute</td>
<td>System is too busy for command to be processed.</td>
</tr>
<tr>
<td>556</td>
<td>UNIX error on FORK: CMS couldn't run because the system was too busy.</td>
<td>System is too busy for command to be processed.</td>
</tr>
<tr>
<td>556</td>
<td>UNIX error on FORK: UNIX process limit exceeded, system is too busy</td>
<td>CMS was unable to start a process. This will occur most likely if a user is logged into CMS through multiple terminals. Make sure each user logs in on only one CMS terminal/session at a time. If this message occurs when timetables are running, try adjusting the starting times of the timetables so that fewer are running simultaneously. If it occurs when running Main Menu Additions, try rewriting the Main Menu Additions to use fewer simultaneous Solaris processes.</td>
</tr>
<tr>
<td>556</td>
<td>UNIX error on FORK: Call records not being sent. Call Services.</td>
<td>The process for transferring external call records could not be started. Call Services.</td>
</tr>
<tr>
<td>557</td>
<td>UNIX call error: UNIX process limit exceeded. System is too busy</td>
<td>This error could occur for multiple reasons. Call services for assistance.</td>
</tr>
<tr>
<td>557</td>
<td>UNIX call error: uucp failed</td>
<td>The uucp file transfer mechanism for the External Call Records feature has failed. The system will automatically retry the transfer. If it fails repeatedly, call Services.</td>
</tr>
<tr>
<td>1001</td>
<td>UNIX error on NEW Agent upper bound has been reached. You have administered more Agent Exceptions than are allocated. You must either delete unneeded exceptions or allocate more space in System Setup: Data Storage Allocation.</td>
<td>The exception distributor process (ED) is attempting to log more agent exceptions than will fit in the storage space allocated for them. Delete unneeded exceptions or allocate more space in System Setup &gt; Data Storage Allocation.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1001</td>
<td>UNIX error on NEW Split upper bound has been reached. You have administered more Split Exceptions than are allocated. You must either delete unneeded exceptions or allocate more space in System Setup: Data Storage Allocation.</td>
<td>The exception distributor process (ED) is attempting to log more Split exceptions than will fit in the storage space allocated for them. Delete unneeded exceptions or allocate more space in System Setup &gt; Data Storage Allocation.</td>
</tr>
<tr>
<td>1001</td>
<td>UNIX error on NEW Trunk group upper bound has been reached. You have administered more Trunk Group Exceptions than are allocated. You must either delete unneeded exceptions or allocate more space in System Setup: Data Storage Allocation.</td>
<td>The exception distributor process (ED) is attempting to log more Trunk Group exceptions than will fit in the storage space allocated for them. Delete unneeded exceptions or allocate more space in System Setup &gt; Data Storage Allocation.</td>
</tr>
<tr>
<td>1001</td>
<td>UNIX error on NEW VDN upper bound has been reached. You have administered more VDN Exceptions than are allocated. You must either delete unneeded exceptions or allocate more space in System Setup: Data Storage Allocation.</td>
<td>The exception distributor process is attempting to log more VDN exceptions than will fit in the storage space allocated for them. Delete unneeded exceptions or allocate more space in System Setup &gt; Data Storage Allocation.</td>
</tr>
<tr>
<td>1001</td>
<td>UNIX error on NEW Vector upper bound has been reached. You have administered more Vector Exceptions than are allocated. You must either delete unneeded exceptions or allocate more space in System Setup: Data Storage Allocation.</td>
<td>The exception distributor process is attempting to log more Vector exceptions than will fit in the storage space allocated for them. Delete unneeded exceptions or allocate more space in System Setup &gt; Data Storage Allocation.</td>
</tr>
<tr>
<td>1050</td>
<td>INFORMIX SQL syntax error:</td>
<td>The given SQL command is syntactically incorrect. Usually more details of the error are included. For customers, this error is reported via their custom report and is corrected there. For CMS, this is usually a software problem which may need reporting. Correct the SQL statement in the custom report.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
<td>--------------</td>
</tr>
<tr>
<td>1053</td>
<td>INFORMIX insert error</td>
<td>An internal error or a full ACD dbspace is preventing data from being inserted into the ag_actv database table. Make sure that there is enough room in the ACD dbspace that holds the table.</td>
</tr>
<tr>
<td>1100</td>
<td>IPC error on messages: message queue queue is NN% full</td>
<td>This message is logged when a message queue is more than 75 percent full. Each message queue is checked approximately once every two minutes. If this message is repeatedly logged, CMS is in danger of losing messages that may result in loss of customer data. Single occurrences of this message can be ignored. If it happens repeatedly, contact services for assistance. Try reducing your CMS usage while this message is being logged to reduce the chances of losing data. If this message occurs while you are doing a CMS backup, try doing the backup during a less busy period.</td>
</tr>
<tr>
<td>1302</td>
<td>PROCESS COMMUNICATIONS (PO) library error, function: ERROR - &lt;HARCH&gt; receiving too many exceptions too fast. Some exceptions have been discarded. Reduce the number of active exceptions or change thresholds so that fewer exceptions are triggered.</td>
<td>Exceptions are being generated faster than interval archiver process can handle them. This is the result of having too many exceptions activated, or having thresholds set to produce too many exceptions. Reduce the number of active exceptions or change thresholds so that fewer exceptions are triggered.</td>
</tr>
<tr>
<td>1302</td>
<td>PROCESS COMMUNICATIONS (PO) library error, function: ERROR - &lt;IDBM&gt; receiving too many exceptions too fast. Some exceptions have been discarded. Reduce the number of active exceptions or change thresholds so that fewer exceptions are triggered.</td>
<td>Exceptions are being generated faster than intermediate database manager interface process can handle them. This is the result of having too many exceptions activated, or having thresholds set to produce too many exceptions. Reduce the number of active exceptions or change thresholds so that fewer exceptions are triggered.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1302</td>
<td>PROCESS COMMUNICATIONS (PO) library error, function: ERROR - &lt;SPI&gt; receiving too many exceptions too fast. Some exceptions have been discarded. Reduce the number of active exceptions or change thresholds so that fewer exceptions are triggered.</td>
<td>Exceptions are being generated faster than the switch interface process can handle them. This is the result of having too many exceptions activated, or having thresholds set to produce too many exceptions. Reduce the number of active exceptions or change thresholds so that fewer exceptions are triggered.</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: Unable to successfully complete archiving.</td>
<td>Unable to initialize CMS environment. Re-initiate Data Summarizing.</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: Failure in agent exception database table. Agent exception data not being stored. Call Services.</td>
<td>This error message is logged when the exception distributor process is unable to insert rows in the agent exception table. The error can occur when the ACD dbspace holding the agent exception table becomes full. No more agent exceptions can be recorded until the problem is corrected.</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: Failure in link exception database table. Link exception data not being stored. Call Services.</td>
<td>This error message is logged when the exception distributor process is unable to insert rows in the link exception (linkEx) table. The error can occur when the disk partition holding the link exception table becomes full. No more link exceptions can be recorded until the problem is corrected.</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: Failure in malicious call trace exception database table. MCT exception data not being stored. Call Services.</td>
<td>This error message is logged when the exception distributor process is unable to insert rows in the malicious call trace exception (mctEx) table. The error can occur when the disk partition holding the malicious call trace exception table becomes full. No more malicious call exceptions can be recorded until the problem is corrected. Call Services.</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: Failure in split exception database table. Split exception data not being stored. Call Services.</td>
<td>This error message is logged when the exception distributor process is unable to insert rows in the split exception (spEx) table. The error can occur when the disk partition holding the split exception table becomes full. No more split exceptions can be recorded until the problem is corrected. Call Services.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: Failure in trunk group exception table. Trunk group exception data not being stored. Call Services.</td>
<td>This error message is logged when the exception distributor process is unable to insert rows in the trunk group exception table. The error can occur when the disk partition holding the trunk group exception table becomes full. No more trunk group exceptions can be recorded until the problem is corrected. Call Services.</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: Failure in VDN exception database table. VDN exception data not being stored. Call Services.</td>
<td>This error message is logged when the exception distributor process is unable to insert rows in the VDN exception (vdnEx) table. The error can occur when the disk partition holding the VDN exception table becomes full. No more VDN exceptions can be recorded until the problem is corrected. Call Services.</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: Failure in vector exception database table. Vector exception data not being stored. Call Services.</td>
<td>This error message is logged when the exception distributor process is unable to insert rows in the vector exception (vecEx) table. The error can occur when the disk partition holding the vector exception table becomes full. No more vector exceptions can be recorded until the problem is corrected. Call Services.</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: CMS task limit exceeded, system is too busy</td>
<td>This message means that a CMS task cannot be created because CMS is already running the maximum number of tasks. Make sure each user logs in to CMS only once. If this message occurs when timetables are running, try adjusting the starting times of the timetables so that fewer are running simultaneously. If it occurs when running Main Menu Additions, try rewriting the Main Menu Additions to use fewer simultaneous Solaris processes.</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: Update failure for &lt;item searched&gt; Too much data. Try again with a more restrictive search.</td>
<td>Item searched for is too large. The search needs to be restricted further. Restrict the search to a smaller amount of data.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: disk may be full.</td>
<td>Error in searching for item. Disk may be full.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Clean up unnecessary files from disk.</td>
</tr>
<tr>
<td>1350</td>
<td>GENERAL error internal to process: Failure in removing data from database table: ag_actv. Agent Trace data not being stored. Call Services.</td>
<td>An internal error occurred that prevents data from being deleted from the ag_actv database table. Call Services.</td>
</tr>
<tr>
<td>1351</td>
<td>GENERAL error in process interface: Invalid action request.</td>
<td>Something is corrupted with the window interface.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Exit and re-enter the data summarizing window. Attempt to initiate data summarizing again.</td>
</tr>
<tr>
<td>1351</td>
<td>GENERAL error in process interface: Cannot archive a day which interval data does not exist for.</td>
<td>Interval data does not exist for the requested day or any day prior to the requested day. The number of days of interval data saved is based on the Days of Intrahour field set on the Data Storage Allocation window. Re-initiate Data Summarizing for a day that is within the number of Days of Intrahour saved. For future reference, the number of Days of Intrahour data can be increased. Disk space must be considered before changing this parameter.</td>
</tr>
<tr>
<td>1351</td>
<td>GENERAL error in process interface: Cannot archive the requested week/month. Daily data does not exist for all tables for the week/month beginning xx/xx/xx.</td>
<td>Daily data does not exist for the requested week/month or any week/month prior to the requested day. The number of days of interval data saved is based on the Days of Daily field set on the Data Storage Allocation window. Re-initiate Data Summarizing for a week/month that is within the number of Days of Daily saved. For future reference, the number of Days of Daily data can be increased. Disk space must be considered before changing this parameter. If the number of Days of Daily is changed and intrahour daily data is present for the days of the requested week/month, those days can be archived and the week/month can then be archived.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
<td>--------------</td>
</tr>
<tr>
<td>1351</td>
<td>GENERAL error in process interface: ERROR - &lt;ARCH&gt; receiving too many archive requests too fast. Some requests have been discarded.</td>
<td>Too many data summarizing requests (more than 25) have been initiated in a short period of time (approx. 1/2 hour) and cannot all be processed. Determine all data summarizing requests that have been initiated. Once all requests have been processed, verify the requests against the completed archives (as reported in /cms/dc/archive/arch.log). Re-initiate archive for the date and archive (daily/weekly/monthly) for the archives not initiated. In the future, do not initiate all requests at once.</td>
</tr>
<tr>
<td>1351</td>
<td>GENERAL error in process interface: Cannot archive a day in the future.</td>
<td>The date of the requested archive has not happened yet. Re-initiate the daily archive for a date prior to today.</td>
</tr>
<tr>
<td>1351</td>
<td>GENERAL error in process interface: Cannot archive a partial weeks/months data.</td>
<td>The last day for the week/month has not been archived yet. Verify that a weekly/monthly archive is not being requested for the current week/month. That is, the end of the week/month has not been reached yet. Re-initiate the weekly/monthly archive for a week/month in which the last day has already been archived.</td>
</tr>
<tr>
<td>1351</td>
<td>GENERAL error in process interface: stopping task id to free up message queue</td>
<td>A message queue is more than 85 percent full and the task that should be reading from the queue is apparently stuck. This message is logged when CMS restarts the task to attempt to clear the error condition. Depending on which task has been stopped, it is likely that some customer data has been lost. Report the problem to services. If this error is logged repeatedly, try reducing your CMS usage while this message is being logged to reduce the chances of losing data. If this message occurs while you are doing a CMS backup, try conducting the backup during a less busy period.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
<td>--------------</td>
</tr>
<tr>
<td>1351</td>
<td>GENERAL error in process interface: External applications not started. Set to OFF</td>
<td>When the External Application feature was started, there was some general error. The feature was turned back off because of this error. Request help from your External Application provider (Avaya Professional Services Organization).</td>
</tr>
<tr>
<td>1351</td>
<td>GENERAL error in process interface: Activate Agent Trace request failed. Try again.</td>
<td>This error is logged when the agent activity recorder process (AAR) has too many messages in its message queue to accept any more. This can occur when many very active agents are being traced, keeping aar's queue full. Trace fewer agents or try this request again later.</td>
</tr>
<tr>
<td>1351</td>
<td>GENERAL error in process interface: Task &lt; task_num&gt; of timetable &lt;name&gt; may not have completed, window status was: &lt;status&gt;</td>
<td>Timetable ran and has a status other than Successful. Based on what the timetable was, examine the state of things (database, ACD administration, etc) to see if the request completed. If desired, complete the action manually by running CMS now.</td>
</tr>
<tr>
<td>1400</td>
<td>SPI session error: data collection session is down</td>
<td>An error has occurred in the X.25 connection to the switch. CMS data is not being collected. CMS will automatically try to restore the link. If the link does not re-establish by itself within five minutes, check the cables, modems, and other hardware between the CMS and the switch for any obvious loose connections.</td>
</tr>
<tr>
<td>1404</td>
<td>SPI configuration error: Insufficient unmeasured trunks allocated. To avoid further data loss, go to Data Storage Allocation and administer more unmeasured trunk facilities.</td>
<td>There are not enough unmeasured trunks allocated in the CMS realtime database to track all calls. This message is logged once during each data collection interval when the error condition occurs. When this message appears, some call data has already been lost. Data will continue to be lost until more trunk facilities have been allocated. Allocate more unmeasured trunk facilities in the Data Storage Allocation screen.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1404</td>
<td>SPI configuration error: Switch and UNIX clocks differ by more than 24 hours. Switch clock is <code>&lt;nn:nn:nn nn/nn/nn&gt;</code> UNIX clock is <code>&lt;mm:mm:mm mm/mm/mm&gt;</code> Data collection will remain down until switch or UNIX clock is reset so they agree.</td>
<td>CMS requires that the times on the Communication Manager and Solaris systems remain within 24 hours of each other. This is done to prevent an accidental deletion of all historical data if someone were to inadvertently change the clock to a date far into the future. If the Solaris clock is correct but the Communication Manager clock is incorrect, reset the clock at the switch. CMS will bring the link up automatically within five minutes after correcting the switch clock.</td>
</tr>
<tr>
<td>1404</td>
<td>SPI configuration error: Extension <code>&lt;number&gt;</code> has been staffed by two different login IDs: <code>&lt;first&gt;</code> and <code>&lt;second&gt;</code>. Data will be tracked only for the last login ID. Ask the agent to log off and log in again with a single login ID.</td>
<td>Protocol error as explained in the message. Ask the agent to log off and log in again with a single login ID.</td>
</tr>
<tr>
<td>1404</td>
<td>One of the following messages will be displayed depending on the switch configuration: Two agents at extensions <code>&lt;ext&gt;</code> in split <code>&lt;num&gt;</code> and <code>&lt;ext&gt;</code> in split <code>&lt;num&gt;</code> are logged in with the same login ID: <code>&lt;id&gt;</code> This may indicate table corruption on the switch. Contact Services to repair table as soon as possible. Two agents at extensions <code>&lt;ext&gt;</code> and <code>&lt;ext&gt;</code> are logged in with the same login ID: <code>&lt;id&gt;</code>. This may indicate table corruption on the switch. Contact Services to repair table as soon as possible.</td>
<td>Protocol violation or switch corruption. Try requesting new translations in Maintenance: ACD Status screen. If the problem persists, call Services.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
<td>--------------</td>
</tr>
<tr>
<td>1404</td>
<td>One of the following messages will be displayed depending on the switch configuration: SPI configuration error: Agent &lt;logid&gt; at extension &lt;ext&gt; has logged into too many splits: &lt;sp1&gt;, and &lt;sp2&gt;. Data will only be tracked for the last split. This may indicate incorrect switch type on CMS for G3. SPI configuration error: Agent &lt;logid&gt; at extension &lt;ext&gt; has logged into too many splits: &lt;sp1&gt;, &lt;sp2&gt;, &lt;sp3&gt;, and &lt;sp4&gt;. Data will only be tracked for the last split. This may indicate incorrect switch type on CMS for G3. SPI configuration error: Agent &lt;logid&gt; at extension &lt;ext&gt; has logged into too many splits: &lt;sp1&gt;, &lt;sp2&gt;, &lt;sp3&gt;, &lt;sp4&gt;, and &lt;sp5&gt;. Data will only be tracked for the last split. This may indicate incorrect switch type on CMS for G3.</td>
<td>Switch type mismatch, protocol violation or switch table corruption. Try requesting new translations in Maintenance: ACD Status screen. If the problem persists, call Services.</td>
</tr>
<tr>
<td>1406</td>
<td>SPI data message error: ERROR can't new a message (or got illegal opcode)</td>
<td>This generally indicates that there is a mismatch between the administered CMS type on the Communication Manager system and the actual CMS or there is a mismatch between the administered switch type and feature set of the switch on the CMS. This results in message formats being of unexpected lengths. Data is lost since the remainder of the buffer is discarded after the unknown message. Determine if the problem happens more than once. Call Services.</td>
</tr>
<tr>
<td>1407</td>
<td>SPI timer expired error: there is no response from the switch</td>
<td>CMS has stopped receiving messages from the Communication Manager system. CMS data is not being collected. CMS will automatically try to restore the link. At the switch, perform a busy out and release the MIS connection.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1409</td>
<td>SPI ACD administration error: switch was unable to logon agent &lt;logid&gt; with skill &lt;num&gt;</td>
<td>For some reason the login failed on the switch. This login may have been part of a Move Agent or Change Agent Skills request which was pending. Have the agent try to log in to the skill again. Or put the agent in the AUX workmode for all skills and have no calls on their set. Repeat the administration request. If the request fails again, collect the information from the status window for Services.</td>
</tr>
<tr>
<td>1409</td>
<td>One of the following messages will be displayed:</td>
<td>Previous ACD administration request for moving an agent or changing an agent's skills was pending. When the pending was resolved, the agent could not be moved for some reason. Put the agent in the AUX workmode for all split/skills and have no calls on their set. Repeat the administration request. If the request fails again, collect the information from the status window for Services.</td>
</tr>
<tr>
<td></td>
<td>SPI ACD administration error: switch unable to move ext &lt;ext&gt; from split &lt;num&gt; to &lt;num&gt;</td>
<td></td>
</tr>
<tr>
<td></td>
<td>SPI ACD administration error: switch unable to move ext &lt;ext&gt; from split &lt;num&gt;</td>
<td></td>
</tr>
<tr>
<td>1501</td>
<td>SCREEN MANAGER error: system may be overloaded by real time reports behind by XX seconds.</td>
<td>CMS is behind on refreshing the real-time reports currently running. Run fewer real-time reports or lengthen refresh rates for the reports currently running.</td>
</tr>
<tr>
<td>1600</td>
<td>FORECAST status: Forecast Manager failed for mm/dd/yy</td>
<td>Forecast Manager failed in its attempt to perform the daily data collection and/or the current day report for mm/dd/yy. If the date is invalid, correct the date and rerun the report. If it is not a problem with the date, call Services for assistance.</td>
</tr>
<tr>
<td>1600</td>
<td>FORECAST status: Forecast Manager failed for mm/dd/yy - mm/dd/yy</td>
<td>Forecast Manager failed in its attempt to perform the recollect data for a range of dates mm/dd/yy - mm/dd/yy. The first date is the start date and the second date is the stop date. If the dates are invalid, correct the date and rerun the report. If it is not a problem with the date, call Services for assistance.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
<td>--------------</td>
</tr>
<tr>
<td>1700</td>
<td>BACKUP Process out of sync. Contact Services.</td>
<td>A bad message was received from the backup screen. If this occurs, some sort of interference may have occurred in the message queue between the backup process and backup screen. If the problem re-occurs, something is impacting the communication between the processes. Further investigation is necessary to determine the source of the problem. Exit the current instance of the backup screen and re-initiate the backup. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>1701</td>
<td>BACKUP Process out of memory. Contact Services.</td>
<td>If this error occurs, it is when the tape is being verified, but after the backup has already completed successfully. If tape verification is not essential, no further action is necessary. This error indicates a problem with memory allocation. Exit the current instance of the backup screen and re-initiate the backup. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>1702</td>
<td>BACKUP Process startup failed. Contact Services</td>
<td>Any number of startup activities could cause this problem. Most are message and database activities that should never be encountered. If the problem re-occurs, something is peculiar in the environment of the backup process and further investigation is necessary to determine the source of the problem. Exit the current instance of the backup screen and re-initiate the backup. Verify that the problem does not re-occur.</td>
</tr>
</tbody>
</table>
| 1703       | BACKUP Volume access failed. Retry Backup. | A problem accessing the backup device has occurred. This problem could range from an invalid backup device to the tape drive requiring cleaning. Verify the following:  
  * The backup device is administered properly (name corresponds with solaris administered device)  
  * The tape compatibility is correct(320 meg tape for 320 meg drive, etc.).  
  * The tape drive is clean. |
<table>
<thead>
<tr>
<th>Error Code</th>
<th>Message</th>
<th>Reason/Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1704</td>
<td>BACKUP Volume check failed. Retry Backup.</td>
<td>Either the inserted tape is a recent backup and backup was initiated in timetable or backup had difficulty determining the most recent backup (either full or incremental) volume. Determine if the inserted tape is associated with the most recent backup (full or incremental). Replace the tape and re-execute backup (or services run br_check).</td>
</tr>
<tr>
<td>1705</td>
<td>BACKUP Volume verification failed. Retry Backup.</td>
<td>A problem reading the tape exists. Exit the current instance of the backup screen and re-initiate the backup. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>1706</td>
<td>BACKUP Table backup failed. Retry Backup. Table=</td>
<td>A problem was encountered either reading the indicated table or writing that table to tape. Replace the tape with a new tape (after verifying no problems with the indicated table) and re-execute the backup process. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>1707</td>
<td>BACKUP Volume span failed. Retry Backup</td>
<td>When verifying the backup tape, a problem was discovered between the current volume and the previous volume. Most likely, the blocks are out of sequence. More specifically, at least 1 block is missing. Re-execute the backup process. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>1708</td>
<td>BACKUP Error in process communication. Retry Backup.</td>
<td>This should never be encountered. A bad message was received from the backup screen (or erroneously from another process). If this occurs, some sort of interference occurred in the message queue between the backup process and backup screen. If the problem re-occurs, something is impacting the communication between the processes. Further investigation is necessary to determine the source of the problem. Exit the current instance of the backup screen and re-initiate the backup. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1709</td>
<td>BACKUP Backup history update failed. Retry Backup.</td>
<td>This should never be encountered. The backup was completed successfully. A problem exists with the update tables or the process to update the tables. Verify that the next backup does not encounter this problem.</td>
</tr>
<tr>
<td>1710</td>
<td>BACKUP Process in need of service. Please check the Backup screen.</td>
<td>An acknowledgement window is requiring a response. Respond to the backup acknowledgement window.</td>
</tr>
<tr>
<td>1711</td>
<td>INFO Warning backup waited 210/7200 seconds before archive completed.</td>
<td>The backup process waited 210 seconds for the current archiving process to finish. Backups should not be run during the archiving process. If this occurs consistently, consider rescheduling your archiving and backup processes so that overlap does not occur.</td>
</tr>
<tr>
<td>1711</td>
<td>ERROR backup terminated because archive did not complete within 2 hours.</td>
<td>The backup process waited two hours for the archiving process to be completed and was terminated as a result. Backups should not be run during the archiving process. Reschedule the backup and archiving processes so that simultaneous processing does not occur.</td>
</tr>
<tr>
<td>1711</td>
<td>BACKUP INFO:</td>
<td>Backup was initiated through a timetable and information is reported (number of volumes and backup completed) simply for information purposes. No action required</td>
</tr>
<tr>
<td>1750</td>
<td>BACKUP Screen startup failed. Contact Services.</td>
<td>Any number of startup activities could cause this problem. Most problems deal with accessing screen entries and database activities that should never be encountered. If the problem re-occurs, something is peculiar in the environment of the backup process. Further investigation is necessary to determine the source of the problem. Exit the current instance of the backup screen and re-initiate the backup. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>----------------------------------------------</td>
<td>-------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1751</td>
<td>BACKUP Screen execution failed. Retry Backup.</td>
<td>Any number of startup activities could cause this problem. Most problems deal with accessing screen entries and database activities that should never be encountered. If the problem re-occurs, something is peculiar in the environment of the backup process. Further investigation is necessary to determine the source of the problem. Exit the current instance of the backup screen and re-initiate the backup. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>1800</td>
<td>RESTORE Process out of sync. Contact Services.</td>
<td>A bad message was received from the restore screen. If this occurs, some sort of interference occurred in the message queue between the restore process and restore screen. If the problem re-occurs, something is impacting the communication between the processes. Further investigation is necessary to determine the source of the problem. Exit the current instance of the restore screen and re-initiate the restore. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>1801</td>
<td>RESTORE Process out of memory. Contact Services.</td>
<td>A problem with memory allocation exists. Exit the current instance of the restore screen and re-initiate the restore. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>1802</td>
<td>RESTORE Process startup failed. Contact Services.</td>
<td>Any number of startup activities could cause this problem. If the problem re-occurs, something is peculiar in the environment of the restore process and further investigation is necessary to determine the source of the problem. Exit the current instance of the restore screen and re-initiate the restore. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>---------</td>
<td>--------------</td>
</tr>
</tbody>
</table>
| 1803       | RESTORE Volume access failed. Retry Restore. | A problem exists accessing the restore device. This could be an invalid restore device, the tape drive requiring cleaning, or a table header format problem (internal error). Verify the following:  
- The backup/restore device is administered properly (name corresponds with Solaris administered device).  
- The tape compatibility is correct (320 meg tape for 320 meg drive, etc.).  
- The tape drive is clean. |
<p>| 1804       | RESTORE Error in process communication. Retry Restore. | A bad message was received either by the restore screen or the restore process. If this occurs, some sort of interference occurred in the message queue between the restore process and the restore screen. If the problem re-occurs, something is impacting the communication between the processes. Further investigation is necessary to determine the source of the problem. Exit the current instance of the restore screen and re-initiate the restore. Verify that the problem does not re-occur. |
| 1805       | RESTORE Table restore failed. Retry Restore. Table= | A problem was encountered either reading the indicated table from tape or writing that table into the database. Perform a specific table restore for the indicated table. Verify that the problem does not re-occur. |
| 1806       | RESTORE INFO: Volume contains no data for ACD=X | This is an Information message indicating that the current table for the indicated ACD does not have data. No action required. |
| 1850       | RESTORE Screen startup failed. Contact Services. | Any number of startup activities could cause this problem. Most problems result from accessing screen entries that should never be encountered. If the problem re-occurs, something is peculiar in the environment of the restore process and further investigation is necessary to determine the source of the problem. Exit the current instance of the restore screen and re-initiate the restore. Verify that the problem does not re-occur. |</p>
<table>
<thead>
<tr>
<th>Error Code</th>
<th>Message</th>
<th>Reason/Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>1851</td>
<td>RESTORE Screen execution failed. Retry Restore.</td>
<td>Updating the status on the screen could cause this problem (although extremely rare). If the problem re-occurs, something is peculiar in the environment of the restore process and further investigation is necessary to determine the source of the problem. Exit the current instance of the restore screen and re-initiate the restore. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>1900</td>
<td>SYSTEM MESSAGE OVERLOAD: Agent Trace (AAR) is overloaded, some agent trace data lost. Turn off traces for some agents to prevent possible further overloading.</td>
<td>AAR is receiving messages faster than it can process them. Turn off traces for some agents. Data is being sent faster than it can be processed. This usually indicates that the system as a whole is overloaded. Stop some reports or applications so that the system capacity is increased.</td>
</tr>
<tr>
<td>1900</td>
<td>SYSTEM MESSAGE OVERLOAD: Call History Recorder (ch_rec) overloaded, some call record data lost.</td>
<td></td>
</tr>
<tr>
<td>1901</td>
<td>FULL DISK ERROR: Out of disk space. Data Collection failed (Archiver).</td>
<td>Enough disk space is not available for the insertion of daily/weekly/monthly archive data. Free up disk space or add more disk space in the form of additional hard disks.</td>
</tr>
<tr>
<td>1901</td>
<td>FULL DISK ERROR: Out of disk space. Harchiver could not write to &lt;TABLENAME&gt;.</td>
<td>Enough disk space is not available for the insertion of agent login/logout or interval archive data. Free up disk space or add more disk space in the form of additional hard disks. If the problem persists, call Services.</td>
</tr>
<tr>
<td>1901</td>
<td>FULL DISK ERROR: cannot write to xxx.</td>
<td>The filesystem or ACD dbspace is out of disk space. Use Free Space Allocation and/or Data Storage Allocation to adjust the amount of space available to the ACD. There is no more disk space to load the data for this pseudo-ACD. The load ACD process cannot continue. Delete the pseudo-ACD and start over again using a later &quot;Start date&quot; for the pseudo-ACD and load less data. Reduce the amount of historical data kept in other ACDs.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1901</td>
<td>FULL DISK ERROR: Automatically turning off data collection and bringing CMS to single user mode</td>
<td>All ACD dbspaces are checked for free space every 10 minutes. By turning off data collection and going to single user mode, CMS prevents corruption of the data that may occur if IDS tries to write data to a full ACD dbspace. CMS cannot be returned to its normal operational state until space has been made available in the ACD dbspace. Use <strong>Free Space Allocation</strong> and/or <strong>Data Storage Allocation</strong> to adjust the amount of space available to the ACD.</td>
</tr>
<tr>
<td>1901</td>
<td>FULL DISK ERROR: WARNING: File system &lt;filesys&gt; is &lt;NN&gt; percent full.</td>
<td>This message is logged once each day near midnight and whenever CMS is started. The message is logged once for each file system or ACD dbspace that is at or beyond 80 percent of maximum capacity. This message is intended as an early warning that disk space may need to be reallocated. No immediate action is necessary. Eventually, you should use <strong>Free Space Allocation</strong> to allocate more space to the ACD dbspace. You should plan to do this well in advance of the ACD dbspace or file system becoming completely full.</td>
</tr>
<tr>
<td>1901</td>
<td>FULL DISK ERROR: Storage Interval Migration failed migrating</td>
<td>The disk or ACD dbspace is out of space. Use <strong>Free Space Allocation</strong> or <strong>Data Storage Allocation</strong> to adjust the amount of space available to the ACD.</td>
</tr>
<tr>
<td>1901</td>
<td>FULL DISK ERROR</td>
<td>The dbspace containing the <code>ag_actv</code> database table is full. Change the allocation of disk space for the various classes of data to accommodate storage of more agent trace records.</td>
</tr>
<tr>
<td>1901</td>
<td>FULL DISK ERROR: Out of disk space. Call Records not recorded.</td>
<td>The dbspace containing the <code>call_rec</code> database table is full. Change the allocation of disk space for the various classes of data to accommodate storage of more internal call records.</td>
</tr>
<tr>
<td>1901</td>
<td>FULL DISK ERROR: Call Records not being stored. Call Services.</td>
<td>The dbspace containing the external call records files is full. Call Services.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>1902</td>
<td>CALL RECORD ERROR: Call Records not being stored. Call Services.</td>
<td>An error was encountered in writing call records to a disk file. Call Services</td>
</tr>
<tr>
<td>1902</td>
<td>ALL RECORD ERROR: Call Records are being collected again.</td>
<td>Previous errors writing files have been cleared and records are again being stored. No action necessary.</td>
</tr>
<tr>
<td>1902</td>
<td>CALL RECORD ERROR: Call Records not being stored, buffer area is full. Call Services</td>
<td>Files containing call records have not been successfully transferred. All storage space has been used and new records cannot be added. Call Services.</td>
</tr>
<tr>
<td>1902</td>
<td>CALL RECORD ERROR: Call rate exceeded capacity: xxx calls not transmitted</td>
<td>The internal Call History feature is activated but the call rate exceeds the maximum capacity handled by this feature; therefore, call records are not being sent to the Call History feature. This message indicates how many calls were not sent in the past data collection interval. This has no effect on the collection of regular data. Call Services.</td>
</tr>
<tr>
<td>2000</td>
<td>Could not run timetable: - Aborting Timetable. &lt;timetable name&gt;</td>
<td>Something is wrong with the timetable which is not allowing proper functionality. Try rescheduling the timetable. Consult this document for information on using timetables to see if there are erroneous tasks in the timetable.</td>
</tr>
<tr>
<td>2000</td>
<td>Could not run timetable: &lt;timetable name&gt; Task &lt;number&gt; of &lt;total&gt; was unable to complete. Reason: &lt;reason&gt;</td>
<td>A timetable task is in error. One common possibility is that the user does not have permissions for the split, vdn, etc. for which they are running reports.</td>
</tr>
</tbody>
</table>
### Error Code | Message | Reason/Action
--- | --- | ---
2000 | Could not run timetable: don't run timetable, in single user mode. timetable = <timetable_name> <user_name> | Timetables cannot run when CMS is in single user mode. An administrator has put CMS in single user mode as required by some special administrative tasks. The severity of the problem is that the user's timetables are not being run when expected. Schedule the timetables that should have run to be performed as soon as possible and then reschedule those timetables back to their original times. Schedule their timetables to run at a time that does not conflict during the time when CMS needs to be in single user mode.

2000 | Could not run timetable: sorry post office open of timetable creat_io_man was not successful for timetable - <timetable name> and <cms id> - <user name>. | Communications cannot be established with a creat_io_man in order to run the timetable. Try rescheduling the timetable.

2000 | Could not run timetable: -- Archiver <timetable name> did not run on <date> for the user - <user name>. Please schedule it to rerun using the Data Summarizing screen. | The Archiver has a problem in moving historical data into tables for the timetable to use. Call Services.

2000 | Could not run timetable: -- Archiver <timetable name> did not run on <date> for the user - <user name>. To schedule a timetable to run as soon as possible, enter a cms start time that is two minutes into the future, and a start date of 0. | A user scheduled a timetable to run in less than two minutes into the future. Reschedule the timetable for at least two minutes into the future.

2100 | Unable to execute <process>. <Impact-description>. Call Services. | The specified process could not be executed. The impact is usually the failure of a major component of CMS such as Agent Trace, Exceptions, or Data Collection. This problem can usually be repaired by stopping CMS and restarting it. Call Services.

2200 | Sometimes the problem can be repaired by stopping CMS and restarting it. <table> | An error was encountered during migration. Call services for assistance.
<table>
<thead>
<tr>
<th>Error Code</th>
<th>Message</th>
<th>Reason/Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>2300</td>
<td>INTERVAL MIGRATION: Interval migration was canceled before it completed. Restart it from the Storage Intervals screen to complete the migration</td>
<td>The migration was canceled manually before it completed. Restart the migration from the Storage Intervals screen.</td>
</tr>
<tr>
<td>2300</td>
<td>INTERVAL MIGRATION: Migrating intrahour historical data for ACD xx from xx to yy minute interval is complete.</td>
<td>This message indicates when intrahour migration is complete. No action required.</td>
</tr>
<tr>
<td>2400</td>
<td>FREE SPACE ALLOCATION: &lt;error message&gt;</td>
<td>This type of error message specifies that the Free Space Allocation feature has suffered a problem in locating or updating database tables. Contact services.</td>
</tr>
<tr>
<td>2500</td>
<td>STORAGE INTERVALS: Weekly start/stop day(s) have been changed from xx to yy.</td>
<td>This is an informational message indicating that the Storage Interval days have changed. Verify that the new days are correct.</td>
</tr>
<tr>
<td>2600</td>
<td>ARCHIVER status: Daily/Weekly/ Monthly Archive not executed for xx/xx/xx due to Data Storage Allocation administration.</td>
<td>Data Storage Allocation indicates 0 days/weeks/months are to be saved; therefore, no reason to archive data exists. This is most commonly a result of an error in user input. If daily archives are desired, Data Storage: Days of Daily/Weeks of Weekly/Months of Monthly entry(ies) must be changed to allow an archive to take place. Disk space must be considered before changing these fields.</td>
</tr>
<tr>
<td>Error Code</td>
<td>Message</td>
<td>Reason/Action</td>
</tr>
<tr>
<td>------------</td>
<td>--------------------------------------------------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>2700</td>
<td>MIGRATE DATA Process out of sync. Call Services.</td>
<td>A bad message was received from the R3 Migrate screen. If this occurs, some sort of interference occurred in the message queue between the R3 Migrate process and the associated screen. If the problem re-occurs, something is impacting the communication between the processes. Further investigation is necessary to determine the source of the problem. Exit the current instance of the R3 Migrate screen and re-initiate the migration. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>2701</td>
<td>MIGRATE DATA Process out of memory. Contact Services.</td>
<td>A problem with memory allocation has occurred. Exit the current instance of the R3 Migrate screen and re-initiate the migration. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>2702</td>
<td>MIGRATE DATA Process startup failed. Contact Services</td>
<td>Any number of startup activities could cause this problem. If the problem re-occurs, there is an error in the environment of the migrate process and further investigation is necessary to determine the source of the problem. Exit the current instance of the R3 Migrate screen and re-initiate the migration. Verify that the problem does not re-occur.</td>
</tr>
</tbody>
</table>
| 2703       | MIGRATE DATA Volume access failed. Retry Restore.                        | A problem exists accessing the migration device. This could range from:  
  ● Invalid migration device  
  ● Tape drive needs cleaning  
  ● Table header format problem (internal error).  
Verify the following:  
  ● The backup/restore device is administered properly (name corresponds with Solaris administered device)  
  ● The tape compatibility is correct (320 meg tape for 320 meg drive, etc.).  
  ● The tape drive is clean. |
<table>
<thead>
<tr>
<th>Error Code</th>
<th>Message</th>
<th>Reason/Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>2706</td>
<td>MIGRATE DATA Table migration failed. Retry Migrate. Table=</td>
<td>A problem was encountered either reading the indicated table from tape or writing that table into the database. Stop the migration and call Services for help with the table that failed. After the problem is fixed, restart the migration.</td>
</tr>
<tr>
<td>2708</td>
<td>MIGRATE DATA Error in process communication. Retry Restore.</td>
<td>A bad message was received either by the R3 Migrate screen or the migration process. If this occurs, some sort of interference occurred in the message queue between the migration process and the R3 Migrate screen. If the problem re-occurs, something is impacting the communication between the processes. Further investigation is necessary to determine the source of the problem. Exit the current instance of the R3 Migrate screen and re-initiate the migration. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>2750</td>
<td>MIGRATE DATA Screen startup failed. Contact Services.</td>
<td>Any number of startup activities could cause this problem. Most can be attributed to accessing screen entries that should never be encountered. If the problem re-occurs, something is in error in the environment of the migrate process and further investigation is necessary to determine the source of the problem. Exit the current instance of the R3 Migrate screen and re-initiate the migrate. Verify that the problem does not re-occur.</td>
</tr>
<tr>
<td>2751</td>
<td>MIGRATE DATA Screen execution failed. Retry Migrate.</td>
<td>This error can result when an update to the R3 Migrate screen fails. If the problem re-occurs, something is in error in the environment of the migrate process and further investigation is necessary to determine the source of the problem. Exit the current instance of the R3 Migrate screen and re-initiate the migration. Verify that the problem does not reoccur.</td>
</tr>
</tbody>
</table>
ACD Administration Log

The ACD Administration Log provides an audit trail for administrative changes made to an ACD by CMS users. The ACD Administration Log records real-time administrative changes made by a user through the CMS ASCII interface, Supervisor, or Visual Vectors. The log also records the administrative changes made by a user through a scheduled timetable or Supervisor script.

This section contains the following topics:

- **Before you begin** on page 608
- **Permissions** on page 608
- **Running the ACD Administration Log report** on page 609
- **ACD Administration Log window field descriptions** on page 611

---

### Before you begin

The following items should be read and understood before working with the ACD Administration Log report:

- The maximum capacity for the log is set at 30,000 records and cannot be changed. When the table size exceeds 30,000 records, the 100 oldest records will be deleted.

- This report can be scheduled through a CMS timetable or a Supervisor script.

- The historical database items of the CMS ACD Administration Log is not available for use with the Avaya CMS Supervisor Report Designer tool. The Supervisor File menu option for this report will not display the Designer option. It will, however, behave in the same manner as drill-down reports.

---

### Permissions

To view the ACD Administration Log report, the user ID used to log in to this Supervisor session requires *read* permission for the Maintenance subsystem.

⚠️ **Important:**

If the ACD Administration Log report is run to display all 30,000 records, your PC should have no less than 200 MB of free disk space to allow for the caching of this data.
Running the ACD Administration Log report

Steps
To run the ACD Administration Log report:

1. From the Controller window, select **Tools > Maintenance**.
   
   *Supervisor* displays the **Maintenance** window.

2. Select the **Reports** tab.

3. In the **Reports** list, select **ACD Administration Log Report**.
   
   It is not necessary to select an ACD in the **ACD**: field as this feature allows ACD specification in a subsequent dialog.
4. Select **OK**.

*Supervisor* displays the **ACD Administration Log** window.

![ACD Administration Log window](image)

The height of this dialog box varies according to the current screen resolution of your PC. A higher screen resolution results in more fields being displayed.

For a description of the **ACD Administration Log** window fields, see [ACD Administration Log window field descriptions](#) on page 611 for additional information.

5. In the available fields, enter the data to use in the report. The data can also be selected through the drop-down history lists or through the Browse buttons.

The more fields that you specify, the more restricted the data will be that is used in the report. If all of the input fields are left blank, all records will be displayed.

6. In the **Destination** group, select one of the following output options:

- **View Report on Screen** - The report is displayed on the screen.
- **Print Report on** - The report is sent to the specified printer. Any printer available to the PC can be used and selected through the button at the right of the field.
7. Select OK.

Supervisor displays the ACD Administration Log Report with the specified data.

ACD Administration Log window field descriptions

The following table provides descriptions for the fields on the ACD Administration Log window:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CMS User IDs:</td>
<td>The login(s) of the user(s) to display in the report. If changes were made to the ACD with the specified IDs, those user IDs and the associated changes will be displayed.</td>
</tr>
<tr>
<td>Dates:</td>
<td>The date or range of dates to be covered in the report. Only those administrative changes made on or within the date(s) specified will be present in the report.</td>
</tr>
<tr>
<td>Times:</td>
<td>A range of time for which log entries are to be displayed. Only those administrative changes made within this time range will be present in the report.</td>
</tr>
<tr>
<td>ACDs(n):</td>
<td>The ACD(s) to include in the report.</td>
</tr>
<tr>
<td>VDNs(n):</td>
<td>The VDN(s) to include in the report.</td>
</tr>
<tr>
<td>Vectors(n):</td>
<td>The Vector(s) to include in the report.</td>
</tr>
<tr>
<td>Agents(n):</td>
<td>The login ID(s) to include in the report.</td>
</tr>
</tbody>
</table>
Chapter 12: Using Solaris

Avaya CMS uses the Solaris operating system on the Sun computer platform to communicate with terminals and printers, to log errors, and to perform operations. This section addresses how to perform several procedures using Sun Microsystems, Inc. Solaris operating system commands.

This section contains the following topics:

- Before you begin on page 613
- Logging in to CMS on page 614
- Administering passwords on page 616
- Using Solaris printer commands on page 619

Before you begin

Be cautious when accessing the Solaris system and running Solaris system commands. Damage can result to your CMS system if you use the Solaris system commands incorrectly. Before you run any Solaris system command, be sure you know what effect it will have.
Logging in to CMS

This section contains procedures for logging in to CMS through methods other than using Supervisor. Some administrators will need to do this in order to access capabilities not available through the Supervisor interface.

This section contains the following topics:

- Logging in to CMS from the remote console on page 614
- Logging in to CMS from the server console on page 614

Logging in to CMS from the remote console

This procedure describes how to log in to CMS from a remote console. Most users log in to CMS remotely.

⚠️ Important:

Do not allow users to share the same login ID as this action will use up Solaris system processes.

Steps

1. At the Login: prompt, enter your login ID.
   The Password: prompt is displayed.
2. Enter your password.
   A prompt for the terminal type is displayed.
3. Enter your terminal type.
   If you use a login other than cms, CMS will automatically open to the CMS Main Menu.
   If cms is used as the login, you will have to enter cms a second time at the $ prompt before the Main Menu will be displayed

Logging in to CMS from the server console

This procedure describes how to log in to CMS from the CMS server console. Logging in to CMS at the server is occasionally necessary in order to perform certain functions, such as a CMSADM backup or other administration functions that require you to switch to single-user mode.
**Important:**

Users who use a `/usr/bin/cms` shell will not be able to log in to CMS through the Common Desktop Environment (CDE).

To remedy this problem, you can either use the `/usr/bin/ksh` shell or use a command line login. The command line login will not use the CDE.

**Steps**

To log in to CMS at the server:

1. If the server has just been rebooted or inactive for an extended period of time, the console may be password-protected. If this is the case, unlock the console by entering your authorized username (if necessary) and password in the appropriate login console fields.

   Solaris displays the CDE interface.

2. Right-click the cursor in an empty area within the desktop space.

   The **Workspace Menu** is displayed.

3. Depending on how CMS was installed, choose one of the following alternatives:

   - If the CMS `XTERM` option is displayed in the **Workspace Menu**, you can open an `xterm` window directly by selecting that option.
If the CMS XTERM option is not displayed, choose Tools > Terminal from the Workspace Menu to open a terminal window. At the command prompt, enter xterm to open an xterm window.

An xterm window is displayed with a # prompt.

Administering passwords

For system security, passwords are required for all CMS user login IDs. If a password is not entered on your first login, the system will prevent you from continuing until one is supplied.

CMS users can enter and change their passwords, but only a CMS administrator working on the Sun Microsystems, Inc. Solaris system can replace a forgotten password.

This section contains the following topics:

- Before you begin on page 616
- Changing a user's password on page 617
- Administering password aging on page 618

Before you begin

The following items should be read and understood before attempting to administer passwords:

- Password administration should only be done by an administrator with the password for the root user.

- Forcing a password change and administering the Password Aging feature can only be done through the CMS ASCII interface. The ASCII interface is available through the following methods:
  - A Terminal Emulator connection to the CMS server
  - A telnet session to the CMS server
  - Direct interaction with the CMS server

- Users should choose a password with no less than six characters. The password must have at least one character as a number or special character and have a minimum of two alphabetic characters.

- When changing a password, the new password must have at least three characters that are different from the previous password.
Changing a user's password

When a user's password expires or it is forcibly made to expire by an administrator, the user is presented with a prompt or window during the CMS login process that allows the entry of a new password. The following procedure allows an administrator to cause a user’s password to expire so that the user must enter a new password upon their next login attempt.

Steps

If a user forgets their password, perform the following procedure:

1. From the CMS Main Menu, highlight the Commands Screen-Labeled Key (SLK).
   CMS displays the Commands menu.
2. Select UNIX (r) system.
   The screen clears and a $ prompt is displayed.
3. Enter the following command:
   su
4. At the Password: prompt, enter the root password.
   The # prompt is displayed.
5. Enter the following command:
   passwd <userid>
   Where <userid> is the ID of the user who needs a new password.
   Solaris displays a prompt for the new password.
6. Enter a new password for the user.
   Solaris displays the # prompt.
7. Enter the following command:
   passwd -f <userid>
   Where <userid> is the ID of the user with a new password.
   Solaris displays the # prompt.
   The passwd -f command will force the user to change their password the next time they log in to CMS.
8. Enter the following command:
   ```
   exit
   ```
   *Solaris* displays the $ prompt.

9. Enter the following command and press the **Enter** key:
   ```
   exit
   ```
   *CMS* displays the **Main Menu**.

---

### Administering password aging

This section provides introductory and prerequisite information regarding the password aging feature of *CMS*.

Password aging is a feature that forces *CMS* users to change their password after a specified number of weeks have passed. Once this feature is activated, all users are required to change their passwords when the expiration period is reached.

**Before you begin**

⚠️ **Important:**

If you have a custom configuration from the Avaya Professional Services Organization (PSO) or use third-party applications on your *CMS* server, you must contact the PSO before enabling the password aging feature so that customizations are not affected. The PSO can be contacted through the technical support telephone number.

The following items should be read and understood before attempting to change the password aging feature:

- The number of weeks that pass before a password change is required can range from 1 to 52 weeks. The default value for this feature is 9 weeks.
- The password aging feature is only available through the `cmsadm` menu in the ASCII interface of *CMS*. This feature is not accessible through *Avaya CMS Supervisor*.

**Steps**

For more information and procedures for administering the password aging feature, see *Avaya Call Management System Software Installation, Maintenance, and Troubleshooting Guide*. 

---
Using Solaris printer commands

The Solaris commands for performing printer administration can be found in the Avaya CMS Terminals, Printers, and Modems document.

Note:

It is recommended that you use the port administration tool instead of the Solaris tools to administer terminals, printers, and modems. The port administration tool keeps a record of all administrative activity in a format that is more structured than the Solaris tools. Once you start using the port administration tool, you should consistently use it for all port administration.
Chapter 13: Using timetables and shortcuts

This section provides information on timetables and shortcuts and how to create and administer them. Timetables and shortcuts are used to run multiple administrative tasks and are only available through the CMS ASCII interface.

Access to the CMS ASCII interface can be done through the following methods:

- Terminal Emulator
- Telnet session to the CMS
- Direct interaction with the CMS server console

This section contains the following topics:

- Timetables on page 621
- Shortcuts on page 644

Timetables

A timetable is a CMS feature that enables the scheduling of one or more administrative tasks. Each timetable can consist of up to 100 tasks and can be scheduled to run at any specific time. When you are creating a timetable, CMS records the tasks you perform and includes them in the timetable. This feature is similar to macros in many PC applications that perform multiple tasks or actions when the single macro is run.

Timetables are better suited for mission-critical tasks than Supervisor scripts. This is due to the fact that scripts reside on the PC where they were created. If network difficulties occur or if the PC where the script resides is powered down, the script cannot run. Timetables run directly on the CMS server and do not suffer from such problems.

This section contains the following topics:

- Before you begin on page 622
- Permissions on page 623
- Creating and scheduling a timetable on page 623
- Adding tasks to a timetable on page 627
- Listing all timetables on page 629
Using timetables and shortcuts

- **Copying a timetable** on page 630
- **Copying timetable tasks** on page 631
- **Modifying timetable tasks** on page 633
- **Editing timetables globally** on page 635
- **Globally editing tasks in a timetable** on page 637
- **Deleting tasks from a timetable** on page 640
- **Deleting a timetable** on page 642

---

**Before you begin**

The following items should be read and understood before working with timetables:

**General**

- You cannot schedule real-time reports, Vector Contents, or custom report creation through a timetable.
- Timetables run in the background, not in the terminal session.
- Timetables that fail at some point during execution are logged in the Maintenance Error Log Report.
- Up to five timetables can be scheduled to run at the same time.
- You can have tasks associated with different ACDs in the same timetable.
- Do not create a timetable that attempts to write a file in the home directory of different user.
- The ACD that is currently selected when a timetable task is created will be the ACD on which the task runs. To change the ACD, you must delete the task and reset the current ACD before adding the correct task.
- When a CMS user is deleted, any timetables associated with that user ID are also deleted. For this reason, it is recommended that mission-critical timetables be created under the cms user ID.
- If the System Administration Terminal (SAT) terminal is still logged in to the Communication Manager system and is displaying a screen used in timetables, those timetables will not run.
- Timetables cannot run if CMS is in single-user mode.

**Printing**

- You cannot select the terminal as the destination for report output through a timetable.
Timetables

- To print a report more than once from a timetable, you must enter a task for each copy of the report.
- Print jobs from timetables go to the default printer for the user who owns the timetable unless otherwise specified when the timetable is created. If the default printer for a user is changed, there is no need to edit the timetable as CMS automatically sends the print jobs from the timetable to the new default printer.
- If a user specifies a printer other than their default printer for a timetable task and that printer is out of service, the timetable will not execute.
- If the printer jams while attempting to print timetable tasks, you must resubmit the request that did not print.

Backups

- Timetables for incremental and full backups are created when the system is installed, but are not scheduled.
- Be sure to schedule backups to run either before archiving begins or after archiving has been completed.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

- To view timetables, the user ID used to log in to this CMS session requires read permission for the Timetables feature, the requested CMS actions, and any ACD entities accessed by the timetable.
- To add, delete, or modify timetables, the user ID used to log in to this CMS session requires write permission for the Timetables feature.
- Users who are not Administrators can view and copy timetables from other users, but they cannot add, delete, or modify the timetables or the task entries.
- Users with Administrator permissions can add, delete, and modify timetables created by other users.
- If a timetable contains tasks for which the user does not have adequate permissions, the timetable will fail.

Creating and scheduling a timetable

This topic provides the procedure for creating and scheduling a timetable through the CMS ASCII interface.
Using timetables and shortcuts

Steps
To create a timetable:

1. From the **CMS Main Menu**, select the **Keep** Screen-Labeled Key (SLK).
   
   Depending on the connection method to the CMS interface, this action can be accomplished through the following methods:
   
   - For *Terminal Emulator*, select the F4 key.
   - From the CMS console, press the F4 key.
   - For a telnet session from a PC, press **Ctrl+P, 4**.

2. Select **Timetable** and press the **Enter** key.
   
   CMS displays the **Timetable** window.

3. In the **Timetable name**: field, enter a unique name for this timetable. The name of the timetable cannot be changed after it has been created. Every timetable must have a unique name.

   The following list provides the types of characters that can be entered in this field:
   
   - Alphanumeric (A-z, 0-9)
   - Underscore (_)
   - Blank ( )
   - Comma (,)
   - Period (.)
   - Single Quotation Marks (’)
   - Plus sign (+)
4. In the **Description**: field, enter a description for the timetable. This field is optional.

5. In the **User ID**: field, the user ID currently logged in is displayed. If you are an administrator and want to create this timetable for another user ID, enter that user ID in this field.

6. In the **Start time**: field, enter the time when the timetable will be executed. If you do not wish to schedule the timetable at this time, leave this field blank. This field can accept time in the following formats:
   - HH AM/PM
   - HH:MM AM/PM
   - 24-hour (00:00 - 23:59)
   If AM/PM is not specified, CMS assumes that the time entered is in the 24-hour format.

7. In the **Start date**: field, enter the date on which the timetable will begin running. Use one of the following formats for entering the date in this field:
   - MM/DD/YY - For example, 12/12/01. Do not enter four-digits years in this field.
   - Relative format - For example, entering a 1 specifies the timetable will begin one day from today (tomorrow).

  **Important:**
  If you do not wish to schedule the time table at this point, leave the **Start time**: and **Start date**: fields blank, ensure an x is in the **Once** field, and skip ahead to Step 11.

8. In the **Frequency and attributes**: group, choose from the following options:
   - **Once** - This option runs the timetable one time for the date and time specified in the **Start time**: and **Start date**: fields. This is the default value for this field group.
   - **Dates** - This option runs the timetable on specific dates. Enter the dates in the fields provided for this option.
   - **Hourly** - This option runs the timetable each hour. In the **Stop time**: field, enter the time when the timetable should stop running.
   - **Daily** - This option runs the timetable on the selected days in the **Hourly/Daily Days** group.

9. If the **Hourly** or **Daily** option was selected in the previous step, place an x next to the days in the **Hourly/Daily Days** group for which the timetable should run.

10. Place an x in one of the following options:
   - **Run only on this CMS server** - The timetable will run only on this CMS server. If this timetable is backed up and migrated to another CMS server, it will not run.
Using timetables and shortcuts

- **Run on this or another CMS server** - The timetable is capable of running on this or any other CMS server. If this timetable is backed up and migrated to another CMS server, it will function normally.

11. Press the Enter key, highlight the Add item on the action list by using the arrow keys on the keyboard, and press Enter again.

The window displays a Working message. If the timetable name is currently present, already exists displays on the status line and you must enter a different timetable name in the Timetable name: field. If all entries are valid, the Main Menu displays with Keeping Entries displayed in the border.

12. Select a task from the CMS Main Menu that will be recorded to this new timetable.

CMS displays an Entries Stored in the status line of the current window when the task is run.

To run an historical report for the system:

a. Select Reports from the Main Menu.

b. Select Historical.

c. Select System.

d. Select System.

e. Select Daily.

CMS displays the report window.

13. Enter the required information in the Split(s)/Skill(s) and Date fields.

The Date field can accept relative dates; for example, 0 represents today and -1 represents yesterday.

14. Press the Enter key to access the action list, select the menu item that performs the necessary action, and then press the Enter key again.

CMS displays a confirmation window.

It is possible to create more than one timetable task from a window. For example, suppose you want historical split/skill summary interval reports for skills 1 through 9, and you also want the same date and times for each report. To create this report, perform the following steps:

a. Go to the report window and enter the following data:
   
   - Enter 1 for the skill number.
   - Enter 0 for the date.
   - Enter 8:00-16:00 for the times.

b. Select Run on the action list. This creates a timetable task for skill 1.

c. Returning to the report input window, enter 2 for the skill number and select Run on the action list. This creates a timetable task for skill 2. Repeat the same process for skills 3 through 9.
15. Exit the window for the task and return to the **Main Menu**.

16. To add more tasks to the timetable, return to Step 12. Otherwise, open the **Keep** SLK menu and then select the **Stop** option.

   CMS displays a confirmation window asking if the timetable should be saved.

17. When CMS displays the confirmation window, press the **Y** key for **Yes** and then the **Enter** key to save the task.

   **Note:**
   To exit the timetable at any time without saving your changes, select **Stop** from the **Keep** SLK menu and then enter **n** in the confirmation window.

18. Select the **Exit** SLK to close the **Timetable** window.

---

### Adding tasks to a timetable

This topic provides the procedure for adding tasks to an existing timetable. This feature enables you to add tasks to a timetable in the same way you added tasks when you first created the timetable.

**Steps**

To add tasks to a timetable:

1. From the **CMS** **Main Menu**, select the **Keep** Screen-Labeled Key (SLK).

2. Select **Timetable** and press the **Enter** key.

   CMS displays the **Timetable** window.
3. Press Ctrl + Z.

The fields in the window are cleared of all default information.

4. In the **Timetable name** field, enter the name of the timetable to which you want to add a task.

5. Press the **Enter** key.

**CMS** shifts focus to the action list.

6. In the action list, use the arrow keys to select **Get contents** and press the **Enter** key.

**CMS** displays the **Timetable: Get Contents** window.

7. In the **Task(s):** field, enter the number of the task that you want to precede the task being added.

   If the task being added should appear as the fifth task, enter 4 in the **Task(s):** field.

   To add a task to the beginning of the timetable, leave the **Task(s):** field blank. The new task is added before the first task.

   To add tasks to a timetable with no tasks, leave the **Task(s):** field blank.

8. Press the **Enter** key.

**CMS** shifts focus to the action list.

9. Use the arrow keys to highlight the **Add tasks** item and press the **Enter** key.

   **CMS** displays the **Main Menu** and is waiting for you to perform an action that it can add as a task. The status line of the **Main Menu** displays **Keeping Entries**.

10. Perform the task that you wish to have added to timetable. For more information on the steps necessary in adding a task to a timetable, see Step 12 in **Creating and scheduling a timetable** on page 623.

    When the task is performed, **CMS** displays **Entries Stored** in the status line.

11. Exit the task window.

    **CMS** displays the **Main Menu**.

    At this point, more tasks can be added simply by performing them. These tasks will be added to the timetable in order following the previous task.

12. If you finished adding tasks to the timetable, open the **Keep** SLK menu and then select the **Stop** option.

    **CMS** displays a confirmation window asking if the timetable should be saved.
13. Press the Y key for Yes and then the Enter key.

CMS saves the timetable with the newly added tasks and displays the **Timetable: Get Contents** window.

---

**Listing all timetables**

This topic provides the procedure for listing all timetables that currently exist in the CMS database. Listing all timetables can assist in finding specific timetables when you cannot remember the entire name of a timetable. It is also useful in helping to determine if too many timetables are scheduled to run at the same time.

**Steps**

To list all timetables:

1. From the CMS Main Menu, select the Keep Screen-Labeled Key (SLK).
2. On the Keep SLK menu, select Timetable.

CMS displays the **Timetable** window.
3. Press Ctrl + Z.

CMS clears the default information from all fields in the **Timetable** window.
4. Press the Enter key.

CMS shifts focus to the action list.
5. Using the arrow keys, move the cursor to the List all menu item and press the Enter key.

CMS displays the **Timetable: List All** window listing all timetables.

![Timetable: List All window](image)

Use the right- and left-arrow keys to scroll to the other fields in this window.

The following list describes the entries that can appear in the **Status** field.

- **Finished** - This message indicates that the timetable was scheduled to run once and it completed successfully.
- **Failed** - This message indicates that the timetable failed to run successfully for the last scheduled run time.
Using timetables and shortcuts

- **Successful** - This message indicates that the timetable completed successfully.
- **Unscheduled** - This message indicates that the timetable does not have a start time or start date.
- **Running** - This message indicates that the timetable is currently running.

---

### Copying a timetable

This topic provides the procedure for copying an existing timetable to a new timetable. Although you can copy timetables from other users, you cannot copy over an existing timetable. When you copy a timetable, the scheduling information and tasks in the timetable are copied. The name of the timetable that will be copied should be known before starting this procedure.

**Steps**

To copy a timetable:

1. Select **Timetable** on the **Keep** Screen-Labeled Key (SLK) menu.
   
   CMS displays the **Timetable** window.

2. In the **Timetable name**: field, enter the name that will be used for the new timetable. The following list provides the types of characters that can be entered in this field:
   - Alphanumeric (A-z, 0-9)
   - Underscore (_)
   - Blank ( )
   - Comma (,)

---

630 CMS Administration
3. In the **User ID** field, confirm that your user ID is present.

4. Press the **Enter** key.

   CMS shifts focus to the action list.

5. Use the arrow keys to highlight the **Copy** item in the action list and press the **Enter** key.

   CMS displays the **Timetable: Copy** window.

6. In the **Copy from** field, enter the name of the timetable to copy.

7. In the **User ID** field, enter the user ID that is currently associated with the existing timetable.

8. Press the **Enter** key.

   CMS shifts focus to the action list of the **Timetable: Copy** window.

9. Press the **Enter** key again.

   CMS displays **Successful** in the status bar.

   If this new timetable is not scheduled to run, CMS displays a message notifying you that this copy needs to be rescheduled.

10. Select the **Exit SLK** to close the **Timetable** window.

### Copying timetable tasks

This topic provides the procedure for duplicating tasks within a timetable.

**Before you begin**

The following items should be read and understood before copying timetable tasks:

- Only the owner of the timetable or an administrator can copy timetable tasks.

- You cannot copy a task more than once using the **Copy** command in the **Get Contents** window. You must reuse the **Copy** command to make additional copies of a task.

- You cannot copy more than 100 tasks into a timetable. If you exceed the limit, none of the tasks are copied. The status line will display a **Failed** message when this occurs.
Using timetables and shortcuts

- Copies of tasks can be placed after a specified task in the timetable, or each copy can be placed directly after the task from which it was copied. The default is to place the copies after the last task in the timetable.

Steps

To copy a timetable task:

1. From the **CMS Main Menu**, select the **Keep Screen-Labeled Key (SLK)**.
2. Select **Timetable** and press the **Enter** key.
   
   **CMS** displays the **Timetable** window.

3. Press **Ctrl + Z**.
   
   The fields in the window are cleared of all default information.

4. In the **Timetable name:** field, enter the name of the timetable containing the task to copy.

5. In the **User ID:** field, enter the user ID that created the timetable.
   
   If you are not the owner or an administrator, you will not be able to copy tasks in the timetable.

6. Press the **Enter** key.
   
   **CMS** shifts focus to the action list.
7. Use the arrow keys to highlight the **Get contents** menu item and press the **Enter** key. 

**CMS** displays the **Timetable: Get Contents** window.

![Timetable: Get Contents](image)

8. In the **Task(s):** field, enter the task number to copy and press the **Enter** key. 

**CMS** shifts focus to the action list of the **Timetable: Get Contents** window.

9. Using the arrow keys, highlight the **Copy** menu item, and press the **Enter** key. 

**CMS** displays the **Timetable: Get Contents: Copy** window.

![Timetable: Get Contents: Copy](image)

10. Choose one of the following options by placing an x next to it:

   - **Add following task** - The copied task will be placed immediately after the task specified in this field.
   
   - **Add each task after the task from which it was copied** - The copied task is placed immediately after itself.

   The default action is to place the copied task at the end of the list.

11. Press the **Enter** key. 

   **CMS** shifts focus to the action list.

12. Press the **Enter** key again.

   **CMS** displays **Working** in the status line. When the operation completes, the status line displays **Successful**. **CMS** closes the **Copy** window and displays the **Get Contents** window.

   If the operation fails, a message window appears stating the reason for the failure.

13. To close the **Get Contents** window, select the **Exit SLK**.

---

**Modifying timetable tasks**

This topic provides the procedure for modifying tasks within a timetable. The **Modify** feature allows you to modify the action or data associated with any task within the selected timetable.
Before you begin

The following items should be read and understood before modifying timetable tasks:

- Only the owner or an administrator can modify timetable tasks.
- The Current and Main Menu Screen-Labeled Keys (SLKs) are blocked while modifying tasks.
- If you press the Exit SLK without selecting a task action, a popup window is displayed stating that the task modification has been cancelled.
- To exit the timetable without saving any changes, select the Stop item from the Keep SLK menu.

Steps

To change a timetable task:

1. From the CMS Main Menu, select the Keep Screen-Labeled Key (SLK).
2. Select Timetable and press the Enter key.
   CMS displays the Timetable window.

3. Press Ctrl + Z.
   The fields in the window are cleared of all default information.
4. In the Timetable name: field, enter the name of the timetable containing the task to modify.
5. In the User ID: field, enter the user ID that created the timetable.
   If you are not the owner or an administrator, you will not be able to modify tasks in the timetable.
6. Press the **Enter** key.
   
   *CMS* shifts focus to the action list.

7. Use the arrow keys to highlight the **Get contents** menu item and press the **Enter** key.
   
   *CMS* displays the **Timetable: Get Contents** window.

8. In the **Task(s):** field, enter the number of the task to modify and press the **Enter** key.
   
   *CMS* shifts focus to the action list of the **Get Contents** window.

9. Using the arrow keys, highlight the **Modify** menu item and press the **Enter** key.
   
   *CMS* displays a window for the specified task.

   Example:

10. Make any necessary changes to the task.

11. When the changes have been made, press the **Enter** key.

   *CMS* shifts focus to the action list.

12. Using the arrow keys, highlight the appropriate action to perform in the action list and press the **Enter** key.

   *CMS* displays a confirmation window asking if changes should be saved.

13. To save the changes made to the task, press the **Y** key for ‘Yes’ and then press the **Enter** key.

   *CMS* saves the task changes to the timetable and displays the **Get Contents** window.

14. To exit the **Get Contents** window, select the **Exit** SLK.

---

**Editing timetables globally**

Globally editing timetables changes the server compatibility for all timetables associated with a user ID.
Using timetables and shortcuts

Server compatibility of timetables can be one of the two following states:

- **Run only on this CMS server** - The timetable will run only on this CMS server. If this timetable is backed up and migrated to another CMS server, it will not run.

- **Run on this or another CMS server** - The timetable is capable of running on this or any other CMS server. If this timetable is backed up and migrated to another CMS server, it will function normally.

**Before you begin**

The following items should be read and understood before making global edits to timetable tasks:

- Only the owner of the timetable or an administrator can globally edit a timetable.
- If an error is made during a global edit, CMS displays an error message describing the nature of the problem. All errors must be corrected before CMS allows you to complete the modifications.

**Steps**

To edit a timetable globally:

1. From the **CMS Main Menu**, select the **Keep Screen-Labeled Key (SLK)**.
2. Select **Timetable** and press the **Enter** key.
   
   CMS displays the **Timetable** window.

3. Press **Ctrl + Z**.
   
   The fields in the window are cleared of all default information.

4. In the **Timetable name**: field, enter the name of the timetable containing the tasks to modify globally.
5. Press the **Enter** key.
   CMS shifts focus to the action list.

6. Using the arrow keys, highlight **Find one** and press the **Enter** key.
   CMS locates the timetable and populates the remaining fields with the information from the timetable.

7. Press the **Enter** key.
   CMS shifts focus to the action list.

8. Using the arrow keys, highlight **Global edit** and press the **Enter** key.
   CMS displays the Timetable: Global Edit window.

9. Select one of the following options by placing an x in the associated field:
   - **Run timetables only on this CMS server** - All timetables owned by the specified user ID will be modified so that they can only run on this CMS server. Timetables migrated to another server will not function.
   - **Run timetables on this or another CMS server** - All timetables owned by the specified user ID will be modified so that they can run on the current CMS server or, if migrated, a different CMS server.

10. Press the **Enter** key.
    CMS shifts focus to the action list and highlights the **Modify** action.

11. Press the **Enter** key again.
    CMS will display a message in the status line of this window indicating how many timetables were updated.

12. Use the **Exit SLK** to close this window and return to the Timetable window.
    The timetable displayed in the Timetable window does not update automatically. Use the **Find one** action to re-query for this table in order to show the current configuration.

---

**Globally editing tasks in a timetable**

This topic provides the procedure for changing multiple tasks in a timetable to use a common date, time, or printer destination. For example, you may want to run all reports within a timetable so that instead of reporting on data for today (relative date: 0), the reports will use data from yesterday (relative date: -1). Using the global edit feature can change the dates used for these reports in a simple series of steps instead of modifying...
Using timetables and shortcuts

each task separately. This feature can also be used to modify tasks that have different values for times, dates, or printer destinations so that all specified tasks use consistent values.

Before you begin

The following items should be read and understood before making global edits to timetable tasks:

- Only the owner of the timetable or an administrator can globally edit a timetable.
- If an error is made during a global edit, CMS displays an error message describing the nature of the problem. All errors must be corrected before CMS allows you to complete the modifications.

Steps

To edit multiple tasks within a timetable:

1. From the CMS Main Menu, select the Keep Screen-Labeled Key (SLK).
2. Select Timetable and press the Enter key.

   CMS displays the Timetable window.

3. Press Ctrl + Z.

   The fields in the window are cleared of all default information.

4. In the Timetable name: field, enter the name of the timetable containing the tasks to modify globally.

5. Press the Enter key.

   CMS shifts focus to the action list.
6. Using the arrow keys, highlight **Find one** and press the **Enter** key. 

**CMS** locates the timetable and populates the remaining fields with the information from the timetable.

7. Press the **Enter** key. 

**CMS** shifts focus to the action list.

8. Using the arrow keys, highlight **Get contents** and press the **Enter** key. 

**CMS** displays the **Timetable: Get Contents** window.

9. In the **Task(s):** field, enter the tasks to modify using the following methods:

- **Range** - For example, `1-50`
- **Separate values** - For example, `1;3;6;7`
- **Combination** - For example, `1;3-7;10`

10. After the tasks to globally edit have been specified, press the **Enter** key. 

**CMS** shifts focus to the action list.

11. Using the arrow keys, highlight **Global edit** and press the **Enter** key. 

**CMS** displays the **Timetable: Get contents: Global edit** window.

12. Place an `x` in the field that will be changed for all specified tasks.

13. In the field to the right of the selected option, enter one or more values as necessary. 

To have multiple reports retrieve contact center data that occurred at 2:00 PM, place an `x` in the **Times** option and enter `2:00 PM` or `14:00` in the associated field to the right.

For the **Date/Dates** option, enter dates in either MM/DD/YY format or the relative format based on today (0 for today, -1 for yesterday). You can separate individual data entry items with semicolons (;) and value ranges with hyphens (-) between entries.

14. Press the **Enter** key. 

**CMS** shifts focus to the action list.
15. Using the arrow keys, highlight **Confirm** and press the **Enter** key.

   *CMS displays the **Timetable: Get Contents: Global Edit: Confirm** window.*

   ![Timetable: Get Contents: Global Edit: Confirm](image)

   This window is used to confirm the tasks that will be modified. No changes have been made at this point. If some specified tasks do not appear in the confirmation window, it is because those tasks do not use the data specified when they are run. For example, some reports only use a date value to retrieve information; therefore, changing the time value will not modify this task. If the tasks listed in this window are not correct, you can go back to the previous windows and make adjustments as necessary.

16. Select the **Exit** SLK.

   *CMS closes the **Timetable: Get Contents: Global Edit: Confirm** window.*

17. If you are satisfied with the changes, press the **Enter** key.

   *CMS shifts focus to the action list.*

18. Using the arrow keys, highlight **Modify** and press the **Enter** key.

   *CMS modifies the tasks in this timetable with the data values specified, closes the **Timetable: Get Contents: Global Edit** window, and displays **Successful** in the status line when the operation is complete.*

19. Close the **Timetable: Get Contents** by selecting the **Exit** SLK.

---

### Deleting tasks from a timetable

This topic provides the procedure for deleting individual tasks from a timetable.

**Before you begin**

The following items should be read and understood before deleting tasks from a timetable:

- Only the owner of the timetable or an administrator can delete tasks from a timetable.
- To exit the timetable without saving any changes, select the **Stop** item from the **Keep** SLK menu.
Steps

To delete a task from a timetable:

1. From the **CMS Main Menu**, select the **Keep** Screen-Labeled Key (SLK).
2. Select **Timetable** and press the **Enter** key.

   **CMS** displays the **Timetable** window.

3. Press **Ctrl + Z**.

   The fields in the window are cleared of all default information.

4. In the **Timetable name**: field, enter the name of the timetable containing the tasks to modify globally.

5. Press the **Enter** key.

   **CMS** shifts focus to the action list.

6. Using the arrow keys, highlight **Find one** and press the **Enter** key.

   **CMS** locates the timetable and populates the remaining fields with the information from the timetable.

7. Press the **Enter** key.

   **CMS** shifts focus to the action list.
8. Using the arrow keys, highlight **Get contents** and press the **Enter** key.

   **CMS** displays the **Timetable: Get Contents** window.

   ![Timetable: Get Contents](image)

9. In the **Task(s):** field, enter the number of the task to delete.

10. Press the **Enter** key.

   **CMS** shifts focus to the action list.

11. Using the arrow keys, highlight **Delete** and press the **Enter** key.

   **CMS** displays a confirmation window.

12. Press the **Y** key for 'Yes' and then the **Enter** key to save the changes.

   **CMS** deletes the task from the timetable, the tasks are renumbered, the timetable is saved, and the status line displays a **Successful** message.

13. Select the **Exit SLK** to close the **Timetable: Get Contents** window.

---

**Deleting a timetable**

This topic provides the procedure for deleting a timetable.

**Before you begin**

Only the owner of the timetable or an administrator can delete timetables.

**Steps**

To delete a timetable:

1. From the **CMS Main Menu**, select the **Keep** Screen-Labeled Key (SLK).
2. Select **Timetable** and press the **Enter** key.

   CMS displays the **Timetable** window.

3. Press **Ctrl + Z**.

   The fields in the window are cleared of all default information.

4. In the **Timetable name:** field, enter the name of the timetable containing the tasks to modify globally.

5. Press the **Enter** key.

   CMS shifts focus to the action list.

6. Using the arrow keys, highlight **Find one** and press the **Enter** key.

   CMS locates the timetable and populates the remaining fields with the information from the timetable.

7. Press the **Enter** key.

   CMS shifts focus to the action list.

8. Using the arrow keys, highlight **Delete** and press the **Enter** key.

   CMS displays a confirmation window.

9. Press the **Y** key for ‘Yes’ and then the **Enter** key.

   CMS deletes the timetable and a successful message is displayed in the status line.
Shortcuts

A shortcut is similar to a timetable except that it is not run based on time but rather when it is executed by a user. A shortcut is a fast and easy way for an ASCII terminal user to select windows that are used often. For example, you can create a shortcut for two different real-time reports that you normally view throughout the day. The shortcut displays these reports, fills out the input windows, and places them on the terminal screen so that they can both be viewed at once. Although useful for other tasks, shortcuts are most commonly used to run real-time reports.

This section contains the following topics:

- Before you begin on page 644
- Permissions on page 645
- Creating a shortcut on page 645
- Adding tasks to a shortcut on page 647
- Running a shortcut on page 648
- Modifying a shortcut description on page 649
- Copying a shortcut on page 650
- Copying shortcut tasks on page 651
- Modifying shortcut tasks on page 653
- Deleting shortcut tasks on page 654
- Deleting a shortcut on page 655

Before you begin

The following items should be read and understood before working with shortcuts:

- Shortcuts are only available through the ASCII interface to CMS.
- Each user can create a maximum of ten shortcuts.
- Once a shortcut has started running, it cannot be stopped.
- Shortcuts can be copied from those created by other users.
- You cannot exceed your maximum allowable window count by using a shortcut.
- You cannot create a custom report using a shortcut.
- When using the Keep mode to record the tasks for a shortcut, the Current Screen-Labeled Key (SLK) will only shift focus between windows in the shortcut window. It will not shift focus to windows that were open before you entered Keep mode.
● When you create a shortcut, tasks that have errors in them are saved, but they will not execute when the shortcut is run. The task containing the error will display an error message which causes the shortcut to stop. The error must be corrected before the shortcut can run properly. To delete the error, exit the shortcut without saving changes or edit the shortcut if the error has already been saved.

● Deleting a CMS user who owns shortcuts results in those shortcuts also being deleted.

Permissions

Depending on the procedure that you want to perform, you need the following permissions:

● All users are allowed to create shortcuts.

● You must have read and write permissions for any CMS subsystems and ACD entities associated with the tasks included in a shortcut.

● Users without the Administrator permission can view and copy the shortcuts of other users, but they cannot add, modify, or delete those shortcuts.

● If the access permissions for a user are changed, it could cause the shortcuts of that user to not run properly. For example, removing skill permissions for a user can result in a shortcut report not running or displaying data for that skill.

Creating a shortcut

This topic provides the procedure for creating a shortcut and adding tasks for it to perform.

Steps
To create a shortcut:

1. From the CMS Main Menu, select the Keep Screen-Labeled Key (SLK).
2. Select **Shortcut** and press the **Enter** key.

   *CMS displays the **Shortcut** window.*

![Shortcut window](image)

   The **User ID:** field shows the ID of the user who ran this command. Unless you have **Administrator** permissions, you will not be able to create a shortcut for another user.

3. In the **Shortcut name:** field, enter a unique name for this shortcut.

   Keep the name for the shortcut simple as it becomes the name that must be entered when you wish to execute it from the **CMS Main Menu**.

4. In the **Description:** field, enter a brief description for the shortcut.

   This field is optional.

5. Press the **Enter** key.

   *CMS shifts focus to the action list.*

6. Highlight the **Add** item and press the **Enter** key.

   *CMS displays the **Main Menu**. CMS is now in **Keep** mode.*

7. Use the **Main Menu** to select tasks. Multiple windows can be shown on the screen at one time.

8. Use the **Move** and **Size** items from the **Window SLK** menu to adjust the placement and dimensions of each window.

9. When satisfied with the report windows, input windows, and their placement and sizes on the screen, select the **Stop** item from the **Keep SLK** menu.

   *CMS displays a confirmation window asking if the shortcut should be saved.*

10. Press the **Y** key for ‘Yes’ and then **Enter** to save the shortcut.

    *CMS displays the **Shortcut** window again and the status line displays a **Successful** message indicated that the shortcut was saved.*

11. Select the **Exit SLK** to close the **Shortcut** window and return to the **Main Menu**.
Adding tasks to a shortcut

This topic provides the procedure for adding tasks to an existing shortcut.

Steps

To add tasks to a shortcut:

1. From the CMS Main Menu, select the Keep Screen-Labeled Key (SLK).
2. Select Shortcut and press the Enter key.

   CMS displays the Shortcut window.

3. In the Shortcut name: field, enter the name of the shortcut which will have new tasks added.
4. Press the Enter key.

   CMS shifts focus to the action list.
5. Highlight Get contents and press the Enter key.

   CMS displays the Shortcut: Get Contents window.

6. In the Task(s): field, enter the number of the task that the new task will follow.
   To add a task in the second position of the shortcut, enter 1 in the Task(s): field.
   If you wish the new task to be in the first position, leave the Task(s): field blank.
Using timetables and shortcuts

7. Press the **Enter** key.

   CMS shifts focus to the action list.

8. Highlight **Add tasks** and press the **Enter** key.

   CMS displays the **Main Menu**.

9. On the **Main Menu**, use the normal menu items to perform the tasks you want to add to the shortcut.

   When you have made and validated each action list selection, **Entries Stored** displays on the status line.

10. When you have finished performing tasks for the shortcut, select **Stop** from the **Keep SLK** menu.

    CMS displays a confirmation asking if the changes should be saved.

11. Press the **Y** key for ‘Yes’ and then the **Enter** key.

    CMS saves the tasks and displays the **Shortcut: Get Contents** window.

12. Select the **Exit SLK** to close the **Shortcut: Get Contents** window.

### Running a shortcut

This topic provides the procedure for executing a shortcut.

**Steps**

To run a shortcut:

1. At the **CMS Main Menu**, press the ; (semicolon) key.

   CMS selects the command line of the **Main Menu**.
2. Enter the name of the shortcut to run and press the Enter key.

   The shortcut starts running and locks the keyboard until the shortcut finishes. When
   the shortcut finishes, the status line displays a Successful message.

---

**Modifying a shortcut description**

This topic provides the procedure for editing the name or description of a shortcut.

**Steps**

To edit a shortcut:

1. From the CMS Main Menu, select the Keep Screen-Labeled Key (SLK).
2. Select Shortcut and press the Enter key.
   
   CMS displays the Shortcut window.

3. In the Shortcut name: field, enter the name of the shortcut to modify.
4. Press the Enter key.
   
   CMS shifts focus to the action list.
5. Highlight Find one and press the Enter key.
   
   CMS retrieves the shortcut and populates the Description: and User ID: fields with
   information from the shortcut.
6. Make the necessary change to the Description: field.
7. Press the Enter key.
   
   CMS shifts focus to the action list.
8. Highlight Modify and press the Enter key.
   
   CMS saves the changes to the shortcut displays a Successful message in the status
   line.
9. Select the Exit SLK to close the Shortcut window.
Copying a shortcut

This topic provides the procedure for copying an existing shortcut into a new shortcut. All users can copy shortcuts owned by other users. However, no shortcuts owned by your user ID, even as an Administrator, can be copied by you to another user. It is not possible to copy a shortcut over an existing shortcut.

Steps

To copy a shortcut:

1. From the CMS Main Menu, select the Keep Screen-Labeled Key (SLK).
2. Select Shortcut and press the Enter key.
   CMS displays the Shortcut window.

3. In the Shortcut name: field, enter the name of the new shortcut that will be created.
4. In the Description: field, enter a brief phrase identifying the new shortcut.
   This field is optional.
5. In the User ID: field, ensure your user ID is present.
6. Press the Enter key.
   CMS shifts focus to the action list.
7. Highlight Copy and press the Enter key.
   CMS displays the Shortcut: Copy window.

8. In the Copy from: field, enter the name of the shortcut to copy as the new shortcut.
9. In the User ID: field, enter the ID of the user that owns the shortcut to copy.
10. Press the Enter key.
   CMS shifts focus to the action list.
11. Press the Enter key again.
   CMS creates the new shortcut, closes the Shortcut: Copy window, and displays a Successful message in the status line.
12. Select the Exit SLK to close the Shortcut window.

---

**Copying shortcut tasks**

This topic provides the procedure for copying tasks within a shortcut.

**Steps**

To copy a shortcut task:

1. From the CMS Main Menu, select the Keep Screen-Labeled Key (SLK).
2. Select Shortcut and press the Enter key.
   CMS displays the Shortcut window.

   ![Shortcut window](image)

3. In the Shortcut name: field, enter the name of the shortcut in which a task will be copied.
4. Press the Enter key.
   CMS shifts focus to the action list.
5. Highlight **Get contents** and press the **Enter** key.

   *CMS* displays the **Shortcut: Get contents** window.

   ![Shortcut: Get Contents](image)

6. In the **Task(s):** field, enter the number of the task to copy and press the **Enter** key.

   *CMS* shifts focus to the action list.

7. Highlight **Copy** and press the **Enter** key.

   *CMS* displays the **Shortcut: Get Contents: Copy** window.

   ![Shortcut: Get Contents: Copy](image)

8. Place an **x** in one of the following options:

   - **Add following task** - This option will create the task after the task number specified in the field to the right.

   - **Add each task after the task from which it was copied** - This option will create the task and place it immediately following the original task. If you specified to make a copy of task #1, the copy will be created as task #2. Any other tasks are shifted to a higher number to accommodate this action.

9. Press the **Enter** key.

   *CMS* shifts focus to the action list.

10. Press the **Enter** key again.

    *CMS* copies the original task, creates the new task, closes the **Shortcut: Get Contents: Copy** window, and displays a **Successful** message in the status line.

    If any sort of error occurs, the status line will display **Failed** and *CMS* displays an error message describing the nature of the error.

11. Select the **Exit SLK** to close the **Shortcut: Get Contents** window.
Modifying shortcut tasks

This topic provides the procedure for editing tasks within a shortcut.

Steps

To modify a shortcut task:

1. From the **CMS Main Menu**, select the **Keep Screen-Labeled Key (SLK)**.
2. Select **Shortcut** and press the **Enter** key.
   
   **CMS** displays the **Shortcut window**.

3. In the **Shortcut name:** field, enter the name of the shortcut where tasks will be modified.
4. Press the **Enter** key.
   
   **CMS** shifts focus to the action list.
5. Highlight **Get contents** and press the **Enter** key.
   
   **CMS** displays the **Shortcut: Get Contents window**.

6. In the **Task(s):** field, enter the number of the task to modify and press the **Enter** key.
   
   **CMS** shifts focus to the action list.
7. Highlight **Modify** and press the **Enter** key.
   
   **CMS** displays the input window of the specified task.

8. Change the input parameters of the window as necessary. For example, this might include changing the split, agent, or another entity on which a report is based. This can also include making changes to the size and position of the task window.

9. When the appropriate information has been entered, press the **Enter** key.
   
   **CMS** shifts focus to the action list.

10. Highlight **Modify** and press the **Enter** key.
    
    **CMS** displays a confirmation asking if the changes should be saved.

11. Press the **Y** key for ‘Yes’ and then the **Enter** key.
    
    **CMS** saves the changes to the task, closes the task window, and displays a **Successful** message in the status line.

12. Select the **Exit** SLK to close the **Shortcut: Get Contents** window.

---

**Deleting shortcut tasks**

This topic provides the procedure for deleting a task from a shortcut.

**Steps**

To delete a shortcut task:

1. From the **CMS Main Menu**, select the **Keep Screen-Labeled Key (SLK)**.

2. Select **Shortcut** and press the **Enter** key.

   **CMS** displays the **Shortcut** window.

3. In the **Shortcut name**: field, enter the name of the shortcut containing the task to delete.
4. Press the Enter key.

   CMS shifts focus to the action list.

5. Highlight Get contents and press the Enter key.

   CMS displays the Shortcut: Get Contents window.

6. In the Task(s): field, enter the number of the task to delete.

7. Press the Enter key.

   CMS shifts focus to the action list.

8. Highlight Delete and press the Enter key.

   CMS displays a confirmation window asking if the changes to the shortcut should be saved.

9. Press the Y key for ‘Yes’ and then the Enter key.

   CMS deletes the specified tasks and displays the Shortcut: Get Contents window.

10. Select the Exit SLK to close the Shortcut: Get Contents window.

---

**Deleting a shortcut**

This topic provides the procedure for deleting a shortcut from the CMS server.

**Steps**

To delete a shortcut:

1. From the CMS Main Menu, select the Keep Screen-Labeled Key (SLK).
Using timetables and shortcuts

2. Select **Shortcut** and press the **Enter** key.

   *CMS* displays the **Shortcut** window.

   ![Shortcut Window]

3. In the **Shortcut name**: field, enter the name of the shortcut to delete.

   Shortcuts owned by other users cannot be deleted.

4. Press the **Enter** key.

   *CMS* shifts focus to the action list.

5. Highlight **Find one** and press the **Enter** key.

   *CMS* retrieves the information for the specified shortcut. If the shortcut with the name specified cannot be found, this will be indicated on the status line.

6. Verify that this is the shortcut to be deleted and press the **Enter** key.

   *CMS* shifts focus to the action list.

7. Highlight **Delete** and press the **Enter** key.

   *CMS* displays a confirmation window.

8. Press the **Y** key for ‘Yes’ and then the **Enter** key.

   *CMS* deletes the specified shortcut and displays a **Successful** message in the status line.
Glossary

abandoned call  A call on which a caller hangs up before an agent answers.

abandoned call search  An ACD capability that enables the system to verify that the caller is still on the line before passing the call to an agent.

acceptable service level  1) A target value for the acceptable amount of time before an agent answers a call.
                        2) A percentage of calls answered within a set amount of time (for example, 80% of calls answered within 20 seconds).

access permissions  Permissions assigned to a CMS user so that the user can access different CMS capabilities or administer specific elements such as splits/skills, trunks, or vectors. Access permissions can be read, write, or exceptions. See also read permission, write permission.

ACD  See Automatic Call Distribution (ACD)

ACD call  1) A call that queues to a split/skill and is answered by an agent in that split/skill.
           2) A call that queues as a direct agent call and is answered by the agent for whom it was queued.

Action List  A menu in the upper right-hand corner of most CMS ASCII screens. The menu lists the actions available for that particular window.

active VDN calls  A Call Vectoring feature on Communication Manager systems that provides conditional branching to a different step in the same vector or to a different vector, based on the number of incoming trunk calls a VDN is processing in a vector or at an agent position. Also called counted calls to VDN.

ACW  See after call work (ACW)

Adjunct/Switch Applications Interface (ASAI)  A recommendation for interfacing adjuncts and communications systems that is based on the CCITT Q.932 specification for layer 3. ASAI supports activities such as event notification and call control.
**after call work (ACW)**

An agent state consisting of work related to the preceding ACD call. If an agent hangs up after an ACD call, the agent is in ACW. ACW is also accessible by a button on the agent's set and does not have to be related to an ACD call.

**agent**

A person or VRU port that answers calls to an ACD split/skill. The agent is represented to CMS by a login identification keyed into a voice terminal.

**agent login ID**

A 1- to 9-digit number keyed by an ACD agent from a voice terminal to activate the agent position. Agent logins are needed for all CMS-measured ACD agents.

**agent occupancy**

The percentage of time that you expect or target for each split/skill agent to spend on ACD calls and in ACD while logged in.

**agent position (EAS)**

The combination of the agent login ID and the skills the agent is assigned. Data is collected for the agent by skill so that the total work for the agent is the sum of all skills in which the agent worked.

**agent position (non-EAS)**

The combination of the agent login ID and the split the agent logged into. Agents logged into multiple splits are associated with multiple positions. Call data is collected separately for each agent/split combination.

**agent role**

A description of the kind of service an agent in multiple skills give for one of these skills. Agent role is a combination of call-handling preference and skill/reserve levels.

**agent skill**

An attribute that is associated with an ACD agent and that qualifies the agent to handle calls requiring the attribute. An agent can be assigned up to 60 skills; for example, the ability to speak a particular language or the expertise to handle a certain product.

See also **primary skill**, **secondary skill**, and **skill level**

**agent state**

A feature of agent call handling that allows agents to change their availability to the switch; for example, ACW, AVAIL, AUX.

**agent terminal**

The voice terminal used by a contact center agent.

**agent trace**

A CMS capability that allows you to trace agent activities such as state changes which can then be shown in a report.

**AI**

See **Auto-in (AI)**.

**ANI**

See **Automatic Number Identification (ANI)**.
**announcement**  
A recorded voice message that typically identifies the call’s destination, asks the caller to stay on the line, and describes the product or service offered. With the Call Vectoring feature, announcements can be part of a vector’s call processing.

**ASA**  
See [Average Speed of Answer (ASA)](#).

**ASAI**  
See [Adjunct/Switch Applications Interface (ASAI)](#).

**auto-available split**  
An ACD capability that enables VRUs such as the CONVERSANT® Voice Information System to be brought online again immediately after a power failure or system restart without time-consuming reprogramming.

**Auto-in (AI)**  
An ACD work mode that makes the agent available to receive calls and allows the agent to receive a new ACD call immediately after disconnecting from the previous call.

**Automatic Call Distribution (ACD)**  
1) A switch feature that channels high-volume incoming and outgoing call traffic to agent groups (splits or skills).  
2) An agent state in which the extension is engaged on an ACD call.

**Automatic Number Identification (ANI)**  
An industry term for notification of the calling party number (CPN). When the calling party is connected through a switch, the CPN can be either a billing number for the switch or the station identification (SID) number.

**AUX**  
See [auxiliary work (AUX)](#).

**AUX reason codes**  
Codes that enable a contact center to track an agent’s time more precisely when the agent is in the AUX state. Agents can specify why they are in the AUX state - for example, on break or in a meeting.

**auxiliary work (AUX)**  
An agent state in which the agent is doing non-ACD work, is on break, or is in a meeting. Agent enter AUX work by pressing the AUX WORK button or dialing the access code from their voice terminal. Agents can also enter AUX work by going off-hook to make or answer an extension call while in AVAIL mode or with a call on hold.

**AVAIL**  
See [available (AVAIL)](#).

**available (AVAIL)**  
An agent work mode in which the extension can accept an ACD call. The agent enters this state by selecting the AI (auto-in) or MI (manual-in) work mode.
average agent service time

The average time you are expecting or targeting each agent to spend on an ACD call including talk time and ACW time.

Avaya Business Advocate

A set of features designed to enhance call and agent selection in a contact center.

Avaya Interactive Response

A powerful voice-response system that may include automated call routing, announcement storage, message retrieval, and callback. Used to be called CONVERSANT.

Average Speed of Answer (ASA)

The average time a caller waits in queue before connecting to an agent. The ASA for a split/skill includes the time spent in queue and the time ringing an agent. The ASA for a VDN includes the time spent in vector processing including the time spent in queue and the time ringing for the VDN that the call was answered in.

backup

The process of protecting data by writing the contents of the disk to an archive, such as tape, that can be removed from the computer environment and stored safely.

calculation

A formula for representing contact center entities in the Dictionary. Calculations generate the date for fields in a report.

call-based items

The category of database items in CMS that are entered in the database after a call completes. If a call starts and ends in different intrahour intervals, the call-based data is recorded for the interval in which the call completed. Most database items are call-based.

call-handling performance

A parameter of agent administration in an EAS environment that specifies how calls are selected for the agent.

call-handling profile

A set of objectives describing how a split/skill handles calls. Call-handling profiles are part of the Avaya CMS Forecast product.

Call Prompting

A switch feature that routes incoming calls based on information supplied by the caller such as an account number. The caller hears an announcement and is prompted to select an option from those listed in the announcement.

Call Vectoring

A switch feature that provides a highly flexible method for processing ACD calls using VDNs and vectors as processing points between trunk groups and splits. Call Vectoring permits a treatment of calls that is independent of splits.

Call Work Code (CWC)

An ACD capability that allows the agent to enter a string of digits during or after the call and send them to CMS for management reporting.
calls carried  The number of inbound/outbound calls carried by a trunk.

change agent skills  A CMS capability that allows you to change a single agent’s skill assignment or apply an agent template to multiple agents.

Call Management System (CMS)  A software product used to connect to a switch that monitors and records data for large volumes of telephone calls that are processed through the ACD feature of the switch.

CMSADM backup  A backup that saves all the file systems on the CMS server including the Solaris operating system, CMS programs, CMS data, and non-CMS data.

CONN  See connected (CONN).

connected (CONN)  A trunk state in which a caller and an agent are connected on an ACD call.

connected call  A non-ACD call connected to an agent through a VDN and for which CMS receives an indication that the call rang or was answered.

CONVERSANT  See Avaya Interactive Response.

current  A CMS operation that displays data from the current interval.

current interval  The current intrahour period of time (15, 30, or 60 minutes) which is archived to the historical database when the period expires. The current interval is part of the real-time database.

current wait time  The time a call has waited for service in a call queue adjusted for queue priority.

custom report  A real-time or historical report that has been customized from standard reports or created by the user through the Custom Reports subsystem of CMS.

CWC  See Call Work Code (CWC).

DABN  See dequeued and abandoned (DABN).

DACD  See direct agent ACD (DACD).

DACW  See direct agent ACW (DACW).

daily data  Interval data that has been converted to a 1-day summary.
data collection

This CMS feature can be used to determine if call activity and the associated ACD data is recorded. In many maintenance operations, it is necessary to disable data collection. If data collection is turned off, CMS does not void data on current call activity.

database

The CMS databases are used to store ACD data according to a specific time period. This can be current and previous intrahour real-time data or intrahour, daily, weekly, and monthly historical data.

database item

A name for a specific type of data stored in one of the CMS databases. A database item can store ACD identifiers such as split numbers or names, login IDs, and VDNs or statistical data on ACD performance such as number of ACD calls, wait time for calls in queue, current states of individual agents, and so forth.

database tables

Each CMS database can consist of several database tables which are used to logically separate data based on different criteria. For example, historical reports can be used to display data on a daily, weekly, or monthly basis; each of these different time measurements are stored in separate database tables.

DDC

See direct department calling (DDC).

dequeued and abandoned (DABN)

A trunk state in which the trunk quickly goes idle after the caller abandons the call.

designer reports

Customized reports that you create and run through Avaya CMS Supervisor Report Designer. See the Avaya CMS Supervisor Report Designer User Guide for more information.

Dictionary

A CMS capability used to assign easily-interpreted names to contact center entities such as login IDs, splits/skills, trunk groups, VDNs, and vectors.

DID

See direct inward dialing (DID).

Digital Subscriber Line (DSL)

A public switched telephone network (PSTN) line that provides high bandwidth for short distances using copper cable. This type of line operates at the Basic Rate Interface (BRI) with two 64-kilobit per second circuit-switched channels and one 16-kilobit packet-switched channel. DSL can carry both data and voice signals at the same time.

direct agent ACD (DACD)

An agent state in which the agent is on a direct agent ACD call.

direct agent ACW (DACW)

An agent state in which the agent is in the after call work (ACW) state for a direct agent ACD call.
direct agent calling
An EAS capability that allows a caller to reach the same agent every time and allows the contact center to include the call as an ACD call in management tracking. This is ideal for claims processing in which a client needs to speak with the agent handling the claim. It also ensures a high level of customer service without reducing management control.

direct department calling (DDC)
A non-EAS option to select an agent when more than one agent is available. The call goes to the agent closest to the top of an ordered list.

direct inward dialing (DID)
The use of an incoming trunk used for dialing directly from the public network into a communications system without help from the attendant.

DSL
See Digital Subscriber Line (DSL).

EAS
See Expert Agent Selection (EAS).

entity
A generic term for an agent, split/skill, trunk, trunk group, VDN, or vector.

EWT
See expected wait time (EWT).

exception
Activity in an ACD which falls outside the limits you have defined and usually indicates abnormal or unacceptable performance of the ACD, agents, splits/skills, VDNs, vectors, trunks, or trunk groups. The parameters used to determine the occurrence of an exception are defined in the Exceptions subsystem of CMS.

exception permissions
The rights that a user has in being notified or viewing the instances where calls, contact center entities, or subsystems operated above or below specified thresholds.

expected wait time (EWT)
An estimate of how long a caller will have to wait to be served by a contact center while in queue. EWT is based on current and past traffic, handling time, and staffing conditions. Time spent in vector processing before being queued and time spent ringing an agent with manual answering is not included in the EWT. This is switch-based calculation.

Expert Agent Selection (EAS)
An optional Communication Manager feature that routes incoming calls to an agent who is a member of the specific skill required to handle the problems of the caller.

extension call
A call originated by an agent or a non-ACD call received by an agent. Extension calls include calls an agent makes to set up a conference or transfer.

FBUSY
See forced busy (FBUSY).
FDISC

FDISC
See forced disconnect (FDISC).

flex agents
Agents who have the role of roving, backup, or allocated. Top and reserve agents are not flex agents. See the Avaya Business Advocate User Guide for more information.

flexible routing
An ACD capability that allows you to choose how incoming calls should be routed to agents in a split. Calls can be routed to the first available agent or to the most-idle agent.

forced busy (FBUSY)
A trunk state in which the caller receives a forced busy signal.

forced disconnect (FDISC)
A trunk state in which the caller receives a forced disconnect.

Forced Multiple Call Handling (FMCH)
A feature available for Communication Manager system which, when activated for a split/skill, allows calls to be automatically delivered to an idle line appearance if the agent is in the AI (auto-in) or MI (manual-in) work mode and if an unrestricted line appearance is available on the voice terminal.

Forecast, Avaya CMS
An Avaya product used to generate reports displaying expected call traffic and agent/trunk group requirements for the contact center for a particular day or period in the future.

historical database
A CMS database consisting of intrahour records for up to 62 days, daily records for up to 5 years, and weekly/monthly records for up to 10 years for each CMS-measured agent, split/skill, trunk, trunk group, VDN, and vector.

historical reports
Reports of past ACD data for various agent, split/skill, trunk, trunk group, VDN, or vector activities. Historical reports summarize call data into daily, weekly, or monthly totals.

HOLD
A trunk state in which an agent has put a call on this trunk on hold.

IDLE
A trunk state in which this trunk is not in use and is waiting for a call.

II
See Information Indicator (II).

Inbound Call Management (ICM)
A set of switch and adjunct features using ASAI to enable the adjunct to provide automatic screen delivery and call routing.

Information Indicator (II)
A 2-digit code that identifies the type of originating line for incoming ISDN PRI calls, such as hotel or pay phone.
### INFORMIX
A relational database management system used to store and retrieve CMS data.

### INFORMIX SQL
An interactive interface typically used to view the INFORMIX database.

### Integrated Services Digital Network (ISDN)
A digital standard for telephony that enables analog and digital signals on the same line.

### interval ASA
The average time a call waits in queue before connecting to an agent, calculated on reporting interval boundaries. Interval ASA is cleared to zero at the start of each reporting interval. See also [Average Speed of Answer (ASA)](#) and [rolling ASA](#).

### interval-based items
A category of database items that represent the amount of time during a collection interval spent on a particular activity. Interval-based items are updated throughout the collection interval and timing is restarted at the end of the interval.

### intrahour interval
A 15-, 30-, or 60-minute segment of time starting on the hour. An intrahour interval is the basic unit of CMS report time.

### ISDN
See [Integrated Services Digital Network (ISDN)](#).

### LAN
See [local area network (LAN)](#).

### local area network (LAN)
A private interactive communication network that allows computers and compatible devices to communicate over short distances, usually less than one mile, at high data transfer rates.

### Logical Agent
An EAS feature that associates an agent’s login ID with a physical extension when the agent logs in. Properties such as the assigned skills, class of restriction, and coverage path are associated with the login ID rather than the physical extension. This allows agents to log in at any available set.

### LOGOFF
An agent trace work mode in which an agent is logged out and not available to take ACD calls.

### LOGON
An agent trace work mode in which an agent is logged in and available to take ACD calls.

### logout reason codes
Codes that enable an agent to specify the reason for logging out such as the end of a shift or for training.
### Look Ahead Interflow (LAI)

**Look Ahead Interflow (LAI)** - A switch feature that can be used to balance the call load among multiple contact centers. LAI works with Call Vectoring and ISDN PRI trunks to intelligently route calls between contact centers. This allows multiple contact centers to share workloads, expand hours of coverage, and allows calls to be transparently handled by contact centers in different time zones.

### maintenance

**maintenance** - A CMS subsystem that is used for routine maintenance of CMS, such as backing up data, checking on the status of the connection to the switch, and scanning the error log.

### maintenance busy (MBUSY)

**maintenance busy (MBUSY)** - A trunk state in which the trunk is out of service for maintenance purposes.

### Manual-In (MI)

**Manual-In (MI)** - An ACD work mode in which an agent is available to receive an ACD call and is automatically placed into the ACW state upon release from the call.

### MBUSY

**MBUSY** - See maintenance busy (MBUSY).

### MCH

**MCH** - See Multiple Call Handling (MCH).

### measured

**measured** - A term meaning that an ACD element such as agent, split/skill, trunk, trunk group, VDN, or vector that is identified to CMS for data collection. If the ACD element is not measured, no data is collected.

### MI

**MI** - See Manual-In (MI).

### MIA

**MIA** - See Most Idle Agent (MIA).

### monthly data

**monthly data** - Daily data that has been converted to a monthly summary.

### Most Idle Agent (MIA)

**Most Idle Agent (MIA)** - An ACD distribution method that maintains a queue of idle agents. An agent is put at the end of the list for a particular split when the agent completes an ACD call for that split. The agent continues to advance on the list as long as he or she remains staffed and in ACW, AVAIL, or on AUXIN/OUT extension calls from the AVAIL mode.

### Multiple Call Handling (MCH)

**Multiple Call Handling (MCH)** - A process in which an agent receives an ACD call while other calls are active on the agent’s station. The agent must put the current call on hold and press Auto-In/Manual-In to receive another ACD call.

### multiple split queuing

**multiple split queuing** - A Call Vectoring capability that directs a call to up to three splits at the same time, with the first agent who is free receiving the call.

### multi-user mode

**multi-user mode** - A CMS state in which any administered user can log into CMS and data continues to be collected if the data collection feature is enabled.
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>name (synonym) fields</td>
<td>A field in which you can input a name (synonym) that you have entered in the Dictionary. For example, you can input names of agents, splits/skills, agent groups, trunk groups, VDNs, or vectors.</td>
</tr>
<tr>
<td>night service</td>
<td>A switch capability that enables calls that arrive after business hours or on weekends to be automatically re-routed to a split, an announcement, or an alternate destination set up for after-hours coverage.</td>
</tr>
<tr>
<td>nonprimary split/skill</td>
<td>The second and third splits/skills to which a call queued to multiple splits/skills queues in a VDN. Also called secondary and tertiary split/skill, respectively.</td>
</tr>
<tr>
<td>OTHER</td>
<td>An agent work mode in which the agent is on a direct agent call, on a call for another split or skill, or has put a call on hold and has not chosen another work mode.</td>
</tr>
<tr>
<td>Outbound Call Management (OCM)</td>
<td>A set of switch and adjunct features using ASAI that distributes outbound calls initiated by an adjunct to internal extensions (usually ACD agents).</td>
</tr>
<tr>
<td>phantom abandon call timer</td>
<td>A CMS capability that tracks information about abandoned calls. When the phantom abandon call timer is enabled, calls with a duration shorter than the administered value (0 to 10 seconds) are counted as phantom abandon calls. Setting the timer to 0 disables this capability.</td>
</tr>
<tr>
<td>percent within service level</td>
<td>The percentage of calls that you are expecting or targeting to be answered by an agent within a specific number of seconds.</td>
</tr>
<tr>
<td>previous interval</td>
<td>An intrahour interval that is part of the real-time database. At the end of each intrahour interval, the contents of the current intrahour interval are copied to the previous intrahour interval portion of the real-time database.</td>
</tr>
<tr>
<td>primary skill</td>
<td>A skill assigned to an agent as that agent's strongest skill. Primary skills are the areas in which the agent has the most expertise.</td>
</tr>
<tr>
<td>pseudo-ACD</td>
<td>An area created on CMS to place previously backed-up ACD data. A pseudo-ACD is not a live (real) ACD and does not communicate with any switch.</td>
</tr>
<tr>
<td>queue</td>
<td>A holding area for calls waiting to be answered in the order in which they were received. Calls in a queue may have different priority levels, in which case, calls with a higher priority are answered first.</td>
</tr>
<tr>
<td>QUEUED</td>
<td>A trunk state in which an ACD call has seized the trunk and is queued to a split/skill, waiting for an agent to answer.</td>
</tr>
</tbody>
</table>
read permission

A permission with which a CMS user can access and view data; for example, running reports or viewing the Dictionary subsystem.

real-time database

A CMS database consisting of the current intrahour data on each CMS-measured agent, split, trunk, trunk group, VDN, and vector.

real-time reports

A report that shows ACD call activity on agents, split/skills, trunks, trunk groups, VDNs, and vectors for the current or previous intrahour interval.

Redirect On No Answer

An ACD capability that assist the user if a call is not answered in a specified number of rings. The terminal extension, including ports with VRUs, is busied out and the call goes back into the queue at top priority.

refresh rate

The number of seconds that CMS should wait for each update of real-time report data.

reserve agent

An agent whose skills are set so that they do not have a top skill, but are used to handle calls when all other agents of that skill are unavailable. Reserve agents are used for high-priority skills where customers must not wait for long periods of time.

RINGING

1) An agent state consisting of the time a call rings at an agent’s voice terminal after leaving the queue and before the agent answers the call.

2) A trunk state in which a call is ringing at the agent’s voice terminal.

rolling ASA

A running, weighted, average calculation made without using interval boundaries. Rolling ASA is used for vector routing; it is calculated on the Communication Manager system and set to CMS.

scripting

A CMS Supervisor capability that allows you to automate operations such as changing an agent’s skills, running a report, and exporting report data.

secondary skill

A skill assigned to an agent in a subject that is not that agent's strongest area of expertise. Secondary skills are used in Communication Manager systems with Expert Agent Selection (EAS).

SEIZED

A trunk state in which an incoming or outgoing call is using the trunk.

service level

A time, in seconds, within which all calls should be answered. Also called acceptable service level.

Service Observing - Remote

A feature that allows a user to dial into the switch and monitor a call.
<table>
<thead>
<tr>
<th><strong>Service Observing - VDNs</strong></th>
<th>A feature available with Communication Manager systems that give a user the ability to monitor the treatment that a call receives as it is processed by a VDN.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>shortcut</strong></td>
<td>A series of tasks which, when run, are performed on the CMS server. Shortcuts are a fast, easy way to view windows every day for the same ACD entities.</td>
</tr>
<tr>
<td><strong>single-user mode</strong></td>
<td>A CMS mode in which only one administrator can log in to the CMS server. Data continues to be collected if the data collection feature is enabled.</td>
</tr>
<tr>
<td><strong>skill</strong></td>
<td>See agent skill.</td>
</tr>
<tr>
<td><strong>skill level</strong></td>
<td>A rating from 1 (highest) to 16 (lowest) that indicates an agent’s level of expertise in handling calls for which that expertise is needed.</td>
</tr>
<tr>
<td><strong>screen-labeled key (SLK)</strong></td>
<td>The first eight function keys at the top of the keyboard that correspond to the screen labels at the bottom of the CMS ASCII terminal screen. The screen labels indicate each key’s function.</td>
</tr>
<tr>
<td><strong>split</strong></td>
<td>A group of extensions that receive calls.</td>
</tr>
<tr>
<td><strong>staffed agent</strong></td>
<td>An agent who is currently logged in to the switch.</td>
</tr>
<tr>
<td><strong>standard reports</strong></td>
<td>The set of reports that are supplied with CMS or CMS Supervisor.</td>
</tr>
</tbody>
</table>
| **station**                   | 1) An unmeasured extension  
2) An extension that is not currently staffed by an agent or that is a member of an unmeasured split/skill. |
| **switch**                    | A system providing voice or voice/data communication services for a group of terminals.         |
| **timetable**                 | A CMS feature that allows you to schedule one or more activities to run unattended. Timetables can be set to run once or at multiple times. |
| **trunk**                     | A telephone circuit that carries calls between two switches, between a central office and a switch, or between a central office and a telephone. |
| **trunk group**               | A group of trunks that are assigned the same dialing digits: either a phone number or a direct inward dialed (DID) prefix. |
| **uniform call distribution (UCD)** | A method of call distribution in which the most idle agent for a skill receives the call (if the agent is available). |
universal call identifier (UCID)

A number that uniquely identifies a call in a network of nodes that support UCID.

UNKNOWN

1) An agent state in which CMS does not recognize the state of the agent.
2) A trunk state in which CMS does not recognize the state of the trunk.

UNSTAF

An agent state in which the agent is not logged in and, therefore, is not tracked by CMS.

VDN

See Vector Directory Number (VDN).

VDN calls-counted

See active VDN calls.

VDN or Origin Announcement (VOA)

A short announcement that is assigned to a VDN through switch administration. The VOA identifies the origin or purpose of a call for the contact center agent who answers the call.

VDN skill preference

A prioritized list of agent skills administered for a VDN that are needed or preferred for the answering agent. VDN skill preferences require a call to be routed to an ACD agent with a particular attribute or set of attributes.

vector

A list of steps that process calls according to a user definition. The steps in a vector can send calls to splits, play announcements and music, disconnect calls, give calls a busy signal, or route calls to other destinations based on specific criteria.

vector command

A step in a vector that describes the action to be executed for a call.

Vector Directory Number (VDN)

An extension number that enables calls to connect to a vector for processing. A VDN can connect calls to a vector when the calls arrive over an assigned automatic-in trunk group or when the calls arrive over a DID trunk group and the final digits match the VDN. The VDN by itself may be dialed to access the vector from any extension connected to the switch.

vector step

A single task within a vector that performs an action regarding a call. A vector step consists of a command with the possibility of one or more conditions or parameters, if necessary.

vector step condition

A condition accompanying a vector command that defines the circumstances in which the command is applied to a call.

VOA

See VDN or Origin Announcement (VOA).
<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>voice terminal</td>
<td>A telephone set, usually with buttons.</td>
</tr>
<tr>
<td>weekly data</td>
<td>Daily data that has been converted to a weekly summary.</td>
</tr>
<tr>
<td>write permission</td>
<td>A permission with which a CMS user can add, modify, or delete data and execute processes.</td>
</tr>
</tbody>
</table>
write permission
Index

A

ACD
  Administration Log .................................. 608
  administrative interface ........................... 27
  listing connection status ............................ 570
  listing status ....................................... 530
  name, deleting ........................................ 62
  settings, listing all ................................ 522
  settings, viewing ..................................... 521
  setup .................................................. 520
  translations, requesting ............................. 533
  user permissions ..................................... 394
  user permissions, adding ............................ 395
  user permissions, deleting ........................... 402
  user permissions, listing all ....................... 398
  user permissions, modifying ......................... 400
  user permissions, viewing ........................... 397
  viewing archiving status of all ..................... 536
  viewing archiving status of one ....................... 535
  viewing connection status ........................... 568
  viewing status ....................................... 527
ACD Groups ............................................. 55, 246
  Adding .................................................. 249
  Adding an ACD .......................................... 251
  Call Center Administration ......................... 246
  deleting ............................................... 258
  deleting an ACD ....................................... 254
  Dictionary ............................................. 55
    view contents ........................................ 57
  List all
    Dictionary ........................................... 56
  listing all
    Call Center Admin .................................. 250
    modifying ............................................ 256
    renaming ............................................. 256
    view contents ......................................... 57
    viewing contents .................................... 252
ACD status ............................................. 526
ACDs ..................................................... 59
adding agents to an existing agent group ........ 69
adding an ACD name .................................... 60
adding an agent group ................................ 65
adding an AUX reason code name ...................... 87
administering printers ................................. 574
agent
  copying agent groups ................................ 68
  exceptions ............................................. 313
  exceptions, adding ................................... 314
  exceptions, definitions .............................. 321
  exceptions, deleting ................................ 318
  exceptions, modifying ................................ 316
  exceptions, report .................................... 323
  skills, changing ....................................... 225
  templates, changing skills for ...................... 225
  trace, starting and stopping ......................... 218
  trace, viewing current states ....................... 221
agent group
  deleting ............................................... 72
  listing agents ......................................... 66
agent group members
  running a report ....................................... 189
agent groups ............................................ 64
agent string value field descriptions ................ 77
agent string values .................................... 74
agent trace
  stopping ............................................... 218
agents
  adding to an existing group ......................... 69
  administrating ....................................... 217
  deleting from an existing group ..................... 71
  multiple, adding to another skill .................. 232
  multiple, changing skills for ....................... 233
  multiple, moving from skill to skill ................ 232
  trace, listing all records ........................... 223
allocating
  disk space ........................................... 472
ANI/SID
  see automatic number identification/station number
  identification
announcement name
  adding .................................................. 80
  deleting ............................................... 84
  listing all ............................................ 82
  modifying ............................................. 83
  viewing ............................................... 81
announcement names .................................... 79
archiving data
  Data Summarizing ..................................... 481
archiving status ....................................... 534
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Call Center Administration</td>
<td>246</td>
</tr>
<tr>
<td>ACD Groups</td>
<td>246</td>
</tr>
<tr>
<td>Call Vectoring</td>
<td>217</td>
</tr>
<tr>
<td>call work code 0</td>
<td>260</td>
</tr>
<tr>
<td>call work code names</td>
<td>103</td>
</tr>
<tr>
<td>adding</td>
<td>107</td>
</tr>
<tr>
<td>deleting</td>
<td>105</td>
</tr>
<tr>
<td>listing all</td>
<td>106</td>
</tr>
<tr>
<td>modifying</td>
<td>104</td>
</tr>
<tr>
<td>call work codes</td>
<td>102</td>
</tr>
<tr>
<td>adding</td>
<td>261</td>
</tr>
<tr>
<td>configuring</td>
<td>260</td>
</tr>
<tr>
<td>deleting</td>
<td>265</td>
</tr>
<tr>
<td>listing all</td>
<td>264</td>
</tr>
<tr>
<td>AUX reason code names</td>
<td>86</td>
</tr>
<tr>
<td>adding</td>
<td>87</td>
</tr>
<tr>
<td>deleting</td>
<td>92</td>
</tr>
<tr>
<td>listing all</td>
<td>89</td>
</tr>
<tr>
<td>modifying</td>
<td>90</td>
</tr>
<tr>
<td>viewing</td>
<td>88</td>
</tr>
<tr>
<td>backup</td>
<td>551</td>
</tr>
<tr>
<td>CMSADM</td>
<td>551</td>
</tr>
<tr>
<td>maintenance</td>
<td>553</td>
</tr>
<tr>
<td>recovery kit</td>
<td>560</td>
</tr>
<tr>
<td>backup information</td>
<td>559</td>
</tr>
<tr>
<td>how to interpret</td>
<td>559</td>
</tr>
<tr>
<td>backup volume</td>
<td>559</td>
</tr>
<tr>
<td>labeling</td>
<td>559</td>
</tr>
<tr>
<td>backup/restore devices</td>
<td>543</td>
</tr>
<tr>
<td>adding</td>
<td>546</td>
</tr>
<tr>
<td>deleting</td>
<td>541</td>
</tr>
<tr>
<td>listing all</td>
<td>544</td>
</tr>
<tr>
<td>modifying</td>
<td>540</td>
</tr>
<tr>
<td>calculations</td>
<td>94</td>
</tr>
<tr>
<td>adding</td>
<td>98</td>
</tr>
<tr>
<td>deleting</td>
<td>100</td>
</tr>
<tr>
<td>listing all</td>
<td>97</td>
</tr>
<tr>
<td>modifying</td>
<td>99</td>
</tr>
<tr>
<td>viewing</td>
<td>95</td>
</tr>
<tr>
<td>CentreVu® CMS ACD</td>
<td>466</td>
</tr>
<tr>
<td>master, selecting</td>
<td>466</td>
</tr>
<tr>
<td>CentreVu® CMS data</td>
<td>497</td>
</tr>
<tr>
<td>migrating</td>
<td>497</td>
</tr>
<tr>
<td>migrating, R3</td>
<td>497</td>
</tr>
<tr>
<td>CentreVu® CMS state</td>
<td>465</td>
</tr>
<tr>
<td>changing</td>
<td>465</td>
</tr>
<tr>
<td>chunks</td>
<td>32</td>
</tr>
<tr>
<td>ACD dbspace, modifying</td>
<td>494</td>
</tr>
<tr>
<td>CMSADM backup</td>
<td>551</td>
</tr>
<tr>
<td>colors threshold</td>
<td>44</td>
</tr>
<tr>
<td>colors, reports</td>
<td>40</td>
</tr>
<tr>
<td>Communications Tab</td>
<td>40, 47</td>
</tr>
<tr>
<td>connection status</td>
<td>568</td>
</tr>
<tr>
<td>constants</td>
<td>109</td>
</tr>
<tr>
<td>adding</td>
<td>110</td>
</tr>
<tr>
<td>deleting</td>
<td>114</td>
</tr>
<tr>
<td>listing all</td>
<td>112</td>
</tr>
<tr>
<td>modifying</td>
<td>113</td>
</tr>
<tr>
<td>viewing</td>
<td>111</td>
</tr>
<tr>
<td>copying an existing agent group to a new name</td>
<td>68</td>
</tr>
<tr>
<td>custom database items</td>
<td>116</td>
</tr>
<tr>
<td>adding</td>
<td>117</td>
</tr>
<tr>
<td>deleting</td>
<td>121</td>
</tr>
<tr>
<td>listing all</td>
<td>119</td>
</tr>
<tr>
<td>modifying</td>
<td>120</td>
</tr>
<tr>
<td>viewing</td>
<td>118</td>
</tr>
<tr>
<td>custom, modifying</td>
<td>120</td>
</tr>
<tr>
<td>custom, listing all</td>
<td>119</td>
</tr>
<tr>
<td>custom, deleting</td>
<td>121</td>
</tr>
<tr>
<td>custom, viewing</td>
<td>118</td>
</tr>
<tr>
<td>CentreVu® CMS state</td>
<td>465</td>
</tr>
<tr>
<td>changing</td>
<td>465</td>
</tr>
<tr>
<td>chunks</td>
<td>32</td>
</tr>
<tr>
<td>ACD dbspace, modifying</td>
<td>494</td>
</tr>
<tr>
<td>CMSADM backup</td>
<td>551</td>
</tr>
<tr>
<td>colors threshold</td>
<td>44</td>
</tr>
<tr>
<td>colors, reports</td>
<td>40</td>
</tr>
<tr>
<td>Communications Tab</td>
<td>40, 47</td>
</tr>
<tr>
<td>connection status</td>
<td>568</td>
</tr>
<tr>
<td>constants</td>
<td>109</td>
</tr>
<tr>
<td>adding</td>
<td>110</td>
</tr>
<tr>
<td>deleting</td>
<td>114</td>
</tr>
<tr>
<td>listing all</td>
<td>112</td>
</tr>
<tr>
<td>modifying</td>
<td>113</td>
</tr>
<tr>
<td>viewing</td>
<td>111</td>
</tr>
<tr>
<td>copying an existing agent group to a new name</td>
<td>68</td>
</tr>
<tr>
<td>custom database items</td>
<td>116</td>
</tr>
<tr>
<td>adding</td>
<td>117</td>
</tr>
<tr>
<td>deleting</td>
<td>121</td>
</tr>
<tr>
<td>listing all</td>
<td>119</td>
</tr>
<tr>
<td>modifying</td>
<td>120</td>
</tr>
<tr>
<td>viewing</td>
<td>118</td>
</tr>
<tr>
<td>custom, modifying</td>
<td>120</td>
</tr>
<tr>
<td>custom, listing all</td>
<td>119</td>
</tr>
<tr>
<td>custom, deleting</td>
<td>121</td>
</tr>
<tr>
<td>custom, viewing</td>
<td>118</td>
</tr>
<tr>
<td>CentreVu® CMS state</td>
<td>465</td>
</tr>
<tr>
<td>changing</td>
<td>465</td>
</tr>
<tr>
<td>chunks</td>
<td>32</td>
</tr>
<tr>
<td>ACD dbspace, modifying</td>
<td>494</td>
</tr>
<tr>
<td>CMSADM backup</td>
<td>551</td>
</tr>
<tr>
<td>colors threshold</td>
<td>44</td>
</tr>
<tr>
<td>colors, reports</td>
<td>40</td>
</tr>
<tr>
<td>Communications Tab</td>
<td>40, 47</td>
</tr>
<tr>
<td>connection status</td>
<td>568</td>
</tr>
<tr>
<td>constants</td>
<td>109</td>
</tr>
<tr>
<td>adding</td>
<td>110</td>
</tr>
<tr>
<td>deleting</td>
<td>114</td>
</tr>
<tr>
<td>listing all</td>
<td>112</td>
</tr>
<tr>
<td>modifying</td>
<td>113</td>
</tr>
<tr>
<td>viewing</td>
<td>111</td>
</tr>
<tr>
<td>copying an existing agent group to a new name</td>
<td>68</td>
</tr>
<tr>
<td>custom database items</td>
<td>116</td>
</tr>
<tr>
<td>adding</td>
<td>117</td>
</tr>
<tr>
<td>deleting</td>
<td>121</td>
</tr>
<tr>
<td>listing all</td>
<td>119</td>
</tr>
<tr>
<td>modifying</td>
<td>120</td>
</tr>
<tr>
<td>viewing</td>
<td>118</td>
</tr>
<tr>
<td>custom, modifying</td>
<td>120</td>
</tr>
<tr>
<td>custom, listing all</td>
<td>119</td>
</tr>
<tr>
<td>custom, deleting</td>
<td>121</td>
</tr>
<tr>
<td>custom, viewing</td>
<td>118</td>
</tr>
<tr>
<td>Dictionary</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>ACD Groups</td>
<td>55</td>
</tr>
<tr>
<td>List all</td>
<td>56</td>
</tr>
<tr>
<td>view contents</td>
<td>57</td>
</tr>
<tr>
<td>ACD name, deleting</td>
<td>62</td>
</tr>
<tr>
<td>announcement name, running</td>
<td>80</td>
</tr>
<tr>
<td>announcement name, viewing</td>
<td>81</td>
</tr>
<tr>
<td>calculations, adding</td>
<td>98</td>
</tr>
<tr>
<td>calculations, listing all</td>
<td>97</td>
</tr>
<tr>
<td>calculations, viewing</td>
<td>95</td>
</tr>
<tr>
<td>call work code names, adding</td>
<td>103</td>
</tr>
<tr>
<td>call work code names, deleting</td>
<td>107</td>
</tr>
<tr>
<td>call work code names, listing all</td>
<td>105</td>
</tr>
<tr>
<td>call work code names, modifying</td>
<td>106</td>
</tr>
<tr>
<td>call work code names, viewing</td>
<td>104</td>
</tr>
<tr>
<td>call work codes</td>
<td>102</td>
</tr>
<tr>
<td>constant, deleting</td>
<td>114</td>
</tr>
<tr>
<td>constants</td>
<td>109</td>
</tr>
<tr>
<td>constants, adding</td>
<td>110</td>
</tr>
<tr>
<td>constants, listing all</td>
<td>112</td>
</tr>
<tr>
<td>constants, modifying</td>
<td>113</td>
</tr>
<tr>
<td>constants, viewing</td>
<td>111</td>
</tr>
<tr>
<td>custom database item, viewing</td>
<td>118</td>
</tr>
<tr>
<td>custom database items</td>
<td>116</td>
</tr>
<tr>
<td>custom database items, adding</td>
<td>117</td>
</tr>
<tr>
<td>custom database items, deleting</td>
<td>121</td>
</tr>
<tr>
<td>custom database items, listing all</td>
<td>119</td>
</tr>
<tr>
<td>custom database items, modifying</td>
<td>120</td>
</tr>
<tr>
<td>location ID, adding</td>
<td>126</td>
</tr>
<tr>
<td>location ID, deleting</td>
<td>130</td>
</tr>
<tr>
<td>location ID, listing all</td>
<td>128</td>
</tr>
<tr>
<td>location ID, modifying</td>
<td>129</td>
</tr>
<tr>
<td>location ID, viewing</td>
<td>127</td>
</tr>
<tr>
<td>location IDs</td>
<td>125</td>
</tr>
<tr>
<td>login ID name, adding</td>
<td>133</td>
</tr>
<tr>
<td>login ID name, deleting</td>
<td>137</td>
</tr>
<tr>
<td>login ID name, listing all</td>
<td>135</td>
</tr>
<tr>
<td>login ID name, modifying</td>
<td>136</td>
</tr>
<tr>
<td>login ID name, viewing</td>
<td>134</td>
</tr>
<tr>
<td>login ID names</td>
<td>132</td>
</tr>
<tr>
<td>logout reason code name, adding</td>
<td>140</td>
</tr>
<tr>
<td>logout reason code name, deleting</td>
<td>145</td>
</tr>
<tr>
<td>logout reason code name, listing all</td>
<td>142</td>
</tr>
<tr>
<td>logout reason code name, modifying</td>
<td>143</td>
</tr>
<tr>
<td>logout reason code name, viewing</td>
<td>141</td>
</tr>
<tr>
<td>logout reason code names</td>
<td>139</td>
</tr>
<tr>
<td>reports</td>
<td>187</td>
</tr>
<tr>
<td>reports, printing</td>
<td>187</td>
</tr>
<tr>
<td>search</td>
<td>52</td>
</tr>
<tr>
<td>split/skill name, adding</td>
<td>153</td>
</tr>
<tr>
<td>split/skill name, deleting</td>
<td>157</td>
</tr>
<tr>
<td>split/skill name, listing all</td>
<td>155</td>
</tr>
<tr>
<td>split/skill name, modifying</td>
<td>156</td>
</tr>
<tr>
<td>split/skill name, viewing</td>
<td>154</td>
</tr>
<tr>
<td>split/skill names</td>
<td>152</td>
</tr>
<tr>
<td>split/skill string value, field descriptions</td>
<td>150</td>
</tr>
<tr>
<td>split/skill string values</td>
<td>147</td>
</tr>
<tr>
<td>split/skill string values, modifying</td>
<td>149</td>
</tr>
<tr>
<td>split/skill string values, viewing</td>
<td>148</td>
</tr>
<tr>
<td>standard CMS item, viewing</td>
<td>160</td>
</tr>
<tr>
<td>standard database item, viewing</td>
<td>160</td>
</tr>
<tr>
<td>standard database items</td>
<td>159</td>
</tr>
<tr>
<td>standard database items, viewing alphabetically</td>
<td>161</td>
</tr>
<tr>
<td>trunk group name, adding</td>
<td>163</td>
</tr>
<tr>
<td>trunk group name, deleting</td>
<td>167</td>
</tr>
<tr>
<td>trunk group name, listing all</td>
<td>164</td>
</tr>
<tr>
<td>trunk group name, modifying</td>
<td>166</td>
</tr>
<tr>
<td>trunk group names</td>
<td>162</td>
</tr>
<tr>
<td>trunk group names, listing all</td>
<td>165</td>
</tr>
<tr>
<td>trunk string value, viewing and modifying</td>
<td>170</td>
</tr>
<tr>
<td>trunk string values</td>
<td>169</td>
</tr>
<tr>
<td>trunk string values, field descriptions</td>
<td>171</td>
</tr>
<tr>
<td>VDN Name, adding</td>
<td>174</td>
</tr>
<tr>
<td>VDN name, adding</td>
<td>178</td>
</tr>
<tr>
<td>VDN name, deleting</td>
<td>176</td>
</tr>
<tr>
<td>VDN name, modifying</td>
<td>177</td>
</tr>
<tr>
<td>VDN name, viewing</td>
<td>175</td>
</tr>
<tr>
<td>VDN names</td>
<td>173</td>
</tr>
<tr>
<td>vector name, adding</td>
<td>181</td>
</tr>
<tr>
<td>vector name, deleting</td>
<td>185</td>
</tr>
<tr>
<td>vector name, listing all</td>
<td>183</td>
</tr>
<tr>
<td>vector name, modifying</td>
<td>184</td>
</tr>
</tbody>
</table>
export chart data window ........................................ 207
extensions
split assignments, changing .................................. 236
splits, moving between ......................................... 239
external application status feature ....................... 483
disabling ......................................................... 484
enabling ......................................................... 484
external applications
starting or stopping ........................................... 486
states, viewing ................................................ 485
feature access
user permissions, listing all ................................ 408
user permissions, modifying ................................ 410
user permissions, viewing ................................... 407
first day of week ............................................... 38
free space allocation .......................................... 489
contents, viewing ............................................. 492
modifying ...................................................... 494
viewing ......................................................... 490

generic string values synonyms ......................... 122

helplines ...................................................... 26
historical data
archiving ...................................................... 481
informix dynamic server (IDS) ............................ 489
informix software, inc.INFORMIX®
interface to historical database ........................... 27
input window
scripting ....................................................... 210
interval
intrahour ..................................................... 510
intrahour, changing ......................................... 512
intervals
storage ........................................................ 510
storage, viewing ............................................. 511
intrahour interval ............................................. 510
changing ....................................................... 512

listing agents in an agent group ......................... 66

vector name, viewing ........................................ 182
vector names ................................................... 180
dictionary rules ............................................... 51
disk space allocating ......................................... 472
E
EAS (See Expert Agent Selection), Expert Agent Selection 217
EAS (see Expert Agent Selection), Expert Agent Selection 27
error log messages
maintenance .................................................... 584
exceptions
agent ............................................................ 313
agent, adding .................................................. 314
agent, definitions ............................................ 321
agent, deleting ................................................ 318
agent, modifying ............................................ 316
agent, report ................................................... 323
data collection ............................................... 373
definition ...................................................... 305
malicious call trace report ................................ 376
notification ..................................................... 311
Real-time exceptions log .................................... 379
split/skill ....................................................... 327
split/skill, adding ............................................ 328
split/skill, definitions ....................................... 334
split/skill, deleting .......................................... 332
split/skill, modifying ....................................... 330
split/skill, report ............................................. 335
trunk group ..................................................... 339
trunk group, adding ......................................... 340
trunk group, deleting ....................................... 344
trunk group, modifying ..................................... 342
trunk group, report .......................................... 346
VDN, adding .................................................. 351
VDN, deleting ................................................. 355
VDN, modifying ............................................. 353
VDN, report .................................................... 358
vector ............................................................ 362
vector, adding ................................................ 363
vector, deleting .............................................. 367
vector, modifying .......................................... 365
vector, report ................................................ 369
expert agent selection (EAS)
agent trace .................................................... 218
export
report output ................................................ 207
export all data window ...................................... 207
Options

Name Format Tab ........................................... 47

login ID name
adding .................................................... 133
deleting .................................................. 137
listing ...................................................... 135
modifying ................................................ 136
viewing .................................................... 134

login ID names ........................................... 132
logout reason code name
adding .................................................... 140
deleting .................................................. 142
listing all ............................................... 141
modifying ................................................ 143
viewing .................................................... 141

logout reason code names ................................ 139

M

Main Menu
Addition Access, assigning/modifying .............. 416
Addition Access, listing all .......................... 414
Addition Access, viewing ............................... 413

maintenance backup ....................................... 553
Maintenance Error Log
running ................................................... 581
Maintenance Error Log messages .................... 584
Maintenance tool ......................................... 525
malicious call trace
report ....................................................... 376

master ACD
see ACD
migrating CentreVu® CMS data ....................... 497
modifying a custom calculation ...................... 99
modifying an ACD name ................................ 61
modifying an announcement name ................... 83
modifying an AUX reason code name ............... 90
modifying generic string values ..................... 124
multi-user mode
setting ..................................................... 465

N

Name Format Tab ........................................... 47

O

Options
Default ACD ............................................... 38
First Day of Week ........................................ 38
general ..................................................... 38
report colors ............................................. 40

threshold colors ............................................ 44
time synchronization ....................................... 38

Options...

Communications Tab ...................................... 40, 47
Name Format Tab ........................................... 47

P

password
aging ....................................................... 618
passwords
choosing .................................................. 616

permissions
ACD ........................................................... 394
Main Menu Addition Access, assigning/modifying 416
Main Menu Addition Access, listing all ............. 414
Main Menu Addition Access, viewing ............... 413
split/skill, adding user .................................. 419
split/skill, deleting user ................................ 426
split/skill, listing all user .............................. 423
split/skill, modifying user .............................. 424
split/skill, viewing user ................................ 421
trunk group, adding user ................................ 430
trunk group, deleting user .............................. 437
trunk group, listing all user ........................... 434
trunk group, modifying user ........................... 435
trunk group, viewing user .............................. 432
user, adding ACD ......................................... 395
user, deleting ACD ....................................... 402
user, listing all ACD ...................................... 398
user, listing all Feature Access ....................... 408
user, modifying ACD ..................................... 400
user, modifying Feature Access ....................... 410
user, viewing ACD ......................................... 397
user, viewing Feature Access ......................... 407
VDN, adding user ......................................... 452
VDN, deleting user ....................................... 459
VDN, listing all user ..................................... 456
VDN, modifying user ..................................... 457
VDN, viewing user ......................................... 454
vector, adding user ....................................... 441
vector, deleting user ..................................... 448
vector, listing all user ................................... 445
vector, modifying user ................................... 446
vector, viewing user ..................................... 443
phantom abandon call timer ............................ 520

print
setup ....................................................... 198
print window ............................................... 197
printer
adding ..................................................... 575
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>pseudo-ACDs</td>
<td>502</td>
</tr>
<tr>
<td>pseudo-A CD</td>
<td>504</td>
</tr>
<tr>
<td>deleting</td>
<td>506</td>
</tr>
<tr>
<td>printing</td>
<td>194</td>
</tr>
<tr>
<td>AC D Administration Log</td>
<td>608</td>
</tr>
<tr>
<td>choosing</td>
<td>194</td>
</tr>
<tr>
<td>configuring</td>
<td>44</td>
</tr>
<tr>
<td>custom</td>
<td>192</td>
</tr>
<tr>
<td>data collection</td>
<td>373</td>
</tr>
<tr>
<td>Dictionary</td>
<td>187</td>
</tr>
<tr>
<td>Dictionary, printing</td>
<td>187</td>
</tr>
<tr>
<td>exceptions</td>
<td>323</td>
</tr>
<tr>
<td>exceptions, trunk group</td>
<td>346</td>
</tr>
<tr>
<td>generating</td>
<td>196</td>
</tr>
<tr>
<td>malicious call trace</td>
<td>376</td>
</tr>
<tr>
<td>members, trunk group</td>
<td>286</td>
</tr>
<tr>
<td>print setup, changing</td>
<td>198</td>
</tr>
<tr>
<td>printing</td>
<td>197</td>
</tr>
<tr>
<td>restarting</td>
<td>199</td>
</tr>
<tr>
<td>running</td>
<td>194</td>
</tr>
<tr>
<td>split members, running</td>
<td>242</td>
</tr>
<tr>
<td>split/skill, exceptions</td>
<td>335</td>
</tr>
<tr>
<td>standard</td>
<td>192</td>
</tr>
<tr>
<td>to summarize</td>
<td>193</td>
</tr>
<tr>
<td>types of</td>
<td>192</td>
</tr>
<tr>
<td>VDN, exceptions</td>
<td>358</td>
</tr>
<tr>
<td>vector, exceptions</td>
<td>369</td>
</tr>
<tr>
<td>members report, running</td>
<td>242</td>
</tr>
<tr>
<td>restore</td>
<td>194</td>
</tr>
<tr>
<td>automatic</td>
<td>562</td>
</tr>
<tr>
<td>manual</td>
<td>564</td>
</tr>
<tr>
<td>restoring data</td>
<td>581</td>
</tr>
<tr>
<td>running a report</td>
<td>194</td>
</tr>
</tbody>
</table>

R

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>recovery kit</td>
<td>560</td>
</tr>
<tr>
<td>report colors</td>
<td>40</td>
</tr>
<tr>
<td>Report Designer</td>
<td>192</td>
</tr>
<tr>
<td>reports</td>
<td>192</td>
</tr>
<tr>
<td>ACD Administration Log</td>
<td>608</td>
</tr>
<tr>
<td>choosing</td>
<td>194</td>
</tr>
<tr>
<td>colors</td>
<td>44</td>
</tr>
<tr>
<td>configuring</td>
<td>192</td>
</tr>
<tr>
<td>custom</td>
<td>192</td>
</tr>
<tr>
<td>data collection</td>
<td>373</td>
</tr>
<tr>
<td>Dictionary</td>
<td>187</td>
</tr>
<tr>
<td>Dictionary, printing</td>
<td>187</td>
</tr>
<tr>
<td>exceptions</td>
<td>323</td>
</tr>
<tr>
<td>exceptions, trunk group</td>
<td>346</td>
</tr>
<tr>
<td>generating</td>
<td>196</td>
</tr>
<tr>
<td>malicious call trace</td>
<td>376</td>
</tr>
<tr>
<td>members, trunk group</td>
<td>286</td>
</tr>
<tr>
<td>print setup, changing</td>
<td>198</td>
</tr>
<tr>
<td>printing</td>
<td>197</td>
</tr>
<tr>
<td>restarting</td>
<td>199</td>
</tr>
<tr>
<td>running</td>
<td>194</td>
</tr>
<tr>
<td>split members, running</td>
<td>242</td>
</tr>
<tr>
<td>split/skill, exceptions</td>
<td>335</td>
</tr>
<tr>
<td>standard</td>
<td>192</td>
</tr>
<tr>
<td>to summarize</td>
<td>193</td>
</tr>
<tr>
<td>types of</td>
<td>192</td>
</tr>
<tr>
<td>VDN, exceptions</td>
<td>358</td>
</tr>
<tr>
<td>vector, exceptions</td>
<td>369</td>
</tr>
<tr>
<td>Reports input window</td>
<td>197</td>
</tr>
<tr>
<td>reports saved as HTML</td>
<td>208</td>
</tr>
<tr>
<td>restarting a report</td>
<td>199</td>
</tr>
<tr>
<td>restore</td>
<td>199</td>
</tr>
<tr>
<td>automatic</td>
<td>562</td>
</tr>
<tr>
<td>manual</td>
<td>564</td>
</tr>
<tr>
<td>restoring data</td>
<td>581</td>
</tr>
<tr>
<td>running a report</td>
<td>194</td>
</tr>
</tbody>
</table>

S

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save As HTML window</td>
<td>209</td>
</tr>
<tr>
<td>Save As Script - Action window</td>
<td>212</td>
</tr>
<tr>
<td>scripts</td>
<td>210</td>
</tr>
<tr>
<td>server</td>
<td>27</td>
</tr>
<tr>
<td>service level</td>
<td>274</td>
</tr>
<tr>
<td>increments</td>
<td>293</td>
</tr>
<tr>
<td>settings</td>
<td>522</td>
</tr>
<tr>
<td>ACD, listing all</td>
<td>522</td>
</tr>
<tr>
<td>ACD, viewing</td>
<td>521</td>
</tr>
<tr>
<td>setup</td>
<td>520</td>
</tr>
<tr>
<td>ACD/switch</td>
<td>520</td>
</tr>
<tr>
<td>shortcuts</td>
<td>621</td>
</tr>
<tr>
<td>copying</td>
<td>650</td>
</tr>
<tr>
<td>copying tasks in</td>
<td>651</td>
</tr>
<tr>
<td>creating</td>
<td>645</td>
</tr>
<tr>
<td>deleting</td>
<td>655</td>
</tr>
<tr>
<td>description, modifying</td>
<td>649</td>
</tr>
<tr>
<td>overview</td>
<td>644</td>
</tr>
<tr>
<td>running</td>
<td>648</td>
</tr>
<tr>
<td>tasks, adding</td>
<td>647</td>
</tr>
<tr>
<td>tasks, deleting</td>
<td>654</td>
</tr>
<tr>
<td>tasks, modifying</td>
<td>653</td>
</tr>
<tr>
<td>single-user mode</td>
<td>465</td>
</tr>
<tr>
<td>setting</td>
<td>465</td>
</tr>
<tr>
<td>skills</td>
<td>233</td>
</tr>
<tr>
<td>multi-agent, changing</td>
<td>233</td>
</tr>
<tr>
<td>multiple agents, changing</td>
<td>232</td>
</tr>
<tr>
<td>VDN, configuring preferences</td>
<td>267</td>
</tr>
<tr>
<td>Solaris</td>
<td>613</td>
</tr>
<tr>
<td>changing user passwords</td>
<td>617</td>
</tr>
<tr>
<td>local login</td>
<td>614</td>
</tr>
<tr>
<td>printer commands</td>
<td>619</td>
</tr>
<tr>
<td>remote login</td>
<td>614</td>
</tr>
<tr>
<td>split</td>
<td>236</td>
</tr>
<tr>
<td>extension assignments, changing</td>
<td>236</td>
</tr>
<tr>
<td>extensions, moving</td>
<td>239</td>
</tr>
<tr>
<td>members report, running</td>
<td>242</td>
</tr>
</tbody>
</table>

split/skill
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>trunk group name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>163</td>
</tr>
<tr>
<td>deleting</td>
<td>167</td>
</tr>
<tr>
<td>listing all</td>
<td>164</td>
</tr>
<tr>
<td>modifying</td>
<td>166</td>
</tr>
<tr>
<td>trunk group names</td>
<td>162</td>
</tr>
<tr>
<td>listing all</td>
<td>165</td>
</tr>
<tr>
<td>trunk string values</td>
<td>169</td>
</tr>
<tr>
<td>field descriptions</td>
<td>171</td>
</tr>
<tr>
<td>modifying</td>
<td>170</td>
</tr>
<tr>
<td>viewing</td>
<td>170</td>
</tr>
<tr>
<td>settings, viewing</td>
<td>282</td>
</tr>
<tr>
<td>trunk group name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>163</td>
</tr>
<tr>
<td>deleting</td>
<td>167</td>
</tr>
<tr>
<td>listing all</td>
<td>164</td>
</tr>
<tr>
<td>modifying</td>
<td>166</td>
</tr>
<tr>
<td>trunk group names</td>
<td>162</td>
</tr>
<tr>
<td>listing all</td>
<td>165</td>
</tr>
<tr>
<td>trunk string values</td>
<td>169</td>
</tr>
<tr>
<td>field descriptions</td>
<td>171</td>
</tr>
<tr>
<td>modifying</td>
<td>170</td>
</tr>
<tr>
<td>viewing</td>
<td>170</td>
</tr>
<tr>
<td>settings, viewing</td>
<td>282</td>
</tr>
<tr>
<td>trunk group name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>163</td>
</tr>
<tr>
<td>deleting</td>
<td>167</td>
</tr>
<tr>
<td>listing all</td>
<td>164</td>
</tr>
<tr>
<td>modifying</td>
<td>166</td>
</tr>
<tr>
<td>trunk group names</td>
<td>162</td>
</tr>
<tr>
<td>listing all</td>
<td>165</td>
</tr>
<tr>
<td>trunk string values</td>
<td>169</td>
</tr>
<tr>
<td>field descriptions</td>
<td>171</td>
</tr>
<tr>
<td>modifying</td>
<td>170</td>
</tr>
<tr>
<td>viewing</td>
<td>170</td>
</tr>
<tr>
<td>settings, viewing</td>
<td>282</td>
</tr>
<tr>
<td>trunk group name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>163</td>
</tr>
<tr>
<td>deleting</td>
<td>167</td>
</tr>
<tr>
<td>listing all</td>
<td>164</td>
</tr>
<tr>
<td>modifying</td>
<td>166</td>
</tr>
<tr>
<td>trunk group names</td>
<td>162</td>
</tr>
<tr>
<td>listing all</td>
<td>165</td>
</tr>
<tr>
<td>trunk string values</td>
<td>169</td>
</tr>
<tr>
<td>field descriptions</td>
<td>171</td>
</tr>
<tr>
<td>modifying</td>
<td>170</td>
</tr>
<tr>
<td>viewing</td>
<td>170</td>
</tr>
<tr>
<td>settings, viewing</td>
<td>282</td>
</tr>
<tr>
<td>trunk group name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>163</td>
</tr>
<tr>
<td>deleting</td>
<td>167</td>
</tr>
<tr>
<td>listing all</td>
<td>164</td>
</tr>
<tr>
<td>modifying</td>
<td>166</td>
</tr>
<tr>
<td>trunk group names</td>
<td>162</td>
</tr>
<tr>
<td>listing all</td>
<td>165</td>
</tr>
<tr>
<td>trunk string values</td>
<td>169</td>
</tr>
<tr>
<td>field descriptions</td>
<td>171</td>
</tr>
<tr>
<td>modifying</td>
<td>170</td>
</tr>
<tr>
<td>viewing</td>
<td>170</td>
</tr>
<tr>
<td>settings, viewing</td>
<td>282</td>
</tr>
<tr>
<td>trunk group name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>163</td>
</tr>
<tr>
<td>deleting</td>
<td>167</td>
</tr>
<tr>
<td>listing all</td>
<td>164</td>
</tr>
<tr>
<td>modifying</td>
<td>166</td>
</tr>
<tr>
<td>trunk group names</td>
<td>162</td>
</tr>
<tr>
<td>listing all</td>
<td>165</td>
</tr>
<tr>
<td>trunk string values</td>
<td>169</td>
</tr>
<tr>
<td>field descriptions</td>
<td>171</td>
</tr>
<tr>
<td>modifying</td>
<td>170</td>
</tr>
<tr>
<td>viewing</td>
<td>170</td>
</tr>
<tr>
<td>settings, viewing</td>
<td>282</td>
</tr>
<tr>
<td>trunk group name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>163</td>
</tr>
<tr>
<td>deleting</td>
<td>167</td>
</tr>
<tr>
<td>listing all</td>
<td>164</td>
</tr>
<tr>
<td>modifying</td>
<td>166</td>
</tr>
<tr>
<td>trunk group names</td>
<td>162</td>
</tr>
<tr>
<td>listing all</td>
<td>165</td>
</tr>
<tr>
<td>trunk string values</td>
<td>169</td>
</tr>
<tr>
<td>field descriptions</td>
<td>171</td>
</tr>
<tr>
<td>modifying</td>
<td>170</td>
</tr>
<tr>
<td>viewing</td>
<td>170</td>
</tr>
<tr>
<td>settings, viewing</td>
<td>282</td>
</tr>
<tr>
<td>trunk group name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>163</td>
</tr>
<tr>
<td>deleting</td>
<td>167</td>
</tr>
<tr>
<td>listing all</td>
<td>164</td>
</tr>
<tr>
<td>modifying</td>
<td>166</td>
</tr>
<tr>
<td>trunk group names</td>
<td>162</td>
</tr>
<tr>
<td>listing all</td>
<td>165</td>
</tr>
<tr>
<td>trunk string values</td>
<td>169</td>
</tr>
<tr>
<td>field descriptions</td>
<td>171</td>
</tr>
<tr>
<td>modifying</td>
<td>170</td>
</tr>
<tr>
<td>viewing</td>
<td>170</td>
</tr>
<tr>
<td>settings, viewing</td>
<td>282</td>
</tr>
<tr>
<td>trunk group name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>163</td>
</tr>
<tr>
<td>deleting</td>
<td>167</td>
</tr>
<tr>
<td>listing all</td>
<td>164</td>
</tr>
<tr>
<td>modifying</td>
<td>166</td>
</tr>
<tr>
<td>trunk group names</td>
<td>162</td>
</tr>
<tr>
<td>listing all</td>
<td>165</td>
</tr>
<tr>
<td>trunk string values</td>
<td>169</td>
</tr>
<tr>
<td>field descriptions</td>
<td>171</td>
</tr>
<tr>
<td>modifying</td>
<td>170</td>
</tr>
<tr>
<td>viewing</td>
<td>170</td>
</tr>
<tr>
<td>settings, viewing</td>
<td>282</td>
</tr>
<tr>
<td>V</td>
<td></td>
</tr>
<tr>
<td>VDN</td>
<td></td>
</tr>
<tr>
<td>call profile, adding</td>
<td>294</td>
</tr>
<tr>
<td>call profile, deleting</td>
<td>299</td>
</tr>
<tr>
<td>call profile, modifying</td>
<td>297</td>
</tr>
<tr>
<td>call profile, viewing</td>
<td>296</td>
</tr>
<tr>
<td>call profiles</td>
<td>293</td>
</tr>
<tr>
<td>exceptions, adding</td>
<td>351</td>
</tr>
<tr>
<td>exceptions, deleting</td>
<td>355</td>
</tr>
<tr>
<td>exceptions, modifying</td>
<td>353</td>
</tr>
<tr>
<td>exceptions, report</td>
<td>358</td>
</tr>
<tr>
<td>skill preferences</td>
<td>267</td>
</tr>
<tr>
<td>skill preferences, changing</td>
<td>268</td>
</tr>
<tr>
<td>skill preferences, configuring</td>
<td>267</td>
</tr>
<tr>
<td>skill preferences, listing all</td>
<td>271</td>
</tr>
<tr>
<td>skill preferences, viewing</td>
<td>269</td>
</tr>
<tr>
<td>user permissions, adding</td>
<td>452</td>
</tr>
<tr>
<td>user permissions, deleting</td>
<td>459</td>
</tr>
<tr>
<td>user permissions, listing all</td>
<td>456</td>
</tr>
<tr>
<td>user permissions, modifying</td>
<td>457</td>
</tr>
<tr>
<td>user permissions, viewing</td>
<td>454</td>
</tr>
<tr>
<td>VDN name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>174</td>
</tr>
<tr>
<td>deleting</td>
<td>178</td>
</tr>
<tr>
<td>listing all</td>
<td>176</td>
</tr>
<tr>
<td>modifying</td>
<td>177</td>
</tr>
<tr>
<td>viewing</td>
<td>175</td>
</tr>
<tr>
<td>VDN names</td>
<td>173</td>
</tr>
<tr>
<td>VDN-to-vector assignments</td>
<td>288</td>
</tr>
<tr>
<td>modifying</td>
<td>291</td>
</tr>
<tr>
<td>viewing all</td>
<td>289</td>
</tr>
<tr>
<td>viewing by vector</td>
<td>290</td>
</tr>
<tr>
<td>vector</td>
<td></td>
</tr>
<tr>
<td>configuration report</td>
<td>301</td>
</tr>
<tr>
<td>configuration report, running</td>
<td>302</td>
</tr>
<tr>
<td>exceptions</td>
<td>362</td>
</tr>
<tr>
<td>exceptions, adding</td>
<td>363</td>
</tr>
<tr>
<td>exceptions, deleting</td>
<td>367</td>
</tr>
<tr>
<td>exceptions, modifying</td>
<td>365</td>
</tr>
<tr>
<td>exceptions, report</td>
<td>369</td>
</tr>
<tr>
<td>user permissions, adding</td>
<td>441</td>
</tr>
<tr>
<td>user permissions, deleting</td>
<td>448</td>
</tr>
<tr>
<td>user permissions, listing all</td>
<td>445</td>
</tr>
<tr>
<td>user permissions, modifying</td>
<td>446</td>
</tr>
<tr>
<td>user permissions, viewing</td>
<td>443</td>
</tr>
<tr>
<td>vector name</td>
<td></td>
</tr>
<tr>
<td>adding</td>
<td>181</td>
</tr>
<tr>
<td>deleting</td>
<td>185</td>
</tr>
</tbody>
</table>
listing all ........................................ 183
modifying ........................................ 184
viewing ........................................ 182
vector names ..................................... 180
viewing an AUX reason code name ............ 88
viewing generic string values .................... 123

W
week
  beginning of .................................... 516
  end of .......................................... 516
work day
  start time .................................... 516
  stop time .................................... 516