The process of transmitting data and call messaging between the Meridian 1 and Contact Center Manager is proprietary to Nortel Networks. Any other use of the data and the transmission process is a violation of the user license unless specifically authorized in writing by Nortel Networks prior to such use. Violations of the license by alternative usage of any portion of this process or the related hardware constitutes grounds for an immediate termination of the license and Nortel Networks reserves the right to seek all allowable remedies for such breach.

This page and the following page are considered the title page, and contain Nortel Networks and third-party trademarks.
# Contents

## 1 Getting started

- New in this release ................................................................. 14
- Overview .................................................................................. 18
- About Contact Center Manager Administration and Server Utility .... 19
- How to use this guide ............................................................... 24
- Skills you need ......................................................................... 27
- Related documents ................................................................. 29
- How to get help ......................................................................... 32

## 2 Contact Center setup and management tasks

- Telephony switch configuration tasks ........................................ 36
- Contact Center configuration tasks ......................................... 38

## Part 1 Contact Center Manager Administration

## 3 Getting started with Contact Center Manager Administration

- Overview .................................................................................. 46
- To start Contact Center Manager Administration .................... 52

## 4 Configuration

- Overview .................................................................................. 66
- What is new in Configuration .................................................. 67
- To add and configure contact center servers ............................ 70
- Configuring resources ............................................................. 74
- Using the Configuration user interface to configure resources .... 75
- To upload configuration data using the Configuration Tool spreadsheets ... 78

## 5 Contact Center Management

- What is new in Contact Center Management .......................... 92
- Overview .................................................................................. 94
Supervisors view ......................................................... 97
Agents view .......................................................... 101
Skillsets view .......................................................... 107
Assignments view .................................................... 110
Network Agent Admin view ........................................ 113
To add Contact Center Manager Server users .............. 117
Default Queue Management ...................................... 124
Using the XML automated assignments feature ............. 127

6 Access and Partition Management .............................. 137
What is new in Access and Partition Management .......... 138
Overview .............................................................. 140
Access classes ......................................................... 145
Report groups ......................................................... 159
Standard partitions and reporting agents .................... 162
User-defined partitions ............................................. 171
Contact Center Manager Administration users ............ 178
Partitions in Historical Reporting, Real-Time Reporting, and Contact Center Management ......................... 184
Access and Partition Management Reports .................. 194
To upgrade from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0 ......................... 196

7 Real-Time Reporting ................................................ 203
Overview .............................................................. 204

8 Historical Reporting ................................................ 207
Overview .............................................................. 208
Report Creation Wizard ............................................. 209

9 Audit Trail ............................................................ 211
Overview .............................................................. 212
Audit Trail events ..................................................... 214

10 Scripting .............................................................. 225
What is new in Scripting ............................................. 226
Overview .............................................................. 228
To view, create, edit, validate, activate, and export scripts .............................................................................. 229
To view and create script variables. ........................................ 234
To view, edit, and assign application threshold classes ............... 237
To work with sample scripts. .............................................. 239
To check variables for referencing scripts .............................. 241

11 Outbound Campaign Management Tool 243
  Overview ................................................................. 244
  To launch the Outbound Campaign Management Tool ............ 248
  To create a campaign .................................................. 251
  To modify campaigns ................................................... 267
  To review campaign progress and results ......................... 269
  To create and preview an agent script .............................. 274
  To define disposition codes ......................................... 277
  To view log files ...................................................... 279
  To archive outbound campaigns .................................... 283

12 Server performance 285
  Tips for optimum server performance ............................... 286

13 License Manager Service for Report Creation Wizard 289
  Overview ................................................................. 290
  Windows event logging ................................................ 291
  Audit Trail logging ..................................................... 295
  Debug log files ....................................................... 296

Part 2 Contact Center Manager Server Utility 297

14 Getting started with the Server Utility 299
  Overview ................................................................. 300
  To log on to the server ................................................ 301
  Overview of the Server Utility window ............................ 305
  Overview of PC Event Browser ...................................... 306
  Overview of the Provider application ............................. 307
  Overview of Service Monitor (for networking) ................. 309
## 15 User Administration

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>312</td>
</tr>
<tr>
<td><strong>Section A: To work with access classes</strong></td>
<td>315</td>
</tr>
<tr>
<td>Overview of access classes</td>
<td>316</td>
</tr>
<tr>
<td>To add access classes</td>
<td>317</td>
</tr>
<tr>
<td>To view the members of an access class</td>
<td>321</td>
</tr>
<tr>
<td>Other procedures for access classes</td>
<td>323</td>
</tr>
<tr>
<td>Functions and privileges</td>
<td>324</td>
</tr>
<tr>
<td><strong>Section B: To work with desktop user accounts</strong></td>
<td>333</td>
</tr>
<tr>
<td>Overview of desktop user accounts</td>
<td>334</td>
</tr>
<tr>
<td>To add desktop user accounts</td>
<td>335</td>
</tr>
<tr>
<td>To control access to the server</td>
<td>338</td>
</tr>
<tr>
<td>To reset desktop passwords</td>
<td>341</td>
</tr>
<tr>
<td>Other procedures for desktop users</td>
<td>343</td>
</tr>
<tr>
<td><strong>Section C: To manage user sessions</strong></td>
<td>345</td>
</tr>
<tr>
<td>To view connected users</td>
<td>346</td>
</tr>
<tr>
<td>To log users off</td>
<td>347</td>
</tr>
</tbody>
</table>

## 16 System configuration

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>350</td>
</tr>
<tr>
<td>System configuration settings</td>
<td>351</td>
</tr>
<tr>
<td>System performance monitoring</td>
<td>353</td>
</tr>
</tbody>
</table>

## 17 Voice Prompt Editor in Meridian Mail

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>356</td>
</tr>
<tr>
<td>To log on and off the Voice Prompt Editor</td>
<td>358</td>
</tr>
<tr>
<td><strong>Section A: To work with voice files</strong></td>
<td>361</td>
</tr>
<tr>
<td>To create a voice file</td>
<td>362</td>
</tr>
<tr>
<td>To open a voice file</td>
<td>364</td>
</tr>
<tr>
<td>Other procedures for voice files</td>
<td>366</td>
</tr>
<tr>
<td><strong>Section B: To work with voice segments</strong></td>
<td>369</td>
</tr>
<tr>
<td>To create a voice segment</td>
<td>370</td>
</tr>
<tr>
<td>To record a voice segment</td>
<td>371</td>
</tr>
<tr>
<td>To play a voice segment</td>
<td>372</td>
</tr>
<tr>
<td>To create and play a group of voice segments</td>
<td>373</td>
</tr>
<tr>
<td>To search for a voice segment</td>
<td>375</td>
</tr>
<tr>
<td>To edit a voice segment length</td>
<td>377</td>
</tr>
</tbody>
</table>
To edit the length of all voice segments in a voice file ........................................ 380
Other procedures for voice segments ................................................................. 382

18 Alarms and events 383
Overview ................................................. 384

Section A: To view events 387
Overview ................................................. 388
To open the Event Browser ............................................. 390
To view online Help for an event ........................................... 392
To save a list of events from the Event Browser ................................. 393
To change the filtering criteria for events ........................................ 395

Section B: To manage event preferences 399
Overview ................................................. 400
To add event preferences ............................................. 401
To throttle all events ............................................. 403
Other procedures for event preferences ........................................ 405

Section C: To use the Alarm Monitor 407
Overview ................................................. 408
To view events in the Alarm Monitor ........................................ 409
To clear active alarms ............................................. 412

19 Server backup 415
Overview ................................................. 416
To schedule a backup ............................................. 417
To monitor backups ............................................. 422
Other procedures for backups ........................................ 423

Part 3 Appendixes 425

A CS 1000 Data Extraction Tool 427
Overview ................................................. 428

Section A: To install the CS1000 Data Extraction Tool 429
System requirements ............................................. 430
To install the CS1000 Data Extraction Tool ........................................ 431
To uninstall the CS1000 Data Extraction Tool ........................................ 433
Section B: To use the CS1000 Data Extraction Tool
To extract data from the CS 1000/Meridian 1 ................................. 436
Error messages ................................................................. 446

Section C: To capture the CS 1000/Meridian 1 data output
Overview ................................................................. 448
To capture Terminal Number data ......................................... 449
To capture voice port data ................................................... 451
To capture CDN data ......................................................... 452
To capture IVR ACD-DN data ............................................... 453

B Supervisor/reporting agents matrix
Overview ................................................................. 456
Real-Time Reporting ....................................................... 457
Historical Reporting ........................................................ 465
Contact Center Management ............................................... 468

C Configuration data tables
Overview ................................................................. 472
CS1000/Meridian 1 Nodal Configuration ............................ 473
CS1000/Meridian 1 configuration ......................................... 477
CS2x00/DMS configuration ................................................. 482
Network Control Center configuration .............................. 488

D Troubleshooting
Technical support ............................................................. 490

Section A: General troubleshooting items
CCMA functions incorrectly following a change to the CCMS ........ 492
You have display problems on the client PC ......................... 494
Problems while running two sessions on one client PC ............. 495
System tree icons are missing ............................................. 496
Problems with Select All in CCMA components .................. 497
Contents from the about:blank Web site blocked by IE Enhanced Security Configuration ........................................ 499
You cannot launch CCMA windows; pop-ups are blocked ........ 500
Contact Center Manager Administration logon screen displays
ERROR:UNKNOWN! ......................................................... 502

Section B: Access and Partition Management
Cannot view agents or skillsets in User Defined Partitions view .... 504
February 2009

Cannot create Report Groups due to failure of XML counter upgrade . . . . 505
Section C: Contact Center Management
507
“No Supervisors Defined” error messages appear in Contact Center
Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 508
Section D: Historical Reporting
509
You cannot access a report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 510
You cannot print scheduled reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 512
Network call-by-call reports are missing data . . . . . . . . . . . . . . . . . . . . . . . 514
Problem connecting to the data source in Historical Reporting . . . . . . . . . . 515
The report viewer is blank when you launch an ad hoc report . . . . . . . . . . . 516
Cannot synchronize imported reports; access denied on the network drive. 517
Cannot synchronize imported reports; cannot copy to CCMA server . . . . . 518
Cannot connect to the data source . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 519
Cannot import custom report templates; ASP script timeout error occurs . . 520
Exporting large reports to PDF causes error message . . . . . . . . . . . . . . . . . 521
Last column of a report is cut off . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 522
Section E: Real-Time Reporting
523
You cannot launch real-time displays. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 524
Real-time displays are blank. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 525
No names appear in real-time displays . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 530
New Web pages replace real-time displays in the same browser . . . . . . . . . 531
Real-time displays do not show any data . . . . . . . . . . . . . . . . . . . . . . . . . . . 532
RTDs missing information after you uninstall ActiveXControl.msi . . . . . . 533
Agent map does not launch after you upgrade SWC 4.5 to CCMA 6.0. . . . 534
Real-time displays crash when you add %Skillset_Abdnd_Aft_Th. . . . . . . 535
Site does not appear in NCRTD when added by IP address. . . . . . . . . . . . . 536
Modified agent names are not reflected in the Standard Agent Display . . . 537
Real-time displays do not work after you reboot or update CCMA. . . . . . . 538
New agents appear as UNKNOWN in real-time displays . . . . . . . . . . . . . . 539
Performance issues when using RTD filters and user-defined partitions. . . 540
Number of Calls Waiting in the Application and Skillset Realtime Displays Do
Not Match . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 541
Number of Contacts Waiting in the Skillset Realtime Displays May Not Match
CCAD Contact Query Result . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 542
Section F: Report Creation Wizard
543
Cannot obtain or release a license. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 544
Launching RCW: Crystal RAS service fails to start. . . . . . . . . . . . . . . . . . . 545
RCW reports fail to run in Historical Reporting. . . . . . . . . . . . . . . . . . . . . . 547

Administrator’s Guide

xi


Glossary  549

Index  589
Chapter 1

Getting started

In this chapter

New in this release 14
Overview 18
About Contact Center Manager Administration and Server Utility 19
How to use this guide 24
Skills you need 27
Related documents 29
How to get help 32
New in this release

The following sections detail what is new in the Nortel Contact Center Manager Administrator’s Guide (297-2183-927) for release 10.01.

- “Features” on page 14
- “Other changes” on page 16

Features

See the following sections for information about feature changes:

- “Contact Center Manager Server Utility” on page 14
- “Outbound Campaign Management Tool” on page 15
- “Connection status and server time” on page 15
- “Configuration” on page 15
- “Contact Center Management” on page 15
- “Access and Partition Management” on page 15
- “Scripting” on page 16
- “CS1000 Data Extraction Tool” on page 16
- “Updates to GIVE IVR for Communication Server 2X00/DMS” on page 16

Contact Center Manager Server Utility

The Contact Center Manager Server Utility is a streamlined version of the Symposium Call Center Server Release 5.0 Classic Client—it provides server maintenance and monitoring functions and retains the same look and feel as the Classic Client. By using the Contact Center Manager Server Utility, you can retire the traditional Classic Client as functions previously available in the Classic Client are now available through Server Utility. The Contact Center Manager Server Utility affects the following sections:

- “Getting started with the Server Utility” on page 299
- “User Administration” on page 311
- “System configuration” on page 349
- “Voice Prompt Editor in Meridian Mail” on page 355
Outbound Campaign Management Tool
Contact Center Manager Release 6.0 delivers integrated outbound capability and an Outbound Campaign Management Tool, which the outbound administrator can launch from the Contact Center Manager Administration launchpad window. Administrators can use this tool to import contact data, define campaign parameters, create agent call scripts, and monitor campaign results. The new Outbound Campaign Management Tool affects the following sections:

- “Outbound Campaign Management Tool” on page 243

Connection status and server time
You can launch the Connection Status window from the menu bar within any application. The Connection Status window displays a list of servers currently administered by Contact Center Manager Administration, along with the local time on each server and the connection status of each server.

Configuration
There are several enhancements available in the Configuration component. The Configuration enhancements affect the following section:

- “What is new in Configuration” on page 67

Contact Center Management
There are several enhancements available in the Contact Center Management component. The Contact Center Management enhancements affect the following section:

- “What is new in Contact Center Management” on page 92

Access and Partition Management
There are several enhancements available in the Access and Partition Management component. The Access and Partition Management enhancements affect the following section:

- “What is new in Access and Partition Management” on page 138
**Scripting**
There are several enhancements available in the Scripting component. The Scripting enhancements affect the following section:

- “What is new in Scripting” on page 226

**CS1000 Data Extraction Tool**
The CS1000 Data Extraction Tool runs on a PC with the following additional operating systems installed:

- Vista Business
- Vista Enterprise

For more information, see “System requirements” on page 430.

**Updates to GIVE IVR for Communication Server 2X00/DMS**
The GIVE IVR command for scripting has an optional TREATMENT variable. See “GIVE IVR command” on page 227.

**Other changes**
See the following sections for information about changes that are not feature-related.

- “Audit Trail” on page 16
- “License Manager Service for Report Creation Wizard” on page 17
- “User-defined partitions” on page 17
- “VERITAS Backup 9.1” on page 17
- “SIP CDN URI” on page 17
- “Real-time Reporting data” on page 17

**Audit Trail**
The location of saved Audit Trail events was added to the Audit Trail “Overview” on page 212. New events were added to “Audit Trail events” on page 214.
License Manager Service for Report Creation Wizard
A new section “License Manager Service for Report Creation Wizard” on page 289 was added.

User-defined partitions
When you work with real-time display filters and user-defined partitions, it can negatively impact performance in Contact Center Manager Administration. For more information, see “Performance issues when using RTD filters and user-defined partitions” on page 540.

VERITAS Backup 9.1
When you install VERITAS Backup 9.1, it uses the default TCP port setting of 10 000, which is also the default port for the Contact Center Manager Administration Toolkit Name Service. For more information, see “New agents appear as UNKNOWN in real-time displays” on page 539.

Added configuration data
A list of the configuration data tables is found in the appendices of the document. The list contains the information in the configuration section of the Contact Center Manager Administration Server.

SIP CDN URI
A description about SIP CDN URI as been updated in “What is new in configuration” on page 69.

Real-time Reporting data
Updated information about the number of Calls Waiting in the Application and Skillset Real-time Displays on page 541.
Overview

The Contact Center Manager Administrator’s Guide provides information about how to configure and manage Contact Center Manager Administration.

This guide provides instructions to perform administrative tasks using two applications: Contact Center Manager Administration (for all configuration and administration tasks) and the Contact Center Manager Server Utility (for monitoring the server). These applications have online Help available with step-by-step instructions to perform each administrative task.

Restricted access to this guide

This guide contains sensitive information about how to maintain Contact Center Manager Server, including passwords, procedures, and information that can damage the system if used incorrectly. Nortel recommends that access to this guide be restricted to senior administrators only.

Optional features

Some features described in this guide are optional. To determine which features you have access to, Nortel supplies a special code called a license manager file that you use when you install the Contact Center Manager software. Fields and commands for features that you did not purchase are not available.
About Contact Center Manager Administration and Server Utility

This section provides a high-level overview of the two applications available to help you manage your contact center:

- **Contact Center Manager Administration**—provides all configuration, administration, and maintenance functions
- **Server Utility**—provides additional server monitoring functions.

This section also provides a task matrix outlining in which application you perform certain tasks.

For more information, see “Contact Center Manager Administration” on page 43 or “Contact Center Manager Server Utility” on page 297.

Contact Center Manager Administration

Contact Center Manager Administration is a browser-based tool that helps you maintain and configure contact centers and their users. While Contact Center Manager Administration is primarily used by contact center administrators and supervisors, it can also be used by team leaders, work force management, reporting teams, and managers, as well as by the information technology team that supports Contact Center Manager Administration.

Contact Center Manager Administration consists of the following components:

- Contact Center Management
- Access and Partition Management
- Configuration
- Scripting
- Outbound
- Real-Time Reporting
- Historical Reporting
- Emergency Help
Server Utility

The Server Utility is an application with maintenance and monitoring utilities, not available in Contact Center Manager Administration, for the Contact Center Manager Server Release 6.0 server and the Symposium Call Center Server Release 5.0 server. While an administrator can use the Server Utility for some functions (for example, Voice Prompt Editor or Desktop Users), the Server Utility is primarily used by the Information Technology support group.

The Server Utility consists of the following components:

- User Administration
- System Administration
- Provider
- Service Monitor

The components that are available in the system tree depend on the telephony switch type and the user’s permissions.

User Administration

You can use the User Administration component to create desktop users and access classes. Descriptions for users and access classes follow:

- **Users**—Use Server Utility to create desktop user accounts that can access the Contact Center Manager Server. Desktop users can include wallboard users, database users, third-party application users, and Open Database Connectivity (ODBC) connections.

- **Access Classes**—Access Classes created in the Server Utility identify access levels for Server Utility users. Access classes created in the Server Utility do not affect Contact Center Manager Administration users.
System Administration
The following subcomponents are available in the System Administration component:

- **System Configuration**
  - **Serial Ports**—view or edit serial port settings
  - **Switch Resource**—view telephony switch information
  - **Voice Prompt Editor**—create voice segments in Meridian Mail for use in scripts
  - **Server Settings**—view detailed server resource information
  - **Connected Sessions**—view connected users and disconnect users

- **Server Backup**
  - **Backup Scheduler**—schedule a backup to run before and after major system operations take place

- **Alarms and Events**
  - **Alarm Monitor**—view details of active alarms on the system
  - **Event Browser**—view system events
  - **Event Preferences**—specify event logging frequency and event severities

- **System Performance Monitoring**
  - **Server Performance Monitor**—view server operating conditions (for example, processor capacity, memory, or storage space)

Provider
The Provider application receives Contact Center script information over the Host Data Exchange (HDX) interface. Additionally, it can be configured to return information to the Contact Center script.

Service Monitor (for networking)
With the Service Monitor, you can monitor the status of Contact Center Manager Server services from a stand-alone computer. The information returned is similar to the information provided by SMONW.
**Task matrix**

This table provides a high-level list of administration and monitoring tasks described in this guide and indicates which application you use to perform the tasks. The chapters that follow describe the tasks in detail.

<table>
<thead>
<tr>
<th>To perform this task</th>
<th>Use this application</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set up Server Utility (add desktop user accounts and access classes)</td>
<td>Contact Center Manager Server Utility</td>
</tr>
<tr>
<td>Add and configure contact center servers</td>
<td>Contact Center Manager Administration (Configuration component)</td>
</tr>
<tr>
<td>Configure telephony switch resources on the server</td>
<td>Contact Center Manager Administration (Configuration component)</td>
</tr>
<tr>
<td>Create Contact Center Manager Server users (agents, supervisors, and supervisor/agents)</td>
<td>Contact Center Manager Administration (Contact Center Management component)</td>
</tr>
<tr>
<td>Configure agent-to-supervisor and agent-to-skillset assignments</td>
<td>Contact Center Manager Administration (Contact Center Management component)</td>
</tr>
<tr>
<td>Create report groups</td>
<td>Contact Center Manager Administration (Access and Partition Management component)</td>
</tr>
<tr>
<td>Create access classes for Contact Center Manager Administration users</td>
<td>Contact Center Manager Administration (Access and Partition Management component)</td>
</tr>
<tr>
<td><strong>To perform this task</strong></td>
<td><strong>Use this application</strong></td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------------------------</td>
</tr>
<tr>
<td>Create user-defined partitions (if required)</td>
<td>Contact Center Manager Administration (Access and Partition Management component)</td>
</tr>
<tr>
<td>Create Contact Center Manager Administration users and assign access rights, standard partitions, user-defined partitions (if created), access classes, and supervisor/reporting agent combinations</td>
<td>Contact Center Manager Administration (Access and Partition Management component)</td>
</tr>
<tr>
<td>Create and edit scripts and variables</td>
<td>Contact Center Manager Administration (Scripting component)</td>
</tr>
<tr>
<td>Record voice prompts (in Meridian Mail) (CS 1000/Meridian 1 only)</td>
<td>Contact Center Manager Server Utility</td>
</tr>
<tr>
<td>Schedule Contact Center Manager Server backups</td>
<td>Contact Center Manager Server Utility</td>
</tr>
<tr>
<td>View Audit Trail</td>
<td>Contact Center Manager Administration (Audit Trail component)</td>
</tr>
<tr>
<td>Monitor system configuration and server performance</td>
<td>Contact Center Manager Server Utility</td>
</tr>
<tr>
<td>View Contact Center Manager Server alarms and events</td>
<td>Contact Center Manager Server Utility</td>
</tr>
<tr>
<td>Record voice prompts (in CallPilot)</td>
<td>CallPilot application builder.</td>
</tr>
</tbody>
</table>
How to use this guide

This guide includes information and procedures for:

- Contact Center Manager Administration:
  - Configuration
  - Contact Center Management
  - Access and Partition Management
  - Real-Time Reporting
  - Historical Reporting
  - Scripting
  - Outbound
  - Audit Trail

- Server Utility:
  - Provider
  - Service Monitor
  - PC Event Browser
  - User Administration
  - System Configuration
  - Voice Prompt Editor
  - Alarms and events
  - Server Backup

This guide does not include all of the tasks that you can perform in Contact Center Manager Administration or in Server Utility. If the task you want to perform is not listed here, in the table of contents, or in the index, see the Contact Center Manager Administration online Help.
Where to start in this guide

The following table describes where to find information for Contact Center Manager Administration components and Server Utility components frequently used by administrators.

<table>
<thead>
<tr>
<th>If you want information about</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configuring resources on Contact Center Manager Server</td>
<td>Chapter 4, “Configuration”</td>
</tr>
<tr>
<td>Working in Contact Center Management</td>
<td>Chapter 5, “Contact Center Management”</td>
</tr>
<tr>
<td>Working with Supervisor/reporting agents</td>
<td>Appendix B, “Supervisor/reporting agents matrix”</td>
</tr>
<tr>
<td>Working with the Outbound Campaign Management Tool</td>
<td>Chapter 11, “Outbound Campaign Management Tool”</td>
</tr>
<tr>
<td>Working with scripts</td>
<td>Chapter 10, “Scripting”</td>
</tr>
<tr>
<td>Configuring Access Classes in Server Utility</td>
<td>“To work with access classes” on page 315</td>
</tr>
<tr>
<td>Configuring Desktop Users in Server Utility</td>
<td>“To work with desktop user accounts” on page 333</td>
</tr>
<tr>
<td>Working in Voice Prompt Editor</td>
<td>Chapter 17, “Voice Prompt Editor in Meridian Mail”</td>
</tr>
<tr>
<td>Viewing and managing alarms and events</td>
<td>Chapter 18, “Alarms and events”</td>
</tr>
<tr>
<td>Working in Backup Scheduler</td>
<td>Chapter 19, “Server backup”</td>
</tr>
</tbody>
</table>
Other documents

The following documents are now in the Contact Center Manager Administrator’s Guide.

<table>
<thead>
<tr>
<th>Document</th>
<th>For information, see</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>M1 Data Extraction Tool User Guide</em></td>
<td>“CS 1000 Data Extraction Tool” on page 427</td>
</tr>
<tr>
<td>The M1 Data Extraction Tool is now the CS1000 Data Extraction Tool.</td>
<td></td>
</tr>
<tr>
<td><em>Installation and User Guide for XML Assignments Service</em></td>
<td>“Using the XML automated assignments feature” on page 127 for user information</td>
</tr>
<tr>
<td></td>
<td><em>Contact Center Manager Administration Installation and Maintenance Guide</em> for installation information</td>
</tr>
</tbody>
</table>
Skills you need

This section describes the skills, experience, and knowledge recommended for using and administering Contact Center Manager Server.

Nortel product knowledge

Knowledge of, or experience with, the following Nortel products is helpful when you administer Contact Center Manager Server:

- Contact Center Manager Server or Symposium Call Center Server
- applicable switch platform
  - Nortel Meridian 1 PBX or Nortel Communication Server 1000
  - Communication Server 2x00/DMS (unless otherwise stated, references to CS 2x00/DMS also apply to SL-100, Nortel Communication Server 2000, and Nortel Communication Server 2100)
  - MCS 5100
- CallPilot, Meridian Mail, or Nortel SIP Media Application Server

CallPilot is available for deployment on the Communication Server 1000/ Meridian 1 PBX and CS 2x00/DMS switch family, but has voice-processing interoperability, for example GIVE IVR treatment, with the CS 1000/Meridian 1 switch only.

If CallPilot is installed on a CS 2x00/DMS switch, it can be used for menuing and routing to Contact Center Manager Server, but for GIVE IVR functionality in this environment, an IVR (Nortel MPS 500/1000) is required.

A SIP-enabled Contact Center uses the Nortel SIP Media Application Server for all tones, announcements, music, and integrated IVR. The Nortel SIP Media Application Server also provides advanced treatments such as instant messaging (IM) autoresponse and Web page push.
PC experience or knowledge

Knowledge of, or experience with, the following PC products is helpful when you administer Contact Center Manager Server:

- Microsoft Windows XP Professional SP1
- Windows 2000 Professional
- Windows Server 2003 Enterprise Edition

Other experience or knowledge

Other experience or knowledge of use to you includes:

- analytical skills
- knowledge of your contact center organizational structure and your contact center objectives
## Related documents

The following guides are available on the Contact Center portfolio DVD or on the Nortel Web site (www.nortel.com).

<table>
<thead>
<tr>
<th>For information about</th>
<th>Refer to</th>
<th>NTP number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Planning and engineering guidelines,</td>
<td><em>Nortel Contact Center Planning and Engineering Guide</em></td>
<td>297-2183-934</td>
</tr>
<tr>
<td>and server requirements</td>
<td><em>Nortel Contact Center Manager CapTool User’s Guide</em></td>
<td>297-2183-935</td>
</tr>
<tr>
<td>The Contact Center portfolio</td>
<td><em>Nortel Contact Center What is New in Release 6.0</em></td>
<td>297-2183-903</td>
</tr>
<tr>
<td>Required installation and server data</td>
<td><em>Nortel Contact Center Installer’s Roadmap</em> (see <a href="http://www.nortel.com/pic">www.nortel.com/pic</a>)</td>
<td>297-2183-226</td>
</tr>
<tr>
<td>Switch configuration</td>
<td><em>Nortel Contact Center Communication Server 1000/ Meridian 1 and Voice Processing Guide</em></td>
<td>297-2183-931</td>
</tr>
<tr>
<td></td>
<td><em>Nortel Contact Center Manager Switch Guide for Communication Server 2X00/DMS</em></td>
<td>297-2183-937</td>
</tr>
<tr>
<td></td>
<td><em>Nortel SIP Contact Center Switch Configuration Guide</em></td>
<td>297-2183-962</td>
</tr>
<tr>
<td>For information about</td>
<td>Refer to</td>
<td>NTP number</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Installation, upgrades, migration, and</td>
<td>Contact Center Manager Server Installation and Maintenance Guide</td>
<td>297-2183-925</td>
</tr>
<tr>
<td>maintenance</td>
<td>Nortel Contact Center Manager Server Installation and Maintenance Guide for the Co-resident Server</td>
<td>297-2183-218</td>
</tr>
<tr>
<td></td>
<td>Nortel Contact Center Manager Server Installation and Maintenance Guide for the Standby Server</td>
<td>297-2183-219</td>
</tr>
<tr>
<td></td>
<td>Nortel Contact Center Manager Administration Installation and Maintenance Guide</td>
<td>297-2183-926</td>
</tr>
<tr>
<td></td>
<td>Nortel Media Application Server Installation and Configuration Guide for Contact Center 6.0</td>
<td>297-2183-227</td>
</tr>
<tr>
<td>Scripting</td>
<td>Nortel Contact Center Manager Scripting Guide for Communication Server 1000/Meridian 1 PBX</td>
<td>297-2183-930</td>
</tr>
<tr>
<td></td>
<td>Nortel Contact Center Manager Scripting Guide for Communication Server 2X00/DMS</td>
<td>297-2183-936</td>
</tr>
<tr>
<td></td>
<td>Nortel Contact Center Manager Database Integration User Guide</td>
<td>297-2183-940</td>
</tr>
<tr>
<td>Networked contact center</td>
<td>Nortel Contact Center Manager Network Control Center Administrator’s Guide</td>
<td>297-2183-932</td>
</tr>
<tr>
<td>Supervising contact centers</td>
<td>Nortel Contact Center Manager Supervisor’s Guide</td>
<td>297-2183-928</td>
</tr>
<tr>
<td></td>
<td>Nortel Contact Center Historical Reporting and Data Dictionary</td>
<td>297-2183-914</td>
</tr>
<tr>
<td>For information about</td>
<td>Refer to</td>
<td>NTP number</td>
</tr>
<tr>
<td>----------------------------</td>
<td>--------------------------------------------------</td>
<td>------------</td>
</tr>
<tr>
<td>Handling contacts</td>
<td><em>Nortel Contact Center Agent Desktop User Guide</em></td>
<td>297-2183-945</td>
</tr>
<tr>
<td>Recording voice prompts</td>
<td><em>CallPilot Application Builder Guide</em></td>
<td>555-7171-325</td>
</tr>
</tbody>
</table>
How to get help

This section explains how to get help for Nortel products and services. However, before contacting Nortel for support, consult the Troubleshooting section of this guide.

Finding the latest updates on the Nortel Web site

The content of this documentation was current at the time the product was released. To check for updates to the latest documentation and software for Contact Center 6.0, click one of the following links:

<table>
<thead>
<tr>
<th>Link to</th>
<th>Takes you directly to</th>
</tr>
</thead>
<tbody>
<tr>
<td>Latest software</td>
<td>The Nortel page for Contact Center located at <a href="http://www.nortel.com/espl">www.nortel.com/espl</a>.</td>
</tr>
<tr>
<td>Latest documentation</td>
<td>The Nortel page for Contact Center documentation located at <a href="http://www.nortel.com/support">www.nortel.com/support</a>.</td>
</tr>
</tbody>
</table>

Getting help from the Nortel Web site

The best way to get technical support for Nortel products is the Nortel Technical Support Web site:

www.nortel.com/support

This site provides quick access to software, documentation, bulletins, and tools to address issues with Nortel products. From this site, you can:

- download software and related tools
- download technical documents, release notes, and product bulletins
- sign up for automatic notification of new software and documentation
- search the Technical Support Web site and Nortel Knowledge Base for answers to technical issues
- open and manage technical support cases
Getting help over the phone from a Nortel Solutions Center

If you do not find the information you require on the Nortel Technical Support Web site, and you have a Nortel support contract, you can also get help over the phone from a Nortel Solutions Center.

In North America, call 1-800-4NORTEL (1-800-466-7835).

Outside North America, go to the following Web site to obtain the phone number for your region:

www.nortel.com/callus

Getting help from a specialist by using an Express Routing Code

You can use an Express Routing Code (ERC) to more quickly route your call to the appropriate support specialist. To locate the ERC for your product or service, go to:

www.nortel.com/erc

Getting help through a Nortel distributor or reseller

If you purchased a service contract for your Nortel product from a distributor or authorized reseller, you can contact the technical support staff for that distributor or reseller.
Chapter 2

Contact Center setup and management tasks

In this chapter

Telephony switch configuration tasks 36
Contact Center configuration tasks 38
Before you can use Contact Center Manager Server with the telephony switch, you must configure the telephony switch.

To use Contact Center Manager Server with a Communication Server 2x00/DMS telephony switch, you require Intelligent Call Manager (ICM) on the telephony switch. For more information about ICM, see the ICM documentation.

**Telephony switch configuration tasks**

You must perform the following tasks to configure the telephony switch for Contact Center Manager Server.

**Communication Server 1000/Meridian 1 PBX**

If you use a CS 1000/Meridian 1 telephony switch, complete the following tasks:

- Configure CDNs.
- Configure NACD-DNs.
- Configure IVR ACD-DNs.
- Configure voice ports.
- Configure agent and supervisor phonesets.
- Configure routes.

If you use Contact Center Voice Services on either CallPilot or Meridian Mail, you must also configure the voice processing system. If you use Meridian Link, you must also configure Meridian Link.

For more information, see the *Contact Center Communication Server 1000/Meridian 1 and Voice Processing Guide*.

**Communication Server 2x00/DMS**

If you use a CS 2x00/DMS telephony switch, perform the following tasks:
Configure the server logon process.

Configure recorded announcements (RAN) and music routes, including routes for forced incoming and overflow announcements, in the ACDGRP table, and configure call treatments in the AUDIO table.

Configure the automatic call distribution (ACD) groups in the ACDGRP table.

Configure the ACD subgroups in the ACDSGRP table.

Configure ACD-DNs in the DNROUTE table.

Before you define ACD-DNs, you must define the area code and office code in the TOFCNAME table.

Configure agent and supervisor phonesets using the SERVORD utility.

Before you can configure phonesets, you must define the NCOS in the NCOS table and define features for the customer group in the CUSTHEAD table.

Define agent logon IDs in the ACDLOGIN table.

Add controlled directory numbers (CDN [Route Points]) in the table.

(optional) Configure a second ICM connection for redundancy.

For more information, see the Contact Center Manager Switch Guide for Communication Server 2X00/DMS.

**MCS 5100**

If you use an MCS 5100 telephony switch on an MCP System Management Console (thick client), configure Authentication Method.

If you use an MCS 5100 with an MCS Provisioning Client (thin client), perform the following tasks:

Create the Contact Center domains.

Create service packages for the local SIP subscriber and for CDN (Route Points).

Configure the local SIP subscriber.

For more information, see the SIP Contact Center Switch Configuration Guide.
Contact Center configuration tasks

This section provides a high-level overview of the steps you must perform to configure and maintain your contact center in the manner required to meet your contact center objectives. This section also describes where you can find more information about each task. For detailed task flow information, see the *Contact Center Planning and Engineering Guide*.

For information about planning and setting up a new system, see the *Contact Center Planning and Engineering Guide*.

For information about installing your system, see the *Contact Center Manager Server Installation and Maintenance Guide* and the *Contact Center Manager Administration Installation and Maintenance Guide*.

<table>
<thead>
<tr>
<th>Task</th>
<th>For more information, see</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Set up Server Utility (configure desktop users and access classes)</td>
<td>Chapter 15, “User Administration”&lt;br&gt;“To add and configure contact center servers” on page 70&lt;br&gt;For more information about accepting the licensing agreement, see the <em>Contact Center Manager Administration Installation and Maintenance Guide</em>.&lt;br&gt;For information about desktop user passwords, see “To add desktop user accounts” on page 335.</td>
</tr>
<tr>
<td>2 Add each Contact Center Manager Server in the network (in Contact Center Manager Administration). Before you can add a newly configured server in Contact Center Manager Administration, you must first accept the license agreement and then change the server default password. Because you cannot change the default password in the Configuration component, you must use the Server Utility to log on to new servers for the first time. After you change the default password, you can then use Contact Center Manager Administration to add the servers.</td>
<td></td>
</tr>
<tr>
<td>Task</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------</td>
</tr>
<tr>
<td>3</td>
<td>Upload Contact Center Manager Server configuration resources for each server. OR Configure and maintain each server by individually adding the resources, such as skillsets, CDNs, DNISs, threshold classes, routes, phonesets, and voice ports where applicable. Administrators must be logged on as webadmin to add and configure servers, and to upload and download configuration data. When naming CDNs, skillsets, agent names, and other resources, do not use spaces as the first character.</td>
</tr>
<tr>
<td>4</td>
<td>Upload Contact Center Manager Server user data. OR Create and maintain individual Contact Center Manager Server users (supervisors, agents, and supervisor/agents).</td>
</tr>
<tr>
<td>5</td>
<td>Assign agents to supervisors, and assign agents to skillsets.</td>
</tr>
<tr>
<td>6</td>
<td>Create required user-defined report groups for Contact Center Manager Administration users.</td>
</tr>
<tr>
<td>7</td>
<td>Define required access classes for Contact Center Manager Administration users.</td>
</tr>
<tr>
<td>Task</td>
<td>For more information, see</td>
</tr>
<tr>
<td>------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>8</td>
<td>Create the appropriate partitions for the contact center, specifying the agents, applications, skillsets, CDNs, DNISs, and report groups that belong in each partition. All agents assigned to a supervisor must also be included in the partition assigned to that supervisor. That way, the supervisor can monitor the agents in Real-Time Reporting, Historical Reporting, and Contact Center Management. If you assign the user one of the following options: Full Data Across All Servers, All Data on the selected server, or All Agents &amp; Supervisors, the user automatically see all agents. If the partition assigned to the user contains Supervisor/Reporting Agents, then the user sees all agents reporting to the selected supervisors.</td>
</tr>
<tr>
<td>9</td>
<td>Create the Contact Center Manager Administration users. Grant each user basic access rights to specific Contact Center Manager Administration components, and assign the appropriate partitions, access classes, and supervisors and their reporting agents to each user.</td>
</tr>
<tr>
<td>Task</td>
<td>For more information, see</td>
</tr>
<tr>
<td>------</td>
<td>---------------------------</td>
</tr>
<tr>
<td>10</td>
<td>Create and maintain scripts.</td>
</tr>
<tr>
<td>11</td>
<td>Configure historical statistics and real-time displays.</td>
</tr>
<tr>
<td>12</td>
<td>Record voice prompts (CS 1000/Meridian 1 only).</td>
</tr>
<tr>
<td>13</td>
<td>Record voice and video prompts (Nortel Media Application Server only)</td>
</tr>
<tr>
<td>14</td>
<td>Create custom reports.</td>
</tr>
<tr>
<td>15</td>
<td>Generate reports.</td>
</tr>
<tr>
<td>16</td>
<td>Schedule regular backups.</td>
</tr>
<tr>
<td>17</td>
<td>View the Audit Trail.</td>
</tr>
<tr>
<td>18</td>
<td>Monitor system configuration and server performance.</td>
</tr>
<tr>
<td>Task</td>
<td>For more information, see</td>
</tr>
<tr>
<td>------</td>
<td>--------------------------</td>
</tr>
<tr>
<td>19</td>
<td>View alarms and events.</td>
</tr>
</tbody>
</table>
part 1

Contact Center Manager Administration
Chapter 3

Getting started with Contact Center Manager Administration

In this chapter

Overview 46
To start Contact Center Manager Administration 52
Overview

Contact Center Manager Administration is a browser-based tool for contact center administrators and supervisors. You can use Contact Center Manager Administration to manage and configure a contact center and its users, define access to data, and view real-time and historical reports.

Contact Center Manager Administration components

Contact Center Manager Administration consists of the following components:

**Contact Center Management**
Use Contact Center Management to add, edit, view, or delete:

- users (agents, supervisors, or supervisor/agents) on a server in Contact Center Manager Server
- agent-to-supervisor assignments
- agent-to-skillset assignments

Users with the appropriate access class can also assign agents and supervisor/agents to partitions in this component.

**Access and Partition Management**
Use Access and Partition Management to add, edit, view, or delete:

- Contact Center Manager Administration users
- partitions
- access classes
- report groups for Historical Reporting
- basic access rights to different Contact Center Manager Administration components

You also use this component to assign access classes, partitions, and supervisor/reporting agent combinations to Contact Center Manager Administration users.
When you add a user in Access and Partition Management, you add a Contact Center Manager Administration user. Contact Center Manager Administration users can log on to the Contact Center Manager Administration server and use the Contact Center Manager Administration components to which they have access. To add a user (agent, supervisor, or supervisor/agent) to Contact Center Manager Server, you must use the Contact Center Management component or use the spreadsheets in the Configuration component.

Some Contact Center Manager Server users (supervisors and supervisor/agents) might also be Contact Center Manager Administration users and be given a Contact Center Manager Administration user ID and password to access the Contact Center Manager Administration server; however, many Contact Center Manager Server users never use Contact Center Manager Administration.

**Configuration**

The Configuration component helps you to configure and administer the Contact Center Manager Server. You must be logged on as webadmin to add and configure servers, and to upload and download data using the Configuration Tool spreadsheets.

Use the CS1000 Data Extraction Tool to extract configuration data from the Communication Server 1000/Meridian 1 PBX. Use the Contact Center Manager Administration Configuration Tool spreadsheets to upload the extracted data to the Contact Center Manager Server. For more information, see Appendix A, “CS 1000 Data Extraction Tool.” The CS1000 Data Extraction Tool is intended for use with the CS 1000/Meridian 1 only.

If you configure a contact center for a customer, at the customer site, you can use the Configuration component of the Contact Center Manager Administration application located at the customer site to upload the Configuration Tool spreadsheets.

**Scripting**

Contact Center Manager Server uses scripts to route calls. With the Scripting component, you can create and modify call routing instructions for your contact center using the following components:

- Script Manager
- Script Editor
- Script Variable creator
Script Command Reference

You can also apply thresholds to your applications and edit application threshold classes using the Scripting component.

The Scripting component also includes a validation tool that checks your scripts for errors before they run.

Real-Time Reporting
Contact center supervisors can use the Real-Time Reporting component to view the dynamics of contact activity. Real-time displays are available for both networked and single sites. This is an optional component.

The following standard Real-Time Reporting displays are available in Contact Center Manager Administration:

- six nodal real-time displays for single Contact Center Manager Server sites
- three network consolidated real-time displays for a network of Contact Center Manager Server sites

Historical Reporting
Use Historical Reporting to gather information about the past performance of the contact center. This is an optional component.

You can generate two types of historical reports:

- summarized historical reports, which contain totals for information gathered during a specific interval of time (for example, daily totals or weekly totals)
- event and detail reports for specific events that occurred in the contact center (for example, an Agent Activity report).

Emergency Help
When a supervisor opens the Emergency Help panel, the system notifies the supervisor automatically whenever an agent presses the Emergency key on their phoneset. Agents can press the Emergency key when they require assistance from the supervisor (for example, if the caller is abusive). The Emergency Help panel shows information about the agent, including the agent’s name, location, and time when the Emergency key was pressed.
Outbound Campaign Management Tool
Use the Outbound Campaign Management Tool component to create, schedule, and monitor outbound campaigns. This component provides interfaces for importing and reviewing call data, defining campaign parameters and agent call scripts, and reviewing campaign status. The Outbound Campaign Management Tool is not available in a SIP Contact Center.

Audit Trail
The Audit Trail records actions performed in the following components and identifies the user ID of the person who made the changes:

- **Configuration**—logs logon and logoff events of Contact Center Manager Administration users; logs initiation of site synchronization.
- **Contact Center Management**—logs when a user adds, modifies, and deletes agents, supervisors, and assignments. Logs when a user activates, deactivates, and modifies scheduled assignments and Run Now assignments.
- **Access and Partition Management**—logs when Contact Center Manager Administration users, access classes, user-defined partitions, and report groups are added, modified, and deleted.
- **Scripting**—logs scripts that are added, validated, modified, and deleted.
- **Historical Reporting**—logs when historical reports are added, modified, deleted, activated, deactivated, and imported, and logs when ad hoc reports are run.
- **Real-Time Reporting**—logs when real-time display templates and filters are added, modified, and deleted.
- **License Manager**—logs when a license is granted and released.
- **Launchpad**—logs when a user logs on and off.

Agent Desktop Display
Agent Desktop Display provides real-time skillset monitoring to agents. You must configure Agent Desktop Display on the Contact Center Manager Administration server and on client PCs that use the tool.

For more information about Agent Desktop Display, see the *Contact Center Manager Supervisor’s Guide*, the Agent Desktop Display Server online Help, and the Agent Desktop Display Client online Help.
User types in Contact Center Manager Administration

It is important to understand the difference between the Contact Center Manager Administration user and the Contact Center Manager Server user. The following table lists where each user is created.

<table>
<thead>
<tr>
<th>User type</th>
<th>User definition</th>
<th>Created in</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact Center Manager Server user</td>
<td>agents, supervisors, supervisor/agents</td>
<td>Contact Center Management or Configuration</td>
</tr>
<tr>
<td>Contact Center Manager Administration user</td>
<td>anyone who logs on to the application server and monitors the performance and activities of Contact Center Manager Server</td>
<td>Access and Partition Management</td>
</tr>
</tbody>
</table>

The role of the administrator

This chapter is intended for administrators and provides conceptual information about the components that administrators use to configure a contact center:

- Configuration
- Contact Center Management (administrative functions)
- Access and Partition Management
- Audit Trail
- Scripting

Historical Reporting procedures are normally performed by supervisors and are, therefore, described in the Contact Center Manager Supervisor’s Guide.

For conceptual information about Real-Time Reporting, Historical Reporting, Contact Center Management (supervisor functions), and Emergency Help, see the Contact Center Manager Supervisor’s Guide. For detailed procedures, see the Contact Center Manager Administration online Help.
To find out more about using a component
For information about the boxes, buttons, and procedures for using any of the components in Contact Center Manager Administration, open the component that you want to use, and then select Help > On This Window. Help for the current window appears. Click the Procedures book in the online Help table of contents to view a list of Contact Center Manager Administration procedures.

To view Help procedures specific to one component, click the component name in the table of contents, and then review the topics listed for that component.
To start Contact Center Manager Administration

Before you log on to Contact Center Manager Administration, make sure you install all required third-party applications on the client PC, including Internet Explorer Version 6.0 Service Pack 1 or later and if you install a release earlier than SU04, Microsoft SOAP toolkit 3.0. You must also configure your browser. For more information, see the Contact Center Manager Administration Installation and Maintenance Guide.

To log on to Contact Center Manager Administration for the first time

When you log on to Contact Center Manager Administration for the first time after installation, you must log on as the default administrator, webadmin. For security reasons, Nortel highly recommends that you change the default password when you first log on to the application. Contact Center Manager Administration user passwords can contain only English characters.
Logging on to the application server for the first time and changing the default password

ATTENTION
When you change the webadmin password, if you lose or forget the new password, you cannot log on to Contact Center Manager Administration as the webadmin administrator. You must uninstall and reinstall Contact Center Manager Administration to reinstate the original webadmin user account with the default password.

As a precaution, after you install Contact Center Manager Administration, log on to the application server as webadmin and create a new administrator account of your choice (for example, tempadmin), giving this user account Access and Partition Management rights. If you lose or forget your new webadmin password, you can still log on to the application server as tempadmin and change the webadmin password. For more information about adding Contact Center Manager Administration users, see the Contact Center Manager Administration online Help.

A tempadmin user with full access to Access and Partition Management has the same access privileges as a webadmin user in Access and Partition Management, but does not have access to any other components.

1 Launch Internet Explorer.

Result: The Internet Explorer window appears.

2 In the Address box, type the URL address of the Contact Center Manager Administration application server. The default URL address is http://<Application Server>.

Tip: You can save the application server address by adding it to your list of Internet Explorer Favorites.
Do not type the IP address in the Address box. Using the IP address results in problems with Scripting, Historical Reporting, Configuration, Contact Center Management, and Access and Partition Management.

**Result:** The Contact Center Manager Administration server displays the Contact Center Manager Administration main logon window.

Click **About Contact Center Manager Administration** to view a dialog box containing details of the Contact Center Manager Administration build number and Service Update version.

3. Click **Change Password**.

**Result:** The Change Password dialog box appears.

4. In the **User name** box, type your user name.
5 In the **Old password** box, type your old password.

6 In the **New password** box, type your new password.

   Contact Center Manager Administration user passwords can contain English characters only.

7 In the **Confirm password** box, reenter the new password.

   You can modify only the default user name password. You cannot change the default user name, webadmin.

8 Click **Submit**.

   **Result:** The default password is changed and the main logon window reappears.

9 In the main logon window, type the user name and the password, and then click **Login**.

   **Result:** If you installed a release earlier than SU04 and did not install the client version of the Microsoft SOAP toolkit 3.0 on the PC, a warning message appears, notifying you that you must install this software. For details about how to install the Microsoft SOAP toolkit 3.0, see the *Contact Center Manager Administration Installation and Maintenance Guide*. 
If you installed SU04 or later and configured the Contact Center Manager Administration server name as a Trusted Site or if you installed a release earlier than SU04 and configured the Contact Center Manager Administration server name as a Trusted Site and installed the client version of the Microsoft SOAP toolkit 3.0 on the PC, the Contact Center Manager Administration warning message window appears.

To accept the conditions of the message, click **OK**.

If no entry exists for the message title and the message text, the Login Warning Screen appears.

**Result:** The Contact Center Manager Server configuration window appears.

The Type box is prepopulated with CCMS. If the setup is co-resident, Contact Center Manager Server IP address and server name appear automatically.
11 In the **Server Name** box, type the server name of the Contact Center Manager Server you want to add.

Do not enter the fully qualified domain name of the server in the Server Name box. Enter the computer name of the server.

**Result:** The IP Address field automatically populates.

If the value *Unknown* appears in the IP Address box, then the server name is not registered with either the Domain Name Service (DNS) or the HOSTS table. In this case, you must update your DNS or host file on the Contact Center Manager Administration server with the name of the Contact Center Manager Server. For details, see the *Contact Center Manager Administration Technical Requirements and Operating System Configuration Guide*.

12 In the **Display Name** box, type the name of the Contact Center Manager Server as you want it to appear on the system tree in Contact Center Manager Administration.

13 In the **Login ID** box, enter a login ID for the Contact Center Manager Server.

14 In the **Password** box, enter a password for the Contact Center Manager Server.

Contact Center Manager Administration user passwords can contain only English characters.
15 Click **Reset** to clear all boxes and start over; otherwise, click **Submit** to save the server configuration.

**Result:** The server is added. The configuration utility then checks if the license agreement was accepted. If the license agreement was not accepted, you must launch the Server Utility and accept the license agreement. For instructions about how to accept the license agreement, see the *Contact Center Manager Administration Installation and Maintenance Guide*. If the License agreement was accepted, the Contact Center Manager launchpad window appears.

![Contact Center Manager Launchpad](image)

**Tip:** If you lose or forget the new webadmin password, you cannot log on to Contact Center Manager Administration as the webadmin administrator. In this case, you must uninstall and reinstall Contact Center Manager Administration to reinstate the original webadmin user account with the default password. To avoid this scenario, as a safety precaution, you can now open Access and Partition Management and create a new user account with administrator rights, such as tempadmin. If you forget or lose the new webadmin password that you entered, you can log on to the application server as tempadmin and change the webadmin password.
Configuring the Login Warning Message

The logon message is the standard message used by Microsoft Windows. This is also the same Microsoft Windows message that is displayed to users when they log on to Microsoft Windows.

Configure the message title and text in the local security policy of the Contact Center Manager Administration Server or the domain controller security policy. The domain policy message is used if it exists; otherwise, the local security policy message is used.

1. Select **Start > Programs > Administrative Tools > Local (or Domain) Security Policy.**

   **Result:** The Local Security Settings window appears.

2. In the right pane, double-click the **Local (or Domain) Policies** folder.

   **Result:** The Local (or Domain) Policies folder expands.
3  Double-click the **Security Options** folder.

**Result:** The Security Options folder expands.

![Security Options folder expanded](image)

4  In the right pane, double-click **Interactive logon: Message text for users attempting to log on**.

**Result:** The Local Policy Setting window appears.

![Local Policy Setting window](image)

5  In the box, type the message text.

6  Click **OK**.
7 In the right pane, double-click **Interactive logon: Message title for users attempting to log on**.

**Result:** The Local Security Setting window appears.

8 In the box, type the message title.

9 Click **OK**.

The message displayed combines the text configured in the Local Policy Setting and Local Security Setting windows.
Turning off the Login Warning Message

You have the option to not display the Login Warning Message in Contact Center Manager Administration even if it is configured in Windows.

1. On the Contact Center Manager Administration server, select **Start > Programs > Nortel Contact Center > Manager Administration > Configuration**.

   **Result:** The Nortel Contact Center Manager Administration Configuration window appears.

2. In the left pane, click the **Login Warning Message** folder.

3. In the right pane, click the **Change Login Warning Settings** icon.

   **Result:** The Login Warning Properties window appears.

4. Clear the **Use Login Warning Message** check box.

5. Click **OK**.

   **ATTENTION** The Use Login Warning Message setting is server-specific. If the Contact Center Manager Administration server is part of a networked contact center, you must configure this setting on each server.
Default timeout rate

Contact Center Manager Administration no longer has a default timeout rate. Your session does not time out if the application remains idle.

What is next?

After you log on to the application server for the first time, you must add and configure the servers in Contact Center Manager Server using the Configuration component. Only administrators who are logged on as webadmin can add and configure servers in Contact Center Manager Server.

For a configuration overview, see “Contact Center configuration tasks” on page 38. For conceptual information, see Chapter 4, “Configuration.”

For detailed step-by-step procedures, refer to the online Help in the Configuration component.
Chapter 4

Configuration

In this chapter
Overview 66
To add and configure contact center servers 70
Configuring resources 74
Using the Configuration user interface to configure resources 75
To upload configuration data using the Configuration Tool spreadsheets 78
Overview

You perform two main tasks using the Configuration component:

- adding, configuring, and deleting Contact Center Manager Servers
- adding, configuring, and deleting resources using one of the following methods:
  - individually using the Web-based user interface
  - uploading and downloading bulk data using the Configuration Tool spreadsheets

You must be logged on to Contact Center Manager Administration as a webadmin user to add and configure servers, and to upload and download data using the Configuration Tool spreadsheets.

This chapter provides a high-level overview of these procedures. For step-by-step procedures about using the Configuration component, see the Contact Center Manager Administration online Help.

Configuration main window

The following figure shows the Configuration main window.
What is new in Configuration

The following enhancements are available in the Contact Center Manager Administration Configuration component:

- **Adding a server on initial logon**—When you (with configuration access privileges) log on to Contact Center Manager Administration, a check is performed to locate the configured server. If the check results in no configured servers, you receive a prompt to enter the details of a Contact Center Manager Server before you can proceed to the launchpad.

- **Accepting the license agreement**—Following the check for a configured server, a check determines if the you accepted the license agreement. If not, you are directed to launch the Server Utility on the Contact Center Manager Server and to accept the license agreement.

- **Refreshing servers**—The administrator can use the Refresh Server option to obtain the latest list of feature and system information from the Contact Center Manager Server. Alternatively, the administrator can use the Refresh All Servers option to obtain the latest list of feature and system information from all Contact Center Manager Servers.

- **Viewing routing table assignment schedules**—You can view routing table assignment schedules from the NCC to a particular site in the network.

- **Synchronizing data from the NCC to a particular site in the network**—The ability to synchronize data from the NCC to a particular site in the network is a feature that exists on the Classic Client but did not exist in Symposium Web Client 4.5. In Contact Center Manager Administration, you can initiate the synchronization from within the Sites application screen through the Sync Site button.

- **Phoneset display icon**—The display template 1*24 and 1*18 phone icon is updated to reflect the Nortel telephony suite and uses the IP Phone 2004 graphic. The phoneset display icon is not available in a SIP-enabled contact center.

- **Configuration Tool: Adding Skillsets during Users Upload**—Using the Configuration Tool, you can assign skillsets to agents during upload. With prior releases, it was necessary to configure the skillsets in Contact Center Manager Administration before assigning the skillsets to agents. For Release 6.0, you can add skillsets to Contact Center Manager Server when
you upload users or you can add skillsets through Contact Center Manager Administration.

- **Configuration Tool: IVR spreadsheet**—You can use the IVR spreadsheet to upload and download IVR ACD-DNs on a Communication Server 2x00/DMS switch.

- **Configuration Tool: Threshold classes**—You can use the Threshold classes spreadsheet to upload and download IVR Threshold classes on a CS 2x00/DMS switch.

- **Global Settings**—In a SIP-enabled contact center, in the Global Settings window, you can select a selection algorithm to determine how the Media Application Server handles a treatment request from Contact Center Manager Server Scripting. The selection algorithm options are Round Robin and Linear. Linear is the default selection and is the Nortel-recommended choice.

- **Media Servers**—This is a new window in the Configuration component. In a SIP-enabled contact center, use this window to add installed media servers.

- **Media Services**—This is a new window in the Configuration component. In a SIP-enabled contact center, you can associate media services with the configured media servers in this window and you can assign priority to the media servers.

- **IVR ACD-DNs (CS 2x00/DMS switch)**—In this window, you can configure and acquire IVR ACD-DNs. You can assign an IVR threshold template to the IVR ACD-DN and you can configure an IVR ACD-DN with a maximum of seven digits.

- **Formulas (CS 2x00/DMS switch)**—You can create IVR formulas for real-time displays. All statistics available on the CS 1000/Meridian 1 are applicable on the CS 2x00/DMS.

- **Historical Statistics (CS 2x00/DMS switch)**—You can specify the number of IVR ACD-DNs to configure; collect statistics for ACD-DN, IVR, and IVR Port Login; and specify the duration of time, in days, that the IVR Voice Port statistic is stored.

- **Real-time Statistics (CS 2x00/DMS switch)**—You can select the mode to display IVR statistics.

- **Threshold Classes (CS 2x00/DMS switch)**—You can configure IVR_Template thresholds.
- **SIP URI** —To enable the server to acquire a SIP CDN (Route Point), you must first configure SIP CDN (Route Point) on the switch, and then add the SIP CDN (Route Point) to Contact Center Manager Server. When you configure a CDN on a SIP-enabled server, in the URI box type the Universal Resource Identifier of the CDN on the Media application.
To add and configure contact center servers

After you log on to Contact Center Manager Administration as the user webadmin, you can add Contact Center Manager Servers in the Configuration component by accessing the Server menu from the toolbar.

The Server menu is visible only when you log on to Contact Center Manager Administration as the webadmin user.

Before you can add a newly configured Contact Center Manager Server, you must first change the server default password. Because you cannot change this password in the Configuration component, you must use the Contact Center Manager Server Utility to log on to new servers for the first time. After you change the default password, you can then use Contact Center Manager Administration to add the servers according to the following procedure.

Server menu

The following figure shows the Server menu.

From the Server menu, you can delete existing servers, edit the properties of an existing server, or refresh a server that is already added to Contact Center Manager Administration.

You must refresh all servers configured on the Contact Center Manager Administration application if you:

- upgrade Contact Center Manager Administration
- upgrade Contact Center Manager Server
- change a Contact Center Manager Server keycode feature
- change the Contact Center Manager Server sysadmin password
Until you refresh the servers, Contact Center Manager will not work as expected. For detailed steps about how to refresh a server, see the Contact Center Manager Administration online Help.

**Adding a Contact Center Manager Server**

1. In the Configuration component, from the menu, select **Server > Add Server**.

   **Result:** The Contact Center Manager Server Properties window appears.

2. In the **Server Name** box, type the name of the Contact Center Manager Server. Do not enter the fully qualified domain name of the server in the **Server Name** box. Enter the computer name of the server.
3 Press Tab.

**Result:** The server IP address automatically appears in the IP Address box.

**ATTENTION** If the value *Unknown* appears in the IP Address box, then the server name is not registered with either the Domain Name Service (DNS) or the HOSTS table. In this case, you must update your DNS or host file on the Contact Center Manager Administration server with the name of the Contact Center Manager Server. For details, see the *Contact Center Manager Administration Technical Requirements and Operating System Configuration Guide*.

4 In the **Display Name** box, type the name of the Contact Center Manager Server as you want it to appear in the system tree in Contact Center Manager Administration.

**Result:** The system automatically assigns a display name that is the same as the server name. If you want to enter a different display name, it must be a unique name.

5 To add a Contact Center Manager Server, in the **Login ID** box, type your logon ID for Contact Center Manager Server. This logon ID corresponds to a user account created using the Contact Center Manager Server Utility. (It is not a Windows 2000 ID defined on the Contact Center Manager Server.)

**OR**

To add a Contact Center Multimedia server, in the **Login ID** box, type your logon ID for the Contact Center Multimedia server. This logon ID corresponds to the user used when running historical reports in Contact Center Manager Administration. This user is configured in the Multimedia database and has access to data within that database. The Login ID is always mmReport. The default password is mmRep. To change this password, use the Contact Center Multimedia Administrator.

6 In the **Password** box, type your password.

7 From the **Type** list, select the server type. If you select server type CCMS or CCMM, proceed to step 9.

8 If you selected Other from the type list, in the **DSN Prefix** box, type the DSN prefix for the server.
The DSN prefix defaults to CCMS and CCMM for server types CCMS and CCMM, respectively. For these server types, the DSN prefix is read-only.

9 Click **Submit**.

**Result:** The configuration utility checks to see if the license agreement was accepted. If the license agreement was not accepted, you must launch the Server Utility on the Contact Center Manager Server and accept the license agreement. For instructions about how to accept the license agreement, see the *Contact Center Manager Server Installation and Maintenance Guide*. If the license agreement was accepted, the server is acquired and now appears on the server tree in the left pane of the window. Click the plus symbol (+) beside the server name to access the server.

**ATTENTION**

The Contact Center Manager Server logon ID and password that you specify when you configure a new server in Contact Center Manager Administration must match an existing logon ID and password that an administrator configured on Contact Center Manager Server. Therefore, if an administrator uses the Server Utility to change a server logon ID that you entered in Contact Center Manager Administration, then you must update the Login ID box in the Configuration component of Contact Center Manager Administration to match the new logon ID. Likewise, if an administrator changes the Contact Center Manager Server password using the Server Utility, then you must update the password in the Configuration component of Contact Center Manager Administration to match the new password.
Configuring resources

You can configure resources using one of two methods, both of which are described in this section:

- individually, using the Web-based Configuration user interface
- in bulk, using the Contact Center Manager Configuration Tool spreadsheets to upload data

You cannot acquire resources such as CDNs (Route Points), routes, voice ports, IVR ACD-DNs, and phonesets through the Configuration spreadsheets. You must use the Web-based interface in the Configuration component for resource acquisition.

After a phoneset is acquired, you cannot modify it. If you want to modify, upgrade, or reconfigure a phoneset, you must first deacquire the phoneset, delete the phoneset from Contact Center Manager Server, and remove the phoneset from the telephony switch. You can then reconfigure the modified phoneset on the telephony switch, add the phoneset on Contact Center Manager Server, and reacquire the phoneset.

For step-by-step procedures for adding, deleting, acquiring, or deacquiring phonesets and other resources, see the Contact Center Manager Administration online Help.
Using the Configuration user interface to configure resources

Use the Configuration user interface to add configuration resource data. When you click the resource in the system tree, the corresponding data table appears on the right side of the window. Click an empty row and type the configuration data in the appropriate columns. When you exit a row, the information is automatically saved in Contact Center Manager Server.

**ATTENTION**

Do not click Back or Refresh on the Internet Explorer toolbar to save or refresh the data in the table. To refresh the table while working with routes, CDNs (Route Points), phonesets, and IVR ACD-DNs, click Refresh in the Configuration window. To refresh the table while working with any other type of data, click the server name on the system tree.

Based on your contact center server (Communication Server 1000/Meridian 1 PBX, Communication Server 2x00/DMS, SIP, or Network Control Center), you can configure some or all of the following resources using the Configuration interface:

**ATTENTION**

When naming resources, the name must begin with an alphabetical character. Letters, numbers, spaces and hyphens are allowed in the name after the first character.

- CDNs (Route Points)
- DNISs
- Phonesets and voice ports
- Phoneset displays
- Routes
- Activity codes
- Skillsets
- Global settings
- Call presentation classes
- IVR ACD-DNs
- Threshold classes
- Network communication parameters
- Formulas
- Historical statistics
- Network skillsets
- Network historical Statistics
- Media servers

**Configuration user interface**
The following figure shows the Activity Codes window of the Configuration component.

![Activity Codes Window]

**Editing configuration data**
To edit information in a cell, click that cell and make the desired changes.

**Deleting configuration data**
Click the row and press **Delete**.
Saving data

Click a different row, or press Tab to move to the next row.
To upload configuration data using the Configuration Tool spreadsheets

Use the Configuration Tool spreadsheets to save time when you configure a new contact center. Instead of entering the data for each resource individually, you can simultaneously upload all configuration data that you entered in the spreadsheet. When you upload the data from the spreadsheet, you can choose to upload all configuration items at once or only a portion.

To use the Configuration Tool spreadsheets, Microsoft Excel 97 or later must be installed on the PC.

You must log on to Contact Center Manager Administration as the webadmin user, to upload and download data and to download the spreadsheet template from the Configuration component.

If you log on as the webadmin user, but you still cannot download the spreadsheet templates from the Contact Center Manager Administration server, IIS Lockdown and URLScan may be enabled on the Contact Center Manager Administration server. You must either download the spreadsheets before you enable these security features, or temporarily relax the URLScan feature by modifying the urlscan.ini file to enable the downloading of files that end with .exe (such as the Configuration Tool spreadsheets). For more information, see the Contact Center Manager Administration Installation and Maintenance Guide.

Based on your contact center server (CS 1000/Meridian 1, CS 2x00/DMS, SIP, or NCC), you can upload some or all of the following configuration data using the corresponding Configuration Tool spreadsheet:

**ATTENTION** When naming resources, the name must begin with an alphabetical character. Letters, numbers, spaces and hyphens are allowed in the name after the first character.

- Users
- Skillsets
- DNISs
- Global settings
The number of agent-to-skillset assignments that you can upload from the Configuration Tool spreadsheets is restricted due to the Microsoft Excel limit of 256 columns for each worksheet.

Although you can upload supervisor and agent configuration data using the Configuration Tool spreadsheets, you must modify and delete this data using the Contact Center Management component, not the Configuration component.

After you upload a phoneset or voice port, you cannot modify it. You can delete an uploaded phoneset or voice port and add a new phoneset or voice port. For example, after you upload a voice port, you cannot change it to a phoneset. Instead, you must delete the voice port and add a new phoneset.

You cannot add phonesets, voice ports, or IVR ACD-DNs to a SIP system.

**To download the Configuration Tool spreadsheet template**

You can download the appropriate Configuration Tool spreadsheet templates from the Configuration component by using the Download menu on the toolbar.

The Download menu is visible only when you log on to Contact Center Manager Administration as the webadmin user.

If you log on as the webadmin user, but you still cannot download the spreadsheet templates from the application server, IIS Lockdown and URLScan may be enabled on the application server. You must either download the spreadsheets before you enable these security features, or temporarily relax the security features.
URLScan feature by modifying the urlscan.ini file to enable the downloading of files that end with .exe (such as the Configuration Tool spreadsheets). For more information, see the *Contact Center Manager Administration Installation and Maintenance Guide*.

The number of agent-to-skillset assignments that you can download to the Configuration Tool spreadsheets is restricted due to the Microsoft Excel limit of 256 columns for each worksheet.

**Download menu**
The following figure shows the Download menu.

![Download menu image](image)

When you download a spreadsheet, four files are included: the spreadsheet file (.xls), the validation file (.xml), the Help file (.chm), and the Asian validation file (.xml). Make sure all files reside in the same folder on your computer after you download them.

For step-by-step procedures about downloading the Configuration Tool spreadsheet templates, see the Contact Center Manager Administration online Help.

**Configuration Tool spreadsheet template**

After you download the appropriate Configuration Tool spreadsheet template for your contact center (that is, CS 1000/Meridian 1, CS 2x00/DMS, NCC, or SIP), you can enter configuration data directly into the spreadsheet, or you can copy configuration data into the spreadsheet from various sources:

- existing spreadsheets
- CS1000 Data Extraction Tool spreadsheets
- personnel files (for user names)
You must copy data from existing spreadsheets into the Configuration Tool spreadsheet templates. You cannot upload data directly from an existing spreadsheet.

For more information about extracting configuration data from the CS 1000/Meridian 1 and uploading to the Configuration Tool spreadsheet using the CS1000 Data Extraction Tool, see Appendix A, “CS 1000 Data Extraction Tool.”

You can perform the following tasks from the toolbar on the Configuration Tool spreadsheet:

- Download existing configuration data from Contact Center Manager Server.
- Upload configuration data to Contact Center Manager Server.
- Validate the data that you entered into the spreadsheet.
- Clear error messages from the spreadsheet after you validate and repair the data.
- Log off the Contact Center Manager Administration application server.
- Access Contact Center Manager Configuration Tool Help.

**Configuration Tool spreadsheet**

The following figure shows a CS 1000/Meridian 1 Configuration Tool spreadsheet.
When you open the Configuration Tool spreadsheets, a Microsoft Excel message asks if you want to enable all macros. Click Yes to enable all macros.

**To view the version number of the Configuration Tool spreadsheet**

For information only, you can view the version number of the spreadsheets that you download from the application server. The version number changes if the spreadsheet is updated with new functionality and placed in a new Contact Center Manager Administration build.

**Viewing the version number**

Select File > Properties.

**Result:** The version number appears in the Author box on the Summary tab.

**ATTENTION** You must not change the version number shown on this tab. If you change the version number, the Configuration Tool spreadsheet does not function correctly.
Language support in the Configuration Tool spreadsheets

You can type data in one of five languages in the Configuration Tool spreadsheets (English, French, German, Japanese, or Chinese). You can also ensure that the data is validated correctly by choosing the appropriate language in the Data Upload window and confirming that the correct validation file is in the same folder as the spreadsheet. The following table outlines which validation file is used with each type of data.

You must ensure that the correct validation file is located in the same folder as the spreadsheet before you validate or upload data to the server.

<table>
<thead>
<tr>
<th>Server type</th>
<th>Language in which data is written</th>
<th>Validation file</th>
</tr>
</thead>
<tbody>
<tr>
<td>CS 1000/ Meridian 1</td>
<td>English, French, or German</td>
<td>CS1000(M1)_Validation.xml</td>
</tr>
<tr>
<td></td>
<td>Japanese or Chinese</td>
<td>CS1000(M1)_Validation_Asian.xml</td>
</tr>
<tr>
<td>CS 2x00/DMS</td>
<td>English, French, or German</td>
<td>CS2x00(DMS)_Validation.xml</td>
</tr>
<tr>
<td></td>
<td>Japanese or Chinese</td>
<td>CS2x00(DMS)_Validation_Asian.xml</td>
</tr>
<tr>
<td>NCC</td>
<td>English, French, or German</td>
<td>NCC_Validation.xml</td>
</tr>
<tr>
<td></td>
<td>Japanese or Chinese</td>
<td>NCC_Validation_Asian.xml</td>
</tr>
<tr>
<td>SIP</td>
<td>English, French, or German</td>
<td>MCS_Validation.xml</td>
</tr>
<tr>
<td></td>
<td>Japanese or Chinese</td>
<td>MCS_Validation_Asian.xml</td>
</tr>
</tbody>
</table>
Uploading data to Contact Center Manager Server

1. After you enter the configuration information into the spreadsheet, click **Data Validation** on the toolbar to validate your data.

   **ATTENTION**
   To ensure that the system properly validates the data you upload, the appropriate validation file must be in the same folder as the spreadsheet. For a list of validation files, see “Language support in the Configuration Tool spreadsheets” on page 83.

2. After you correct any invalid information and successfully validate the information, click **CCM Server Upload** on the toolbar.

   **Result:** A Configuration Tool dialog box appears, prompting you to log on to the application server.

3. In the **Server Name or IP box**, type the Contact Center Manager Administration server name or IP address.

4. In the **User ID** box, type the user ID.

5. In the **Password** box, type the password.
6 Click **Login**.

**Result:** The Data Upload - Configuration Tool window appears.

7 Select the server to which you want to upload the data (or select the appropriate NCC server if you are working in the NCC spreadsheet).

The Available Servers box displays the servers that correspond to the Configuration Tool spreadsheet you use. For example, if you use the CS1000(M1)_ConfigurationTool.xls spreadsheet, NCC servers do not appear in the Available Servers box during the upload. To upload data to an NCC server, you must use the NCC_ConfigurationTool.xls spreadsheet.

8 In the **Configuration Data** section, select the type of data you want to upload.

9 From the list of languages, select the language in which the data you upload is written. You can choose from English, French, German, Japanese, or Chinese.
10 Click **OK**.

**Result:** The Upload Status - Configuration Tool window appears.

As your data uploads, the Current Status box displays each uploaded data. After the upload process is complete, the Summary Status box lists the data that was successfully uploaded, as well as any errors that occurred. If errors occur, they also appear in the Status Message column of the spreadsheet.

11 Click **Close** to close the Upload Status - Configuration Tool window.

You cannot acquire resources such as CDNs (Route Points), routes, voice ports, IVR ACD-DNs, and phonesets through the Configuration Tool spreadsheet. You must use the Web-based interface in the Configuration component for resource acquisition.

For more step-by-step procedures about the Configuration Tool spreadsheets, see the Configuration Tool online Help.
Downloading data from Contact Center Manager Server

You can download configuration data from Contact Center Manager Server to the Configuration Tool spreadsheets. You can do this to review your configuration data, or to make changes to the data, and then upload the data back to the server in Contact Center Manager Server.

1. Download the appropriate Configuration Tool spreadsheet from the Configuration component.

   To make sure you do not overwrite an existing Configuration Tool spreadsheet, rename the spreadsheet or save it in a different directory when downloading.

2. Open the spreadsheet and click CCM Server Download on the toolbar.

   **Result:** If you are not currently logged on to the Contact Center Manager Administration, a Configuration Tool dialog box appears, prompting you to log on. If you are logged on, proceed to step 7.

3. In the **Server Name or IP box**, type the Contact Center Manager Administration server name or IP address.

4. In the **User ID** box, type your Contact Center Manager Administration user ID.

5. In the **Password** box, type your Contact Center Manager Administration password.
6 Click **Login**.

**Result:** The Data Download - Configuration Tool window appears.

![Data Download - Configuration Tool](image)

7 Select the server to which you want to download the data (or select the appropriate NCC server if you are working in the NCC spreadsheet).

8 In the **Configuration Data** section, indicate the type of data you want to upload.

9 From the list of languages, select the language in which the data you download is written. You can choose from English, French, German, Japanese, or Chinese.

10 Click **OK**.

**Result:** A Save as window appears.

11 Browse to where you want to save the spreadsheet.
12 Type a file name and click **Save**.

**Result:** The Download Status - Configuration Tool window appears.

For more step-by-step procedures about the Configuration Tool spreadsheets, see the Configuration Tool online Help.

**What is next?**

Create the Contact Center Manager Server users; designate them as supervisors, agents, or supervisor/agents; and assign agents to supervisors.
Chapter 5
Contact Center Management

In this chapter
What is new in Contact Center Management 92
Overview 94
Supervisors view 97
Agents view 101
Skillsets view 107
Assignments view 110
Network Agent Admin view 113
To add Contact Center Manager Server users 117
Default Queue Management 124
Using the XML automated assignments feature 127
What is new in Contact Center Management

The following enhancements are available in the Contact Center Management component:

- **Running user defined assignments on an ad hoc basis**—You can run user-defined agent-to-skillset and agent-to-supervisor assignments on an ad hoc basis.

- **Viewing schedule of agent-to-skillset and agent-to-supervisor assignments**—You can view scheduled agent-to-skillset and agent-to-supervisor assignments from the Scheduled Events folder in the Assignments view of Contact Center Management. The list of assignments spans all servers in the network. Access levels for agent-to-skillset assignments and agent-to-supervisor assignments are implemented for this feature.

- **Selecting skillset priority or standby from a list**—You can select the skillset priority level for each skillset in agent-to-skillset assignments. Alternatively, you can place each skillset in standby.

- **Displaying the current logged on or logged off status of an agent**—You can display the current status of the agent (logged on or logged off) in all views (Supervisors, Agents, Skillsets, Assignments, and Agent Details).

- **Searching by agent status (Logged in or Logged Out)**—You can search for logged on or logged off agents.

- **Displaying the agent TN name**—In the Agent Details view, you can view the Terminal Number (TN) name of the agent.

- **Bulk assigning a group of agents to a new supervisor**—You can change all agents in an agent-to-supervisor assignment to a new supervisor at once.

- **Bulk deleting agents**—In the Agents view, you can bulk delete agents. After a user deletes agents, a grid appears detailing any errors that occurred during the bulk delete.

- **Bulk adding Agents and Supervisors**—You can import agents and supervisors in bulk from a comma-delimited text file containing the unique information for each agent or supervisor.

- **Bulk assigning agents to a new supervisor using Supervisor Search**—You can search for agents based on an assigned supervisor. To assign all
agents to a new supervisor, click the Assign box at the top of the column, and then click Submit.

- **Applying ad hoc skillset assignment changes to multiple agents**—In the Skillset view, you can bulk change the priority level of a skillset assignment for all agents assigned to that skillset or to bulk change the priority level of all skillsets assigned to an agent.

- **Limit number of skillsets assigned to agent**—The maximum skillsets that can be assigned to an agent on a Symposium Call Center Server 5.0 server is 50. The maximum skillsets that can be assigned to an agent on a Contact Center Manager Server 6.0 server is now increased to 100.

- **Default Queue Management**—Contact Center Manager does not rely on agent positions assigned to ACD Queues, which means an agent can log in from any phoneset. The default ACD Queue for an agent is now managed from the Contact Center Manager Client.

- **Network agent admin view**—This is a new view in Contact Center Management. You can search for agents across multiple servers based on their first name, last name, login ID, department ID or login status. You can also search for agents based on skillset assignment. To make modifications, you can launch the agent details screen or the skillset view.
Overview

After you add and configure each server in Contact Center Manager Server, you can use the Contact Center Management component to perform the following tasks:

- Add, edit, view, or delete users on a server in Contact Center Manager Server.
- Add, edit, view, or delete agent-to-supervisor assignments.
- Add, edit, view, or delete agent-to-skillset assignments.
- View the schedule of all agent-to-skillset and agent-to-supervisor assignments.
- Run user-defined assignments on an ad hoc basis.
- Apply assignment changes to multiple agents simultaneously.
- Display agent logon status in Agents, Supervisors, Skillsets and Assignments and Agent Details views.
- Search by agent logged in or logged out status.
- Display agent TN name in Agent Details view.
- Assign an agent to default queue management.
- Use Contact Center Management to quickly assign agents to existing partitions instead of opening the Access and Partition Management component to do so.

This section provides a high-level overview of adding Contact Center Manager Server users; designating them as supervisors, agents, or supervisor/agents; editing their profiles; and assigning agents to supervisors and skillsets.

This section assumes that, as an administrator, you have:

- the appropriate access class to perform all functions in Contact Center Management (the Add/Edit/Delete Agents and Supervisors access level under the CCM access heading, and the Schedule Assignments access level under both the Agent to Supervisor Assignment and Skillset Assignment access headings)
no partitions or supervisor/reporting agent combinations assigned to you, therefore, you can view all data in Contact Center Management

For detailed information about working in Contact Center Management, see the Contact Center Manager Supervisor’s Guide, or see the step-by-step procedures in the Contact Center Manager Administration online Help.

Main data views

Contact Center Management is separated into the following five main data views, each accessible from the View/Edit menu:

- Supervisors (this is the default view that appears when you first open Contact Center Management)
- Agents
- Skillsets
- Assignments
- Network Agent Admin

To switch from one view to the next one, select the desired command from the View/Edit menu.

When you select a command, the system loads the corresponding data type in the system tree. Before you can work with each data type, you must first select a server name in the tree to log on to the server and view the agents, supervisors, and skillsets on that server. If you work in a networked environment, the system tree contains multiple servers, with each server representing a contact center in the network.

For more information about each of these data views, see the following corresponding sections.

To create new users, select Agent, Supervisor, or Supervisor/Agent from the Add menu. When you select a command, the corresponding new user details window appears, where you can type the properties for that user. For more information about creating users, see the Contact Center Manager Administration online Help.
To create a new agent, in addition to the preceding option, you can right-click a supervisor in the system tree, and then select Add Agent from the resulting menu.

To create many new agents or supervisors, right-click a supervisor in the system tree, and select Add Many Users from the resulting menu.

When you click Refresh, the system collapses the tree, closes the window in which you are currently working, and reloads the Supervisors view. After the supervisor view reloads, click a server to log on again.
Supervisors view

When you open Contact Center Management from the Contact Center Manager Administration launchpad, the Contact Center Management window opens in Supervisors view. You can use this view to:

- quickly view the configured supervisors on each server in the system tree
- list the agents assigned to each supervisor
- immediately assign agents to supervisors (ad hoc assignments)
- quickly add many new supervisors by importing a comma-separated values file (.csv)

To create saved and scheduled assignments, you must use the assignments view. For more information, see “Assignments view” on page 110.

To add new supervisors, use the Add menu.
Ad hoc agent-to-supervisor assignments
To work with agents and supervisors, you must first log on to the appropriate server in the system tree. The server expands to reveal all the configured supervisors. Click a supervisor in the tree to open the Supervisor window and see the supervisor’s reporting agents and their corresponding logon IDs.

Users with administrator rights (that is, users who have basic access to all Contact Center Manager Administration components and who have no partitions or supervisor/reporting agents assigned to them) automatically see all supervisors and agents in all windows of Contact Center Management. However, users who are assigned a partition containing agents, or a partition and a supervisor/reporting agent combination, see only those agents to whom they have access.

To create saved and scheduled assignments, you must use the assignments view. For more information, see “Assignments view” on page 110.
To quickly assign new agents to a supervisor, click Assign Agents. The agent search feature appears, where you can search for specific agents by choosing from up to seven criteria (first name, last name, department, comment, login ID, logged in, or logged out) or list all agents configured on the server (only those agents included in the partitions and supervisor/reporting agent combinations assigned to you). When you click Search or List All, the agents appear in a new table.

Partitions and supervisor/reporting agent assignments control the agent data that users can see in Contact Center Management. To give a user access to all agents, do not assign a partition to the user. To give a user access only to their reporting agents, assign the user a partition (even if it contains no agents) and the supervisor/reporting agent combination containing the user’s agents.

When you find the agents you want to assign to the supervisor, click the Assign check box beside their names, and then click Submit. The system immediately assigns the agents to the supervisor.
Each agent can be assigned to only one supervisor at a time. Therefore, when you assign an agent to a supervisor, you unassign the agent from the agent’s current supervisor.

You can also assign agents to the supervisor, one agent at a time, using the drag-and-drop feature. In the system tree in supervisor view, locate the agent you want to assign to the supervisor. Click the agent icon and, while still holding down the left mouse button, drag the icon over the desired supervisor icon. Release the mouse button to immediately assign the agent to the supervisor.
Agents view

In the following section, the term agent also includes users who are supervisor/agents. In the agent view, you can work with both types of users.

In the agent view, you can search for particular agents or list all agents on a server. After you locate the desired agents, you can:

- view and edit the agents’ properties, including the skillsets and partitions to which the agents are assigned
- delete the agents from the server one at a time or in bulk
- quickly create a new agent by copying a current agent’s properties
- quickly create many new agents by importing a comma-separated values file (.csv)

To open the agent view, choose View/Edit > Agents. Then click the desired server in the system tree to log on to the server and work with the configured agents. When you click a server in the system tree, the Agents List window appears. In this window, you can use the agent search boxes to locate specific agents, or you can click List All to list all agents on the selected server.

A new feature is available when searching for Agents, where you can search on multiple logon IDs.

Searching for agents based on multiple logon IDs

1. In the Contact Center Management component, from the View/Edit menu, select Agents.
2. In the system tree, select the server to log on to.
   
   **Result:** The Agents list window appears.
3. From the search criteria list (first box), select **Login IDs**.
4. From the conditions search list (second box), select **Equal to (multiple)**.
5. In the search box, type the logon IDs separated by commas.
6 Click **Search**.

**Result:** If matches are found, the system displays a list of agents with the logon IDs you entered.

To add a new agent, see “Adding an agent” on page 119.

**To view or edit agent details**

In the Agents List window, from the table of agents you located through your search, you can view or edit an agent’s details in two ways:

- Click the agent’s name.
- Click Functions beside the desired agent, and then select View Agent Details from the resulting menu.

When you click either option, the Agent Details window appears, where you can view all of the agent’s properties, such as name, login ID, supervisor information, and the skillsets and partitions to which the agent is assigned.
Agent Details window

The following figure shows the Agent Details window on a Contact Center Manager Server with a CS 1000/Meridian 1 telephony switch. Open Queue is not enabled.

Use the User Details and Agent Information sections of this window to view and change information about the agent, such as the name, login ID, user type, and primary supervisor.

In addition, when you create supervisors and supervisor/agents, the Supervisor Information section is enabled. In the Supervisor Information section, you can assign these users a Contact Center Manager Administration user ID and password.

This information is required for users who log on to the application server and use Contact Center Manager Administration. When you finish adding the user’s details, you must click Submit to save your changes.

To view or edit ad hoc agent-to-skillset assignments

In the Agent Details window, click the Skillsets heading to view the skillsets to which the agent is assigned and change the skillset priority.
Click List All to list all configured skillsets on the server and assign the agent to new skillsets.

The Contact Type column is new and is used in a multimedia contact center to show the multimedia contact type associated with each skillset. For more information about contact types, see the Contact Center Manager Administration online Help.

The number of skillsets that you can assign to an agent is 50 for Symposium Call Center Server 5.0 and 100 for Contact Center Manager Server 6.0.

<table>
<thead>
<tr>
<th>Skillset Name</th>
<th>Contact Type</th>
<th>Priority</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default_Skillset</td>
<td>Voice</td>
<td>1</td>
</tr>
<tr>
<td>VI_Collection</td>
<td>Voice</td>
<td>1</td>
</tr>
<tr>
<td>VI_Credit</td>
<td>Voice</td>
<td>1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Skillset Name</th>
<th>Contact Type</th>
<th>Priority</th>
</tr>
</thead>
<tbody>
<tr>
<td>VI_Custom_Collection</td>
<td>Voice</td>
<td>Unassigned</td>
</tr>
<tr>
<td>VI_Marketing</td>
<td>Voice</td>
<td>Unassigned</td>
</tr>
<tr>
<td>VI_Reservation</td>
<td>Voice</td>
<td>Unassigned</td>
</tr>
<tr>
<td>VI_Sales</td>
<td>Voice</td>
<td>Unassigned</td>
</tr>
</tbody>
</table>

To view or edit user-defined partition assignments
In the Agent Details window, click the Partitions heading to view the user-defined partitions to which the agent is assigned and to assign the agent to new user-defined partitions.

To improve performance, Nortel recommends that you assign Standard partitions and reporting agents instead of user-defined partitions.

To assign an agent to a partition, select the check box beside the partition name, and click Submit. The agent is automatically included in the assigned partition and can be viewed by the supervisors to whom this partition is assigned.

To unassign the agent from the partition, you can
- clear the check box beside the partition name.
remove the agent from the partition in the Access and Partition Management component. To improve performance, Nortel recommends that you select this option.

Before you unassign an agent from a user-defined partition, ensure that the agent’s supervisor can still see the agent in Contact Center Management, Historical Reporting, and Real-Time Reporting. To do so, verify that the agent is included in another partition assigned to the supervisor or that the supervisor is assigned a supervisor/reporting agent combination (which automatically includes the agent).

**Deleting an agent in the Agents view**

1. In the Contact Center Management component, from the View/Edit menu, select **Agents**.
2. In the system tree, select a server to log on to.
   
   **Result:** The Agents List window appears.
3. Search for the agent that you want to delete.
4. In the Agents List window, for the agent that you want to delete, select **Functions > Delete Agent**
  
   OR

   select the **Delete** check box beside the agent and click **Submit**.
   
   **Result:** A confirmation dialog box appears asking you to confirm your choice.
5. Click **Yes**.
   
   **Result:** The system deletes the selected agent.

   To bulk delete agents, select the **Delete** check box at the top of the column and click **Submit**.

**To copy agent properties**

In the Agents List window, use the Functions menu to quickly create a new agent by copying the properties of an existing agent.
When you select Copy Agent Properties from the Functions menu, the system copies the following properties from the existing agent into the New Agent Details window:

- skillset assignment
- department
- user type
- language
- comment
- supervisor
- call presentation
- threshold
- agent key
- the list of partitions for this agent

To create the new agent, you must type the new agent’s name and logon ID. You can also change any of the copied properties, and then click Submit to save your changes. The system saves the agent under the supervisor that you specified, and the agent’s icon appears in the system tree.
Skillsets view

Use the Skillsets view to create new ad hoc agent-to-skillset assignments and to change the priority of skillsets already assigned to agents. Click View/Edit > Skillsets to change the system tree to skillset view. Then click the desired server in the system tree to log on to the server and work with the configured skillsets and agents.

When you click a skillset in the system tree, the Skillsets window appears, listing the agents who are currently assigned to the skillset and the priority for this skillset.

Ad hoc agent-to-skillset assignments

In the Skillsets window, you can immediately assign an agent to a new skillset or change the priority of an assigned skillset.

Immediately assigning a new agent to a skillset

1. In the Contact Center Management component, from the View/Edit menu, select Skillsets.

Result: The Skillsets window appears.
2 In the system tree, select the server to log on to.
   **Result:** A list of skillsets appears under the server.

3 From the list of skillsets, select a skillset.
   **Result:** The skillset window appears.

4 Click the **Assign Agents** heading.
   **Result:** The agent search feature appears. You can search for agents by up to seven criteria or list all agents configured on the server (only those agents included in the partitions and supervisor/reporting agent combinations assigned to you).

5 From the search criteria list, select **Last Name, First Name, Department, Comment, Login ID, Logged In, or Logged Out**.

6 From the conditions list, select **Contains, Equal to, or Starts with**.

7 In the search box, type the item to search for based on what you selected from the search criteria list. For example, if you selected last name from the search criteria list, type the last name for the agent.

8 From the join list, select **And or Or**. You can define up to five levels of search criteria.

9 Click **Search**.
   **Result:** If matches are found, the system displays a list of agents.

To list all available agents, click **List All**.

10 From the list of unassigned agents, choose the skillset priority for each agent.
11 Click Submit to save your changes.

**Result:** The system immediately assigns the agents to the skillset with the priority you chose.

**Tip:** To simultaneously assign all agents in the list to the skillset, from the **Set all agents to priority** list, choose the priority. Click Submit to save your changes.

### Changing the priority of an agent assigned to a skillset

1 In the Contact Center Management component, from the **View/Edit** menu, select **Skillsets**.

**Result:** The Skillsets window appears.

2 In the system tree, select the server to log on to.

**Result:** A list of skillsets appears under the server.

3 From the list of skillsets, select a skillset.

**Result:** The skillset window appears.

4 From the **Priority** list for the selected agent, choose the new priority.

5 Click Submit to save your changes.

### Simultaneously changing the priority of all agents assigned to a skillset

1 In the Contact Center Management component, from the **View/Edit** menu, select **Skillsets**.

**Result:** The Skillsets window appears.

2 In the system tree, select the server to log on to.

**Result:** A list of skillsets appears under the server.

3 From the list of skillsets, select a skillset.

**Result:** The skillset window appears.

4 From the **Set all agents to priority** list, choose the new priority.

5 Click Submit to save your changes.

To create saved or scheduled assignments, you must use the assignments view. For more information, see “Assignments view” on page 110.
Assignments view

Use the assignments view to view, add, edit, and delete agent-to-skillset and agent-to-supervisor assignments and to create ad hoc agent-to-skillset and agent-to-supervisor assignments. Select View/Edit > Assignments to load the assignment data in the system tree. Then click the desired server in the system tree to log on to the server and work with the configured assignments.

This section gives a brief overview of the assignments view. For more information about this view, including assignment scenarios and an example of scheduling an assignment and creating a reset assignment, see the Contact Center Manager Supervisor’s Guide.

Assignment types

You can create two types of assignments in Contact Center Management:

- **Agent-to-supervisor assignments**—You can create agent-to-supervisor assignments to automatically change supervisor assignments for multiple agents. You can use agent-to-supervisor assignments to reassign agents when supervisors go on break or on vacation.

- **Agent-to-skillset assignments**—You can create agent-to-skillset assignments to temporarily assign agents to different skillsets for shifts when fewer agents are available, to cover other agents’ breaks, or when agents are sick, on vacation, or on a course.

An agent-to-skillset assignment makes multiple agents active or inactive for multiple skillsets. When an assignment is run, it changes the skillset priority of each agent added to the assignment. An assignment can make an agent inactive for a skillset by changing the agent’s priority to Standby, or it can make an agent active for a skillset by changing the agent’s priority to a value from 1 to 48 (with 1 being the highest priority for the skillset).

In assignments view, you can save and schedule the assignments to take effect at a later date, you can create reset assignments to revert the contact center to the original configuration that existed before scheduled assignments are run, and you can create ad hoc assignments (those that are effective immediately).
You can save an unscheduled assignment.

You can also create ad hoc assignments in the skillset or supervisor views. For more information, see “Ad hoc agent-to-supervisor assignments” on page 98 or “Ad hoc agent-to-skillset assignments” on page 107.

To create and run multiple assignments automatically, you can use the XML automated assignments feature. For more information, see “Using the XML automated assignments feature” on page 127.

To work with assignments

In assignments view, you can perform the following tasks:

- work with existing assignments by clicking the assignment name in the system tree
- add new agent-to-skillset or agent-to-supervisor assignments by right-clicking the Agent Skillset Assignments or Agent Supervisor Assignments folder, and then choosing Add Assignment from the resulting menu
- run existing assignments immediately
- view all scheduled assignments across all servers by clicking the Scheduled Events folder in the system tree

When you log on to a server in the system tree, it expands to reveal the Agent Skillset Assignments and Agent Supervisor Assignments folders. Click the appropriate folder to view the list of assignments. Then click the assignment name to open the assignment window and view the assignment details in a table. Based on the type of assignment that you select in the system tree, either the Agent to Skillset Assignment window or the Agent to Supervisor Assignment window appears.

Agent to Skillset Assignment window

When you unassign an agent from a skillset on an ad-hoc basis, the agent is automatically removed from that skillset in all scheduled agent-to-skillset assignments where the agent is assigned to the skillset.

The following graphic shows the assignment details that appear when you click an existing agent-to-skillset assignment in the system tree.
For details about working in this window, see the Contact Center Manager Supervisor’s Guide.
Network Agent Admin view

Use the Network Agent Admin view to search for agents by selected agent properties or by skillset assignment across multiple servers in the network. You can view and modify an agent's skillsets. You can also launch the Agent Details window and the skillset view if additional modifications are required.

Launching the Network Agent Admin view

In the Contact Center Management component, from the View/Edit menu, select Network Agent Admin.

Result: The Network Agent Admin view window appears.

Searching for agents across servers based on agent properties

1. In the Contact Center Management component, from the View/Edit menu, select Network Agent Admin.

   Result: The Network Agent Admin view window appears.

2. Select the servers on which you want to search.
3 Select the **Network Agent Search** option.

**Result:** The agent search boxes appear.

4 From the search criteria list, select **First Name, Last Name, Department, Comment, Login ID, Logged in** or **Logged out**.

5 From the search conditions list, select **Contains, Equal to, or Starts with**.

6 In the search box, type text relevant to the selected search criteria.

7 From the join list, select **And** or **Or**.

You can define up to five levels of search criteria.

8 Click **Search**.

**Result:** Agents that match the selected search criteria are returned in a table. The search results are read-only. To sort the results, click the relevant column header.
9 To view agent details, click the first name or last name of the agent to display the details for that agent.

Result: The Agent Details window for the selected agent appears in a new browser.

Searching for agents across servers based on skillset assignments

1 In the Contact Center Management component, from the View/Edit menu, select Network Agent Admin.

Result: The Network Agent Admin view window appears.

2 Select the servers on which you want to search.

3 Select the Network Skillset Search option.

Result: The skillset search boxes appear.

4 From the skillset list, select a skillset.

5 From the search criteria list, select Assigned, In StandBy, or Not Assigned.

6 From the next search criteria list, select Logged In or Logged Out.
7. From the join list, select **And** or **Or**. Up to five levels of search criteria can be defined.

8. Click **Search**.

   **Result:** Agents that match the selected search criteria are returned in a table. The search results are read-only. To sort the results, click the relevant column header.

9. To view the skillset assignments of an agent, click the first column beside the agent whose skillset assignments you want to view.

   **Result:** The skillset assignments for the selected agent appear below the search results.

You can modify the skillset priority level for each agent on the selected server in the Network Agent Admin view.
**To add Contact Center Manager Server users**

The users you add in Contact Center Management are Contact Center Manager Server users—the agents, supervisor/agents, and supervisors who work in the contact center. Agents do not need to log on to the Contact Center Manager Administration server to use Contact Center Manager Administration and, therefore, do not have a Contact Center Manager Administration user ID and password.

However, when you create Contact Center Manager Server users in Contact Center Management, you can give the supervisors and supervisor/agents who need to use Contact Center Manager Administration a Contact Center Manager Administration user ID and password. When you do so, the user’s profile is automatically copied to the Access and Partition Management component, where you must finish configuring the user’s Contact Center Manager Administration profile by assigning basic access rights, access classes, partitions, report groups, and supervisor/reporting agent combinations. For more information about creating Contact Center Manager Administration users, see “Contact Center Manager Administration users” on page 178.

To add users in Contact Center Management, you must first log on to a server in the system tree in any of the four data views (supervisors, agents, skillsets, or assignments). Then, when you log on to the server on which you want to create the user, select the appropriate command from the Add menu. You can choose one of the following commands:

- **Agent**
- **Supervisor**
- **Supervisor/Agent**
- **Many Users**
Add menu
The following figure shows the Add menu.

When you select a command from this menu, the corresponding new user details window appears, with sections for entering the new user’s properties. For example, if you add a new supervisor, the New Supervisor Details window appears.

To add agents only, instead of using the Add menu, right-click the supervisor under whom you want to create the new agent and, from the resulting menu, click Add Agent. The New Agent Details window appears with the supervisor information already filled in. You can change this information or leave it as is. When you finish adding the agent details, click Submit to save your changes. For more information about each section of the user details window, see “Adding an agent” on page 119.

To delete users, you must do so in Contact Center Management; you cannot delete users through the Configuration component user interface or spreadsheets.

The following procedure describes how to add a new agent. For details about adding other types of users, see the Contact Center Manager Administration online Help.
Adding an agent

1. In the Contact Center Management component, log on to a server in the system tree.

2. From the Add menu, select Agent.

Result: The New Agent Details window appears and the User Details section is expanded.

3. In the User Details section, type or select the following mandatory information about the agent:
   - first name
   - last name

Note: Alphanumeric characters are supported only in the first and last name fields. Special characters are not supported.
   - user type
   - login ID

The ACD Queue and ACD Queue Error fields are not present when you configure a SIP agent.
- SIP URI (not shown in the graphic) is mandatory when you add an agent on a SIP-enabled server
- SIP terminal (not shown in the graphic) is mandatory when you add an agent on a SIP-enabled server

All other fields are optional. For more information about a SIP URI or a SIP terminal, see the Contact Center Manager Administration online Help.

**Note:** If you configure a CDN (Route Point) on a SIP-enabled sever, type the Universal resource Identifier (URI) of the CDN (Route Point) on the Media application server. The URI must equate to the fully qualified SIP address for the CDN (Route Point).

4 Click the **Agent Information** heading.

**Result:** The Agent Information heading expands to reveal the Agent Information section.

The Agent Key and TN Name fields are not present when you configure a SIP agent.

5 Type or select the following mandatory information about the agent:
- primary supervisor
- call presentation
- threshold

All other fields are optional.
6 Click the **Skillsets** heading to assign the agent to skillsets and select the skillset priority.

**Result:** The Skillsets section appears.

![Skillsets Table](image)

7 Click **List All**.

**Result:** A table containing skillsets available, based on the user's access or user-defined partition on the current server, appears.

8 From the **Priority** list, select the priority number for each skillset to which you want to assign the new agent. You can also select **Standby**.

The Contact Type column is new and is used in multimedia contact centers to show the multimedia contact type associated with each skillset. In this example, all of the contact types are Voice. For more information about contact types, see the Contact Center Manager Administration online Help.

9 To add the new agent to a partition, click the **Partitions** heading.

10 In the resulting table, select the check boxes beside the partitions to which you want to add the agent. Ensure that you add the agent to the partition assigned to the agent's supervisor so the supervisor can see the agent in real-time and historical reports and in Contact Center Management.

This step is required only if you created user-defined partitions.

11 Click **Submit** to save your changes.

**Result:** The agent is added in Contact Center Manager Server.
Supervisor information
When you add a supervisor or a supervisor/agent in Contact Center Management, you can give the user a Contact Center Manager Administration user ID and password at the same time. In the Supervisor Information section, type the supervisor’s Contact Center Manager Administration user ID and password.

Contact Center Manager Administration user passwords can contain only English characters.

Telephony/Port
In the Telephony/Port field, you must type the position ID of the supervisor's phoneset (SPID). This is mandatory only when adding a supervisor as only supervisors have a SPID. The switch maps agent keys of the supervisor's reporting agents to the phoneset identified by this field.

To communicate with their reporting agents through the phoneset (for example, using the Emergency and Answer Emergency keys), the supervisor must log in to the phoneset with this specified address. Supervisors cannot roam; their location is fixed.

Access and Partition Management
After you add a Contact Center Manager Server supervisor or supervisor/agent as a Contact Center Manager Administration user, you must configure the user in the Access and Partition Management component. For example, you must still assign the user basic access rights to the different components, access classes, partitions, and supervisor/reporting agents.

To enable this supervisor to see their reporting agents, in Access and Partition Management, assign the corresponding Contact Center Manager Administration user profile:

- the applicable supervisor/reporting agent combination (their reporting agents)
- a partition

For more information about supervisor/reporting agents, see “Reporting agents” on page 164.
More information

For more information about adding Contact Center Manager Server users, see the *Contact Center Manager Supervisor’s Guide*, or see the step-by-step procedures in the Contact Center Manager Administration online Help.
Default Queue Management

This feature applies to Contact Center Manager Servers connected to a CS 1000/Meridian 1 R4.0 or X112540b switch with patch MPLR20264 and to Contact Center Manager Servers connected to a CS 1000/Meridian 1 R4.5.

When agent positions are first defined on the telephony switch, they must be assigned to an ACD queue. The ACD queue is attached to the Agent ID and not the phoneset.

An agent's default ACD queue can now be managed from the Contact Center Manager Administration server. Daily management of the default ACD queue for the phoneset that the agent logs on to is not required.

With Default Queue Management, an agent can log on to any phoneset and the default ACD queue is automatically updated to the appropriate queue for the agent.

When an agent logs on

A number of actions take place when an agent logs on to a phoneset:

- The CS 1000/Meridian 1 telephony switch requests Contact Center Manager Server to validate the logon ID.
- Contact Center Manager Server validates the logon ID and sends the default ACD queue assigned to the agent to the CS 1000/Meridian 1 telephony switch.
- The CS 1000/Meridian 1 telephony switch checks if the agent phoneset is configured under a different queue. If the agent phoneset is configured on a different queue, the telephony switch tries to move the agent phoneset to the new default ACD Queue.
- If the agent phoneset is successfully moved to the new default ACD Queue, the CS 1000/Meridian 1 telephony switch proceeds with the agent logon process.
- If no default ACD Queue is sent to the CS 1000/Meridian 1 telephony switch, the telephony switch proceeds with the agent logon process.
The phoneset remains assigned to the ACD queue defined on the telephony switch.

**To update the ACD queue while the agent is logged on**

If the ACD queue is updated in the agent profile while the agent is logged on, Contact Center Manager Administration updates the agent profile in the database with the new ACD queue and updates the ACD error field with the following error message:

“Agent is required to login again for the new ACD queue to take effect.”

**What happens when an agent logs on with errors**

If an error occurs while moving the agent into the default ACD queue:

- The CS 1000/Meridian 1 telephony switch proceeds with the agent logon process, but the response to Contact Center Manager Server contains an error code for the agent phoneset assigned to the new default ACD queue.
- Contact Center Manager Server updates the agent profile with the error returned from the CS 1000/Meridian 1 telephony switch. You can view the error in the agent profile in Contact Center Manager Administration.
- An event is written to the event log containing the agent ID, default ACD DN, and the reason for failure.
- The agent can still log on successfully.
- The phoneset remains assigned to the ACD queue defined on the telephony switch.

If errors occur during the agent logon process and while moving the agent phoneset to the new ACD queue, the error encountered during logon supersedes the Default Queue Management error.

When the agent logs off the phoneset, the ACD error is cleared from the agent profile.
Reasons for failure

You cannot move a phoneset to another ACD queue if any of the following applies:

- The ACD queue is an invalid ACD DN or does not exist on the telephony switch.
- The ACD queue is an IVR queue or has automatic logon set to yes.
- The maximum positions in the new ACD queue are occupied.
- The ACD queue on the telephony switch is corrupt. The relevant ACD pointers cannot be set.
Using the XML automated assignments feature

The XML automated assignments feature includes a component service that can help you create or update multiple assignments simultaneously by parsing through agent-to-skillset and agent-to-supervisor assignment data in XML files that you create. After the service parses the data, it either creates a new assignment on the indicated server, or it updates an existing assignment (if the assignment name in the XML file matches an existing assignment name on the selected server in Contact Center Manager Server).

When you create the XML file, you can specify whether you want the service to create an ad hoc assignment (one that is run immediately) or a scheduled assignment. If the service creates a new scheduled assignment, you must use the Contact Center Management component to manually schedule and activate the assignment; if the service updates an existing scheduled assignment, the schedule still applies and the assignment remains active. However, if you want the assignment to run only at the scheduled time, you must select the Schedule option in the XML file. If you choose the Execute Now option, the scheduled assignment runs twice: it runs immediately and at the scheduled time. If you do not include the <EXECUTENOW> field in your XML file, or if you type an invalid value in this field, the system defaults to scheduling the assignment, and you must use Contact Center Management to manually schedule the new assignment.

This feature does not include an interface for writing the XML files. You must create the files using a proprietary tool of your choice, and you must design the files based on the specifications in “Specifications for XML files” on page 131. For guidance on creating the XML files, you can view the sample files that are shipped with the Contact Center Manager Administration software. These files are on the Contact Center Manager Administration server in the folder 
C:\Program Files\Nortel Networks\WClient\Server\XMLAssignments\Sample XML Files, where C is the drive on which you installed Contact Center Manager Administration.
Who should use this feature

The XML automated assignments feature provides an interface for third-party applications to issue scheduled or ad hoc assignments.

For example, you can use this feature in the following scenarios:

- An agent is assigned to three skillsets during normal traffic periods, but during busy hours, you can use the XML automated assignments feature to assign this agent to additional skillsets.

- An is in Standby mode for certain skillsets during non-peak times. However, during busy periods, you can use this feature to schedule an assignment that gives the agent a priority for these skillsets. You can run a second assignment later to put the agents into Standby mode again.

- An agent receives contacts in the morning; in the afternoon, the agent is in training, in meetings, or doing other work. You can use this feature to place these agents in Standby mode in the afternoon. You can also use this feature where agents handle voice calls in the morning, and then, in the afternoon, handle e-mail, Web requests, and so on.

Example

Your contact center has 500 agents, each of whom rotates daily in free-seating mode within their team with the skillset changing according to the seat the agent occupies.

In this example, agent John Smith works with skillsets S1, S2, and S3. On Monday morning, John works in area 1 (dedicated to skillset S1); in the afternoon, he works in area 2 (dedicated to S2); on Tuesday he works in area 3 (dedicated to S3), and so on.

You must create separate XML files—for agent-to-skillset and agent-to-supervisor assignments—that contain the assignment data for all 500 agents and their supervisors for each seat-rotation period. In this scenario, therefore, you create separate agent-to-skillset and agent-to-supervisor assignment files for the Monday morning period, new files for Monday afternoon, more files for Tuesday morning, and so on.
After you create the files and are satisfied that they conform to the standards listed in the section “Specifications for XML files” on page 131, you must copy them to the designated drop folder. When you place the files in this folder, the program automatically parses the assignment data and creates or updates the assignments for all 500 agents. If you create new scheduled assignments, you must use Contact Center Management to schedule and activate the assignments. If you update existing scheduled and activated assignments, the assignments still use the same schedule and you do not need to use Contact Center Management.

Prerequisites

Before you can use the XML automated assignments feature, you must:

- install it manually on the Contact Center Manager Administration server
  For more information, see the Contact Center Manager Administration Installation and Maintenance Guide.
- be familiar with creating XML files
  This feature does not include an interface for creating the XML files. However, it does include an XML Schema. The XML Schema file describes the format in which you must generate the files using the tool of your choice—either a Work Force Management (WFM) system or another third-party application—so that they can be interpreted by this feature. The file is called SWCXMLAssignments.xsd and is in the following folder on the Contact Center Manager Administration server: `C:\Program Files\Nortel Networks\WClient\Server\XMLAssignments`, where `C` is the drive on which you installed Contact Center Manager Administration.

Limitations

This section lists the maximum number of agent-to-skillset and agent-to-supervisor assignments that you can set up and schedule to run concurrently using the XML automated assignments feature.

Supervisor assignment limits

You can create an agent-to-supervisor assignment that contains a maximum of 1000 entries, where assigning an agent to a supervisor is considered an entry. Nortel recommends that you do not run multiple supervisor assignments concurrently.
Skillset assignment limits
You can create an agent-to-skillset assignment that contains a maximum of 1000 entries, where assigning an agent to a skillset is considered an entry and where the number of skillsets multiplied by the number of agents involved is less than 5000. Nortel recommends that you do not run multiple skillset assignments concurrently.

Generally, Nortel recommends that you do not assign more than 2500 entries per hour, a figure based on operational experience. However, due to the broad spectrum of processor speeds and the diversity of contact centers, this value is a guideline rather than a strict limit.

Overview of steps
The XML automated assignments feature involves the following general steps:

1. Create XML files for agent-to-supervisor and agent-to-skillset assignments using the tool of your choice (for example, a WFM system).

   Because agent-to-supervisor and agent-to-skillset assignment data cannot exist in the same XML file, you must create separate XML files for each type of assignment.

2. Place the XML files in the designated drop folder. This is the folder that you specified during the installation of the XML automated assignments feature. If you did not choose a specific folder, then place the files in the default folder: \Program Files\Nortel Networks\WClient\Assignments\XMLAssignments, where C is the drive on which you installed Contact Center Manager Administration.

3. When you place a file in this folder, the service automatically detects it and parses the file. If you specified a new assignment name in the file, the program creates a new assignment on the Contact Center Manager Server that you indicated in the file. If you specified an assignment name that exists on the selected server, the program updates the existing assignment with the new details.

4. After it parses the file, the service deletes it from the drop folder, thus ensuring that only new files are parsed.

5. If you created a new ad hoc assignment and specified it to Execute Now, the assignment runs immediately. If you created a new scheduled assignment,
you must schedule and activate it using the Contact Center Management interface.

New scheduled assignments created with the XML automated assignments feature do not run until you activate and schedule them in the Contact Center Management component. However, if you update an existing activated and scheduled assignment with the XML automated assignments feature, the schedule remains intact and the assignment remains activated. If you want the assignment to run only at the scheduled time, you must select the Schedule option in the XML file. If you choose the Execute Now option, the scheduled assignment runs twice: it runs immediately and at the scheduled time. If you do not include the <EXECUTENOW> field in your XML file, or if you type an invalid value in this field, the system defaults to scheduling the assignment, and you must use Contact Center Management to manually schedule the new assignment.

6. If the service encounters errors in the XML file that you created, it stops parsing the file, it does not create or update the assignment, and it moves the file to the designated drop folder for problem files. If you did not choose a specific location for problem files during the installation, the program places the files in the default location: C:\Program Files\Nortel Networks\WClient\Assignments\XMLAssignmentError, where C is the drive on which you installed Contact Center Manager Administration. The system notifies you of problem assignments in the Audit Trail component.

The program rejects files that contain more than 1000 entries and notifies you of rejected assignments in the Audit Trail component. An example of an entry is assigning an agent to a supervisor or to a skillset. To prevent the program from rejecting your files, limit each file to 1000 entries or less. For more information, see “Limitations” on page 129.

7. If the service rejects the XML file you create, fix the problem and place the file in the drop folder to be parsed again. Continue this process until the service successfully parses the file and creates or updates the assignment, and then schedule and activate the assignment in Contact Center Management, if required.

**Specifications for XML files**

Valid XML files must contain the following data items for the service to parse them successfully:
- **Version**—The service uses the version field to identify the XML Schema version used by the XML file.

- **Assignment name**—This is an alphanumeric data field that identifies the name of the assignment to be created or updated. This data is enclosed within the XML tags `<ASSIGNMENTNAME> </ASSIGNMENTNAME>`.

- **Execute option**—Use this optional field to specify whether you want to run the assignment immediately or schedule it. If you want to run the assignment immediately, type the value Execute Now. If you want to save and schedule a new assignment in Contact Center Management, or if you want to update an existing scheduled assignment, type the value Schedule. (If you do not include this field in your XML file, or if you type an invalid value in this field, the system defaults to scheduling the assignment, and you must use Contact Center Management to manually schedule the new assignment.) The value you choose is enclosed within the XML tags `<EXECUTEOPTION> </EXECUTEOPTION>`.

- **Contact Center Manager Server IP address**—This is an alphanumeric field used to identify the IP address of the Contact Center Manager Server on which you want to create or update the assignment. This data is enclosed within the XML tags `<IPADDRESS> </IPADDRESS>`.

- **Agent details**—The agent details section contains data that uniquely identifies an agent (for example, the agent’s first name, last name, and phoneset login ID). In this section, the first name and last name are optional; the login ID is mandatory. This data is enclosed within the following XML tags:

```xml
<AGENT>
  <FIRSTNAME> </FIRSTNAME>
  <LASTNAME> </LASTNAME>
  <LOGINID> </LOGINID>
</AGENT>
```

- **Skillset details**—The skillset details contain the skillset name and priority for the agent-to-skillset assignment. This data is enclosed within the following XML tags:

```xml
<Skillset>
  <NAME> </NAME>
</Skillset>
```
The XML skillset tag `<SKILLSET>` is embedded within the agent XML tag `<AGENT>` for each skillset assigned to or unassigned from an agent, as shown in the following script example. In this section, the first name and last name are optional; the remaining data is mandatory:

```xml
<AGENT>
  <FIRSTNAME>  </FIRSTNAME>
  <LASTNAME>  </LASTNAME>
  <LOGINID>  </LOGINID>
  <SKILLSET>
    <NAME>  </NAME>
    <PRIORITY>  </PRIORITY>
  </SKILLSET>
  <SKILLSET>
    <NAME>  </NAME>
    <PRIORITY>  </PRIORITY>
  </SKILLSET>
  ............
  ............
</AGENT>
```

- **Supervisor details**—The supervisor details section contains data that uniquely identifies the supervisor to whom the agent is to be assigned. In this section, the name is optional; the ID is mandatory. This data is enclosed within the following XML tags:

```xml
<PRIMARYSUPERVISOR>
  <ID>  </ID>
  <NAME>  </NAME>
</PRIMARYSUPERVISOR>
```
The supervisor XML tag <SUPERVISOR> is embedded within the agent XML tag <AGENT>. The supervisor tag appears once within the agent tag for each agent-to-supervisor assignment, as shown in the following script example. In this section, the agent first name, last name, and primary supervisor name are optional; the login ID and ID values are mandatory:

<AGENT>
<FIRSTNAME>  </FIRSTNAME>
<LASTNAME>  </LASTNAME>
<LOGINID>  </LOGINID>
<PRIMARYSUPERVISOR>
<ID>  </ID>
<NAME>  </NAME>
</PRIMARYSUPERVISOR>
</AGENT>

Sample XML data files

This section contains examples of XML files with agent-to-skillset assignment data and agent-to-supervisor assignment data. Both examples are based on the XML Schema definition file, SWCXMLAssignments.xsd, in the following folder on the Contact Center Manager Administration server: C:\Program Files\Nortel Networks\WClient\Server\XMLAssignments, where C is the drive on which you installed Contact Center Manager Administration.

Agent-to-skillset assignment data and agent-to-supervisor assignment data cannot exist in the same XML file.

Sample agent-to-skillset assignment XML file

<?xml version="1.0" encoding="UTF-8"?>
<ASSIGNMENTS xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="E:\Documents\WebClient\SWCXMLAssignments.xsd">
  <VERSION>1.0.0</VERSION>
  <IPADDRESS>10.10.10.10</IPADDRESS>
Sample agent-to-supervisor assignment XML file

```xml
<?xml version="1.0" encoding="UTF-8"?>
<ASSIGNMENTS xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="E:\Documents\Web Client\SWCXMLAssignments.xsd">
  <VERSION>1.0.0</VERSION>
  <IPADDRESS>10.10.10.10</IPADDRESS>
  <ASSIGNMENTNAME>AgentSalesAssign</ASSIGNMENTNAME>
  <EXECUTEOPTION>Execute Now</EXECUTEOPTION>
</ASSIGNMENTS>
```
<AGENT>
  <FIRSTNAME>John</FIRSTNAME>
  <LASTNAME>Smith</LASTNAME>
  <LOGINID>2312</LOGINID>
  <PRIMARYSUPERVISOR>
    <ID>007</ID>
    <NAME>James Monroe</NAME>
  </PRIMARYSUPERVISOR>
</AGENT>

<AGENT>
  <FIRSTNAME>Pat</FIRSTNAME>
  <LASTNAME>Jones</LASTNAME>
  <LOGINID>4523</LOGINID>
  <PRIMARYSUPERVISOR>
    <ID>3221</ID>
    <NAME>James Monroe</NAME>
  </PRIMARYSUPERVISOR>
</AGENT>

</ASSIGNMENTS>
# Chapter 6

**Access and Partition Management**

---

## In this chapter

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>What is new in Access and Partition Management</td>
<td>138</td>
</tr>
<tr>
<td>Overview</td>
<td>140</td>
</tr>
<tr>
<td>Access classes</td>
<td>145</td>
</tr>
<tr>
<td>Report groups</td>
<td>159</td>
</tr>
<tr>
<td>Standard partitions and reporting agents</td>
<td>162</td>
</tr>
<tr>
<td>User-defined partitions</td>
<td>171</td>
</tr>
<tr>
<td>Contact Center Manager Administration users</td>
<td>178</td>
</tr>
<tr>
<td>Partitions in Historical Reporting, Real-Time Reporting, and Contact Center Management</td>
<td>184</td>
</tr>
<tr>
<td>Access and Partition Management Reports</td>
<td>194</td>
</tr>
<tr>
<td>To upgrade from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0</td>
<td>196</td>
</tr>
</tbody>
</table>
What is new in Access and Partition Management

The following enhancements are available in the Access and Partition Management component:

- **Access different data in different components**—For example, a user has access to view only their agents in Contact Center Management, but has access to view all agents in Real-Time Reporting and Historical Reporting.

- **Standard Partitions**—With Standard Partitions, you can automatically assign all data of a particular type on a per-server and per-component basis. For example, on the Toronto server a user can view all agents in Real-Time Reporting, but views no agents in Contact Center Management. Unlike user defined partitions, standard partitions are dynamic, meaning that they automatically update as new data is added to a server. Therefore, if a user is assigned the All Agents Standard Partition, when a new agent is created and assigned to a supervisor, this user automatically sees the agent.

- **Consistent behavior of Partitions**—Partitions behave consistently across all three components to which they apply: Contact Center Management, Real-Time Reporting, and Historical Reporting.

- **User Interface redesign**—The user interface is redesigned so that an administrator can see at a glance the data that each user can access in each component, on each server.

- **Real-Time Reporting filters**—All users, except webadmin, can create Real-Time Reporting filters whether the user is assigned a partition or not. A user is no longer required to be assigned a user defined partition. The user can now be assigned any partition configuration.

- **Historical Reporting filters**—Users with access to Historical Reports, including webadmin, can create Historical Reporting filters whether the user is assigned a partition or not. A user is no longer required to be assigned a user defined partition. The user can now be assigned any partition configuration.

- **User defined report groups**—All user defined report groups are visible to a user who has access to all data.
- **Partitions of different types**—If an administrator assigns a user different types of partitions (for example, user defined and standard), the user sees the union of all data in all partitions.

- **Enhanced Real-Time Reporting access classes**—Access classes for both real-time tabular and graphical displays on each server are enhanced.

- **Enhanced Historical Reporting access classes**—Historical Reporting access classes, including Run and Import access and Report Creation access, are enhanced.

- **Contact Center Management access class**—Network Admin View is a new access class in Contact Center Management. Access levels are “None” and “Based on CCM privilege level”.

- **Access and Partition Management access classes**—Access and Partition Management has new access classes: User Administration, Access Classes, User Defined Partitions, and Report Groups.
Overview

You can use the Access and Partition Management component to create Contact Center Manager Administration users and to assign to users appropriate access privileges to the system. Contact Center Manager Administration users can log on to the Contact Center Manager Administration server and can use the Contact Center Manager Administration components to which they have access. You can control user access privileges by assigning basic access rights, access classes, and partitions, including reporting agent combinations.

To add a Contact Center Manager Server user (agent, supervisor, or supervisor/agent), you must use the Contact Center Management component or the Configuration Tool spreadsheet in the Configuration component. Some Contact Center Manager Server users (supervisors and supervisor/agents) can also be Contact Center Manager Administration users and can be given a Contact Center Manager Administration user ID and password to access the Contact Center Manager Administration server; however, many Contact Center Manager Server users never use Contact Center Manager Administration.

You can use Access and Partition Management to add, edit, view, or delete:

- access classes
- report groups (you cannot edit report groups)
- partitions
- Contact Center Manager Administration users

Access classes

You can use access classes to control the actions (for example, none, read only, read/update, read/update/create/delete) that users can perform in the Contact Center Management, Real-Time Reporting, Historical Reporting, Configuration, Scripting, and Access and Partition Management components.

For more information about access classes, see “Access classes” on page 145.
Report groups

Report groups are folders in Historical Reporting that store historical reports. There are two types of report groups: public and user-defined. Public report groups contain standard report templates. User-defined report groups contain no standard report templates.

When you create a report group, a folder for the report group is created in Historical Reporting. Users can save their custom reports in this report group folder to share with other report group members. Users can also customize a standard template and save it in their report group folder so that other members of their group can use the same custom report.

For more information about report groups in Access and Partition Management, see “Report groups” on page 159.

User-defined partitions

User-defined partitions are useful to restrict a user access to a specific list of data. You can use user-defined partitions in conjunction with standard partitions and reporting agents. They can contain any number of specific data items. You need to maintain user-defined partitions. For more information, see “User-defined partitions” on page 171.

Contact Center Manager Administration users

When you define Contact Center Manager Administration users, you can assign to them:

- access rights to the appropriate components within Contact Center Manager Administration.
- access classes that control the actions they can perform in these components.
- standard and user-defined partitions and reporting agent combinations that control the data they can see in these components.
**Access rights**
The most basic security level is the overall right to access the components within Contact Center Manager Administration. You can assign access rights to a user in the User Administration view of the Access and Partition Management component. When you add Contact Center Manager Administration users, you can specify which components the users can access. If you do not grant a user basic access to a component, then the component is not visible to the user on the Contact Center Manager Administration launchpad.

<table>
<thead>
<tr>
<th>Basic Access Rights</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access and Partition Management</td>
</tr>
<tr>
<td>Configuration</td>
</tr>
<tr>
<td>Emergency Help</td>
</tr>
</tbody>
</table>

**Partitions**
You can use partitions to specify which data Contact Center Manager Administration users can view and manage on a per-server basis in the Real-Time Reporting, Historical Reporting, and Contact Center Management components. You can configure partitions for each user in the User Administration view of the Access and Partition Management component. After you grant a user basic access rights to these components, you can control the data that the user can access on each server by adding the data elements to the partition assigned to the user. You can, for example, give a user access to data on only one server in the network.

Partitions can have one of, or a combination of, the following access rights:

- **Full data across all servers**—This is the default setting for a new Contact Center Manager Administration user. This user can view all data on all servers configured on the Contact Center Manager Administration server.

- **Server rights**—It is possible to assign a user access to all data on a server, to assign access to no data on a server, or to specify the data that a user can
view on a server. Before you can perform any of the previous actions, you must clear the Full Data Across All Servers check box.

- **Standard partitions**—Standard partitions are dynamic. The All Agents & Supervisors partition is one of several standard partitions. The All Agents & Supervisors partition provides a Contact Center Manager Administration user access to all agents and supervisors on the server for which this partition is configured.

To configure Standard partitions for a user, you must clear the Full Data Across All Servers check box.

- **Reporting agents**—When you assign a supervisor in the Reporting Agents list to a Contact Center Manager Administration user, the user can see all agents associated with that supervisor on the configured server.
To configure the Reporting Agents feature for a user, you must clear the Full Data Across All Servers check box.

For a Contact Center Manager Administration user who is also a supervisor, you can link the two profiles, ensuring that the supervisor automatically sees all their agents in the historical reports, real-time displays, and in Contact Center Management. After you associate a Contact Center Manager Administration user with a supervisor, then the user automatically sees all the supervisor’s reporting agents.

If you do not change the Full Data Across all Servers default partition configuration for a new user, that user can see all data in the Historical Reporting, Real-Time Reporting and Contact Center Management components on each server in the network. This is based on the assumption that the user has sufficient basic access rights and access class for these components.

For more information, see Appendix B, “Supervisor/reporting agents matrix.”

For more information about Contact Center Manager Administration users, see “Contact Center Manager Administration users” on page 178.
Access classes

You can use access classes to control the actions that users can perform in the Contact Center Management, Real-Time Reporting, Historical Reporting, Configuration, Scripting, and Access and Partition Management components.

Users do not require an access class to work in any other component; instead, they require only basic access rights.

Contact Center Management access class elements

The following table describes the available access levels for the Contact Center Management access class elements.

<table>
<thead>
<tr>
<th>Contact Center Management Access Class Element</th>
<th>Access Levels</th>
</tr>
</thead>
<tbody>
<tr>
<td>CCM</td>
<td>■ None</td>
</tr>
<tr>
<td></td>
<td>■ View Agent Properties</td>
</tr>
<tr>
<td></td>
<td>■ Edit Agent Properties</td>
</tr>
<tr>
<td></td>
<td>■ Edit Agent Properties including Partitions</td>
</tr>
<tr>
<td></td>
<td>■ Add/Edit/Delete Agents</td>
</tr>
<tr>
<td></td>
<td>■ View Agent and Supervisor Properties</td>
</tr>
<tr>
<td></td>
<td>■ Edit Agent and Supervisor Properties</td>
</tr>
<tr>
<td></td>
<td>■ Add/Edit/Delete Agents and Supervisors</td>
</tr>
<tr>
<td>Skillset Assignment</td>
<td>■ None</td>
</tr>
<tr>
<td></td>
<td>■ View Assignments</td>
</tr>
<tr>
<td></td>
<td>■ Ad-hoc Assignments</td>
</tr>
<tr>
<td></td>
<td>■ Run Now Assignments</td>
</tr>
<tr>
<td></td>
<td>■ Add/Edit/Delete Assignments</td>
</tr>
<tr>
<td></td>
<td>■ Schedule Assignments</td>
</tr>
</tbody>
</table>
### Contact Center Management Access Class Element

<table>
<thead>
<tr>
<th>Contact Center Management Access Class Element</th>
<th>Access Levels</th>
</tr>
</thead>
<tbody>
<tr>
<td>Supervisor Assignment</td>
<td>- None&lt;br&gt;- View Assignments&lt;br&gt;- Ad-hoc Assignments&lt;br&gt;- Run Now Assignments&lt;br&gt;- Add/Edit/Delete Assignments&lt;br&gt;- Schedule Assignments</td>
</tr>
<tr>
<td>CCM - Network Admin view</td>
<td>- None&lt;br&gt;- Access based on CCM privilege level</td>
</tr>
</tbody>
</table>

### Real-Time Reporting access elements

The following table describes the available access levels for the Real-Time Reporting access class elements.

<table>
<thead>
<tr>
<th>Real-Time Reporting Access Class Element</th>
<th>Access Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Real-Time Tabular Displays</td>
<td>- None&lt;br&gt;- Launch&lt;br&gt;- Create Private&lt;br&gt;- Create Public</td>
</tr>
<tr>
<td>Real-Time Graphical Displays</td>
<td>- None&lt;br&gt;- Launch&lt;br&gt;- Create Private&lt;br&gt;- Create Public</td>
</tr>
</tbody>
</table>

### Historical Reporting access class elements

Historical Reporting has one access class element. The access levels are None, Run and Import, and Report Creation.
Configuration access class elements

The following table describes the available access levels for the Configuration access class elements.

<table>
<thead>
<tr>
<th>Configuration Access Class Element</th>
<th>Access Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity Codes</td>
<td>- None</td>
</tr>
<tr>
<td></td>
<td>- Read Only</td>
</tr>
<tr>
<td></td>
<td>- Read and Update</td>
</tr>
<tr>
<td></td>
<td>- Read Update Create/Delete</td>
</tr>
<tr>
<td>Threshold Classes</td>
<td>- None</td>
</tr>
<tr>
<td></td>
<td>- Read Only</td>
</tr>
<tr>
<td></td>
<td>- Read and Update</td>
</tr>
<tr>
<td></td>
<td>- Read Update Create/Delete</td>
</tr>
<tr>
<td>CDN (Route Points)</td>
<td>- None</td>
</tr>
<tr>
<td></td>
<td>- Read Only</td>
</tr>
<tr>
<td></td>
<td>- Read and Update</td>
</tr>
<tr>
<td></td>
<td>- Read Update Create/Delete</td>
</tr>
<tr>
<td>Call Presentation Classes</td>
<td>- None</td>
</tr>
<tr>
<td></td>
<td>- Read Only</td>
</tr>
<tr>
<td></td>
<td>- Read and Update</td>
</tr>
<tr>
<td></td>
<td>- Read Update Create/Delete</td>
</tr>
<tr>
<td>DNISs</td>
<td>- None</td>
</tr>
<tr>
<td></td>
<td>- Read Only</td>
</tr>
<tr>
<td></td>
<td>- Read and Update</td>
</tr>
<tr>
<td></td>
<td>- Read Update Create/Delete</td>
</tr>
<tr>
<td>Configuration Access Class Element</td>
<td>Access Level</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Formulas</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td></td>
<td>Read Update Create/Delete</td>
</tr>
<tr>
<td>Global Settings</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td>Historical Statistics</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td>IVR ACD-DNs (not available on a SIP server)</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td></td>
<td>Read Update Create/Delete</td>
</tr>
<tr>
<td>Media Servers (only available on a SIP server)</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td></td>
<td>Read Update Create/Delete</td>
</tr>
<tr>
<td>Media Services (only available on a SIP server)</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td></td>
<td>Read Update Create/Delete</td>
</tr>
<tr>
<td>Phoneset Displays (not available on a SIP server)</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td>Configuration Access Class Element</td>
<td>Access Level</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Phonesets and Voice Ports</td>
<td>None</td>
</tr>
<tr>
<td>(not available on a SIP server)</td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td></td>
<td>Read Update Create/Delete</td>
</tr>
<tr>
<td>Real-Time Statistics</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td>Routes</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td></td>
<td>Read Update Create/Delete</td>
</tr>
<tr>
<td>Skillsets</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td></td>
<td>Read Update Create/Delete</td>
</tr>
<tr>
<td>Network Communication Parameters</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td>Contact Types Configuration</td>
<td>None</td>
</tr>
<tr>
<td></td>
<td>Read Only</td>
</tr>
<tr>
<td></td>
<td>Read and Update</td>
</tr>
<tr>
<td></td>
<td>Read Update Create/Delete</td>
</tr>
</tbody>
</table>
Scripting access class elements

The following table describes the available access levels for the Scripting access class elements.

<table>
<thead>
<tr>
<th>Scripting Access Class Element</th>
<th>Access Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scripts</td>
<td>- None</td>
</tr>
<tr>
<td></td>
<td>- Read Only</td>
</tr>
<tr>
<td></td>
<td>- Read and Update</td>
</tr>
<tr>
<td></td>
<td>- Read Update Create/Delete</td>
</tr>
<tr>
<td>Script Variables</td>
<td>- None</td>
</tr>
<tr>
<td></td>
<td>- Read Only</td>
</tr>
<tr>
<td></td>
<td>- Read and Update</td>
</tr>
<tr>
<td></td>
<td>- Read Update Create/Delete</td>
</tr>
<tr>
<td>Application Thresholds</td>
<td>- None</td>
</tr>
<tr>
<td></td>
<td>- Read Only</td>
</tr>
<tr>
<td></td>
<td>- Read and Update</td>
</tr>
</tbody>
</table>

Access and Partition Management Reporting access class elements

Users assigned an access level to any of these access class elements have access across all servers. The following table describes the available access levels for the Access and Partition Management access class elements.

<table>
<thead>
<tr>
<th>Access and Partition Management Reporting Access Class Element</th>
<th>Access Level</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Administration access</td>
<td>- None</td>
</tr>
<tr>
<td></td>
<td>- Read Only</td>
</tr>
<tr>
<td></td>
<td>- Read and Update</td>
</tr>
<tr>
<td></td>
<td>- Read Update Create/Delete</td>
</tr>
</tbody>
</table>
If you work in a multiple Contact Center Manager Server environment, each access class that you create spans multiple servers. However, to configure and manage the access classes by logging on to only one server—the Contact Center Manager Administration server, where access classes are stored.

The following diagram shows a simple network configuration for Contact Center Manager Administration. When you log on to the Contact Center Manager Administration server from a client workstation, you can use the Access and Partition Management component to configure access classes for the Contact Center Manager Servers, and for the Network Control Center (NCC) server.
Each access class that you create spans all servers in the network, even if you select no access class elements on a particular server. For example, in the preceding network scenario, you create an access class that contains Configuration access elements only on the NCC server, and you assign it to a user. By specifying no access elements on any other server in the network, you limit the user’s actions on all servers, not only on the NCC server. This user does not have access to any of the Configuration elements on either server in Contact Center Manager Server; the user can perform only the actions included in the access class to configure the NCC server.

If the user needs to configure either server in Contact Center Manager Server, you must edit the user’s access class to include access rights on the other servers.

When you grant a user access privileges that span multiple servers, the user needs only to log on to one server—the application server—to access all servers included in the access class. Users no longer need to log on to each server to which they have access.
Creating a new access class

1. In the Access and Partition Management component, from the Add menu, select New Access Class.

2. In the New Access Class Name box, type a name for the access class. Use a descriptive name for the type of user to have this access level or, the type of privileges available at this access level. You can use alphanumeric characters only for the access class name.

3. Click Submit.

Result: The new access class appears in the system tree and the available servers are listed underneath.

4. Select a server on which you want to configure the access class.

Result: The Access Class Properties window appears.

5. For each element in the Access Class Properties list, select an access level.

6. Click Submit.
To grant access on all servers in your network, you must configure each server shown in the list of servers.

**Viewing an access class**

1. In the Access and Partition Management component, from the View/Edit menu, select Access Classes.
   
   **Result:** The access classes appear in the system tree.

2. In the system tree, click an access class.
   
   **Result:** The list of users currently assigned to the selected access class appears in the right pane.

**To define typical contact center administrator access**

The following access privileges provide examples of those that an administrator might have in a typical contact center on at least one server in the network. This administrator can perform the following tasks:

- Read, update, create, and delete all call presentation classes, skillsets, activity codes, phonesets, DNISs, routes, IVR ACD-DNs, CDNs (Route Points), scripts and script variables, formulas, threshold classes, contact types and all users, including supervisors. This user can also assign Contact Center Manager Administration user IDs and passwords to the supervisors and supervisor/agents who need to log on to the Contact Center Manager Administration server and use Contact Center Manager Administration (the administrator must then finish configuring the new Contact Center Manager Administration user profile in Access and Partition Management).

- View and assign all agents in agent-to-supervisor assignments and agent-to-skillset assignments.

- Create and run reports in Historical Reporting, and create and view all real-time displays.

- Edit all historical statistics, real-time statistics, and applications.

- View the status of Emergency Help requests.

To give a contact center administrator these sample access privileges in Contact Center Manager Administration, you must use a combination of two levels of security: basic access rights and access classes.
To ensure that administrators always have access to all data, ensure you assign the Full Data Across All Servers option in their partition configuration.

1. Create an administrator access class that has read, update, create, and delete access for the following elements on the applicable server:
   - call presentation classes
   - skillsets
   - activity codes
   - phonesets and voice ports
   - DNISs
   - routes
   - IVR ACD-DNs
   - CDNs (Route Points)
   - formulas
   - threshold classes
   - scripts
   - script variables
   - contact types

   The administrator access class must also have read and update access for:
   - historical statistics
   - real-time statistics
   - application thresholds

   Additionally, the administrator access class must have:
   - add, edit, delete agents and supervisors access in CCM
   - schedule assignments access under both the Agent to Supervisor Assignment and Skillset Assignment access class elements

   Finally, the administrator access class must have:
   - create public access for real-time tabular and graphical displays
   - report creation access for historical reporting.

2. Create the administrator user profile in Access and Partition Management, and give the administrator basic access rights to all components in Contact Center Manager Administration, except Access and Partition Management. (Users assigned basic access to Access and Partition Management also need
to be assigned an access class with appropriate permissions on the Contact Center Manager Administration server. There must be one administrator with this privilege in the contact center network.)

When you grant basic access to the remaining components of Contact Center Manager Administration, the administrator can launch the Outbound Campaign Management Tool, view the Audit Trail, and view the status of Emergency Help requests.

3. Assign the access class to the administrator.

If the administrator requires access privileges on more servers in the network, you can add the access privileges on the additional servers to the administrator’s access class.

To define typical supervisor access

The following access privileges are examples of those that a typical contact center supervisor might have on one server in the network. This supervisor can perform the following tasks:

- View and edit agents and supervisors, and view and assign all agents in agent-to-supervisor assignments and agent-to-skillset assignments.
- Create and run agent performance reports in Historical Reporting.
- Create and view all real-time displays.
- View the status of Emergency Help requests.

To give a contact center supervisor these access privileges in Contact Center Manager Administration, you need to use a combination of up to four features: basic access rights, access classes, partitions, and, optionally, supervisor/reporting agent combinations.

1. Create a supervisor access class that has the following access levels on the applicable server:

- edit agent and edit supervisor properties access for CCM
- schedule assignments access for both Agent to Supervisor Assignments and Skillset Assignments
- create public access for Real-Time Tabular and Graphical Displays
- report creation access for Historical Reporting
The supervisor uses the access class to view and edit agents and supervisors, assign agents to partitions in Contact Center Management, view and assign all agents in agent-to-supervisor assignments and agent-to-skillset assignments, schedule these assignments, create and run performance reports, and create and view all real-time displays.

If you do not want supervisors to view and edit users, but want them only to create ad hoc assignments, then the access class must have *Ad Hoc Assignments* access for agent-to-supervisor assignments and agent-to-skillset assignments. The supervisor access class does not include any access level in the CCM access class element.

2. Create the supervisor user profile in Access and Partition Management and give the supervisor basic access rights to Real-Time Reporting, Historical Reporting, Contact Center Management, and Emergency Help.

The supervisor can now have basic access to each component, create and view real-time displays (containing only the data included in their partition configuration), create and run historical reports (only the agent performance reports included in their partition, and only with the partitioned agents, skillsets, and applications), and view the status of Emergency Help requests.

3. Assign the access class to the supervisor’s Contact Center Manager Administration user profile. Whenever possible, use standard partitions and reporting agents options as these options are dynamic and aid performance.

If the supervisor requires access privileges on more servers in the network, you can add the access privileges on the additional servers to the supervisor access class.

To view an example of how to configure a Contact Center Manager Administration user and assign partitions, supervisor/reporting agent combinations, and other features such as access classes and report groups, see “Sample task flow to configure Contact Center Manager Administration users” on page 179.
If you do not clear the Full Data Across All Servers check box for a user, that user can view all data in the Historical Reporting, Real-Time Reporting and Contact Center Management components on each server on the network. This is based on the assumption that the user has sufficient basic access rights and access class for these components. For more information, see “Supervisor/reporting agents matrix” on page 459.

If you assign a user a user-defined partition only, the user can see only the data that is in the user-defined partition. Therefore, when you add an agent in Contact Center Management, you must also add the agent to the user’s user-defined partition to enable the user to see the agent in real-time displays, historical reports, and in the Contact Center Management component.

Where possible, use standard partitions and reporting agents instead of user-defined partitions, as standard partitions and reporting agents are dynamic and you need not update or maintain them.

You can use standard partitions in conjunction with user-defined partitions.

When you create and assign partitions, the following factors increase the performance hit for the users to whom you assign the partitions when they connect to Contact Center Manager Administration:

- The greater the amount of data that you include in each partition, the greater the performance hit.
- The more partitions you assign to users, the greater the performance hit.
- The previous limit on the number of each element that could be added to a partition (999) is removed. For tips to correctly configure partitions, see “Server performance” on page 285.

Nortel recommends that:

- you use standard partitions as much as possible to improve performance
- you configure and assign your partitions according to your company internal departmental organization, granting users access only to the data that they regularly need to see
Report groups

Because you can add report groups to partitions, you may want to create the report groups before you define the partitions and assign them to users.

Two categories of report groups are available in Historical Reporting:

- **Public report groups**—These report groups contain the standard public report templates. The eight public report groups are:
  - Agent Performance
  - Configuration
  - Call-by-Call
  - Multimedia
  - Networking
  - Outbound
  - Others
  - NCC (on the NCC only)

- **User-defined report groups**—These report groups contain the report templates that users belonging to the group customized and want to share with other members of the report group. The user-defined report groups that you create in this window are for use in Historical Reporting. You can assign any unique name to these groups.

**Public report groups versus user-defined report groups**

Unlike the public report groups that contain all of the standard templates, user-defined report groups contain no standard templates. The user-defined report groups that you create in Access and Partition Management are folders for Historical Reporting users who belong to the same group to share their customized reports. Users can customize a standard template and save it in their group folder so that other group members can use the same custom report.
You can create user-defined report groups to reflect each department in your contact center, such as the Sales Group or the Marketing Group. If you are configuring a shared contact center, you can also create separate groups for each company sharing the contact center, such as the Best Air Group and the Econo Air Group. In this way, you can keep customized reports that contain company information separate from other companies in the same contact center.

The data shown in each report is based on the partitions assigned to the user and the selection criteria the user applies to the report.

You can use report groups to grant a user access to a very limited number of reports. For example, if you do not want to give a user access to any of the standard report templates, you can create a user-defined report group and add it to the partition assigned to the user. When the user opens Historical Reporting, they see only the user-defined report group folder, and can only see reports that other members of the group saved in the group folder.

After you create a report group, you may add it to a partition created under the same server as the report group. Then you may assign the partition to the users belonging to the report group. When these users log on to Contact Center Manager Administration, they see the report group name in Historical Reporting under the server where you created it.

Standard report groups may be assigned to a user in the same way as standard partitions. There is no requirement to create and maintain a user-defined partition. The standard partition “All User Defined Report Groups” may also be assigned to a user on a per-server basis. This allows the user access to any user-defined report groups created on that server.
Creating a report group

1. Select **Add > New Report Group** from the menu.

2. In the **Report group name** box, enter a name.

3. From the **Create the group under server** list, select the server.

4. Click **Submit**.

**Result:** The new Report Group appears on the system tree in the Report Groups folder.
Standard partitions and reporting agents

Partitions restrict the data that users can view in the following three components of Contact Center Manager Administration:

- Historical Reporting
- Real-Time Reporting
- Contact Center Management

An administrator can use the following ways to partition the data that users can see.

**Full data across all servers**—When an administrator first creates a user, the user is assigned the Full Data Across All Servers option by default so the user can view all data on all servers. If a new server is added to the system, the user with this level of data access can see all data on that server too.

**Server rights**—An administrator can assign a user access to all data or no data on particular servers. To configure standard partitions and reporting agents on a particular server, an administrator must assign the Configure option on that server.
Standard partitions (this includes report groups)—A Standard partition contains all data of a particular type on a particular server. The administrator can assign all data on a per-component basis (only among those components to which the user is granted basic access). For example, the administrator can choose to grant the user access to All agents and All skillsets in both Contact Center Management and Real-Time Reporting on the Toronto server only. The administrator can choose from:

- All Agents & Supervisors
- All Skillsets
- All Applications
- All CDNs (Route Points)
- All DNISs
- All User Defined Report Groups
- All standard reports that are shipped with the software on selected servers and selected components
Standard partitions are dynamic, which means that anytime a new data element is added to the system, it is automatically available to the Contact Center Manager Administration user. In this regard, Standard partitions are similar to Reporting Agents. Standard partitions may be assigned on a per-component basis. For example, the administrator can assign the All Skillsets partition to the Real-Time Reporting component only.

To assign a user a Standard partition on a Contact Center Manager Server, click the Standard & Reporting Agents heading, select the Standards tab, select the Configure option for the server and then select the server from the Configure Server list.

It is possible to assign Standard partitions on a per-component basis:

- **CCM**—Contact Center Management
- **RTR**—Real-Time Reporting
- **HR**—Historical Reporting

In the preceding example, All Agents & Supervisors and All Skillsets are assigned to the Contact Center Management and Real-Time Reporting components while only All CDNs (Route Points) are assigned to the Historical Reporting component.

**Reporting agents**

Use the Reporting Agent feature to dynamically link supervisors and all their reporting agents with one or more Contact Center Manager Administration users, thereby enabling the users to view the agents in Contact Center Manager Administration components, such as Real-Time and Historical Reporting, and Contact Center Management. You assign Supervisor/Reporting agent combinations to Contact Center Manager Administration users by using the Reporting Agents tab in the Standard & Reporting Agents section in the User Properties window of Access and Partition Management.

For a detailed list of how this feature works in conjunction with partitions in each of the Contact Center Manager Administration components (Real-Time Reporting, Historical Reporting and Contact Center Management), see Appendix B, “Supervisor/reporting agents matrix.”
User types

It is important to know the difference between a Contact Center Manager Server user and a Contact Center Manager Administration user.

<table>
<thead>
<tr>
<th>User type</th>
<th>User definition</th>
<th>Created in</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact Center Manager Server user</td>
<td>agents, supervisors, supervisor/agents</td>
<td>Contact Center Management or Configuration</td>
</tr>
<tr>
<td>Contact Center Manager Administration user</td>
<td>anyone who logs on to the Contact Center Manager Administration server and monitors the performance and activities of Contact Center Manager Server using Contact Center Manager Administration; this user can be a supervisor or an administrator</td>
<td>Access and Partition Management</td>
</tr>
</tbody>
</table>

Users

After you create a supervisor's Contact Center Manager Server user profile in Contact Center Management (or Configuration), to enable the supervisor to log on to the Contact Center Manager Administration server and use Contact Center Manager Administration, you must also configure a Contact Center Manager Administration user profile for this supervisor.

Supervisors who do not need to use Contact Center Manager Administration do not need a Contact Center Manager Administration user profile; these supervisors require only a Contact Center Manager Server user profile.

When you configure the supervisor's Contact Center Manager Administration user profile, you can create a link between two user profiles (the Contact Center Manager Administration user profile and the supervisor's Contact Center Manager Server user profile) by using the Supervisors tab in the Standard & Reporting Agents area of the Partitions section in Access and Partition Management.
Management. Each name on the Supervisors tab represents a supervisor and all of their reporting agents on a per-server basis. Therefore, when you link a supervisor's name with a Contact Center Manager Administration user, the user can automatically see all the supervisor's reporting agents.

This association is dynamic, meaning that each time a new agent is assigned to the supervisor, the agent is automatically associated with the supervisor's Contact Center Manager Administration user profile.

Use this feature to set up supervisors so they can view all of their own reporting agents, or you can enable one supervisor to see all the reporting agents of another supervisor. The following shows how to configure Reporting agents in Access and Partition Management.

**To configure reporting agents**

To view reporting agents, select a user, click the Partitions heading, and then click the Standard & Reporting Agents section. If Full Data Across All Servers check box is selected, the Standard & Reporting Agents heading is disabled.

To assign a user Reporting Agents on a Contact Center Manager Server, set the server to Configure and select the server from the list. To assign Reporting Agents, click the Reporting Agents tab and select supervisors from the table. You can combine a configuration to include standard partitions and Reporting Agents.
Supervisors (Reporting Agents) are assigned on a per-component basis:

- **CCM**—Contact Center Management
- **RTR**—Real-Time Reporting
- **HR**—Historical Reporting

**Reporting agents and standard partition example**

The company Best Air has two sales departments, Europe and Canada. The two corresponding supervisors for each department are Andrew Engel and Liz Matthews. The administrator creates two new Contact Center Manager Administration users for the two supervisors and assigns them both the following standard partitions on one Contact Center Manager Server:

- **Contact Center Management**—All Skillsets
- **Real-Time Reporting**—All Skillsets
- **Historical Reporting**—All standard report groups, All CDNs (Route Points), and All DNISs

The administrator assigned this reporting agent configuration for all available components: Contact Center Management, Real-Time Reporting and Historical Reporting. Additionally, each User profile is assigned as a Supervisor/Reporting Agent.
**Result in Real-Time Reporting**
In Real-Time Reporting (including Filters), Andrew can use all Skillsets as he is assigned the All Skillsets standard partition for this component. He can also see any agents reporting to him as he is configured with the Supervisors “Andrew Engel” for all components.

**Result in Historical Reporting**
In Historical Reporting, Andrew can use all CDNs (Route Points) and DNISs as these standard partitions are assigned to his user properties. He can also use all agents reporting to him. This is true for both Selection Criteria and filters.

Andrew can also see all of the standard report groups as these are included in his Standard partition configuration.

**Result in Contact Center Management**
Andrew has access to all skillsets and only the agents that are assigned to him. In the Supervisors view, only one supervisor (himself) is displayed.

For Andrew Engel to view all of Liz's reporting agents, include Liz Matthews in Andrew’s user profile (in the Reporting Agents Tab). The administrator may also specify the components to make available to these agents. If only a subset of these agents is required, you can create a user-defined partition and assign it to Andrew’s properties. Assigning user-defined partitions is covered in the next section.

**Differences between user-defined partitions, standard partitions and reporting agent combinations**
In addition to assigning a Contact Center Manager Administration user standard (All Agents & Supervisors) or user-defined partitions, you can assign a user a supervisor/reporting agent combination. The primary advantage of reporting agents and standard partitions over user-defined is that standard and reporting agents are dynamic and require no maintenance.

As an example, a user is assigned a supervisor/reporting agent combination. In Real-Time Reporting, to view only those reporting agents on a display, the user can assign this supervisor/real-time reporting combination to the display. For more information, see “Reporting agents” on page 164, and Appendix B, “Supervisor/reporting agents matrix”.
When you assign a Contact Center Manager Administration user a partition configuration containing agents, it is similar to assigning the user a supervisor/reporting agent combination. The difference between using user-defined, Standard and Reporting agent partitions is illustrated in the following table.

<table>
<thead>
<tr>
<th>User-defined partitions containing agents</th>
<th>Standard partitions</th>
<th>Supervisor/reporting agent combination</th>
</tr>
</thead>
<tbody>
<tr>
<td>You can customize user-defined partitions.</td>
<td>You cannot customize standard partitions.</td>
<td>You cannot customize supervisor/reporting agent combinations.</td>
</tr>
<tr>
<td>You can specify which agents you want the Contact Center Manager Administration user to see, on a per-server basis.</td>
<td>When you assign a Contact Center Manager Administration user a standard partition, you grant the user access to all agents on a per-server basis.</td>
<td>When you assign a Contact Center Manager Administration user a supervisor/reporting agent combination, you automatically grant the user access to all the supervisor’s reporting agents, on a per-server basis.</td>
</tr>
</tbody>
</table>

Partitions are not dynamic. When you assign a new agent to a supervisor, you must manually update the partition assigned to the supervisor (the Contact Center Manager Administration user) to include the new agent.

<table>
<thead>
<tr>
<th></th>
<th>Standard partitions are dynamic.</th>
<th>Supervisor/reporting agent combinations are dynamic.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>When a new agent is added to a server in the system they are automatically available to the Contact Center Manager Administration user who is assigned a standard partition on that server.</td>
<td>When you assign a new agent to a supervisor, the corresponding supervisor/reporting agent combination is automatically updated to include the new agent. Any Contact Center Manager Administration users who have this supervisor/reporting agent combination assigned to them automatically have access to this new agent.</td>
</tr>
</tbody>
</table>
Example
Based on your contact center configuration, you may want to combine partitions containing agents and supervisor/reporting agent combinations. For example, you may want a user to always see their reporting agents plus three other agents who are not assigned to the user (so that the user can act as the associated supervisor for these agents). In this case, you assign the user a partition containing the three associated agents and the supervisor/reporting agent combination containing the user’s own agents.

To see an example of how to configure Contact Center Manager Administration users and assign partitions, supervisor/reporting agent combinations, and other features such as access classes and report groups, see “Sample task flow to configure Contact Center Manager Administration users” on page 179.
User-defined partitions

User-defined partitions are useful to restrict a user access to a specific list of data. You can use user-defined partitions in conjunction with standard partitions and reporting agents.

To improve performance, Nortel recommends that you use standard partitions and reporting agents instead of user-defined partitions.

Creating a user-defined partition

1. Select Add > New User Defined Partition.
   
   **Result:** You are prompted to enter a partition name

2. In the New Partition Name box, type the partition name.

3. Click Submit.
   
   **Result:** The partition is created and appears in the system tree.

1. In the system tree, select the partition.
   
   **Result:** A list of available servers appears under the partition.
2 From the list of servers, select a server.

**Result:** The Partitions Properties window appears.

![Partitions Properties Window]

In this window you can select elements to add to your user-defined partition on a per-server basis.

3 Select the tabs to load the data elements for that server.

4 Select the elements that you want to include in the user-defined partition.

5 Click **Submit** to save.

6 Repeat this procedure with each server containing data that you want to add to the user-defined partition.

If you create user-defined partitions to contain all of a particular element, for example, All agents or All CDNs (Route Points) on a particular server, use standard partitions instead. You can configure standard partitions in the user properties window. Standard partitions require no maintenance when you add new elements to the Contact Center Manager Server. Use user-defined partitions only if a specific set of data is required for the user.

For step-by-step procedures about partitions, see Contact Center Manager Administration online Help.

Click a partition name in the tree to view the list of users who are currently assigned the partition.
To give users access to data on more than one server in your network, you can create a partition that spans multiple servers. However, note that when doing so, you must choose the partition properties on each server so the user can see the data on these servers. For example, for a user to see agents configured on two servers, you must select this agent on each server individually when configuring the partition. If you choose elements on one server for the partition, then the users assigned the partition can see only the data on this one server.

If a large number of agents configured on the server, when you click the Agents tab, you may have to wait a few moments while the system retrieves the agent data.

When you edit user-defined partitions, note that the greater the number of users assigned to the partition that you edit, the greater your performance hit, particularly if these users have Real-Time Reporting filters configured.

Nortel recommends:

- that you keep the amount of data included in each partition as minimal as possible because small partitions lead to more efficient application response time.
- that you configure and assign your partitions according to your company internal departmental organization, granting users access only to the data that they regularly need to see.
- that you use standard partitions where possible, including server rights options that can be configured for any configured server; for example, All Data on server Toronto. Standard partitions require no maintenance and are more efficient to use than user-defined partitions that may contain large amounts of data.

**To assign user-defined partitions**

Create user-defined partitions in the Partitions view (choose View/Edit > Partitions). User-defined partitions can contain specific data elements across multiple servers. Assign user-defined partitions to a user in the Users view (choose View/Edit > Users). You can combine user-defined partitions with standard partitions and supervisor/reporting agent combinations.

You must clear the Full Data Across All servers check box before you can assign user-defined partitions.
As with standard partitions and reporting agent combinations, you can assign supervisors on a per-component basis:

- **CCM**—Contact Center Management
- **RTR**—Real-Time Reporting
- **HR**—Historical Reporting

**Partition properties**

When you create a partition, you can specify the following types of data:

- agents
- skillsets
- report groups
- applications
- CDNs (Route Points)
- DNISs

When you assign a partition that contains all six types of data to a user, the user sees either all data types in the partition, or a fraction of them, depending on the component to which the partition is assigned. The Contact Center Manager Administration components are each designed so users can work with particular types of data. For example, Contact Center Management is used strictly to configure and manage contact center supervisors and agents, and to assign agents to skillsets; therefore, the only partition elements that appear in Contact Center Management are agents and skillsets. If you configure, for a user, a combination of user-defined partitions, standard partitions and reporting agents, then the user sees the union of this data when using Contact Center Manager Administration components.

If you do not include certain types of data in a user’s partition, then the user does not see this data. For example, if you do not include CDNs (Route Points) and DNISs in the user’s partition, then the user sees no CDNs (Route Points) or DNISs in Historical Reporting.
If you assign a partition containing all six elements to a user, the user sees the following elements in each of the Contact Center Manager Administration applications.

<table>
<thead>
<tr>
<th>Component</th>
<th>Types of data available in the partition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Historical Reporting</td>
<td>- skillsets</td>
</tr>
<tr>
<td></td>
<td>- agents</td>
</tr>
<tr>
<td></td>
<td>- applications</td>
</tr>
<tr>
<td></td>
<td>- CDNs (Route Points)</td>
</tr>
<tr>
<td></td>
<td>- DNISs</td>
</tr>
<tr>
<td></td>
<td>- report groups</td>
</tr>
<tr>
<td>Real-Time Reporting</td>
<td>- skillsets</td>
</tr>
<tr>
<td></td>
<td>- agents</td>
</tr>
<tr>
<td></td>
<td>- applications</td>
</tr>
<tr>
<td>Contact Center Management</td>
<td>- agents</td>
</tr>
<tr>
<td></td>
<td>- skillsets</td>
</tr>
</tbody>
</table>

A partition can contain any combination of the six elements, but it does not have to contain all elements. For example, it can contain only skillsets and agents, but not CDNs (Route Points), DNISs, applications, or report groups.

After you create the partition, you can select it in the user properties window, in the User Defined area of the Partitions section.

The previous limit on the number of each element that could be added to a partition (999) is removed. For tips to correctly configure partitions, see Chapter 12, “Server performance.”

**Partitions and your contact center**

User-defined partitions are especially useful when competing companies share the same contact center. In the following example, the two companies that share the contact center are Best Air and Econo Air.
To grant users access to data pertaining only to their company, administrators can create partitions within the contact center and assign the partitions to different users, thereby restricting each user’s view of the contact center data.

For example, at a Toronto contact center, there are 18 skillsets. Ten skillsets apply to agents answering calls for Best Air, while the remaining eight skillsets apply to agents answering calls for Econo Air. To divide the contact center so that supervisors see only the contact activity applicable to their company, the contact center administrator creates the following two partitions at the Toronto site:

- The first partition contains the 10 Best Air skillsets and the agents that answer these calls.
- The second partition contains the 8 Econo Air skillsets and the agents that answer these calls.

After creating these partitions, the contact center administrator assigns them to the appropriate supervisors. When the supervisors view the Real-Time Reporting displays or the historical reports, they see only those elements in the partitions to which they belong.

Partitions can restrict only one element at a time. For example, when a user runs a Skillset by Agent Performance report, they can choose to view agents from among those in their partition configurations. However, sometimes an agent in the user's partition configuration may be assigned to a skillset that is outside the user's partition configuration. If a call is routed to an agent for a skillset that is not in the user's partition configuration, then the call statistic (and possibly the skillset details) appear in the Skillset by Agent Performance report.

Partitions are also useful if you want to separate your contact center into different departments within the same company. For example, the administrator can create separate partitions for the Sales and Marketing departments, and assign each partition to supervisors working in each department.

When creating and assigning user-defined partitions, note that the following factors increase the performance hit for the users to whom you assign the partitions when they connect to Contact Center Manager Administration:

- The greater the amount of data that you include in each partition, the greater the performance hit.
- The more partitions you assign to users, the greater the performance hit.
Nortel recommends, therefore, that you configure and assign your partitions according to your company internal departmental organization, granting users access only to the data that regularly need to see. Additionally, Nortel recommends that you use standard partitions whenever possible.
Contact Center Manager Administration users

You can create Contact Center Manager Administration users in the Access and Partition Management component. These are the users who log on to the Contact Center Manager Administration server to use Contact Center Manager Administration. To add a new Contact Center Manager Administration user, choose Add > New User from the toolbar in the Access and Partition Management main window.

The following graphic shows the User properties window in Access and Partition Management.

To assign basic access rights, access classes, partitions, and supervisor/reporting agent combinations

When you define Contact Center Manager Administration users, you assign to them:
- basic access to the appropriate components within Contact Center Manager Administration.
- access classes that control the actions they can perform in these components. You can view the Access Classes that you create in the Access Classes section.
- partitions and supervisor/reporting agent combinations that control the data they can see in these components. You can view the standard partitions and the list of all supervisors who are configured on each server in your network in the Standard & Reporting Agents area of the Partitions section. Each supervisor name represents the supervisor and all of their reporting agents. You can view the partitions that you create in the User Defined area of the Partitions section.

**ATTENTION**

After you create a user, you cannot modify the user name. You must delete the user and create a new user with the new name.

Users configured with basic access rights to Access and Partition Management access also require an access class with privileges set for each of the Access and Partition Management views. Users with full access rights in Access and Partition Management can perform almost all administrative functions. However, only the default administrator, webadmin, can access and use the Configuration Tool spreadsheets for uploading and downloading configuration data, and can add, edit, delete and refresh servers in Configuration.

To view an example of how to configure Contact Center Manager Administration users and assign them partitions, supervisor/reporting agent combinations, and other features, such as access classes and report groups, see “Sample task flow to configure Contact Center Manager Administration users” on page 179.

**Sample task flow to configure Contact Center Manager Administration users**

In this example, your contact center contains three supervisors on the Toronto server: John, Sheila, and Cathy. Each supervisor has ten reporting agents. You assign a combination of partitions and supervisor/reporting agents to arrange the following scenario:
Each supervisor can automatically see all ten of their reporting agents in the real-time displays, in historical reports, and in Contact Center Management (assuming they have access to these components).

In addition to his own ten agents, John can see five of Cathy’s agents so he can manage them when she is on break.

In addition to her own ten agents, Sheila can see the remaining five of Cathy’s agents so she can manage them when Cathy is on break.

The following table summarizes this scenario:

<table>
<thead>
<tr>
<th>Supervisor</th>
<th>Agents the supervisor can see</th>
</tr>
</thead>
<tbody>
<tr>
<td>John</td>
<td>■ his ten reporting agents</td>
</tr>
<tr>
<td></td>
<td>■ five of Cathy’s agents</td>
</tr>
<tr>
<td>Sheila</td>
<td>■ her ten reporting agents</td>
</tr>
<tr>
<td></td>
<td>■ the other five of Cathy’s agents</td>
</tr>
<tr>
<td>Cathy</td>
<td>■ her ten reporting agents</td>
</tr>
</tbody>
</table>

**High-level task flow**
The following table gives a high-level overview of the steps to arrange the scenario in this example. For detailed procedures, see the online Help included with the application.

<table>
<thead>
<tr>
<th>Perform this step</th>
<th>in this component</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Create the user profiles for the three supervisors, John, Cathy, and Sheila.</td>
<td>Contact Center Management</td>
</tr>
<tr>
<td>2 Create the user profiles for the 30 agents, assigning the appropriate 10 agents to each of the 3 supervisors created in step 1.</td>
<td>Contact Center Management</td>
</tr>
<tr>
<td>3 Create any user-defined report groups that the supervisors require to share custom report templates. If supervisors do not need to share custom reports, then you do not have to create report groups.</td>
<td>Access and Partition Management &gt; Report Groups</td>
</tr>
<tr>
<td>Perform this step</td>
<td>in this component</td>
</tr>
<tr>
<td>---------------------------------------------------------------------------------</td>
<td>-----------------------------------------------------</td>
</tr>
<tr>
<td>4 If supervisors need to work in Contact Center Management, create the access classes that they need to perform their duties in this component. To work in most Contact Center Manager Administration components, access classes are required. In this example we want these supervisors to be able to work in Contact Center Management, Real-Time Reporting and Historical Reporting. Access classes are required for each of these components.</td>
<td>Access and Partition Management &gt; Access Classes</td>
</tr>
<tr>
<td>5 Create partitions for the supervisors, specifying the individual agents, applications, skillsets, CDNs (Route Points), DNISs, and report groups that belong in each partition. For this example, create:</td>
<td>Access and Partition Management &gt; Partitions</td>
</tr>
<tr>
<td>- partition A, containing Cathy’s 5 agents that John monitors in her absence</td>
<td></td>
</tr>
<tr>
<td>- partition B, containing Cathy’s remaining 5 agents that Sheila monitors in Cathy’s absence</td>
<td></td>
</tr>
<tr>
<td>6 Create the user profiles for each of the three supervisors.</td>
<td>Access and Partition Management &gt; Users</td>
</tr>
<tr>
<td>7 Assign each user basic access rights to the components they need to use. Typical supervisors require basic access to Real-Time and Historical Reporting, Contact Center Management, and Emergency Help.</td>
<td>Access and Partition Management</td>
</tr>
<tr>
<td>8 Assign each user the appropriate standard partitions. Example “All Skillsets” to dynamically view all available skillsets. Also include any Standard Report groups required by each user.</td>
<td>Access and Partition Management &gt; Users &gt; Standard and Reporting Agents &gt; Standard Tab</td>
</tr>
</tbody>
</table>
### Perform this step

| 9   | Assign each user the appropriate supervisor/reporting agent combination, enabling the user to automatically see all of their reporting agents. For more information, see “Reporting agents” on page 164.  
In this example, you assign John’s supervisor profile (and all of his reporting agents) to John’s Contact Center Manager Administration user profile. Perform the same procedure for both Sheila and Cathy. |
| 10  | Assign each user the appropriate access class. |
| 11  | Assign each user the appropriate user-defined partition. In this example, you assign partition A to John’s Contact Center Manager Administration user profile, containing Cathy’s 5 agents that he monitors in her absence. You assign partition B to Sheila and partition C to Cathy.  
If you assign Cathy new agents that you want John or Sheila to monitor in Cathy’s absence, then you must update the partitions assigned to John and Sheila to include the new agents. Alternatively, to enable John or Sheila to automatically view all of Cathy’s agents, assign Cathy’s supervisor profile (and all her reporting agents) to John’s and Sheila’s Contact Center Manager Administration user profiles. |

### in this component

<p>| 9 | Access and Partition Management &gt; Users &gt; Standard and Reporting Agents &gt; Standard Tab |
| 10 | Access and Partition Management &gt; Users &gt; Access Classes tab |
| 11 | Access and Partition Management &gt; Users &gt; Partitions tab |</p>
<table>
<thead>
<tr>
<th>Perform this step</th>
<th>in this component</th>
</tr>
</thead>
<tbody>
<tr>
<td>12 Click Submit after configuring each user profile.</td>
<td>Access and Partition Management</td>
</tr>
</tbody>
</table>

**Result:** When John, Sheila, and Cathy open Contact Center Manager Administration, they can:

- log on and use the components to which you gave them basic access
- perform the functions their access class enables them to do in Contact Center Management (assuming they have basic access to this component)
- see all their own reporting agents
- see the additional agents and the data included in the partitions assigned to them
Partitions in Historical Reporting, Real-Time Reporting, and Contact Center Management

Users are restricted to viewing only the data in their partition configuration, including the default Full Data Across All Servers option and the following options:

- **Server rights**—You can select All Data, No Data or Configure options for each configured server.
- **Standard partitions**—These are dynamically updated partitions used to assign to a user access to all of a particular data type on a per-component basis.
- **Reporting agents**—These are dynamically updated giving the user access to all the agents reporting to a particular Supervisor.
- **User-defined partitions**—These are created in the Partitions view and give a user access to specific data elements.

You can assign standard, user-defined and reporting agent partitions on a per-component basis (for example, a user may have access to the All Agents & Supervisors standard partition in the Contact Center Management component only).

If a user remains configured with the default configuration Full Data Across All Servers, then the user can see all data in Contact Center Management, Real-Time Reporting and Historical Reporting.

**Selection criteria and partition rules in historical reporting**

The following section describes selection criteria limits and partition rules in historical reporting.
Selection criteria limits
When running a historical report, the following conditions apply.

<table>
<thead>
<tr>
<th>IF</th>
<th>THEN</th>
</tr>
</thead>
<tbody>
<tr>
<td>the server is Symposium Call Center Server 4.0 or 4.2</td>
<td>Symposium Web Client 4.0 and 4.5 limit the number of selection criteria elements to 250</td>
</tr>
<tr>
<td>the server is Symposium Call Center Server 5.0 (included in SWC SUS0601 PEP)</td>
<td>Symposium Web Client 4.5 limits the number of selection criteria elements to 300</td>
</tr>
<tr>
<td>the server is Contact Center Manager Server 6.0</td>
<td>Contact Center Manager Administration 6.0 limits the number of selection criteria elements to 300</td>
</tr>
</tbody>
</table>

If you select no selection criteria elements, all data to which a user is granted access is included in the report.

If a user is assigned a partition with greater than 250 elements on Symposium Web Client 4.0 or 4.5 or is assigned a partition with greater than 300 elements on Symposium Web Client 4.5 or Contact Center Manager Administration 6.0, and the selection criteria is blank, the report contains all data. Symposium Web Client partition rules (configured in Access and Partition Management) break.

Partitions often contain all configured elements, such as all skillsets or all applications. For example, for customers to restrict access to certain reports, partitions are required to be assigned to the user in Symposium Web Client 4.0 and 4.5.

In this configuration, it is acceptable to run the report for all data (selection criteria blank). It is unacceptable for customers who do want to limit the data that a user can access.

Partition rules
Historical reporting partition rules in Contact Center Manager Administration 6.0 means a user can generate the reports based on the data access granted to the user by the administrator. Partition rules are a combination of factors:

- the Contact Center Manager Server SQL query limit (300)
- the number of partition elements per-entity (Agents, Skillsets, Applications, CDN (Route Point) and DNISs)
- the type of partition (standard, reporting agents or user-defined Partitions) that is granted to the user by the Contact Center Manager Administration administrator.

Partition rules are enforced in Contact Center Manager Administration 6.0.

Using partition rules, Historical Reporting determines if a user can generate a report with all available selection criteria elements. Historical Reporting enforces partition rules while running, saving, and scheduling the reports.

When a user has only user-defined partitions and/or reporting agents configured in Access and Partition Management, the user can generate reports only with the data configured in the user-defined partitions and/or reporting agents.

However, reports generate for all data when you select at least one of the following standard partition elements:

- **Full Data Across All Servers**—Reports generate for all data.
- **All Data**—Reports generate for all data on the configured Contact Center Manager Administration server.
- **All Agents & Supervisors**—Reports generate for All Agents/Supervisors on the configured Contact Center Manager Administration server.
- **All Applications**—Reports generate for All Applications on the configured Contact Center Manager Administration server.
- **All CDNs (Route Points)**—Reports generate for All CDNs (Route Points) on the configured Contact Center Manager Administration server.
- **All DNISs**—Reports generate for All DNISs on the configured Contact Center Manager Administration server.
- **All Skillsets**—Reports generate for All DNISs on the configured Contact Center Manager Administration server.

The administrator can configure a user in Access and Partition Management to either see all data on a server or assign user-defined partitions with individual partition elements (All Agents, All Skillsets, All Applications, All CDNs (Route Points) and All DNISs).
Historical Reporting implements partition rules as configured by the administrator in Access and Partition Management. These partition rules can be configured for each user. See the following table for a list of the partitioning rules in Access and Partition Management that are available for Historical Reporting.

<table>
<thead>
<tr>
<th><strong>Access and Partition Management Configuration</strong></th>
<th><strong>Data available to the user</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Partitions—Full Data Across All Servers</td>
<td>Full data access for all the Contact Center Manager Servers configured (All Agents, All Supervisors, All Skillsets, All Applications, All CDNs (Route Points), and All DNISs)</td>
</tr>
<tr>
<td>&lt;Server Name&gt;—All Data</td>
<td>All data for the configured Contact Center Manager Server (All Agents, All Supervisors, All Skillsets, All Applications, All CDNs (Route Points), and All DNISs on the configured server)</td>
</tr>
<tr>
<td>Standard—All Agents &amp; Supervisors</td>
<td>All Agents and All Supervisors for the configured Contact Center Manager Server</td>
</tr>
<tr>
<td>Standard—All Applications</td>
<td>All Applications for the configured Contact Center Manager Server</td>
</tr>
<tr>
<td>Standard—All CDNs (Route Points)</td>
<td>All CDNs (Route Points) for the configured Contact Center Manager Server</td>
</tr>
<tr>
<td>Standard—All DNIS</td>
<td>All DNIS for the configured Contact Center Manager Server</td>
</tr>
<tr>
<td>Standard—All Skillsets</td>
<td>All Skillsets for the configured Contact Center Manager Server</td>
</tr>
<tr>
<td>Reporting Agents</td>
<td>Agents assigned to the Supervisors included in <em>Reporting Agents</em> for the configured Contact Center Manager Server</td>
</tr>
</tbody>
</table>
### Access and Partition Management Configuration

<table>
<thead>
<tr>
<th>Data available to the user</th>
</tr>
</thead>
<tbody>
<tr>
<td>User-defined partitions</td>
</tr>
<tr>
<td>Only elements (Agents, Skillsets, Applications, CDN (Route Points), and DNIS) listed in the selected user-defined partitions</td>
</tr>
</tbody>
</table>

## How reports function

A user can select a maximum of 300 elements in the selection criteria area of the Historical Reporting user interface to run an ad hoc report or to save the report for scheduling. This maximum keeps the SQL query elements for the report within the database query limits for Contact Center Manager Server.

If a user selects more than 300 elements, the report cannot be run or saved. A warning message is displayed as follows: “The maximum number of elements supported by the SQL Query is 300. Select up to 300 elements to save/run the report or leave the selection criteria blank to report on all data.”

If a user selects no available elements to run reports with Agents or Skillsets in the selection criteria, the report returns results for all agents or all skillsets in the user’s partition, provided that the user is not assigned more than 300 agents or more than 300 skillsets. A list of examples for reports that have Agents or Skillsets in the selection criteria follows.

### Scenario 1: A user has a user-defined partition and/or has configured Reporting Agents

Historical Reporting determines if a user has a user-defined partition or configured reporting agents in Access and Partition Management. If a user is has a user-defined partition, Contact Center Manager Administration partition rules are enforced.

**Example 1**—A user has a user-defined partition containing 500 Skillsets. The user runs the Agent by Skillset Performance Report without selecting any of the 500 available Skillsets from the user-defined partition.
**Result:** The report does not run because the number of elements (500 skillsets) in the SQL query is more than the database query limit for Contact Center Manager Server, which is 300.

Instead, the user can run two reports by selecting a maximum of 300 skillsets per-report. For example, the first report contains the first 300 skillsets, and the second report contains the remaining 200 skillsets. This meets the partition rules set by the Contact Center Manager Administration server administrator in Access and Partition Management.

**Example 2**—A user is assigned 350 agents using the Reporting Agent feature. The user runs the Agent Performance Report without selecting any of the 350 available agents from the reporting agent partition.

**Result:** The report does not run because the number of elements (350 agents) in the SQL query is more than the database query limit for Contact Center Manager Server, which is 300.

Instead, the user can run two reports by selecting a maximum of 300 agents per-report. For example, the first report contains the first 300 agents, and the second report contains the remaining 50 agents. This meets the partition rules set by the Contact Center Manager Administration server administrator in Access and Partition Management.

**Example 3**—A user is assigned a user-defined partition with 300 agents. The user runs the report without selecting any of 300 available agents from the user-defined partition.

**Result:** The SQL query for the report is within the database SQL query limits for Contact Center Manager Server. The report is run with the 300 agents assigned to the user by the Contact Center Manager Administration server Administrator in Access and Partition Management.

**Scenario 2: A user has Full Data Across All Servers, All Data, All Agents & Supervisors, All Skillsets, All Applications, and All DNIS or All CDNs (Route Points)**

If a user is assigned Full Data Across All Servers, All Data or All Agents in Access and Partition Management, reports generate for all available agents/supervisors. If a user is assigned All Skillsets, All Applications, All DNIS or All CDNs (Route Points), reports generate for all available skillsets, applications, DNIS, or CDNs (Route Points) respectively.
**Example 1**—The Contact Center Manager Server has 1000 agents configured. The user is assigned Full Data Across All Servers, All Data or All Agents & Supervisors. The user runs the report without selecting any of the 1000 available agents.

**Result:** The report generates for all 1000 agents.

**Partitions and filters in Historical Reporting**

In Historical Reporting, users can specify the applications, DNISs, routes, and skillsets that they want to see in both standard and private network consolidated historical reports by creating filters. Users can choose from among those items included in the partition configurations assigned to them. They can select multiple resource items across multiple sites in the network and save them in one filter.

The data available in Filters Sets is based on the partition configuration for a user, including Full Data Across All Servers, server rights, and any standard and user-defined partitions.

Filters are not dynamic. This means that if a user creates a filter, and then you subsequently remove elements from the user’s partition configuration that the user saved in the filter, these elements are still included in the filter even though they are no longer in the user’s partition configuration. The only way to prevent the user from accessing these items in the network consolidated historical reports, therefore, is to delete the filter, and to notify the user that they must create a new filter, choosing from among the newly partitioned items.

For more information about Historical Reporting, see the *Contact Center Manager Supervisor's Guide*. For a more detailed look at the results of supervisor/reporting agents combinations and partitions in Historical Reporting, see Appendix B, “Supervisor/reporting agents matrix.”
Partitions and Filters in Real-Time Reporting

Just as the user can assign a filter to a private display so that they see only the filtered information in the display, so too can the user assign a supervisor/reporting agent combination to view all the applicable reporting agents in the agent display. Both the filters the user created and the supervisor/reporting agent combinations assigned to the user appear on the Filters tab in Real-Time Reporting. The user can assign a filter, a supervisor/reporting agent combination, or sometimes both, to a display.

The data available in Filters is based on the partition configuration for a user. This includes Full Data Across All Servers, server rights, and standard partitions. It also includes Reporting Agents.

A user who is assigned to any of the following options has access to the relevant supervisors as Supervisor Filters:

- **Full Data Across All Servers**
- **All Data** for the given server
- **All Agents & Supervisors** Standard partition for the Real-Time Reporting Component
- any supervisors for the Real-Time Reporting Component in the Reporting Agents partition

For more information about Real-Time Reporting, see the *Contact Center Manager Supervisor’s Guide*.

Partitions in Contact Center Management

The data available to a user in Contact Center Management is based on the partition configuration for that user. This includes Full Data Across All Servers, server rights, and standard partitions. It also includes any Reporting Agents.

If using the Reporting Agents feature, the user can see any Supervisors in their partition configuration along with all agents that report to the selected Supervisor.
Normally, users whose access class enables them to work only with assignments are supervisors. These supervisors can create only ad hoc agent-to-supervisor and agent-to-skillset assignments; they cannot add, edit, create, or delete users, or schedule assignments. Users who can perform all functions in Contact Center Management have administrator privileges in this component.

Users with administrator privileges usually need to see all supervisors and agents in Contact Center Management so they can perform their required duties, such as editing and deleting user profiles, and creating and scheduling assignments. The best way to ensure that these users always see all agents is to assign the agent Full Data Across All Servers.

Since most supervisors are restricted to viewing specific data in the contact center, Contact Center Manager Administration administrators usually assign partitions containing this data to them. As an added way to control the data that supervisors can see, administrators can also assign supervisor/reporting agent combinations to them.

The following table summarizes, using four scenarios, the effect that agent and skillset partitions and supervisor/reporting agent combinations have on Contact Center Management. For a detailed look at the results of supervisor/reporting agent combinations and partitions in Contact Center Management, see Appendix B, “Supervisor/reporting agents matrix.”

There are four scenarios:

<table>
<thead>
<tr>
<th>IF the user</th>
<th>THEN the user sees in Contact Center Management</th>
</tr>
</thead>
<tbody>
<tr>
<td>has agents in a user-defined partition and no supervisors assigned</td>
<td>all supervisors listed</td>
</tr>
<tr>
<td>has supervisors assigned but has no agents in a assigned user-defined partition</td>
<td>supervisors associated with the Contact Center Management user</td>
</tr>
<tr>
<td>has supervisors assigned and has agents in a user-defined partition assigned</td>
<td>all supervisors listed</td>
</tr>
</tbody>
</table>
So if user has even one agent in a partition they see all Supervisors.

Which supervisors a user sees in Contact Center Management depends on the supervisors associated with the user and the agents in the partitions assigned to that user.

A Contact Center Manager Administration user configured with user-defined partitions containing agents see all Supervisors in the Supervisors view. Agents are restricted based on partition configuration.
Access and Partition Management Reports

The following Access and Partition Management reports are available in the Historical Reporting component of Contact Center Manager Administration:

- Access Classes
- Reports Groups
- User Defined Partitions
- Users

Access and Partition Management reports can be run by the following users:

- the webadmin
- a user who is assigned Full Data Across All Servers
- a user who is assigned All Data on the Administration server.
- a user who is assigned Standard Configuration Reports on the Administration server.

Running an Access and Partition Management report

1. Launch **Historical Reporting**.
2. Select the **Administration** server in the system tree.
3. Expand the **Public Report Templates** folder.
4. Select the **Configuration** folder.
5. In the **Configuration** folder, select one of the four available reports:
   - Access Classes
   - Report Groups
   - User Defined Partitions
Users

**Result:** The report details for the selected report appear.

Configure the Selection Criteria data in Access and Partition Management.
To upgrade from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0

To support new Contact Center Manager Administration users, access class features, and partition features in Contact Center Manager Administration 6.0, you must upgrade existing Access and Partition Management configurations when you upgrade from Symposium Web Client 4.5. Upgrading Access and Partition Management configurations is a fully automatic process and is completed as part of the Symposium Web Client 4.5 to Contact Center Manager Administration 6.0 upgrade. The information in this section is intended as a reference guide that describes configuration changes that occur during the upgrade process. Two main areas where configurations are upgraded include:

- to support new or modified access classes
- to support User and Partition enhancements

Access Classes

Five Access Classes are added or modified in Contact Center Manager Administration 6.0. Therefore, when a user migrates from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0, each of their Access Class levels needs to be changed in some way.

The following two Access Classes are modified:

- Skillset Assignment
- Supervisor Assignment (previously known as Agent to Supervisor Assignment)

The following Access Classes are added:

- Real-time Tabular Displays
- Real-time Graphical Displays
- Historical Reporting
- CCM – Network Admin View
- User Administration
- Access Classes
- User Defined Partitions
- Report Groups

There are two separate functions of the Upgrade Utility with respect to Access Classes when upgrading from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0:

1. map Access Class levels for the modified Access Class elements
2. create Access Class levels for the new 6.0 Access Class elements

**Skillset and Supervisor Assignment Access Class elements**

The Skillset Assignment and Supervisor Assignment Access Class elements previously existed in Symposium Web Client 4.5. Additional access levels are added, for both, in Contact Center Manager Administration 6.0.

<table>
<thead>
<tr>
<th>Access Class levels in Symposium Web Client 4.5</th>
<th>Access Class levels in Contact Center Manager Administration 6.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>■ None</td>
<td>■ None</td>
</tr>
<tr>
<td>■ View Assignments</td>
<td>■ View Assignments</td>
</tr>
<tr>
<td>■ Create Ad-hoc Assignments</td>
<td>■ Ad-hoc Assignments</td>
</tr>
<tr>
<td>■ Schedule Assignments</td>
<td>■ Run Now Assignments</td>
</tr>
<tr>
<td></td>
<td>■ Add/Edit/Delete Assignments</td>
</tr>
<tr>
<td></td>
<td>■ Schedule Assignments</td>
</tr>
</tbody>
</table>

The levels None, View, and Schedule Assignments remain the same. The access level Create Ad-hoc Assignments is broken into three other access levels:

- Ad-hoc Assignments
- Run Now Assignments
- Add/Edit/Delete Assignments

For more information about the upgrade path of a Symposium Web Client 4.5 user assigned access to Skillset Assignments or Supervisor Assignments, see “Upgrade paths for Access Classes” on page 199.
Access and Partition Management Access Classes

The Access and Partition Management access classes are new for Contact Center Manager Administration 6.0. Any user that previously had basic access to Access and Partition Management is assigned a new standard access class giving them full privileges.

<table>
<thead>
<tr>
<th>Access Class levels in Symposium Web Client 4.5</th>
<th>Access Class levels in Contact Center Manager Administration 6.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>■ Basic access rights</td>
<td>■ None</td>
</tr>
<tr>
<td></td>
<td>■ Read Only</td>
</tr>
<tr>
<td></td>
<td>■ Read and Update</td>
</tr>
<tr>
<td></td>
<td>■ Read Update Create/Delete</td>
</tr>
</tbody>
</table>

For more information about the upgrade path of a Symposium Web Client 4.5 user assigned access to Access and Partition Management, see “Upgrade paths for Access Classes” on page 199.

New Access Class Elements

When you migrate from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0, the new Access Class elements Real-time Tabular Displays, Real-time Graphical Displays, and Historical Reporting are added to the previously existing Access Classes in Symposium Web Client 4.5 and default Access levels assigned.

Real-time Tabular Displays

The default Access Class level assigned, on a migration from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0, is the highest level (Create Public) because previously users had full access to these areas.

For more information about the upgrade path of a Symposium Web Client 4.5 user assigned access to Real-time Tabular Displays, see “Upgrade paths for Access Classes” on page 199.
**Real-Time Graphical Displays**
The default Access Class level assigned, on a migration from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0, is the highest level (Create Public) because previously users had full access to these areas.

For more information about the upgrade path of a Symposium Web Client 4.5 user assigned access to Real-time Graphical Displays, see “Upgrade paths for Access Classes” on page 199.

**Historical Reporting**
The default Access Class level assigned when you migrate from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0, is Run and Import. Previously users had that level of access, and the Report Creation function did not exist in Symposium Web Client 4.5. The Run and Import access level maintains the user's level of access on a migration from 4.5 to 6.0.

For more information about the upgrade path of a Symposium Web Client 4.5 user assigned access to Historical Reporting, see “Upgrade paths for Access Classes” on page 199.

**Upgrade paths for Access Classes**
The following table describes the access a user is assigned when upgraded from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0.

<table>
<thead>
<tr>
<th>Access Classes in Symposium Web Client 4.5</th>
<th>Access Classes in Contact Center Manager Administration 6.0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Skillset Assignment</td>
<td>Any access class with the following access level remains unchanged: None, View Assignments, Schedule Assignments.</td>
</tr>
<tr>
<td>Supervisor Assignment</td>
<td>Any access class with the Create Ad-Hoc assignments level is reset to Ad-Hoc Assignments in Contact Center Manager Administration 6.0.</td>
</tr>
</tbody>
</table>
### Access Classes in Symposium Web Client 4.5

<table>
<thead>
<tr>
<th>Access Classes in Contact Center Manager Administration 6.0</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Real-Time Tabular</strong></td>
</tr>
<tr>
<td>Previously did not exist; therefore users had full access rights</td>
</tr>
<tr>
<td><strong>Real-Time Graphical</strong></td>
</tr>
<tr>
<td>Previously did not exist; therefore users had full access rights</td>
</tr>
<tr>
<td><strong>Historical Reporting</strong></td>
</tr>
<tr>
<td>Previously did not exist; therefore users had full access rights</td>
</tr>
<tr>
<td><strong>User Administration</strong></td>
</tr>
<tr>
<td>Previously did not exist; therefore users had full access rights</td>
</tr>
<tr>
<td><strong>Access Classes</strong></td>
</tr>
<tr>
<td><strong>User Defined Partitions</strong></td>
</tr>
<tr>
<td><strong>Report Groups</strong></td>
</tr>
</tbody>
</table>

### Partitions

To support the new partition and user options, users created in Symposium Web Client 4.5 need to be upgraded to function correctly in Contact Center Manager Administration 6.0.

This is an automatic process and is integrated into the Contact Center Manager Administration upgrade/install application.
The upgrade procedure is logged to the following location on the Contact Center Manager Administration server:
Program Files\Nortel Networks\WClient\Nortel_Log\APMUsersUpgrade.log

Upgrade paths for partitions

The following table describes the partition a user is assigned when upgraded from Symposium Web Client 4.5 to Contact Center Manager Administration 6.0.

<table>
<thead>
<tr>
<th>Symposium Web Client 4.5 User</th>
<th>Contact Center Manager Administration 6.0 User</th>
</tr>
</thead>
<tbody>
<tr>
<td>no partitions and no supervisors</td>
<td>Full Data Across All Servers</td>
</tr>
<tr>
<td>no partitions and a few supervisors selected on one server (SVRTest)</td>
<td>Full Data Across All Servers is not selected. Standard &amp; Reporting Agents section—Server SVRTest is set to Configure and appropriate supervisors are selected in Reporting Agents tab for all components. All standard partitions are selected for this server. All other servers are set to All Data. User Defined Section—No user-defined partitions selected.</td>
</tr>
<tr>
<td><strong>Symposium Web Client 4.5 User</strong></td>
<td><strong>Contact Center Manager Administration 6.0 User</strong></td>
</tr>
<tr>
<td>---------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
</tbody>
</table>
| some supervisors and some partitions | Full Data Across All Servers is not selected.  
Standard & Reporting Agents section—Servers with supervisors assigned is set to Configure.  
Appropriate supervisors are selected in Reporting Agents tab for all components. No Standard partitions selected.  
All other servers are set to No Data.  
User Defined Section—Appropriate user-defined partitions are selected across all components. |
| no supervisors selected and a few user-defined partitions | Standard & Reporting Agents section—All servers are set to No Data.  
User Defined Section—Appropriate partitions are selected across all components. |
Chapter 7

Real-Time Reporting

In this chapter

Overview 204
Overview

Real-time displays provide up-to-date statistics for your contact center and its resources. You can use these statistics to monitor your contact center and determine its effectiveness.

Contact Center Manager Administration provides four types of displays:

- Public tabular displays
- Public graphical displays
- Private tabular displays
- Private graphical displays

Public tabular displays

Public tabular displays include both the standard tabular displays that ship with Contact Center Manager, and custom private tabular displays that you share with other users by saving them in the Public Tabular Displays folder. To modify either type of display, you must make a copy of the display and save it as a private (user-defined) display.

Public graphical displays

After you customize a graphical display and save it in your Private Graphical Displays folder, you can share the display with other users by making a public copy (provided that you have the correct access class). You can make public copies of all graphical displays except agent maps. You can copy the display only to the Public Graphical Displays folder on the currently selected server; you cannot copy graphical displays across all servers to which you have access in the network (unlike real-time tabular displays). To modify these displays, you must make a copy of the display and save it as a private (user-defined) display.

You can create the following graphical displays:

- agent maps
- charts
- billboard
- collections
- billboard collections

**Collections and Billboard Collections**

You do not have to make a private, user-defined copy of the collection or billboard collection before you save a copy as a public display. Instead, for display type, you create a new public display just as you create a new private display (provided you have the correct access class).

For more information about collections and billboard collections and for information about the other graphical display types, see the *Contact Center Manager Supervisor’s Guide*.

**Private tabular displays**

Private tabular displays are copies of public tabular displays that you customize and save in your Private Tabular Displays folder. Only the creator of the private display can access or modify it. To grant other users access to your private display, you must save a copy as a public display. You can save public copies of private tabular displays on the current server or across all servers to which you have access.

**Private graphical displays**

Private graphical displays can either be new custom displays that you create and save in your Private Graphical Displays folder or copies of public displays that other users share with you by saving them in the Public Graphical Displays folder. Only the creator of the private display can access or modify it. To grant other users access to your private display, you must save a copy as a public display.

Which items users can view in these displays is governed by Access and Partition Management. For further information, see “Real-Time Reporting” on page 457.
Only a webadmin user can delete user-defined public tabular displays or public graphical displays of the type Chart or Billboard. Public graphical displays of the type Collection or Billboard Collection can be deleted either by a webadmin user or the user who created the display. Standard tabular displays shipped with Contact Center Manager cannot be deleted.
Chapter 8

Historical Reporting

In this Chapter

Overview 208
Report Creation Wizard 209
Overview

Use Historical Reporting to produce nodal and network consolidated reports that detail the past performance of the contact center. In Contact Center Manager Administration, you can specify the data range of the reports, schedule the reports to run at a specific time, and apply selection criteria to the reports.

You can schedule any number of reports, but only five scheduled reports are processed at the same time. This gives higher priority to the ad hoc reports.

Historical Reporting is packaged with a set of standard reports that appear in the public report folders. You can also create and import reports that are created in Crystal version 9.0 and later. You can save user-defined and user-created reports in your private report folders. You can share the reports with other users by saving the reports into shared report group folders.

For details about Historical Reporting, see the Contact Center Manager Supervisor's guide.
Report Creation Wizard

Report Creation Wizard is a new reporting feature accessible through the main Historical Reporting interface. Use Report Creation Wizard to create, maintain, and modify custom ad hoc reports through a user-friendly interface. You can then import and schedule the reports in Historical Reporting. In previous releases of Contact Center Manager Administration (formerly known as Symposium Web Client), users had to be familiar with the Crystal Reports Designer and Structured Query Language (SQL) to modify certain aspects of user-created reports, such as:

- the databases, table and views to use within the report
- the field and column data for the report
- the title and subtitle, and other aspects of the appearance of the report

However, with the introduction of Report Creation Wizard, you can create new reports and modify these reports by using Report Creation Wizard its user-friendly interface.

After you create reports through Report Creation Wizard, you can work with them in the Historical Reporting component, and use the same access permissions, partitions, and filters as you would with any other report. You can also use the Historical Reporting interface to schedule reports that you create with Report Creation Wizard.

For more information about Report Creation Wizard, see the Contact Center Manager Supervisor's guide and the Contact Center Manager Administration online Help.
Chapter 9

Audit Trail

In this chapter

Overview 212
Audit Trail events 214
Overview

Use the Audit Trail to view the most recent actions that users performed in the following Contact Center Manager Administration components:

- Launchpad
- Configuration
- Contact Center Management
- Access and Partition Management
- Real-Time Reporting
- Scripting
- Historical Reporting
- Report Creation Wizard

Audit Trail also logs actions performed in the XML automated assignments feature.

The Audit Trail events are saved in the following location:
Nortel Networks/WClient/Apps/Common/icedb/ICELog.mdb

For Contact Center Manager Administration, you can use the Nortel Backup Utility to back up logged events. For Symposium Web Client 4.5, you can use the Microsoft Backup and Restore Utility to back up logged events.

Event codes and descriptions are listed in “Audit Trail events” on page 214.

Audit Trail does not track changes made on the Server Utility, nor does it record the success or failure of assignments created in the contact center.
Viewing the Audit Trail

on the Contact Center Manager Administration launchpad, click **Audit Trail**.

**Result:** The Audit Trail window appears.

```
<table>
<thead>
<tr>
<th>Time</th>
<th>Event Code</th>
<th>User ID</th>
<th>Client IP</th>
<th>Server IP</th>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>16/20/2005 2:11:52 PM</td>
<td>10192</td>
<td>torowley</td>
<td>207.179.167.111</td>
<td>192.168.249.70</td>
<td>Contact Center Management</td>
<td>User Crowley Tammy was deleted.</td>
</tr>
<tr>
<td>16/20/2005 2:11:52 PM</td>
<td>10220</td>
<td>torowley</td>
<td>207.179.167.111</td>
<td>cairing</td>
<td>Launchpad</td>
<td>Contact Center Manager Administrato User torowley logged in.</td>
</tr>
<tr>
<td>16/20/2005 2:10:15 PM</td>
<td>10241</td>
<td>torowley</td>
<td>207.179.167.111</td>
<td>cairing</td>
<td>Access and Partition Management</td>
<td>Contact Center Manager Administrato User torowley was modified.</td>
</tr>
<tr>
<td>16/20/2005 2:10:15 PM</td>
<td>10220</td>
<td>torowley</td>
<td>207.179.167.111</td>
<td>cairing</td>
<td>Launchpad</td>
<td>Contact Center Manager Administrato User torowley logged in.</td>
</tr>
<tr>
<td>16/20/2005 2:07:56 PM</td>
<td>10235</td>
<td>torowley</td>
<td>207.179.167.111</td>
<td>cairing</td>
<td>Launchpad</td>
<td>Contact Center Manager Administrato User torowley failed to log in.</td>
</tr>
<tr>
<td>16/20/2005 12:36:13 PM</td>
<td>10190</td>
<td>torowley</td>
<td>207.179.167.111</td>
<td>192.168.249.70</td>
<td>Contact Center Management</td>
<td>User Tammy Crowley was added.</td>
</tr>
<tr>
<td>16/20/2005 12:20:18 PM</td>
<td>10220</td>
<td>torowley</td>
<td>207.179.167.111</td>
<td>cairing</td>
<td>Launchpad</td>
<td>Contact Center Manager Administrato User torowley logged in.</td>
</tr>
<tr>
<td>16/20/2005 12:20:18 PM</td>
<td>10221</td>
<td>torowley</td>
<td>207.179.167.111</td>
<td>cairing</td>
<td>Launchpad</td>
<td>Contact Center Manager Administrato User torowley logged out.</td>
</tr>
<tr>
<td>16/20/2005 12:06:39 PM</td>
<td>10220</td>
<td>torowley</td>
<td>207.179.167.111</td>
<td>cairing</td>
<td>Launchpad</td>
<td>Contact Center Manager Administrato User torowley logged in.</td>
</tr>
</tbody>
</table>
```

Configuring the number of stored Audit Trail events

1. In the Audit Trail component, from the menu, select **Administration > Edit Database Size**.

**Result:** The Audit Trail Database Size dialog box appears.

2. In the **Maximum number of events stored** box, type the maximum number of events to store in the database.

You can store up to 10 000 events in the database; however, the more events you store, the longer the system takes to retrieve the event information and display it online.
## Audit Trail events

The following section lists Audit Trail events.

### Launchpad events

Audit Trail logs the following Launchpad events:

<table>
<thead>
<tr>
<th>Event code</th>
<th>Event description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10220</td>
<td>Contact Center Manager Administration User <code>&lt;User Name&gt;</code> logged in.</td>
</tr>
<tr>
<td>10221</td>
<td>Contact Center Manager Administration User <code>&lt;User Name&gt;</code> logged out.</td>
</tr>
<tr>
<td>10223</td>
<td>Contact Center Manager Administration User <code>&lt;User Name&gt;</code> failed to log in.</td>
</tr>
</tbody>
</table>

### Configuration events

Audit Trail logs the following Configuration events:

<table>
<thead>
<tr>
<th>Event Code</th>
<th>Event description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10230</td>
<td>Password change on Contact Center Manager Server <code>&lt;Server Name&gt;</code>.</td>
</tr>
<tr>
<td>10000</td>
<td>Activity Code <code>&lt;Activity Code Number&gt;</code> was added. Name = <code>&lt;Activity Code Name&gt;</code>.</td>
</tr>
<tr>
<td>10001</td>
<td>Activity Code <code>&lt;Activity Code Number&gt;</code> was modified. Name = <code>&lt;Activity Code Name&gt;</code>.</td>
</tr>
<tr>
<td>10002</td>
<td>Activity Code <code>&lt;Activity Code Number&gt;</code> was deleted. Name = <code>&lt;Activity Code Name&gt;</code>.</td>
</tr>
<tr>
<td>10010</td>
<td>Call Presentation Class <code>&lt;Call Presentation Class Name&gt;</code> was added.</td>
</tr>
<tr>
<td>Event Code</td>
<td>Event description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>10011</td>
<td>Call Presentation Class <code>&lt;Call Presentation Class Name&gt;</code> was modified.</td>
</tr>
<tr>
<td>10012</td>
<td>Call Presentation Class <code>&lt;Call Presentation Class Name&gt;</code> was deleted.</td>
</tr>
<tr>
<td>10020</td>
<td>CDN (Route Point) <code>&lt;CDN Name&gt;</code> was added.</td>
</tr>
<tr>
<td>10021</td>
<td>CDN (Route Point) <code>&lt;CDN Name&gt;</code> was modified.</td>
</tr>
<tr>
<td>10022</td>
<td>CDN (Route Point) <code>&lt;CDN Name&gt;</code> was deleted.</td>
</tr>
<tr>
<td>10380</td>
<td>Contact Type <code>&lt;Contact Type Name&gt;</code> was added.</td>
</tr>
<tr>
<td>10381</td>
<td>Contact Type <code>&lt;Contact Type Name&gt;</code> was modified.</td>
</tr>
<tr>
<td>10382</td>
<td>Contact Type <code>&lt;Contact Type Name&gt;</code> was deleted.</td>
</tr>
<tr>
<td>10030</td>
<td>DNIS <code>&lt;DNIS Number&gt;</code> was added. Name = <code>&lt;DNIS Name&gt;</code>, Service Level Threshold = <code>&lt;Service Level Threshold&gt;</code>.</td>
</tr>
<tr>
<td>10031</td>
<td>DNIS <code>&lt;DNIS Number&gt;</code> was modified. Name = <code>&lt;DNIS Name&gt;</code>, Service Level Threshold = <code>&lt;Service Level Threshold&gt;</code>.</td>
</tr>
<tr>
<td>10032</td>
<td>DNIS <code>&lt;DNIS Number&gt;</code> was deleted. Name = <code>&lt;DNIS Name&gt;</code>, Service Level Threshold = <code>&lt;Service Level Threshold&gt;</code>.</td>
</tr>
<tr>
<td>10040</td>
<td>Formula <code>&lt;Formula Name&gt;</code> was added.</td>
</tr>
<tr>
<td>10041</td>
<td>Formula <code>&lt;Formula Name&gt;</code> was modified.</td>
</tr>
<tr>
<td>10042</td>
<td>Formula <code>&lt;Formula Name&gt;</code> was deleted.</td>
</tr>
<tr>
<td>10050</td>
<td>Global setting <code>&lt;Global Setting Name&gt;</code> was modified.</td>
</tr>
<tr>
<td>10060</td>
<td>Historical Statistics configuration was modified.</td>
</tr>
<tr>
<td>10070</td>
<td>IVR ACD-DN <code>&lt;IVR ACD-DN Number&gt;</code> was added. Name = <code>&lt;IVR ACD-DN Name&gt;</code>.</td>
</tr>
<tr>
<td>10071</td>
<td>IVR ACD-DN <code>&lt;IVR ACD-DN Number&gt;</code> was modified. Name = <code>&lt;IVR ACD-DN Name&gt;</code>.</td>
</tr>
<tr>
<td>Event Code</td>
<td>Event description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>10072</td>
<td>IVR ACD-DN &lt;IVR ACD-DN Number&gt; was deleted. Name = &lt;IVR ACD-DN Name&gt;.</td>
</tr>
<tr>
<td>20025</td>
<td>Media Server &lt;Media Server Name&gt; was added.</td>
</tr>
<tr>
<td>20026</td>
<td>Media Server &lt;Media Server Name&gt; was modified.</td>
</tr>
<tr>
<td>20027</td>
<td>Media Server &lt;Media Server Name&gt; was deleted.</td>
</tr>
<tr>
<td>20020</td>
<td>Media Service &lt;Media Service Name&gt; was added.</td>
</tr>
<tr>
<td>20021</td>
<td>Media Service &lt;Media Service Name&gt; was modified.</td>
</tr>
<tr>
<td>20023</td>
<td>Media Service &lt;Media Service Name&gt; was deleted.</td>
</tr>
<tr>
<td>20024</td>
<td>The service routes for Media Service &lt;Media Service Name&gt; were updated.</td>
</tr>
<tr>
<td>10080</td>
<td>Networking Communication Parameters were modified for server &lt;Server Name&gt;.</td>
</tr>
<tr>
<td>10081</td>
<td>Network Communication Parameters - Site Filter stopped for server &lt;Server Name&gt;.</td>
</tr>
<tr>
<td>10082</td>
<td>Network Communication Parameters - Skillset Filter stopped for server &lt;Server Name&gt;.</td>
</tr>
<tr>
<td>10150</td>
<td>Network Historical Statistics configuration was modified.</td>
</tr>
<tr>
<td>10160</td>
<td>Network Skillset &lt;Skillset Name&gt; was added.</td>
</tr>
<tr>
<td>10161</td>
<td>Network Skillset &lt;Skillset Name&gt; was modified.</td>
</tr>
<tr>
<td>10162</td>
<td>Network Skillset &lt;Skillset Name&gt; was deleted.</td>
</tr>
<tr>
<td>10090</td>
<td>Phoneset/Voice Port &lt;TN Number&gt; was added. Name = &lt;Name&gt;.</td>
</tr>
<tr>
<td>10091</td>
<td>Phoneset/Voice Port &lt;TN Number&gt; was modified. Name = &lt;Name&gt;.</td>
</tr>
<tr>
<td>10092</td>
<td>Phoneset/Voice Port &lt;TN Number&gt; was deleted. Name = &lt;Name&gt;.</td>
</tr>
<tr>
<td>10100</td>
<td>Phoneset Display Field list &lt;Phoneset type&gt; was modified.</td>
</tr>
<tr>
<td>Event Code</td>
<td>Event description</td>
</tr>
<tr>
<td>------------</td>
<td>------------------</td>
</tr>
<tr>
<td>10110</td>
<td>Real-Time Statistics configuration was modified in the server.</td>
</tr>
<tr>
<td>10120</td>
<td>Route &lt;Route Number&gt; was added. Name = &lt;Route Name&gt;.</td>
</tr>
<tr>
<td>10121</td>
<td>Route &lt;Route Number&gt; was modified. Name = &lt;Route Name&gt;.</td>
</tr>
<tr>
<td>10122</td>
<td>Route &lt;Route Number&gt; was deleted. Name = &lt;Route Name&gt;.</td>
</tr>
<tr>
<td>10173</td>
<td>The Routing Table of Source Site &lt;Site Name&gt; was modified.</td>
</tr>
<tr>
<td>10180</td>
<td>A Routing Table Assignment &lt;Assignment Name&gt; with Source Site &lt;Site Name&gt; was added.</td>
</tr>
<tr>
<td>10181</td>
<td>A Routing Table Assignment &lt;Assignment Name&gt; was modified.</td>
</tr>
<tr>
<td>10182</td>
<td>A Routing Table Assignment &lt;Assignment Name&gt; was deleted.</td>
</tr>
<tr>
<td>10183</td>
<td>The schedule for Routing Table Assignment &lt;Assignment Name&gt; was modified.</td>
</tr>
<tr>
<td>10170</td>
<td>Site &lt;Site Name&gt; was added.</td>
</tr>
<tr>
<td>10171</td>
<td>Site configuration on site &lt;Site Name&gt; was modified.</td>
</tr>
<tr>
<td>10172</td>
<td>Site &lt;Site Name&gt; was deleted.</td>
</tr>
<tr>
<td>10174</td>
<td>Site &lt;Site Name&gt; was synchronized.</td>
</tr>
<tr>
<td>10130</td>
<td>Skillset &lt;Skillset Name&gt; was added.</td>
</tr>
<tr>
<td>10131</td>
<td>Skillset &lt;Skillset Name&gt; was modified.</td>
</tr>
<tr>
<td>10132</td>
<td>Skillset &lt;Skillset Name&gt; was deleted.</td>
</tr>
<tr>
<td>10140</td>
<td>Threshold Template &lt;Template Name&gt; was added. Type = &lt;Template Type&gt;.</td>
</tr>
<tr>
<td>10141</td>
<td>Threshold Template &lt;Template Name&gt; was modified. Type = &lt;Template Type&gt;.</td>
</tr>
</tbody>
</table>
### Audit Trail Standard 10.03

### Contact Center Management events

Audit Trail monitors the following Contact Center Management events:

<table>
<thead>
<tr>
<th>Event code</th>
<th>Event description</th>
</tr>
</thead>
</table>
| 10142      | Threshold Template &lt;Template Name&gt; was deleted. Type = &lt;Template Type&gt;.
| 20028      | Servers &lt;IP Address or Server Name&gt;, refreshed successfully.

<table>
<thead>
<tr>
<th>Event Code</th>
<th>Event Description</th>
</tr>
</thead>
</table>
| 10142      | Threshold Template &lt;Template Name&gt; was deleted. Type = &lt;Template Type&gt;.
| 20028      | Servers &lt;IP Address or Server Name&gt;, refreshed successfully.

<table>
<thead>
<tr>
<th>Event code</th>
<th>Event description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10190</td>
<td>User &lt;First Name&gt; &lt;Last Name&gt; was added.</td>
</tr>
<tr>
<td>10191</td>
<td>User &lt;First Name&gt; &lt;Last Name&gt; was modified.</td>
</tr>
<tr>
<td>10192</td>
<td>User &lt;First Name&gt; &lt;Last Name&gt; was deleted.</td>
</tr>
<tr>
<td>10194</td>
<td>User &lt;Lastname Firstname&gt; with Login ID &lt;Login ID&gt; was added.</td>
</tr>
<tr>
<td>10193</td>
<td>User &lt;Lastname Firstname&gt; with Login ID &lt;Login ID&gt; was deleted.</td>
</tr>
<tr>
<td>20000</td>
<td>Bulk upload from an excel spreadsheet.</td>
</tr>
<tr>
<td>10200</td>
<td>An Agent to Supervisor Assignment &lt;Assignment Name&gt; was added.</td>
</tr>
<tr>
<td>10201</td>
<td>An Agent to Supervisor Assignment &lt;Assignment Name&gt; was modified.</td>
</tr>
<tr>
<td>10202</td>
<td>An Agent to Supervisor Assignment &lt;Assignment Name&gt; was deleted.</td>
</tr>
<tr>
<td>10203</td>
<td>The schedule for Agent to Supervisor Assignment &lt;Assignment Name&gt; was modified.</td>
</tr>
<tr>
<td>10204</td>
<td>The scheduled Agent to Supervisor Assignment &lt;Assignment Name&gt; was activated.</td>
</tr>
</tbody>
</table>
Audit Trail monitors the following Access and Partition Management events:

<table>
<thead>
<tr>
<th>Event code</th>
<th>Event description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10205</td>
<td>The scheduled Agent to Supervisor Assignment &lt;Assignment Name&gt; was deactivated.</td>
</tr>
<tr>
<td>10210</td>
<td>An Agent to Skillset Assignment &lt;Assignment Name&gt; was added.</td>
</tr>
<tr>
<td>10211</td>
<td>An Agent to Skillset Assignment &lt;Assignment Name&gt; was modified.</td>
</tr>
<tr>
<td>10212</td>
<td>An Agent to Skillset Assignment &lt;Assignment Name&gt; was deleted.</td>
</tr>
<tr>
<td>10216</td>
<td>The Agent to Skillset Assignment &lt;Assignment Name&gt; was run.</td>
</tr>
<tr>
<td>10213</td>
<td>The schedule for Agent to Skillset Assignment &lt;Assignment Name&gt; was modified.</td>
</tr>
<tr>
<td>10214</td>
<td>The scheduled Agent to Skillset Assignment &lt;Assignment Name&gt; was activated.</td>
</tr>
<tr>
<td>10215</td>
<td>The scheduled Agent to Skillset Assignment &lt;Assignment Name&gt; was deactivated.</td>
</tr>
</tbody>
</table>

Access and Partition Management events

Audit Trail monitors the following Access and Partition Management events:

<table>
<thead>
<tr>
<th>Event code</th>
<th>Event description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10240</td>
<td>Contact Center Manager Administration User &lt;First Name&gt; &lt;Last Name&gt; was added.</td>
</tr>
<tr>
<td>10241</td>
<td>Contact Center Manager Administration User &lt;First Name&gt; &lt;Last Name&gt; was modified.</td>
</tr>
<tr>
<td>10242</td>
<td>Contact Center Manager Administration User &lt;First Name&gt; &lt;Last Name&gt; was deleted.</td>
</tr>
<tr>
<td>10250</td>
<td>Access Class &lt;Access Class Name&gt; was added.</td>
</tr>
<tr>
<td>10251</td>
<td>Access Class &lt;Access Class Name&gt; was modified.</td>
</tr>
</tbody>
</table>
Audit Trail Standard 10.03

Real-Time Reporting events

Audit Trail monitors the following Real-Time Reporting events:

<table>
<thead>
<tr>
<th>Event code</th>
<th>Event description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10252</td>
<td>Access Class <code>&lt;Access Class Name&gt;</code> was deleted.</td>
</tr>
<tr>
<td>10260</td>
<td>Partition <code>&lt;Partition Name&gt;</code> was added.</td>
</tr>
<tr>
<td>10261</td>
<td>Partition <code>&lt;Partition Name&gt;</code> was modified.</td>
</tr>
<tr>
<td>10262</td>
<td>Partition <code>&lt;Partition Name&gt;</code> was deleted.</td>
</tr>
<tr>
<td>10270</td>
<td>Report Group <code>&lt;Report Group Name&gt;</code> was added.</td>
</tr>
<tr>
<td>10271</td>
<td>Report Group <code>&lt;Report Group Name&gt;</code> was modified.</td>
</tr>
<tr>
<td>10272</td>
<td>Report Group <code>&lt;Report Group Name&gt;</code> was deleted.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Event code</th>
<th>Event description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10280</td>
<td>Real-time Display <code>&lt;template Name&gt;</code> was added.</td>
</tr>
<tr>
<td>10281</td>
<td>Real-time Display <code>&lt;template Name&gt;</code> was modified.</td>
</tr>
<tr>
<td>10282</td>
<td>Real-time Display <code>&lt;template Name&gt;</code> was deleted.</td>
</tr>
<tr>
<td>10290</td>
<td>Real-time filter <code>&lt;filter Name&gt;</code> was added.</td>
</tr>
<tr>
<td>10291</td>
<td>Real-time filter <code>&lt;filter Name&gt;</code> was modified.</td>
</tr>
<tr>
<td>10292</td>
<td>Real-time filter <code>&lt;filter Name&gt;</code> was deleted.</td>
</tr>
</tbody>
</table>

Scripting events

Audit Trail monitors the following Scripting events:

<table>
<thead>
<tr>
<th>Event code</th>
<th>Event description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10330</td>
<td>Script <code>&lt;Script Name&gt;</code> was added.</td>
</tr>
<tr>
<td>10331</td>
<td>Script <code>&lt;Script Name&gt;</code> was modified.</td>
</tr>
<tr>
<td>10332</td>
<td>Script <code>&lt;Script Name&gt;</code> was deleted.</td>
</tr>
</tbody>
</table>
### Historical Reporting events

Audit Trail monitors the following Historical Reporting events:

<table>
<thead>
<tr>
<th>Event code</th>
<th>Event description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10360</td>
<td>Historical Report &lt;Report Name&gt; in Report Group &lt;Report Group Name&gt; was added.</td>
</tr>
<tr>
<td>10361</td>
<td>Historical Report &lt;Report Name&gt; in Report Group &lt;Report Group Name&gt; was modified.</td>
</tr>
<tr>
<td>10362</td>
<td>Historical Report &lt;Report Name&gt; in Report Group &lt;Report Group Name&gt; was deleted.</td>
</tr>
<tr>
<td>10365</td>
<td>The Historical Report &lt;Report Name&gt; in Report Group &lt;Report Group Name&gt; was run.</td>
</tr>
<tr>
<td>10363</td>
<td>The scheduled Historical Report &lt;Report Name&gt; in Report Group &lt;Report Group Name&gt; was activated.</td>
</tr>
<tr>
<td>10364</td>
<td>The scheduled Historical Report &lt;Report Name&gt; in Report Group &lt;Report Group Name&gt; was deactivated.</td>
</tr>
</tbody>
</table>
### Event code | Event description
--- | ---
10370 | Historical Filter <Filter Name> was added.
10371 | Historical Filter <Filter Name> was modified.
10372 | Historical Filter <Filter Name> was deleted.
10366 | Import Report completed: <Report Type; Report Name; Template Name; Location;>.

**Report Creation Wizard events**

Audit Trail monitors the following Report Creation Wizard events:

### Event code | Event description
--- | ---
10390 | License Granted. User: %1, License Type: %2.
10391 | License Denied. User: %1, License Type: %2.
10392 | License Released. User: %1, License Type: %2.
10393 | License Release Failed. User: %1, License Type: %2.
10400 | RCW Report <Report Name> was added.

**XML automated assignments feature Audit Trail events**

Audit Trail monitors whether agent-to-skillset and agent-to-supervisor assignments were created successfully using the XML automated assignments feature. For an assignment to be successful, you must create an XML file that meets specific criteria, and the file must be parsed by the automated assignments utility on the application server. Audit Trail records both successful and failed assignments. For more information about this feature, see “Using the XML automated assignments feature” on page 127.
Audit Trail monitors the following XML automated assignments feature events:

<table>
<thead>
<tr>
<th>Event code</th>
<th>Event description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10300</td>
<td>IceAssignment service started.</td>
</tr>
<tr>
<td>10301</td>
<td>IceAssignment: Notification not started. dwChangeHandle is invalid.</td>
</tr>
<tr>
<td>10302</td>
<td>IceAssignment: Error starting directory monitoring. Could not create directory.</td>
</tr>
<tr>
<td>10303</td>
<td>IceAssignment: Error: Contact Center Manager server IP address is invalid or does not exist in &lt;XML file-name&gt;.</td>
</tr>
<tr>
<td>10304</td>
<td>IceAssignment: Error: Assignment name not provided in &lt;XML file-name&gt;.</td>
</tr>
<tr>
<td>10305</td>
<td>IceAssignment: &lt;XML file-name&gt; moved to xml errors directory.</td>
</tr>
<tr>
<td>10306</td>
<td>IceAssignment: Error: Failed to create assignment &lt;assignment name&gt;.</td>
</tr>
<tr>
<td>10307</td>
<td>IceAssignment: Error: Cannot parse xml in &lt;XML file-name&gt;.</td>
</tr>
<tr>
<td>10308</td>
<td>IceAssignment: Error: No agent details specified in &lt;XML file-name&gt;.</td>
</tr>
<tr>
<td>10309</td>
<td>IceAssignment: Error: Cannot build assignment list in &lt;XML file-name&gt;.</td>
</tr>
<tr>
<td>10310</td>
<td>IceAssignment: Error: Unrecognizable skillset &lt;Skillset name&gt;.</td>
</tr>
<tr>
<td>10311</td>
<td>IceAssignment: Error: Skillset assignment not created for agent with login ID &lt;loginId&gt;.</td>
</tr>
<tr>
<td>10312</td>
<td>IceAssignment: Error: Failed to set data for &lt;assignment-name&gt;.</td>
</tr>
<tr>
<td>10313</td>
<td>IceAssignment: &lt;XML file-name&gt;: Assignment has been created successfully.</td>
</tr>
<tr>
<td>Event code</td>
<td>Event description</td>
</tr>
<tr>
<td>------------</td>
<td>-------------------</td>
</tr>
<tr>
<td>10314</td>
<td>IceAssignment: Error: Skillset assignment not created for supervisor with login ID &lt;login Id&gt;.</td>
</tr>
<tr>
<td>10315</td>
<td>IceAssignment: Error: 1000 entry limit reached in &lt;XML File-name&gt;.</td>
</tr>
<tr>
<td>10316</td>
<td>IceAssignment: Error: Invalid Login ID: Supervisor assignment not created for agent with login ID&lt;Login ID&gt;.</td>
</tr>
<tr>
<td>10317</td>
<td>IceAssignment: Error: Invalid Execute Option for &lt;Assignment Name&gt;, Defaulting to Schedule</td>
</tr>
<tr>
<td>10318</td>
<td>IceAssignment: Error: Failed to execute the assignment &lt;Assignment Name&gt;</td>
</tr>
<tr>
<td>10319</td>
<td>IceAssignment: &lt;Assignment Name&gt;: Assignment has been executed successfully.</td>
</tr>
</tbody>
</table>
Chapter 10

Scripting

In this chapter

What is new in Scripting 226
Overview 228
To view, create, edit, validate, activate, and export scripts 229
To view and create script variables 234
To view, edit, and assign application threshold classes 237
To work with sample scripts 239
To check variables for referencing scripts 241
What is new in Scripting

For Release 6.0, Contact Center Manager Administration provides a fully integrated Web-based Script Manager and a larger Script Editor window; viewing, sorting, and printing enhancements for script variables and scripts; and import and export improvements.

New Script Variables Window
The Script Variables window provides the following functions:

- View all variables in folder and grid format
- Yes/No indication if a variable is used in an active script
- Filter on variable types
- View script variable properties
- Change attributes
- Copy variable

New Script Manager Window
The Script Manager window provides the following functions:

- Remove need for Terminal Services with Scripting
- List all scripts....Open/New/Delete/Rename options
- Sort column headers
- See “last modified by” username

New Script Editor Window
The Script Editor window provides the following functions:

- Edit, validate and activate scripts
- View multiple scripts
- Maximize screen working area with full-screen view
- Function menus and toolbar
- Integrated Script Commands tab in Script Editor
- Easy-to-find validation errors through hyperlinks
- Import and Export scripts
- Text Find and Replace
- Character Count

**GIVE IVR command**

For a CS 2x00/DMS switch, the GIVE IVR command is supported in the scripts commands for the INTERRUPTIBLE keyword and the WITH TREATMENT optional segment.

The WITH TREATMENT segment enables you to specify the treatment that a call receives. If you do not specify a treatment, the system applies the default treatment DN.

The supported syntax is:

```plaintext
GIVE IVR {INTERRUPTIBLE} <ivr_dn> {WITH TREATMENT <vsdn>}
```

**Multimedia scripts**

Multimedia contacts are supported on the Communication Server 1000/M1 switch (e-mail, Web communications and outbound) and the Communication Server 2x00/DMS switch (e-mail, Web communications). The scripting functionality for multimedia contacts is presented in the Web-based Script Editor. The TRANSFERRED intrinsic cannot be used in Communication Server 2x00/DMS scripts. The intrinsic is replaced with the CONSULTED intrinsic.
Overview

Use the Scripting component of Contact Center Manager Administration to write scripts that determine the sequence of steps a call follows after it enters the system. These steps can include call treatment, such as music or ringback, skill-based routing, or Interactive Voice Response (IVR).

In the Scripting component, you can perform the following procedures (provided that a user with administrator privileges assigns you the appropriate access privileges):

- View existing scripts.
- Create and edit scripts.
- Validate scripts.
- Display all script variables and corresponding parameters.
- View, edit, and assign application threshold classes.

If you need to perform one of the preceding actions, but you cannot access the necessary Scripting component, request that your administrator review your access class privileges. The administrator may need to update your Scripting access privileges. For more information about Scripting access classes, see “Scripting access class elements” on page 150 or the Contact Center Manager Administration online Help.

This section provides you with a high-level overview of the Scripting component. For more information, see the Contact Center Manager Scripting Guide for Communication Server 1000/Meridian 1 PBX, the Contact Center Manager Scripting Guide for Communication Server 2X00/DMS, or the Contact Center Manager Administration online Help.
To view, create, edit, validate, activate, and export scripts

You can view a list of the existing scripts for a specific server in Contact Center Manager Server. You can also create, edit, validate, activate, and export scripts.

Viewing a script

1. In the system tree, select a server.
2. Click the **Script Manager** folder.

**Result:** The Script Manager window appears.

![Script Manager Window](image)

The Last Modified column displays the date and time from the telephony switch for that modified script. The Time column in the Audit Trail component displays the date and time from the Contact Center Manager Administration server for that modified script.

Displaying or editing a script

1. In the system tree, select a server.
2. Click the **Script Manager** folder.
3 In the Script Manager window, double-click a script or right-click a script and select **Open**.

**Result**: The Scripts Editor window appears.

![Web Scripts Editor - Microsoft Internet Explorer](image)

You can make changes to activated scripts and to scripts that are validated but not activated.

When you write or edit a script in the Scripts Editor window, you can click the Script Commands tab to launch the Script Command Reference window, where you can insert script elements, such as commands, operators, events, intrinsics, and variables.

### Creating a script

1 In the system tree, select a server.

2 Click the **Script Manager** folder.

3 Right-click the Script Manager folder and select **New**.

**Result**: The Scripts Editor window appears.
Saving a new script

1. In the Scripts Editor window, from the menu, select **File > Save**.
   
   **Result:** A confirmation dialog box appears asking you to confirm whether you want to save the script to the selected server.

2. Click **Yes**.
   
   **Result:** The New Script Name dialog box appears.

3. In the New Name box, type a name for your script. Script names can contain a maximum of 30 English-only characters.

Validating a script

1. In the Script Editor window, select **Edit > Validate**.
   
   **Result:** A Validate Confirmation dialog box appears asking you to confirm that you want to validate the script.

2. Click **Yes**.
   
   **Result:** The validation results appear at the bottom of the Scripts Editor window.
If a script fails to validate, an error message appears in the bottom section of the Scripts Editor window. Accompanying this message is a list of errors. The list includes the line and position number for each error, as well as whether the error is critical. In addition to errors, the list also includes warning messages and suggestions. Click an error in the list to highlight and display the section of the script associated with that error.

A message also appears to the user if the script is validated successfully.

Validation options

You can set the validation options so that the application informs you when you break script writing rules. The rules help eliminate run-time errors that result in improper call routing in Contact Center Manager Server.

Viewing validation options

In the Script Editor window, click View > Validation Options.

Result: The Validation Options dialog box appears.
You can configure validation options to enforce scriptwriting rules automatically after a script is successfully validated or before an activated script is edited and then reactivated. You can also configure validation options to display warning messages.

**Activating a script**

An edited script is inactive until you activate it. You cannot activate an edited script until you validate the script.

1. In the Scripts Editor window, from the menu, select File > Activate.
   
   **Result:** An Activate Confirmation dialog box appears asking you to confirm that you want to activate the script.

2. Click Yes.
   
   **Result:** A message appears at the bottom of the Scripts Editor window indicating whether the script was activated successfully.

   Single scripts cannot exceed 50,000 characters. An error message appears if you exceed this limit.

**Exporting scripts**

1. In the Scripts Editor window, click File > Export. If a script references another script, you can export both scripts at once by clicking File > Export All.
   
   **Result:** A Save As dialog box appears.

2. Browse to a location in which to save the script.

3. Click Save.
   
   **Result:** The Export command outputs the script to a file on the Contact Center Manager Administration server with the file extension .s. The system creates a new file if the file does not exist; if a file with the same name exists, the exported script overwrites it. A message appears at the bottom of the Scripts Editor window indicating whether the script was exported successfully.
To view and create script variables

Script variables, like variables used in any programming language, represent a value. You can define a script variable in the Script Variables window and use it in more than one script. When you change a variable in the Script Variables window, all occurrences of that variable change.

Before you create script variables, you must set up all system resources such as RAN routes, music routes, voice ports, CDNs, IVR-DNs, and call treatments. In addition, you must configure all skillsets and agents on the selected server. Finally, if you plan to create voice segment variables, you must create all of the voice segments.

For a detailed list of the script variables types that you can create, and their valid values, see the Contact Center Manager Administration online Help.

Viewing a script variable

1 In the Scripting component, in the system tree, click the name of the server on which you want to view the script variable.

    **Result:** The server expands to reveal a series of icons.

2 Click the **Script Variables** folder.

    **Result:** The Script Variables tree expands, listing all types of script variables, and the Script Variables window appears.

    All existing variables on the selected server are listed beneath the Script Variables heading in the folder corresponding to the variable type. If you do not see the Script Variables heading in the system tree, then your administrator has not given you access to this component of Scripting. Contact your administrator and request access to Script Variables on the selected server.

3 In the system tree, double-click the variable type folder that contains the variable that you want to view.

    **Result:** The variable type folder expands and the variables appear.

4 Click the variable that you want to view.

    **Result:** The Script Variables window appears.
Creating a script variable

1. From the system tree, click the name of the server on which you want to create the script variable.

   **Result:** The server expands to reveal a series of icons.

2. Click the **Script Variables** folder.

   **Result:** The Script Variables tree expands, listing all of the script variable types, and the Script Variables window appears.

   All existing variables on the selected server are listed beneath the Script Variables heading in the folder corresponding to the type of variable. If you do not see the Script Variables heading on the system tree, then your administrator has not given you access to this component of Scripting. Contact your administrator and request access to Script Variables on the selected server.

3. In the system tree, right-click on the variable type folder of the variable you want to create and select **New**.

   This prepopulates the Type list on the Attribute tab with the relevant script variable type. You can also right-click the Script Variables folder and select New to create a new variable. In this case, the Type list prepopulates with the first script variable type, which is ACD. You can then change it to the variable type that you want.

4. Below the table, click **Script Variable Properties**.

   **Result:** The heading expands to reveal the General and Attribute tabs.

5. On the **General** tab, in the **Name** box, type the name of the new variable.

   Script variable names must be unique. Names cannot be the same as any script language keywords or intrinsics. (For more information, see the Contact Center Manager Administration online Help.)

   Names can contain up to 30 characters, must begin with an alphabetic character, and cannot contain spaces.

   Valid characters for script variable names are A–Z, a–z, 0–9, and _ (underscore). Use an underscore in place of a space.

6. Click the **Call Variable** option button if the variable is for one specific call only; otherwise, click **Global Variable** to be able to use the variable in all scripts.

7. In the **Comment** box, type any comments you want to save with the variable.
8 Click the **Attribute** tab.

9 From the **Type** list, select the variable type, and then type the value or a range of values for the variable type in the **Value** box.

10 Based on the variable type, you may be able to choose the class assigned to the script variable. The class indicates if a script variable has a single value (**Item**) or a set of values (**Set**).

11 Click **Submit** to save your data.

**Result:** The new variable appears in the system tree in the folder corresponding to the variable type.
To view, edit, and assign application threshold classes

You can view and edit threshold classes and assign them to applications in the Scripting component. To create new threshold classes or to delete threshold classes, you must use the Threshold Classes window in the Configuration component.

Applications are used for reporting. For the Master script and each activated primary script called by the Master script, the system automatically creates an application with the same name as the script.

No scripts are associated with the ACD_DN application or the NACD_DN application.

Viewing, editing, or assigning application thresholds

Applications track information about calls, contact types, and conditions in the contact center. Contact center managers and supervisors can view this information by using real-time displays or by running reports against the applications. You can assign thresholds to applications by creating application threshold classes in the Threshold Classes window of the Configuration component and then applying the threshold classes to the application. For a complete list of application thresholds, see the Contact Center Manager Administration online Help.
1 In the system tree, select a server.
2 Select the **Application Thresholds** folder.

**Result:** The Application Thresholds window appears.

3 From the list of applications in the left pane of the window, select the application for which you want to view thresholds.
4 In the right pane, from the list, select the threshold class.

**Result:** The thresholds associated with the selected threshold class appear in a table.
5 Make the desired changes.
6 For the new threshold values to take effect, select the **Enabled** check box beside each application threshold.
To work with sample scripts

When you install Contact Center Manager Administration on the Contact Center Manager Administration server, it automatically installs sample scripts in separate folders in the following default location:

C:\Program Files\Nortel Networks\WClient\Server\SampleScripts

where C: is the drive on which you installed Contact Center Manager Administration.

In this location, the system installs the following types of sample scripts, each type in its own folder:

- CS2x00 (DMS)_samples
- CS1000 (M1)_samples
- Multimedia_samples
- SIP_samples

To use these sample scripts, import the scripts that you want to use from the Contact Center Manager Administration server into Contact Center Manager Administration by using the Import command in the Scripting component. The Import command adds the text of the imported script to any text in the current script. For detailed information about sample scripts, see the Contact Center Manager Scripting Guide for Communication Server 1000/Meridian 1 PBX or the Contact Center Manager Scripting Guide for Communication Server 2x00/DMS.

The variables used in the sample scripts are examples only. If you use a sample script that contains variables, you must create and define the variables on your system.

Before you begin using sample scripts, verify the following conditions:

- All system resources, such as RAN routes, music routes, voice ports, call treatments, DNs, and IVR DNs are set up.
- All variables, agents, and skillsets are created.
- All voice segments for voice prompts are created.
Importing sample scripts into Contact Center Manager Administration

To use the sample scripts in Contact Center Manager Administration, you can import them into either an existing script or a new script in the Scripting component. The Import command adds the text of the imported sample script at the end of text in the current script.

1. To import a sample script into an existing script, in the Script Manager, double-click the script into which you want to import the sample script.
   
   **Result:** The script opens in the Script Editor.
   
   OR
   
   To import a sample script into a blank script, right-click on the Script Manager folder and select **New** from the resulting menu.
   
   **Result:** The Script Editor opens with a blank starting page.

2. In the Script Editor, click **File > Import**.
   
   **Result:** The Import window appears.

3. Select **From Server**, and then navigate to the location on the server where the sample scripts are stored.

4. Select the sample script that you want to import.

5. Click **OK**.
   
   **Result:** The system adds the text of the sample script.

**ATTENTION**

The script that you import may contain references to variables. Variables are not imported with the script. You must define the variables on your system.
To check variables for referencing scripts

You can use this procedure to check whether a variable is referenced by any active scripts. If a script variable is referenced by any active scripts, you cannot change its properties (except for its value), rename it, or delete it.

Checking variables for referencing scripts

1. On the system tree, click the server containing the variable that you want to check for referencing scripts.
   
   Result: The server expands to reveal a list of folders.

2. Click Script Variables.

   Result: The Script Variables tree appears listing all script variable types.

   If you require access to script variables, but you do not see the Script Variables heading on the system tree, then your administrator has not given you access to this component of Scripting. Contact your administrator and request access to Script Variables on the selected server.

3. On the Script Variables tree, click the folder containing the script variable you want to check for referencing scripts.

   Result: The folder expands to reveal the list of configured variables.

4. Click the script variable that you want to check for referencing scripts.

   Result: The Script Variables window appears.

5. Check for activated scripts that reference the variable as follows:
   
   a. In the Script Variables table, if the value in the Used in Script box is Yes, then the variable is referenced in a script.

   b. Click Script Variable Properties, and then click the General tab. Activated scripts that currently reference the variable are listed in the Referencing Scripts table.

   c. If the variable is referenced in activated scripts, deactivate the scripts, or remove references to the variable in the scripts.
Chapter 11

Outbound Campaign Management Tool

In this chapter

Overview 244
To launch the Outbound Campaign Management Tool 248
To create a campaign 251
To modify campaigns 267
To review campaign progress and results 269
To create and preview an agent script 274
To define disposition codes 277
To view log files 279
To archive outbound campaigns 283
Overview

Use the Outbound Campaign Management Tool to create, modify, and monitor outbound campaigns. You can configure a maximum of 100 active outbound campaigns with 20,000 contacts in each campaign.

**ATTENTION**

Contact Center Outbound functions are only supported on the Communication Server 1000/Meridian 1 switch.

An active outbound campaign is defined as the campaigns that are currently running, waiting to run, or are paused. An inactive campaign is a campaign that is complete, cancelled or expired. The total number of active and inactive campaigns can not exceed 500. To ensure operational efficiency, perform regular archives. For more information about archiving campaigns, see the Contact Center Multimedia and Outbound Installation and Maintenance Guide.

The Outbound Campaign Management Tool can support a maximum of 20,000 queued contacts at one time. To regulate the flow of outbound contacts into the queue, perform one of the following:

- specify a campaign date and start time.
- manually pause or resume a campaign

The Outbound Campaign Management Tool is not available in a SIP-enabled contact center.

The following diagram shows how outbound contacts interact with Contact Center Manager Administration, Contact Center Multimedia, and Contact Center Manager Server.
Contact Center Outbound consists of the following components:

- **Outbound Campaign Management Tool**—A contact center administrator or supervisor can use the Outbound Campaign Management Tool to create and monitor outbound campaigns. The Outbound Campaign Management Tool provides the following main functions:
  - Define a campaign.
  - Import call data.
  - Create disposition codes.
  - Review outbound call data.
  - Create and preview optional agent scripts.
  - Review campaign progress.

- **Campaign Scheduler**—This Contact Center Multimedia server component determines when to queue contacts to the Contact Center Manager Server. The Campaign Scheduler monitors the status of each campaign and performs the following actions:
- Sets the campaign status to running and queues contacts to Contact Center Manager Server when the campaign start time or daily start time occurs.
- Sets the campaign status to nonrunning and removes contacts from Contact Center Manager Server when the daily end time occurs.
- Sets the campaign status to expired and removes contacts from Contact Center Manager Server when the daily end time occurs.
- Sets the campaign status to completed when all contacts are processed.

Contacts are queued to Contact Center Manager Server at the configured rate. By default, the Campaign Scheduler presents outbound contacts every 60 seconds. Use the Campaign Scheduler Configuration window in the Contact Center Multimedia Administrator to change the interval length.

- **Contact Center Agent Desktop**—Agents use Contact Center Agent Desktop to process outbound contacts. When a campaign runs, outbound contacts are routed to Agent Desktop, and agents can:
  - Accept or reject an outbound contact.
  - Review and update customer information.
  - Make the outbound voice call.
  - Follow an agent script and record customers answers and comments.
  - Select a disposition code to record the result of the call.

For more information about Contact Center Agent Desktop, see the *Contact Center Agent Desktop User Guide*.

- **Contact Center Manager Administration**—Use Real-Time Reporting and Historical Reporting in Contact Center Manager Administration to create and run real-time and historical reports for campaigns.

Real-Time Reporting displays real-time and up-to-date statistics information regarding a campaign, such as the number of waiting contacts, the number of answered contacts, or the average answer delay. For more information about Real-Time Reporting, see Chapter 7, “Real-Time Reporting.”

Historical Reporting provides information about outbound campaigns in the following standard reports:
- Campaign Call Details
- Campaign Script Result Details
- Campaign Summary
- Script Summary

For more information about Historical Reporting, see Chapter 8, “Historical Reporting.” In addition to the standard reports, you can use Report Creation Wizard to customize and create new reports.

The following sections provide a high-level overview of the Outbound Campaign Management Tool. For detailed information, see the step-by-step procedures in the Outbound Campaign Management Tool online Help.
To launch the Outbound Campaign Management Tool

Before a user can launch the Outbound Campaign Management Tool you must complete the following prerequisites:

- Configure a Contact Center Multimedia server in the Configuration component of Contact Center Manager Administration. For more information, see “To add and configure contact center servers” on page 70.

- Install Microsoft .Net Framework version 1.1 and the .Net Service Pack 1 on the computer that you use to configure outbound campaigns. The dotnetfx.exe file is on the Contact Center DVD in Multimedia/ Microsoft .NET Framework 1.1 Redistributables. The NDP1.1sp1-KB867460-X86.exe file is in Multimedia/ Microsoft .NET Framework 1.1 Redistributables/Service Pack 1. For more information, see the Contact Center Multimedia Installation and Maintenance Guide.

- Install the Nortel Multimedia security policy, CCMM_Security_Policy.msi, using Systems Management Server (SMS) or Group Policy. The CCMM_Security_Policy.msi file is on the Contact Center DVD in Multimedia/CCMM Security Policy. For more information, see the Contact Center Multimedia Installation and Maintenance Guide.

- Assign users basic access rights to the Outbound component in Access and Partition Management using Contact Center Manager Administration.

Assigning basic access rights

1. In the Access and Partition Management component, choose View/Edit > User Administration.

2. Select the user from the list in the system tree.
3 In the window on the right, click **Basic Access Rights**.

![Access and Partition Management](image)

4 Select the **Outbound** component.

5 Click **Submit**.

**Starting the Outbound Campaign Management Tool**

1 Click the **Outbound** component in the Contact Center Manager Administration launchpad window.

**Result:** The Outbound window appears.

![Outbound](image)

- **Outbound**
  - The tree displays a list of currently configured CCRM servers
  - Click on any CCRM server to connect to that server
2 In the system tree of the Outbound window, click on a Contact Center Multimedia server.

Result: The Outbound Campaign Management Tool window appears.
To create a campaign

To create a new campaign, click Create & Append on the toolbar of the Outbound Campaign Management Tool. When you create an outbound campaign, you define the required and optional settings for the campaign.

You can also use the Create & Append window to add call data to an existing campaign.

To define campaign settings

You can use the Campaign Settings page to define the campaign settings. To view the Campaign Settings page, in the Create & Append window, click the Campaign Settings tab.

Campaign Settings page
Required settings
You must define the following settings for each campaign:

- **Campaign Details**—Assign a name to the campaign. You can also enter a description (optional).

- **Campaign Start Date & Time**—Select Start Immediately to start the campaign immediately or specify a date and time to start the campaign. The time is local to the Contact Center Multimedia server and appears in the status bar of the window.

  The campaign scheduler interval affects the actual campaign start date and time. For example, if a campaign starts at 9:00 a.m. and the campaign scheduler interval is 1 minute, it could be 9:01 a.m. before the first contact is queued to the Contact Center Manager Server.

- **Skillset Routing**—Associate the campaign with a skillset. Each campaign can be associated with only one skillset. The default outbound skillset is OB_Default_Skillset.

  To report on campaign-specific statistics in real-time displays and historical reports, Nortel recommends that you create a new skillset for each campaign.

- **Call Priority**—Assign a priority (from 1 to 6) to the calls in the campaign; 1 indicates the highest priority and 6 indicates the lowest priority.

  Consider the priority of your incoming calls when you select the priority for the outbound campaign. In most contact centers, incoming voice calls have a higher priority than outbound calls.

- **Disposition Codes**—Assign disposition codes to the campaign. At the end of an outbound call, an agent chooses a disposition code to record the status of the call (for example, Sale Made or No Answer). For more information about disposition codes, see “To create disposition codes” on page 277.

Optional settings
The following campaign settings are optional:

- **Agent Script**—Choose a script to associate with the campaign. When you associate a script with a campaign, that script is presented to the agent on acceptance of the contact. For information about creating scripts, see “To create and preview an agent script” on page 274.
To save the agent script results for a campaign, you must create a disposition code and set the Save Agent Script option to yes. Agents must use the correct disposition codes that save the script answers when they close the contact. For more information about creating disposition codes, see “To define disposition codes” on page 277.

- **Dialer Settings**—Define when the call is dialed. You can choose one of the following dialing options:
  - **Manual Dial**—The agent makes the call when ready.
  - **Auto Dial Immediately**—The call is dialed immediately after the agent accepts the call.
  - **Auto Dial after specific time**—The call is dialed a specific number of seconds after the agent accepts the call.

If the minimum dial timeout function is enabled, the telephone rings for the specified time. The dial timeout function prevents an agent from making a call and immediately hanging up. The value for the dial timeout must be from 1 to 180 seconds.

If applicable, in the Trunk Access Code box, type the number required to access an external line for outbound calls. For example, at some organizations, agents must dial 9 to access an outside line.

- **Custom Fields**—Add custom data fields that are applicable to the campaign, for example, date of birth, or mother's maiden name. To populate custom fields, you can:
  - use the Import Wizard (for more information, see “To import call data” on page 256)
  - enter the data manually
  - use the Insert Text function to insert a value
  - leave the custom field blank for the agent to populate on the Contact Center Agent Desktop

When an agent receives a contact, the custom field name and value appear on the customer details panel in the Contact Center Agent Desktop.

- **Campaign End Date & Time**—Select an end date and time for the campaign. This time is relative to the Contact Center Multimedia server time. The server time is shown at the bottom of the Outbound Campaign Management Tool window for reference. You must use the server time as the time when campaigns start and end. By default, a campaign runs until all calls in the campaign are complete.
- **Daily Start & End Time**—Define the period of execution for the campaign (the start and end time for calls on a daily basis). These times are local to the Contact Center Multimedia server.

**ATTENTION**

When you configure the outbound campaign, be sure to obey local laws for telephone calls. For example, in North America, no outbound calls can be made to a private house after 9:00 p.m. You must determine the local policies for outbound call rules.

Defining the period of execution in the Outbound Campaign Management Tool can generate large amounts of high traffic volume. To reduce the high traffic volume, Nortel recommends that you create a scheduled event in Contact Center Manager Administration to assign agents to the skillset. For more information about assigning agents to the skillset, see “Ad hoc agent-to-skillset assignments” on page 107. Contact Center Manager Administration Scheduled Events provide identical functionality without the high traffic volume.

In cases where the server and client are in different time zones, the outbound campaign is configured for the time zone where the Contact Center Multimedia server is located. The local time for the Contact Center Multimedia server is displayed in the status bar at the bottom of the Outbound Campaign Management Tool window. You can use the agent-to-skillset assignments to create a skillset for each time zone to manage the calls.

You must also consider the rate at which contacts are queued to the Contact Center Manager Server when you determine your campaign end times. Depending on the system load, it can take 1 second to drop 3 contacts from the Contact Center Manager Server. You must account for dropping a number of contacts from your campaign before the end time. For example, you need to end a 750-contact campaign at 9:00 p.m. During this campaign, the maximum number of contacts to drop from the Contact Center Manager Server is 750. It can take as long as 250 seconds (5 minutes) to drop 750 contacts, so, to obey local laws, you must set the campaign daily end time at 8:55 p.m.

- **Call queue rate**—Define the frequency at which contacts are presented to Contact Center Manager Server. If you do not define a call rate, all contacts are presented at once to the specified skillset queue.
Contacts are queued to Contact Center Manager Server at a rate of approximately five contacts per second. So for a 750-contact campaign, it takes about 2.5 minutes to queue all contacts to Contact Center Manager Server.

After you define the campaign settings, you must assign customer data to the campaign. For more information, see “To define call settings” on page 255.

**To define call settings**

Use the Call Settings page to associate customers to a campaign. You can import customer data or manually add customer data. When the data is imported, you can clean up data by checking particular fields, searching for particular calls, completing data for calls, removing duplicate calls, and checking the Do Not Call list.

**Call Settings page**
To import call data

Use the Import Wizard to import call data from one of three sources—a text file, an ODBC database, or an existing campaign.

- **Importing call data from a text file**—When you import data from a text file, the file can be delimited as shown in the following example. The file can be delimited by a tab, a space, or any specified character. The following example shows a portion of comma-delimited file.

```
733201,091,353,John,Smith,john@nortel.com
731457,091,353,Paul,Johnson,paul@nortel.com
736123,091,353,Seamus,Howard,seamus@nortel.com
```

The data fields within the file are listed in any order; however, the order must be consistent throughout the file. Each row must contain one valid phone number. During the import process, you can map the import data fields to the standard Outbound Campaign Management Tool data fields (for example, to identify common fields such as name, address, and phone number).

- **Importing call data from an ODBC data source**—When you import call data from an external Open Database Connectivity (ODBC) database, you must define a Data Source Name (DSN) on the computer on which the Outbound Campaign Management Tool is running. Within the Outbound Campaign Management Tool, select the DSN of the external database and the table/view from which you want to import call data. This import method
is useful for contact centers that maintain a stand-alone Customer Relationship Management (CRM) database.

When you import the data from a text file or an ODBC data file, you can drag the database fields and place them in the corresponding Outbound Campaign Management Tool field.

![OCMT ODBC Import Wizard - Map Columns (step 3 of 3)](image)

**ATTENTION**

If the Outbound Campaign Management Tool runs on a Microsoft Windows 2000 computer, you must have Microsoft Data Access Components (MDAC) version 2.6 or later. You can download the updates from the Microsoft Web site (www.microsoft.com).

- **Importing call data from an existing campaign**—You can import call data from the Contact Center Multimedia database to generate a new campaign from a previously used outbound campaign. For example, you can generate a call list of customers who indicated interest in a particular product during an outbound sales campaign, but did not purchase the product during that campaign. In this example, you could use a disposition code to filter the results of a previous campaign to create a follow-up outbound campaign.

For a detailed explanation of how to import call data, see the Outbound Campaign Management Tool online Help.

**To enter customer data manually**

If data is not available in electronic format, you can manually enter customer data into the Call Data table. To enter customer data, click a column in the data table and type the data on the next blank line.
If you add a custom field to the campaign setting, a column in the Call Data table appears with this name. You can perform the same operations on this custom field that you can perform on any of the default fields.

To review call data
You can perform a manual review of the Call Data table. To list data alphanumerically, click a column header to sort the field. At any time, you can click one of the following options to select a group of calls or perform an operation:

- **Check All**—Select all calls in the Call Data table.
- **Uncheck All**—Clear all calls in the Call Data table.
- **Toggle**—Reverse the selected and cleared calls.
- **Undo Last or Redo Last**—Undo or redo the last operation performed on the Call Data table. For example, you can restore deleted information or reverse a change.
- **Delete Checked Calls**—Delete the selected calls from the Call Data table.
- **Export Checked Calls**—Launch the export wizard to export selected calls to a file. You can use this feature to save customer data that fails validation. For more information about exporting call data, see the Contact Center Manager Administration online Help.

To clean up call data
To clean up call data, on the Call Settings page, click the Call Data Cleanup tab.

Use the Call Data Cleanup page to perform the following tasks on a selected group of calls:
- **Insert text**—Insert text into a field. You can choose to overwrite the contents of the field, add text to the beginning of the field, or add the text to the end of the field.

- **Remove text**—Remove characters from a field. For example, you can choose to remove brackets from the area code field of the call data.

- **Replace text**—Replace a character with a number. For example, where there is a plus (+) sign in front of an international code, you can replace the plus (+) sign with the correct country code.

- **Split phone number**—Separate digits in a phone number field. For example, you might import phone numbers that include the international and area codes in the same field. You can leave the numbers as they are (therefore, no international or area code fields are populated, but the numbers are still dialable). Or, you can use this page to split the number into its relevant international code and area code parts. Use this feature to ensure that the telephone numbers appear in a clear format on the Agent Desktop application.

- **Validate call data**—Validate the call data to ensure that all telephone number fields contain only numbers.

**To search call data**

To search call data, on the Call Settings page, click the Call Data Search tab.

![Call Data Search](image)

Use the Call Data Search page to perform the following tasks:

- **Length search**—Search for fields with a particular number of characters. For example, you can search for telephone numbers in the Phone Number field that are longer than seven digits.

- **Value search**—Search for fields that contain a particular number. For example, you can search for calls that are in a particular region with the same area code.
- **Numeric search**—Search for fields that contain only numbers. For example, you can search for account fields that only contain numbers.

**To search for duplicate calls**
To search for duplicate calls, on the Call Settings page, click the Duplicate Calls tab.

Use the Duplicate Calls page to search for duplicate call listings based on the selected fields.

**To match customers to the Multimedia database**
To match customers, on the Call Settings page, click the Customer Match tab.

Click Check Customer Association to find exact and close matches between the data in the Call Data table and the Multimedia database. When a customer in the call table matches a customer in the Multimedia database, the information from the Multimedia database is used to provide more data for the customer. Also, you can update customer information in the Multimedia database based on the information in the Call Data table.
To add information to the Call Data table, the Outbound Campaign Management Tool matches existing customers in the Multimedia database to the Call Data table information based on the following criteria:

- exact e-mail match
- exact first name and last name and phone number (international code, area code, and phone number)

If a customer in the Call Data table matches one of these criterion, then the information in the customer record in the Contact Center Multimedia database is added to the Call Data table.

The customer match feature also indicates close matches to existing customers in the Contact Center Multimedia database, so the administrator that creates the outbound campaign can determine whether the information in the Call Data table is a new customer, for which a new record should be created, or an existing customer. For example, if Mike Smith 091 12345 is in the Contact Center Multimedia database, and Michael Smith 091 12345 is in the Call Data table, when you run the Check Customer Association feature, the system displays the similarities to the administrator.

If you select the Enable Partial Phone Number Match check box, similarities between the Call Data table and the Contact Center Multimedia database are shown based on partial matches of the telephone number. For example, if the Call Data table contains Michael Smith 12345, and the Contact Center Multimedia database contains Mike Smith 091 12345, the partial match highlights the similarities. If you do not select the Enable Partial Phone Number Match check box, the entry in the Call Data table is considered new.

When a customer in the Call Data table matches a customer in the Multimedia database, two rules are applied:

- **Merge Rule**—Data present in the Call Data table and not in the Contact Center Multimedia database is merged into the customer record in the database. For example, if Mr. Mike Smith 091 12345 is in the Call Data table, and only Mike Smith 091 12345 is in the Contact Center Multimedia database, Mr. is added to the customer record in the Contact Center Multimedia database.

- **Update Rule**—If you select the Overwrite Existing Customer Data With New Data check box on the Call Data Import page, when you import data, the data in the Call Data table replaces the data in the Contact Center
Multimedia database. For example, if you select the Overwrite Existing Customer Data With New Data check box, the data, Mister Mike Smith 091 12345 in the Call Data table replaces the data, Mr. Mike Smith 091 12345, in the Contact Center Multimedia database.

**Examples**

**Updating existing customer records with overwrite=off**—If a customer in the Contact Center Multimedia database has an e-mail address that matches the e-mail address of an imported customer record, only blank fields in the customer database are updated with information from the imported customer record. If a telephone number exists in the Contact Center Multimedia database, then a new telephone number is added to the database record and that number is set to the default number.

Similarly, if a telephone number in the Contact Center Multimedia database matches a telephone number of an imported customer record, and an e-mail address exists, a new e-mail address is added to the Contact Center Multimedia database.

**Updating existing customer records with overwrite=on**—If a customer in the Contact Center Multimedia database has an e-mail address that matches the e-mail address of an imported customer record, all fields in the customer database are updated with information from the imported customer record. If a telephone number already exists in the Contact Center Multimedia database, then a new telephone number is added to the database record.

Similarly, if a telephone number in the Contact Center Multimedia database matches a telephone number of an imported customer record, and an e-mail address exists, a new e-mail address is added to the Contact Center Multimedia database.
The following table displays how imported customer information is saved in the database depending on the overwrite setting.

<table>
<thead>
<tr>
<th>Overwrite setting</th>
<th>Imported customer information</th>
<th>Existing database information</th>
<th>Result saved in database</th>
</tr>
</thead>
<tbody>
<tr>
<td>Off</td>
<td>Phone: 091 797123 First: Derek  Last: Jone's E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a> Title: Mr. Address: Kilcahill St. Number 204, Claregalway, Galway</td>
<td>Phone: Phone: 091 797123 First: D Last: Jones E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a> Title:</td>
<td>Phone: 091 797123 First: D Last: Jones E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a> Title: Mr. Address: 204 St. Silgo</td>
</tr>
<tr>
<td>On</td>
<td>Phone: 091 797123 First: Derek  Last: Jone's E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a> Title: Mr. Address: Kilcahill St. Number 204, Claregalway, Galway</td>
<td>Phone: Phone: 091 797123 First: D Last: Jones E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a> Title:</td>
<td>Phone: 091 797123 First: Derek Last: Jone's E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a> Title: Mr. Address: Kilcahill St. Number 204, Claregalway, Galway</td>
</tr>
<tr>
<td>Off</td>
<td>Phone: 091 797123 First: Derek  Last: Jone's E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a> Title: Mr. Address: Kilcahill St. Number 204, Claregalway, Galway</td>
<td>Phone: Phone: 086 432986 First: D Last: Jones E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a> Title:</td>
<td>Phone: 091 797123 * 086 432986 First: D Last: Jones E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a> Title: Mr. Address: 204 St. Silgo</td>
</tr>
</tbody>
</table>
To identify do not call numbers

Do not call numbers are numbers on a list either maintained by a government agency or maintained within your company to honor a request from a customer to not be called. Your call data must be checked against any government agency lists before you import the information into the Outbound Campaign Management Tool. The Outbound Campaign Management Tool automatically checks numbers against the internal do not call list that is generated by agents.

You can view the Do Not Call page on the Call Settings page in Create & Append.

<table>
<thead>
<tr>
<th>Overwrite setting</th>
<th>Imported customer information</th>
<th>Existing database information</th>
<th>Result saved in database</th>
</tr>
</thead>
<tbody>
<tr>
<td>On</td>
<td>Phone: 091 797123</td>
<td>Phone: 086 432986</td>
<td>Phone: 091 797123 * 086 432986</td>
</tr>
<tr>
<td></td>
<td>First: Derek</td>
<td>First: D</td>
<td>First: Derek</td>
</tr>
<tr>
<td></td>
<td>Last: Jone’s</td>
<td>Last: Jones</td>
<td>Last: Jone’s</td>
</tr>
<tr>
<td></td>
<td>E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a></td>
<td>E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a></td>
<td>E-mail: <a href="mailto:djones@nortel.com">djones@nortel.com</a></td>
</tr>
<tr>
<td></td>
<td>Title: Mr.</td>
<td>Title:</td>
<td>Title: Mr.</td>
</tr>
<tr>
<td></td>
<td>Address: Kilcahill St.</td>
<td>Address: 204 St., Silgo</td>
<td>Address: Kilcahill St.</td>
</tr>
<tr>
<td></td>
<td>Number 204,</td>
<td></td>
<td>Number 204,</td>
</tr>
<tr>
<td></td>
<td>Claregalway, Galway</td>
<td></td>
<td>Claregalway, Galway</td>
</tr>
</tbody>
</table>

Use the Do Not Call page to compare the telephone numbers against the internal Contact Center Multimedia Do Not Call list and remove matched results from the Call Data table.
If you do not remove a Do Not Call number before you start a campaign, the contact is set to a closed status and the disposition code is Do Not Call. The number of processed contacts in this campaign is incremented for each Do Not Call number.

After you import, clean up, and validate your call data, you can load the calls into the Contact Center Multimedia database and activate the campaign. See “To activate the campaign” on page 265.

**To activate the campaign**

When your data is cleaned up and ready to be used in the campaign, open the Campaign Activation page.

**Campaign Activation page**

From the Campaign Activation page, you can review and print the campaign summary and create the campaign.
When you click Create Campaign, you load the calls and campaign settings into the Contact Center Multimedia database to begin running according to the campaign settings.

Call validation is automatically invoked when you attempt to load the campaign into the database. If any of the telephone numbers are not dialable, the campaign is not loaded into the database, and the system prompts you to fix all problems with the call data.

Before you load the campaign into the Multimedia database, the campaign must meet the following requirements:

- The campaign size cannot exceed 5000 contacts.
- Any customer can receive only one call per campaign.
- Duplicate customers based on an exact e-mail match or exact first name and last name and phone number (international code, area code, and phone number) are not permitted.
- The mandatory phone number field must contain only numeric values and spaces and cannot exceed 32 characters.
- The area code must contain only numeric values and spaces and cannot exceed 10 characters.
- The international code field must contain only numeric values and spaces and cannot exceed 10 characters.
- The first name field cannot exceed 50 characters.
- The last name field cannot exceed 100 characters.
- If an e-mail address field is included, an @ symbol is required, and the address cannot exceed 128 characters.
- All other Call Data table fields cannot exceed 128 characters.

If any data fields fail validation, an error message appears. You can edit the customer details or delete the customer from the campaign.
To modify campaigns

To view the details of the campaign and modify campaign-level settings at any time, click Modify Campaign on the Outbound Campaign Management Tool toolbar. You can also cancel, pause, or restart a campaign from the Modify Campaign window.

**ATTENTION**

Modifying the campaign can impact system performance.

A campaign can have one of the following assigned status levels:

- **Waiting**—The campaign is waiting for the start date and time.

- **Running**—The campaign is within the campaign start and end date and time and within the daily start and end times, and contacts are presented to Contact Center Manager Server. If no daily start and end time is configured, after a campaign starts, it is in a Running state until it expires or is paused or canceled.

- **Non-running**—The campaign is within the campaign start and end date and time but outside the daily start and end time, therefore, the campaign is out of hours.

- **Paused**—The campaign is paused temporarily. When a campaign is in aPaused state, all contacts are deleted from Contact Center Manager Server and assigned the Waiting status. Only the administrator can return the campaign status to Running.

- **Cancelled**—The campaign is canceled. When a campaign is in a Cancelled state, all contacts are removed from Contact Center Manager Server. Unprocessed contacts are closed and the Campaign Cancelled disposition code is assigned.

- **Expired**—The campaign has reached its end date and time. Unprocessed contacts are closed and the Campaign Expired disposition code is assigned. If a campaign expires and you extend the campaign end date and time, you must restart the campaign for the contacts to be queued to Contact Center Manager Server.

- **Completed**—All contacts are complete and the campaign is complete.
To modify campaign settings

Use the Modify Campaign window to cancel, pause, or restart campaigns, and to modify the following campaign settings:

- Campaign start date and time
- Campaign end date and time
- Daily start and end time
- Dialer mode and minimum dial time
- Call rate settings
- Agent desktop script
- Disposition codes

For more information about modifying campaign settings, see the step-by-step procedures in the Outbound Campaign Management Tool online Help.
To review campaign progress and results

Review the status of all campaigns, including contact status, disposition code status, and call-by-call results including individual answers to script questions, if available. You can also view and print an up-to-date campaign summary and export the campaign summary or call data to a text file.

Skillset and agent information is reported for outbound campaigns in real-time displays and reports in Contact Center Manager Administration.

To view campaign progress and results

Select Progress & Results on the Outbound Campaign Management Tool toolbar to view the progress and results of all campaigns. You can review progress and results during the campaign and when the campaign is complete. You can view the following:

- Call Status Chart
- Disposition Codes Chart
- Call Details
- Campaign History
Call Status Chart page
Use the Call Status Chart page to view a summary of all contacts for the selected campaign.

You can assign the following status levels to contacts:

- **Waiting**—The initial state of an outbound contact that is waiting to be presented to Contact Center Manager Server. A contact is in a waiting state for one of the following reasons:
  - The campaign has not yet started.
  - The campaign is paused.
  - The campaign is running, but waiting contacts are not yet queued into Contact Center Manager Server.

- **New**—The campaign is running and the contact is queued to Contact Center Manager Server.

- **Open**—An agent opened the contact.

- **Closed**—The contact is closed for one of the following reasons:
  - An agent completed the contact.
  - An administrator cancelled the campaign.
  - The campaign expired.
**Disposition Codes Chart page**

Use the Disposition Codes Chart page to view a summary of disposition codes for closed contacts for the campaign.
**Call Details page**

Use the Call Details page to view a call-by-call campaign summary of customer data (for example, name, phone number, and e-mail address) as defined during the campaign setup. If the agent changes the customer data during the call, the table displays the updated information.

For campaign calls that are rescheduled, the callback time appears in the Call Progress and Results table in Greenwich Mean Time (GMT). You must apply the regional offset for your location to calculate the actual rescheduled time. For example, to convert to Eastern Standard Time (EST), subtract five hours from GMT.

You can also review data collected during execution of the agent script, if a script is assigned to the campaign.
Campaign History page
Use the Campaign History page to view a history of campaign status changes.
To create and preview an agent script

Use the Agent Script window to create and review agent call scripts. An agent call script can contain an introduction, a conclusion, and questions you want agents to ask customers during outbound calls. When you associate a script with an outbound campaign, the agent views the script when accepting a contact.

An agent script is optional for each campaign. Only one agent script can be used in a single campaign.

To create an agent script

When you add questions to a script, you can indicate allowed results, specify a graphical user interface (GUI) component (for example, combo box or radio buttons) to associate with that question, provide default answers, and select an option so the agent can enter free-form answers or notes to record customer feedback during the call.

A script must meet the following requirements:
- It must have an introduction, a conclusion, or one question.
- The introduction text cannot exceed 1024 characters.
- The conclusion text cannot exceed 1024 characters.
- The maximum number of questions is 40.
- The text for each question cannot exceed 1024 characters.
- You must select GUI Component or Allowed Free Text for each question.
- If you select GUI Component, at least one allowed answer must exist.
- The maximum number of allowed answers is 32.
- If you include a default answer, the default answer must exist in the allowed answers.

When you provide allowed answers, you must separate the allowed answers with a comma, for example, Yes, No, Maybe.

**To preview a script**

Click Preview Script in the Script Creation window to preview the script during creation. The preview shows how the agent script appears to agents on the Agent Desktop when they accept a contact from this campaign.
Agent Script Preview window

For detailed information about creating and previewing agent scripts, see the step-by-step procedures in the Outbound Campaign Management Tool online Help.
To define disposition codes

Use the Disposition Codes window to create, update, and delete disposition codes used in any campaign. Agents use disposition codes to record the status of an outbound call. Examples of disposition codes might include Answer Machine, Number Busy, No Answer, or Sale Made. When you monitor campaign results, you can view the disposition code status for each campaign.

To create disposition codes

Click Disposition Codes on the toolbar of the Outbound Campaign Management Tool to display the Disposition Codes window.

When you create a disposition code, you assign a name and, optionally, a retry timeout and maximum number of retries. For example, if you create a disposition code that indicates the call was not completed, such as Customer Not Available, you can configure the amount of time before the contact is presented again to an agent and the maximum number of times to retry the call.
To save the agent script results for a campaign, you must create a disposition code and set the Save Agent Script option to Yes. For example, if you sell a product, you can create a disposition code, Sale Made and set the Save Agent Script option to Yes, to save the customer answers for future marketing. By default, for Number Busy, the Save Agent Script option is No because there are no script answers to save to the Contact Center Multimedia database.

Use the Voice Call Required option to configure whether agents must make a voice call before they can complete the contact. By default, the Voice Call Required option is set to yes. If a voice call is not required, agents can complete the contact without making the voice call. For example, if an agent cannot speak the same language as a customer, the agent can select a disposition code that does not require that agent to make a voice call and can reschedule the contact by configuring a retry timeout.

**ATTENTION**

You can delete user-defined disposition codes only; you cannot delete the predefined disposition codes provided with the Outbound Campaign Management Tool.

You can delete a disposition code only if no campaign uses that disposition code. To delete a disposition code that is used within a campaign, you must first archive or purge the campaign from the Multimedia database using the Contact Center Multimedia Administration Archive utility.

You can configure a maximum of 40 disposition codes.

For more information about disposition codes, see the step-by-step procedures in the Outbound Campaign Management Tool online Help.
To view log files

Use the OCMT Client Logging window to view the location of the log files for the Outbound Campaign Management Tool (OCMT) and the Outbound Campaign Services (OCS). The log files show error, warning, and information messages from the Contact Center Multimedia server.

To view the log files location

Click General Settings on the toolbar to display the OCMT Client Logging and OCS Service Information pages.

OCMT Client Logging page
The OCMT Client Logging page displays the log file configuration settings and the location of the current log file.
OCS Service Information page
The OCS Service Information page performs two functions:

- connects to the Contact Center Multimedia server to read the status of the Outbound Scheduler service and reports if the service is running

- connects to the Contact Center Multimedia server to read the Nortel Outbound Event Scheduler log

Viewing the Outbound Event Scheduler log

Click View to open the Outbound Event Scheduler log and view its contents.

Result: The OCS Server Event Viewer Messages window appears.
Ensuring you have the correct permissions

To view the OCMT client logging files or the OCS server event messages, you must ensure that you have the correct permissions on the Contact Center Multimedia server. If you do not, you receive an error when you attempt to view the log files. This is a Windows permission issue. Nortel recommends the following procedure to grant access:

1. On the Contact Center Multimedia server, create a new local security group (for example, OCMTusers).
2. Place any domain accounts that require access to the Outbound Campaign Management Tool into this security group.
3. Give the security group the rights to read the services by adding the security group to the Power Users security group of the Contact Center Multimedia server.

Creating a new local security group on the Contact Center Multimedia server

1. Log on to the Contact Center Multimedia server.
2. Click Start > All Programs > Administrative Tools > Component Services.
   Result: The Component Services window appears.
3. In the left pane, click the folder in which you want to add the new group.
4 On the Action menu, click New > Group.

   **Result:** The New Object - Group dialog box appears.

5 In the Group name box, type a name for your group (for example, OCMTusers).

6 Under Group scope, select Domain local.

7 Under Group type, select Security.

8 Click OK.

**Adding the group to the Power Users security group**

   1 Log on to the Contact Center Multimedia server.

   2 Click Start > All Programs > Administrative Tools > Computer Management.

      **Result:** The Computer Management window appears.

   3 In the left pane, click the plus sign (+) next to Local Users and Groups.

   4 Click Groups.

   5 In the right pane, double-click Power Users.

      **Result:** The Power Users Properties dialog box appears.

   6 Click Add.

   7 In the **Enter the object names to select** box, type the name of the new group, and then click Check Names.

      **Result:** The system verifies the group name exists.

   8 Click OK.

   9 On the Power Users Properties dialog box, click Apply.
To archive outbound campaigns

For information about archiving complete outbound campaigns, see the Contact Center Multimedia Installation and Maintenance Guide.
Chapter 12

Server performance

In this chapter

Tips for optimum server performance 286
Tips for optimum server performance

To help you maximize the performance of the application server, Nortel recommends that you follow the configuration and operation tips listed in this section when you administer your server and work in Contact Center Manager Administration.

These tips are broken down by Contact Center Manager Administration component. Based on the component, the tip is applicable to either the administrator or the supervisor. For example, supervisors use the Historical Reporting and Real-Time Reporting components most often. Therefore, administrators must inform the supervisors who use these components of the following tips for each component.

Access and Partition Management tips

The following tips relate to Access and Partition Management and are, therefore, applicable to administrators:

- When you configure partitions, ensure that they contain only the required data. For example, do not add all agents on a server if you only require 20 agents.
- Whenever possible, assign users supervisor/reporting agent combinations so they always see the most up-to-date list of agents. Partitions containing agents must be manually updated as changes occur.
- When you create partitions, create multiple partitions rather than including too much data in one partition. Also, when you create multiple partitions, avoid repeating data across the partitions. For example, when you include agents in users’ partitions, if there are many agents, try to include subsets of them in several partitions, rather than repeating the whole group of agents in many partitions.
- When you assign partitions, try to assign them to only those users who need to see this data.
- Remove Contact Center Manager Administration user profiles when they are no longer required.
Real-Time Reporting tips

The following tips relate to Real-Time Reporting and are, therefore, applicable to supervisors who use this component. Nortel recommends that administrators inform these supervisors of the following tips to ensure optimum performance:

- Remove real-time filters that are no longer required; keep only those filters that are used regularly.
- When you create real-time filters, limit the data to only that which you need to see in your real-time reports.
- Limit the number of agents shown in agent map displays. You can do this in two ways:
  - Administrators can limit the number of agents that a supervisor can see by assigning partitions that contain only these agents to the supervisors.
  - When supervisors create filters for their displays, they should choose only those agents they need to see in the agent map display.

Historical Reporting tips

The following tip relates to Historical Reporting and, therefore, is applicable to supervisors who use this component. Nortel recommends that administrators inform these supervisors of the following tip to ensure optimum performance:

- Reuse configured historical reports with saved selection criteria elements rather than reconfiguring and saving a new report each time. Supervisors can still update the saved report with a new name and remove selection criteria elements as required. When supervisors click a standard report, save it as private, and configure the selection criteria, it consumes more system resources to display all available selection criteria elements, rather than just the subset that is included with a saved report.
Chapter 13

License Manager Service for Report Creation Wizard

In this Chapter

Overview 290
Windows event logging 291
Audit Trail logging 295
Debug log files 296
Overview

The Contact Center Manager Administration License Manager Service is a licensing service for Report Creation Wizard. When a user launches Report Creation Wizard, a license is requested from the Contact Center Manager Administration License Manager Service for that user. After the license is granted to the user, the Report Creation Wizard window opens. The user's license is released when the user closes the Report Creation Wizard browser window. If the license cannot be obtained because the number of users exceeds the maximum allowed per session or due to other license service issues, the Report Creation Wizard session cannot be opened. The user is prompted with the appropriate message in the browser window. Events related to the Contact Center Manager Administration License Manager Service are recorded in Audit Trail, Windows application event log, Windows security event log, and the debug log file on the Contact Center Manager Administration server.

If the Contact Center Manager Administration License Manager Service is in the stopped state:

- When a user opens Report Creation Wizard, the License Manager Service starts automatically to obtain a Report Creation Wizard license.
- When a user closes Report Creation Wizard, the License Manager Service starts automatically to release the Report Creation Wizard license.
Windows event logging

The Contact Center Manager Administration License Manager Service logs error and informational events in the Windows security and Windows application event logs. The Contact Center Manager Administration server administrator can filter these events using the event source LMService.

The following messages are logged in the Windows security event log and the Windows application event log:

<table>
<thead>
<tr>
<th>Event ID</th>
<th>Event text</th>
<th>Event log location</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>18000</td>
<td>LM Service - LM I/F Init Failed: %1</td>
<td>Application</td>
<td>The Contact Center Manager Administration License Manager Service failed to initiate the License Manager interface to License Manager server.</td>
</tr>
<tr>
<td>18001</td>
<td>LM Service - LM I/F Init OK: %1</td>
<td>Application</td>
<td>The Contact Center Manager Administration License Manager Service successfully initiated the License Manager interface to License Manager server.</td>
</tr>
<tr>
<td>18002</td>
<td>LM Service - License Denied: %1</td>
<td>Security</td>
<td>License request is denied to open a new Report Creation Wizard session.</td>
</tr>
<tr>
<td>18003</td>
<td>LM Service - License Granted: %1</td>
<td>Security</td>
<td>License is granted to open a new Report Creation Wizard session.</td>
</tr>
<tr>
<td>Event ID</td>
<td>Event text</td>
<td>Event log location</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>---------------------------------------------------------------------------</td>
<td>--------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>18004</td>
<td>LM Service - License Release Failed: %1</td>
<td>Security</td>
<td>The Contact Center Manager Administration License Manager Service failed to release the license when the user closed the Report Creation Wizard session.</td>
</tr>
<tr>
<td>18005</td>
<td>LM Service - License Released: %1</td>
<td>Security</td>
<td>Contact Center Manager Administration License Manager Service released the license when the user closed the Report Creation Wizard session.</td>
</tr>
<tr>
<td>18006</td>
<td>LM Service - License Refresh Error: %1</td>
<td>Application</td>
<td>An error occurred refreshing the existing licensing (for opened Report Creation Wizard sessions).</td>
</tr>
<tr>
<td>18007</td>
<td>LM Service - Communication re-established with LM Server</td>
<td>Application</td>
<td>The communication between Contact Center Manager Administration License Manager Service and License Manager (on Contact Center Manager Server) is reestablished).</td>
</tr>
<tr>
<td>18008</td>
<td>LM Service - Communication Error with LM Server, Grace period will expire in %1 days</td>
<td>Application</td>
<td>A communication error occurred between Contact Center Manager Administration License Manager Service and License Manager (on Contact Center Manager Server).</td>
</tr>
<tr>
<td>Event ID</td>
<td>Event text</td>
<td>Event log location</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>----------------------------------------------------------</td>
<td>--------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>18009</td>
<td>LM Service - Fatal Communication error with LM Server, grace period expired after %1 days. LM Service will be shutdown now.</td>
<td>Application</td>
<td>There is a fatal communication error between Contact Center Manager Administration License Manager Service and License Manager (on Contact Center Manager Server). For example, communication could not be established for more than five days.</td>
</tr>
<tr>
<td>18010</td>
<td>LM Service - Unable to Persist the LM I/F Data. Error: %1</td>
<td>Application</td>
<td>Contact Center Manager Administration License Manager Service could not persist (backup) the license usage data.</td>
</tr>
<tr>
<td>18012</td>
<td>LM Service - Unable to Retrieve persistent data. Error: %1</td>
<td>Application</td>
<td>Contact Center Manager Administration License Manager Service could not retrieve the license usage data when Contact Center Manager Administration License Manager Service was started.</td>
</tr>
<tr>
<td>18014</td>
<td>LM Service - Retrieve Data - LoadXML Error: %1</td>
<td>Application</td>
<td>Contact Center Manager Administration License Manager Service could not retrieve the license usage data when Contact Center Manager Administration License Manager Service was started due to bad XML record from ADAM.</td>
</tr>
<tr>
<td>Event ID</td>
<td>Event text</td>
<td>Event log location</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>------------------------------------------------</td>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>18015</td>
<td>LM Service - LM Service - Audit Trail Logging Error</td>
<td>Application</td>
<td>Contact Center Manager Administration License Manager Service could not add events to Audit Trail.</td>
</tr>
<tr>
<td>18016</td>
<td>LM Service - LM Service - Cannot log event to security event log</td>
<td>Application</td>
<td>Contact Center Manager Administration License Manager Service could not add events to Security event log.</td>
</tr>
</tbody>
</table>
Audit Trail logging

The Contact Center Manager Administration License Manager Service logs the events statuses of license requests in the Audit Trail log.

The messages posted to Audit Trail are as follows:

<table>
<thead>
<tr>
<th>Message ID</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>10390</td>
<td>License Granted. User: %1, License Type: %2</td>
</tr>
<tr>
<td>10391</td>
<td>License Denied. User: %1, License Type: %2</td>
</tr>
<tr>
<td>10392</td>
<td>License Released. User: %1, License Type: %2</td>
</tr>
<tr>
<td>10393</td>
<td>License Release Failed. User: %1, License Type: %2</td>
</tr>
</tbody>
</table>
Debug log files

The Contact Center Manager Administration License Manager Service has optional debug logs to record events (success and errors). The log files are created on the Contact Center Manager Administration server. You can open debug log files in Notepad. The name and location of debug logs are:

- **LMService.log**—Contact Center Manager Administration License Manager Service log file in `<install drive>:\Program Files\Nortel Networks\WClient\Nortel_Log`
- **LM_Interface.log**—the default License Manager interface log file.
  - Location: C:\LM_Interface.log (For a stand-alone Contact Center Manager Administration server)
  - Location: C:\lm.log (For a co-resident Contact Center Manager Administration server)

You can turn logging on by modifying the LM Service Log Level using the LM Service - Configuration Setup program. The available options are:

- **No log** (default)—No message printed. Prints errors and warnings.
- **Errors only**—Prints errors only.
- **Debug**—Prints all events.

The event IDs are the same as listed in the security event log.
part 2

Contact Center Manager
Server Utility
Chapter 14

Getting started with the Server Utility

In this chapter

Overview 300
To log on to the server 301
Overview of the Server Utility window 305
Overview of PC Event Browser 306
Overview of the Provider application 307
Overview of Service Monitor (for networking) 309
Overview

Use Server Utility to monitor and maintain Contact Center Manager Server Release 6.0 and Symposium Call Center Server Release 5.0. Server Utility provides functions that are not available in Contact Center Manager Administration.

Server Utility is shipped with the Contact Center Manager DVD and is installed with the user interface provided on the DVD.

This chapter provides a description of Server Utility components and describes how to use Server Utility to log on to the server to monitor and maintain the server.

Server Utility components

Server Utility has the following components:

- **Server Utility window**—Use the Server Utility window to monitor and maintain the following components:
  - User Administration—Users (desktop) and Access Classes
  - System Configuration—Serial ports, switch resources, Voice Prompt Editor, server settings, and connected sessions
  - Server Backup—Backup scheduler
  - Alarms and Events—Alarm monitor, event browser, and event preferences
  - System Performance Monitoring—Service performance monitor

- **PC Event Browser**—Use the PC Event Browser to view events that occur on the client PC. Events that occur on the server cannot be viewed in the PC Event Browser.

- **Service Monitor (for networking)**—Use the Service Monitor to monitor the state of services across multiple Contact Center Manager Servers on the network similar to the CCMS Service Monitor.

- **Provider**—Use the Provider to receive Contact Center script information over the Host Data Exchange (HDX) interface. Additionally, you can configure this program to return information to the contact center script.
To log on to the server

To perform Contact Center Manager Server maintenance and monitoring tasks, you must log on to the server. If you have multiple servers (on separate telephony switches or on the same telephony switch), you can connect to all of them through Server Utility.

This section describes how to log on to Server Utility. You log on to Server Utility using the system administrator account for Contact Center Manager Server. You can launch the Server Utility multiple times to activate connections to different servers at the same time.

**ATTENTION**

Server Utility can be installed on a stand-alone Windows 2000 Professional or Windows XP Professional PC, or it can co-reside with the Contact Center Manager Server. (Server Utility co-residing with Contact Center Manager Server may have a minimal impact on server CPU, depending on how many versions of the Server Utility are running.)

Server Utility can co-reside with a Network Control Center (NCC) server.

To use a dial-up connection to the server

Client PCs that are not in the same local area network (LAN) as the server must use Dial-Up Networking to establish a network connection. For instructions, see the *Contact Center Manager Server Installation and Maintenance Guide*. 
Logging on to the server

1. On the computer on which Server Utility is installed, from the Windows Start menu, choose Programs > Nortel Contact Center > Server Utility > Server Utility.

   Result: The Nortel Contact Center Manager Server Utility Login window appears.

2. In the User ID box, type your user ID.

3. In the Password box, type your password.

4. In the Server Name or IP Address box, type the server name or IP Address of the server to which you want to connect.

   The Server Utility logon window allows up to 30 server names or IP addresses. You can select a server name or IP address from the list, or you can enter a new server name or IP address at logon time. You can connect to multiple Contact Center servers concurrently.

5. Click OK.

   Result: If a logon warning message is configured, a logon warning dialog box appears. Proceed to the next step. If a logon warning message is not configured, the logon window closes and the Server Utility window appears.

6. Click OK.

   Result: The logon warning dialog box closes and the Server Utility window appears.
Configuring a logon warning message

The logon message is the standard message used by Microsoft Windows. This is the same Microsoft Windows message that appears when you log on to Microsoft Windows.

Configure the message title and text in the local security policy of the Contact Center Manager Server, the domain security policy of the domain controller, or the domain controller security policy. The domain policy message is used if it exists; otherwise the local security policy message is used.

1. Select **Start > All Programs > Administrative Tools > Local (or Domain) Security Policy**.
   
   Result: The Local Security Settings window appears.

2. In the right pane, double-click the **Local (or Domain) Policies** folder.
   
   Result: The Local (or Domain) Policies folder expands.
3 Double-click the **Security Options** folder.

**Result:** The Security Options folder expands.

4 In the right pane, double-click **Interactive logon: Message text for users attempting to log on**.

**Result:** The Interactive logon: Message text for users attempting to log on window appears.

5 In the box, type the message text.

6 Click **OK**.

7 In the right pane, double-click **Interactive logon: Message title for users attempting to log on**.

**Result:** The Interactive logon: Message title for users attempting to log on window appears.

8 In the box, type the message title.

9 Click **OK**.

The message displayed combines the text that you configure in the **Message title for users attempting to log on** and **Message text for users attempting to log on**.
Overview of the Server Utility window

The Server Utility window displays a tree of server administration tasks to which you have access. This window appears after you log on to the server.

Server Utility window

The following figure shows the Server Utility window. The contents of the window depend on the system administration tasks available and your access permissions. Your Server Utility window may look different from the following example.
Overview of PC Event Browser

Use the PC Event Browser to view events that occur on the client PC. Events that occur on the server cannot be viewed in PC Event Browser.

Launching the PC Event Browser

On the Contact Center Manager Server, select Start > Programs > Nortel Contact Center > Server Utility > PC Event Browser.

Result: The PC Events window appears
Overview of the Provider application

The Provider application receives Contact Center script information over the Host Data Exchange (HDX) interface between the Contact Center Manager Server (provider.exe host) and the Contact Center Manager Administration server (scripts).

Additionally, you can configure Provider to return information to the Contact Center script. The receiving side receives both SEND INFO and SEND REQUEST information from the Contact Center script. The sending side can be configured to send a variety of information to the Contact Center script. The Contact Center script command GET RESPONSE receives the information sent by Provider.
Launching Provider

On the Contact Center Manager Server, select Start > All Programs > Nortel Contact Center > Server Utility > Provider.

Result: The Provider window appears.

For detailed information about Provider, see Contact Center Manager Scripting Guide for Communication Server 1000/Meridian 1 PBX or the Provider online Help.
Overview of Service Monitor (for networking)

You can use Service Monitor to monitor the state of services at the Network Control Center (NCC) and across multiple Contact Center Manager Servers on the NCC.

Services are divided into two categories:

- **Core Services**
  - Agent Skillset Manager (ASM)
  - Telephony Services Manager (TSM)
  - Meridian Link Services Manager
  - Task Flow Executor (TFE)
  - Voice Services Manager (VSM)

- **Database Services**
  - Operations, Administration and Maintenance Auditing (Audit)
  - Event Broker (EB)
  - Event Server (ES)—event server is not on every computer so this is not checked against the monitor lights
  - Historical Data Collector (HDC)
  - Historical Data Manager (HDM)
  - Intrinsic Server (IS)
  - Operations, Administration, and Maintenance (OAM)
  - NCC Operations, Administration, and Maintenance (NCCOAM)
  - Nodal Operations, Administration, and Maintenance (NDLOAM)
  - Real-Time Data Collector (RDC)
  - Real-Time Statistics Multicast (RSM)
  - Statistical Data Manager Configuration Administrator (SDMCA)
  - Server Data Propagator (SDP)
  - Task Flow Access (TFA)

On the NCC, the services that can be running and monitored are limited to: Audit, HDM, OAM, TSM, and NCCOAM.
Launching Service Monitor

On the Contact Center Manager Server, select Start > Programs > Nortel Contact Center > Server Utility > Service Monitor.

Result: The Service Monitor window appears.

For detailed information about Service Monitor, see the Service Monitor online Help.
Chapter 15

User Administration

In this chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>312</td>
</tr>
<tr>
<td>Section A: To work with access classes</td>
<td>315</td>
</tr>
<tr>
<td>Section B: To work with desktop user accounts</td>
<td>333</td>
</tr>
<tr>
<td>Section C: To manage user sessions</td>
<td>345</td>
</tr>
</tbody>
</table>
Overview

Today, much information that is vital to companies is transmitted over networks. These networks must be protected so that only authorized users can access, change, or delete information.

The system administrator establishes and maintains system security. The administrator sets up security by assigning logon passwords and access classes to users. By assigning the appropriate access classes to the appropriate users, the administrator can help ensure system security.

For example, you may want to restrict access to certain Server Utility components to senior administrators.

To set up security

To set up security, perform these tasks:

1. Define access classes.
2. For each access class, select the Contact Center Manager Server functions that members of that class can use in Server Utility. For a complete list of functions and privileges, see “Functions and privileges” on page 324.
3. Create desktop user accounts for users who require access to Contact Center Manager Server functions.
4. Assign access classes to user accounts, giving users the privileges they need to perform their jobs.

Password retry lockout

Users are locked out of the system if they attempt to log on more than three consecutive times using an invalid password. (This is based on Windows settings configured during the installation.) To restore a user’s access to the system, an administrator must reset the password retry count to zero. For more information, see “Restoring a user’s access to the server” on page 339.
If the locked-out user is an administrator, another administrator must restore access. (If you are logged on as sysadmin, you are not locked out.)

If only one administrator exists, only Nortel customer support staff can reset the account. Therefore, be sure you create at least two users with administrator privileges.

**Password expiry**

The desktop user password expires after 180 days. Seven days before the expiry of the password, the Server Utility software displays a warning message during the user logon. If the desktop user password expires, the administrator must reset the password. For more information, see “To reset desktop passwords” on page 341.

The sysadmin password does not expire.
Section A: To work with access classes

In this section

Overview of access classes 316
To add access classes 317
To view the members of an access class 321
Other procedures for access classes 323
Functions and privileges 324
Overview of access classes

An access class is a set of privileges for the various functions available for Contact Center Manager Server through Server Utility.

Default access classes

The installation process creates three default access classes:

- **adminGroup**—Users belonging to this class have administrator access to the system and can access all functions.
- **Call Center Admin**—Users belonging to this class can access User Administration and System Configuration.
- **Supervisor**—Users belonging to this class can view users in User Administration reporting to them.
To add access classes

This section describes how to add access classes from the Server Utility window. You can also add access classes using Contact Center Manager Administration. For details, see the online Help that comes with the application.

Adding an access class

1. From the **Server Utility** window, double-click **User Administration** and then double-click **Access Classes**.

   **Result:** The Access Classes window appears.
2 Choose **File > New**.

**Result:** The New Access Class dialog box appears.

![New Access Class dialog box](image)

3 In the **Name** box, type a name for the access class. Use a descriptive name to describe the type of user having this access level or the type of privileges available at this access level.

4 In the **Comments** box, type additional optional information about the access class.
5 Click the **Access** tab.

**Result:** The Access page appears, showing the available Contact Center Manager functions and the level of access that members of this access class have for each function.

![New Access Class](image)

**ATTENTION**

For third-party access to the Sybase database or real-time data in Contact Center Manager Administration, you can use the Server Utility to create desktop user accounts with permission granted to select all data from the Historical Reporting views or real-time data. You cannot configure desktop users as supervisors.

Most items in this list correspond to functions in the Server Utility window.

After you assign users to an access class, a third tab appears, named Members. This tab shows you all the users who belong to the access class.

6 Select a function that you want to make available to this access class. For a list of functions and available access levels, see “Functions and privileges” on page 324.

**Result:** The selected function appears in the Selected item box.
7 From the **Level of Access** list, select the desired level of access for that function.

8 Repeat steps 6 and 7 for each function that you want this access class to have access to.

9 Click **Save**.

**Result:** You return to the Access Classes window.

10 To return to the Server Utility window, choose **File > Close**.
To view the members of an access class

This section describes how to view the members of an access class from the Server Utility window. If you use Contact Center Manager Administration, you can view the members of an access class by using the Access and Partition Management component. For details, see the online Help that comes with the application.

Viewing the members of an access class

1. From the Server Utility window, expand **User Administration**.
2. Double-click **Access Classes**.

   **Result:** The Access Classes window appears.

3. Select the access class for which you want to display the members.
4. Choose **File > Properties**.

   **Result:** The Access Class Properties page appears.
5 Click the **Members** tab. 

**Result:** The Members page appears.

6 Click **Cancel**. 

**Result:** You return to the Access Classes window. 

7 To return to the Server Utility window, choose **File > Close**.
Other procedures for access classes

This section describes other procedures for access classes available through the Server Utility. For details about working with access classes in Contact Center Manager Administration, see the online Help that comes with the application.

Changing the properties of an access class

From the Access Classes window, select the access class you want to change, and then choose **File > Properties.**

For step-by-step instructions, press F1 to access the online Help.

Previewing the list of access classes

From the Access Classes window, choose **File > Print Preview.**

For step-by-step instructions, press F1 to access the online Help.

Printing the list of access classes

From the Access Classes window, choose **File > Print.**

For step-by-step instructions, press F1 to access the online Help.

Deleting an access class

You cannot delete the default access classes (AdminGroup, Call Center Admin, or Supervisor) or any access class that has members.

From the Access Classes window, select the access classes you want to delete, and then choose **File > Delete.**
Functions and privileges

This section describes Contact Center Manager Server functions and privileges. For details about the functions and privileges available in Contact Center Manager Administration, see the online Help that comes with the application.

Server Utility functions and privileges

The following table describes the privileges assigned to functions in Server Utility.

<table>
<thead>
<tr>
<th>Function</th>
<th>Privilege</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access Classes</td>
<td>View</td>
<td>Users can display the Access Classes window and view the properties for any access class.</td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td>Users can display the Access Classes window and view and change properties for any access class.</td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td>Users can display the Access Classes window and view, change, add, and delete access classes.</td>
</tr>
<tr>
<td>Alarm Monitor</td>
<td>View</td>
<td>Users can display the Alarm Monitor and view event details for system alarms.</td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td>Users can display the Alarm Monitor, view event details for system alarms, and clear and acknowledge alarms.</td>
</tr>
<tr>
<td>Backup Devices</td>
<td>View</td>
<td>Users can display the Backup Devices window and view the list of available backup devices.</td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td>Users can display the Backup Devices window and view and change the properties of backup devices.</td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td>Users can display the Backup Devices window and view, change, and delete backup devices.</td>
</tr>
<tr>
<td>Function</td>
<td>Privilege</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Backup Scheduler</td>
<td>View</td>
<td>Users can display the Backup Scheduler window and view the scheduled date and time of backups.</td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td>Users can display the Backup Scheduler window and view and change the scheduled date and time of backups.</td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td>Users can display the Backup Scheduler window and view, change, and delete scheduled backups.</td>
</tr>
<tr>
<td>Connected Sessions</td>
<td>View</td>
<td>Users can display the Connected Sessions window.</td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td>Users can display the Connected Sessions window and log off connected users.</td>
</tr>
<tr>
<td>Event Browser</td>
<td>View</td>
<td>Users can display the Event Browser and view all Informational, Critical, Minor, or Major events.</td>
</tr>
<tr>
<td>Event Preferences</td>
<td>View</td>
<td>Users can view event preferences configured for event codes.</td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td>Users can view event preferences and increase or decrease their severity.</td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td>Users can create event preferences, increase or decrease their severity, and delete event preferences.</td>
</tr>
<tr>
<td>Serial Ports</td>
<td>View</td>
<td>Users can display the Serial Ports window and view properties for all serial ports.</td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td>Users can display the Serial Ports window and view and change properties for all serial ports.</td>
</tr>
<tr>
<td>Server Performance Monitor</td>
<td>View</td>
<td>Users can display the Server Performance Monitor. This monitor displays information about processing capacity, memory, and storage space.</td>
</tr>
<tr>
<td>Server Settings</td>
<td>View</td>
<td>Users can display detailed information about the server, such as the software release it is running and its serial number.</td>
</tr>
<tr>
<td>Function</td>
<td>Privilege</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>----------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Switch Resource</strong></td>
<td>View</td>
<td>Users can view the Switch Resource properties. These properties display information about the telephony switch type.</td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td>Users can view and change the Switch Resource properties.</td>
</tr>
<tr>
<td><strong>Users</strong></td>
<td>View reporting agents only</td>
<td>Users can display the Users window and view properties for reporting agents.</td>
</tr>
<tr>
<td></td>
<td>View and edit reporting agents only</td>
<td>Users can display the Users window and view and change properties for reporting agents.</td>
</tr>
<tr>
<td></td>
<td>Edit all agents–create agents only</td>
<td>Users can display the Users window and view, change, create, and delete any agents.</td>
</tr>
<tr>
<td></td>
<td>View all users</td>
<td>Users can display the Users window and view properties for all desktop users, supervisors, and agents. Users require this access privilege to generate call-by-call reports.</td>
</tr>
<tr>
<td></td>
<td>Edit all users</td>
<td>Users can display the Users window and view and change properties for all desktop users, supervisors, and agents.</td>
</tr>
<tr>
<td></td>
<td>Edit all users–create any type</td>
<td>Users can view the Users window and view, change, add, and delete desktop users, supervisors, and agents.</td>
</tr>
<tr>
<td><strong>Voice Ports</strong></td>
<td>View</td>
<td>Users can display the Voice Ports window and view properties for all voice ports.</td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td>Users can display the Voice Ports window and view and change properties for all voice ports.</td>
</tr>
</tbody>
</table>
## Access privileges to database views

The following table lists the access privileges assigned to database views. For a detailed description, see the *Contact Center Historical Reporting and Data Dictionary*.

<table>
<thead>
<tr>
<th>Function</th>
<th>Privilege</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Voice Prompt Editor</strong></td>
<td>View</td>
<td>Users can log on to the Voice Prompt Editor and view voice files and voice segments.</td>
</tr>
<tr>
<td>(Contact Center Voice Services on Meridian Mail)</td>
<td>Edit</td>
<td>Users can log on to the Voice Prompt Editor and view and change voice segments and voice files.</td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td>Users can log on to the Voice Prompt Editor and view, change, add, and delete voice files and voice segments. In CallPilot, use Application Builder to work with voice prompts.</td>
</tr>
</tbody>
</table>

### Access privileges to database views

The following table lists the access privileges assigned to database views. For a detailed description, see the *Contact Center Historical Reporting and Data Dictionary*.

<table>
<thead>
<tr>
<th>Function</th>
<th>Privilege</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Activity Codes</strong></td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td><strong>Agent Threshold Classes</strong></td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td><strong>Agent to Skillset Assignments</strong></td>
<td>View own agents only</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View and assign own agents only</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View all agents</td>
<td></td>
</tr>
<tr>
<td><strong>Agent to Supervisor Assignments</strong></td>
<td>View all agents</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View and assign all agents</td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Privilege</td>
<td></td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>--------------------</td>
<td></td>
</tr>
<tr>
<td>Application Threshold Classes</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Applications</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Call Presentation Classes</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>CDNs</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>DNISs</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Emergency Help</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td>Formulas</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Historical Statistics</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>IVR ACD-DN Threshold Classes (CS 1000/Meridian 1)</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Privilege</td>
<td></td>
</tr>
<tr>
<td>----------------------------------</td>
<td>----------------------------------</td>
<td></td>
</tr>
<tr>
<td>IVR ACD-DNs (CS 1000/Meridian 1)</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Network Communication Parameters</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>Network Historical Statistics (NCC)</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>Network Skillsets (NCC)</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Nodal Threshold Class</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>Phoneset Displays (CS 1000/Meridian 1)</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>Phonesets</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Real-Time Displays</td>
<td>View own agents</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View own agents–create displays</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View all agents</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View all agents–create displays</td>
<td></td>
</tr>
<tr>
<td>Real-time Statistics</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>Reports</td>
<td>Create and run any report</td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Privilege</td>
<td></td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>--------------------------------</td>
<td></td>
</tr>
<tr>
<td>Reports–Agent Performance</td>
<td>Create and run any report</td>
<td></td>
</tr>
<tr>
<td>Reports–Call by Call</td>
<td>Create and run any report</td>
<td></td>
</tr>
<tr>
<td>Reports–Other</td>
<td>Create and run any report</td>
<td></td>
</tr>
<tr>
<td>Route Threshold Classes</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td>(CS 1000/Meridian 1)</td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Routes</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td>(CS 1000/Meridian 1)</td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Scheduler</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Script Variables</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Scripts</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Sites (NCC)</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Skillset Threshold Classes</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Privilege</td>
<td></td>
</tr>
<tr>
<td>----------------------------------</td>
<td>------------------------------------------------</td>
<td></td>
</tr>
<tr>
<td>Skillsets</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Switch Resource</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>Table Routing Assignments (NCC)</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Create/Delete</td>
<td></td>
</tr>
<tr>
<td>Users</td>
<td>View reporting agents only</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View and edit reporting agents only</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit all agents–create agents only</td>
<td></td>
</tr>
<tr>
<td></td>
<td>View all users</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit all users</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit all users–create any type</td>
<td></td>
</tr>
<tr>
<td>Voice Ports</td>
<td>View</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Edit</td>
<td></td>
</tr>
</tbody>
</table>
Section B: To work with desktop user accounts

In this section

Overview of desktop user accounts 334
To add desktop user accounts 335
To control access to the server 338
To reset desktop passwords 341
Other procedures for desktop users 343
Overview of desktop user accounts

A desktop user account uses the Server Utility application to access Contact Center Manager Server 6.0 (or Symposium Call Center Server 5.0). You must create a desktop user account for each user who requires access to the server. You must also assign each account to the access class that gives users the privileges they need to perform their job.

You can use the Server Utility to create desktop user accounts. These accounts can be used to log on to the Server Utility, to access the server database, or to log on to a wallboard.

When creating desktop user accounts for third-party access to the Sybase database in previous versions of the Symposium Call Center Server Classic Client, the administrator could create a user account for a supervisor to run reports with only those agents belonging to that supervisor. This account was a desktop user account in Server Utility and a supervisor in Symposium Call Center Server. This function is no longer available in Contact Center Manager.

For third-party access to the Sybase database or real-time data in Contact Center Manager, the administrator can use the Server Utility to create desktop user accounts with permission granted to select all data from the Historical Reporting views or real-time data. The administrator cannot configure desktop users as supervisors.

A system administrator (sysadmin) desktop user exists on all Contact Center Manager Servers and can be viewed in the Server Utility through Desktop Users.
To add desktop user accounts

When you create a desktop user account, the account is assigned the default password *password*. When users log on to the server, they are prompted to change the password.

The desktop user password expires after 180 days. Seven days before the password expires, Server Utility displays a warning message during the user logon. To change your password, log on to the server and choose Utilities > Change Password.

Adding desktop user accounts

1. On the Server Utility window, double-click **User Administration** and then double-click **Users**.

   **Result:** The Users window appears.
2  Select **File > New**.

**Result:** The New User dialog box appears.

3  On the General page, enter the user’s contact information.

4  Click the **Desktop** tab.

**Result:** The Desktop page appears.

5  In the **User ID** box, type a user ID. The desktop user uses this to log on to the server. You cannot change the user ID after you save the user account.
6 Click Set Password.

**Result:** The Set Password window appears.

If you open an existing desktop user, this button appears as Reset Password.

7 In the New Password and Confirm Password boxes, type the password.

8 Click OK.

**Result:** The Set Password window closes.

9 Select the Password Expires check box to indicate that the user’s password expires in 180 days.

   For special users, such as wallboard displays used with third-party software, you can choose not to allow the password to expire. The administrator’s password does not expire.

10 From the Access Class list, select the access class to which you want to assign the user.

   The access class must already exist (for more information about adding access classes, see “To add access classes” on page 317).

11 Click Save to save your settings and return to the Users window.

   If you click Save before you enter the necessary information, the system prompts you to complete the required boxes.

12 To return to the Server Utility window, choose File > Close.

The Password retry count box displays the number of times the user attempted to log on and failed.

The User desktop status box shows whether the user currently has access to the system. A user’s status can be OK or Locked out by an administrator. Users are locked out under the following conditions:

- when the system administrator locks them out manually (see “To control access to the server” on page 338)
- when the user tries and fails to log on the maximum number of times

If the Contact Center Manager Server is connected to a CS 2x00/DMS, you may need to confirm that the user ID (logon ID) is configured at the telephony switch before the user can log on to the system.
To control access to the server

This section provides instructions to restrict and restore access to the server for individual desktop users.

Preventing users from accessing the server

**ATTENTION** If the desktop user you want to lock out is currently logged on, log the desktop user off (see “To log users off” on page 347).

1. On the Server Utility window, double-click **User Administration** and then double-click **Users**.
   
   **Result:** The Users window appears.

2. Double-click the user's name.
   
   **Result:** The User Properties window appears.

3. Click the **Desktop** tab.
   
   **Result:** The Desktop page appears.
4 Click **Lock Out**.

**Result:** The user desktop status changes to Locked out by an administrator. This continues to be the current status of the user until an administrator restores it to OK. The Lock Out button changes to Restore.

5 Click **Save**.

**Result:** You return to the Users window.

6 To return to the Server Utility window, choose **File > Close**.

**Restoring a user’s access to the server**

Use this procedure when a user is locked out of the system after exceeding the password retry count or after an administrator manually locks out a user.

1 On the Server Utility window, double-click **User Administration** and then double-click **Users**.

**Result:** The Users window appears.

2 Double-click the user’s name.

**Result:** The User Properties window appears.

3 Click the **Desktop** tab.

**Result:** The Desktop page appears.
4 Click **Restore**.

**Result:** The user desktop status changes to OK. The Restore button changes to Lock Out.

5 Click **Save**.

**Result:** You return to the Users window.

6 To return to the Server Utility window, choose **File > Close**.
To reset desktop passwords

Follow this procedure when users forget their desktop password or if the desktop password expires.

By resetting the password, you can set a new password for the desktop user.

The desktop user password expires after 180 days unless users change the password within that time. Seven days before the expiry of the password, the Server Utility displays a warning message during the user logon.

If users want to change their password, they can do so by logging on to the server and choosing Utilities > Change Password.

To reset the sysadmin desktop password, you must log on as sysadmin.

Resetting the desktop password

1. On the Server Utility window, double-click **User Administration** and then double-click **Users**.
   
   **Result:** The Users window appears.

2. Double-click the user’s name.
   
   **Result:** The User Properties window appears.
3 Click the **Desktop** tab.

**Result:** The Desktop page appears.

![Desktop page](image1)

4 Click **Reset Password**.

**Result:** The Reset Password window appears.

![Reset Password window](image2)

5 In the **New Password** and **Confirm New Password** boxes, type the new password and click **OK** to close the Reset Password window.

6 Click **Save**.

**Result:** You return to the Users window.

7 To return to the Server Utility window, choose **File > Close**.
Other procedures for desktop users

This section describes how to perform other procedures for desktop users. Detailed step-by-step instructions are available in the online Help.

Changing the properties of a desktop user

ATTENTION

Ensure that the user is not logged on when you change the user’s access class. If the user is logged on, the server logs the user off when you make the change.

From the Users window, select the desktop user you want to change, and then choose File > Properties.

For step-by-step instructions, press F1 to access the online Help.

Printing the list of users (including desktop users)

From the Users window, choose File > Print.

For step-by-step instructions, press F1 to access the online Help.

Deleting a desktop user

If you delete a user who is currently logged on, the user is automatically logged off.

From the Users window, select the desktop user you want to delete, and then choose File > Delete.

For step-by-step instructions, press F1 to access the online Help.
Section C: To manage user sessions

In this section

To view connected users 346
To log users off 347
To view connected users

Follow the procedure in this section to check the status of a desktop user’s connection to the server.

Viewing a list of connected users

1. From the Server Utility window, click **System Administration > System Configuration**
2. Double-click **Connected Sessions**.

   **Result:** The Connected Sessions window appears. This list shows the desktop users who are logged on to the server, their user IDs, their location (network address), and the time of their last activity on the system.

3. To return to the Server Utility window, choose **File > Close**.

Printing a list of connected users

From the Connected Users window, choose **File > Print**.

For step-by-step instructions about printing, press F1 to access the online Help.
To log users off

Follow the procedure in this section to disconnect a user from the server.

This procedure disconnects and logs users off immediately. The disconnected user is not warned.

Logging a user off

1. From the Server Utility window, choose **System Administration > System Configuration > Connected Sessions**.

   **Result:** The Connected Sessions window appears.

2. Select the PC User ID of the user you want to disconnect.

3. Choose **File > Disconnect Session**.

   **Result:** A message box appears asking you to confirm that you want to disconnect the user, because this action logs the user off immediately.

4. Click **Yes**.

   **Result:** You return to the Connected Sessions window. The user is no longer on the list.

5. To return to the Server Utility window, choose **File > Close**.
Chapter 16

System configuration

In this chapter
Overview 350
System configuration settings 351
System performance monitoring 353
Overview

You can use the Server Utility to view and edit the following system configuration information:

- serial ports
- switch resources
- server settings
- system performance

This chapter describes how to use the Server Utility to monitor system configuration settings and performance.
System configuration settings

This section provides an overview of system configuration settings you can record, view, or edit using the Server Utility. For detailed step-by-step instructions, see the Server Utility online Help.

Serial ports

Serial ports are input/output devices used to connect external equipment, such as CD-ROMs or modems, to your computer. Serial ports transmit data from these external devices one bit at a time.

You can use the Serial Ports window to view, print, or edit serial port settings. From this window, you can modify a serial port baud rate, data bits, stop bits, parity, and flow control. You can also use the Serial Port Properties page to edit serial port settings.

The Serial Ports option is available only when you connect to a Communication Server 1000/Meridian 1 PBX server. It is not available when you connect to a Communication Server 2x00/DMS server or when you connect to a Media Application Server.

For step-by-step instructions, press F1 to access the online Help.

Switch resources

Use the Switch Configuration tab to record information about a CS 1000/Meridian 1 or a CS 2x00/DMS after initial software installation. You can record the type, subtype, release number, and the host port assigned to the CS 1000/Meridian 1 or to the CS 2x00/DMS.

The Switch Resources option is not available when you connect to a Media Application Server.

For step-by-step instructions, press F1 to access the online Help.
System configuration

Server settings

You can use the Server Settings window to view detailed information about the server resources, such as the software release number and the serial number. This information is saved to the server database at the time of installation and can be retrieved for technical support purposes. You can print the contents of the Server Settings window for future reference. You can also view a list of the services and features installed on your system.

For step-by-step instructions, press F1 to access the online Help.

Connected sessions

You can use the Connected Sessions window to view the users logged on to the server and to disconnect sessions. You can print information about connected sessions for future reference.

For step-by-step instructions, press F1 to access the online Help.
System performance monitoring

Use the Server Performance Monitor window to view the server operating conditions. You can use the information in this window to determine whether your system has sufficient processor capacity, memory, or storage space. You can also use this information to improve the efficiency of your system. For example, to improve daytime performance, you can reschedule events to run at night, when the server is not as busy. You can print server performance data for future reference.

For step-by-step instructions, press F1 to access the online Help.
Chapter 17

Voice Prompt Editor in Meridian Mail

In this chapter

Overview 356
To log on and off the Voice Prompt Editor 358
Section A: To work with voice files 361
Section B: To work with voice segments 369
Overview

If you use Contact Center Voice Services on Meridian Mail, you can set up and manage voice prompts (messages) with the Voice Prompt Editor.

If you use Contact Center Voice Services on CallPilot, use Application Builder to set up and manage your voice prompts. For more information, see the *CallPilot Application Builder Guide*.

If you use Contact Center Voice and Video Services on Nortel Media Application Server, see the *Nortel Media Application Server Installation and Configuration Guide for Contact Center 6.0*.

The Voice Prompt Editor is not available if:

- you use CallPilot for voice services
- you use Nortel Media Application Server for voice and video services
- Server Utility is connected to a CS 2x00/DMS switch

Voice segments

Each voice prompt consists of segments. To minimize the storage required for your voice prompts, you can create modular segments. You can use these segments in different combinations to produce your voice prompts.

Example

You can have a voice prompt similar to the following prompt:

“Welcome to the BestAir Booking line.
To verify the departure time of one of today’s flights, press 1.
To book a flight, press 2.
To obtain schedule information, press 3.
For any other information, please remain on the line.”

When users press 1, they hear the following message:

“Flight BA971 to Munich is delayed 1 hour, and is now scheduled for departure at 2:19 p.m. All other flights are on time.”
These prompts consist of a number of segments. One voice segment contains the word press, which is used several times in the first prompt. Other voice segments contain the numbers, 1, 2, 3, 7, 9, and 19, and the phrases p.m. and flights.

**Voice files**

Voice segments are stored in voice files. You can use voice files to organize your voice segments.

**ATTENTION**

When you use Meridian Mail with ACCESS, Nortel recommends that you create no more than two voice files. When Voice Services Manager logs on the voice ports, a maximum of two files are opened. For Voice Services Manager to access prompts in another file, it must close one of the open files and open the next file, which can cause performance issues. This is a Meridian Mail ACCESS restriction and does not apply to CallPilot.

**Play groups**

Within each voice file, you can organize voice segments into play groups. A play group is a set of voice segments. You can use play groups to play back multiple segments during testing.
To log on and off the Voice Prompt Editor

To create and manage voice files and voice prompts for Contact Center Voice Services on Meridian Mail, you must log on to the Voice Prompt Editor. When you finish using the Voice Prompt Editor, you can log off and exit.

The Voice Prompt Editor is available only if you use:

- Contact Center Voice Services on Meridian Mail
- Contact Center Voice Services on CallPilot
- Application Builder to manage your voice prompts

The Voice Prompt Editor is not available if you are connected to a CS 2x00/DMS telephony switch.

Logging on to the Voice Prompt Editor

1. From the Server Utility window, double-click **System Administration**.
2. Double-click **Voice Prompt Editor**.
   
   **Result:** The Voice Prompt Editor Login dialog box appears.

3. In the **Account** box, type the Meridian Mail mailbox containing the voice prompts that you want to work with.
4. In the **Password** box, type the password for that mailbox.
5. In the **Telephone No.** box, type the telephone number of the phoneset that you want to use to record or play back voice segments.
Click **Login**.

**Result:** The Voice Prompt Editor Login dialog box closes, and the Voice Prompt Editor window appears.

### Logging off the Voice Prompt Editor

1. To log off the Voice Prompt Editor, choose **File > Login**.
   
   **Result:** The program prompts for confirmation.

2. Click **OK**.

   **Result:** You are logged off from the current session, any open voice files are closed, and the Voice Prompt Editor Login window appears.

3. To exit completely, choose **File > Exit**.
Section A: To work with voice files

In this section

To create a voice file 362
To open a voice file 364
Other procedures for voice files 366
To create a voice file

This section describes how to create a voice file. You can use voice files to organize your voice segments.

**ATTENTION**

When you use Meridian Mail with ACCESS, Nortel recommends that you create no more than two voice files. When Voice Services Manager logs on the voice ports, a maximum of two files are opened. For Voice Services Manager to access prompts in another file, it must close one of the open files and open the next file, which can cause performance issues. This is a Meridian Mail ACCESS restriction and does not apply to CallPilot.

Creating a voice file

1. From the Voice Prompt Editor window, choose **File > New**.

**Result:** The New Voice File dialog box appears.

2. Enter information into the following boxes:

**File Name:** The name of the new voice file.

Voice file names are case-sensitive. When you reference voice files in scripts and variables, make sure the file name matches the name you create here.

**Subject:** Optional. A description of the new voice file.
3 Click **OK**.

**Result:** You return to the Voice Prompt Editor window.

Before you work with the voice file, you must open it. See “To open a voice file” on page 364.
To open a voice file

This section describes how to open a voice file. When you open a voice file, the system displays a list of voice segments stored in the selected voice file.

Opening a voice file

1. From the Voice Prompt Editor window, choose **File > Open**.

   **Result:** The Open Voice File dialog box appears.

2. Select the file you want to open.
3 Click OK.

**Result:** You return to the Voice Prompt Editor window. The window contains the list of segments in the selected voice file.
Other procedures for voice files

This section describes how to perform other procedures for voice files. Detailed step-by-step instructions are available in the online Help.

Saving a voice file

From the Voice Prompt Editor window, choose File > Save.

Reverting to a previously saved voice file

If you make changes to a voice file, and then you decide that you do not want to keep the changes you made, you can restore the last-saved copy of the voice file.

From the Voice Prompt Editor window, choose File > Revert.

For step-by-step instructions, press F1 to access the online Help.

Copying a voice file

The voice file you copy must be closed.

From the Voice Prompt Editor window, choose File > Copy.

For step-by-step instructions, press F1 to access the online Help.

Renaming a voice file

The voice file you rename must be closed.

From the Voice Prompt Editor window, choose File > Rename.

For step-by-step instructions, press F1 to access the online Help.

Deleting a voice file

The voice file you delete must be closed.
The voice file is not deleted until you log off the Voice Prompt Editor. Until then, you can restore any voice file that you mark for deletion.

From the Voice Prompt Editor window, choose **File > Delete**.

For step-by-step instructions, press **F1** to access the online Help.

**Restoring a voice file**

If you delete a voice file, you can restore it, provided that you did not log off the Voice Prompt Editor since deleting the file.

From the Voice Prompt Editor window, choose **File > Undelete**.

For step-by-step instructions, press **F1** to access the online Help.
Section B: To work with voice segments

In this section

To create a voice segment 370
To record a voice segment 371
To play a voice segment 372
To create and play a group of voice segments 373
To search for a voice segment 375
To edit a voice segment length 377
To edit the length of all voice segments in a voice file 380
Other procedures for voice segments 382
To create a voice segment

This section describes how to create a voice segment. Before you begin, open the voice file to which you are adding a new voice segment (for more information, see “To open a voice file” on page 364).

Creating a voice segment

1. In the Voice Prompt Editor window, in the Voice Segment box, click **New**.
   
   **Result:** The New Voice Segment dialog box appears.

   ![New Voice Segment dialog box](image)

   If you choose **File > New**, you create a new voice file.

2. In the **Name** box, type the name of the new voice segment.

3. In the **Title** box, type a description for the new voice segment.

4. In the **Script** box, type the text that the new segment is to contain. (This is for reference only.)

5. Click **OK**.
   
   **Result:** The New Voice Segment dialog box closes and the new segment is created.

6. Continue with the following procedure to record the voice segment.
To record a voice segment

This section describes how to record a voice segment. As described in the following procedure, you must save all new voice segments to the server before you close the Voice Prompt Editor.

Recording a voice segment

1. In the Voice Prompt Editor window, select the voice segment you want to record.
2. Click Record (●).
   Result: The phoneset that you specified during logon rings.
3. Answer the phone.
4. After the tone, say the words that you want to record in the voice segment.
5. Click Stop (■).
6. To record another segment, follow these steps:
   a. Select the segment.
   b. Click Record (●).
   c. After the tone, say the words that you want to record in the voice segment.
   d. Click Stop (■).
7. Repeat step 6 until you finish recording segments.
8. Select File > Save to save the new voice segments.
   You must save all new voice segments to the server before you close the Voice Prompt Editor.
9. To play your voice segments, continue with step 2 on page 372.
10. Hang up.

You may find that you recorded too much silence at either the beginning or the end of the segment. To edit the silence, see “To edit a voice segment length” on page 377.
To play a voice segment

This section describes how to play back a voice segment. If you recorded too much silence at either the beginning or the end of the segment, you can edit the silence. For details, see “To edit a voice segment length” on page 377.

Playing a voice segment

If you just recorded a voice segment, start at step 2.

1. In the Voice Prompt Editor window, select the voice segment that you want to play.
2. Click Play (▶).

   **Result:** If the phoneset that you specified during logon is on-hook, it rings. Continue with the next step. If the phoneset is off-hook, the segment starts to play. Continue with step 4.

3. Answer the phone.

   **Result:** The segment starts to play.

4. To move backward or forward by increments of 5 seconds, click Skip Backward (◀) or Skip Forward (▶).

5. To play the next voice segment in the Voice Segment list, click Play Next (▶).

6. To stop, click Stop (■).

7. Hang up.
To create and play a group of voice segments

You may want to play a group of voice segments after you record them to see how they fit together, and to find out if the silence of any segment needs to be adjusted. This section describes how to play a group of voice segments.

Playing a group of voice segments

1  In the Voice Prompt Editor window, click **Group**.

   **Result:** The Edit Play Group dialog box appears.

2  In the **Voice Segments** list, click a voice segment that you want to add to the play group.

3  Click **Add**.

   **Result:** The voice segment is added to the Play Group list.

4  Repeat steps 2 and 3 until the voice segments that you need appear in the play group.

   To remove a voice segment from the group, click the voice segment in the Play Group list, and then click **Remove**.

5  Click **Play**.

   If you need to move a voice segment up or down, click the voice segment in the Play Group list, and then click **Up** or **Down**.
6  When you finish playing the group, click Stop.
7  Click Close to return to the Voice Prompt Editor window.
To search for a voice segment

You can search for a voice segment by its segment ID or by one or more of the following elements:

- the name of the voice segment
- the title of the voice segment
- the words used in the voice segment (as specified in the Script box)
- the duration of the voice segment

Searching for a voice segment

1. On the Voice Prompt Editor window, click **Search**.
   
   **Result:** The Search for Segment dialog box appears.

2. To search on the segment ID, follow these steps:
   
   a. Click **Segment ID**.
   
   b. In the **Segment ID** box, type the ID number of the voice segment.

3. To search on name, title, script, or duration, follow these steps:
   
   a. Click **Text Fields**.
   
   b. In the **Name**, **Title**, **Script**, or **Duration** boxes, type the text you want to find.
4  Click **Find Next**.

5  Click **Find Next** again to find the next segment that satisfies the search conditions.

6  When you finish, click **Cancel** to close the Search for Segment dialog box.
To edit a voice segment length

After you record a voice segment, you may find that you have too much or too little silence in the segment, or that you want to shorten the recording. This section provides instructions to:

- shorten a voice segment
- lengthen (adding silence to) a voice segment
- remove all silence from a voice segment

Shortening a voice segment

1. In the Voice Prompt Editor window, select the voice segment.
2. Click Length.

Result: The Edit Length for Current Segment dialog box appears.

3. Select the Edit Length at option.
4. To remove voice, noise, or silence from the beginning of the voice segment, follow these steps:
   a. Select the Beginning with check box
   b. From the Beginning with list, select a negative number of milliseconds.
5. To remove voice, noise, or silence from the end of the voice segment, follow these steps:
   a. Select the End with check box
b. From the **End with** list, select a negative number of milliseconds.

6 Click **Apply**.

**Result:** The Edit Length for Current Segment dialog box closes, and the voice segment is shortened.

To check that you removed the correct amount of silence or noise, play the voice segment (see “To play a voice segment” on page 372). Repeat this procedure as many times as necessary until the segment is correct.

### Lengthening a voice segment

1 In the Voice Prompt Editor window, select the voice segment.

2 Click **Length**.

**Result:** The Edit Length for Current Segment dialog box appears.

3 Select the **Edit Length at** option.

4 To add silence to the beginning of the voice segment, follow these steps:
   a. Select the **Beginning with** check box.
   b. From the **Beginning with** list, select a positive number of milliseconds.

5 To add silence to the end of the voice segment, follow these steps:
   a. Select the **End with** check box.
   b. From the **End with** list, select a positive number of milliseconds.

6 Click **Apply**.

**Result:** The Edit Length for Current Segment dialog box closes, and the voice segment is lengthened.
To check that you added the correct amount of silence, play the voice segment (see “To play a voice segment” on page 372). Repeat this procedure as many times as necessary until the segment is correct.

Removing all silence from a voice segment

1. In the Voice Prompt Editor window, select the voice segment.
2. Click Length.

_result: The Edit Length for Current Segment dialog box appears.

3. Select the Normalize check box.
4. To remove voice, noise, or silence from the beginning of the voice segment, select the Beginning of Segment check box.
5. To remove voice, noise, or silence from the end of the voice segment, select the End of Segment check box.
6. Click Apply.

_result: The Edit Length for Current Segment dialog box closes, and all silence is removed from the beginning or end of the voice segment, or from both.

To check that you removed the correct amount of silence or noise, play the voice segment (see “To play a voice segment” on page 372). Repeat this procedure as many times as necessary until the segment is correct.
To edit the length of all voice segments in a voice file

After you record voice segments, you may find that you have too much or too little silence in the segments, or that you want to have the same amount of silence for each voice segment. This section provides instructions to:

- shorten all voice segments
- lengthen (adding silence to) all voice segments
- remove all silence from all voice segments

Removing a specified length from all voice segments

1. From the Voice Prompt Editor window, choose File > Length.
   
   Result: The Edit Segment Lengths in Voice File dialog box appears.

2. Select the Edit Length at option.

3. To remove voice, noise, or silence from the beginning of the voice segments, follow these steps:
   
   a. Select the Beginning with check box.
   
   b. From the Beginning with list, select a negative number of milliseconds.

4. To remove voice, noise, or silence from the end of the voice segments, follow these steps:
   
   a. Select the End with check box.
   
   b. From the End with list, select a negative number of milliseconds.

5. Click Apply.

   Result: The Edit Segment Lengths in Voice File dialog box closes, and all voice segments are shortened.

To check that you removed the correct amount of silence or noise, play the voice segment (see “To play a voice segment” on page 372). Repeat this procedure as many times as necessary until the segments are correct.
Adding a specified length to all voice segments

1. From the Voice Prompt Editor window, choose File > Length.
   
   **Result:** The Edit Segment Lengths in Voice File dialog box appears.

2. Select the Edit Length at option.

3. To add silence to the beginning of the voice segments, follow these steps:
   a. Select the Beginning with check box.
   b. From the Beginning with list, select a positive number of milliseconds.

4. To add silence to the end of the voice segments, follow these steps:
   a. Select the End with check box.
   b. From the End with list, select a positive number of milliseconds.

5. Click Apply.

   **Result:** The Edit Segment Lengths in Voice File dialog box closes, and all voice segments are lengthened.

To check that you added the correct amount of silence, play the voice segment (see “To play a voice segment” on page 372). Repeat this procedure as many times as necessary until the segments are correct.

Removing all silence from all voice segments

1. From the Voice Prompt Editor window, choose File > Length.

   **Result:** The Edit Segment Lengths in Voice File dialog box appears.

2. Select the Normalize option.

3. To remove voice, noise, or silence from the beginning of the voice segment, select the Beginning of Segment check box.

4. To remove voice, noise, or silence from the end of the voice segment, select the End of Segment check box.

5. Click Apply.

   **Result:** The Edit Segment Lengths in Voice File dialog box closes, and all silence is removed from the beginning or end of all voice segments, or both.

To check the results, play the voice segment (see “To play a voice segment” on page 372).
Other procedures for voice segments

This section describes how to perform other procedures for voice segments. Detailed step-by-step instructions are available in the online Help.

Changing the attributes of a voice segment

In the Voice Prompt Editor window, select the voice segment. Change the attributes as required.

For step-by-step instructions, press F1 to access the online Help.

Deleting a voice segment

1. In the Voice Prompt Editor window, from the Voice Segment list, click the voice segment.
2. Click Delete.

Result: The deletion mark (**d**) appears beside the selected voice segment.

The voice segment is not deleted until you close the voice file or log off the Voice Prompt Editor. Until then, you can restore any voice segments that you mark for deletion.

For step-by-step instructions, press F1 to access the online Help.

Restoring a deleted voice segment

If you delete a voice segment and then decide you do not want to delete it, you can cancel the deletion, provided that you did not close the voice file since deleting the segment.

In the Voice Prompt Editor window, click the voice segment marked for deletion and then click Undo.

Result: The deletion mark (**d**) disappears from beside the selected voice segment.

For step-by-step instructions, press F1 to access the online Help.
Chapter 18

Alarms and events

In this chapter

Overview 384
Section A: To view events 387
Section B: To manage event preferences 399
Section C: To use the Alarm Monitor 407
Overview

The Event Browser and Alarm Monitor show events that occur on the server. These programs provide many common features for viewing events. For more information about the features, see the “Event Browser versus Alarm Monitor feature matrix” on page 385.

To view client events, such as successful logon or logoff or failure to connect, use the PC Event Browser. To launch the PC Event Browser, go to Start > All Programs > Nortel Contact Center > Server Utility > PC Event Browser.

Event Browser

The main advantages of the Event Browser are as follows:

- You can filter events by several categories, including severity and event code range.
- You can limit the display to the most recent events.

Alarm Monitor

The main advantage of the Alarm Monitor is that it automatically appears in the foreground of the desktop when an event occurs, thus alerting you to problems immediately. You can specify whether the Alarm Monitor appears in the foreground for only critical events, major and critical events, or all events, or whether it stays in the background.

In the Alarm Monitor, you can filter events by severity only. The Alarm Monitor does not display information events.
## Event Browser versus Alarm Monitor feature matrix

<table>
<thead>
<tr>
<th>Feature</th>
<th>in Event Browser?</th>
<th>in Alarm Monitor?</th>
</tr>
</thead>
<tbody>
<tr>
<td>view events</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>view online Help for an event</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>sort events by category</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>save a list of events</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>print a list of events</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>view minor, major, critical events</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>view information events</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>filter events by code, type, severity, latest events</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>filter events using Event Preferences graphical user interface</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>automatically show the graphical user interface in the foreground when an event occurs</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>clear an event</td>
<td>No</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Section A: To view events

In this section

Overview 388
To open the Event Browser 390
To view online Help for an event 392
To save a list of events from the Event Browser 393
To change the filtering criteria for events 395
Overview

This section describes how to view and filter events with the Event Browser.

You can also use the Windows Event Viewer to view events. For detailed instructions, see the Contact Center Manager Server Installation and Maintenance Guide.

Contact Center Manager Server also supports Simple Network Management Protocol (SNMP) traps. You can use SNMP to send Contact Center Manager Server events to a Network Management System (NMS) on your network. For more information, see the Contact Center Manager Server Installation and Maintenance Guide.

This chapter describes procedures for the following tasks:

- viewing, sorting, and printing the event log using the Event Browser on the client
- changing the filtering criteria for the Event Browser
- using the event throttling option to prevent events from repeating in the event log

Events

Events are log entries that record activities in Contact Center Manager Server, such as:

- sending or receiving messages
- opening or closing applications
- errors

Some events are for information only, while others can indicate problems. Events are categorized by severity.
Event severity

Events are assigned a default severity of information, minor, major, or critical. The Alarm Monitor does not report information-level events.

**Information**
These events indicate that something noteworthy happened on the system but do not indicate a problem. For example, an information-level event can indicate that a service started or stopped. These events appear in the Event Browser but not in the Alarm Monitor.

**Minor**
These events indicate that a non-service-affecting fault condition exists and that you must take corrective action to prevent a more serious fault. For example, a minor event is generated when the file system is 90 percent full.

**Major**
These events indicate that a service-affecting condition exists and urgent corrective action is required. The event condition can cause severe degradation in server performance, and you must restore full capacity. For example, a major event is generated when the file system is 100 percent full.

**Critical**
These events indicate that a service-affecting condition exists and immediate corrective action is required. Critical events are reported when a component is completely out of service, and you must take immediate action to restore it. For example, a critical event is generated when the file system crashes.
To open the Event Browser

Contact Center Manager Server generates alarms to notify you when minor, major, and critical system events occur. It also issues information messages. Alarms appear in both the Alarm Monitor and the Event Browser on the client PC. Information messages appear only in the Event Browser.

By default, only the latest 100 critical events appear in the Event Browser. You can configure the filter to display all events. For more information, see “To change the filtering criteria for events” on page 395.

Follow the procedures in this section to view events in the Event Browser.

You can also use the Audit Trail component in Contact Center Manager Administration to view the configured server resources that users added, modified or deleted. For more information, see Chapter 9, “Audit Trail.”
Opening the Event Browser

1. From the Server Utility window, expand **System Administration > Alarms & Events**.

2. Double-click **Event Browser**.

**Result:** The Event Browser window appears.

3. To adjust the column widths, position the pointer on the bar between the column heading names and scroll to the left or right.

**Sorting events**

Click the header of the column by which you want to sort. For example, to sort the events by type, click the **Event Type** header.

The default order lists the latest event first.
To view online Help for an event

You can view online Help for a selected event. The online Help may provide a recommended action to correct the problem or more information about the event.

Viewing online Help for an event

1. In the Event Browser or Alarm Monitor, double-click the event that you are investigating.

   **Result:** An Event Details dialog box appears.

2. Click **Help on Event**.

   **Result:** The online Help for the selected event appears.
To save a list of events from the Event Browser

Nortel recommends that you print or save relevant sections of the event log in the event of a problem with your system. The log helps technical support representatives to conduct a thorough analysis of your system.

Before you begin

Make sure that the filter settings are set to show the type and number of events that you want to save. For more information, see “To change the filtering criteria for events” on page 395.

Saving events

1. From the Server Utility window, choose Alarms & Events > Event Browser.

Result: The Event Browser appears.
2 Choose **File > Save Event Log.**

**Result:** The Save As dialog box appears.

![Save As dialog box](image)

3 Choose one of the following options:

- To save all of the events in the Event Browser, select the **All events** option.
- To save only the currently selected events, select the **Selected event(s)** option.

4 Click **OK.**

**Result:** A dialog box appears for you to provide a file name and select a location.

5 Enter a recognizable file name and location.

6 Click **Save.**

**Printing a list of events**

From the Event Browser window, choose **File > Print.**

For step-by-step instructions, press **F1** to access the online Help.
To change the filtering criteria for events

If you want to reduce the number of events shown at one time in the Event Browser, you can screen the log to view a specific number of the most recently filtered events.

Filter settings

You can set the event log filter to display:

- a specific number of latest events, or all events (all events available on or retrieved from the system)
- events of a certain severity (critical, major, minor, information)
- a specific event code range or all event codes
- a specific type of alarm (alarm set, alarm cleared, or message)
- events that occurred during a specific date and time interval

The Set Event Filter Properties tabs work together.

Example

At BestAir, system engineer Jane Oliver is testing a new server component. Before she performs the tests, she changes the filtering criteria to display all events, including information events. (These events tell her whether system components are starting.) When Jane finishes her tests, she changes the filtering criteria back to the default setting.
Viewing all events

1. From the Server Utility window, expand **Alarms & Events** and double-click **Event Browser**.
2. Choose **File > Change Filter criteria**.
   **Result:** The Set Event Filter Properties dialog box appears. The Report and Severity page appears first.

3. Select the **All events** option.
4. Select all of the Severity check boxes: **Critical**, **Major**, **Minor**, and **Information**.
5. Click the **Code and Type** tab.
   **Result:** The Code and Type page appears.

6. Select the **All Codes** option.
7. Select all of the Type check boxes: **Alarm Set**, **Alarm Cleared**, and **Message**.
8 Select the **Interval** tab.

**Result:** The Interval page appears.

![Set Event Filter Properties dialog box]

9 To view all events, ensure that the Time and Date boxes are blank.

10 Click **OK** to change the filter.

**To filter the events**

Follow the steps in “Viewing all events” on page 396, except specify the criteria you are looking for. Events that match the criteria on all tabs in the Set Event Filter Properties dialog box are listed in the Event Browser.

**Report and Severity page**

On this page, specify the number of latest events to view, or select all events to view all events that match the other filter criteria. Also, specify the severity of events to view.

**Code and Type page**

On this page, specify the range of event codes to view, or select all codes. Also, specify the types of alarms to view.

**Interval page**

On this page, you can specify that you want to view events from a specific date and time range. If you do not want to restrict the list of events to a certain date and time range, leave the date and time range blank.
Section B: To manage event preferences

In this section

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>400</td>
</tr>
<tr>
<td>To add event preferences</td>
<td>401</td>
</tr>
<tr>
<td>To throttle all events</td>
<td>403</td>
</tr>
<tr>
<td>Other procedures for event preferences</td>
<td>405</td>
</tr>
</tbody>
</table>
Overview

This section describes how to change the classification of particular events. For example, you can choose to treat a major event as a minor event if you are aware that the event is being resolved.

You can create an event preference to override the default severity or throttling parameters of any event code. For example, you can change the preferences of an event to:

- increase the severity of an event (for example, from Information to Minor). By increasing an event severity, you ensure that the event appears in the Alarm Monitor when it occurs.
- reduce the severity of a recurring alarm to Information. By reducing an event severity, you prevent it from appearing in the Alarm Monitor.
- set the throttling parameters to reduce the frequency with which an event is logged.

Previous occurrences of the event are not affected. You can revert to the default event definition at any time by deleting the event preference for that event code.

Example

At BestAir, Contact Center Manager is generating a critical alarm because of a database error. The system engineer, Jane Oliver, ordered a replacement for the malfunctioning disk drive that is causing the problem. Because she is aware of the problem, Jane does not want to see an alarm on her console every time the error occurs.

Jane can use event preferences to reduce the severity of the error from Critical to Information. After the new disk is installed, she can delete the event preference to restore the severity to Critical.
To add event preferences

To create an event preference for an event, follow the procedure in this section. If an event preference is already defined for the event, you can change the event severity. For more information about changing the event severity, see “Changing an event preference” on page 405.

Adding an event preference

1. From the Server Utility window, expand System Administration > Alarms & Events and then double-click Event Preferences.

   Result: The Event Preferences window appears.

2. Choose File > New.

3 In the **Event Code** box, type the event code number for the event you want to add.

Contact Center Manager does not accept unrecognized event codes. For a complete list of valid event codes, refer to the Event Browser and select Event Code Reference from the Help menu.

4 From the **Severity** list, select the severity you want to assign to the event.

5 In the **Interval** box, type the throttling interval (the time interval during which the event can be logged a specified number of times).

**Example:** In 30 minutes (the interval), log the event a maximum of 10 times (the number).

6 In the **Threshold** box, type the number of instances of the event that can be logged during the specified interval.

7 Click **Save** to return to the Event Preferences window.

**Result:** The new event is added to the list of events.

8 To return to the Server Utility window, choose **File > Close**.
To throttle all events

Use event throttling to control the frequency with which events are recorded by the server log. You can throttle all events to prevent the log from becoming overcrowded. If too many instances of each event are recorded, the log might have insufficient space to record more important events. Too many instances of the same event can distract users, causing them to overlook other important events.

To set throttling on specific event codes, see “To add event preferences” on page 401.

**Throttling all events**

1. From the Server Utility window, choose **Alarms & Events > Event Preferences**.

   **Result:** The Event Preferences window appears.
2 Choose **File > Default Throttling**.

**Result:** The Set Default Throttling Properties dialog box appears.

3 Select the **Enable** check box.

4 In the **Interval** box, type the interval for which you want to configure throttling.

5 In the **Number** box, type the number of instances of each event that you want logged.

6 Click **Save** to return to the Event Preferences window.

7 To return to the Server Utility window, choose **File > Close**.
Other procedures for event preferences

This section describes how to perform other procedures for event preferences. Detailed step-by-step instructions are available in the online Help.

Changing an event preference

From the Event Preferences window, select the event preference that you want to change, and then choose **File > Properties**.

If the event code that you want does not appear in the list, define an event preference first. For information about creating a new event preference, see “To add event preferences” on page 401.

For step-by-step instructions, press **F1** to access the online Help.

Printing the list of event preferences

From the Event Preferences window, choose **File > Print**.

For step-by-step instructions, press **F1** to access the online Help.

Deleting an event preference

When you delete an event preference, the event settings for severity and throttling revert to their default values.

From the Event Preferences window, select the event preference that you want to delete, and then choose **File > Delete**.

For step-by-step instructions, press **F1** to access the online Help.
Section C: To use the Alarm Monitor

In this section

Overview 408
To view events in the Alarm Monitor 409
To clear active alarms 412
Overview

This section describes how to view and manage alarms. Contact Center Manager generates alarms to notify you when minor, major, and critical system events occur.

You can configure the Alarm Monitor to appear in either of the following locations when a new alarm is registered:

- the foreground
- the background

In the Alarm Monitor, you can view, clear, and print system alarm information.

To prevent recurring alarms

You can prevent an alarm from recurring in the following ways:

- Change the throttling parameters for all events (see “To throttle all events” on page 403).
- Change the throttling parameters for a specific event (see “To add event preferences” on page 401).
- Override the default severity of the event so it no longer appears in the Alarm Monitor. For more information, see “To add event preferences” on page 401.
To view events in the Alarm Monitor

By default, the Alarm Monitor appears in the foreground when a critical, major, or minor event occurs. If you cannot see the Alarm Monitor or if it is closed, follow the steps in this section to open it.

Opening the Alarm Monitor

1. From the client PC, log on to the server.
2. From the Server Utility window, expand System Administration > Alarms & Events and then double-click Alarm Monitor.

Result: The Alarm Monitor window appears.

To adjust the column widths, position on the bar between the column heading names, and then click and drag the pointer left or right.

Refreshing the Alarm Monitor

From the Alarm Monitor window, choose View > Refresh.

After you refresh the Alarm Monitor, the number of alarms may decrease. Alarms cleared by other processes are removed from the Alarm Monitor.
Sorting events

From the Alarm Monitor window, click the header of the column by which you want to sort. For example, to sort the events by type, click the Event Type header.

Note: By default, events are sorted by timestamp in reverse chronological order.

Specifying when the Alarm Monitor appears in the foreground

By default, the Alarm Monitor appears in the foreground when any event occurs (that is, it takes the focus from the currently active window). You can configure the severity of alarm that forces the Alarm Monitor to appear in the foreground.

In the Server Utility window, from the Utilities menu, select one of the following options:

- Alert All Alarms—Shows the Alarm Monitor window every time an alarm is registered or updated.
- Alert Major and Critical Only—Shows the Alarm Monitor window every time a Major or Critical alarm is registered or updated.
- Alert Critical Only—Shows the Alarm Monitor window every time a Critical alarm is registered or updated.

Configuring the Alarm Monitor to appear in the background

If you do not want to see the Alarm Monitor every time it receives and updates a new alarm, you can force it to appear in the background of your display.

In the Server Utility window, from the Utilities menu, select Alerting Off.

Result: The Alarm Monitor moves to the background. When a critical alarm is registered, the Alarm Monitor window taskbar flashes until you move the Alarm Monitor window to the foreground.

If you select Alerting Off and then minimize the Alarm Monitor, the minimized Alarm Monitor flashes when a critical alarm is registered until you restore the Alarm Monitor window.
Obtaining more information about an alarm

1. In the Alarm Monitor, double-click an alarm entry.
   
   **Result:** The Event Details dialog box appears.

2. Click **Help on Event**.
To clear active alarms

Alarms are cleared from the Alarm Monitor in one of two ways:

- Contact Center Manager automatically clears alarms when the alarm condition changes.
- You clear alarms manually.

When you clear an alarm, you remove the selected alarm (but not the event that raised it) from the event log. This action also removes the selected alarm from the list in the Alarm Monitor. If the event occurs again, however, the alarm reappears in the Alarm Monitor.

Example
At BestAir, an alarm appears with the description “Disk is 90% full.” Mark Brown, the system administrator, checks the system disk space, removes temporary files, and decides to order a larger hard drive. Only after he resolves the problem does he clear the alarm from the Alarm Monitor.
Clearing an alarm

1. From the Server Utility window, expand **System Administration > Alarms & Events** and then double-click **Alarm Monitor**.

   **Result:** The Alarm Monitor window appears.

2. Select the alarm you want to clear.

3. From the Alarm Monitor menu, select **File > Clear Alarm**.

   **Result:** A dialog box appears asking you to confirm that you want to clear the selected alarm.

4. Click **Yes**.

   **Result:** The alarm entry is removed from the Alarm Monitor.
Overview

You can use the Server Utility Backup Scheduler to schedule backups for the server. Schedule a backup:

- before and after major system operations take place, such as an upgrade or the application of an Emergency Customer Solution.
- after major modifications, such as the addition of a large number of users or customized prompts
- after the server is installed and operational

When a backup is scheduled, it appears in the Backup Scheduler window. You must log on as an administrator or ensure that you have administrative privileges to schedule a backup.

**ATTENTION**

You can schedule backups to run online, while calls are serviced. (Restores are performed offline.) However, because backups compete with services for system resources, schedule backups to run only during off-peak hours when there is little or no system activity.

Avoid scheduling backups during the MMFS audit hour (3:00 to 4:00 a.m., server time); they do not successfully complete.
To schedule a backup

To ensure that your system information can be restored after a hardware failure or data corruption, schedule regular backups. This section describes how to schedule backups using the Server Utility. For more information about scheduling, backup options, and recovery procedures, see the *Contact Center Manager Server Installation and Maintenance Guide*.

You can back up your database to either a local tape drive or a remote directory on a network computer. You must configure one of these options on Contact Center Manager Server before you schedule a backup. For detailed instructions, see the *Contact Center Manager Server Installation and Maintenance Guide*.
Scheduling a backup

ATTENTION

Ensure that the destination backup device is listed in the Backup device table.

Backups performed on unformatted tapes are unsuccessful.

If you do not select overwrite, the backup is appended to the last backup on the tape.

1. In the Server Utility window, expand **System Administration > Server Backup** and then double-click **Backup Scheduler**.

Result: The Backup Scheduler window appears.
2. From the **File** menu, select **New Schedule**.

**Result:** The Event Properties window appears.

3. From the **Device Name** list, select the destination device.

4. From the **Backup Definition** list, select the type of backup.

5. Select the **Overwrite** check box to overwrite the previous backup.

   If you select the Overwrite check box, the backup is written to the same location as the previous backup and the previous backup is lost. If you do not select the Overwrite check box, the backup is stored in a new directory and the previous backup remains.
6  Click the **Schedule** tab.

**Result:** The Schedule page appears.

7  Select the type of schedule: **Daily**, **Weekly**, **Monthly**, **Yearly**, or **Specific date(s)**.

8  Select the month, day, or dates on which you want to run the backup.

   The options available depend on the type of schedule you select.

9  In the **Start** box, select the start time for the backup.

   The backup is scheduled according to the server time, which is not necessarily the same as the client PC time.

10 In the **Maximum wait time** box, select the maximum wait interval (the length of time the system can wait before starting the backup).

   This time is required in case a scheduling conflict with other tasks forces the backup to wait. If the wait time expires before the backup can start, the backup is skipped. For example, you can schedule a backup for a non-peak period, but in 3 hours the morning shift arrives. In this case, you can enter 03:00 as the interval time. This ensures that the backup does not take place when the morning shift arrives.
11 Click the **Others** tab.

**Result:** The Others page appears.

12 In the **Description** box, type the description or the purpose of the backup.

13 Click **Save**.

**Result:** The backup is scheduled and a message box appears reminding you to also schedule a backup for the Contact Center Manager Administration server.

14 Click **OK**.
To monitor backups

You can monitor the status of a running backup using the Backup Status window. This window appears when a scheduled backup runs.

You can also use log files to verify whether a backup succeeded. The backup log is generated at the end of the backup and is stored on the server in the following directory: D:\Nortel\data\backup\backuplogs. For more information about using log files, see the Contact Center Manager Server Installation and Maintenance Guide.

Backup Status window

The Backup Status window lists files skipped or copied in error during backup. If a file is not copied successfully, a minor alarm is generated. Obtain the event ID from the alarm in the Alarm Monitor for more information.

Viewing the Backup Status window

From the Backup Scheduler window, choose View > View backup status.
Other procedures for backups

You can change any detail of a scheduled backup using the Event Properties window. You can also delete backups from this window.

Changing a scheduled backup

On the Backup Scheduler window, select the scheduled backup that you want to change, and then choose File > Properties.

For step-by-step instructions, press F1 to access the online Help.

Deleting a scheduled backup

On the Backup Scheduler window, select the scheduled backup that you want to delete, and then choose File > Delete.

For step-by-step instructions, press F1 to access the online Help.

Canceling a running backup

From the Backup Scheduler window, choose View > View backup status. On the Backup Status window, click Cancel.

If you cancel the backup, data that was written to the backup device is unusable.
part 3

Appendixes
Appendix A

CS 1000 Data Extraction Tool

In this chapter

Overview 428
Section A: To install the CS1000 Data Extraction Tool 429
Section B: To use the CS1000 Data Extraction Tool 435
Section C: To capture the CS 1000/Meridian 1 data output 447
Overview

The CS1000 Data Extraction Tool is a software application that extracts information about resources such as Terminal Numbers (TNs), voice ports, Controlled Directory Numbers (CDNs), Interactive Voice Response Automatic Call Distribution DNs (IVR ACD-DNs), and routes from a Communication Server 1000/Meridian 1 PBX telephony switch. The tool saves this information in Excel spreadsheets.

To save data entry time, you can use Excel spreadsheets with the Contact Center Manager Administration Configuration upload utility by copying the CS 1000/Meridian 1 telephony switch data and pasting it into the Configuration Tool spreadsheet templates that you download from the Contact Center Manager Administration application.

You cannot upload data from the CS 1000 Data Extraction Tool spreadsheets directly to Contact Center Manager Administration. You must copy the data from the CS 1000 Data Extraction Tool spreadsheet into the Contact Center Manager Administration Configuration Tool spreadsheet and then upload the data. Contact Center Manager Administration does not support uploading directly from the CS 1000 Data Extraction Tool spreadsheets.

For more information about Contact Center Manager Administration Configuration Tool spreadsheets, see the Contact Center Manager Administration online Help.
Section A: To install the CS1000 Data Extraction Tool

In this section

- System requirements 430
- To install the CS1000 Data Extraction Tool 431
- To uninstall the CS1000 Data Extraction Tool 433
System requirements

The CS1000 Data Extraction Tool runs on a PC with the following operating systems installed:

- Windows 2000 Server/Advanced Server/Professional
- Windows XP Professional
- Windows Vista Business
- Windows Vista Enterprise

Hardware requirements

The following table lists the minimum hardware configuration required to install and run the CS1000 Data Extraction Tool:

- Pentium 166 MHz or better
- 64 MB of RAM (128 MB of RAM recommended)
- 10 MB of hard disk space
- an available serial port or modem

If you install and run the CS 1000 Data Extraction Tool on the Contact Center Manager Administration server, consult the Contact Center Manager Administration Installation and Maintenance Guide for the list of minimum hardware requirements for the application server.

Software requirements

The CS1000 Data Extraction Tool requires that Microsoft Excel 97 or later be installed on the PC.
To install the CS1000 Data Extraction Tool

You can install the CS1000 Data Extraction Tool from the Contact Center application DVD using an automated setup program that guides you through the installation process from start to finish. The entire installation takes only a few minutes to complete. After you install the software, you can immediately use the CS1000 Data Extraction Tool.

When you install and use the CS1000 Data Extraction Tool on the client PC, the tool connects directly to the CS 1000/Meridian 1 telephony switch through a serial port or a modem; it does not connect to the telephony switch through a server.

Installing the CS1000 Data Extraction Tool

1. Insert the Contact Center DVD into the computer.
2. Browse the DVD contents and open the **CS1000 Data Extraction Tool** folder.
3. Double-click the **CS1000 Data Extraction Tool.msi** file.
   
   **Result:** The InstallShield Wizard welcome page appears.

4. Click **Next**.
   
   **Result:** The Customer Information window appears.

You can click **Cancel** at any time during the installation to exit the Setup program.

4. Click **Next**.
   
   **Result:** The Customer Information window appears.
In the **User Name** box, type your name.

In the **Organization** box, type your company name.

Customer information is optional.

Select one of the following two options to install this application for:

- **Anyone who uses this computer** (all users)
- **Only for me** (<User Name>)

Click **Next**.

**Result:** The **Setup Type** window appears.

If you select the **Complete** option, follow these steps. This option installs all program features and requires the most disk space.

a. Click **Next**.

b. Click **Install**.

   **Result:** The InstallShield Wizard Completed window appears.

c. Click **Finish**.

   **Result:** The CS1000 Data Extraction Tool is installed.

If you select the **Custom** option, follow these steps. Select this option to choose which program features you want to install and where you want to install them. This option is recommended for advanced users only.

a. Click **Next**.

   **Result:** The Custom Setup window appears.

b. Click an icon in the list to change how a feature is installed.

c. To view available space on selected drives, click **Space**.

d. To change the folder destination, Click **Change**.

e. To view descriptions of feature installation options, click **Help**.

f. Click **Next**.

g. Click **Install**.

   **Result:** The selected program features are installed and the InstallShield Wizard Completed window appears.

h. Click **Finish**.

   **Result:** The CS1000 Data Extraction Tool is installed.
To uninstall the CS1000 Data Extraction Tool

You can completely uninstall the CS1000 Data Extraction Tool using the Uninstaller program included with the software.

Uninstalling the CS1000 Data Extraction Tool

1. From your Start menu click Settings > Control Panel.
2. Double-click Add or Remove Programs.
   Result: The Add or Remove Programs window appears.
3. In the list of programs, select CS1000 Data Extraction Tool.
4. Click Change.
   If the CS1000 Data Extraction Tool was installed on Windows 2003 Server, proceed to step 8.
   Result: The CS1000 Data Extraction Tool InstallShield Wizard window appears.
5. Click Next.
   Result: The Program Maintenance window appears.
6. Select the Remove option.
7  Click **Next**.

**Result:** The Remove the Program window appears.

![Remove the Program window](image)

8  Click **Remove**.

**Result:** The CS1000 Data Extraction Tool is uninstalled.

9  Click **Finish**.
Section B: To use the CS1000 Data Extraction Tool

In this section
To extract data from the CS 1000/Meridian 1 436
Error messages 446
To extract data from the CS 1000/Meridian 1

You can use the CS1000 Data Extraction Tool to connect to the Communication Server 1000/Meridian 1 PBX through an available serial port or modem; extract data about telephony switch resources, such as TNs, CDNs, and routes; and save the data in an Excel spreadsheet.

You can also use a terminal emulator application, such as the Microsoft HyperTerminal utility, to connect to the CS 1000/Meridian 1 and capture an output data file containing the telephony switch resource information. After you save the data as a text file on your computer, you can use the CS1000 Data Extraction Tool to export it into an Excel spreadsheet.

To save data entry time, you can use these Excel spreadsheets with the Contact Center Manager Administration Configuration upload utility by copying the CS 1000/Meridian 1 data and pasting it into the Configuration Tool spreadsheet templates that you download from the Contact Center Manager Administration application.

You cannot upload data from the CS1000 Data Extraction Tool spreadsheets directly to Contact Center Manager Administration. You must copy the data from the CS1000 Data Extraction Tool spreadsheet into the Contact Center Manager Administration Configuration Tool spreadsheet and then upload the data. Contact Center Manager Administration does not support uploading directly from the CS1000 Data Extraction Tool spreadsheets.

For more information about Contact Center Manager Administration Configuration Tool spreadsheets, see the Contact Center Manager Administration online Help.

Extracting data using a serial connection

You can extract data from the CS 1000/Meridian 1 through a serial connection using an available serial port on your computer.

When you install and use the CS1000 Data Extraction Tool on the client PC, the tool connects directly to the CS 1000/Meridian 1 through the serial port; it does not connect to the telephony switch through a server.
1 From the Start menu, choose Programs > Nortel Contact Center > CS100 Data Extraction Tool > CS1000 Data Extraction Tool.

Result: The Select Options window appears.

2 Select Serial Port, and then click Next.

Result: The CS1000 Data Extraction Tool - Step 1 of 4 window appears.

3 Set your serial connection parameters.

Your serial connection parameters must match the parameters of the CS 1000/Meridian 1. Contact your telephony switch administrator if you do not know which parameters to select.

a. From the Connect Using list, select your available COM port.

b. In the Connection Preferences area, select your connection preferences.

c. In the Flow Control area, select a flow control option.
4  To test your COM port, click **Test**.
   **Result:** A message appears in the **Status** box informing you if your COM port is working.

5  Click **Next**.
   **Result:** The CS1000 Data Extraction Tool - Step 2 of 4 window appears.

6  In the **Switch Resources** area, select the resources that you want to download from the telephony switch.

7  In the **Login Account** section, enter your user ID and password for the telephony switch. The default user ID is **admin**.

   Do not type CS 1000/Meridian 1 overlay commands in the User ID box. Type only your user ID for the CS 1000/Meridian 1 telephony switch.

8  In the **Select option to load TN Data** section, select which overlay you want to use to download TN data: **LD 20 All TNS** or **LD 81 Agent & Supervisors TNS**.

9  In the Customer Number box, type your customer number.

10 Click **Browse** to select the folder where you want to save your exported data.

   **Result:** The Save As window appears with the default folder selected.

11 Accept the default selection or navigate to the folder of your choice.

12 Click **OK**.

   **Result:** The path you select appears in the **File name** box.
13 Click **Next**.

**Result:** The CS1000 Data Extraction Tool - Step 3 of 4 window appears, confirming your selected resources, user ID, and exported file name.

![Step 3 of 4](image)

If the system displays the Failed to logon dialog box, exit the CS1000 Data Extraction Tool and confirm your settings. Restart the program by choosing Programs > Nortel Contact Center > CS100 Data Extraction Tool > CS1000 Data Extraction Tool, and attempt to log on again.

14 Click **Next** to download the data.

**Result:** The CS1000 Data Extraction Tool - Step 4 of 4 window appears, informing you of the progress of connecting to the CS 1000/Meridian 1, retrieving the data, and exporting it to the Excel file.

![Step 4 of 4](image)

15 Click **Finish** when the data extraction is complete.
Extracting data using a modem

You can extract data by using a modem to connect to the CS 1000/Meridian 1.

1. From the Start menu, choose Programs > Nortel Contact Center > CS100 Data Extraction Tool > CS1000 Data Extraction Tool.

   Result: The Select Options window appears.

2. Select Modem, and then click Next.

   Result: The CS1000 Data Extraction Tool - Step 1 of 4 window appears.

3. Set your modem connection parameters:
   a. From the Connect using list, select the modem you want to use.
   b. In the Phone number box, type the phone number used to connect to the modem at the CS 1000/Meridian 1 telephony switch.
4 To test your COM port, click Test.

**Result:** A message appears in the Status box informing you if your COM port is working.

5 Click Next.

**Result:** The CS1000 Data Extraction Tool - Step 2 of 4 window appears.

6 In the **Switch Resources** section, select the resources that you want to download from the telephony switch.

7 In the **Login Account** section, enter your user ID and password for the telephony switch.

8 In the **Select option to load TN Data** section, select which overlay you want to use to download TN data: LD 20 All TNS or LD 81 Agent & Supervisor TNS.

9 In the Customer Number box, type your **Customer Number**.

10 Click **Browse** to select the folder where you want to save your exported data.

**Result:** The Browse for Folder window appears with the default folder selected.

11 Accept the default selection, or navigate to the folder of your choice.

12 Click **OK**.

**Result:** The path you select appears in the **File name** box.
13 Click **Next**.

**Result:** The CS1000 Data Extraction Tool - Step 3 of 4 window appears, confirming your selected resources, user ID, and exported file name.

![CS1000 Data Extraction Tool - Step 3 of 4](image)

14 Click **Next** to download the data.

**Result:** The CS1000 Data Extraction Tool - Step 4 of 4 window appears, informing you of the progress of connecting to the CS 1000/Meridian 1, retrieving the data, and exporting it to the Excel file.

![CS1000 Data Extraction Tool - Step 4 of 4](image)

15 Click **Finish** when the data extraction is complete.

**Extracting data from a file**

You can use the Extract from File option to extract data from an output file that you captured from the CS 1000/Meridian 1 and saved on your computer.
For details about capturing an output file from the CS 1000/Meridian 1, see “To capture the CS 1000/Meridian 1 data output” on page 447.

1 From the Start menu, choose Programs > Nortel Contact Center > CS100 Data Extraction Tool > CS1000 Data Extraction Tool.

Result: The Select Options window appears.

2 Select File, and then click Next.

Result: The CS1000 Data Extraction Tool - Step 1 of 4 window appears.

3 In the Source File name box, type the name of the file that contains the CS 1000/Meridian 1 data.

If you do not know the file name, click Browse to navigate to the file.

4 Click Next.

Result: The CS1000 Data Extraction Tool - Step 2 of 4 window appears.
5 In the **Switch Resources** section, check the telephony switch resources that you want to download from the file.

6 In the **File name** box, enter the path and file name, or click **Browse** to select the folder where you want to save your exported data.

**Result:** The Browse for Folder window appears with the default folder selected.

7 Accept the default selection, or navigate to the folder of your choice. Click **OK**.

**Result:** The path you select appears in the **File name** box.

8 Click **Next**.

**Result:** The CS1000 Data Extraction Tool - Step 3 of 4 window appears, confirming your selected resources and the exported file name.
9  Click **Next**.

**Result:** The CS1000 Data Extraction Tool - Step 4 of 4 window appears, informing you of the progress of connecting to the output file and exporting the data you selected to the Excel file.

10  Click **Finish** when the data extraction is complete.

**Tip:** You can now copy the data you extracted and paste it into the Contact Center Manager Administration Configuration templates to save data-entry time. For more information, see the Contact Center Manager Administration online Help.

You cannot upload data from the CS1000 Data Extraction Tool spreadsheets directly to Contact Center Manager Administration. You must copy the data from the CS1000 Data Extraction Tool spreadsheet into the Contact Center Manager Administration Configuration Tool spreadsheet and then upload the data. Contact Center Manager Administration does not support uploading directly from the CS1000 Data Extraction Tool spreadsheets.
Error messages

The following section describes CS 1000 Data Extraction Tool error messages

Fail to connect

The “Fail to connect” message appears under the following conditions:

- If the “Fail to connect” message appears in the Status box when you verify the selected serial port in the CS1000 Data Extraction Tool - Step 1 of 4 window, then the serial port is either an invalid port, or another application is using it.
  Select another serial port and try again.

- If the telephony switch is not configured for multiple users to log on, the “Fail to connect” message appears in the Status box if you try to log on to the telephony switch when another user is already logged on.
  You must wait until the user logs off, and then try to connect again. To prevent the problem from occurring again, contact your telephony switch administrator to enable the multiple user logon feature.

Fail to log on

If the “Fail to logon. Try again” message appears in the CS1000 Data Extraction Tool - Step 4 of 4 window, then the user ID or password that you entered may be incorrect.

Click Back to return to the CS1000 Data Extraction Tool - Step 2 of 4 window, and verify that your user ID and password are correct before you try to log on again. If you still fail to log on, exit the CS1000 Data Extraction Tool, confirm your settings, restart the program by choosing Programs > Nortel Contact Center > CS100 Data Extraction Tool > CS1000 Data Extraction Tool, and attempt to log on again.

If you still fail to log on after trying several times, use the HyperTerminal application to check if the connection between your PC and the CS 1000/ Meridian 1 is working.
Section C: To capture the CS 1000/Meridian 1 data output

In this appendix

Overview 448
To capture Terminal Number data 449
To capture voice port data 451
To capture CDN data 452
To capture IVR ACD-DN data 453
Overview

You can use a terminal emulator application, such as the Microsoft HyperTerminal, to connect to the CS 1000/Meridian 1 telephony switch and extract data about Terminal Numbers (TNs), voice ports, Controlled Directory Numbers (CDNs), routes, and Interactive Voice Response Automatic Call Distribution Directory Numbers (IVR ACD-DNs).

Based on the type of data you want to capture, after you connect to the telephony switch, you must load an overlay program and type the required commands to extract the data. You can choose from four overlay programs:

- Use program 20 to download data on the TNs configured on the telephony switch.
- Use program 21 to download data on routes.
- Use program 23 to download data on all CDNs and IVR ACD-DNs configured on the telephony switch.
- Use program 81 to download data on voice ports.

After you load the program and enter the commands, the telephony switch displays the data you requested. To use the data with the CS1000 Data Extraction Tool, capture the data with the terminal emulator application and save it to your computer as a text file. For more information about using the file, see “Extracting data from a file” on page 442.
To capture Terminal Number data

You can capture a list of all Terminal Numbers (TNs) that are configured by entering the following commands when you are connected to the telephony switch and loading Overlay program 20:

LD 20
REG PRT
TYPE TNB
TN
CDEN
CUST x (where x is the Customer Number)
DATE
PAGE
DES

An example of the output follows:

DES  LAB30
TN   002 0 00 00
TYPE 500
CDEN 4D
CUST 0
WRLS NO
DN   7050 0     MARP
    CPND
      NAME 500 set-1
      XPLN 9
      DISPLAY_FMT FIRST,LAST
AST  NO
IAPG 0
HUNT
TGAR 0
LDN NO
NCOS 0
SGRP 0 RNPG 0
XLST
SCI 0

CLS UNR DTN FBD XFA WTA THFD FND HTD ONS
  LPR XRA CWD SWD MWD RMMD SMWD LPD XHD CCSD LND TVD
  CFTD SFD MRD C6D CNID CLBD AUTU
  ICDD CDMD LLCN EHTD MCTD
  GPUD DPUD CFXD ARHD OVDD AGTA CLTD LDTD ASCD
  MBXD CPFA CPTA DDGA NAMA
  MCRD
  EXR0 SHL ABDD CFHD DNDY DNO3
  CWND USMD USRD BNRD OCBD RTDD RBDD RBHD FAXD CNUD CNAD
  PGND FTTU
PLEV 02
SPID NONE
PRI 01
AACD NO
AACS NO
MLWU_LANG 0
FTR CFW 16 FTR PHD
FTR ACD 3500 3204
AGN
DATE 8 MAR 1999
To capture voice port data

You can capture a list of all voice ports that are configured as TNs on the telephony switch by using Overlay program 81. To separate voice ports from the other TNs, request only those TNs with the Voice Messaging Allowed (VMA) feature, as follows:

LD 81
REQ 1st
CUST x (where x is the Customer Number)
DATE
PAGE
DES
FEAT vma
FEAT

An example of the output follows:

<table>
<thead>
<tr>
<th>VMA</th>
<th>TN</th>
<th>SL1</th>
<th>MMAIL</th>
<th>DATE</th>
</tr>
</thead>
<tbody>
<tr>
<td>00</td>
<td>0100001</td>
<td>SL1</td>
<td>MMAIL</td>
<td>NO DATE</td>
</tr>
<tr>
<td>00</td>
<td>0100008</td>
<td>SL1</td>
<td>MMAIL</td>
<td>15 MAY 1997</td>
</tr>
</tbody>
</table>
To capture CDN data

You can capture a list of all of the CDNs by using Overlay program 23, as follows:

LD 23
REQ PRT
TYPE CDN
CUST x (where x is the Customer Number)
CDN

The following is an example of the output produced after running Overlay program 23 with PRT option CDN on an Option 11C switch:

TYPE CDN
CUST 0
CDN 4911
FRRT
SRRT
....
ACNT
To capture IVR ACD-DN data

You can capture a list of all of the IVR ACD-DNs by using Overlay program 23, as follows:

LD 23
REQ prt
TYPE ACD
CUST x (where x is the Customer Number)
ACDN

The following is an example of the output from Option 11C for IVR ACD-DNs:

TYPE ACD
CUST 0
ACDN 6700
....
CWNT NONE

Capturing route data

You can capture a list of all of the route numbers from the switch by using Overlay program 21, as follows:

LD 21
REQ prt
TYPE rdb
CUST x (where x is the Customer Number)
ROUT
ACOD
Appendix B

Supervisor/reporting agents matrix

In this appendix

Overview 456
Real-Time Reporting 457
Historical Reporting 465
Contact Center Management 468
Overview

Use the supervisor/reporting agents feature to dynamically link a supervisor and reporting agents with one or more Contact Center Manager Administration users, so users can view the agents in Contact Center Manager Administration components, such as Real-Time Reporting, Historical Reporting, and Contact Center Management. You assign supervisor/reporting agent combinations to Contact Center Manager Administration users by using the Supervisors tab in the User Properties window of Access and Partition Management.

Supervisor/reporting agent combinations and partitions affects the data differently that users can view, based on the component in which the user is working and the type of data the user is viewing. For example, a private real-time display behaves differently than a public real-time display. The tables in this appendix outline the effect of supervisor/reporting agent combinations and partitions in each of the applicable Contact Center Manager Administration components.

In most cases, the supervisor/reporting agents feature works only in conjunction with partitions; you must assign both a partition and a supervisor/reporting agent combination to a user to restrict the user to seeing their reporting agents. The exception to this rule is in Real-Time Reporting, specifically for the private agent real-time displays and agent map displays. If you assign the user only a supervisor/reporting agent combination in Access and Partition Management (not a partition), then the user can apply this supervisor/reporting agent combination (on the Filters tab) to either a private agent real-time display or an agent map display to view only those reporting agents.
Real-Time Reporting

The data that users see in Real-Time Reporting varies based on whether the user opens a public agent real-time display, a private agent real-time display, or an agent map display.

**Public agent tabular real-time displays**
Users can apply custom filters and supervisor/reporting agent combinations to public agent, skillset, or application real-time displays. To assign custom filters and supervising/reporting agent combinations, launch the public display and click the Filters button. If you assign the user a supervisor/reporting agent combination in Access and Partition Management, it affects the data that the user sees in public agent real-time displays. Additionally, partitions affect the data that users see in public agent real-time displays.

**Private agent tabular real-time displays**
For private real-time displays, users can create custom filters by choosing the items from their partitioned data that they want to see in the display. Then, when they customize their private display, they can assign one or more of these filters to the display in the Filters tab.

This tab also lists any supervisor/reporting agent combinations that the administrator assigned to the user in Access and Partition Management, represented by the corresponding supervisor’s name. Each supervisor name represents all of that supervisor’s reporting agents.

Based on the supervisor/reporting agent combinations that the administrator assigned to the user, there may be more than one supervisor name on this tab. For example, the administrator can assign the supervisor their own agents (and, therefore, the supervisor’s own name appears on this tab) and the reporting agents of another supervisor, in which case this other supervisor’s name also appears on the tab. When the user customizes the display, the user can assign the supervisor/reporting agent combinations to the display by clicking the names of the appropriate supervisors to view all the reporting agents of these selected supervisors.
Private real-time displays are different from public real-time displays in that users do not require a partition to restrict the agent data that they can see in the display. If the administrator assigns the user only a supervisor/reporting agent combination in Access and Partition Management (not a partition), the user can apply this supervisor/reporting agent combination (on the Filters tab) to the private agent real-time display to view only those reporting agents.

**Agent map graphical displays**
Before a user can launch an agent map graphical display, the user must apply either a custom filter or a supervisor/reporting agent combination to it, but the user cannot apply both at the same time.

Agent map graphical displays are different from public real-time displays in that users do not require a partition to restrict the agent data that they can see in the display. If the administrator assigns the user only a supervisor/reporting agent combination in Access and Partition Management (not a partition), then the user can apply this supervisor/reporting agent combination to the agent map display to view only those reporting agents.

**User-defined and standard partitions and tabular and graphical displays**
The following table details the data that is visible when partitions are assigned to the user for public and private agent tabular real-time displays and agent map displays.

<table>
<thead>
<tr>
<th>User-defined partition assigned to the user</th>
<th>Standard partition assigned to the user</th>
<th>Filter applied to the display</th>
<th>Data the user sees in the agent display (public or private)</th>
</tr>
</thead>
<tbody>
<tr>
<td>No, Full Data partition selected</td>
<td>No, Full Data partition selected</td>
<td>No</td>
<td>All agents</td>
</tr>
<tr>
<td>No, Full Data partition selected</td>
<td>No, Full Data partition selected</td>
<td>Yes</td>
<td>Agents included in filter</td>
</tr>
<tr>
<td><strong>User-defined partition assigned to the user</strong></td>
<td><strong>Standard partition assigned to the user</strong></td>
<td><strong>Filter applied to the display</strong></td>
<td><strong>Data the user sees in the agent display (public or private)</strong></td>
</tr>
<tr>
<td>-----------------------------------------------</td>
<td>--------------------------------------------</td>
<td>---------------------------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>No or Yes with no agents selected</td>
<td>One or more supervisor partitions</td>
<td>No</td>
<td>Agents reporting to the selected supervisors</td>
</tr>
<tr>
<td>No or Yes with no agents selected</td>
<td>One or more supervisor partitions</td>
<td>Custom filter - Filters can be created with agents from the supervisor partitions</td>
<td>Agents reporting to the selected supervisor and included in the custom filter</td>
</tr>
<tr>
<td>No or Yes with no agents selected</td>
<td>One or more supervisor partitions</td>
<td>Supervisor filter</td>
<td>Agents reporting to the selected supervisors included in the supervisor filter</td>
</tr>
<tr>
<td>No or Yes with no agents selected</td>
<td>One or more supervisor partitions, but no agents reporting to the supervisors</td>
<td>Supervisor filter (only custom filters can be empty)</td>
<td>No agents</td>
</tr>
<tr>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>Agents included in the user-defined partition</td>
</tr>
<tr>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>Agents included in filter (subset of agents in user-defined partition)</td>
</tr>
<tr>
<td>User-defined partition assigned to the user</td>
<td>Standard partition assigned to the user</td>
<td>Filter applied to the display</td>
<td>Data the user sees in the agent display (public or private)</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>----------------------------------------</td>
<td>------------------------------</td>
<td>----------------------------------------------------------</td>
</tr>
<tr>
<td>Yes</td>
<td>One or more supervisor partitions</td>
<td>No</td>
<td>Agents included in the user-defined partition</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Agents reporting to selected supervisors</td>
</tr>
<tr>
<td>Yes</td>
<td>One or more supervisor partitions</td>
<td>Custom filter</td>
<td>Agents included in custom filter (subset of the agents in the user-defined partition and the agents reporting to the selected supervisors)</td>
</tr>
<tr>
<td>Yes</td>
<td>One or more supervisor partitions</td>
<td>Supervisor filter</td>
<td>Agents reporting to the selected supervisors in the supervisor filter</td>
</tr>
<tr>
<td>Yes</td>
<td>One or more supervisor partitions, but no agents reporting to the supervisors</td>
<td>No</td>
<td>Agents in the user-defined partition</td>
</tr>
<tr>
<td>Yes</td>
<td>One or more supervisors, but no agents reporting to the supervisors</td>
<td>Supervisor filter</td>
<td>No agents</td>
</tr>
<tr>
<td>User-defined partition assigned to the user</td>
<td>Standard partition assigned to the user</td>
<td>Filter applied to the display</td>
<td>Data the user sees in the agent display (public or private)</td>
</tr>
<tr>
<td>------------------------------------------</td>
<td>---------------------------------------</td>
<td>------------------------------</td>
<td>----------------------------------------------------------</td>
</tr>
<tr>
<td>Yes</td>
<td>One or more supervisor partitions, but no agents reporting to the supervisors</td>
<td>Custom filter</td>
<td>Agents included in the custom filter</td>
</tr>
<tr>
<td>Yes (no agents selected)</td>
<td>No Data</td>
<td>No (supervisor filters are not available, agents are not available for custom filters)</td>
<td>No agents</td>
</tr>
</tbody>
</table>

The following table describes the data that is visible for creating or modifying a real-time display filter.

<table>
<thead>
<tr>
<th>User-defined partition assigned to user</th>
<th>Standard partition assigned to user</th>
<th>Data the user sees when managing filters</th>
</tr>
</thead>
<tbody>
<tr>
<td>No, Full Data partition selected</td>
<td>No, Full Data partition selected</td>
<td>All agents, all skillsets, all applications</td>
</tr>
<tr>
<td>No or Yes with no agents, no skillsets, or no applications selected</td>
<td>One or more supervisor partitions</td>
<td>Agents reporting to selected supervisors</td>
</tr>
<tr>
<td>No or Yes with no agents, no skillsets, or no applications selected</td>
<td>All skillsets</td>
<td>Standard supervisor filters for the selected supervisors</td>
</tr>
<tr>
<td></td>
<td>All applications</td>
<td>All skillsets</td>
</tr>
<tr>
<td></td>
<td></td>
<td>All applications</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No standard supervisor filters for agent and skillset displays</td>
</tr>
<tr>
<td>User-defined partition assigned to user</td>
<td>Standard partition assigned to user</td>
<td>Data the user sees when managing filters</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>------------------------------------</td>
<td>----------------------------------------</td>
</tr>
<tr>
<td>No or Yes with no agents, no skillsets, or no applications selected</td>
<td>One or more supervisor partitions</td>
<td>Agents reporting to the selected Supervisors</td>
</tr>
<tr>
<td></td>
<td>All skillsets</td>
<td>All skillsets</td>
</tr>
<tr>
<td></td>
<td>All applications</td>
<td>All applications</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Standard supervisor filters for each selected supervisor partition for agent and skillset displays</td>
</tr>
</tbody>
</table>

| No or Yes with no agents, no skillsets, or no applications selected | One or more supervisor partitions, but with no agents reporting to the supervisors | All skillsets |
| | All skillsets | All applications |
| | | Standard supervisor filters for each selected supervisor partition for agent and skillset displays |

| Yes (includes agents, skillsets, and applications) | No | All skillsets |
| | | All applications |
| | | Standard supervisor filters for each selected supervisor partition for agent and skillset displays |

<p>| Yes (includes skillsets and applications) | One or more supervisor partitions | Agents assigned to the selected supervisors |
| | | Skillsets and applications included in the user-defined partition |
| | | Standard supervisor filters for each selected supervisor partition for agent and skillset real-time displays |</p>
<table>
<thead>
<tr>
<th>User-defined partition assigned to user</th>
<th>Standard partition assigned to user</th>
<th>Data the user sees when managing filters</th>
</tr>
</thead>
</table>
| Yes (includes skillsets and applications) | All agents | All agents  
Skillsets and applications included in the user-defined partition  
Standard supervisor filters for all supervisors for agent and skillset real-time displays |
| Yes (includes agents, skillsets, and applications) | One or more supervisor partitions | Agents, skillsets, and applications included in the user-defined partition  
Agents assigned to selected supervisors  
Standard supervisor filters for each of the selected supervisor partitions for agent and skillset real-time displays |
| Yes (includes agents, skillsets, and applications) | One or more supervisor partitions, but with no agents reporting to these supervisors  
All skillsets  
All applications | Agents in custom partition and agents assigned to the selected supervisor (none), All skillsets, all applications  
Standard supervisor filters for each selected supervisor partition for agent and skillset real-time displays |
<table>
<thead>
<tr>
<th>User-defined partition assigned to user</th>
<th>Standard partition assigned to user</th>
<th>Data the user sees when managing filters</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes (includes skillsets and applications)</td>
<td>Yes (all agents and all skillsets and all applications)</td>
<td>All agents, all skillsets, all applications</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Standard supervisor filters for all the supervisors for agent and skillset real-time displays</td>
</tr>
<tr>
<td>Yes (includes skillsets and applications)</td>
<td>No or No Data selected for the server</td>
<td>No agents, skillsets, and applications included in custom partition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No standard supervisor filters for agent and skillset displays</td>
</tr>
<tr>
<td>Yes (includes no agents, no skillsets, and no applications)</td>
<td>No or No data selected for the server</td>
<td>No agents, no skillsets, and no applications</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No standard supervisor filters for agent and skillset displays</td>
</tr>
</tbody>
</table>
Historical Reporting

In Historical Reporting, if a user has one of the following partition configurations in Access and Partition Management, the user can see all agents and supervisors when running reports for the Contact Center Manager Server:

- Full Data Access Across All Servers
- All Data for the Contact Center Manager Server
- All Agents & Supervisors

The following table shows how partitions and reporting agent configurations assigned to a user affect the selection criteria data in Historical Reporting for that user.

<table>
<thead>
<tr>
<th>Access and Partition Management configuration for Historical Reporting</th>
<th>Data available to the user in Historical Reporting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Full Data Across All Servers</td>
<td>All agents</td>
</tr>
<tr>
<td></td>
<td>All supervisors</td>
</tr>
<tr>
<td></td>
<td>All skillsets</td>
</tr>
<tr>
<td></td>
<td>All applications</td>
</tr>
<tr>
<td></td>
<td>All CDNs (Route Points)</td>
</tr>
<tr>
<td></td>
<td>All DNISs</td>
</tr>
<tr>
<td>All Data (for a Contact Center Manager Server)</td>
<td>All agents</td>
</tr>
<tr>
<td></td>
<td>All supervisors</td>
</tr>
<tr>
<td></td>
<td>All skillsets</td>
</tr>
<tr>
<td></td>
<td>All applications</td>
</tr>
<tr>
<td></td>
<td>All CDNs (Route Points)</td>
</tr>
<tr>
<td></td>
<td>All DNISs</td>
</tr>
<tr>
<td>All Agents &amp; Supervisors (for a Contact Center Manager Server)</td>
<td>All agents</td>
</tr>
<tr>
<td></td>
<td>All supervisors</td>
</tr>
<tr>
<td>Access and Partition Management configuration for Historical Reporting</td>
<td>Data available to the user in Historical Reporting</td>
</tr>
<tr>
<td>---------------------------------------------------------------------</td>
<td>-------------------------------------------------</td>
</tr>
<tr>
<td>All Applications (for a Contact Center Manager Server)</td>
<td>All applications</td>
</tr>
<tr>
<td>All CDNs (for a Contact Center Manager Server)</td>
<td>All CDNs (Route Points)</td>
</tr>
<tr>
<td>All DNIS (for a Contact Center Manager Server)</td>
<td>All DNISs</td>
</tr>
<tr>
<td>All Skillsets (for a Contact Center Manager Server)</td>
<td>All skillsets</td>
</tr>
<tr>
<td>Reporting Agents (for a Contact Center Manager Server)</td>
<td>Only those supervisors that are assigned to the user, for the Contact Center Manager Server, under Reporting Agents and the agents assigned to the assigned supervisors. For example, if the user is assigned Agent By Supervisor under Reporting Agents, the user can see those supervisors and the agents (belonging to those supervisors) in the historical reports.</td>
</tr>
<tr>
<td>Access and Partition Management configuration for Historical Reporting</td>
<td>Data available to the user in Historical Reporting</td>
</tr>
<tr>
<td>---------------------------------------------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>User-defined partitions</td>
<td>Only elements that are assigned in the selected user-defined partitions. Available elements are agents, skillsets, applications, CDNs (Route Points) and DNISs. For example, if a user-defined partition contains 100 agents and the Contact Center Manager Server contains 1000 agents, the user can see the only 100 agents assigned to the user-defined partition when running a report with the agent element (Agent Performance report). As another example, if a user-defined partition contains 50 skillsets and Contact Center Manager Server contains 350 skillsets, the user can see only 50 skillsets when running a report with the skillset element (Skillset Performance report).</td>
</tr>
</tbody>
</table>
Contact Center Management

In Contact Center Management, if users do not have a partition assigned to them, they see all agent data, regardless of whether they have a supervisor/reporting agent combination assigned to their user profile.

The administrator can also control the data users see in Contact Center Management by assigning access classes to them. Access classes can restrict the windows or portions of windows that users can open in the application and the actions users can perform. In addition, if the administrator assigns users the *Use Agent & Skillset Partitions in CCM* access class, then they are restricted to viewing only their partitioned skillsets (in addition to their partitioned agents, which is the default behavior).

<table>
<thead>
<tr>
<th>User-defined partition assigned to user?</th>
<th>Standard and supervisor partitions assigned to user?</th>
<th>Data the user sees in Contact Center Management</th>
</tr>
</thead>
<tbody>
<tr>
<td>No, Full Data Across All Servers partition selected</td>
<td>Full Data Across All Servers partition selected</td>
<td>All agents&lt;br&gt;All supervisors&lt;br&gt;All skillsets</td>
</tr>
<tr>
<td>No or Yes, with no agents and no skillsets selected</td>
<td>one or more supervisor partitions</td>
<td>Agents reporting to the selected supervisors&lt;br&gt;selected supervisors</td>
</tr>
<tr>
<td>No or Yes, with no agents and no skillsets selected</td>
<td>one or more supervisor partitions standard partition All Skillsets</td>
<td>Agents reporting to the selected supervisors&lt;br&gt;selected supervisors&lt;br&gt;All skillsets</td>
</tr>
<tr>
<td>User-defined partition assigned to user?</td>
<td>Standard and supervisor partitions assigned to user?</td>
<td>Data the user sees in Contact Center Management</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-------------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>No or Yes, with no agents and no skillsets selected</td>
<td>one or more supervisor partitions with no agents reporting to the supervisors All skillsets</td>
<td>Selected supervisors All skillsets</td>
</tr>
<tr>
<td>No or Yes, with no agents and no skillsets selected</td>
<td>All skillsets</td>
<td>No agents No supervisors All skillsets</td>
</tr>
<tr>
<td>Yes (includes agents and skillsets)</td>
<td>No - Set to No Data</td>
<td>Agents and skillsets included in the user-defined partition All supervisors</td>
</tr>
<tr>
<td>Yes (includes agents only)</td>
<td>No - Set to No Data</td>
<td>Agents included in the user-defined partition All supervisors</td>
</tr>
<tr>
<td>Yes (includes skillsets only)</td>
<td>No - Set to No Data</td>
<td>Skillsets included in the user-defined partition All supervisors</td>
</tr>
<tr>
<td>Yes (includes skillsets only)</td>
<td>One or more supervisor partitions</td>
<td>Agents reporting to the selected supervisors selected supervisors Skillsets included in the user-defined partition</td>
</tr>
<tr>
<td>User-defined partition assigned to user?</td>
<td>Standard and supervisor partitions assigned to user?</td>
<td>Data the user sees in Contact Center Management</td>
</tr>
<tr>
<td>-----------------------------------------</td>
<td>---------------------------------------------------</td>
<td>-----------------------------------------------</td>
</tr>
<tr>
<td>Yes (includes agents and skillsets)</td>
<td>One or more supervisor partitions</td>
<td>Agents included in the user-defined partition</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Agents reporting to the selected supervisors</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Selected supervisors from the supervisor partitions</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Skillsets included in the user-defined partition</td>
</tr>
<tr>
<td>Yes, with no agents and no skillsets selected</td>
<td>No - Set to Configure, but no standard and no supervisor partitions selected</td>
<td>No agents</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No supervisors</td>
</tr>
<tr>
<td></td>
<td></td>
<td>No skillsets</td>
</tr>
</tbody>
</table>
Appendix C

Configuration data tables

In this appendix

Overview 472
CS1000/Meridian 1 Nodal Configuration 473
CS1000/Meridian 1 configuration 477
CS2x00/DMS configuration 482
Network Control Center configuration 488
Overview

The following tables describe the configuration components for the following platforms:

- CS1000/Meridian 1 Nodal Configuration
- CS1000/Meridian 1 configuration
- CS2x00/DMS configuration
- Network Control Center configuration
## CS1000/Meridian 1 Nodal Configuration

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| Activity codes       | A number that an agent can enter on their phoneset to track the amount of time spent on specific activities or service areas or to track Not Ready reasons. Agents can enter up to three activity codes during a single call. If the agent enters no activity code, the call defaults to the system default activity code. You cannot overwrite the following default activity codes:  
  - activity code 0000 (NotRdy_Pull_Mode_Default_Code)  
  - activity code 000 (Not_Ready_Default_Reason_Code)  
  - activity code 00 (Skillset_Default_Activity_Code)  
  - activity code 0 (System_Default_Activity_Code) |
| Call presentation    | A set of options that determines how calls are presented to an agent’s phoneset. You can choose the following presentation methods:  
  - Automatically answer the call at the agent’s phoneset (call forcing).  
  - Return the call to the queue if the call is not answered within a specified period.  
  - Allow the call to ring at the agent’s phoneset until it is answered or abandoned. In addition, you can choose whether to present calls to agents when they are busy on a DN call, and whether to allow the agent time to wrap up a call after it ends. The call force delay timer forces the agent to answer the call after a certain amount of time expires. The call is presented while the call force timer counts down. After the timer expires, the agent is presented with the call. |
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDNs (Route points)</td>
<td>Used to queue calls to the switch and to send messages to the Contact Center Manager Server regarding these calls. To ensure that the Contact Center Manager Server can track when calls terminate at a CDN (Route Point), you must first add a CDN (Route Point) at the switch, then add the corresponding information at the server, and then acquire the CDN (Route Point).</td>
</tr>
<tr>
<td>Contact types</td>
<td>The media types by which (inbound) contacts arrive into a contact center and by which a contact center sends (outbound) contacts.</td>
</tr>
<tr>
<td>DNISs</td>
<td>A method by which the system recognizes the phone number that a caller dials. Agents can receive calls from customers calling in on different DNISs and customize their response according to the DNIS that appears on the phoneset display. Based on the DNIS, the system can direct calls to a controlled CDN and supply different treatments.</td>
</tr>
<tr>
<td>Global Settings</td>
<td>The global values on the Contact Center Manager Server, which includes all configured IVR ACD-DNs and Routes on your system. You must configure the following:</td>
</tr>
<tr>
<td></td>
<td>- To use Meridian Mail to provide voice processing services, configure the global IVR ACD-DN settings.</td>
</tr>
<tr>
<td></td>
<td>- You configure IVR ACD-DNs and Routes only on a Communication Server 1000/Meridian 1 switch.</td>
</tr>
<tr>
<td></td>
<td>- The agent idle time preference skillset setting applies to all skillsets configured on your system.</td>
</tr>
</tbody>
</table>
### Item | Description
--- | ---
Historical Statistics | The following historical statistics collection options:
- the general system parameter values, such as the number of skillsets
- the type of call flow, agent, and IVR historical statistics to be collected
- the applications for which call-by-call data is collected
- the length of time that historical statistics store on Contact Center Manager Server
- the amount of disk space required to run your selected configuration, and you can specify the first business day of the week

IVR ACD-DNs | A Meridian Mail, CallPilot, or IVR queue to which voice-processing calls are directed. Each IVR ACD-DN must have dedicated voice ports to provide voice-processing treatment for different call types. An IVR ACD-DN must be acquired for both integrated and non-integrated systems.

To include GIVE IVR elements in your scripts, you must configure IVR ACD-DNs.

Phoneset displays | The text that appears on an LCD display. The LCD displays on phonesets so that all phonesets of a specific type display the same information.

You can also create custom labels that help define the information appearing on the phoneset display.

Phonesets and voice ports | Add and acquire each phoneset that an agent or supervisor uses to log on to the system. After Contact Center Manager Server acquires a phoneset, the Communication Server 1000/Meridian 1 PBX switch sends messages about these phonesets to the system.
Configure Contact Center Manager Server to collect the types of statistics that you want to see in the Real-Time Reporting displays. You can configure the following seven types of predefined real-time statistics:

- skillset statistics (mandatory)
- nodal statistics (mandatory)
- application statistics
- IVR statistics (Communication Server 1000/Meridian 1 and Communication Server 2x00/DMS)
- route statistics (CS1000/Meridian 1 switch only)
- agent statistics
- network statistics (CS1000/Meridian 1 switch only)

A group of trunks. Each trunk carries either incoming or outgoing calls to the switch. To create All Trunks Busy (ATB) reports, you must acquire at least one route. Before you can create a route, you must configure it on the Communication Server 1000/Meridian 1 switch, and add the threshold class that is assigned to it in Contact Center Manager Server.

The ability or group of abilities necessary to answer a specific type of call. Skillsets are the basic building blocks of skill-based routing. Skillsets are used to match callers with the agents who can best meet the callers’ needs.

Specify how statistics are treated in reports and real-time displays. You can create threshold classes to distinguish between types of information that the system collects.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| Real-time statistics| Configure Contact Center Manager Server to collect the types of statistics that you want to see in the Real-Time Reporting displays. You can configure the following seven types of predefined real-time statistics:  
  - skillset statistics (mandatory)  
  - nodal statistics (mandatory)  
  - application statistics  
  - IVR statistics (Communication Server 1000/Meridian 1 and Communication Server 2x00/DMS)  
  - route statistics (CS1000/Meridian 1 switch only)  
  - agent statistics  
  - network statistics (CS1000/Meridian 1 switch only) |
| Routes              | A group of trunks. Each trunk carries either incoming or outgoing calls to the switch. To create All Trunks Busy (ATB) reports, you must acquire at least one route. Before you can create a route, you must configure it on the Communication Server 1000/Meridian 1 switch, and add the threshold class that is assigned to it in Contact Center Manager Server. |
| Skillsets           | The ability or group of abilities necessary to answer a specific type of call. Skillsets are the basic building blocks of skill-based routing. Skillsets are used to match callers with the agents who can best meet the callers’ needs. |
| Threshold classes   | Specify how statistics are treated in reports and real-time displays. You can create threshold classes to distinguish between types of information that the system collects. |
## CS1000/Meridian 1 configuration

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| Activity codes        | A number that an agent can enter on their phoneset to track the amount of time spent on specific activities or service areas or to track Not Ready reasons. Agents can enter up to three activity codes during a single call. If the agent enters no activity code, the call defaults to the system default activity code. You cannot overwrite the following default activity codes:  
- activity code 0000 (NotRdy_Pull_Mode_Default_Code)  
- activity code 000 (Not_Ready_Default_Reason_Code)  
- activity code 00 (Skillset_Default_Activity_Code)  
- activity code 0 (System_Default_Activity_Code)     |
| Call presentation     | A set of options that determines how calls are presented to an agent’s phoneset. You can choose the following presentation methods:  
- Automatically answer the call at the agent’s phoneset (call forcing).  
- Return the call to the queue if the call is not answered within a specified period.  
- Allow the call to ring at the agent’s phoneset until it is answered or abandoned.  
In addition, you can choose whether to present calls to agents when they are busy on a DN call, and whether to allow the agent time to wrap up a call after it ends. The call force delay timer forces the agent to answer the call after a certain amount of time expires. The call is presented while the call force timer counts down. After the timer expires, the agent is presented with the call. |
<p>| classes               |                                                                                                                                                                                                                      |</p>
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDNs (Route points)</td>
<td>Used to queue calls to the switch and to send messages to the Contact Center Manager Server regarding these calls.</td>
</tr>
<tr>
<td></td>
<td>To ensure that the Contact Center Manager Server can track when calls terminate at a CDN (Route Point), you must first add a CDN (Route Point) at the switch, then add the corresponding information at the server, and then acquire the CDN (Route Point).</td>
</tr>
<tr>
<td>Contact types</td>
<td>The media types by which (inbound) contacts arrive into a contact center and by which a contact center sends (outbound) contacts.</td>
</tr>
<tr>
<td>DNISs</td>
<td>A method by which the system recognizes the phone number that a caller dials. Agents can receive calls from customers calling in on different DNISs and customize their response according to the DNIS that appears on the phoneset display. Based on the DNIS, the system can direct calls to a controlled CDN and supply different treatments.</td>
</tr>
<tr>
<td>Global Settings</td>
<td>The global values on the Contact Center Manager Server, which includes all configured IVR ACD-DNs and Routes on your system. You must configure the following:</td>
</tr>
<tr>
<td></td>
<td>■ To use Meridian Mail to provide voice processing services, configure the global IVR ACD-DN settings.</td>
</tr>
<tr>
<td></td>
<td>■ You configure IVR ACD-DNs and Routes only on a Communication Server 1000/Meridian 1 switch.</td>
</tr>
<tr>
<td></td>
<td>■ The agent idle time preference skillset setting applies to all skillsets configured on your system.</td>
</tr>
</tbody>
</table>
The following historical statistics collection options:

- the general system parameter values, such as the number of skillsets
- the type of call flow, agent, and IVR historical statistics to be collected
- the applications for which call-by-call data is collected
- the length of time that historical statistics store on Contact Center Manager Server
- the amount of disk space required to run your selected configuration, and you can specify the first business day of the week

A Meridian Mail, CallPilot, or IVR queue to which voice-processing calls are directed. Each IVR ACD-DN must have dedicated voice ports to provide voice-processing treatment for different call types. An IVR ACD-DN must be acquired for both integrated and non-integrated systems.

To include GIVE IVR elements in your scripts, you must configure IVR ACD-DNs.

The text that appears on an LCD display. The LCD displays on phonesets so that all phonesets of a specific type display the same information.

You can also create custom labels that help define the information appearing on the phoneset display.

Add and acquire each phoneset that an agent or supervisor uses to log on to the system. After Contact Center Manager Server acquires a phoneset, the Communication Server 1000/Meridian 1 PBX switch sends messages about these phonesets to the system.
**Network Communication Parameters**

View or modify the network communication parameters for any site on the network. You must configure the following network communication parameters on each server in the network:

- Landing Pad type
- Dialable DN/Prefix
- Number of Retries—the number of times your server tries to queue calls to the site after a route attempt fails and the number of seconds between retries
- Retry timer—the amount of time an agent at the site is reserved to answer a call routed from your server

**Real-time statistics**

Configure Contact Center Manager Server to collect the types of statistics that you want to see in the Real-Time Reporting displays. You can configure the following seven types of predefined real-time statistics:

- skillset statistics (mandatory)
- nodal statistics (mandatory)
- application statistics
- IVR statistics (Communication Server 1000/Meridian 1 and Communication Server 2x00/DMS)
- route statistics (CS1000/Meridian 1 switch only)
- agent statistics
- network statistics (CS1000/Meridian 1 switch only)

**Routes**

A group of trunks. Each trunk carries either incoming or outgoing calls to the switch. To create All Trunks Busy (ATB) reports, you must acquire at least one route. Before you can create a route, you must configure it on the Communication Server 1000/Meridian 1 switch, and add the threshold class that is assigned to it in Contact Center Manager Server.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network</td>
<td>View or modify the network communication parameters for any site on the network. You must configure the following network communication parameters on each server in the network:</td>
</tr>
<tr>
<td>Communication</td>
<td></td>
</tr>
<tr>
<td>Parameters</td>
<td></td>
</tr>
<tr>
<td>Real-time</td>
<td>Configure Contact Center Manager Server to collect the types of statistics that you want to see in the Real-Time Reporting displays. You can configure the following seven types of predefined real-time statistics:</td>
</tr>
<tr>
<td>statistics</td>
<td></td>
</tr>
<tr>
<td>Routes</td>
<td>A group of trunks. Each trunk carries either incoming or outgoing calls to the switch. To create All Trunks Busy (ATB) reports, you must acquire at least one route. Before you can create a route, you must configure it on the Communication Server 1000/Meridian 1 switch, and add the threshold class that is assigned to it in Contact Center Manager Server.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Skillsets</td>
<td>The ability or group of abilities necessary to answer a specific type of call. Skillsets are the basic building blocks of skill-based routing. Skillsets are used to match callers with the agents who can best meet the callers' needs.</td>
</tr>
<tr>
<td>Threshold classes</td>
<td>Specify how statistics are treated in reports and real-time displays. You can create threshold classes to distinguish between types of information that the system collects.</td>
</tr>
</tbody>
</table>
## CS2x00/DMS configuration

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
</table>
| Activity codes        | A number that an agent can enter on their phoneset to track the amount of time spent on specific activities or service areas or to track Not Ready reasons. Agents can enter up to three activity codes during a single call. If the agent enters no activity code, the call defaults to the system default activity code. You cannot overwrite the following default activity codes:  
  - activity code 0000 (NotRdy_Pull_Mode_Default_Code)  
  - activity code 000 (Not_Ready_Default_Reason_Code)  
  - activity code 00 (Skillset_Default_Activity_Code)  
  - activity code 0 (System_Default_Activity_Code) |
| Call presentation     | A set of options that determines how calls are presented to an agent’s phoneset. You can choose the following presentation methods:  
  - Automatically answer the call at the agent’s phoneset (call forcing)  
  - Return the call to the queue if the call is not answered within a specified period.  
  - Allow the call to ring at the agent’s phoneset until it is answered or abandoned.  
  Call forcing does not support configurable delay timer. You can choose whether to present calls to agents when they are busy on a DN call.  
  Some call presentation transitions will only take effect at the next agent log in while other take effect immediately. Changing to Call Forcing after any Return to Queue or Let Call Ring requires the agent to log in again. The other transitions are available immediately.  
classes               |
<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDNs (Route points)</td>
<td>Used to queue calls to the switch and to send messages to the Contact Center Manager Server regarding these calls.</td>
</tr>
<tr>
<td></td>
<td>To ensure that the Contact Center Manager Server can track when calls terminate at a CDN (Route Point), you must first add a CDN (Route Point) at the switch, then add the corresponding information at the server, and then acquire the CDN (Route Point).</td>
</tr>
<tr>
<td>Contact types</td>
<td>The media types by which (inbound) contacts arrive into a contact center and by which a contact center sends (outbound) contacts.</td>
</tr>
<tr>
<td>DNISs</td>
<td>A method by which the system recognizes the phone number that a caller dials. Agents can receive calls from customers calling in on different DNISs and customize their response according to the DNIS that appears on the phoneset display. Based on the DNIS, the system can direct calls to a controlled CDN and supply different treatments.</td>
</tr>
<tr>
<td>Item</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Global Settings</td>
<td>The global values on the Contact Center Manager Server, which includes all configured IVR ACD-DNs and Routes on your system. You must configure the following:</td>
</tr>
</tbody>
</table>
|                   | ■ The agent order preference  
|                   | ■ Default Music/RAN route  
|                   | ■ Data delimiter  
|                   | ■ GIVE IVR settings  
|                   | ■ Provider ID—Specifies the HDX Provider ID for the GIVE IVR feature for communication between CCMS and CCTIVR. (default 1, minimum 0, maximum 1999999999)  
|                   | ■ Timer—Timeout by CCMS when waiting for a response to a HDX request to CCTIVR. (default 10, minimum 0, maximum 65535)  
|                   | ■ Dial Plan—Identifies the number of digits of the IVR ACD-DN that is used to dial the IVR ACD-DN. (default 5, minimum 4, maximum 10)  
|                   | ■ Data Exchange Type—Identifies the method of passing the treatment DN to CCTIVR. (valid: SEND REQUEST/GET RESPONSE, SEND INFO, default SEND REQUEST/GET RESPONSE)  |
Global settings (continued)

- **DNIS Source order**—Provides the ability to select the order of the source for the DNIS of the call. The source of the DNIS is specified. The valid available sources for DNIS are:
  - CallHistoryInfo_origInboundDN
  - forwardingParty_firstFwdNumber
  - forwardingParty_lastFwdNumber
  - acdDN
  - acdGroup

The default selected sources for DNIS are:
- CallHistoryInfo_origInboundDN (default)
- forwardingParty_firstFwdNumber (default)
- acdDN (default)
- acdGroup (default)

Historical Statistics

- The following historical statistics collection options:
  - the general system parameter values, such as the number of skillsets
  - the type of call flow, agent, and IVR historical statistics to be collected
  - the applications for which call-by-call data is collected
  - the length of time that historical statistics store on Contact Center Manager Server
  - the amount of disk space required to run your selected configuration, and you can specify the first business day of the week
**Item** | **Description**
---|---
IVR ACD-DNs | A Meridian Mail, CallPilot, or IVR queue to which voice-processing calls are directed. Each IVR ACD-DN must have dedicated voice ports to provide voice-processing treatment for different call types. An IVR ACD-DN must be acquired for both integrated and non-integrated systems.

To include GIVE IVR elements in your scripts, you must configure IVR ACD-DNs.

Phoneset displays | The text that appears on an LCD display. The LCD displays on phonesets so that all phonesets of a specific type display the same information. The LCD display is limited to 15 characters on one line on the Communication Server 2X00 switch. On the Communication Server 2X00, you cannot display the Trunk Number, Route Name, Route Number, Queue Time and CLID Name.

Phonesets | Add and acquire each phoneset that agents and supervisors use to log on to the system. When the server in Contact Center Manager Server acquires a phoneset, the Communication Server 2x00/DMS switch begins sending phoneset data to the server.

Real-time statistics | Configure Contact Center Manager Server to collect the types of statistics that you want to see in the Real-Time Reporting displays. You can configure the following seven types of predefined real-time statistics:
- skillset statistics (mandatory)
- nodal statistics (mandatory)
- application statistics
- IVR statistics
- agent statistics

Skillsets | The ability or group of abilities necessary to answer a specific type of call. Skillsets are the basic building blocks of skill-based routing. Skillsets are used to match callers with the agents who can best meet the callers' needs.
## Threshold classes

Specify how statistics are treated in reports and real-time displays. You can create threshold classes to distinguish between types of information that the system collects.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Threshold classes</td>
<td>Specify how statistics are treated in reports and real-time displays. You can create threshold classes to distinguish between types of information that the system collects.</td>
</tr>
</tbody>
</table>
# Network Control Center configuration

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Historical Statistics</td>
<td>The length of time to store network call-by-call statistics at the Network Control Center (NCC). Your configuration determines:</td>
</tr>
<tr>
<td></td>
<td>■ the amount of data included in your network call-by-call reports</td>
</tr>
<tr>
<td></td>
<td>■ the amount of disk space required on the NCC</td>
</tr>
<tr>
<td>Network Skillsets</td>
<td>A skillset defined on the NCC that is common to all sites in the network. Calls routed to a network skillset can be sent to any Contact Center Manager Server in the network that has that skillset. You can define a maximum of 1000 local and network skillsets.</td>
</tr>
<tr>
<td>Sites</td>
<td>A location in the network with a Communication Server 1000/ Meridian 1 switch or a Universal Networking enabled switch and a Contact Center Manager Server. You must configure the Network Control Center (NCC) with information about each site in the network so that it can communicate with the network servers and enable the servers to communicate with each other.</td>
</tr>
</tbody>
</table>
Appendix D

Troubleshooting

In this chapter

Technical support 490
Section A: General troubleshooting items 491
Section B: Access and Partition Management 503
Section C: Contact Center Management 507
Section D: Historical Reporting 509
Section E: Real-Time Reporting 523
Section F: Report Creation Wizard 543
Technical support

If you experience technical difficulties, ensure that you download the latest Service Updates and documentation for both Contact Center Manager Server and Contact Center Manager Administration. You can download the latest documentation from either www.nortel.com (for end customers) or www.nortel.com/prd/picinfo (for distributors), and the latest Service Updates from www.nortel.com/espl.

To register for the ESPL Web site, follow the instructions listed at nortel.com/register.

Remote support

Nortel personnel use pcAnywhere as the preferred remote support tool. Alternatively, Nortel also accepts Microsoft Remote Desktop Connection as a remote support tool. To install your remote support access tool, see the Contact Center Manager Administration Installation and Maintenance Guide.

Nortel recommends that you only install one of the supported remote access tools (pcAnywhere or Remote Desktop Connection) on the Contact Center Manager Administration server.
Section A:  General troubleshooting items

In this section

CCMA functions incorrectly following a change to the CCMS  492
You have display problems on the client PC  494
Problems while running two sessions on one client PC  495
System tree icons are missing  496
Problems with Select All in CCMA components  497
Contents from the about:blank Web site blocked by IE Enhanced Security Configuration  499
You cannot launch CCMA windows; pop-ups are blocked  500
Contact Center Manager Administration logon screen displays ERROR:UNKNOWN!  502
CCMA functions incorrectly following a change to the CCMS

You made a change to the Contact Center Manager Server (CCMS) (for example, you performed an upgrade, installed or uninstalled a service update (SU), changed to a standby Contact Center Manager Server, or received a new license file) and Contact Center Manager Administration (CCMA) no longer functions correctly. For example, pages and tabs do not load correctly, new components and features are unavailable, or scripting errors occur.

Solution

Ensure that you refresh your Contact Center Manager Servers. Although Contact Center Manager Administration automatically refreshes all servers every 12 hours, Nortel recommends that you manually refresh servers in the following scenarios to ensure that Contact Center Manager Administration functions correctly.

If any of the following situations occur, use the Refresh All Servers option to refresh all servers at the same time:

- You upgrade from Symposium Web Client 4.5 SUS0601 v1 or later, or you upgrade from a previous version of Contact Center Manager Administration.

- The Contact Center Manager Administration server is changed to connect to a standby Contact Center Manager Server.

If any of the following situations occur, use the Refresh Server option to refresh only the Contact Center Manager Server that incurs a change:

- You upgrade the Symposium Call Center Server or Contact Center Manager Server.

- You install or uninstall a Service Update (SU) on the Contact Center Manager Server.

- A new license file is issued and accepted by Contact Center Manager Server, or you connect to a different License Manager server (that is, a new or standby License Manager server).
If you change the password of the sysadmin user in the Server Utility, you need to change the password in that server.

For step-by-step information about refreshing one or all servers, see the *Contact Center Manager Administration Installation and Maintenance Guide*. 
You have display problems on the client PC

If the layout of the Web interface in Contact Center Manager Administration is distorted, perform these procedures.

Checking the display settings of your computer

1. Click **Start > Settings > Control Panel**.
2. Double-click the **Display** icon.
3. On the **Settings** tab, drag the slider in the **Desktop area** box until the value reads at least 1024 x 768 pixels (it cannot be lower than this value).
4. From the **Font size** list, select **Small Fonts**.
5. Click **OK** to save your changes.

Setting the font size in Internet Explorer

In Internet Explorer, on the **View** menu, click **Text Size > Medium**.

Resizing the font

If the text or content displayed in Internet Explorer is too large for the window, and you cannot resize the window, perform the following step:

In Internet Explorer, on the **View** menu, click **Text Size > Smaller** or **Text Size > Smallest**.
Problems while running two sessions on one client PC

You run more than one Contact Center Manager Administration session at once on the same client PC and experience difficulty.

Solution

For proper Contact Center Manager Administration function, you must not run more than one Contact Center Manager Administration session at one time on a single client PC. In certain scenarios, if you run more than one session simultaneously on a client PC (with different Contact Center Manager Administration users), interference can occur between the sessions. In this situation, you must close all open sessions except one.
System tree icons are missing

System tree icons are missing in the Contact Center Manager Administration Internet browser. Additionally, you cannot create new supervisors and agents in the Contact Center Management component. This occurs when the SSPNG2.dll file does not download to c:\windows\system32 during the Contact Center Manager Administration installation.

Solution

Extract SSPNG2.dll from C:\Program Files\Nortel Networks\WClient\Apps\Common\Controls\ccTree.cab into C:\windows\system32.
Problems with Select All in CCMA components

Your client PC (or the Contact Center Manager Administration [CCMA] server if you use it as a client PC) is running Windows Server 2003 (Enterprise or Standard Edition). When you open certain pages in Contact Center Management, Access and Partition Management, or Historical Reporting, you cannot use the Select All button to select all agents, skillsets, or access classes, and the Submit button remains disabled when you click Select All. In addition, the Submit button remains disabled when you click individual agents, skillsets, or access classes.

In Access and Partition Management, when you view a partition and you select a user from the Members area, you cannot see the selected user’s details.

Solution

This problem occurs only on PCs that run Windows Server 2003 and that are used to connect to Contact Center Manager Administration. When Internet Explorer is used on a Windows Server 2003 platform, it includes the new Internet Explorer Enhanced Security Configuration, which is enabled by default. This configuration is designed to decrease the exposure of the server to potential attacks that can occur through Web content and application scripts.

One of the features of this configuration is to automatically block Web sites that are not listed in the Trusted Sites zone. In Contact Center Manager Administration, certain pages in Contact Center Management, Historical Reporting, and Access and Partition Management that contain lists of agents, skillsets, and access classes make use of a behind-the-scenes URL called about:blank to display the information correctly. Even after you add the Contact Center Manager Administration server URL as a Trusted Site (for example, http://ccmaservername), you still need to add the about:blank URL as a trusted site as well. Doing so ensures that the about:blank URL is not blocked by Internet Explorer and that the Select All and Submit buttons function properly.
Adding the about:blank URL as a Trusted Site

1. On the client PC (or the Contact Center Manager Administration server if used as a client PC) running Windows Server 2003, open Internet Explorer.

2. From the menu bar, select Tools > Internet Options.
   
   **Result:** The Internet Options window appears.

3. Click the Security tab.

4. Click the Trusted Sites icon.

5. Click Sites.
   
   **Result:** The Trusted sites window appears.

6. Ensure that the Require server verification {https:} for all sites in this zone check box is not selected.

7. In the Add this web site to the zone box, type about:blank.

8. Click Add.

9. Ensure that about:blank appears correctly in the Web sites box.

10. Click OK to save your changes and return to the Internet Options window.

11. Click OK to close the Internet Options window.
Contents from the about:blank Web site blocked by IE Enhanced Security Configuration

You receive a message that contents from the about:blank Web site are blocked by Internet Explorer Enhanced Security Configuration.

Solution

For the solution to this problem, see “Problems with Select All in CCMA components” on page 497.
You cannot launch CCMA windows; pop-ups are blocked

When you attempt to launch a window in Contact Center Manager Administration, the window does not open. You may be presented with a message that states “Pop ups were blocked on this page.”

Solution

You have a pop-up blocker enabled on the client PC. To access all Contact Center Manager Administration functions, disable all pop-up blockers. For directions to disable Yahoo pop-up blockers, see “Turning off the Yahoo pop-up blocker” on page 500. For directions to disable Google pop-up blockers, see “Turning off the Google pop-up blocker” on page 501. For directions to disable the pop-up blocker provided with Windows XP Service Pack 2, see “Turning off the Windows XP Service Pack 2 pop-up blocker” on page 501.

Several pop-up blockers are available and the procedure to disable them may differ from the procedures listed here. For information about how to disable pop-up blockers not listed here, contact the pop-up blocker provider.

Turning off the Yahoo pop-up blocker

1. Launch Internet Explorer.

2. On the Yahoo toolbar at the top of the browser window, position the pointer over each of the buttons until you find the one with the tooltip Pop-Up Blocker Is On or Pop-Up Blocker Is Off.

   The button is normally to the left of the Highlight button.

3. Click the button with the tooltip Pop-Up Blocker Is On or Pop-Up Blocker Is Off to expand the menu.

4. Ensure the option Enable Pop-Up Blocker is switched off.
**Turning off the Google pop-up blocker**

1. Launch **Internet Explorer**.

2. On the Google toolbar, normally found along the top of the browser window, click the Popup blocker icon.

   **Result:** The icon now reads Site popups allowed.

**Turning off the Windows XP Service Pack 2 pop-up blocker**

Click **Tools > Pop-up Blocker > Turn Off Pop-up Blocker**.
Contact Center Manager Administration logon screen displays ERROR:UNKNOWN!

When you attempt to launch Contact Center Manager Administration the logon screen displays ERROR: UNKNOWN!

Solution

Ensure that display settings for Internet Explorer are configured for Western European (ISO).

Configuring Internet Explorer display settings for Western European (ISO)

1. Open the Internet Explorer.
2. In Internet Explorer, select View > Encoding.
   
   **Result:** The Encoding selection menu appears.
3. Ensure that Western European (ISO) is selected.
4. Close and reopen Internet Explorer to activate the changes.
Section B: Access and Partition Management

In this section

Cannot view agents or skillsets in User Defined Partitions view 504
Cannot create Report Groups due to failure of XML counter upgrade 505
Cannot view agents or skillsets in User Defined Partitions view

When in the User Defined Partitions view of Access and Partition Management, you cannot view agents or skillsets on a selected user-defined partition.

Investigation

Ensure that all servers configured in Contact Center Manager Administration are fully operational. If a server that is not fully operational is listed for the user-defined partition, a failure to display agent and skillset information for the remaining servers can result.
Cannot create Report Groups due to failure of XML counter upgrade

When a user with the correct permissions, for example the webadmin user, tries to create report groups, the user encounters the following error: “Unable to read ADAM system parameters – Failed to add report group”

This error occurs when the RemoveCounterXML.exe upgrade utility does not run correctly during the SU02 upgrade.

The log file created when you run the upgrade utility is in the Nortel Logs folder. To confirm the error, confirm that the log file on the affected machine is similar to the following example:

RemoveCounterXML.log
CCMA6.0: Adding Counter.xml value to ADAM as System Parameter
------------------------------------------
Begin on: 15/01/2006 15:06:44
ADAM check complete: Counter needs to be updated.
Updating........
ERROR: while creating Counter entry
Error Number:-2147218445 Description:Object doesn't exist.

Solution

Run the RemoveCounterXML.exe upgrade utility.

Running the RemoveCounterXML.exe upgrade utility

1 On the Contact Center Manager Administration server, go to X:\Program Files\Nortel Networks\WClient\Apps\SupportUtil where X:\ is the drive where you installed Contact Center Manager Administration.

2 Double-click RemoveCounterXML.exe.

Result: The utility runs in the background and creates a log entry.
Section C: Contact Center Management

In this section

“No Supervisors Defined” error messages appear in Contact Center Management 508
“No Supervisors Defined” error messages appear in Contact Center Management

You added supervisors through Contact Center Management and exited the component. When you return to the component and select the same server in Contact Center Manager Server on which you defined the supervisors, you find that the supervisors are not there, and an error message appears stating “No Supervisors Defined.”

Solution

This problem can occur when the bindings order of the ELAN subnet network card and Nortel server subnet network card on the server in Contact Center Manager Server is not set up correctly. You must configure the bindings order of the network interface cards so that the Nortel server subnet card comes first, then the ELAN subnet card, and then the virtual adapters for remote access.

Ensure that you have all Contact Center Manager Administration-specific stored procedures on the Contact Center Manager Server.

For more information, see the *Contact Center Manager Administration Installation and Maintenance Guide*. 
Section D: Historical Reporting

In this section

You cannot access a report 510
You cannot print scheduled reports 512
Network call-by-call reports are missing data 514
Problem connecting to the data source in Historical Reporting 515
The report viewer is blank when you launch an ad hoc report 516
Cannot synchronize imported reports; access denied on the network drive 517
Cannot synchronize imported reports; cannot copy to CCMA server 518
Cannot connect to the data source 519
Cannot import custom report templates; ASP script timeout error occurs 520
Exporting large reports to PDF causes error message 521
You cannot access a report

You log on to a server on the system tree and you attempt to generate a report. However, the report that you want to generate does not appear in any of the folders in the system tree.

Investigation

To identify the reason why the tree does not contain the report, answer these questions.

<table>
<thead>
<tr>
<th>Question</th>
<th>Yes</th>
<th>No</th>
</tr>
</thead>
<tbody>
<tr>
<td>Are you logged on to the correct server in the tree?</td>
<td>Check the next question.</td>
<td>Each type of server (CS 1000/Meridian 1 nodal and networking, CS 2x00/DMS, NCC) contains specific types of standard public report templates. If you do not see a type of report template under one server, try logging on to another server.</td>
</tr>
<tr>
<td>Is the report included in the partition assigned to you?</td>
<td>Check the next question.</td>
<td>Ask your system administrator to include the report in the partition assigned to you.</td>
</tr>
<tr>
<td>If the report is a user-defined report, are you logged on with the user ID of the user who created the report?</td>
<td>Check the next question.</td>
<td>When you save a user-defined report in your Private Report Templates folder, your user ID is stored with it. Only you can access the report. If another user logs on to the PC, the user cannot access it. Therefore, make sure that you log on as the user who defined the report.</td>
</tr>
<tr>
<td>If the report is a user-defined report, are you logged on to the server on which the report was defined?</td>
<td>Check the next question.</td>
<td>When you save a user-defined report in your Private or Group folder, the server name is stored with it. If you log on to another server, you cannot access the report. Therefore, make sure you log on to the server to which you were connected when you defined the report.</td>
</tr>
<tr>
<td>Question</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------------------------</td>
<td>-----------------------------------------</td>
</tr>
<tr>
<td>Can you generate the report?</td>
<td>No further action required.</td>
<td>Contact your administrator for assistance.</td>
</tr>
</tbody>
</table>
You cannot print scheduled reports

You scheduled a report to print. After the time to print elapses, you find that no report is generated.

Investigation

To identify why the scheduled report was not printed, answer the following questions.

<table>
<thead>
<tr>
<th>Question</th>
<th>Yes</th>
<th>No</th>
</tr>
</thead>
<tbody>
<tr>
<td>Has the administrator configured a default network printer on the Contact Center Manager Administration server?</td>
<td>Check the next question.</td>
<td>Ask your administrator to configure a default network printer on the Contact Center Manager Administration server. The printer must be accessible to client computers that use Historical Reporting. See the <em>Contact Center Manager Administration Installation and Maintenance Guide</em> for further information.</td>
</tr>
<tr>
<td>If the report is a user-created report, are all data and formulas valid?</td>
<td>Check the next question.</td>
<td>Report the problem to the author of the report.</td>
</tr>
<tr>
<td>If the report is a network report, is the network site available?</td>
<td>Check the next question.</td>
<td>Contact the network administrator to determine whether you have access to the network site, and to find out whether the server is currently running.</td>
</tr>
<tr>
<td>Does the selection criteria for the report contain less than 250 entities?</td>
<td>Check the next question.</td>
<td>Use the Report Properties window to check the selection criteria. Make sure that the number of entities selected is 250 or fewer.</td>
</tr>
<tr>
<td>Question</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>-----------------------------------</td>
<td>-----------------------------------------</td>
</tr>
<tr>
<td>Is the IP address of the client PC unchanged?</td>
<td>Check the next question.</td>
<td>Scheduled reports are saved with the IP address of the server on which they are scheduled. If the server IP address changes, you must reschedule the report to reflect the new IP address.</td>
</tr>
<tr>
<td>Can you generate the report?</td>
<td>No further action required.</td>
<td>Contact your administrator for assistance.</td>
</tr>
</tbody>
</table>
Network call-by-call reports are missing data

You generate a network call-by-call report, but the report contains no information about a call answered at the destination site during the selected interval.

Investigation

This problem occurs if the clocks at the source and destination sites are not synchronized. For example, a call is networked from Toronto at 13:16:00 local time, and is answered at Chicago at 14:14:21 local time. In the Site parameters, the Time Zone Relative to GMT is configured as follows:

<table>
<thead>
<tr>
<th>Site</th>
<th>Time Zone Relative to GMT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toronto</td>
<td>GMT-5</td>
</tr>
<tr>
<td>Chicago</td>
<td>GMT-6</td>
</tr>
</tbody>
</table>

The Chicago administrator wants a Network Call By Call Statistics report with details about this call and requests a report for the period from 13:00:00 to 13:15:00 (after converting local time to the time zone of the source site). The requested report contains no information about the desired call because the Network Call By Call Statistics report contains only information about calls networked from Toronto during this period, and the call was actually networked during the previous period.

To troubleshoot the problem, check and synchronize the clocks at the source and destination servers.

For more information about time zones, see the Contact Center Manager Supervisor’s Guide.
Problem connecting to the data source in Historical Reporting

You try to run historical reports, but when you connect to the server in Contact Center Manager Server, you see an error message in the ad hoc report preview window stating “There is a problem connecting to the data source.”

Solution

This problem can occur when the bindings order of the ELAN and CLAN network cards on the server in Contact Center Manager Server is not set up correctly. Your administrator must configure the bindings order of the network interface cards so that the CLAN network card is first, then the ELAN network card, and then the virtual adapters for remote access. For details, see the Contact Center Manager Administration Installation and Maintenance Guide.
The report viewer is blank when you launch an ad hoc report

When you launch an ad hoc report, the report viewer is blank.

Solution

You must install the required third-party files on the client PC for the Crystal Reports viewer to function properly. For details, see the Contact Center Manager Administration Installation and Maintenance Guide.
Cannot synchronize imported reports; access denied on the network drive

When you try to synchronize a user-imported report, the following message appears: “Access denied on the network drive.”

You are denied access to the network drive because the Contact Center Manager Administration IIS directory security account (that is, IUSR_SWC) cannot read the report template on the network drive because of one of the following issues:

- The source report folder on the network drive is not shared with read permissions for the IIS directory security account.
- Contact Center Manager Administration is on a workgroup and the network PC is on a domain or vice versa.

Solution

To view possible solutions, see the Contact Center Manager Administration Installation and Maintenance Guide.
Cannot synchronize imported reports; cannot copy to CCMA server

When you try to synchronize a user-imported report, the following message appears: “Access denied: Cannot copy to the Contact Center Manager Administration server.”

This issue can occur:

- if the report is currently running and synchronization is started at the same time
- if during the last successful synchronization, the copied report template file has read-only attributes on the network folder

Solution

To view possible solutions, see the *Contact Center Manager Administration Installation and Maintenance Guide.*
Cannot connect to the data source

You are trying to run historical reports, but when you connect to the server in Contact Center Manager Server, you see the following error message in the ad hoc report preview window: “There is a problem connecting to the data source.”

Solution

The appropriate solution for this issue depends on the source of the problem. For more information, see the Contact Center Manager Administration Installation and Maintenance Guide.
Cannot import custom report templates; ASP script timeout error occurs

A major architecture change occurred from Crystal Reports 8.5 to Crystal Reports 9 and later versions. From Crystal Reports 9 onwards, reports generated in Crystal Reports are Unicode compliant. This can cause delay or failure when importing and generating reports on Contact Center Manager Administration if the report templates were created in Crystal Reports 8.5 or earlier.

Solution

Resave the report templates that you cannot import in Crystal Reports 9 or Crystal Reports 10. After you resave the report templates in Crystal Reports 9 or Crystal Reports 10, you can import the report templates into Contact Center Manager Administration. For details about how to resave report templates, see the Contact Center Manager Administration Installation and Maintenance Guide.

This is not always a problem; therefore, Nortel recommends that only customers experiencing this issue perform this procedure.
Exporting large reports to PDF causes error message

When you export a large report to PDF, the following error message appears: “The report was not exported. The selected export format may be disabled on the server.”

The error message appears if you attempt to export a report to PDF that has more than 300 pages.

Solution

To export a report to PDF with more than 300 pages, you must use the page selection fields to export reports in batches of 300 pages or less. For example, export page 1 to page 300 to PDF, and then for the remaining pages, select the pages using ranges of 300 pages or less. Alternatively, you can schedule the report to export.
Last column of a report is cut off

When you launch a report, the last column of the report is cut off.

Solution

On the client, set the paper size of the default printer to legal.

Changing the paper size on the default printer

1. From the Start menu, select Settings > Printers and Faxes.
2. Right-click the default printer, and then select Printing Preferences.
4. From the Paper Size list, select Legal.
5. Click OK to close the Advanced Options dialog box.
6. Click Apply.
7. Click OK to close the Printing Preferences dialog box.
Section E: Real-Time Reporting

In this section

- You cannot launch real-time displays
- Real-time displays are blank
- No names appear in real-time displays
- New Web pages replace real-time displays in the same browser
- Real-time displays do not show any data
- RTDs missing information after you uninstall ActiveXControl.msi
- Agent map does not launch after you upgrade SWC 4.5 to CCMA 6.0
- Real-time displays crash when you add %Skillset_Abdnd_Aft_Th
- Site does not appear in NCRTD when added by IP address
- Modified agent names are not reflected in the Standard Agent Display
- Real-time displays do not work after you reboot or update CCMA
- New agents appear as UNKNOWN in real-time displays
- Performance issues when using RTD filters and user-defined partitions
- Number of Calls Waiting in the Application and Skillset Realtime Displays Do Not Match
- Number of Contacts Waiting in the Skillset Realtime Displays May Not Match CCAD Contact Query Result
You cannot launch real-time displays

When you log on to the client PC and try to launch a real-time display, it does not launch. In Contact Center Manager Administration, for the real-time displays to launch properly, the system downloads and registers a new RTDControl to the client PC when you launch a real-time display for the first time. If you cannot launch real-time displays on a client PC, it may be because you enforced user policies that deny access to the registry on the PC and, therefore, prevent the system from downloading and registering the new RTDControl.

Solution

1. Log on to the client PC as the local administrator (or as a user with registry permissions).
2. Open Contact Center Manager Administration.
3. Open the Real-Time Reporting component.
4. Launch a real-time display.

Result: The system downloads and registers the required RTDControl to the client PC. Now regular users can log on to the client PC and launch real-time displays.

Perform this procedure on every client PC on which real-time displays are launched.
Real-time displays are blank

When you launch a real-time display, it contains no data.

Investigation

Check the following conditions:

- Ensure that the LAN/WAN supports multicast traffic by contacting your network administrator to confirm that the routers have multicast capabilities.
- Verify that you can send and receive data between the server in Contact Center Manager Server, the Contact Center Manager Administration server, and the clients. For more information, see the Contact Center Manager Administration Installation and Maintenance Guide.
- Confirm that the RSM components are sending data to the same IP multicast address.
- Check that the IP Receive address for the Contact Center Manager Administration server matches the IP Send multicast address setting in Contact Center Manager Server. For more information, see the Contact Center Manager Administration Installation and Maintenance Guide.

Multicast and unicast icons in real-time displays

To help you troubleshoot problems with real-time displays, when you first launch a display and while the system is retrieving data, an icon appears on the display identifying whether the Contact Center Manager Administration server supports multicast clients, unicast clients, or both.

The graphic on page 526 shows a display in which both icons appear, indicating that the Contact Center Manager Administration server supports both multicast and unicast. In cases where only one transmission method is supported, only the corresponding icon appears on the display.
After the display launches, the icon indicates the transmission mode used to launch the display. The following graphic shows data received through a unicast connection and a dedicated connection between the Contact Center Manager Administration server and client PC:

If this display were receiving multicast data, a multicast icon appears and no direct connection exists to the Contact Center Manager Administration server. Instead, the client listens to a shared multicast data stream.
The following scenarios describe why the real-time displays can appear blank.

**No unicast sessions available**
This error normally appears on a client computer when an attempt to open a unicast channel fails and the client is not receiving multicast data. From the error message shown in the following graphic, you can see that the Contact Center Manager Administration server supports both multicast and unicast clients, so the implication is that this client is on a unicast-only segment of the network. The absence of a unicast icon indicates that the unicast connection was not successfully established and the client PC is not receiving data packets. In this case, close the display and try to launch the display again later.
**No relevant data**
The following window appears on a client computer when it receives data, but the data is not relevant for the current display (for example, when the information is not available within the user’s partition or the current filter blocks the data from the display). The presence of the unicast icon indicates that a unicast connection was successfully established and the client PC is receiving data packets.

**No data is available on the network**
This window appears on a client PC when it is not receiving any data. No icon at the top of the window indicates that the display is receiving no data. The Transmit Mode = Multicast & Unicast note implies that the server supports only multicast but, in this case, the client PC is not receiving multicast data. This may be the result of a network problem, or it may mean that the server should support unicast but it is not enabled. Report the problem to your administrator so that the administrator can check the Contact Center Manager Administration server settings and enable unicast, if necessary. The administrator can also check the network settings to determine why the client PCs cannot receive multicast data.
The characters * and 0 appear in the display
Occasionally, the statistics in a real-time display may stop updating, and the characters * and 0 appear instead of the variable fields, as shown in the following graphic. In a unicast environment, this indicates that the server stopped sending data to this client. You must close and reopen the display. In a multicast environment, this can indicate that the server stopped sending the multicast stream. Run a trace on the Contact Center Manager Administration server if the problem persists.
No names appear in real-time displays

If the following symptoms appear in your real-time displays, there may be a problem with the network settings or the configuration of your DNS server, or there may be delays in the network causing timeouts:

- Agent names and answering skillset names appear as *UNKNOWN* in agent real-time displays.
- Route names appear as *UNKNOWN* in route real-time displays.
- IVR queue names appear as *UNKNOWN* in IVR real-time displays.
- Skillset and application names appear incorrectly in skillset and application real-time displays.

Investigation

Ensure that the network is functioning correctly, the DNS is configured correctly on the Contact Center Manager Administration server, and the DNS is providing responses within a reasonable time (for example, less than 10 seconds).
New Web pages replace real-time displays in the same browser

When you are viewing a display on your desktop, if you choose to open a link to another Internet site from Microsoft Outlook, the new Web page replaces the real-time display in the same browser window.

Solution

To keep the real-time display open and launch links from Microsoft Outlook in a new browser window, follow this procedure.

Launching links from Microsoft Outlook in a new browser window

1. In Internet Explorer, select Tools > Internet Options.
2. Click the Advanced tab.
3. Under Browsing, ensure that the Reuse windows for launching shortcuts check box is not selected.
4. Click OK.
Real-time displays do not show any data

When you launch a real-time display, it contains no data.

Solution

On the Contact Center Manager Administration server, verify the following conditions:

- You can correctly resolve the Contact Center Manager Server IP address to the server name.
- You can correctly resolve the Contact Center Manager Server name to the expected IP address.

Verifying the IP address and server name

1. From the **Start** menu, click **Run**.
2. Type **cmd**.
3. Click **OK**.
   
   **Result:** The Command Prompt window appears.
4. Type **ping <Contact Center Manager Server name>**.
5. Press **Enter** on your keyboard.
   
   **Result:** The Contact Center Manager Server IP address and the packets sent and received are displayed.
   
   If unexpected results are returned, check your DNS setting and the local host file on the server for incorrect entries.
6. Type **ping -a <Contact Center Manager Server IP address>**.
7. Press **Enter** on your keyboard.
   
   **Result:** The Contact Center Manager Server name and the packets sent and received are displayed.
   
   If unexpected results are returned, check your DNS setting and the local host file on the server for incorrect entries.
RTDs missing information after you uninstall ActiveXControl.msi

Real-time displays (RTD) do not list information for agents logged on to take calls. This occurs when you uninstall the ActiveXControl.msi file on the client computer.

Solution

Register the rope.dll file manually on the client computer.

Manually registering the rope.dll file

1. From the Start menu, select Start > Run.
2. In the box, type `regsvr32 "C:\WINDOWS\system32\rope.dll"`.
3. Click OK.
Agent map does not launch after you upgrade SWC 4.5 to CCMA 6.0

The agent map should launch with no errors in the same configuration in which it was saved in Symposium Web Client 4.5 SU06; however, when you launch the agent map, you receive the following error message:

“Microsoft VBScript runtime error '800a000d'
Type Mismatch”

Solution

Resubmit the agent map again and launch the agent map.
Real-time displays crash when you add %Skillset_Abnd_Aft_Th

If you add %Skillset_Aft_Abdn_Trshold to a custom formula and then add the custom formula to a real-time display, the real-time display crashes when you try to run it. If you add %Skillset_Aft_Abdn_Trshold directly to a real-time display, the real-time display launches without problem.

Solution

Add %Skillset_Aft_Abdn_Trshold directly to a real-time display.
Site does not appear in NCRTD when added by IP address

When you add a Contact Center Manager Server in the Configuration component, if you add the server by IP address versus by server name (you type the IP address, not the server name, in the Server Name box), networked sites do not appear in the network consolidated real-time displays (NCRTD).

Solution

Modify the server configuration so that the server name is entered.

Editing the Contact Center Manager Server properties

1  Log on to Contact Center Manager Administration as the webadmin user.
2  From the launchpad, select Configuration.
3  On the system tree, right-click the Contact Center Manager Server and select Edit Properties from the menu.
   Result: The Contact Center Manager Server Properties window appears.
4  In the Server Name box, delete the IP address and then type the server name.
5  Press Tab.
   Result: The server name appears in the Display Name box.
6  Click Submit.
   Result: A message appears stating that the server properties updated successfully.
Modified agent names are not reflected in the Standard Agent Display

If you modify the first or last name of a logged off agent, log the agent on, and then launch a Standard Agent Display, the original agent name, not the modified agent name, appears in the Standard Agent Display.

Solution

Restart the Contact Center Manager Administration iceRTDService and relaunch the Standard Agent Display.

Restarting the Contact Center Manager Administration IceRTDService

1  On the Contact Center Manager Administration server, select Start > All Programs > Administrative Tools > Services.
   Result: The Services window appears.

2  Select the Extended tab.

3  On the Extended page, in the list, select CCMA IceRTDService.

4  Click the Restart link to restart the service.

5  From the menu, select File > Close to close the Services window.

For information about how to launch a Standard Agent Display, see the Contact Center Manager Administration online Help.
Real-time displays do not work after you reboot or update CCMA

After you reboot or upgrade the Contact Center Manager Administration server, real-time displays do not work. This can occur if adapters are not available when the IceRTDService tries to bind to them.

Solution

To resolve the issue, restart the Contact Center Manager Administration IceRTDService.

Restarting the IceRTDService

1. On the Contact Center Manager Administration server, go to Start > All Programs > Administrative Tools > Services.
   
   Result: The Services window appears.

2. In the list of Services, click CCMA IceRTDService.

3. Click Restart.

Result: The service restarts.
New agents appear as UNKNOWN in real-time displays

When you add new agents, they appear as UNKNOWN in real-time displays.

Investigation

This problem occurs if the administrator installs VERITAS Backup 9.1 on the Contact Center Manager Administration server and does not change the default port setting.

When you install VERITAS Backup 9.1, it uses the default TCP port setting of 10 000, which is also the default port for the Contact Center Manager Administration Toolkit NameService. This conflict results in Contact Center Manager Administration malfunctioning (administrative changes, such as agent and skillset name changes, are not updated in real time, requiring you to restart the ICERTDService to refresh the cache).

Solution

Change the default port that VERITAS Backup 9.1 uses to another port number of your choice (at this time, you cannot change the Contact Center Manager Administration Toolkit NameService port number). When you change the port number, you must first investigate the ports that the products in your network use (both Nortel and third-party products). Then, choose a port that causes no conflict between these products. For a list of ports that Contact Center Manager Administration uses, see the Contact Center Manager Administration Technical Requirements and Operating System Configuration Guide. For information about changing the VERITAS Backup Exec default port number, see the VERITAS support article located at www.seer.support.veritas.com.
Performance issues when using RTD filters and user-defined partitions

Performance issues can occur when you configure RTD filters and user-defined partitions in Contact Center Manager Administration, and then remove an element, such as an agent, from a user-defined partition.

Solution

To improve performance, Nortel recommends the following:

- Assign standard partitions and reporting agents to Contact Center Manager Administration users instead of user-defined partitions. Standard partitions and reporting agents are more efficient and require less resources than user-defined partitions.
- When you work with user-defined partitions, assign the partitions to a small number of Contact Center Manager Administration users. Each time you assign a user-defined partition to another user, performance diminishes.
- To remove agents from a user-defined partition, remove the agent from the partition in the Access and Partition Management component instead of removing the partition from the agent in the Agent Details window in the Contact Center Management component.

For more information about standard partitions and reporting agents, see “Standard partitions and reporting agents” on page 162. For more information about user-defined partitions, see “User-defined partitions” on page 171.
Number of Calls Waiting in the Application and Skillset Realtime Displays Do Not Match

The number of calls waiting in an application and skillset realtime display may not match if:

- There is not a one to one mapping of a skillset being queued to an application (that is, script/application may queue to different skillsets).
- The call may not "queue to skillset", but may "queue to agent" instead in the script/application.
- For multimedia sites if there are no agents logged into the multimedia skillset and a call is routed there, the call may show up as waiting against the original application but not against the unmanned skillset.
Number of Contacts Waiting in the Skillset Realtime Displays May Not Match CCAD Contact Query Result

The number of contacts waiting in a skillset realtime display may not match CCAD Contact Query Result as:

- The contact may not "queue to skillset", but may "queue to agent" instead in the script/application.
- The contact may have been transferred by an agent to a different skillset than initially set by CCMM rules.
- The contact may have been rescheduled by an agent so it is no longer queueing at any skillset, it will count against the application but not against the skillset.
Section F: Report Creation Wizard

In this section

Cannot obtain or release a license 544
Launching RCW: Crystal RAS service fails to start 545
RCW reports fail to run in Historical Reporting 547
Cannot obtain or release a license

Intermittently, the Contact Center Manager Administration License Manager Service cannot grant a license or cannot release a license. This is because the Contact Center Manager Administration License Manager Server grace period for Report Creation Wizard is not fully functional.

Solution

Restart the License Manager on the Contact Center Manager Server and restart the Contact Center Manager Administration License Manager Service on the Contact Center Manager Administration server.

Restarting the License Manager

1. On the Contact Center Manager Server, select Start > All Programs > Administrative Tools > Services.
   
   Result: The Services window appears.

2. Select the Extended tab.

3. On the Extended page, in the list, select CC License Manager.

4. Click the Restart link to restart the service.

5. From the menu, select File > Close to close the Services window.

Restarting the License Manager Service

1. On the Contact Center Manager Administration server, select Start > All Programs > Administrative Tools > Services.
   
   Result: The Services window appears.

2. Select the Extended tab.

3. On the Extended page, in the list, select CCMA LMService.

4. Click the Restart link to restart the service.

5. From the menu, select File > Close to close the Services window.
Launching RCW: Crystal RAS service fails to start

If Database Execution Prevention (DEP) is enabled for all programs and services, when a user launches Report Creation Wizard (RCW), the following error message appears:

“Failed to create a new report document. Check that the Crystal RAS service is running. Exception: failed to connect to server “localhost”. Error returned from Windows Socket API: 0.”

Additionally, the Crystal Report Application Server service fails to start. If you attempt to manually start the service, the following error message appears:

Solution

Configure DEP for essential Windows programs and services only.

Enabling DEP for essential Windows programs and services only

1. From the Start menu, select **Start > Control Panel > System**.
   **Result:** The System Properties dialog box appears.

2. Select the **Advanced** tab.

3. On the Advanced page, in the Performance area, click **Settings**.
   **Result:** The Performance Options dialog box appears.

4. Select the **Data Execution Prevention** tab.

5. Select **Turn on DEP for essential Windows programs and services only**.
6 Click **OK** to close the Performance Options dialog box.
7 Click **OK** to close the System Properties dialog box.
8 Restart the server.
RCW reports fail to run in Historical Reporting

If hardware-based DEP is enabled for all programs and services, then Report Creation Wizard reports with Report Creation Wizard formulas fail to run in Historical Reporting. These formulas depend on functions added to the Crystal framework using the Crystal User Function Library (CRUFL).

When a user runs a Report Creation Wizard report with Report Creation Wizard formulas in Historical Reporting, the Report Viewer window launches but the report is not displayed. In addition, a warning message appears in the Event Log under System. The message has a W3SVC source and is similar to the following:

If rapid-fail protection is enabled for the application pool, the application pool is automatically disabled. This stops all applications that are configured to run in the same application pool from running. By default, the Contact Center Manager Administration server is installed to run in the DefaultAppPool. If rapid-fail protection occurs, an error message appears in the Event Log under System. The message has a W3SVC source and is similar to the following:
Solution

Configure DEP for essential Windows programs and services only.

**Enabling DEP for essential Windows programs and services only**

1. From the Start menu, select **Start > Control Panel > System**.
   
   **Result:** The System Properties dialog box appears.

2. Select the **Advanced** tab.

3. On the Advanced page, in the Performance area, click **Settings**.
   
   **Result:** The Performance Options dialog box appears.

4. Select the **Data Execution Prevention** tab.

5. Select **Turn on DEP for essential Windows programs and services only**.

6. Click **OK** to close the Performance Options dialog box.

7. Click **OK** to close the System Properties dialog box.

8. Restart the server.
accelerator key
A key on a phoneset that an agent can use to place a call quickly. When an agent presses an accelerator key, the system places the call to the configured number associated with the key. For example, if an agent presses the Emergency key, the system places a call to the agent’s supervisor.

ACCESS
An internal protocol used by Contact Center Manager Server to directly control some of the voice services available on the CallPilot or Meridian Mail platform.

access class
A collection of access levels that defines the actions a member of the access class can perform within the system. For example, a member of the Administrator access class might be given a collection of Read/Write access levels.

access level
A level of access or permission given to a particular user for a particular application or function. For example, a user might be given View Only access to historical reports.

ACCESS link
A communication channel between Contact Center Manager Server and CallPilot or Meridian Mail.

ACCESS voice port
A voice port controlled by the ACCESS link.

ACD call
See automatic call distribution call.

ACD-DN
See automatic call distribution directory number.
**ACD group**
See automatic call distribution group.

**ACD routing table**
See automatic call distribution routing table.

**ACD subgroup**
See automatic call distribution subgroup.

**acquired resource**
A resource configured on the switch under the control of Contact Center Manager Server. Resources must be configured with matching values on both the switch and Contact Center Manager Server.

**activated script**
A script that is processing calls or is ready to process calls. Before you can activate a script, you must first validate it.

**active server**
In a system with a Replication Server, the server providing call processing and administration services.

**activity code**
A number that agents enter on their phoneset during a call. Activity codes provide a way of tracking the time agents spend on various types of incoming calls. They are also known as Line of Business (LOB) codes. For example, the activity code 720 might be used to track sales calls. Agents can then enter 720 on their agent desktop applications during sales calls, and this information can be generated in an Activity Code report.

**adapter**
Hardware required to support a particular device. For example, network adapters provide a port for the network wire. Adapters can be expansion boards or part of the computer’s main circuitry.

**administrator**
A user who sets up and maintains Contact Center Manager and Contact Center Multimedia.
agent
A user who handles inbound and outbound voice calls, e-mail messages, and Web communications.

agent logon ID
A unique identification number assigned to a particular agent. The agent uses this number when logging on. The agent ID is not associated with any particular phoneset.

agent priority per skillset
Each agent has a priority per skillset. This priority represents their skill level within the skillset. This priority is used only in queuing the agent in the idle agent queues, thus allowing agents with greater priority in a skillset to be presented with calls before agents of lesser priority. Agent priority per skillset has a range of 1 to 48, with 1 having the greatest priority. Agent priority per skillset is not used to determine which request to present to an idle agent when the agent qualifies for more than one queue request. That presentation is based solely on the calls’ attributes.

agent-to-skillset assignment
A matrix that, when you run it, sets the priority of one or more agents for a skillset. Agent-to-skillset assignments can be scheduled.

agent-to-supervisor assignment
A matrix that, when you run it, assigns one or more agents to specific supervisors. Agent-to-supervisor assignments can be scheduled.

AIP
Advanced I/O Processor

alias
See e-mail alias.

AML
See Application Module Link.

ANI
See automatic Number Identification.
API
See application program interface.

application
1. A logical entity that represents a Contact Center Manager script for reporting purposes. The Master script and each primary script have an associated application. The application has the same name as the script it represents. 2. A program that runs on a computer.

Application Module Link
An internal protocol used by Contact Center Manager Server to communicate directly with the switch.

application program interface
A set of routines, protocols, and tools that programmers use to develop software applications. APIs simplify the development process by providing commonly used programming procedures.

application server
The server on which the Contact Center Manager Administration software is installed. This server acts as the middle layer that communicates with Contact Center Manager Server and makes information available to the client PCs.

associated supervisor
A supervisor who is available for an agent if the agent’s reporting supervisor is unavailable. See also reporting supervisor.

automatic call distribution
A means of automatically distributing an organization’s incoming calls among a number of answering positions (ACD agents). Automatic call distribution is useful in operations where callers want a service rather than a specific person. Calls are serviced in the order they arrive and are distributed so that the workload at each answering position is approximately equal.

automatic call distribution call
A call to an ACD-DN. ACD calls are distributed to agents in an ACD group based on the ACD routing table on the switch. See also automatic call distribution directory number.
**automatic call distribution directory number**
A primary or supplementary DN associated with an ACD group. Calls made to an automatic call distribution directory number are distributed to agents belonging to the group, based on the ACD routing table on the switch.

**automatic call distribution group**
An entity defined on the switch for the purpose of call distribution. When a customer dials an ACD group, the call is routed to any agent who is a member of that group.

**automatic call distribution routing table**
A table configured on the switch that contains a list of ACD-DNs used to define routes for incoming calls. This ensures that incoming calls not processed by Contact Center Manager Server are queued to ACD groups and handled by available agents.

**automatic call distribution subgroup**
An entity defined on the switch to assign supervisory responsibilities. Each subgroup has one supervisor phoneset and a number of agent phonesets associated with it. Agents can log on to any phoneset within their ACD subgroup. The supervisor must log on to the supervisor phoneset to monitor assigned agents.

**automatic Number Identification**
A telephony feature that provides the originating local telephone number of the caller.

**auto-response**
A message sent to a customer with no agent interaction. An auto-response can be an intelligent response, such as a sales promotion flyer, or an acknowledgement, such as, “We received your e-mail and will respond to you within three days.”

**basic call**
A simple unfeatured call between two 2500 phonesets, on the same switch, using a four-digit dialing plan.
BBUA
Back-to-Back User Agent

call age
The amount of time a call waits in the system before being answered by an agent.

call destination
The site to which an outgoing network call is sent. See also call source.

Calling Line Identification
An optional service that identifies the telephone number of the caller. This information can then be used to route the call to the appropriate agent or skillset. The CLID can also be displayed on an agent’s phoneset.

call intrinsic
A script element that stores call-related information assigned when a call enters Contact Center Manager Server. See also intrinsic, skillset intrinsic, time intrinsic, traffic intrinsic.

call presentation class
A collection of preferences that determines how calls are presented to an agent. The presentation options are Let Call Ring, Return To Queue and Call Forcing. The call presentation class specifies whether a break time between calls is allowed or not.

On the Communication Server 1000/Meridian 1 switch, the call presentation class supports an agent putting DN calls on hold for incoming ACD calls, and displaying Reserved on agent phonesets when the agent is presented with a network call. When using call forcing, you can configure a delay before forcing the call.

On the Communication Server 2x00/DMS switch, the call presentation class supports the Not Ready state when an agent is on a Secondary DN. You can not configure a delay before forcing a call or display Reserved on agent phonsets for network calls.
**call priority**
The priority given to a request for a skillset agent in a QUEUE TO SKILLSET or QUEUE TO NETWORK SKILLSET script element. This priority is used only in queuing a pending request in the pending request queue corresponding to the required skillsets. This allows pending requests with greater priority in a skillset to be presented to agents before calls of lesser priority. Call priority has a range of 1 to 6, with 1 having the greatest priority. Six priorities are used to fully support the many queuing variations provided by existing NACD functionality. Call priority is maintained at target nodes for network call requests.

**Call Request Queue Size**
Sets the maximum queue size for network skillsets. When the set maximum is reached, the queue rejects calls. For Network Skill-Based Routing, Call Request Queue Size (CRQS) is configured in Contact Center Manager Administration. If the NACD fallback or the Queue_to_NACD script command is used, CRQS must be configured in LD23 on the switch. See also Flow Control Threshold.

**call source**
The site from which an incoming network call originates. See also call destination.

**call treatment**
A script element that enables you to provide handling to a call while it is waiting to be answered by a contact center agent. For example, a caller can hear a recorded announcement or music while waiting for an agent.

**call variable**
A script variable that applies to a specific call. A call variable follows the call through the system and is passed from one script to another with the call. See also global variable, script variable.

**CallPilot**
A multimedia messaging system you can use to manage many types of information, including voice messages, fax messages, e-mail messages, telephone calls (including conferencing), calendars, and directories.

**campaign**
See outbound campaign.
CAT
Channel Allocation Table

CCR
customer controlled routing

CDN
See controlled directory number.

central processing unit
The component of a computer that performs the instructions of computer programs. Also known as a processor or microprocessor.

centum call seconds
A measure of call traffic density that represents one call in one channel for 100 seconds in 1 hour.

CLAN
See Customer Local Area Network.

CLAN subnet
See enterprise IP network.

CLID
See Calling Line Identification.

client
The part of Contact Center Manager Server that runs on a personal computer or workstation and relies on the server to perform some operations. Two types of client are available: Server Utility and Contact Center Manager Administration. See also server.

closed reasons
An item configured in Contact Center Multimedia to indicate the result of a completed e-mail contact. Agents choose a closed reason, and this information can be generated in a report.
command
A building block used with expressions, variables, and intrinsics to create scripts. Commands perform distinct functions, such as routing a call to a specific destination, playing music to a caller, or disconnecting a caller.

Communication Control Toolkit
A client/server application that integrates a telephone on a user’s desktop with client- and server-based applications.

Communication Server 1000 Telephony Manager
A Nortel application used for Private Branch Exchange (PBX) management.

Computer Telephony Integration
An application that enables a computer to control telephone calls.

Conditionally Toll Denied
Allowed access for calls placed through Basic/Network Alternate Route Selection and Coordinated Dialing Plan.

Contact Center Agent Desktop
An agent tool that contact center agents can use to provide intelligent and personalized customer care. Agents use a personal computer to access the telephony and multimedia functions.

Contact Center Manager
A client/server contact center solution for varied and changing business requirements. It offers a suite of applications that includes call processing and agent handling, management and reporting, networking, and third-party application interfaces.

Contact Center Manager Administration
A browser-based tool for contact center administrators and supervisors used for managing and configuring a contact center and its users, defining access to data, and viewing real-time and historical reports. The Contact Center Manager Administration software is installed on an application server. See also Contact Center Manager Administration server.
**Contact Center Manager Administration server**
The server on which the Contact Center Manager Administration software is installed. This server acts as the middle layer that communicates with Contact Center Manager Server and makes information available to the client PCs.

**Contact Center Manager Server**
This server is responsible for functions such as the logic for call processing, call treatment, call handling, call presentation, and the accumulation of data into historical and real-time databases.

**Contact Center Manager Server call**
A call to a CDN controlled by Contact Center Manager Server. The call is presented to the Incalls key on an agent’s phoneset.

**Contact Center Multimedia server**
A client/server contact center application that expands inbound telephony capabilities to include outbound voice, e-mail, and Web communications.

**Contact Center Standby server**
The server that contains an up-to-date backup version of the Contact Center Manager Server database for use if the active server fails. The database is kept up-to-date by the Replication Server.

**Contivity VPN Switch**
A Nortel product that provides routing, firewall, bandwidth management, encryption, authentication, and data integrity for secure tunneling across managed IP networks and the Internet.

**controlled directory number**
A special directory number that allows calls arriving at the switch to be queued when the CDN is controlled by an application such as Contact Center Manager Server. When a call arrives at this number, the switch notifies the application and waits for routing instructions, which are performed by scripts in Contact Center Manager Server.

**CPH**
calls per hour
**CPU**  
See central processing unit.

**CRM**  
See Customer Relationship Manager.

**CRQS**  
See Call Request Queue Size.

**CSL**  
Command and Status Link

**CTD**  
See Conditionally Toll Denied.

**CTI**  
See Computer Telephony Integration.

**customer administrator**  
A user who maintains Contact Center Manager.

**Customer Local Area Network**  
The LAN to which your corporate servers, third-party applications, and desktop clients connects.

**Customer Relationship Manager**  
An application that provides the tools and information that an organization requires to manage its customer relationships.

**Data Execution Prevention**  
A set of hardware and software technologies that perform additional checks on memory to help to protect against malicious code exploits. In Windows Server 2003 Service Pack 1, Data Execution Prevention is enforced by both hardware and software.
database views
A logical representation of the database used to organize information in the database for your use. Event statistics are accessible through database views.

DBMS
Database Management System

deacquire
To release an acquired switch resource from the control of the contact center.

deactivated script
A script that does not process any new calls. If a script is in use when it is deactivated, calls continue to be processed by the script until they are completed.

default activity code
The activity code assigned to a call if an agent does not enter an activity code manually, or when an agent presses the activity code button twice on the phoneset. Each skillset has a defined default activity code.

default skillset
The skillset to which calls are queued if they are not queued to a skillset or a specific agent by the end of a script.

denial of service
An incident in which a user or organization is unable to gain access to a resource that they can normally access.

DEP
See Data Execution Prevention.

Designer Patch
An emergency fix packaged to address specific individual Contact Center software problems. Designer Patches are viewable from a patch viewer application. Designer Patches are included in the next scheduled Service Update or Service Update Supplementary. See also Service Update, Service Update Supplementary, and Performance Enhancement Package.
**desktop user**
A configured user who can log on to the Contact Center Manager Server from a
client PC.

**destination site**
The site to which an outgoing network call is sent. *See also* source site.

**DHCP**
*See* dynamic host configuration protocol.

**Dial-Up Networking**
*See* Remote Access Services.

**DIALED NUMBER IDENTIFICATION SERVICE**
An optional service that allows Contact Center Manager Server to identify the
phone number dialed by the incoming caller. An agent can receive calls from
customers calling in on different DNISs and, if the DNIS is displayed on the
phoneset, can prepare a response according to the DNIS.

**DID**
Direct Inward Dial

**directory number**
The number that identifies a phoneset on a switch. The directory number (DN)
can be a local extension (local DN), a public network telephone number, or an
automatic call distribution directory number (ACD-DN).

**directory number call**
A call presented to the DN key on an agent’s phoneset.

**display threshold**
A threshold used in real-time displays to highlight a value below or above the
normal range.

**disposition code**
An item configured in Contact Center Multimedia to indicate the result of a
completed outbound contact. Agents choose a disposition code, and this
information can be generated in a report.
**Distant Steering Code**  
Used by the switch to route calls to their intended destination.

**Distance Vector Multicast Routing Protocol**  
The multicast routing protocol used when multicast data recipients extend beyond a single network. This protocol advertises the shortest-path route to the networks on which a multicasting source resides.

**DMS**  
Digital Multiplex Switch

**DN**  
*See* directory number.

**DN call**  
*See* directory number call.

**DNIS**  
*See* Dialed Number Identification Service.

**DoS**  
*See* denial of service.

**DP**  
*See* Designer Patch.

**DSC**  
Distant Steering Code

**DTMF**  
Dual Tone Multi Frequency

**Dual Tone Multi Frequency**  
A method used by the telephone system to communicate the keys pressed when dialing. Pressing a key on the phone's keypad generates two simultaneous tones, one for the row and one for the column. These are decoded by the exchange to determine which key was pressed.
**DVMRP**  
*See* Distance Vector Multicast Routing Protocol.

**dynamic host configuration protocol**  
A protocol for dynamically assigning IP addresses to devices on a network.

**dynamic link library**  
A library of executable functions or data that can be used by a Windows application. Typically, a DLL provides one or more particular functions, and a program accesses the functions by creating either a static or dynamic link to the DLL. Several applications can use a DLL at the same time.

**E**  
**EBC**  
*See* equivalent basic calls.

**EIU**  
Ethernet Interface Unit

**ELAN Subnet**  
*See* embedded local area network.

**e-mail alias**  
An e-mail address that forwards all e-mail messages it receives to another e-mail account. For example, the mailbox general@magscripts.com can have the aliases carz@magsubscriptions.com and planez@magsubscriptions.com. E-mail addressed to either of these aliases is forwarded to the general@magscripts.com mailbox. To route e-mail differently depending on the alias to which it is addressed, create a recipient mailbox as an alias in the Contact Center Multimedia Administrator application and then create routing rules based on the alias.

**e-mail message contact**  
An incoming e-mail message handled intelligently using rules to route a contact according to a skillset, send an auto-response, or close the contact.
e-mail rule
Determine how an e-mail contact is routed based on information about the e-mail message (inputs) and configurations in your contact center (outputs).

embedded local area network
A dedicated Ethernet TCP/IP LAN that connects the Contact Center Manager Server and the switch.

Emergency key
A key on an agent’s phoneset that, when pressed by an agent, automatically calls their supervisor to notify the supervisor of a problem with a caller.

enterprise IP network
Your entire IP network including the ELAN subnet and the Nortel server subnet.

equivalent basic calls
A measure of the telephone switch CPU real time required to process a basic call. See also basic call.

event
1. An occurrence or action on Contact Center Manager, such as the sending or receiving of a message, the opening or closing of an application, or the reporting of an error. Some events are for information only, while others can indicate a problem. Events are categorized by severity: information, minor, major, and critical. 2. An action generated by a script command, such as queuing a call to a skillset or playing music.

expression
1. A building block used in scripts to test for conditions, perform calculations, or compare values within scripts. See also logical expression and mathematical expression. 2. A category of disk drives that employs two or more drives in combination for fault tolerance and performance. See also relational expression.

F

FCTH
See Flow Control Threshold.
**filter timer**
The length of time after the system unsuccessfully attempts to route calls to a destination site before that site is filtered out of a routing table.

**firewall**
A set of programs that protects the resources of a private network from external users.

**first-level threshold**
The value that represents the lowest value of the normal range for a statistic in a threshold class. The system tracks how often the value for the statistic falls below this value.

**Flow Control Threshold**
The number of calls required to reopen a closed network skillset queue. This value must be less than the Call Request Queue Size. For Network Skill-Based Routing, Flow Control Threshold (FCTH) is configured in Contact Center Manager Administration. If the NACD fallback or the Queue_to_NACD script command is used, FCTH must be configured in LD23 on the switch. *See also* Call Request Queue Size.

**global settings**
Settings that apply to all skillsets or IVR ACD-DNs configured on your system.

**global variable**
A variable that contains values that can be used by any script on the system. You can only change the value of a global variable in the Script Variable Properties sheet. You cannot change it in a script. *See also* call variable, variable.

**GOS**
*See* grade of service.

**grade of service**
The probability that calls are delayed by more than a certain number of seconds while waiting for a port.
<table>
<thead>
<tr>
<th>Acronym</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HDX</td>
<td>See Host Data Exchange.</td>
</tr>
<tr>
<td>Host Data Exchange</td>
<td>A rich scripting language provided with Contact Center Manager to control treatment of calls.</td>
</tr>
<tr>
<td>HTTP</td>
<td>See Hypertext Transfer Protocol.</td>
</tr>
<tr>
<td>hundred call seconds</td>
<td>See centum call seconds.</td>
</tr>
<tr>
<td>ICM</td>
<td>See Intelligent Call Manager.</td>
</tr>
<tr>
<td>IGMP</td>
<td>See Internet Group Management Protocol.</td>
</tr>
<tr>
<td>Incalls key</td>
<td>The key on an agent phoneset to which incoming ACD and Contact Center Manager calls are presented.</td>
</tr>
<tr>
<td>Integrated Services Digital Network</td>
<td>A set of standards for transmitting digital information over ordinary telephone wire and other media.</td>
</tr>
<tr>
<td>Integration Package for Meridian Link</td>
<td>A feature that integrates an IVR system with a switch.</td>
</tr>
<tr>
<td>Intelligent Call Manager</td>
<td>A high capacity contact center TCP/IP interface to the switch that enables the exchange of messages between the switch and a remote host computer.</td>
</tr>
</tbody>
</table>
**Interactive Voice Response**
An application that allows telephone callers to interact with a host computer using prerecorded messages and prompts.

**Interactive Voice Response ACD-DN**
A directory number that routes a caller to a specific IVR application. An IVR ACD-DN must be acquired for non-integrated IVR systems.

**Interactive Voice Response event**
A voice port logon or logoff. An IVR event is pegged in the database when a call acquires or deacquires a voice port.

**Internet Group Management Protocol**
The multicast routing protocol used in a network that does not require the delivery of multicast packets between routers or across networks. This protocol transports the following information between host group members, hosts, and routers:

- client requests to join a group
- messages about group membership sent by hosts to routers

**Internet Protocol address**
An identifier for a computer or device on a TCP/IP network. Networks use TCP/IP to route messages based on the IP address of the destination. For customers using NSBR, site IP addresses must be unique and correct. The format of an IP address is a 32-bit numeric address written as four values separated by periods. Each value can be 0 to 255. For example, 1.160.10.240 can be an IP address.

**intrinsic**
A word or phrase used in a script to gain access to system information about skillsets, agents, time, and call traffic that can then be used in formulas and decision-making statements. *See also* call intrinsic, skillset intrinsic, time intrinsic, traffic intrinsic.

**IP address**
*See* Internet Protocol address.

**IPML**
*See* Integration Package for Meridian Link.
ISDN
See Integrated Services Digital Network.

IVR
See Interactive Voice Response.

IVR ACD-DN
See Interactive Voice Response ACD-DN.

IVR event
See Interactive Voice Response event.

IVR port
See voice port.

LAN
See local area network.

Line of Business code
See activity code.

LOB code
See activity code.

local area network
A computer network that spans a relatively small area. Most LANs connect workstations and personal computers and are confined to a single building or group of buildings.

local call
A call that originates at the local site. See also network call.

local skillset
A skillset that can be used at the local site only. See also network skillset, skillset.
**logical expression**
1. A symbol used in scripts to test for different conditions. Logical expressions are AND, OR, and NOT. *See also* expression, mathematical expression. 2. A category of disk drives that employs two or more drives in combination for fault tolerance and performance. *See also* relational expression.

**M**

**M1**
Meridian 1 switch

**M1 IE**
Meridian 1 Internet Enabled switch

**mailbox**
*See* recipient mailbox.

**Management Information Base**
A data structure that describes the collection of all possible objects in a network. Each managed node maintains one or more variables (objects) that describe its state. Contact Center Manager Server Management Information Bases (MIB) contribute to the overall network MIB by:

- identifying Nortel/Meridian/Contact Center Manager Server nodes within the network
- identifying significant events (SNMP traps), such as alarms reporting
- specifying formats of alarms

**Master script**
The first script executed when a call arrives at the Contact Center. A default Master script is provided with Contact Center Manager, but it can be customized by an authorized user. It cannot be deactivated or deleted. *See also* network script, primary script, script, secondary script.
mathematical expression
1. An expression used in scripts to add, subtract, multiply, and divide values. Mathematical expressions are addition (+), subtraction (-), division (/), and multiplication (*). See also expression and logical expression. 2. A category of disk drives that employs two or more drives in combination for fault tolerance and performance. See also relational expression.

mean holding time
1. The time that the agent is involved in serving a call. It is the sum of average talk time. 2. The time required for postcall processing when the agent is not available to handle other calls. 3. Intercall interval (including union break, if any).

Media Application Server
A programmable media endpoint in a SIP signaling network that acts as a SIP user agent to accept and control sessions and the IP media (audio and video) services associated with those sessions. The Media Application Server delivers programmable customized intelligent media services to those sessions using text, voice, and video initially, with extensibility to other media and information types as the applications grow.

mean time between calls
The average time between presentation of calls to an agent.

Meridian Link Services
A communications facility that provides an interface between the switch and a third-party host application.

Meridian Mail
A Nortel product that provides voice messaging and other voice and fax services.

Meridian MAX
A Nortel product that provides call processing based on ACD routing.

MHT
See mean holding time.
MIB
See Management Information Base.

MLS
See Meridian Link Services.

MM
See Meridian Mail.

MOSPF
See Multicasting Extensions to Open Shortest Path First.

MTBC
See mean time between calls.

Multicasting Extensions to Open Shortest Path First
An enhanced version of the Open Shortest Path First (OSPF) routing algorithm that allows a router to forward multicast IP traffic within an autonomous OSPF (v.2) system.

Multimedia database
A Caché database used to store customer information and contact details for outbound, e-mail, and Web communication contacts.

MSL-100
Meridian Stored Logic 100 switch

music route
A resource installed on the switch that provides music to callers while they wait for an agent.

N
NACD call
A call that arrives at the server from a network ACD-DN.

NAT
See Network Address Translation.
**NCC**
*See* Network Control Center.

**NCRTD**
*See* Network Consolidated Real-Time Display.

**Network Address Translation**
The translation of an Internet Protocol (IP) address used within one network to an IP address used within another network. One network is called the inside network and the other is called the outside network.

**network call**
A call that originates at another site in the network. *See also* local call.

**Network Consolidated Real-Time Display**
A real-time display containing data from more than one Contact Center Manager Server. This data is consolidated by Contact Center Manager Administration.

**Network Control Center**
The server on a Contact Center Manager system where Network Skill-Based Routing is configured and where communication between servers is managed.

**network interface card**
An expansion board that enables a PC to connect to a local area network (LAN).

**network script**
The script executed to handle error conditions for Contact Center Manager Server calls forwarded from one site to another for customers using NSBR. The network script is a system-defined script provided with Contact Center Manager, but it can be customized by an authorized user. It cannot be deactivated or deleted. *See also* Master script, primary script, script, secondary script.

**Network Skill-Based Routing**
An optional feature with Contact Center Manager Server that provides skill-based routing to multiple networked sites.
**network skillset**
A skillset common to every site on the network. Network skillsets must be created at the Network Control Center (NCC).

**night mode**
A skillset state in which the server does not queue incoming calls to the skillset, and in which all queued calls are given night treatment. A skillset goes into night mode automatically when the last agent logs off, or the administrator can put it into night mode manually. *See also* out-of-service mode, transition mode.

**Nortel server subnet**
The subnet to which the Nortel servers, such as Contact Center Manager Server, Network Control Center, Contact Center Manager Administration, Contact Center Multimedia, and CallPilot are connected.

**Nortel VPN Router Switch**
A Nortel product that provides routing, firewall, bandwidth management, encryption, authentication, and data integrity for secure tunneling across managed IP networks and the Internet.

**NPA**
*See* Number Plan Area.

**NSBR**
*See* Network Skill-Based Routing.

**Number Plan Area**
Area code

**object linking and embedding**
A compound document standard that enables you to create objects with one application, and then link or embed them in a second application.

**ODBC**
*See* Open Database Connectivity.
**OEM**
Original equipment manufacturer

**Office hours**
Hours configured in the contact center where e-mail messages can be routed using one method when the contact center is open, and another method when the contact center is closed.

**OLE**
*See* object linking and embedding.

**Open Database Connectivity**
A Microsoft-defined database application program interface (API) standard.

**Open Shortest Path First**
A routing algorithm that provides least-cost routing, multipath routing, and load balancing.

**Optivity Telephony Manager**
A Nortel application used for switch management.

**OSPF**
*See* Open Shortest Path First.

**OTM**
*See* Optivity Telephony Manager.

**outbound campaign**
A group of outgoing calls from the contact center for a specific purpose, for example, customer satisfaction surveys.

**Outbound Campaign Management Tool**
An administrator tool accessed through Contact Center Manager Administration for configuring outbound campaigns.

**outbound contact**
An outgoing voice call intelligently routed to an agent according to a skillset within a defined time interval. The call can be dialed by the agent or the switch.
**out-of-service mode**
A skillset state in which the skillset does not take calls. A skillset is out of service if no agents are logged on or if the supervisor puts the skillset into out-of-service mode manually. *See also* night mode, transition mode.

**out-of-service skillset**
A skillset not taking any new calls. While a skillset is out of service, incoming calls cannot be queued to the skillset. *See also* local skillset, network skillset, skillset.

**patch**
*See* Designer Patch.

**PBX**
*See* private branch exchange.

**pegging**
The action of incrementing statistical counters to track and report on system events.

**pegging threshold**
A threshold used to define a cut-off value for statistics, such as short call and service level. Pegging thresholds are used in reports.

**PEP**

**Performance Enhancement Package**
A planned update to address specific individual Contact Center software problems. Product enhancement packages are viewable from a patch viewer application. Product enhancement packages are included in the next scheduled service update or service update Supplementary. *See also* Service Update and Service Update Supplementary.

**personal directory number**
A DN on which an agent can be reached directly, usually for private calls.
phoneset
The physical device, connected to the switch, to which calls are presented. Each agent and supervisor must have a phoneset.

phoneset display
The display area on an agent’s phoneset where information about incoming calls can be communicated.

PIM
See Protocol Independent Multicast.

Platform Vendor Independence
A software-only contact center solution, which operates on any hardware platform that meets specified requirements.

Position ID
A unique identifier for a phoneset, used by the switch to route calls to the phoneset. Referred to as Telephony/Port Address in Contact Center Manager Server.

primary ACD-DN
A directory number that callers can dial to reach an ACD group.

primary script
A script executed or referenced by the Master script. A primary script can route calls to skillsets, or it can transfer routing control to a secondary script. See also Master script, network script, script, secondary script.

priorities
Two sets of priorities affect queuing and call presentation: agent priority per skillset and call priority. For both sets of priorities, the lower in value of the number indicates a greater priority in presentation. All idle agent queues and all pending request queues always queue by priority as its top precedence. All other queuing options, such as age of call and agent idle time, take a lower precedence than priority. See also call priority and agent priority per skillset.
private branch exchange
A telephone switch, typically used by a business to service its internal telephone needs. A PBX usually offers more advanced features than are generally available on the public network.

Protocol Independent Multicast
A protocol that provides efficient routes for multicast traffic that must cross the Internet to reach members of sparsely distributed multicast groups.

PSTN
See public switched telephone network.

public switched telephone network
The international network of private and government-owned voice-oriented public telephone networks.

RAID
See Redundant Array of Intelligent/Inexpensive Disks.

RAN
recorded announcement

RAN route
See recorded announcement route.

RAS
See Remote Access Services.

Real-time Statistics Multicast
An interface that provides real-time information to third-party applications in either multicast or unicast format.
recipient mailbox
A container on the e-mail server that hold e-mail messages. Standard mailboxes are monitored by the Contact Center E-mail Manager, which routes the e-mail to an agent or group of agents (skillset) based on an analytical search of the sender address, the recipient address, the subject and body of an e-mail message for predetermined keywords, or a combination of these. The e-mail server must be compliant with Post Office Protocol 3 (POP3) and Standard Mail Transfer Protocol (SMTP).

recorded announcement route
A resource installed on the switch that offers a recorded announcement to callers.

Redundant Array of Intelligent/Inexpensive Disks
A category of disk drives that employs two or more drives in combination for fault tolerance and performance.

redundant server
A warm standby server, used for shadowing the Multimedia database on the Multimedia server and providing a quick recovery if the primary server fails.

relational expression
An expression used in scripts to test for different conditions. Relational expressions are less than (<), greater than (>), less than or equal to (<=), greater than or equal to (>=), and not equal to (<>). See also expression, logical expression, mathematical expression.

Remote Access Services
A feature built into Windows NT and Windows 95 that enables users to log on to an NT-based LAN using a modem, X.25 connection, or WAN link. This feature is also known as Dial-Up Networking.

Replication Server
A server that backs up the active Contact Center Manager Server to the standby Contact Center Manager Server in real time.
reporting supervisor
The supervisor who has primary responsibility for an agent. When an agent presses the Emergency key on the phoneset, the emergency call is presented to the agent’s reporting supervisor. See also associated supervisor.

Resource Reservation Protocol
The protocol used by routers to allow host systems in an IP network to reserve resources for unicast or multicast dataflows.

round robin routing table
A routing table that queues the first call to the first three sites in the routing table, then the second three sites, then the third three sites, and so on, until an agent is reserved at one of the sites. See also sequential routing table.

route
A group of trunks. Each trunk carries either incoming or outgoing calls to the switch. See also music route, RAN route.

router
A device that connects two LANs. Routers can also filter messages and forward them to different places based on various criteria.

routing table
A table that defines how calls are routed to the sites on the network. See also round robin routing table, sequential routing table.

RSM
See Real-time Statistics Multicast.

RSVP
See Resource Reservation Protocol.

rule
See e-mail rule.
sample script
A script installed with the Contact Center Manager Server client. Sample scripts are stored as text files in a special folder on the client. The contents of these scripts can be imported or copied into user scripts to create scripts for typical contact center scenarios.

SCM
See Service Control Manager.

script
A set of instructions that relates to a particular type of call, caller, or set of conditions, such as time of day or day of week. See also Master script, network script, primary script, secondary script.

script variable
See variable.

second-level threshold
The value used in display thresholds that represents the highest value of the normal range for a given statistic. The system tracks how often the value for the statistic falls outside this value.

secondary directory number
A DN defined on the agent’s phoneset as a Centrex line for incoming and outgoing non-ACD calls.

secondary script
Any script (other than a Master, network, or primary script) referenced from a primary script or any other secondary script. Statistics are not pegged for actions occurring during a secondary script. See also Master script, network script, primary script, script.

sequential routing table
A routing table method that always queues a call to the first three active sites in the routing table. See also round robin routing table.
server
A computer or device on a network that manages network resources. Examples of servers include file servers, print servers, network servers, and database servers. Contact Center Manager Server is used to configure the operations of the contact center. See also client.

server subnet
The subnet to which the Nortel servers, such as Contact Center Manager Server, Network Control Center, Contact Center Manager Administration, Contact Center Multimedia, and CallPilot are connected.

service
A process that adheres to a Windows NT structure and requirements. A service provides system functionality.

Service Control Manager
A Windows NT process that manages the different services on the PC.

service level
The percentage of incoming calls answered within a configured number of seconds.

service level threshold
A parameter that defines the number of seconds within which incoming calls should be answered.

Service Update
A Contact Center supplementary software application that enhances the functionality of previously released software by improving performance, adding functionality, or correcting a problem discovered since the original release. All previous Service Updates (SUs) for the release are included in the latest Service Update. For example, SU02 contains the contents of SU01 as well as the fixes delivered in SU02. SU03 contains SU01, SU02, and the fixes delivered in SU03. See also Service Update Supplementary, Designer Patch, and Performance Enhancement Package.
**Service Update Supplementary**
A stand-alone Contact Center supplementary software application installed on top of a specific Service Update (SU). It does not contain the contents of previous SUs. The next SU includes SUSs built on top of previous SUs. For example, SUS0301 is installed on top of SU03. SU04 contains SU03 and SUS0301 (and any subsequent SUSs built on top of SU03). *See also* Service Update, Designer Patch, and Performance Enhancement Package.

**Session Initiation Protocol**
An application-layer control (signaling) protocol for creating, modifying, and terminating sessions with one or more participants.

**Simple Network Management Protocol**
A systematic way of monitoring and managing a computer network. The SNMP model consists of four components:

- managed nodes, which are any device, such as hosts, routers, and printers, capable of communicating status to network-management systems through an SNMP management process called an SNMP Agent
- management stations, which are computers running special network management software that interact with the Agents for status
- management information, which is conveyed through exact specifications and format of status specified by the MIB
- Management Protocol or SNMP, which sends messages called protocol data units (PDUs)

**SIP**
*See* Session Initiation Protocol.

**SIP Terminal**
The SIP Address of the TR87 controlled terminal dedicated to this agent. This is the phone number that the agent controls, combined with the domain of the agent in the SIP URI.

**SIP URI**
The SIP Address for the agent as configured on the target SIP server. The SIP Address uniquely identifies the agent on the SIP network.
**site**
1. A system using Contact Center Manager Server that can be accessed using Server Utility. 2. A system using Contact Center Manager Server and participating in Network Skill-Based Routing.

**skillset**
A group of capabilities or knowledge required to answer a specific type of call. *See also* local skillset, network skillset.

**skillset intrinsic**
A script element that inserts information about a skillset in a script. Skillset intrinsics return values such as skillsets, integers, and agent IDs. These values are then used in queuing commands. *See also* call intrinsic, intrinsic, time intrinsic, and traffic intrinsic.

**SL-100**
Stored Logic 100 switch

**SNMP**
*See* Simple Network Management Protocol.

**source site**
The site from which an incoming network call originates. *See also* destination site.

**standby**
In skillset assignments, a property that grants an agent membership in a skillset, but makes the agent inactive for that skillset.

**standby server**
A server that contains an up-to-date version of the database, for use when the active server becomes unavailable.

**SU**
*See* Service Update.
supervisor
A user who manages a group of agents. See also associated supervisor and reporting supervisor.

supplementary ACD-DN
A DN associated with a primary DN. Any calls to the supplementary DN are automatically routed to the primary DN. A supplementary DN can be a toll-free (1-800) number.

SUS
See Service Update Supplementary.

switch
See telephony switch.

switch resource
A device configured on the switch. For example, a CDN is configured on the switch and then used as a resource with Contact Center Manager Server. See also acquired resource.

system-defined scripts
The Master_Script and the Network_Script (if NSBR is enabled). Users can customize these scripts, but they cannot deactivate or delete them. These scripts are the first scripts executed for every local or network call arriving at the contact center.

T

TAPI
See Telephony Application Program Interface.

target site
See destination site.

TCP/IP

TDM
See Time-Division Multiplex.
telephony
The science of translating sound into electrical signals, transmitting them, and then converting them back to sound. The term is used frequently to refer to computer hardware and software that perform functions traditionally performed by telephone equipment.

telephony switch
The hardware that processes calls and routes them to their destination.

**Telephony Application Program Interface**
An interface between the switch and an application that allows the application to control the telephone on a user’s desktop.

threshold
A value for a statistic at which system handling of the statistic changes.

threshold class
A set of options that specifies how statistics are treated in reports and real-time displays. *See also* display threshold, pegging threshold.

**Time-Division Multiplex**
A method of transmission in which a signal is separated into multiple segments at the transmission source, and then reassembled at the receiving end.

time intrinsic
A script element that stores information about system time, including time of day, day of week, and week of year. *See also* call intrinsic, intrinsic, skillset intrinsic, traffic intrinsic.

**Token Ring**
A PC network protocol developed by IBM. A Token Ring network is a type of computer network in which all the computers are arranged schematically in a circle.

traffic intrinsic
An intrinsic that inserts information about system-level traffic in a script. *See also* call intrinsic, intrinsic, skillset intrinsic, time intrinsic.
**transition mode**
A skillset state in which the server presents already queued calls to a skillset. New calls queued to the skillset are given out-of-service treatment. *See also* night mode, out-of-service mode.

**Transmission Control Protocol/Internet Protocol**
The communication protocol used to connect devices on the Internet. TCP/IP is the standard protocol for transmitting data over networks.

**treatment**
*See* call treatment.

**trunk**
A communications link between a PBX and the public central office, or between PBXs. Various trunk types provide services such as Direct Inward Dialing (DID trunks), ISDN, and Central Office connectivity.

**Uniform Resource Identifier (URI)**
A compact string of characters used to identify or name a resource on the Internet. The main purpose of this identification is to enable interaction with representations of the resource over a network. The URI must be unique to URIs currently assigned to other CDNs, DNIs or agents.

**user-created script**
A script created by an authorized user on the Contact Center Manager system. Primary and secondary scripts are user created scripts.

**user-defined script**
A script modified by an authorized user on the Contact Center Manager system.

**utility**
A program that performs a specific task, usually related to managing system resources. Operating systems contain a number of utilities for managing disk drives, printers, and other devices.
**validation**
The process of checking a script to ensure that all the syntax and semantics are correct. A script must be validated before it can be activated.

**variable**
A placeholder for values calculated within a script, such as CLID. Variables are defined in the Script Variable Properties sheet and can be used in multiple scripts to determine treatment and routing of calls entering Contact Center Manager Server. *See also* call variable, global variable.

**Virtual Private Network**
A private network configured within a public network to take advantage of the economies of scale and management facilities of large networks.

**Voice Extensible Markup Language**
Allows a user to interact with the Internet through voice-recognition technology.

**Voice over IP**
Voice traffic transmitted in digital format using the IP protocol.

**voice port**
A connection from a telephony port on the switch to a port on the IVR system.

**VPN**
*See* Virtual Private Network.

**VXML**
*See* Voice Extensible Markup Language.

**W**

**WAN**
*See* wide area network.

**Web-on-hold**
A set of URLs that a customer sees after requesting a text chat session, and before the agent connects to the Web Communications contact.
**wide area network**
A computer network that spans a relatively large geographical area. Typically, a WAN consists of two or more local area networks (LANs). The largest WAN in existence is the Internet.

**workload scenarios**
Sets of configuration values defined for typical patterns of system operations. Five typical workload scenarios (entry, small, medium, large, and upper end) are used in the Capacity Assessment Tool for capacity analysis for Contact Center Manager.
Index

A

about blank
message in Internet Explorer 499
URL, adding as a Trusted Site 498
Access and Partition Management
access classes 140
access levels in 145
and servers 151
assigning 178
creating 153
access rights 142
access rights, assigning 178
adding Contact Center Manager Administration users in 178
Audit Trail events 219
overview 46
partitions 142
assigning 178
problems viewing user details in 497
Report Groups
to add a report group 161
select all, problems with 497
supervisor/reporting agent combinations,
assigning 178
what is new 15
access classes
in Access and Partition Management 140
access levels in 145
and servers 151
assigning 178
creating 153
in Server Utility 315, 323
adding 317
deleting 323
functions and privileges 324
previewing 323
printing 323
access rights
in Access and Partition Management 142, 178
access to server, controlling 338–340
activity codes
functions and privileges 327
ad hoc agent-to-skillset assignments, creating 107
ad hoc agent-to-supervisor assignments, creating 98
adding
access classes
in Server Utility 317
desktop users 335–337
event preferences 401–402
adminGroup access class
in Server Utility 316
administrator
defining typical access 154
role of 50
agent call scripts, creating 274
Agent Desktop Display
overview 49
agent desktop script, selecting 252
agent details
editing 102
viewing 102
agent performance reports
functions and privileges 330
agent threshold classes
functions and privileges 327
agents
adding in Contact Center Management 120
agent-to-skillset assignments 94, 110
functions and privileges 327
agent-to-skillset assignments, creating ad hoc 107
agent-to-supervisor assignments 94, 110
function and privileges 327
agent-to-supervisor assignments, creating ad hoc 98
Alarm Monitor 384, 407–411
configuring background 410
configuring foreground 410
functions and privileges 324
help 411
alarms
clearing active 412–413
help 411
investigating 411
printing active 408
printing all 408
recovery path for 411
appending call data to existing campaign 251
application threshold classes
  functions and privileges 328
  in Scripting 237
applications
  function and privileges 328
assigning
  access classes
    in Access and Partition Management 178
    partitions 178
assigning access rights
  in Access and Partition Management 178
assigning access rights for outbound contacts
  outbound 248
assigning, supervisor/reporting agent
  combinations 178
Assignment view
  agent-to-skillset assignments 110
Assignments view
  agent-to-supervisor assignments 110
attributes, changing voice segments’ 382
Audit Trail
  Access and Partition Management events 219
  accessing 213
  Configuration events 214
  Contact Center Management events 218
  Historical Reporting events 221
  Launchpad events 214
  License Manager events 295
  overview 49, 212
  Real-Time Reporting events 220
  Report Creation Wizard events 222
  Scripting events 220
  to configure the number of stored Audit Trail
    events 213
  XML automated assignments feature
    events 223
Audit Trail events
  10000 214
  10001, activity code modified 214
  10002, activity code deleted 214
  10010 214
  10011 215
  10012, call presentation class deleted 215
  10020, CDN (route point) added 215
  10021, CDN (route point) modified 215
  10022, CDN (route point) deleted 215
  10030, DNIS added 215
  10220, Contact Center Manager
    Administration user logged in 214
  10221, Contact Center Manager
    Administration user logged out 214
  10223 214
  10230, password change on Contact Manager
    Server 214
  10380, Contact Type added 215
  10381, Contact Type modified 215
  10382, Contact Type deleted 215

B
  background, configuring Alarm Monitor to appear in 410
Backup Scheduler
  functions and privileges 325
  backups
    stopping 423

C
  call by call reports
    functions and privileges 330
  Call Center Admin access class
    in Server Utility 316
  call presentation classes
    functions and privileges 328
  call queue rate for outbound contacts 254
  calls
    outbound skillsets 252
    outbound start date and time 252
    priority 252
  campaigns
    See outbound campaigns
cancelling backups 423
  capturing
    CS1000 data output 448
    CDN data
      capturing 452
    CDNs function 328
changing
desktop user properties 343
event preferences 405
event severity 401–402
passwords in Server Utility 341
scheduled backups 423
voice segments’ attributes 382
See also editing
clearing alarms 412–413
client PC
running multiple sessions on 495
Communication Server 1000, configuring 36
Communication Server 2x00, configuring 37
Configuration
adding servers in 70
configuring resources 75
configuring resources in 74
downloading spreadsheets from 79
overview 47
setup tasks 35
tasks 66
what is new 15
Configuration Tool
Excel 78
spreadsheets 66
downloading 79
downloading data 87
language support in 83
overview 81
problems downloading due to URLScan 78, 79
to configure resources 80
uploading data 74, 78, 84
viewing the version number of 82
configuring
Communication Server 1000 36
Communication Server 2x00 37
Contact Center Manager Server 38
CS1000 36
CS2x00 37
DMS 37
Meridian 1 PBX, configuring
M1 36
connected sessions 345–347
functions and privileges 325
connection status window 15
Contact Center Management
adding agents in 120
adding supervisors in 122
adding users in 117
Audit Trail events 218
Network Agent Admin view 113
overview 46, 94
partitions and 175
partitions in 184, 191
select all, problems with 497
skillset view in 107
what is new 15
Contact Center Manager Administration 19
Audit Trail
to configure the number of stored Audit Trail events 213
components of 46
default password 53
logging on for first time 52
login warning message 59
logon warning message 303
password 103
running multiple sessions on client PC 495
user ID 103, 122
users 50
adding in Access and Partition Management 178
Contact Center Manager Server
users 50
managing 94
Contact Center tasks
copying voice files 366
creating
a group of voice segments 373
access classes
in Access and Partition Management 153
voice files 362
voice segments 370
creating outbound campaigns 251
critical events 389
CS1000 Data Extraction Tool
installing 429
Microsoft Excel 430
spreadsheets for 80
uninstalling 433
CS1000 data output capturing 448
CS1000, configuring 36
CS2x00, configuring 37
custom fields 253

data
extracting by using a modem 440
extracting from a file 442
extracting from the CS1000/Meridian 1 436
database backups
changing scheduled 423
deleting scheduled 423
stopping 423
debug log files 296
default access classes
in Server Utility 316
default call rates for outbound contacts 254
deleting
access classes
in Server Utility 323
event preferences 405
scheduled backups 423
users 343
voice files 366
voice segments 382
desktop password, resetting 341–342
desktop users
adding 335–337
deleting 343
locking out 338, 339
logging off 347
printing list of 343
resetting password for 341–342
restoring access to server for 339–340
viewing list of logged on 346
dialing outgoing calls 253
dial-up connection 301
disconnecting
logged-on desktop users 347

disposition codes 277
disposition codes, selecting 252
DMS, configuring 37
DNISs function 328
documents in Contact Center 29
downloading
data to Configuration Tool spreadsheets 87

editing
length of all voice segments in a voice file 380
voice segments’ length 377
See also changing
Emergency Help
overview 48
Emergency Help function 328
date for outbound campaigns 253
date for outbound campaigns 254
Event Browser 384, 390–397
functions and privileges 325
Event Code box 402
Event Preferences
functions and privileges 325
event preferences 399–405
adding 401–402
changing 405
deleting 405
printing all 405
printing list of 405
events 388
changing severity of 401–402
event severity
critical 389
information 389
major 389
minor 389
filtering 395–397
printing list of 394
saving list of 393–394
sorting 391
throttling 403–404
Excel 78
existing campaign
adding call data 251
exiting from the Voice Prompt Editor 358
exporting scripts 233
extracting
Index

F

file

extracting data from 442
filtering events 395–397

filters

in Historical Reporting 190
foreground, configuring Alarm Monitor to appear in 410

formulas

functions and privileges 328

H

hardware requirements 430
help, Alarm Monitor 411

Historical Reporting

Audit Trail events 221
error messages in 515
filters in 190
overview 48
partition rules in 184

partitions

creating, user defined 171
properties of 174
partitions and 175
partitions in 184
Report Creation Wizard in 209
report groups in 159
select all, problems with 497
selection criteria 184

historical reports

cannot connect to data source 519
historical statistics

functions and privileges 328

installing

the CS1000 Data Extraction Tool 429
Internet Explorer

font size in 494
Interval box 402

IVR ACD-DNs

data, capturing 453
functions and privileges 329
threshold classes

functions and privileges 328

L

languages

supported in Configuration Tool

spreadsheets 83

length

of all voice segment in voice file, editing 380
of voice segments, editing 377

License Manager Service

debug log files 296
Windows event logging 291
locking out desktop users 338, 339
lockout 312
logged on desktop users

viewing list of 346
logging desktop users off 347

logging on

to the server 301
to the Voice Prompt Editor 358
login warning message

to configure 59
to turn off 62

logon warning message

to configure 303

M

M1, configuring 36

major events 389
members of access classes, viewing 321–322
Meridian 1 PBX, configuring 36
Microsoft Excel 78, 430
Microsoft .Net Framework 248
minor events 389

icons

multicast and unicast in real-time displays 525
information events 389
modem, using to extract data 440
modifying, desktop users
  See changing
multicast
  icons on real-time displays 525
multiple client sessions
  interference caused by 495

N
naming outbound campaign 252
Network Agent Admin view 113
  to open 113
  to search for agents across servers 113, 115
network communication parameters
  functions and privileges 329
network historical statistics
  functions and privileges 329
network skillsets
  functions and privileges 329
nodal threshold classes
  functions and privileges 329

O
OCMT
  assigning access rights 248
  prerequisites 248
  starting 249
online Help 392
opening voice files 364
operating systems 430
other reports
  function and privileges 330
outbound calls
  priority 252
  skillsets 252
  start date and time 252
Outbound Campaign Management Tool 15
  creating call scripts 274
  creating disposition codes 277
  defining campaigns 251
  importing and reviewing call data 255
  modifying campaigns 267
  overview 49, 245
  reviewing campaign results 269
outbound campaigns
  adding custom fields 253
  adding data 251
  call queue rate 254
  creating 251
  daily times 254
  defining call queue rate 254
  dialer settings 253
  naming 252
  required settings 252
  selecting agent script 252
  selecting disposition codes 252
overlay programs
  23 453
partition rules
  in Historical Reporting 184
partitions
  and Access and Partition Management 142
  and Contact Center Management 175, 184, 191
  and Historical Reporting 175, 184
  and Real-Time Reporting 175, 184, 191
  assigning 178
  assigning to users 144
  creating, user defined 171
  properties of 174
password
  retry count 337
password expiry 313
password retry count 337
password retry lockout 312
passwords
  changing default password in Contact Center Manager Administration 53
  changing in Server Utility 341
  expiry 313
  retry lockout 312
performance
  tips for optimum 286
phoneset displays
  functions and privileges 329
Phonesets function 329
playing
  a group of voice segments 373
  voice segment 372
prerequisites for running OCMT 248
preventing access to the server 338, 339
previewing
  access classes
    in Server Utility 323
printing
  access classes
    in Server Utility 323
  alarms 408
  all event preferences 405
  list of desktop users 343
  list of event preferences 405
  list of events 394
priority for outbound calls 252
program
  20 448
  21 448, 453
  23 448, 452
  81 448, 451
programs
  23 453

Q
queue rate 254

R
real-time displays
  functions and privileges 329
  multicast and unicast icons on 525
Real-Time Reporting
  Audit Trail events 220
  filters in 191
  overview 48
  partitions in 175, 184, 191
real-time statistics
  functions and privileges 329
recording a voice segment 371
related documents 29
removing
  a specified length from a voice segment 377
  a specified length from all voice segments 380
  all silence from a voice segment 379
  all silence from all voice segments 381
See also deleting
removing, desktop user
  See deleting
renaming voice files 366
Report Creation Wizard 209
  Audit Trail events 222
Report Groups
to add a report group 161
report groups
  creating, in Historical Reporting 159
    custom 159
    standard 159
reports
  agent performance
    functions and privileges 330
  call by call
    functions and privileges 330
  functions and privileges 329
  other
    functions and privileges 330
required
  information for outbound campaigns 252
resetting the desktop password 341–342
resources
  configuring in Configuration 74
restoring
  access to the server 339–340
restricting access to the server 338, 339
retry lockout 312
reverting to a previously saved voice file 366
route data
  capturing 453
route threshold classes
  functions and privileges 330
routes
  functions and privileges 330

S
sample scripts
  in Scripting 239
saving
  list of events 393–394
  voice files 366
scheduled backups
  changing 423
  deleting 423
scheduler
  functions and privileges 330
Script Editor 230
  validating scripts in 231
Script Manager 229
script variables 234
  functions and privileges 330
  in referencing scripts 241
script, using in outbound campaigns 252
Scripting
  application threshold classes in 237
  Audit Trail 220
  exporting scripts 233
  overview 47, 228
  sample scripts in 239
  Script Editor 230
  Script Manager 229
  script variables 234
    in referencing scripts 241
  validating scripts 231
    validation options 232
  viewing scripts 229
  what’s new 16
scripts
  exporting 233
  functions and privileges 330
  sample scripts 239
  validating 231
  validation options 232
  variables 241
  viewing 229
searching for a voice segment 375
select all problems
  in Access and Partition Management 497
  in Contact Center Management 497
  in Historical Reporting 497
selecting agent desktop script 252
selecting disposition codes 252
selection criteria
  in Historical Reporting 184
serial connection
  using to extract data 436
serial port connection 436
serial ports
  functions and privileges 325
server
  locking users out of 338
server performance
  tips for optimum 286
server performance monitor
  functions and privileges 325
server settings
  functions and privileges 325
Server Utility 20
  access classes
    adding 317
    adminGroup 316
    Call Center Admin 316
  default access classes 316
  deleting 323
  functions and privileges 324
  previewing 323
  printing 323
  properties of 323
  Supervisor 316
Alarm Monitor
  functions and privileges 324
Backup Scheduler
  functions and privileges 325
connected sessions
  functions and privileges 325
Event Browser
  functions and privileges 325
Event Preferences
  functions and privileges 325
passwords
  changing 341
serial ports
  functions and privileges 325
server performance monitor
  functions and privileges 325
server settings
  functions and privileges 325
Server Utility window 305
switch resources
  functions and privileges 326
users
  functions and privileges 326
Voice Prompt Editor 358
  functions and privileges 327
servers
  adding in Configuration 70
  and access classes in Access and Partition Management 151
  controlling access to 338–340
  locking users out of 339
  logging on to 301
  logging users off 347
  restoring access to 339–340
  sessions 345–347
setting up Contact Center Manager Server 38
severity 389
  of events, changing 401–402
Severity box 402
Simple Network Management Protocol. See SNMP
sites
  functions and privileges 330
skillset threshold classes
  functions and privileges 330
skillset view
  in Contact Center Management 107
skillsets
  functions and privileges 331
skillsets for outbound calls 252
SNMP 388
software requirements 430
spreadsheets
  Configuration Tool 66
  downloading data to 87
  downloading from Configuration 79
  for the CS100 Data Extraction Tool 80
  overview of Configuration Tool
  spreadsheets 81
  to configure resources 80
  uploading data to Contact Center Manager Server 84
  using with the CS1000 Data Extraction Tool 436
start date and time for outbound calls 252
start time for outbound campaigns 254
starting OCMT 249
stopping backups 423
supervisor access
  defining typical 156
Supervisor access class
  in Server Utility 316
supervisor/reporting agent combinations, assigning 178
supervisor/reporting agents matrix 456
supervisors
  adding in Contact Center Management 122
  suppressing events 403–404
switch
  configuration 35
  switch resources
    functions and privileges 326, 331
T
  table routing assignments
    functions and privileges 331
  terminal emulator application 436
  terminal number data
    capturing 449
  throttling events 403–404
  tips
    for optimum server performance 286
    to add a report group 161
    to configure the number of stored Audit Trail events 213
    to search for agents across servers 113, 115
  troubleshooting
    Historical Reporting 515
U
  undeleting
    voice segments 382
unicast
  icons on real-time displays 525
uninstalling
  the CS1000 Data Extraction Tool 433
updating, desktop users
  See changing
uploading data
  using Configuration Tool spreadsheets 84
URLScan
  and Configuration Tool spreadsheets 78
  and the Configuration Tool spreadsheets 79
user defined partitions 171
User desktop status 337
user name
  modifying 179
user types
  in Contact Center Manager Administration 50
users
  adding Contact Center Manager Administration users 178
  adding Contact Center Manager Server users 117
  functions and privileges 326, 331
  sessions 345–347
See also agents, desktop users, supervisors

V
validating scripts
  validation options 232
version number
  viewing in the Configuration Tool spreadsheets 82
viewing
  access class membership 321–322
  list of logged on desktop users 346
voice files
  copying 366
  creating 362
  deleting 366
  editing the length of all voice segments in 380
  opening 364
  renaming 366
  reverting to previously saved 366
  saving 366
voice port data
  capturing 451
voice ports
  functions and privileges 326, 331
Voice Prompt Editor
  functions and privileges 327
  logging on to and exiting from the 358
voice segments
changing attributes of 382
creating 370
creating a group of 373
deleting 382
editing length of 377
playing 372
playing a group of 373
recording 371
removing a specified length from 377
removing a specified length from all 380
removing all silence from 379
removing all silence from all 381
searching for 375
undeleting 382

W
webadmin 55, 179
  and Configuration component 66
  and Configuration Tool spreadsheets 78
Windows event logging 291

X
XML automated assignments feature
  Audit Trail events 223
XML files
  sample files 127
Tell us about yourself:

Name:  
Company:  
Address:  
Occupation:  
Phone:  

1. What is your level of experience with this product?
   - [ ] New user  - [ ] Intermediate  - [ ] Experienced  - [ ] Programmer

2. How do you use this book?
   - [ ] Learning  - [ ] Procedural  - [ ] Reference  - [ ] Problem solving

3. Did this book meet your needs?
   - [ ] Yes  - [ ] No
   If you answered No to this question, please answer the following questions.

4. What chapters, sections, or procedures did you find hard to understand?
   __________________________________________________________
   __________________________________________________________
   __________________________________________________________

5. What information (if any) was missing from this book?
   __________________________________________________________
   __________________________________________________________
   __________________________________________________________

6. How could we improve this book?
   __________________________________________________________
   __________________________________________________________
   __________________________________________________________

Please return your comments by fax to 353-91-756050, or mail your comments to Contact Center Documentation Research and Development Prime, Nortel, Mervue Business Park, Galway, Ireland.
Nortel Contact Center Manager
Administrator’s Guide

Nortel Networks
Mervue Business Park
Galway, Ireland

Copyright © 2006-2009 Nortel Networks. All Rights Reserved.

Information is subject to change without notice. Nortel Networks reserves the right to make changes in design or components as progress in engineering and manufacturing may warrant.

The process of transmitting data and call messaging between the Meridian 1 and Contact Center Manager is proprietary to Nortel Networks. Any other use of the data and the transmission process is a violation of the user license unless specifically authorized in writing by Nortel Networks prior to such use. Violations of the license by alternative usage of any portion of this process or the related hardware constitutes grounds for an immediate termination of the license and Nortel Networks reserves the right to seek all allowable remedies for such breach.

Publication number: 297-2183-927
Product release: 6.0
Document release: Standard 10.03
Date: February 2009

To provide feedback or report a problem in this document, go to www.nortel.com/documentfeedback.